DDW.CSharp.Dom

Goblin - A Platform for 3D AR and VR Applications

DDW.CSharp.Dom Namespace

C# grammar (based on ecma-334 spec) -- Robin Debreuil Fri Mar 5, 2004 11:50 -- A (mostly) complete cs parser. It parses into a tree structure loosely based on the CodeDom. Does not yet do #if preprocessor segments, and no unsafe code (as of yet). You can test by downloading the CSharp.zip file and dragging cs files into CSharp.exe. The zip includes the grammar file, as well as the cs token classes (the grammar uses a heterogeneous tree, though that should be simple to turn off). -- permalink: http://www.debreuil.com/CSharp. TJP: copied src, exe to antlr.org and changed link as debreuil's links are dead.

Namespace hierarchy

Classes

Class | Description
AccessorDecl | An accessor declartation.
ArgumentRef | An argument reference.
ArrayCreateExpr | An expression that creates a new array.
ArrayElementRef | A reference to a specific element of an array.
ArrayInitializer | An expression that initializes a new array being created (the {1,2,3} part).
AssemblyReference | A reference to an assembly. This is normally something on the command line.
AssemblyReferenceCollection | A strongly-typed collection of AssemblyReference objects.
AssignExpr | An assignment expression.
AttachDelegateStmt | Attaches a delegate to an event.
BaseRef | A 'base' reference.
BinaryExpr | A binary expression.
BooleanLiteral | A boolean literal.
BreakStmt | A break statement.
BuiltInType | A C# built in type.
Case | A case clause for a switch statement.
CaseCollection | A strongly-typed collection of Case objects.
CastExpr | A cast expression.
Catch | A catch clause.
CatchCollection | A strongly-typed collection of Catch objects.
CharLiteral | A character literal.
CheckedStmt | A checked statement - explicitly checks for overflow.
ClassDecl | A class declartation.
CodeCollectionAttribute | An attribute that specifies that a CSharp Graph property is a code element (as opposed to a helper property) as well as a collection.
CodeElementAttribute | An attribute that specifies that a CSharp Graph property is a code element as opposed to a helper property.
Comment | A comment that may be mixed in with other elements.
CommentStmt | A normal comment.
CommentStmtCollection | A strongly-typed collection of CommentStmt objects.
CompileUnit | A C# file level unit of code. This must be a complete C# file, snippets are not valid.
CompileUnitCollection | A strongly-typed collection of CompileUnit objects.
ConstantDecl | A constant declartation.
ConstantDeclStmt | A constant declaration statement.
ConstructorDecl | A constructor declartation.
ContinueStmt | A continue statement.
CreateDelegateExpr | An expression that creates a new delegate.
CSharpGraph | An abstract base class for CSharpDom elements.
CustomAttribute | An single attribute applied to a code element (eg. [Flags]). Note: multiple comma separated attributes declared in a single attribute element are separated into multiple attributes.
CustomAttributeCollection | A strongly-typed collection of CustomAttribute objects.
Declarator | Code elements such as fields or events can declare multiple variables of the same type in one statement (int x=5, y=6, z=7;). Each of these are declarators.
DeclaratorCollection | A strongly-typed collection of Declarator objects.
DelegateDecl | A delegate declartation.
DelegateInvokeExpr | Invokes a delegate.
DestructorDecl | A destructor declartation.
EnumDecl | An enum declartation.
EnumMemberDecl | An enum declartation.
EventDecl | An event declaration.
EventRef | A reference to an event.
Expression | An abstract base class for expressions.
ExpressionCollection | A strongly-typed collection of Expression objects.
ExprStmt | A code expression that can be treated as a code statement.
FieldDecl | A field declaration.
FieldRef | A reference to a field.
ForEachStmt | A foreach statement that enumerates over a collection.
GotoStmt | A goto statement, jumps to a label or a case clause.
IfStmt | An if (conditional) statement.
Import | An import declaration. This maps to the 'using' statement, so it can also be used to set aliases.
ImportCollection | A strongly-typed collection of Import objects.
IndexerDecl | An indexer declartation.
IndexerRef | A reference to a class indexer.
IntegerLiteral | An interger literal.
InterfaceDecl | An interface declartation.
IterationStmt | A loop construct. This can be a for, do or while loop, however foreach loops are treated separately (as a ForEachStmt).
LabeledStmt | A labeled statement that can be jumped to with a goto statement.
LinePragma |
LocalRef | A local reference.
LockStmt | A lock statement.
MemberAccess | An expression that accesses a member of a variable (x.y).
MemberDecl | An abstract class for all types (class, struct...) and type members (method, field...).
MemberDeclCollection | A strongly-typed collection of MemberDecl objects.
MethodDecl | A method declaration.
MethodInvokeExpr | Invokes a method with the given parameters.
MethodRef | A reference to a method.
NamespaceDecl | A namespace declaration.
NamespaceDeclCollection | A strongly-typed collection of NamespaceDecl objects.
NullLiteral | A null literal.
ObjectCreateExpr | An expression that creates a new object.
OperatorDecl | An operator declartation.
Param | A parameter that will be passed to another code element.
ParamCollection | A strongly-typed collection of Param objects.
ParamDecl | A parameter delaration.
ParamDeclCollection | A strongly-typed collection of ParamDecl objects.
PostfixExpr | A postfix expression (x++, y--).
PrimitiveExpr | An abstract base class for primative types.
PropertyDecl | A property declaration.
PropertyRef | A reference to a property.
PropertySetValueRef | A 'value' reference, used inside a set accessor.
RankSpecifier | A rank specifier for an array. There can be more than one rank specifier in the case of a jagged array (x[][]).
RankSpecifierCollection | A strongly-typed collection of RankSpecifier objects.
RealLiteral | An real literal. Will be a floating point number.
Reference | A variable.
RemoveDelegateStmt | Removes a delegate from an event.
ReturnStmt | A return statement.
Statement | An abstract base class for statements.
StatementCollection | A strongly-typed collection of Statement objects.
StringLiteral | A string literal.
StructDecl | A struct declartation.
SubExpr | A sub (parenthesized) expression. This overrides regular operator precedence eg: (2+4)*6.
SwitchStmt | A switch statement.
TernaryExpr | A ternary (conditional) expression (bool ? expr : expr).
ThisRef | A 'this' reference.
ThrowStmt | A throw statement.
TryCatchFinallyStmt | A try, catch, finally construct.
TypeDecl | An abstract base class for types (classes, structs, interfaces etc).
TypeDeclCollection | A strongly-typed collection of TypeDecl objects.
TypeOfExpr | A 'typeof' expression.
TypeRef | A reference to a type (interface, class, struct, enum, delegate - this includes built in types).
TypeRefCollection | A strongly-typed collection of TypeRef objects.
UnaryExpr | A unary expression.
UncheckedStmt | An unchecked statement - explicitly ignores overflow.
UnknownReference | A variable who's type has not yet been determined.
UsingStmt | A using statement, aquires a resource that will be disposed at the end of the scope.
VariableDecl | A variable declaration.
VariableDeclStmt | A variable declaration statement.

Interfaces

Interface | Description
AssemblyReferenceCollection.IAssemblyReferenceCollectionEnumerator | Supports type-safe iteration over a AssemblyReferenceCollection.
CaseCollection.ICaseCollectionEnumerator | Supports type-safe iteration over a CaseCollection.
CatchCollection.ICatchCollectionEnumerator | Supports type-safe iteration over a CatchCollection.
CommentStmtCollection.ICommentStmtCollectionEnumerator | Supports type-safe iteration over a CommentStmtCollection.
CompileUnitCollection.ICompileUnitCollectionEnumerator | Supports type-safe iteration over a CompileUnitCollection.
CustomAttributeCollection.ICustomAttributeCollectionEnumerator | Supports type-safe iteration over a CustomAttributeCollection.
DeclaratorCollection.IDeclaratorCollectionEnumerator | Supports type-safe iteration over a DeclaratorCollection.
ExpressionCollection.IExpressionCollectionEnumerator | Supports type-safe iteration over a ExpressionCollection.
IDeclaration |
IGraph | An interface that all CSharpDom elements must implement.
ImportCollection.IImportCollectionEnumerator | Supports type-safe iteration over a ImportCollection.
IOverloadable |
IScope |
ISymbolRef |
MemberDeclCollection.IMemberDeclCollectionEnumerator | Supports type-safe iteration over a MemberDeclCollection.
NamespaceDeclCollection.INamespaceDeclCollectionEnumerator | Supports type-safe iteration over a NamespaceDeclCollection.
ParamCollection.IParamCollectionEnumerator | Supports type-safe iteration over a ParamCollection.
ParamDeclCollection.IParamDeclCollectionEnumerator | Supports type-safe iteration over a ParamDeclCollection.
RankSpecifierCollection.IRankCollectionEnumerator | Supports type-safe iteration over a RankSpecifierCollection.
StatementCollection.IStatementCollectionEnumerator | Supports type-safe iteration over a StatementCollection.
TypeDeclCollection.ITypeDeclCollectionEnumerator | Supports type-safe iteration over a TypeDeclCollection.
TypeRefCollection.ITypeRefCollectionEnumerator | Supports type-safe iteration over a TypeRefCollection.

Enumerations

Enumeration | Description
AccessorModifiers | An enumeration of possible accessor types (get, set, add, or remove).
AssemblyReferenceCollection.Tag |
AssignOperator | An enumeration of possible assign expression operators (=, +=, *=...).
AttributeTarget | An enumeration of possible targets a custom attribute can apply to.
BinaryOperator | An enumeration of possible binary expression operators.
CaseCollection.Tag |
CatchCollection.Tag |
CommentStmtCollection.Tag |
CompileUnitCollection.Tag |
CustomAttributeCollection.Tag |
DeclaratorCollection.Tag |
ExpressionCollection.Tag |
GraphTypes | An enumeration of all CSharpDom types. Used to speed up and simplify reflection (each CSharp type has a 'GraphType' property).
ImportCollection.Tag |
IterationType | An enumeration of possible types of iterations (for, do, while, and foreach).
MemberDeclCollection.Tag |
MemberKind | An enumeration of possible type kinds (class, interface, enum etc).
Modifiers | A bit field enumeration of the modifier attributes that can be applied to type members (eg. public, static, override etc).
NamespaceDeclCollection.Tag |
OverloadableOperator | An enumeration of possible overloadable operators (operators that can be redefined).
ParamCollection.Tag |
ParamDeclCollection.Tag |
ParamDirection | An enumeration of possible parameter directions (ref or out).
PostfixOperator | An enumeration of possible postfix expression operators (++ and --).
RankSpecifierCollection.Tag |
StatementCollection.Tag |
TypeDeclCollection.Tag |
TypeKind | An enumeration of possible type kinds (class, interface, enum etc).
TypeModifiers | A bit field enumeration of the modifier attributes that can be applied to types.
TypeRefCollection.Tag |
UnaryOperator | An enumeration of possible unary expression operators.

Send comments on this topic.


AccessorDecl Class

An accessor declartation.

For a list of all members of this type, see AccessorDecl Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.MemberDecl
DDW.CSharp.Dom.AccessorDecl

public class AccessorDecl : MemberDecl, IScope

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

AccessorDecl Members | DDW.CSharp.Dom Namespace


AccessorDecl Members

AccessorDecl overview

Public Instance Constructors

AccessorDecl Constructor Initializes a new instance of the AccessorDecl class.

Public Instance Properties

AccessorModifier | Gets or sets the type of accessor (get, set, add, or remove).
Attributes (inherited from MemberDecl) | Gets or sets the modifier flags for this member (public, private etc).
Comments (inherited from MemberDecl) | Gets the collection of comments for this member.
CustomAttributes (inherited from MemberDecl) | Gets the collection of Custom Attributes used for this member (custom attributes are the ones declared between brackets, like [Flags]).
LinePragma (inherited from CSharpGraph) |
MemberKind |
Scope |
Statements | Gets the collection of statements in the accessor.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
VerifyModifiers (inherited from MemberDecl) |

See Also

AccessorDecl Class | DDW.CSharp.Dom Namespace


AccessorDecl Constructor

Initializes a new instance of the AccessorDecl class.

public AccessorDecl();

See Also

AccessorDecl Class | DDW.CSharp.Dom Namespace


AccessorDecl Properties

The properties of the AccessorDecl class are listed below. For a complete list of AccessorDecl class members, see the AccessorDecl Members topic.

Public Instance Properties

AccessorModifier | Gets or sets the type of accessor (get, set, add, or remove).
Attributes (inherited from MemberDecl) | Gets or sets the modifier flags for this member (public, private etc).
Comments (inherited from MemberDecl) | Gets the collection of comments for this member.
CustomAttributes (inherited from MemberDecl) | Gets the collection of Custom Attributes used for this member (custom attributes are the ones declared between brackets, like [Flags]).
LinePragma (inherited from CSharpGraph) |
MemberKind |
Scope |
Statements | Gets the collection of statements in the accessor.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

AccessorDecl Class | DDW.CSharp.Dom Namespace


AccessorModifier Property

Goblin - A Platform for 3D AR and VR Applications

AccessorDecl.AccessorModifier Property

Gets or sets the type of accessor (get, set, add, or remove).

public AccessorModifiers AccessorModifier {get; set;}

See Also

AccessorDecl Class | DDW.CSharp.Dom Namespace


MemberKind Property

Goblin - A Platform for 3D AR and VR Applications

AccessorDecl.MemberKind Property

public override MemberKind MemberKind {get;}

See Also

AccessorDecl Class | DDW.CSharp.Dom Namespace


Scope Property

Goblin - A Platform for 3D AR and VR Applications

AccessorDecl.Scope Property

public DDW.CSharp.SymbolTable.Scope Scope {get; set;}

Implements

IScope.Scope

See Also

AccessorDecl Class | DDW.CSharp.Dom Namespace


Statements Property

Goblin - A Platform for 3D AR and VR Applications

AccessorDecl.Statements Property

Gets the collection of statements in the accessor.

public StatementCollection Statements {get;}

See Also

AccessorDecl Class | DDW.CSharp.Dom Namespace


AccessorModifiers Enumeration

An enumeration of possible accessor types (get, set, add, or remove).

public enum AccessorModifiers

Members

Member Name | Description
Empty |
Get |
Set |
Add |
Remove |

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

DDW.CSharp.Dom Namespace


ArgumentRef Class

An argument reference.

For a list of all members of this type, see ArgumentRef Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Expression
DDW.CSharp.Dom.Reference
DDW.CSharp.Dom.ArgumentRef

public class ArgumentRef : Reference

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

ArgumentRef Members | DDW.CSharp.Dom Namespace


ArgumentRef Members

ArgumentRef overview

Public Instance Constructors

ArgumentRef Constructor Initializes a new instance of the ArgumentRef class.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
ParameterName | Gets or sets the name of the argument.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ArgumentRef Class | DDW.CSharp.Dom Namespace


ArgumentRef Constructor

Initializes a new instance of the ArgumentRef class.

public ArgumentRef();

See Also

ArgumentRef Class | DDW.CSharp.Dom Namespace


ArgumentRef Properties

The properties of the ArgumentRef class are listed below. For a complete list of ArgumentRef class members, see the ArgumentRef Members topic.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
ParameterName | Gets or sets the name of the argument.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

ArgumentRef Class | DDW.CSharp.Dom Namespace


ParameterName Property

Goblin - A Platform for 3D AR and VR Applications

ArgumentRef.ParameterName Property

Gets or sets the name of the argument.

public string ParameterName {get; set;}

See Also

ArgumentRef Class | DDW.CSharp.Dom Namespace


ArrayCreateExpr Class

An expression that creates a new array.

For a list of all members of this type, see ArrayCreateExpr Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Expression
DDW.CSharp.Dom.ArrayCreateExpr

public class ArrayCreateExpr : Expression

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

ArrayCreateExpr Members | DDW.CSharp.Dom Namespace


ArrayCreateExpr Members

ArrayCreateExpr overview

Public Instance Constructors

ArrayCreateExpr Constructor Initializes a new instance of the ArrayCreateExpr class.

Public Instance Properties

CreateType | Gets or sets the type of the elements that the array being created stores.
DimensionCount | Gets or sets the number of dimensions in the array (where [,,] has three dimensions). The default value is 1 which represents 'normal' arrays (int[]).
Initializer | Gets or sets the objects the array is initialized with (the {1,2,3} part).
LinePragma (inherited from CSharpGraph) |
RankSpecifiers | Gets a collection of rank specifiers for the array. Rank specifiers represent each bracketed section of an array ([,,][,] indicates two rank specifiers). Only the first rank specifier can hold size information, so there is no need for a collection of rank specifier sizes. Note: the .net documentation can be confusing on these terms, as it uses 'rank' and 'dimensions' interchangeably, and 'jagged arrays' for these types of arrays of arrays. This is fine, but leaves us with 'a jag' to refer to a rank specifier. The term 'RankSpecifiers' is thus derived from the C# spec instead.
Sizes | Gets a collection of sizes of each dimension in the array (eg. int[2,3]).
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ArrayCreateExpr Class | DDW.CSharp.Dom Namespace


ArrayCreateExpr Constructor

Initializes a new instance of the ArrayCreateExpr class.

public ArrayCreateExpr();

See Also

ArrayCreateExpr Class | DDW.CSharp.Dom Namespace


ArrayCreateExpr Properties

The properties of the ArrayCreateExpr class are listed below. For a complete list of ArrayCreateExpr class members, see the ArrayCreateExpr Members topic.

Public Instance Properties

CreateType | Gets or sets the type of the elements that the array being created stores.
DimensionCount | Gets or sets the number of dimensions in the array (where [,,] has three dimensions). The default value is 1 which represents 'normal' arrays (int[]).
Initializer | Gets or sets the objects the array is initialized with (the {1,2,3} part).
LinePragma (inherited from CSharpGraph) |
RankSpecifiers | Gets a collection of rank specifiers for the array. Rank specifiers represent each bracketed section of an array ([,,][,] indicates two rank specifiers). Only the first rank specifier can hold size information, so there is no need for a collection of rank specifier sizes. Note: the .net documentation can be confusing on these terms, as it uses 'rank' and 'dimensions' interchangeably, and 'jagged arrays' for these types of arrays of arrays. This is fine, but leaves us with 'a jag' to refer to a rank specifier. The term 'RankSpecifiers' is thus derived from the C# spec instead.
Sizes | Gets a collection of sizes of each dimension in the array (eg. int[2,3]).
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

ArrayCreateExpr Class | DDW.CSharp.Dom Namespace


CreateType Property

Goblin - A Platform for 3D AR and VR Applications

ArrayCreateExpr.CreateType Property

Gets or sets the type of the elements that the array being created stores.

public TypeRef CreateType {get; set;}

See Also

ArrayCreateExpr Class | DDW.CSharp.Dom Namespace


DimensionCount Property

Goblin - A Platform for 3D AR and VR Applications

ArrayCreateExpr.DimensionCount Property

Gets or sets the number of dimensions in the array (where [,,] has three dimensions). The default value is 1 which represents 'normal' arrays (int[]).

public int DimensionCount {get; set;}

See Also

ArrayCreateExpr Class | DDW.CSharp.Dom Namespace


Initializer Property

Goblin - A Platform for 3D AR and VR Applications

ArrayCreateExpr.Initializer Property

Gets or sets the objects the array is initialized with (the {1,2,3} part).

public ArrayInitializer Initializer {get; set;}

See Also

ArrayCreateExpr Class | DDW.CSharp.Dom Namespace


RankSpecifiers Property

Goblin - A Platform for 3D AR and VR Applications

ArrayCreateExpr.RankSpecifiers Property

Gets a collection of rank specifiers for the array. Rank specifiers represent each bracketed section of an array ([,,][,] indicates two rank specifiers). Only the first rank specifier can hold size information, so there is no need for a collection of rank specifier sizes. Note: the .net documentation can be confusing on these terms, as it uses 'rank' and 'dimensions' interchangeably, and 'jagged arrays' for these types of arrays of arrays. This is fine, but leaves us with 'a jag' to refer to a rank specifier. The term 'RankSpecifiers' is thus derived from the C# spec instead.

public RankSpecifierCollection RankSpecifiers {get;}

See Also

ArrayCreateExpr Class | DDW.CSharp.Dom Namespace


Sizes Property

Goblin - A Platform for 3D AR and VR Applications

ArrayCreateExpr.Sizes Property

Gets a collection of sizes of each dimension in the array (eg. int[2,3]).

public ExpressionCollection Sizes {get;}

See Also

ArrayCreateExpr Class | DDW.CSharp.Dom Namespace


ArrayElementRef Class

A reference to a specific element of an array.

For a list of all members of this type, see ArrayElementRef Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Expression
DDW.CSharp.Dom.Reference
DDW.CSharp.Dom.ArrayElementRef

public class ArrayElementRef : Reference

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

ArrayElementRef Members | DDW.CSharp.Dom Namespace


ArrayElementRef Members

ArrayElementRef overview

Public Instance Constructors

ArrayElementRef Constructor Initializes a new instance of the ArrayElementRef class.

Public Instance Properties

Indices | Gets a collection of indexes that navigate to the element. An array may be multi-dimensional ([,,]) so this must be a collection. Index zero represents the first dimension.
LinePragma (inherited from CSharpGraph) |
Target | Gets or sets the target array object to which the element belongs.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ArrayElementRef Class | DDW.CSharp.Dom Namespace


ArrayElementRef Constructor

Initializes a new instance of the ArrayElementRef class.

public ArrayElementRef();

See Also

ArrayElementRef Class | DDW.CSharp.Dom Namespace


ArrayElementRef Properties

The properties of the ArrayElementRef class are listed below. For a complete list of ArrayElementRef class members, see the ArrayElementRef Members topic.

Public Instance Properties

Indices | Gets a collection of indexes that navigate to the element. An array may be multi-dimensional ([,,]) so this must be a collection. Index zero represents the first dimension.
LinePragma (inherited from CSharpGraph) |
Target | Gets or sets the target array object to which the element belongs.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

ArrayElementRef Class | DDW.CSharp.Dom Namespace


Indices Property

Goblin - A Platform for 3D AR and VR Applications

ArrayElementRef.Indices Property

Gets a collection of indexes that navigate to the element. An array may be multi-dimensional ([,,]) so this must be a collection. Index zero represents the first dimension.

public ExpressionCollection Indices {get;}

See Also

ArrayElementRef Class | DDW.CSharp.Dom Namespace


Target Property

Goblin - A Platform for 3D AR and VR Applications

ArrayElementRef.Target Property

Gets or sets the target array object to which the element belongs.

public Expression Target {get; set;}

See Also

ArrayElementRef Class | DDW.CSharp.Dom Namespace


ArrayInitializer Class

An expression that initializes a new array being created (the {1,2,3} part).

For a list of all members of this type, see ArrayInitializer Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Expression
DDW.CSharp.Dom.ArrayInitializer

public class ArrayInitializer : Expression

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

ArrayInitializer Members | DDW.CSharp.Dom Namespace


ArrayInitializer Members

ArrayInitializer overview

Public Instance Constructors

ArrayInitializer Constructor Initializes a new instance of the ArrayInitializer class.

Public Instance Properties

InitialValues | Gets a collection of inital values to give teh array being created.
LinePragma (inherited from CSharpGraph) |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ArrayInitializer Class | DDW.CSharp.Dom Namespace


ArrayInitializer Constructor

Initializes a new instance of the ArrayInitializer class.

public ArrayInitializer();

See Also

ArrayInitializer Class | DDW.CSharp.Dom Namespace


ArrayInitializer Properties

The properties of the ArrayInitializer class are listed below. For a complete list of ArrayInitializer class members, see the ArrayInitializer Members topic.

Public Instance Properties

InitialValues | Gets a collection of inital values to give teh array being created.
LinePragma (inherited from CSharpGraph) |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

ArrayInitializer Class | DDW.CSharp.Dom Namespace


InitialValues Property

Goblin - A Platform for 3D AR and VR Applications

ArrayInitializer.InitialValues Property

Gets a collection of inital values to give teh array being created.

public ExpressionCollection InitialValues {get;}

See Also

ArrayInitializer Class | DDW.CSharp.Dom Namespace


AssemblyReference Class

A reference to an assembly. This is normally something on the command line.

For a list of all members of this type, see AssemblyReference Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.AssemblyReference

public class AssemblyReference : CSharpGraph

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

AssemblyReference Members | DDW.CSharp.Dom Namespace


AssemblyReference Members

AssemblyReference overview

Public Instance Constructors

AssemblyReference Constructor Initializes a new instance of the AssemblyReference class.

Public Instance Properties

HintPath | Gets or set the path used to help find the assembly (works like /lib).
LinePragma (inherited from CSharpGraph) |
Name | Gets or set the name of the assembly.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AssemblyReference Class | DDW.CSharp.Dom Namespace


AssemblyReference Constructor

Initializes a new instance of the AssemblyReference class.

public AssemblyReference();

See Also

AssemblyReference Class | DDW.CSharp.Dom Namespace


AssemblyReference Properties

The properties of the AssemblyReference class are listed below. For a complete list of AssemblyReference class members, see the AssemblyReference Members topic.

Public Instance Properties

HintPath | Gets or set the path used to help find the assembly (works like /lib).
LinePragma (inherited from CSharpGraph) |
Name | Gets or set the name of the assembly.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

AssemblyReference Class | DDW.CSharp.Dom Namespace


HintPath Property

Goblin - A Platform for 3D AR and VR Applications

AssemblyReference.HintPath Property

Gets or set the path used to help find the assembly (works like /lib).

public string HintPath {get; set;}

See Also

AssemblyReference Class | DDW.CSharp.Dom Namespace


Name Property

Goblin - A Platform for 3D AR and VR Applications

AssemblyReference.Name Property

Gets or set the name of the assembly.

public string Name {get; set;}

See Also

AssemblyReference Class | DDW.CSharp.Dom Namespace


AssemblyReferenceCollection Class

A strongly-typed collection of AssemblyReference objects.

For a list of all members of this type, see AssemblyReferenceCollection Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.AssemblyReferenceCollection

public class AssemblyReferenceCollection : CSharpGraph, IList, ICollection, IEnumerable, ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

AssemblyReferenceCollection Members | DDW.CSharp.Dom Namespace


AssemblyReferenceCollection Members

AssemblyReferenceCollection overview

Public Static Methods

ReadOnly | Creates a read-only wrapper for a AssemblyReferenceCollection instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a AssemblyReferenceCollection instance.

Public Instance Constructors

AssemblyReferenceCollection Overloaded. Initializes a new instance of the AssemblyReferenceCollection class.

Public Instance Properties

Capacity | Gets or sets the number of elements the AssemblyReferenceCollection can contain.
Count | Gets the number of elements actually contained in the AssemblyReferenceCollection.
GraphType |
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the AssemblyReference at the specified index.
LinePragma (inherited from CSharpGraph) |
SyncRoot | Gets an object that can be used to synchronize access to the collection.
Text |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Add | Adds a AssemblyReference to the end of the AssemblyReferenceCollection.
AddRange | Overloaded. Adds the elements of a AssemblyReference array to the current AssemblyReferenceCollection.
Clear | Removes all elements from the AssemblyReferenceCollection.
Clone | Creates a shallow copy of the AssemblyReferenceCollection.
Contains | Determines whether a given AssemblyReference is in the AssemblyReferenceCollection.
CopyTo | Overloaded. Copies the entire AssemblyReferenceCollection to a one-dimensional AssemblyReference array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the AssemblyReferenceCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the zero-based index of the first occurrence of a AssemblyReference in the AssemblyReferenceCollection.
Insert | Inserts an element into the AssemblyReferenceCollection at the specified index.
Remove | Removes the first occurrence of a specific AssemblyReference from the AssemblyReferenceCollection.
RemoveAt | Removes the element at the specified index of the AssemblyReferenceCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Constructors

AssemblyReferenceCollection Overloaded. Initializes a new instance of the AssemblyReferenceCollection class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AssemblyReferenceCollection Class | DDW.CSharp.Dom Namespace


AssemblyReferenceCollection Constructor

Initializes a new instance of the AssemblyReferenceCollection class that is empty and has the default initial capacity.

Overload List

Initializes a new instance of the AssemblyReferenceCollection class that is empty and has the default initial capacity.

public AssemblyReferenceCollection();

Initializes a new instance of the AssemblyReferenceCollection class that contains elements copied from the specified AssemblyReference array.

public AssemblyReferenceCollection(AssemblyReference[]);

Initializes a new instance of the AssemblyReferenceCollection class that contains elements copied from the specified AssemblyReferenceCollection.

public AssemblyReferenceCollection(AssemblyReferenceCollection);

protected AssemblyReferenceCollection(Tag);

Initializes a new instance of the AssemblyReferenceCollection class that has the specified initial capacity.

public AssemblyReferenceCollection(int);

See Also

AssemblyReferenceCollection Class | DDW.CSharp.Dom Namespace


AssemblyReferenceCollection Constructor ()

Initializes a new instance of the AssemblyReferenceCollection class that is empty and has the default initial capacity.

public AssemblyReferenceCollection();

See Also

AssemblyReferenceCollection Class | DDW.CSharp.Dom Namespace | AssemblyReferenceCollection Constructor Overload List


AssemblyReferenceCollection Constructor (Int32)

Initializes a new instance of the AssemblyReferenceCollection class that has the specified initial capacity.

public AssemblyReferenceCollection(
int capacity
);

Parameters

capacity
The number of elements that the new AssemblyReferenceCollection is initially capable of storing.

See Also

AssemblyReferenceCollection Class | DDW.CSharp.Dom Namespace | AssemblyReferenceCollection Constructor Overload List


AssemblyReferenceCollection Constructor (AssemblyReferenceCollection)

Initializes a new instance of the AssemblyReferenceCollection class that contains elements copied from the specified AssemblyReferenceCollection.

public AssemblyReferenceCollection(
AssemblyReferenceCollection c
);

Parameters

c
The AssemblyReferenceCollection whose elements are copied to the new collection.

See Also

AssemblyReferenceCollection Class | DDW.CSharp.Dom Namespace | AssemblyReferenceCollection Constructor Overload List


AssemblyReferenceCollection Constructor (AssemblyReference[])

Initializes a new instance of the AssemblyReferenceCollection class that contains elements copied from the specified AssemblyReference array.

public AssemblyReferenceCollection(
AssemblyReference[] a
);

Parameters

a
The AssemblyReference array whose elements are copied to the new list.

See Also

AssemblyReferenceCollection Class | DDW.CSharp.Dom Namespace | AssemblyReferenceCollection Constructor Overload List


AssemblyReferenceCollection Constructor (Tag)

protected AssemblyReferenceCollection(
Tag t
);

See Also

AssemblyReferenceCollection Class | DDW.CSharp.Dom Namespace | AssemblyReferenceCollection Constructor Overload List


AssemblyReferenceCollection Properties

The properties of the AssemblyReferenceCollection class are listed below. For a complete list of AssemblyReferenceCollection class members, see the AssemblyReferenceCollection Members topic.

Public Instance Properties

Capacity | Gets or sets the number of elements the AssemblyReferenceCollection can contain.
Count | Gets the number of elements actually contained in the AssemblyReferenceCollection.
GraphType |
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the AssemblyReference at the specified index.
LinePragma (inherited from CSharpGraph) |
SyncRoot | Gets an object that can be used to synchronize access to the collection.
Text |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

AssemblyReferenceCollection Class | DDW.CSharp.Dom Namespace


Capacity Property

Goblin - A Platform for 3D AR and VR Applications

AssemblyReferenceCollection.Capacity Property

Gets or sets the number of elements the AssemblyReferenceCollection can contain.

public virtual int Capacity {get; set;}

See Also

AssemblyReferenceCollection Class | DDW.CSharp.Dom Namespace


Count Property

Goblin - A Platform for 3D AR and VR Applications

AssemblyReferenceCollection.Count Property

Gets the number of elements actually contained in the AssemblyReferenceCollection.

public virtual int Count {get;}

Implements

ICollection.Count

See Also

AssemblyReferenceCollection Class | DDW.CSharp.Dom Namespace


GraphType Property

Goblin - A Platform for 3D AR and VR Applications

AssemblyReferenceCollection.GraphType Property

public override GraphTypes GraphType {get;}

Implements

IGraph.GraphType

See Also

AssemblyReferenceCollection Class | DDW.CSharp.Dom Namespace


IsFixedSize Property

Goblin - A Platform for 3D AR and VR Applications

AssemblyReferenceCollection.IsFixedSize Property

Gets a value indicating whether the collection has a fixed size.

public virtual bool IsFixedSize {get;}

Property Value

true if the collection has a fixed size; otherwise, false. The default is false

Implements

IList.IsFixedSize

See Also

AssemblyReferenceCollection Class | DDW.CSharp.Dom Namespace


IsReadOnly Property

Goblin - A Platform for 3D AR and VR Applications

AssemblyReferenceCollection.IsReadOnly Property

gets a value indicating whether the IList is read-only.

public virtual bool IsReadOnly {get;}

Property Value

true if the collection is read-only; otherwise, false. The default is false

Implements

IList.IsReadOnly

See Also

AssemblyReferenceCollection Class | DDW.CSharp.Dom Namespace


IsSynchronized Property

Goblin - A Platform for 3D AR and VR Applications

AssemblyReferenceCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread-safe).

public virtual bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

AssemblyReferenceCollection Class | DDW.CSharp.Dom Namespace


Item Property

Goblin - A Platform for 3D AR and VR Applications

AssemblyReferenceCollection.Item Property

Gets or sets the AssemblyReference at the specified index.

public virtual AssemblyReference this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

AssemblyReferenceCollection Class | DDW.CSharp.Dom Namespace


SyncRoot Property

Goblin - A Platform for 3D AR and VR Applications

AssemblyReferenceCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

public virtual object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

AssemblyReferenceCollection Class | DDW.CSharp.Dom Namespace


Text Property

Goblin - A Platform for 3D AR and VR Applications

AssemblyReferenceCollection.Text Property

public override string Text {get;}

Implements

IGraph.Text

See Also

AssemblyReferenceCollection Class | DDW.CSharp.Dom Namespace


AssemblyReferenceCollection Methods

The methods of the AssemblyReferenceCollection class are listed below. For a complete list of AssemblyReferenceCollection class members, see the AssemblyReferenceCollection Members topic.

Public Static Methods

ReadOnly | Creates a read-only wrapper for a AssemblyReferenceCollection instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a AssemblyReferenceCollection instance.

Public Instance Methods

Add | Adds a AssemblyReference to the end of the AssemblyReferenceCollection.
AddRange | Overloaded. Adds the elements of a AssemblyReference array to the current AssemblyReferenceCollection.
Clear | Removes all elements from the AssemblyReferenceCollection.
Clone | Creates a shallow copy of the AssemblyReferenceCollection.
Contains | Determines whether a given AssemblyReference is in the AssemblyReferenceCollection.
CopyTo | Overloaded. Copies the entire AssemblyReferenceCollection to a one-dimensional AssemblyReference array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the AssemblyReferenceCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the zero-based index of the first occurrence of a AssemblyReference in the AssemblyReferenceCollection.
Insert | Inserts an element into the AssemblyReferenceCollection at the specified index.
Remove | Removes the first occurrence of a specific AssemblyReference from the AssemblyReferenceCollection.
RemoveAt | Removes the element at the specified index of the AssemblyReferenceCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AssemblyReferenceCollection Class | DDW.CSharp.Dom Namespace


AssemblyReferenceCollection.Add Method

Adds a AssemblyReference to the end of the AssemblyReferenceCollection.

public virtual int Add(
AssemblyReference item
);

Parameters

item
The AssemblyReference to be added to the end of the AssemblyReferenceCollection.

Return Value

The index at which the value has been added.

See Also

AssemblyReferenceCollection Class | DDW.CSharp.Dom Namespace


AddRange Method

Goblin - A Platform for 3D AR and VR Applications

AssemblyReferenceCollection.AddRange Method

Adds the elements of a AssemblyReference array to the current AssemblyReferenceCollection.

Overload List

Adds the elements of a AssemblyReference array to the current AssemblyReferenceCollection.

public virtual int AddRange(AssemblyReference[]);

Adds the elements of another AssemblyReferenceCollection to the current AssemblyReferenceCollection.

public virtual int AddRange(AssemblyReferenceCollection);

See Also

AssemblyReferenceCollection Class | DDW.CSharp.Dom Namespace


AssemblyReferenceCollection.AddRange Method (AssemblyReference[])

Adds the elements of a AssemblyReference array to the current AssemblyReferenceCollection.

public virtual int AddRange(
AssemblyReference[] x
);

Parameters

x
The AssemblyReference array whose elements should be added to the end of the AssemblyReferenceCollection.

Return Value

The new Count of the AssemblyReferenceCollection.

See Also

AssemblyReferenceCollection Class | DDW.CSharp.Dom Namespace | AssemblyReferenceCollection.AddRange Overload List


AssemblyReferenceCollection.AddRange Method (AssemblyReferenceCollection)

Adds the elements of another AssemblyReferenceCollection to the current AssemblyReferenceCollection.

public virtual int AddRange(
AssemblyReferenceCollection x
);

Parameters

x
The AssemblyReferenceCollection whose elements should be added to the end of the current AssemblyReferenceCollection.

Return Value

The new Count of the AssemblyReferenceCollection.

See Also

AssemblyReferenceCollection Class | DDW.CSharp.Dom Namespace | AssemblyReferenceCollection.AddRange Overload List


AssemblyReferenceCollection.Clear Method

Removes all elements from the AssemblyReferenceCollection.

public virtual void Clear();

Implements

IList.Clear

See Also

AssemblyReferenceCollection Class | DDW.CSharp.Dom Namespace


AssemblyReferenceCollection.Clone Method

Creates a shallow copy of the AssemblyReferenceCollection.

public virtual object Clone();

Implements

ICloneable.Clone

See Also

AssemblyReferenceCollection Class | DDW.CSharp.Dom Namespace


AssemblyReferenceCollection.Contains Method

Determines whether a given AssemblyReference is in the AssemblyReferenceCollection.

public virtual bool Contains(
AssemblyReference item
);

Parameters

item
The AssemblyReference to check for.

Return Value

true if item is found in the AssemblyReferenceCollection; otherwise, false.

See Also

AssemblyReferenceCollection Class | DDW.CSharp.Dom Namespace


CopyTo Method

Goblin - A Platform for 3D AR and VR Applications

AssemblyReferenceCollection.CopyTo Method

Copies the entire AssemblyReferenceCollection to a one-dimensional AssemblyReference array.

Overload List

Copies the entire AssemblyReferenceCollection to a one-dimensional AssemblyReference array.

public virtual void CopyTo(AssemblyReference[]);

Copies the entire AssemblyReferenceCollection to a one-dimensional AssemblyReference array, starting at the specified index of the target array.

public virtual void CopyTo(AssemblyReference[],int);

See Also

AssemblyReferenceCollection Class | DDW.CSharp.Dom Namespace


AssemblyReferenceCollection.CopyTo Method (AssemblyReference[])

Copies the entire AssemblyReferenceCollection to a one-dimensional AssemblyReference array.

public virtual void CopyTo(
AssemblyReference[] array
);

Parameters

array
The one-dimensional AssemblyReference array to copy to.

See Also

AssemblyReferenceCollection Class | DDW.CSharp.Dom Namespace | AssemblyReferenceCollection.CopyTo Overload List


AssemblyReferenceCollection.CopyTo Method (AssemblyReference[], Int32)

Copies the entire AssemblyReferenceCollection to a one-dimensional AssemblyReference array, starting at the specified index of the target array.

public virtual void CopyTo(
AssemblyReference[] array,
int start
);

Parameters

array
The one-dimensional AssemblyReference array to copy to.
start
The zero-based index in array at which copying begins.

See Also

AssemblyReferenceCollection Class | DDW.CSharp.Dom Namespace | AssemblyReferenceCollection.CopyTo Overload List


AssemblyReferenceCollection.GetEnumerator Method

Returns an enumerator that can iterate through the AssemblyReferenceCollection.

public virtual IAssemblyReferenceCollectionEnumerator GetEnumerator();

Return Value

An Enumerator for the entire AssemblyReferenceCollection.

See Also

AssemblyReferenceCollection Class | DDW.CSharp.Dom Namespace


AssemblyReferenceCollection.IndexOf Method

Returns the zero-based index of the first occurrence of a AssemblyReference in the AssemblyReferenceCollection.

public virtual int IndexOf(
AssemblyReference item
);

Parameters

item
The AssemblyReference to locate in the AssemblyReferenceCollection.

Return Value

The zero-based index of the first occurrence of item in the entire AssemblyReferenceCollection, if found; otherwise, -1.

See Also

AssemblyReferenceCollection Class | DDW.CSharp.Dom Namespace


AssemblyReferenceCollection.Insert Method

Inserts an element into the AssemblyReferenceCollection at the specified index.

public virtual void Insert(
int index,
AssemblyReference item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The AssemblyReference to insert.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

AssemblyReferenceCollection Class | DDW.CSharp.Dom Namespace


AssemblyReferenceCollection.ReadOnly Method

Creates a read-only wrapper for a AssemblyReferenceCollection instance.

public static AssemblyReferenceCollection ReadOnly(
AssemblyReferenceCollection list
);

Return Value

An AssemblyReferenceCollection wrapper that is read-only.

See Also

AssemblyReferenceCollection Class | DDW.CSharp.Dom Namespace


AssemblyReferenceCollection.Remove Method

Removes the first occurrence of a specific AssemblyReference from the AssemblyReferenceCollection.

public virtual void Remove(
AssemblyReference item
);

Parameters

item
The AssemblyReference to remove from the AssemblyReferenceCollection.

Exceptions

Exception Type | Condition
ArgumentException | The specified AssemblyReference was not found in the AssemblyReferenceCollection.

See Also

AssemblyReferenceCollection Class | DDW.CSharp.Dom Namespace


AssemblyReferenceCollection.RemoveAt Method

Removes the element at the specified index of the AssemblyReferenceCollection.

public virtual void RemoveAt(
int index
);

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

AssemblyReferenceCollection Class | DDW.CSharp.Dom Namespace


AssemblyReferenceCollection.Synchronized Method

Creates a synchronized (thread-safe) wrapper for a AssemblyReferenceCollection instance.

public static AssemblyReferenceCollection Synchronized(
AssemblyReferenceCollection list
);

Return Value

An AssemblyReferenceCollection wrapper that is synchronized (thread-safe).

See Also

AssemblyReferenceCollection Class | DDW.CSharp.Dom Namespace


AssemblyReferenceCollection.TrimToSize Method

Sets the capacity to the actual number of elements.

public virtual void TrimToSize();

See Also

AssemblyReferenceCollection Class | DDW.CSharp.Dom Namespace


AssemblyReferenceCollection.IAssemblyReferenceCollectionEnumerator Interface

Supports type-safe iteration over a AssemblyReferenceCollection.

For a list of all members of this type, see AssemblyReferenceCollection.IAssemblyReferenceCollectionEnumerator Members.

public interface AssemblyReferenceCollection.IAssemblyReferenceCollectionEnumerator

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

AssemblyReferenceCollection.IAssemblyReferenceCollectionEnumerator Members | DDW.CSharp.Dom Namespace


AssemblyReferenceCollection.IAssemblyReferenceCollectionEnumerator Members

AssemblyReferenceCollection.IAssemblyReferenceCollectionEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

AssemblyReferenceCollection.IAssemblyReferenceCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


AssemblyReferenceCollection.IAssemblyReferenceCollectionEnumerator Properties

The properties of the AssemblyReferenceCollection.IAssemblyReferenceCollectionEnumerator interface are listed below. For a complete list of AssemblyReferenceCollection.IAssemblyReferenceCollectionEnumerator interface members, see the AssemblyReferenceCollection.IAssemblyReferenceCollectionEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

AssemblyReferenceCollection.IAssemblyReferenceCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


Current Property

Goblin - A Platform for 3D AR and VR Applications

AssemblyReferenceCollection.IAssemblyReferenceCollectionEnumerator.Current Property

Gets the current element in the collection.

AssemblyReference Current {get;}

See Also

AssemblyReferenceCollection.IAssemblyReferenceCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


AssemblyReferenceCollection.IAssemblyReferenceCollectionEnumerator Methods

The methods of the AssemblyReferenceCollection.IAssemblyReferenceCollectionEnumerator interface are listed below. For a complete list of AssemblyReferenceCollection.IAssemblyReferenceCollectionEnumerator interface members, see the AssemblyReferenceCollection.IAssemblyReferenceCollectionEnumerator Members topic.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

AssemblyReferenceCollection.IAssemblyReferenceCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


AssemblyReferenceCollection.IAssemblyReferenceCollectionEnumerator.MoveNext Method

Advances the enumerator to the next element in the collection.

bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Exceptions

Exception Type | Condition
InvalidOperationException | The collection was modified after the enumerator was created.

See Also

AssemblyReferenceCollection.IAssemblyReferenceCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


AssemblyReferenceCollection.IAssemblyReferenceCollectionEnumerator.Reset Method

Sets the enumerator to its initial position, before the first element in the collection.

void Reset();

See Also

AssemblyReferenceCollection.IAssemblyReferenceCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


AssemblyReferenceCollection.Tag Enumeration

protected enum AssemblyReferenceCollection.Tag

Members

Member Name | Description
Default |

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

DDW.CSharp.Dom Namespace


AssignExpr Class

An assignment expression.

For a list of all members of this type, see AssignExpr Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Expression
DDW.CSharp.Dom.AssignExpr

public class AssignExpr : Expression

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

AssignExpr Members | DDW.CSharp.Dom Namespace


AssignExpr Members

AssignExpr overview

Public Static Methods

OperatorFromString | A helper method that returns the AssignOperator from string input.
StringFromOperator | A helper method that returns a string (that would be used in C# code) from an AssignOperator.

Public Instance Constructors

AssignExpr Constructor Initializes a new instance of the AssignExpr class.

Public Instance Properties

Left | Gets or sets the left side of the assignment.
LinePragma (inherited from CSharpGraph) |
Operator | Gets or sets the assignment operator.
Right | Gets or sets the right side of the assignment.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AssignExpr Class | DDW.CSharp.Dom Namespace


AssignExpr Constructor

Initializes a new instance of the AssignExpr class.

public AssignExpr();

See Also

AssignExpr Class | DDW.CSharp.Dom Namespace


AssignExpr Properties

The properties of the AssignExpr class are listed below. For a complete list of AssignExpr class members, see the AssignExpr Members topic.

Public Instance Properties

Left | Gets or sets the left side of the assignment.
LinePragma (inherited from CSharpGraph) |
Operator | Gets or sets the assignment operator.
Right | Gets or sets the right side of the assignment.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

AssignExpr Class | DDW.CSharp.Dom Namespace


Left Property

Goblin - A Platform for 3D AR and VR Applications

AssignExpr.Left Property

Gets or sets the left side of the assignment.

public Expression Left {get; set;}

See Also

AssignExpr Class | DDW.CSharp.Dom Namespace


Operator Property

Goblin - A Platform for 3D AR and VR Applications

AssignExpr.Operator Property

Gets or sets the assignment operator.

public AssignOperator Operator {get; set;}

See Also

AssignExpr Class | DDW.CSharp.Dom Namespace


Right Property

Goblin - A Platform for 3D AR and VR Applications

AssignExpr.Right Property

Gets or sets the right side of the assignment.

public Expression Right {get; set;}

See Also

AssignExpr Class | DDW.CSharp.Dom Namespace


AssignExpr Methods

The methods of the AssignExpr class are listed below. For a complete list of AssignExpr class members, see the AssignExpr Members topic.

Public Static Methods

OperatorFromString | A helper method that returns the AssignOperator from string input.
StringFromOperator | A helper method that returns a string (that would be used in C# code) from an AssignOperator.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AssignExpr Class | DDW.CSharp.Dom Namespace


AssignExpr.OperatorFromString Method

A helper method that returns the AssignOperator from string input.

public static AssignOperator OperatorFromString(
string op
);

Parameters

op
The string to be converted.

Return Value

The resulting AssignOperator.

See Also

AssignExpr Class | DDW.CSharp.Dom Namespace


AssignExpr.StringFromOperator Method

A helper method that returns a string (that would be used in C# code) from an AssignOperator.

public static string StringFromOperator(
AssignOperator op
);

Parameters

op
The AssignOperator to be parsed.

Return Value

The string representation.

See Also

AssignExpr Class | DDW.CSharp.Dom Namespace


AssignOperator Enumeration

An enumeration of possible assign expression operators (=, +=, *=...).

public enum AssignOperator

Members

Member Name | Description
Empty |
Assign |
AdditionAssign |
SubtractionAssign |
MultiplyAssign |
DivisionAssign |
ModulusAssign |
BitwiseAndAssign |
BitwiseOrAssign |
ExclusiveOrAssign |
LeftShiftAssign |
RightShiftAssign |

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

DDW.CSharp.Dom Namespace


AttachDelegateStmt Class

Attaches a delegate to an event.

For a list of all members of this type, see AttachDelegateStmt Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Statement
DDW.CSharp.Dom.AttachDelegateStmt

public class AttachDelegateStmt : Statement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

AttachDelegateStmt Members | DDW.CSharp.Dom Namespace


AttachDelegateStmt Members

AttachDelegateStmt overview

Public Instance Constructors

AttachDelegateStmt Constructor Initializes a new instance of the AttachDelegateStmt class.

Public Instance Properties

Event | Gets or sets the event to add the delegate to.
LinePragma (inherited from CSharpGraph) |
Listener | Gets or sets the listener method to be attached.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AttachDelegateStmt Class | DDW.CSharp.Dom Namespace


AttachDelegateStmt Constructor

Initializes a new instance of the AttachDelegateStmt class.

public AttachDelegateStmt();

See Also

AttachDelegateStmt Class | DDW.CSharp.Dom Namespace


AttachDelegateStmt Properties

The properties of the AttachDelegateStmt class are listed below. For a complete list of AttachDelegateStmt class members, see the AttachDelegateStmt Members topic.

Public Instance Properties

Event | Gets or sets the event to add the delegate to.
LinePragma (inherited from CSharpGraph) |
Listener | Gets or sets the listener method to be attached.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

AttachDelegateStmt Class | DDW.CSharp.Dom Namespace


Event Property

Goblin - A Platform for 3D AR and VR Applications

AttachDelegateStmt.Event Property

Gets or sets the event to add the delegate to.

public TypeRef Event {get; set;}

See Also

AttachDelegateStmt Class | DDW.CSharp.Dom Namespace


Listener Property

Goblin - A Platform for 3D AR and VR Applications

AttachDelegateStmt.Listener Property

Gets or sets the listener method to be attached.

public Expression Listener {get; set;}

See Also

AttachDelegateStmt Class | DDW.CSharp.Dom Namespace


AttributeTarget Enumeration

An enumeration of possible targets a custom attribute can apply to.

public enum AttributeTarget

Members

Member Name | Description
Empty |
Assembly |
Module |
Class |
Struct |
Interface |
Enum |
Delegate |
Method |
Parameter |
Field |
PropertyIndexer |
PropertyGetAccessor |
PropertySetAccessor |
EventField |
EventProperty |
EventAdd |
EventRemove |
Event |
Property |
Return |
Type |

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

DDW.CSharp.Dom Namespace


BaseRef Class

A 'base' reference.

For a list of all members of this type, see BaseRef Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Expression
DDW.CSharp.Dom.Reference
DDW.CSharp.Dom.BaseRef

public class BaseRef : Reference

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

BaseRef Members | DDW.CSharp.Dom Namespace


BaseRef Members

BaseRef overview

Public Instance Constructors

BaseRef Constructor Initializes a new instance of the BaseRef class.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BaseRef Class | DDW.CSharp.Dom Namespace


BaseRef Constructor

Initializes a new instance of the BaseRef class.

public BaseRef();

See Also

BaseRef Class | DDW.CSharp.Dom Namespace


BinaryExpr Class

A binary expression.

For a list of all members of this type, see BinaryExpr Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Expression
DDW.CSharp.Dom.BinaryExpr

public class BinaryExpr : Expression

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

BinaryExpr Members | DDW.CSharp.Dom Namespace


BinaryExpr Members

BinaryExpr overview

Public Static Methods

OperatorFromString | A helper method that returns the BinaryOperator from string input.
StringFromOperator | A helper method that returns a string (that would be used in C# code) from a BinaryOperator.

Public Instance Constructors

BinaryExpr Constructor Initializes a new instance of the BinaryExpr class.

Public Instance Properties

Left | Gets or sets the left side of the binary expression.
LinePragma (inherited from CSharpGraph) |
Operator | Gets or sets the binary operator.
Right | Gets or sets the right side of the binary expression.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BinaryExpr Class | DDW.CSharp.Dom Namespace


BinaryExpr Constructor

Initializes a new instance of the BinaryExpr class.

public BinaryExpr();

See Also

BinaryExpr Class | DDW.CSharp.Dom Namespace


BinaryExpr Properties

The properties of the BinaryExpr class are listed below. For a complete list of BinaryExpr class members, see the BinaryExpr Members topic.

Public Instance Properties

Left | Gets or sets the left side of the binary expression.
LinePragma (inherited from CSharpGraph) |
Operator | Gets or sets the binary operator.
Right | Gets or sets the right side of the binary expression.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

BinaryExpr Class | DDW.CSharp.Dom Namespace


Left Property

Goblin - A Platform for 3D AR and VR Applications

BinaryExpr.Left Property

Gets or sets the left side of the binary expression.

public Expression Left {get; set;}

See Also

BinaryExpr Class | DDW.CSharp.Dom Namespace


Operator Property

Goblin - A Platform for 3D AR and VR Applications

BinaryExpr.Operator Property

Gets or sets the binary operator.

public BinaryOperator Operator {get; set;}

See Also

BinaryExpr Class | DDW.CSharp.Dom Namespace


Right Property

Goblin - A Platform for 3D AR and VR Applications

BinaryExpr.Right Property

Gets or sets the right side of the binary expression.

public Expression Right {get; set;}

See Also

BinaryExpr Class | DDW.CSharp.Dom Namespace


BinaryExpr Methods

The methods of the BinaryExpr class are listed below. For a complete list of BinaryExpr class members, see the BinaryExpr Members topic.

Public Static Methods

OperatorFromString | A helper method that returns the BinaryOperator from string input.
StringFromOperator | A helper method that returns a string (that would be used in C# code) from a BinaryOperator.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BinaryExpr Class | DDW.CSharp.Dom Namespace


BinaryExpr.OperatorFromString Method

A helper method that returns the BinaryOperator from string input.

public static BinaryOperator OperatorFromString(
string txt
);

Parameters

txt

Return Value

The resulting BinaryOperator.

See Also

BinaryExpr Class | DDW.CSharp.Dom Namespace


BinaryExpr.StringFromOperator Method

A helper method that returns a string (that would be used in C# code) from a BinaryOperator.

public static string StringFromOperator(
BinaryOperator bopEnum
);

Parameters

bopEnum

Return Value

The string representation.

See Also

BinaryExpr Class | DDW.CSharp.Dom Namespace


BinaryOperator Enumeration

An enumeration of possible binary expression operators.

public enum BinaryOperator

Members

Member Name | Description
Empty |
BooleanOr |
BooleanAnd |
BitwiseOr |
BitwiseAnd |
BitwiseXor |
IdentityInequality |
IdentityEquality |
GreaterThanOrEqual |
LessThanOrEqual |
GreaterThan |
LessThan |
Subtract |
Add |
Modulus |
Divide |
Multiply |
As |
Is |
ShiftRight |
ShiftLeft |

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

DDW.CSharp.Dom Namespace


BooleanLiteral Class

A boolean literal.

For a list of all members of this type, see BooleanLiteral Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Expression
DDW.CSharp.Dom.PrimitiveExpr
DDW.CSharp.Dom.BooleanLiteral

public class BooleanLiteral : PrimitiveExpr

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

BooleanLiteral Members | DDW.CSharp.Dom Namespace


BooleanLiteral Members

BooleanLiteral overview

Public Instance Constructors

BooleanLiteral Constructor Initializes a new instance of the BooleanLiteral class.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.
Value | Gets or sets the value of this literal. Must be 'true' or 'false'.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BooleanLiteral Class | DDW.CSharp.Dom Namespace


BooleanLiteral Constructor

Initializes a new instance of the BooleanLiteral class.

public BooleanLiteral();

See Also

BooleanLiteral Class | DDW.CSharp.Dom Namespace


BooleanLiteral Properties

The properties of the BooleanLiteral class are listed below. For a complete list of BooleanLiteral class members, see the BooleanLiteral Members topic.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.
Value | Gets or sets the value of this literal. Must be 'true' or 'false'.

See Also

BooleanLiteral Class | DDW.CSharp.Dom Namespace


Value Property

Goblin - A Platform for 3D AR and VR Applications

BooleanLiteral.Value Property

Gets or sets the value of this literal. Must be 'true' or 'false'.

public bool Value {get; set;}

See Also

BooleanLiteral Class | DDW.CSharp.Dom Namespace


BreakStmt Class

A break statement.

For a list of all members of this type, see BreakStmt Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Statement
DDW.CSharp.Dom.BreakStmt

public class BreakStmt : Statement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

BreakStmt Members | DDW.CSharp.Dom Namespace


BreakStmt Members

BreakStmt overview

Public Instance Constructors

BreakStmt Constructor Initializes a new instance of the BreakStmt class.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BreakStmt Class | DDW.CSharp.Dom Namespace


BreakStmt Constructor

Initializes a new instance of the BreakStmt class.

public BreakStmt();

See Also

BreakStmt Class | DDW.CSharp.Dom Namespace


BuiltInType Class

A C# built in type.

For a list of all members of this type, see BuiltInType Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Expression
DDW.CSharp.Dom.Reference
DDW.CSharp.Dom.BuiltInType

public class BuiltInType : Reference

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

BuiltInType Members | DDW.CSharp.Dom Namespace


BuiltInType Members

BuiltInType overview

Public Instance Constructors

BuiltInType Constructor Initializes a new instance of the BuiltInType class.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
TypeName | Gets or sets the name of the built in type.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BuiltInType Class | DDW.CSharp.Dom Namespace


BuiltInType Constructor

Initializes a new instance of the BuiltInType class.

public BuiltInType();

See Also

BuiltInType Class | DDW.CSharp.Dom Namespace


BuiltInType Properties

The properties of the BuiltInType class are listed below. For a complete list of BuiltInType class members, see the BuiltInType Members topic.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
TypeName | Gets or sets the name of the built in type.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

BuiltInType Class | DDW.CSharp.Dom Namespace


TypeName Property

Goblin - A Platform for 3D AR and VR Applications

BuiltInType.TypeName Property

Gets or sets the name of the built in type.

public string TypeName {get; set;}

See Also

BuiltInType Class | DDW.CSharp.Dom Namespace


Case Class

A case clause for a switch statement.

For a list of all members of this type, see Case Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Case

public class Case : CSharpGraph

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

Case Members | DDW.CSharp.Dom Namespace


Case Members

Case overview

Public Instance Constructors

Case Constructor Initializes a new instance of the Case class.

Public Instance Properties

Condition | Gets or sets the expression that the switch condition will be compared to.
IsDefault | Gets or sets the flag that indicates whether or not this is a 'default' case.
LinePragma (inherited from CSharpGraph) |
Statements | Gets the collection of statements in the case clause. This must include a break statement.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Case Class | DDW.CSharp.Dom Namespace


Case Constructor

Initializes a new instance of the Case class.

public Case();

See Also

Case Class | DDW.CSharp.Dom Namespace


Case Properties

The properties of the Case class are listed below. For a complete list of Case class members, see the Case Members topic.

Public Instance Properties

Condition | Gets or sets the expression that the switch condition will be compared to.
IsDefault | Gets or sets the flag that indicates whether or not this is a 'default' case.
LinePragma (inherited from CSharpGraph) |
Statements | Gets the collection of statements in the case clause. This must include a break statement.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

Case Class | DDW.CSharp.Dom Namespace


Condition Property

Goblin - A Platform for 3D AR and VR Applications

Case.Condition Property

Gets or sets the expression that the switch condition will be compared to.

public Expression Condition {get; set;}

See Also

Case Class | DDW.CSharp.Dom Namespace


IsDefault Property

Goblin - A Platform for 3D AR and VR Applications

Case.IsDefault Property

Gets or sets the flag that indicates whether or not this is a 'default' case.

public bool IsDefault {get; set;}

See Also

Case Class | DDW.CSharp.Dom Namespace


Statements Property

Goblin - A Platform for 3D AR and VR Applications

Case.Statements Property

Gets the collection of statements in the case clause. This must include a break statement.

public StatementCollection Statements {get;}

See Also

Case Class | DDW.CSharp.Dom Namespace


CaseCollection Class

A strongly-typed collection of Case objects.

For a list of all members of this type, see CaseCollection Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.CaseCollection

public class CaseCollection : CSharpGraph, IList, ICollection, IEnumerable, ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

CaseCollection Members | DDW.CSharp.Dom Namespace


CaseCollection Members

CaseCollection overview

Public Static Methods

ReadOnly | Creates a read-only wrapper for a CaseCollection instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a CaseCollection instance.

Public Instance Constructors

CaseCollection Overloaded. Initializes a new instance of the CaseCollection class.

Public Instance Properties

Capacity | Gets or sets the number of elements the CaseCollection can contain.
Count | Gets the number of elements actually contained in the CaseCollection.
GraphType |
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the Case at the specified index.
LinePragma (inherited from CSharpGraph) |
SyncRoot | Gets an object that can be used to synchronize access to the collection.
Text |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Add | Adds a Case to the end of the CaseCollection.
AddRange | Overloaded. Adds the elements of a Case array to the current CaseCollection.
Clear | Removes all elements from the CaseCollection.
Clone | Creates a shallow copy of the CaseCollection.
Contains | Determines whether a given Case is in the CaseCollection.
CopyTo | Overloaded. Copies the entire CaseCollection to a one-dimensional Case array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the CaseCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the zero-based index of the first occurrence of a Case in the CaseCollection.
Insert | Inserts an element into the CaseCollection at the specified index.
Remove | Removes the first occurrence of a specific Case from the CaseCollection.
RemoveAt | Removes the element at the specified index of the CaseCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Constructors

CaseCollection Overloaded. Initializes a new instance of the CaseCollection class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CaseCollection Class | DDW.CSharp.Dom Namespace


CaseCollection Constructor

Initializes a new instance of the CaseCollection class that is empty and has the default initial capacity.

Overload List

Initializes a new instance of the CaseCollection class that is empty and has the default initial capacity.

public CaseCollection();

Initializes a new instance of the CaseCollection class that contains elements copied from the specified Case array.

public CaseCollection(Case[]);

Initializes a new instance of the CaseCollection class that contains elements copied from the specified CaseCollection.

public CaseCollection(CaseCollection);

protected CaseCollection(Tag);

Initializes a new instance of the CaseCollection class that has the specified initial capacity.

public CaseCollection(int);

See Also

CaseCollection Class | DDW.CSharp.Dom Namespace


CaseCollection Constructor ()

Initializes a new instance of the CaseCollection class that is empty and has the default initial capacity.

public CaseCollection();

See Also

CaseCollection Class | DDW.CSharp.Dom Namespace | CaseCollection Constructor Overload List


CaseCollection Constructor (Int32)

Initializes a new instance of the CaseCollection class that has the specified initial capacity.

public CaseCollection(
int capacity
);

Parameters

capacity
The number of elements that the new CaseCollection is initially capable of storing.

See Also

CaseCollection Class | DDW.CSharp.Dom Namespace | CaseCollection Constructor Overload List


CaseCollection Constructor (CaseCollection)

Initializes a new instance of the CaseCollection class that contains elements copied from the specified CaseCollection.

public CaseCollection(
CaseCollection c
);

Parameters

c
The CaseCollection whose elements are copied to the new collection.

See Also

CaseCollection Class | DDW.CSharp.Dom Namespace | CaseCollection Constructor Overload List


CaseCollection Constructor (Case[])

Initializes a new instance of the CaseCollection class that contains elements copied from the specified Case array.

public CaseCollection(
Case[] a
);

Parameters

a
The Case array whose elements are copied to the new list.

See Also

CaseCollection Class | DDW.CSharp.Dom Namespace | CaseCollection Constructor Overload List


CaseCollection Constructor (Tag)

protected CaseCollection(
Tag t
);

See Also

CaseCollection Class | DDW.CSharp.Dom Namespace | CaseCollection Constructor Overload List


CaseCollection Properties

The properties of the CaseCollection class are listed below. For a complete list of CaseCollection class members, see the CaseCollection Members topic.

Public Instance Properties

Capacity | Gets or sets the number of elements the CaseCollection can contain.
Count | Gets the number of elements actually contained in the CaseCollection.
GraphType |
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the Case at the specified index.
LinePragma (inherited from CSharpGraph) |
SyncRoot | Gets an object that can be used to synchronize access to the collection.
Text |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

CaseCollection Class | DDW.CSharp.Dom Namespace


Capacity Property

Goblin - A Platform for 3D AR and VR Applications

CaseCollection.Capacity Property

Gets or sets the number of elements the CaseCollection can contain.

public virtual int Capacity {get; set;}

See Also

CaseCollection Class | DDW.CSharp.Dom Namespace


Count Property

Goblin - A Platform for 3D AR and VR Applications

CaseCollection.Count Property

Gets the number of elements actually contained in the CaseCollection.

public virtual int Count {get;}

Implements

ICollection.Count

See Also

CaseCollection Class | DDW.CSharp.Dom Namespace


GraphType Property

Goblin - A Platform for 3D AR and VR Applications

CaseCollection.GraphType Property

public override GraphTypes GraphType {get;}

Implements

IGraph.GraphType

See Also

CaseCollection Class | DDW.CSharp.Dom Namespace


IsFixedSize Property

Goblin - A Platform for 3D AR and VR Applications

CaseCollection.IsFixedSize Property

Gets a value indicating whether the collection has a fixed size.

public virtual bool IsFixedSize {get;}

Property Value

true if the collection has a fixed size; otherwise, false. The default is false

Implements

IList.IsFixedSize

See Also

CaseCollection Class | DDW.CSharp.Dom Namespace


IsReadOnly Property

Goblin - A Platform for 3D AR and VR Applications

CaseCollection.IsReadOnly Property

gets a value indicating whether the IList is read-only.

public virtual bool IsReadOnly {get;}

Property Value

true if the collection is read-only; otherwise, false. The default is false

Implements

IList.IsReadOnly

See Also

CaseCollection Class | DDW.CSharp.Dom Namespace


IsSynchronized Property

Goblin - A Platform for 3D AR and VR Applications

CaseCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread-safe).

public virtual bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

CaseCollection Class | DDW.CSharp.Dom Namespace


Item Property

Goblin - A Platform for 3D AR and VR Applications

CaseCollection.Item Property

Gets or sets the Case at the specified index.

public virtual Case this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

CaseCollection Class | DDW.CSharp.Dom Namespace


SyncRoot Property

Goblin - A Platform for 3D AR and VR Applications

CaseCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

public virtual object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

CaseCollection Class | DDW.CSharp.Dom Namespace


Text Property

Goblin - A Platform for 3D AR and VR Applications

CaseCollection.Text Property

public override string Text {get;}

Implements

IGraph.Text

See Also

CaseCollection Class | DDW.CSharp.Dom Namespace


CaseCollection Methods

The methods of the CaseCollection class are listed below. For a complete list of CaseCollection class members, see the CaseCollection Members topic.

Public Static Methods

ReadOnly | Creates a read-only wrapper for a CaseCollection instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a CaseCollection instance.

Public Instance Methods

Add | Adds a Case to the end of the CaseCollection.
AddRange | Overloaded. Adds the elements of a Case array to the current CaseCollection.
Clear | Removes all elements from the CaseCollection.
Clone | Creates a shallow copy of the CaseCollection.
Contains | Determines whether a given Case is in the CaseCollection.
CopyTo | Overloaded. Copies the entire CaseCollection to a one-dimensional Case array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the CaseCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the zero-based index of the first occurrence of a Case in the CaseCollection.
Insert | Inserts an element into the CaseCollection at the specified index.
Remove | Removes the first occurrence of a specific Case from the CaseCollection.
RemoveAt | Removes the element at the specified index of the CaseCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CaseCollection Class | DDW.CSharp.Dom Namespace


CaseCollection.Add Method

Adds a Case to the end of the CaseCollection.

public virtual int Add(
Case item
);

Parameters

item
The Case to be added to the end of the CaseCollection.

Return Value

The index at which the value has been added.

See Also

CaseCollection Class | DDW.CSharp.Dom Namespace


AddRange Method

Goblin - A Platform for 3D AR and VR Applications

CaseCollection.AddRange Method

Adds the elements of a Case array to the current CaseCollection.

Overload List

Adds the elements of a Case array to the current CaseCollection.

public virtual int AddRange(Case[]);

Adds the elements of another CaseCollection to the current CaseCollection.

public virtual int AddRange(CaseCollection);

See Also

CaseCollection Class | DDW.CSharp.Dom Namespace


CaseCollection.AddRange Method (Case[])

Adds the elements of a Case array to the current CaseCollection.

public virtual int AddRange(
Case[] x
);

Parameters

x
The Case array whose elements should be added to the end of the CaseCollection.

Return Value

The new Count of the CaseCollection.

See Also

CaseCollection Class | DDW.CSharp.Dom Namespace | CaseCollection.AddRange Overload List


CaseCollection.AddRange Method (CaseCollection)

Adds the elements of another CaseCollection to the current CaseCollection.

public virtual int AddRange(
CaseCollection x
);

Parameters

x
The CaseCollection whose elements should be added to the end of the current CaseCollection.

Return Value

The new Count of the CaseCollection.

See Also

CaseCollection Class | DDW.CSharp.Dom Namespace | CaseCollection.AddRange Overload List


CaseCollection.Clear Method

Removes all elements from the CaseCollection.

public virtual void Clear();

Implements

IList.Clear

See Also

CaseCollection Class | DDW.CSharp.Dom Namespace


CaseCollection.Clone Method

Creates a shallow copy of the CaseCollection.

public virtual object Clone();

Implements

ICloneable.Clone

See Also

CaseCollection Class | DDW.CSharp.Dom Namespace


CaseCollection.Contains Method

Determines whether a given Case is in the CaseCollection.

public virtual bool Contains(
Case item
);

Parameters

item
The Case to check for.

Return Value

true if item is found in the CaseCollection; otherwise, false.

See Also

CaseCollection Class | DDW.CSharp.Dom Namespace


CopyTo Method

Goblin - A Platform for 3D AR and VR Applications

CaseCollection.CopyTo Method

Copies the entire CaseCollection to a one-dimensional Case array.

Overload List

Copies the entire CaseCollection to a one-dimensional Case array.

public virtual void CopyTo(Case[]);

Copies the entire CaseCollection to a one-dimensional Case array, starting at the specified index of the target array.

public virtual void CopyTo(Case[],int);

See Also

CaseCollection Class | DDW.CSharp.Dom Namespace


CaseCollection.CopyTo Method (Case[])

Copies the entire CaseCollection to a one-dimensional Case array.

public virtual void CopyTo(
Case[] array
);

Parameters

array
The one-dimensional Case array to copy to.

See Also

CaseCollection Class | DDW.CSharp.Dom Namespace | CaseCollection.CopyTo Overload List


CaseCollection.CopyTo Method (Case[], Int32)

Copies the entire CaseCollection to a one-dimensional Case array, starting at the specified index of the target array.

public virtual void CopyTo(
Case[] array,
int start
);

Parameters

array
The one-dimensional Case array to copy to.
start
The zero-based index in array at which copying begins.

See Also

CaseCollection Class | DDW.CSharp.Dom Namespace | CaseCollection.CopyTo Overload List


CaseCollection.GetEnumerator Method

Returns an enumerator that can iterate through the CaseCollection.

public virtual ICaseCollectionEnumerator GetEnumerator();

Return Value

An Enumerator for the entire CaseCollection.

See Also

CaseCollection Class | DDW.CSharp.Dom Namespace


CaseCollection.IndexOf Method

Returns the zero-based index of the first occurrence of a Case in the CaseCollection.

public virtual int IndexOf(
Case item
);

Parameters

item
The Case to locate in the CaseCollection.

Return Value

The zero-based index of the first occurrence of item in the entire CaseCollection, if found; otherwise, -1.

See Also

CaseCollection Class | DDW.CSharp.Dom Namespace


CaseCollection.Insert Method

Inserts an element into the CaseCollection at the specified index.

public virtual void Insert(
int index,
Case item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The Case to insert.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

CaseCollection Class | DDW.CSharp.Dom Namespace


CaseCollection.ReadOnly Method

Creates a read-only wrapper for a CaseCollection instance.

public static CaseCollection ReadOnly(
CaseCollection list
);

Return Value

An CaseCollection wrapper that is read-only.

See Also

CaseCollection Class | DDW.CSharp.Dom Namespace


CaseCollection.Remove Method

Removes the first occurrence of a specific Case from the CaseCollection.

public virtual void Remove(
Case item
);

Parameters

item
The Case to remove from the CaseCollection.

Exceptions

Exception Type | Condition
ArgumentException | The specified Case was not found in the CaseCollection.

See Also

CaseCollection Class | DDW.CSharp.Dom Namespace


CaseCollection.RemoveAt Method

Removes the element at the specified index of the CaseCollection.

public virtual void RemoveAt(
int index
);

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

CaseCollection Class | DDW.CSharp.Dom Namespace


CaseCollection.Synchronized Method

Creates a synchronized (thread-safe) wrapper for a CaseCollection instance.

public static CaseCollection Synchronized(
CaseCollection list
);

Return Value

An CaseCollection wrapper that is synchronized (thread-safe).

See Also

CaseCollection Class | DDW.CSharp.Dom Namespace


CaseCollection.TrimToSize Method

Sets the capacity to the actual number of elements.

public virtual void TrimToSize();

See Also

CaseCollection Class | DDW.CSharp.Dom Namespace


CaseCollection.ICaseCollectionEnumerator Interface

Supports type-safe iteration over a CaseCollection.

For a list of all members of this type, see CaseCollection.ICaseCollectionEnumerator Members.

public interface CaseCollection.ICaseCollectionEnumerator

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

CaseCollection.ICaseCollectionEnumerator Members | DDW.CSharp.Dom Namespace


CaseCollection.ICaseCollectionEnumerator Members

CaseCollection.ICaseCollectionEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

CaseCollection.ICaseCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


CaseCollection.ICaseCollectionEnumerator Properties

The properties of the CaseCollection.ICaseCollectionEnumerator interface are listed below. For a complete list of CaseCollection.ICaseCollectionEnumerator interface members, see the CaseCollection.ICaseCollectionEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

CaseCollection.ICaseCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


Current Property

Goblin - A Platform for 3D AR and VR Applications

CaseCollection.ICaseCollectionEnumerator.Current Property

Gets the current element in the collection.

Case Current {get;}

See Also

CaseCollection.ICaseCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


CaseCollection.ICaseCollectionEnumerator Methods

The methods of the CaseCollection.ICaseCollectionEnumerator interface are listed below. For a complete list of CaseCollection.ICaseCollectionEnumerator interface members, see the CaseCollection.ICaseCollectionEnumerator Members topic.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

CaseCollection.ICaseCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


CaseCollection.ICaseCollectionEnumerator.MoveNext Method

Advances the enumerator to the next element in the collection.

bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Exceptions

Exception Type | Condition
InvalidOperationException | The collection was modified after the enumerator was created.

See Also

CaseCollection.ICaseCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


CaseCollection.ICaseCollectionEnumerator.Reset Method

Sets the enumerator to its initial position, before the first element in the collection.

void Reset();

See Also

CaseCollection.ICaseCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


CaseCollection.Tag Enumeration

protected enum CaseCollection.Tag

Members

Member Name | Description
Default |

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

DDW.CSharp.Dom Namespace


CastExpr Class

A cast expression.

For a list of all members of this type, see CastExpr Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Expression
DDW.CSharp.Dom.CastExpr

public class CastExpr : Expression

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

CastExpr Members | DDW.CSharp.Dom Namespace


CastExpr Members

CastExpr overview

Public Instance Constructors

CastExpr Constructor Initializes a new instance of the CastExpr class.

Public Instance Properties

Expression | Gets or sets the expression to cast to a new type.
LinePragma (inherited from CSharpGraph) |
TargetType | Gets or sets the type to cast the expression to.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CastExpr Class | DDW.CSharp.Dom Namespace


CastExpr Constructor

Initializes a new instance of the CastExpr class.

public CastExpr();

See Also

CastExpr Class | DDW.CSharp.Dom Namespace


CastExpr Properties

The properties of the CastExpr class are listed below. For a complete list of CastExpr class members, see the CastExpr Members topic.

Public Instance Properties

Expression | Gets or sets the expression to cast to a new type.
LinePragma (inherited from CSharpGraph) |
TargetType | Gets or sets the type to cast the expression to.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

CastExpr Class | DDW.CSharp.Dom Namespace


Expression Property

Goblin - A Platform for 3D AR and VR Applications

CastExpr.Expression Property

Gets or sets the expression to cast to a new type.

public Expression Expression {get; set;}

See Also

CastExpr Class | DDW.CSharp.Dom Namespace | CastExpr.Expression Overload List


TargetType Property

Goblin - A Platform for 3D AR and VR Applications

CastExpr.TargetType Property

Gets or sets the type to cast the expression to.

public TypeRef TargetType {get; set;}

See Also

CastExpr Class | DDW.CSharp.Dom Namespace


Catch Class

A catch clause.

For a list of all members of this type, see Catch Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Catch

public class Catch : CSharpGraph

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

Catch Members | DDW.CSharp.Dom Namespace


Catch Members

Catch overview

Public Instance Constructors

Catch Constructor Initializes a new instance of the Catch class.

Public Instance Properties

CatchExceptionType | Gets or sets the type of exception this catches.
LinePragma (inherited from CSharpGraph) |
LocalName | Gets or sets the variable name given to this exception.
Statements | Gets the collection of statements in the catch clause.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Catch Class | DDW.CSharp.Dom Namespace


Catch Constructor

Initializes a new instance of the Catch class.

public Catch();

See Also

Catch Class | DDW.CSharp.Dom Namespace


Catch Properties

The properties of the Catch class are listed below. For a complete list of Catch class members, see the Catch Members topic.

Public Instance Properties

CatchExceptionType | Gets or sets the type of exception this catches.
LinePragma (inherited from CSharpGraph) |
LocalName | Gets or sets the variable name given to this exception.
Statements | Gets the collection of statements in the catch clause.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

Catch Class | DDW.CSharp.Dom Namespace


CatchExceptionType Property

Goblin - A Platform for 3D AR and VR Applications

Catch.CatchExceptionType Property

Gets or sets the type of exception this catches.

public TypeRef CatchExceptionType {get; set;}

See Also

Catch Class | DDW.CSharp.Dom Namespace


LocalName Property

Goblin - A Platform for 3D AR and VR Applications

Catch.LocalName Property

Gets or sets the variable name given to this exception.

public string LocalName {get; set;}

See Also

Catch Class | DDW.CSharp.Dom Namespace


Statements Property

Goblin - A Platform for 3D AR and VR Applications

Catch.Statements Property

Gets the collection of statements in the catch clause.

public StatementCollection Statements {get;}

See Also

Catch Class | DDW.CSharp.Dom Namespace


CatchCollection Class

A strongly-typed collection of Catch objects.

For a list of all members of this type, see CatchCollection Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.CatchCollection

public class CatchCollection : CSharpGraph, IList, ICollection, IEnumerable, ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

CatchCollection Members | DDW.CSharp.Dom Namespace


CatchCollection Members

CatchCollection overview

Public Static Methods

ReadOnly | Creates a read-only wrapper for a CatchCollection instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a CatchCollection instance.

Public Instance Constructors

CatchCollection Overloaded. Initializes a new instance of the CatchCollection class.

Public Instance Properties

Capacity | Gets or sets the number of elements the CatchCollection can contain.
Count | Gets the number of elements actually contained in the CatchCollection.
GraphType |
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the Catch at the specified index.
LinePragma (inherited from CSharpGraph) |
SyncRoot | Gets an object that can be used to synchronize access to the collection.
Text |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Add | Adds a Catch to the end of the CatchCollection.
AddRange | Overloaded. Adds the elements of a Catch array to the current CatchCollection.
Clear | Removes all elements from the CatchCollection.
Clone | Creates a shallow copy of the CatchCollection.
Contains | Determines whether a given Catch is in the CatchCollection.
CopyTo | Overloaded. Copies the entire CatchCollection to a one-dimensional Catch array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the CatchCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the zero-based index of the first occurrence of a Catch in the CatchCollection.
Insert | Inserts an element into the CatchCollection at the specified index.
Remove | Removes the first occurrence of a specific Catch from the CatchCollection.
RemoveAt | Removes the element at the specified index of the CatchCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Constructors

CatchCollection Overloaded. Initializes a new instance of the CatchCollection class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CatchCollection Class | DDW.CSharp.Dom Namespace


CatchCollection Constructor

Initializes a new instance of the CatchCollection class that is empty and has the default initial capacity.

Overload List

Initializes a new instance of the CatchCollection class that is empty and has the default initial capacity.

public CatchCollection();

Initializes a new instance of the CatchCollection class that contains elements copied from the specified Catch array.

public CatchCollection(Catch[]);

Initializes a new instance of the CatchCollection class that contains elements copied from the specified CatchCollection.

public CatchCollection(CatchCollection);

protected CatchCollection(Tag);

Initializes a new instance of the CatchCollection class that has the specified initial capacity.

public CatchCollection(int);

See Also

CatchCollection Class | DDW.CSharp.Dom Namespace


CatchCollection Constructor ()

Initializes a new instance of the CatchCollection class that is empty and has the default initial capacity.

public CatchCollection();

See Also

CatchCollection Class | DDW.CSharp.Dom Namespace | CatchCollection Constructor Overload List


CatchCollection Constructor (Int32)

Initializes a new instance of the CatchCollection class that has the specified initial capacity.

public CatchCollection(
int capacity
);

Parameters

capacity
The number of elements that the new CatchCollection is initially capable of storing.

See Also

CatchCollection Class | DDW.CSharp.Dom Namespace | CatchCollection Constructor Overload List


CatchCollection Constructor (CatchCollection)

Initializes a new instance of the CatchCollection class that contains elements copied from the specified CatchCollection.

public CatchCollection(
CatchCollection c
);

Parameters

c
The CatchCollection whose elements are copied to the new collection.

See Also

CatchCollection Class | DDW.CSharp.Dom Namespace | CatchCollection Constructor Overload List


CatchCollection Constructor (Catch[])

Initializes a new instance of the CatchCollection class that contains elements copied from the specified Catch array.

public CatchCollection(
Catch[] a
);

Parameters

a
The Catch array whose elements are copied to the new list.

See Also

CatchCollection Class | DDW.CSharp.Dom Namespace | CatchCollection Constructor Overload List


CatchCollection Constructor (Tag)

protected CatchCollection(
Tag t
);

See Also

CatchCollection Class | DDW.CSharp.Dom Namespace | CatchCollection Constructor Overload List


CatchCollection Properties

The properties of the CatchCollection class are listed below. For a complete list of CatchCollection class members, see the CatchCollection Members topic.

Public Instance Properties

Capacity | Gets or sets the number of elements the CatchCollection can contain.
Count | Gets the number of elements actually contained in the CatchCollection.
GraphType |
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the Catch at the specified index.
LinePragma (inherited from CSharpGraph) |
SyncRoot | Gets an object that can be used to synchronize access to the collection.
Text |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

CatchCollection Class | DDW.CSharp.Dom Namespace


Capacity Property

Goblin - A Platform for 3D AR and VR Applications

CatchCollection.Capacity Property

Gets or sets the number of elements the CatchCollection can contain.

public virtual int Capacity {get; set;}

See Also

CatchCollection Class | DDW.CSharp.Dom Namespace


Count Property

Goblin - A Platform for 3D AR and VR Applications

CatchCollection.Count Property

Gets the number of elements actually contained in the CatchCollection.

public virtual int Count {get;}

Implements

ICollection.Count

See Also

CatchCollection Class | DDW.CSharp.Dom Namespace


GraphType Property

Goblin - A Platform for 3D AR and VR Applications

CatchCollection.GraphType Property

public override GraphTypes GraphType {get;}

Implements

IGraph.GraphType

See Also

CatchCollection Class | DDW.CSharp.Dom Namespace


IsFixedSize Property

Goblin - A Platform for 3D AR and VR Applications

CatchCollection.IsFixedSize Property

Gets a value indicating whether the collection has a fixed size.

public virtual bool IsFixedSize {get;}

Property Value

true if the collection has a fixed size; otherwise, false. The default is false

Implements

IList.IsFixedSize

See Also

CatchCollection Class | DDW.CSharp.Dom Namespace


IsReadOnly Property

Goblin - A Platform for 3D AR and VR Applications

CatchCollection.IsReadOnly Property

gets a value indicating whether the IList is read-only.

public virtual bool IsReadOnly {get;}

Property Value

true if the collection is read-only; otherwise, false. The default is false

Implements

IList.IsReadOnly

See Also

CatchCollection Class | DDW.CSharp.Dom Namespace


IsSynchronized Property

Goblin - A Platform for 3D AR and VR Applications

CatchCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread-safe).

public virtual bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

CatchCollection Class | DDW.CSharp.Dom Namespace


Item Property

Goblin - A Platform for 3D AR and VR Applications

CatchCollection.Item Property

Gets or sets the Catch at the specified index.

public virtual Catch this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

CatchCollection Class | DDW.CSharp.Dom Namespace


SyncRoot Property

Goblin - A Platform for 3D AR and VR Applications

CatchCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

public virtual object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

CatchCollection Class | DDW.CSharp.Dom Namespace


Text Property

Goblin - A Platform for 3D AR and VR Applications

CatchCollection.Text Property

public override string Text {get;}

Implements

IGraph.Text

See Also

CatchCollection Class | DDW.CSharp.Dom Namespace


CatchCollection Methods

The methods of the CatchCollection class are listed below. For a complete list of CatchCollection class members, see the CatchCollection Members topic.

Public Static Methods

ReadOnly | Creates a read-only wrapper for a CatchCollection instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a CatchCollection instance.

Public Instance Methods

Add | Adds a Catch to the end of the CatchCollection.
AddRange | Overloaded. Adds the elements of a Catch array to the current CatchCollection.
Clear | Removes all elements from the CatchCollection.
Clone | Creates a shallow copy of the CatchCollection.
Contains | Determines whether a given Catch is in the CatchCollection.
CopyTo | Overloaded. Copies the entire CatchCollection to a one-dimensional Catch array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the CatchCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the zero-based index of the first occurrence of a Catch in the CatchCollection.
Insert | Inserts an element into the CatchCollection at the specified index.
Remove | Removes the first occurrence of a specific Catch from the CatchCollection.
RemoveAt | Removes the element at the specified index of the CatchCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CatchCollection Class | DDW.CSharp.Dom Namespace


CatchCollection.Add Method

Adds a Catch to the end of the CatchCollection.

public virtual int Add(
Catch item
);

Parameters

item
The Catch to be added to the end of the CatchCollection.

Return Value

The index at which the value has been added.

See Also

CatchCollection Class | DDW.CSharp.Dom Namespace


AddRange Method

Goblin - A Platform for 3D AR and VR Applications

CatchCollection.AddRange Method

Adds the elements of a Catch array to the current CatchCollection.

Overload List

Adds the elements of a Catch array to the current CatchCollection.

public virtual int AddRange(Catch[]);

Adds the elements of another CatchCollection to the current CatchCollection.

public virtual int AddRange(CatchCollection);

See Also

CatchCollection Class | DDW.CSharp.Dom Namespace


CatchCollection.AddRange Method (Catch[])

Adds the elements of a Catch array to the current CatchCollection.

public virtual int AddRange(
Catch[] x
);

Parameters

x
The Catch array whose elements should be added to the end of the CatchCollection.

Return Value

The new Count of the CatchCollection.

See Also

CatchCollection Class | DDW.CSharp.Dom Namespace | CatchCollection.AddRange Overload List


CatchCollection.AddRange Method (CatchCollection)

Adds the elements of another CatchCollection to the current CatchCollection.

public virtual int AddRange(
CatchCollection x
);

Parameters

x
The CatchCollection whose elements should be added to the end of the current CatchCollection.

Return Value

The new Count of the CatchCollection.

See Also

CatchCollection Class | DDW.CSharp.Dom Namespace | CatchCollection.AddRange Overload List


CatchCollection.Clear Method

Removes all elements from the CatchCollection.

public virtual void Clear();

Implements

IList.Clear

See Also

CatchCollection Class | DDW.CSharp.Dom Namespace


CatchCollection.Clone Method

Creates a shallow copy of the CatchCollection.

public virtual object Clone();

Implements

ICloneable.Clone

See Also

CatchCollection Class | DDW.CSharp.Dom Namespace


CatchCollection.Contains Method

Determines whether a given Catch is in the CatchCollection.

public virtual bool Contains(
Catch item
);

Parameters

item
The Catch to check for.

Return Value

true if item is found in the CatchCollection; otherwise, false.

See Also

CatchCollection Class | DDW.CSharp.Dom Namespace


CopyTo Method

Goblin - A Platform for 3D AR and VR Applications

CatchCollection.CopyTo Method

Copies the entire CatchCollection to a one-dimensional Catch array.

Overload List

Copies the entire CatchCollection to a one-dimensional Catch array.

public virtual void CopyTo(Catch[]);

Copies the entire CatchCollection to a one-dimensional Catch array, starting at the specified index of the target array.

public virtual void CopyTo(Catch[],int);

See Also

CatchCollection Class | DDW.CSharp.Dom Namespace


CatchCollection.CopyTo Method (Catch[])

Copies the entire CatchCollection to a one-dimensional Catch array.

public virtual void CopyTo(
Catch[] array
);

Parameters

array
The one-dimensional Catch array to copy to.

See Also

CatchCollection Class | DDW.CSharp.Dom Namespace | CatchCollection.CopyTo Overload List


CatchCollection.CopyTo Method (Catch[], Int32)

Copies the entire CatchCollection to a one-dimensional Catch array, starting at the specified index of the target array.

public virtual void CopyTo(
Catch[] array,
int start
);

Parameters

array
The one-dimensional Catch array to copy to.
start
The zero-based index in array at which copying begins.

See Also

CatchCollection Class | DDW.CSharp.Dom Namespace | CatchCollection.CopyTo Overload List


CatchCollection.GetEnumerator Method

Returns an enumerator that can iterate through the CatchCollection.

public virtual ICatchCollectionEnumerator GetEnumerator();

Return Value

An Enumerator for the entire CatchCollection.

See Also

CatchCollection Class | DDW.CSharp.Dom Namespace


CatchCollection.IndexOf Method

Returns the zero-based index of the first occurrence of a Catch in the CatchCollection.

public virtual int IndexOf(
Catch item
);

Parameters

item
The Catch to locate in the CatchCollection.

Return Value

The zero-based index of the first occurrence of item in the entire CatchCollection, if found; otherwise, -1.

See Also

CatchCollection Class | DDW.CSharp.Dom Namespace


CatchCollection.Insert Method

Inserts an element into the CatchCollection at the specified index.

public virtual void Insert(
int index,
Catch item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The Catch to insert.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

CatchCollection Class | DDW.CSharp.Dom Namespace


CatchCollection.ReadOnly Method

Creates a read-only wrapper for a CatchCollection instance.

public static CatchCollection ReadOnly(
CatchCollection list
);

Return Value

An CatchCollection wrapper that is read-only.

See Also

CatchCollection Class | DDW.CSharp.Dom Namespace


CatchCollection.Remove Method

Removes the first occurrence of a specific Catch from the CatchCollection.

public virtual void Remove(
Catch item
);

Parameters

item
The Catch to remove from the CatchCollection.

Exceptions

Exception Type | Condition
ArgumentException | The specified Catch was not found in the CatchCollection.

See Also

CatchCollection Class | DDW.CSharp.Dom Namespace


CatchCollection.RemoveAt Method

Removes the element at the specified index of the CatchCollection.

public virtual void RemoveAt(
int index
);

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

CatchCollection Class | DDW.CSharp.Dom Namespace


CatchCollection.Synchronized Method

Creates a synchronized (thread-safe) wrapper for a CatchCollection instance.

public static CatchCollection Synchronized(
CatchCollection list
);

Return Value

An CatchCollection wrapper that is synchronized (thread-safe).

See Also

CatchCollection Class | DDW.CSharp.Dom Namespace


CatchCollection.TrimToSize Method

Sets the capacity to the actual number of elements.

public virtual void TrimToSize();

See Also

CatchCollection Class | DDW.CSharp.Dom Namespace


CatchCollection.ICatchCollectionEnumerator Interface

Supports type-safe iteration over a CatchCollection.

For a list of all members of this type, see CatchCollection.ICatchCollectionEnumerator Members.

public interface CatchCollection.ICatchCollectionEnumerator

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

CatchCollection.ICatchCollectionEnumerator Members | DDW.CSharp.Dom Namespace


CatchCollection.ICatchCollectionEnumerator Members

CatchCollection.ICatchCollectionEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

CatchCollection.ICatchCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


CatchCollection.ICatchCollectionEnumerator Properties

The properties of the CatchCollection.ICatchCollectionEnumerator interface are listed below. For a complete list of CatchCollection.ICatchCollectionEnumerator interface members, see the CatchCollection.ICatchCollectionEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

CatchCollection.ICatchCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


Current Property

Goblin - A Platform for 3D AR and VR Applications

CatchCollection.ICatchCollectionEnumerator.Current Property

Gets the current element in the collection.

Catch Current {get;}

See Also

CatchCollection.ICatchCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


CatchCollection.ICatchCollectionEnumerator Methods

The methods of the CatchCollection.ICatchCollectionEnumerator interface are listed below. For a complete list of CatchCollection.ICatchCollectionEnumerator interface members, see the CatchCollection.ICatchCollectionEnumerator Members topic.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

CatchCollection.ICatchCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


CatchCollection.ICatchCollectionEnumerator.MoveNext Method

Advances the enumerator to the next element in the collection.

bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Exceptions

Exception Type | Condition
InvalidOperationException | The collection was modified after the enumerator was created.

See Also

CatchCollection.ICatchCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


CatchCollection.ICatchCollectionEnumerator.Reset Method

Sets the enumerator to its initial position, before the first element in the collection.

void Reset();

See Also

CatchCollection.ICatchCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


CatchCollection.Tag Enumeration

protected enum CatchCollection.Tag

Members

Member Name | Description
Default |

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

DDW.CSharp.Dom Namespace


CharLiteral Class

A character literal.

For a list of all members of this type, see CharLiteral Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Expression
DDW.CSharp.Dom.PrimitiveExpr
DDW.CSharp.Dom.CharLiteral

public class CharLiteral : PrimitiveExpr

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

CharLiteral Members | DDW.CSharp.Dom Namespace


CharLiteral Members

CharLiteral overview

Public Instance Constructors

CharLiteral Constructor Initializes a new instance of the CharLiteral class.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.
Value | Gets or sets the 'char' value of this char literal.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CharLiteral Class | DDW.CSharp.Dom Namespace


CharLiteral Constructor

Initializes a new instance of the CharLiteral class.

public CharLiteral();

See Also

CharLiteral Class | DDW.CSharp.Dom Namespace


CharLiteral Properties

The properties of the CharLiteral class are listed below. For a complete list of CharLiteral class members, see the CharLiteral Members topic.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.
Value | Gets or sets the 'char' value of this char literal.

See Also

CharLiteral Class | DDW.CSharp.Dom Namespace


Value Property

Goblin - A Platform for 3D AR and VR Applications

CharLiteral.Value Property

Gets or sets the 'char' value of this char literal.

public char Value {get; set;}

See Also

CharLiteral Class | DDW.CSharp.Dom Namespace


CheckedStmt Class

A checked statement - explicitly checks for overflow.

For a list of all members of this type, see CheckedStmt Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Statement
DDW.CSharp.Dom.CheckedStmt

public class CheckedStmt : Statement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

CheckedStmt Members | DDW.CSharp.Dom Namespace


CheckedStmt Members

CheckedStmt overview

Public Instance Constructors

CheckedStmt Constructor Initializes a new instance of the CheckedStmt class.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
Statements | Gets the collection of statements in the checked statement.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CheckedStmt Class | DDW.CSharp.Dom Namespace


CheckedStmt Constructor

Initializes a new instance of the CheckedStmt class.

public CheckedStmt();

See Also

CheckedStmt Class | DDW.CSharp.Dom Namespace


CheckedStmt Properties

The properties of the CheckedStmt class are listed below. For a complete list of CheckedStmt class members, see the CheckedStmt Members topic.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
Statements | Gets the collection of statements in the checked statement.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

CheckedStmt Class | DDW.CSharp.Dom Namespace


Statements Property

Goblin - A Platform for 3D AR and VR Applications

CheckedStmt.Statements Property

Gets the collection of statements in the checked statement.

public StatementCollection Statements {get;}

See Also

CheckedStmt Class | DDW.CSharp.Dom Namespace


ClassDecl Class

A class declartation.

For a list of all members of this type, see ClassDecl Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.MemberDecl
DDW.CSharp.Dom.TypeDecl
DDW.CSharp.Dom.ClassDecl

public class ClassDecl : TypeDecl, IScope

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

ClassDecl Members | DDW.CSharp.Dom Namespace


ClassDecl Members

ClassDecl overview

Public Instance Constructors

ClassDecl Constructor Initializes a new instance of the ClassDecl class.

Public Instance Properties

Attributes (inherited from MemberDecl) | Gets or sets the modifier flags for this member (public, private etc).
BaseTypes (inherited from TypeDecl) | Gets or sets the base types that are inherited by this type.
Comments (inherited from MemberDecl) | Gets the collection of comments for this member.
Constructors |
CustomAttributes (inherited from MemberDecl) | Gets the collection of Custom Attributes used for this member (custom attributes are the ones declared between brackets, like [Flags]).
Definition (inherited from TypeDecl) | Gets the (scoped) definition.
LinePragma (inherited from CSharpGraph) |
MemberKind (inherited from TypeDecl) |
Members (inherited from TypeDecl) | Gets a collection of type members in the current type (methods, fields etc.).
Name (inherited from TypeDecl) |
Scope |
TypeAttributes (inherited from TypeDecl) | Gets or sets the modifiers for the type (public, sealed etc). These values can be or'ed with each other. This was derived from the CodeDom, it may be changed for something more suitable.
TypeKind |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

DistanceToType |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
VerifyModifiers (inherited from MemberDecl) |

See Also

ClassDecl Class | DDW.CSharp.Dom Namespace


ClassDecl Constructor

Initializes a new instance of the ClassDecl class.

public ClassDecl();

See Also

ClassDecl Class | DDW.CSharp.Dom Namespace


ClassDecl Properties

The properties of the ClassDecl class are listed below. For a complete list of ClassDecl class members, see the ClassDecl Members topic.

Public Instance Properties

Attributes (inherited from MemberDecl) | Gets or sets the modifier flags for this member (public, private etc).
BaseTypes (inherited from TypeDecl) | Gets or sets the base types that are inherited by this type.
Comments (inherited from MemberDecl) | Gets the collection of comments for this member.
Constructors |
CustomAttributes (inherited from MemberDecl) | Gets the collection of Custom Attributes used for this member (custom attributes are the ones declared between brackets, like [Flags]).
Definition (inherited from TypeDecl) | Gets the (scoped) definition.
LinePragma (inherited from CSharpGraph) |
MemberKind (inherited from TypeDecl) |
Members (inherited from TypeDecl) | Gets a collection of type members in the current type (methods, fields etc.).
Name (inherited from TypeDecl) |
Scope |
TypeAttributes (inherited from TypeDecl) | Gets or sets the modifiers for the type (public, sealed etc). These values can be or'ed with each other. This was derived from the CodeDom, it may be changed for something more suitable.
TypeKind |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

ClassDecl Class | DDW.CSharp.Dom Namespace


Constructors Property

Goblin - A Platform for 3D AR and VR Applications

ClassDecl.Constructors Property

public DDW.CSharp.SymbolTable.OverloadableDefinition Constructors {get;}

See Also

ClassDecl Class | DDW.CSharp.Dom Namespace


Scope Property

Goblin - A Platform for 3D AR and VR Applications

ClassDecl.Scope Property

public DDW.CSharp.SymbolTable.Scope Scope {get; set;}

Implements

IScope.Scope

See Also

ClassDecl Class | DDW.CSharp.Dom Namespace


TypeKind Property

Goblin - A Platform for 3D AR and VR Applications

ClassDecl.TypeKind Property

public override TypeKind TypeKind {get;}

See Also

ClassDecl Class | DDW.CSharp.Dom Namespace


ClassDecl Methods

The methods of the ClassDecl class are listed below. For a complete list of ClassDecl class members, see the ClassDecl Members topic.

Public Instance Methods

DistanceToType |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
VerifyModifiers (inherited from MemberDecl) |

See Also

ClassDecl Class | DDW.CSharp.Dom Namespace


ClassDecl.DistanceToType Method

public override int DistanceToType(
IDefinition baseType,
int distance
);

See Also

ClassDecl Class | DDW.CSharp.Dom Namespace


CodeCollectionAttribute Class

An attribute that specifies that a CSharp Graph property is a code element (as opposed to a helper property) as well as a collection.

For a list of all members of this type, see CodeCollectionAttribute Members.

System.Object
System.Attribute
DDW.CSharp.Dom.CodeElementAttribute
DDW.CSharp.Dom.CodeCollectionAttribute

public class CodeCollectionAttribute : CodeElementAttribute

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

CodeCollectionAttribute Members | DDW.CSharp.Dom Namespace


CodeCollectionAttribute Members

CodeCollectionAttribute overview

Public Instance Constructors

CodeCollectionAttribute Constructor Initializes a new instance of the CodeCollectionAttribute class.

Public Instance Properties

TypeId (inherited from Attribute) When implemented in a derived class, gets a unique identifier for this Attribute.

Public Instance Methods

Equals (inherited from Attribute) |
GetHashCode (inherited from Attribute) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, returns an indication whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value indicating whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeCollectionAttribute Class | DDW.CSharp.Dom Namespace


CodeCollectionAttribute Constructor

Initializes a new instance of the CodeCollectionAttribute class.

public CodeCollectionAttribute();

See Also

CodeCollectionAttribute Class | DDW.CSharp.Dom Namespace


CodeElementAttribute Class

An attribute that specifies that a CSharp Graph property is a code element as opposed to a helper property.

For a list of all members of this type, see CodeElementAttribute Members.

System.Object
System.Attribute
DDW.CSharp.Dom.CodeElementAttribute
DDW.CSharp.Dom.CodeCollectionAttribute

public class CodeElementAttribute : Attribute

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

CodeElementAttribute Members | DDW.CSharp.Dom Namespace


CodeElementAttribute Members

CodeElementAttribute overview

Public Instance Constructors

CodeElementAttribute Constructor Initializes a new instance of the CodeElementAttribute class.

Public Instance Properties

TypeId (inherited from Attribute) When implemented in a derived class, gets a unique identifier for this Attribute.

Public Instance Methods

Equals (inherited from Attribute) |
GetHashCode (inherited from Attribute) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsDefaultAttribute (inherited from Attribute) | When overridden in a derived class, returns an indication whether the value of this instance is the default value for the derived class.
Match (inherited from Attribute) | When overridden in a derived class, returns a value indicating whether this instance equals a specified object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CodeElementAttribute Class | DDW.CSharp.Dom Namespace


CodeElementAttribute Constructor

Initializes a new instance of the CodeElementAttribute class.

public CodeElementAttribute();

See Also

CodeElementAttribute Class | DDW.CSharp.Dom Namespace


Comment Class

A comment that may be mixed in with other elements.

For a list of all members of this type, see Comment Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Comment

public class Comment : CSharpGraph

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

Comment Members | DDW.CSharp.Dom Namespace


Comment Members

Comment overview

Public Instance Constructors

Comment Constructor Initializes a new instance of the Comment class.

Public Instance Properties

CommentText | Gets or set the text of the comment.
DocComment | Set to true if this is a Documentation comment.
LinePragma (inherited from CSharpGraph) |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Comment Class | DDW.CSharp.Dom Namespace


Comment Constructor

Initializes a new instance of the Comment class.

public Comment();

See Also

Comment Class | DDW.CSharp.Dom Namespace


Comment Properties

The properties of the Comment class are listed below. For a complete list of Comment class members, see the Comment Members topic.

Public Instance Properties

CommentText | Gets or set the text of the comment.
DocComment | Set to true if this is a Documentation comment.
LinePragma (inherited from CSharpGraph) |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

Comment Class | DDW.CSharp.Dom Namespace


CommentText Property

Goblin - A Platform for 3D AR and VR Applications

Comment.CommentText Property

Gets or set the text of the comment.

public string CommentText {get; set;}

See Also

Comment Class | DDW.CSharp.Dom Namespace


DocComment Property

Goblin - A Platform for 3D AR and VR Applications

Comment.DocComment Property

Set to true if this is a Documentation comment.

public bool DocComment {get; set;}

See Also

Comment Class | DDW.CSharp.Dom Namespace


CommentStmt Class

A normal comment.

For a list of all members of this type, see CommentStmt Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Statement
DDW.CSharp.Dom.CommentStmt

public class CommentStmt : Statement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

CommentStmt Members | DDW.CSharp.Dom Namespace


CommentStmt Members

CommentStmt overview

Public Instance Constructors

CommentStmt Constructor Initializes a new instance of the CommentStmt class.

Public Instance Properties

Comment | Gets or sets the comment string.
LinePragma (inherited from CSharpGraph) |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CommentStmt Class | DDW.CSharp.Dom Namespace


CommentStmt Constructor

Initializes a new instance of the CommentStmt class.

public CommentStmt();

See Also

CommentStmt Class | DDW.CSharp.Dom Namespace


CommentStmt Properties

The properties of the CommentStmt class are listed below. For a complete list of CommentStmt class members, see the CommentStmt Members topic.

Public Instance Properties

Comment | Gets or sets the comment string.
LinePragma (inherited from CSharpGraph) |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

CommentStmt Class | DDW.CSharp.Dom Namespace


Comment Property

Goblin - A Platform for 3D AR and VR Applications

CommentStmt.Comment Property

Gets or sets the comment string.

public Comment Comment {get; set;}

See Also

CommentStmt Class | DDW.CSharp.Dom Namespace


CommentStmtCollection Class

A strongly-typed collection of CommentStmt objects.

For a list of all members of this type, see CommentStmtCollection Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.CommentStmtCollection

public class CommentStmtCollection : CSharpGraph, IList, ICollection, IEnumerable, ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

CommentStmtCollection Members | DDW.CSharp.Dom Namespace


CommentStmtCollection Members

CommentStmtCollection overview

Public Static Methods

ReadOnly | Creates a read-only wrapper for a CommentStmtCollection instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a CommentStmtCollection instance.

Public Instance Constructors

CommentStmtCollection Overloaded. Initializes a new instance of the CommentStmtCollection class.

Public Instance Properties

Capacity | Gets or sets the number of elements the CommentStmtCollection can contain.
Count | Gets the number of elements actually contained in the CommentStmtCollection.
GraphType |
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the CommentStmt at the specified index.
LinePragma (inherited from CSharpGraph) |
SyncRoot | Gets an object that can be used to synchronize access to the collection.
Text |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Add | Adds a CommentStmt to the end of the CommentStmtCollection.
AddRange | Overloaded. Adds the elements of a CommentStmt array to the current CommentStmtCollection.
Clear | Removes all elements from the CommentStmtCollection.
Clone | Creates a shallow copy of the CommentStmtCollection.
Contains | Determines whether a given CommentStmt is in the CommentStmtCollection.
CopyTo | Overloaded. Copies the entire CommentStmtCollection to a one-dimensional CommentStmt array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the CommentStmtCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the zero-based index of the first occurrence of a CommentStmt in the CommentStmtCollection.
Insert | Inserts an element into the CommentStmtCollection at the specified index.
Remove | Removes the first occurrence of a specific CommentStmt from the CommentStmtCollection.
RemoveAt | Removes the element at the specified index of the CommentStmtCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Constructors

CommentStmtCollection Overloaded. Initializes a new instance of the CommentStmtCollection class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CommentStmtCollection Class | DDW.CSharp.Dom Namespace


CommentStmtCollection Constructor

Initializes a new instance of the CommentStmtCollection class that is empty and has the default initial capacity.

Overload List

Initializes a new instance of the CommentStmtCollection class that is empty and has the default initial capacity.

public CommentStmtCollection();

Initializes a new instance of the CommentStmtCollection class that contains elements copied from the specified CommentStmt array.

public CommentStmtCollection(CommentStmt[]);

Initializes a new instance of the CommentStmtCollection class that contains elements copied from the specified CommentStmtCollection.

public CommentStmtCollection(CommentStmtCollection);

protected CommentStmtCollection(Tag);

Initializes a new instance of the CommentStmtCollection class that has the specified initial capacity.

public CommentStmtCollection(int);

See Also

CommentStmtCollection Class | DDW.CSharp.Dom Namespace


CommentStmtCollection Constructor ()

Initializes a new instance of the CommentStmtCollection class that is empty and has the default initial capacity.

public CommentStmtCollection();

See Also

CommentStmtCollection Class | DDW.CSharp.Dom Namespace | CommentStmtCollection Constructor Overload List


CommentStmtCollection Constructor (Int32)

Initializes a new instance of the CommentStmtCollection class that has the specified initial capacity.

public CommentStmtCollection(
int capacity
);

Parameters

capacity
The number of elements that the new CommentStmtCollection is initially capable of storing.

See Also

CommentStmtCollection Class | DDW.CSharp.Dom Namespace | CommentStmtCollection Constructor Overload List


CommentStmtCollection Constructor (CommentStmtCollection)

Initializes a new instance of the CommentStmtCollection class that contains elements copied from the specified CommentStmtCollection.

public CommentStmtCollection(
CommentStmtCollection c
);

Parameters

c
The CommentStmtCollection whose elements are copied to the new collection.

See Also

CommentStmtCollection Class | DDW.CSharp.Dom Namespace | CommentStmtCollection Constructor Overload List


CommentStmtCollection Constructor (CommentStmt[])

Initializes a new instance of the CommentStmtCollection class that contains elements copied from the specified CommentStmt array.

public CommentStmtCollection(
CommentStmt[] a
);

Parameters

a
The CommentStmt array whose elements are copied to the new list.

See Also

CommentStmtCollection Class | DDW.CSharp.Dom Namespace | CommentStmtCollection Constructor Overload List


CommentStmtCollection Constructor (Tag)

protected CommentStmtCollection(
Tag t
);

See Also

CommentStmtCollection Class | DDW.CSharp.Dom Namespace | CommentStmtCollection Constructor Overload List


CommentStmtCollection Properties

The properties of the CommentStmtCollection class are listed below. For a complete list of CommentStmtCollection class members, see the CommentStmtCollection Members topic.

Public Instance Properties

Capacity | Gets or sets the number of elements the CommentStmtCollection can contain.
Count | Gets the number of elements actually contained in the CommentStmtCollection.
GraphType |
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the CommentStmt at the specified index.
LinePragma (inherited from CSharpGraph) |
SyncRoot | Gets an object that can be used to synchronize access to the collection.
Text |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

CommentStmtCollection Class | DDW.CSharp.Dom Namespace


Capacity Property

Goblin - A Platform for 3D AR and VR Applications

CommentStmtCollection.Capacity Property

Gets or sets the number of elements the CommentStmtCollection can contain.

public virtual int Capacity {get; set;}

See Also

CommentStmtCollection Class | DDW.CSharp.Dom Namespace


Count Property

Goblin - A Platform for 3D AR and VR Applications

CommentStmtCollection.Count Property

Gets the number of elements actually contained in the CommentStmtCollection.

public virtual int Count {get;}

Implements

ICollection.Count

See Also

CommentStmtCollection Class | DDW.CSharp.Dom Namespace


GraphType Property

Goblin - A Platform for 3D AR and VR Applications

CommentStmtCollection.GraphType Property

public override GraphTypes GraphType {get;}

Implements

IGraph.GraphType

See Also

CommentStmtCollection Class | DDW.CSharp.Dom Namespace


IsFixedSize Property

Goblin - A Platform for 3D AR and VR Applications

CommentStmtCollection.IsFixedSize Property

Gets a value indicating whether the collection has a fixed size.

public virtual bool IsFixedSize {get;}

Property Value

true if the collection has a fixed size; otherwise, false. The default is false

Implements

IList.IsFixedSize

See Also

CommentStmtCollection Class | DDW.CSharp.Dom Namespace


IsReadOnly Property

Goblin - A Platform for 3D AR and VR Applications

CommentStmtCollection.IsReadOnly Property

gets a value indicating whether the IList is read-only.

public virtual bool IsReadOnly {get;}

Property Value

true if the collection is read-only; otherwise, false. The default is false

Implements

IList.IsReadOnly

See Also

CommentStmtCollection Class | DDW.CSharp.Dom Namespace


IsSynchronized Property

Goblin - A Platform for 3D AR and VR Applications

CommentStmtCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread-safe).

public virtual bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

CommentStmtCollection Class | DDW.CSharp.Dom Namespace


Item Property

Goblin - A Platform for 3D AR and VR Applications

CommentStmtCollection.Item Property

Gets or sets the CommentStmt at the specified index.

public virtual CommentStmt this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

CommentStmtCollection Class | DDW.CSharp.Dom Namespace


SyncRoot Property

Goblin - A Platform for 3D AR and VR Applications

CommentStmtCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

public virtual object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

CommentStmtCollection Class | DDW.CSharp.Dom Namespace


Text Property

Goblin - A Platform for 3D AR and VR Applications

CommentStmtCollection.Text Property

public override string Text {get;}

Implements

IGraph.Text

See Also

CommentStmtCollection Class | DDW.CSharp.Dom Namespace


CommentStmtCollection Methods

The methods of the CommentStmtCollection class are listed below. For a complete list of CommentStmtCollection class members, see the CommentStmtCollection Members topic.

Public Static Methods

ReadOnly | Creates a read-only wrapper for a CommentStmtCollection instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a CommentStmtCollection instance.

Public Instance Methods

Add | Adds a CommentStmt to the end of the CommentStmtCollection.
AddRange | Overloaded. Adds the elements of a CommentStmt array to the current CommentStmtCollection.
Clear | Removes all elements from the CommentStmtCollection.
Clone | Creates a shallow copy of the CommentStmtCollection.
Contains | Determines whether a given CommentStmt is in the CommentStmtCollection.
CopyTo | Overloaded. Copies the entire CommentStmtCollection to a one-dimensional CommentStmt array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the CommentStmtCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the zero-based index of the first occurrence of a CommentStmt in the CommentStmtCollection.
Insert | Inserts an element into the CommentStmtCollection at the specified index.
Remove | Removes the first occurrence of a specific CommentStmt from the CommentStmtCollection.
RemoveAt | Removes the element at the specified index of the CommentStmtCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CommentStmtCollection Class | DDW.CSharp.Dom Namespace


CommentStmtCollection.Add Method

Adds a CommentStmt to the end of the CommentStmtCollection.

public virtual int Add(
CommentStmt item
);

Parameters

item
The CommentStmt to be added to the end of the CommentStmtCollection.

Return Value

The index at which the value has been added.

See Also

CommentStmtCollection Class | DDW.CSharp.Dom Namespace


AddRange Method

Goblin - A Platform for 3D AR and VR Applications

CommentStmtCollection.AddRange Method

Adds the elements of a CommentStmt array to the current CommentStmtCollection.

Overload List

Adds the elements of a CommentStmt array to the current CommentStmtCollection.

public virtual int AddRange(CommentStmt[]);

Adds the elements of another CommentStmtCollection to the current CommentStmtCollection.

public virtual int AddRange(CommentStmtCollection);

See Also

CommentStmtCollection Class | DDW.CSharp.Dom Namespace


CommentStmtCollection.AddRange Method (CommentStmt[])

Adds the elements of a CommentStmt array to the current CommentStmtCollection.

public virtual int AddRange(
CommentStmt[] x
);

Parameters

x
The CommentStmt array whose elements should be added to the end of the CommentStmtCollection.

Return Value

The new Count of the CommentStmtCollection.

See Also

CommentStmtCollection Class | DDW.CSharp.Dom Namespace | CommentStmtCollection.AddRange Overload List


CommentStmtCollection.AddRange Method (CommentStmtCollection)

Adds the elements of another CommentStmtCollection to the current CommentStmtCollection.

public virtual int AddRange(
CommentStmtCollection x
);

Parameters

x
The CommentStmtCollection whose elements should be added to the end of the current CommentStmtCollection.

Return Value

The new Count of the CommentStmtCollection.

See Also

CommentStmtCollection Class | DDW.CSharp.Dom Namespace | CommentStmtCollection.AddRange Overload List


CommentStmtCollection.Clear Method

Removes all elements from the CommentStmtCollection.

public virtual void Clear();

Implements

IList.Clear

See Also

CommentStmtCollection Class | DDW.CSharp.Dom Namespace


CommentStmtCollection.Clone Method

Creates a shallow copy of the CommentStmtCollection.

public virtual object Clone();

Implements

ICloneable.Clone

See Also

CommentStmtCollection Class | DDW.CSharp.Dom Namespace


CommentStmtCollection.Contains Method

Determines whether a given CommentStmt is in the CommentStmtCollection.

public virtual bool Contains(
CommentStmt item
);

Parameters

item
The CommentStmt to check for.

Return Value

true if item is found in the CommentStmtCollection; otherwise, false.

See Also

CommentStmtCollection Class | DDW.CSharp.Dom Namespace


CopyTo Method

Goblin - A Platform for 3D AR and VR Applications

CommentStmtCollection.CopyTo Method

Copies the entire CommentStmtCollection to a one-dimensional CommentStmt array.

Overload List

Copies the entire CommentStmtCollection to a one-dimensional CommentStmt array.

public virtual void CopyTo(CommentStmt[]);

Copies the entire CommentStmtCollection to a one-dimensional CommentStmt array, starting at the specified index of the target array.

public virtual void CopyTo(CommentStmt[],int);

See Also

CommentStmtCollection Class | DDW.CSharp.Dom Namespace


CommentStmtCollection.CopyTo Method (CommentStmt[])

Copies the entire CommentStmtCollection to a one-dimensional CommentStmt array.

public virtual void CopyTo(
CommentStmt[] array
);

Parameters

array
The one-dimensional CommentStmt array to copy to.

See Also

CommentStmtCollection Class | DDW.CSharp.Dom Namespace | CommentStmtCollection.CopyTo Overload List


CommentStmtCollection.CopyTo Method (CommentStmt[], Int32)

Copies the entire CommentStmtCollection to a one-dimensional CommentStmt array, starting at the specified index of the target array.

public virtual void CopyTo(
CommentStmt[] array,
int start
);

Parameters

array
The one-dimensional CommentStmt array to copy to.
start
The zero-based index in array at which copying begins.

See Also

CommentStmtCollection Class | DDW.CSharp.Dom Namespace | CommentStmtCollection.CopyTo Overload List


CommentStmtCollection.GetEnumerator Method

Returns an enumerator that can iterate through the CommentStmtCollection.

public virtual ICommentStmtCollectionEnumerator GetEnumerator();

Return Value

An Enumerator for the entire CommentStmtCollection.

See Also

CommentStmtCollection Class | DDW.CSharp.Dom Namespace


CommentStmtCollection.IndexOf Method

Returns the zero-based index of the first occurrence of a CommentStmt in the CommentStmtCollection.

public virtual int IndexOf(
CommentStmt item
);

Parameters

item
The CommentStmt to locate in the CommentStmtCollection.

Return Value

The zero-based index of the first occurrence of item in the entire CommentStmtCollection, if found; otherwise, -1.

See Also

CommentStmtCollection Class | DDW.CSharp.Dom Namespace


CommentStmtCollection.Insert Method

Inserts an element into the CommentStmtCollection at the specified index.

public virtual void Insert(
int index,
CommentStmt item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The CommentStmt to insert.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

CommentStmtCollection Class | DDW.CSharp.Dom Namespace


CommentStmtCollection.ReadOnly Method

Creates a read-only wrapper for a CommentStmtCollection instance.

public static CommentStmtCollection ReadOnly(
CommentStmtCollection list
);

Return Value

An CommentStmtCollection wrapper that is read-only.

See Also

CommentStmtCollection Class | DDW.CSharp.Dom Namespace


CommentStmtCollection.Remove Method

Removes the first occurrence of a specific CommentStmt from the CommentStmtCollection.

public virtual void Remove(
CommentStmt item
);

Parameters

item
The CommentStmt to remove from the CommentStmtCollection.

Exceptions

Exception Type | Condition
ArgumentException | The specified CommentStmt was not found in the CommentStmtCollection.

See Also

CommentStmtCollection Class | DDW.CSharp.Dom Namespace


CommentStmtCollection.RemoveAt Method

Removes the element at the specified index of the CommentStmtCollection.

public virtual void RemoveAt(
int index
);

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

CommentStmtCollection Class | DDW.CSharp.Dom Namespace


CommentStmtCollection.Synchronized Method

Creates a synchronized (thread-safe) wrapper for a CommentStmtCollection instance.

public static CommentStmtCollection Synchronized(
CommentStmtCollection list
);

Return Value

An CommentStmtCollection wrapper that is synchronized (thread-safe).

See Also

CommentStmtCollection Class | DDW.CSharp.Dom Namespace


CommentStmtCollection.TrimToSize Method

Sets the capacity to the actual number of elements.

public virtual void TrimToSize();

See Also

CommentStmtCollection Class | DDW.CSharp.Dom Namespace


CommentStmtCollection.ICommentStmtCollectionEnumerator Interface

Supports type-safe iteration over a CommentStmtCollection.

For a list of all members of this type, see CommentStmtCollection.ICommentStmtCollectionEnumerator Members.

public interface CommentStmtCollection.ICommentStmtCollectionEnumerator

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

CommentStmtCollection.ICommentStmtCollectionEnumerator Members | DDW.CSharp.Dom Namespace


CommentStmtCollection.ICommentStmtCollectionEnumerator Members

CommentStmtCollection.ICommentStmtCollectionEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

CommentStmtCollection.ICommentStmtCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


CommentStmtCollection.ICommentStmtCollectionEnumerator Properties

The properties of the CommentStmtCollection.ICommentStmtCollectionEnumerator interface are listed below. For a complete list of CommentStmtCollection.ICommentStmtCollectionEnumerator interface members, see the CommentStmtCollection.ICommentStmtCollectionEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

CommentStmtCollection.ICommentStmtCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


Current Property

Goblin - A Platform for 3D AR and VR Applications

CommentStmtCollection.ICommentStmtCollectionEnumerator.Current Property

Gets the current element in the collection.

CommentStmt Current {get;}

See Also

CommentStmtCollection.ICommentStmtCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


CommentStmtCollection.ICommentStmtCollectionEnumerator Methods

The methods of the CommentStmtCollection.ICommentStmtCollectionEnumerator interface are listed below. For a complete list of CommentStmtCollection.ICommentStmtCollectionEnumerator interface members, see the CommentStmtCollection.ICommentStmtCollectionEnumerator Members topic.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

CommentStmtCollection.ICommentStmtCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


CommentStmtCollection.ICommentStmtCollectionEnumerator.MoveNext Method

Advances the enumerator to the next element in the collection.

bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Exceptions

Exception Type | Condition
InvalidOperationException | The collection was modified after the enumerator was created.

See Also

CommentStmtCollection.ICommentStmtCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


CommentStmtCollection.ICommentStmtCollectionEnumerator.Reset Method

Sets the enumerator to its initial position, before the first element in the collection.

void Reset();

See Also

CommentStmtCollection.ICommentStmtCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


CommentStmtCollection.Tag Enumeration

protected enum CommentStmtCollection.Tag

Members

Member Name | Description
Default |

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

DDW.CSharp.Dom Namespace


CompileUnit Class

A C# file level unit of code. This must be a complete C# file, snippets are not valid.

For a list of all members of this type, see CompileUnit Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.CompileUnit

public class CompileUnit : CSharpGraph, IScope

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

CompileUnit Members | DDW.CSharp.Dom Namespace


CompileUnit Members

CompileUnit overview

Public Instance Constructors

CompileUnit Constructor Initializes a new instance of the CompileUnit class.

Public Instance Properties

AssemblyCustomAttributes | Gets the collection of assembly level custom attributes - eg. [assembly:CLSCompliant(true)] for this Compile unit.
FileName | Gets or sets the name of the file being parsed. This is not a Code Element.
Imports | Gets the collection of imports ('using' declarations) for this Compile unit.
LinePragma (inherited from CSharpGraph) |
Namespaces | Gets the collection of Namespace Declarations for this Compile unit.
ReferencedAssemblies | Gets the collection of referenced assemblies - this does not come from the source code, but rather would be set when invoking the parser.
Scope |
ScopeTable |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CompileUnit Class | DDW.CSharp.Dom Namespace


CompileUnit Constructor

Initializes a new instance of the CompileUnit class.

public CompileUnit();

See Also

CompileUnit Class | DDW.CSharp.Dom Namespace


CompileUnit Properties

The properties of the CompileUnit class are listed below. For a complete list of CompileUnit class members, see the CompileUnit Members topic.

Public Instance Properties

AssemblyCustomAttributes | Gets the collection of assembly level custom attributes - eg. [assembly:CLSCompliant(true)] for this Compile unit.
FileName | Gets or sets the name of the file being parsed. This is not a Code Element.
Imports | Gets the collection of imports ('using' declarations) for this Compile unit.
LinePragma (inherited from CSharpGraph) |
Namespaces | Gets the collection of Namespace Declarations for this Compile unit.
ReferencedAssemblies | Gets the collection of referenced assemblies - this does not come from the source code, but rather would be set when invoking the parser.
Scope |
ScopeTable |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

CompileUnit Class | DDW.CSharp.Dom Namespace


AssemblyCustomAttributes Property

Goblin - A Platform for 3D AR and VR Applications

CompileUnit.AssemblyCustomAttributes Property

Gets the collection of assembly level custom attributes - eg. [assembly:CLSCompliant(true)] for this Compile unit.

public CustomAttributeCollection AssemblyCustomAttributes {get;}

See Also

CompileUnit Class | DDW.CSharp.Dom Namespace


FileName Property

Goblin - A Platform for 3D AR and VR Applications

CompileUnit.FileName Property

Gets or sets the name of the file being parsed. This is not a Code Element.

public string FileName {get; set;}

See Also

CompileUnit Class | DDW.CSharp.Dom Namespace


Imports Property

Goblin - A Platform for 3D AR and VR Applications

CompileUnit.Imports Property

Gets the collection of imports ('using' declarations) for this Compile unit.

public ImportCollection Imports {get;}

See Also

CompileUnit Class | DDW.CSharp.Dom Namespace


Namespaces Property

Goblin - A Platform for 3D AR and VR Applications

CompileUnit.Namespaces Property

Gets the collection of Namespace Declarations for this Compile unit.

public NamespaceDeclCollection Namespaces {get;}

See Also

CompileUnit Class | DDW.CSharp.Dom Namespace


ReferencedAssemblies Property

Goblin - A Platform for 3D AR and VR Applications

CompileUnit.ReferencedAssemblies Property

Gets the collection of referenced assemblies - this does not come from the source code, but rather would be set when invoking the parser.

public AssemblyReferenceCollection ReferencedAssemblies {get;}

See Also

CompileUnit Class | DDW.CSharp.Dom Namespace


Scope Property

Goblin - A Platform for 3D AR and VR Applications

CompileUnit.Scope Property

public DDW.CSharp.SymbolTable.Scope Scope {get; set;}

Implements

IScope.Scope

See Also

CompileUnit Class | DDW.CSharp.Dom Namespace


ScopeTable Property

Goblin - A Platform for 3D AR and VR Applications

CompileUnit.ScopeTable Property

public DDW.CSharp.SymbolTable.ScopeCollection ScopeTable {get;}

See Also

CompileUnit Class | DDW.CSharp.Dom Namespace


CompileUnitCollection Class

A strongly-typed collection of CompileUnit objects.

For a list of all members of this type, see CompileUnitCollection Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.CompileUnitCollection

public class CompileUnitCollection : CSharpGraph, IList, ICollection, IEnumerable, ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

CompileUnitCollection Members | DDW.CSharp.Dom Namespace


CompileUnitCollection Members

CompileUnitCollection overview

Public Static Methods

ReadOnly | Creates a read-only wrapper for a CompileUnitCollection instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a CompileUnitCollection instance.

Public Instance Constructors

CompileUnitCollection Overloaded. Initializes a new instance of the CompileUnitCollection class.

Public Instance Properties

Capacity | Gets or sets the number of elements the CompileUnitCollection can contain.
Count | Gets the number of elements actually contained in the CompileUnitCollection.
GraphType |
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the CompileUnit at the specified index.
LinePragma (inherited from CSharpGraph) |
SyncRoot | Gets an object that can be used to synchronize access to the collection.
Text |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Add | Adds a CompileUnit to the end of the CompileUnitCollection.
AddRange | Overloaded. Adds the elements of a CompileUnit array to the current CompileUnitCollection.
Clear | Removes all elements from the CompileUnitCollection.
Clone | Creates a shallow copy of the CompileUnitCollection.
Contains | Determines whether a given CompileUnit is in the CompileUnitCollection.
CopyTo | Overloaded. Copies the entire CompileUnitCollection to a one-dimensional CompileUnit array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the CompileUnitCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the zero-based index of the first occurrence of a CompileUnit in the CompileUnitCollection.
Insert | Inserts an element into the CompileUnitCollection at the specified index.
Remove | Removes the first occurrence of a specific CompileUnit from the CompileUnitCollection.
RemoveAt | Removes the element at the specified index of the CompileUnitCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Constructors

CompileUnitCollection Overloaded. Initializes a new instance of the CompileUnitCollection class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CompileUnitCollection Class | DDW.CSharp.Dom Namespace


CompileUnitCollection Constructor

Initializes a new instance of the CompileUnitCollection class that is empty and has the default initial capacity.

Overload List

Initializes a new instance of the CompileUnitCollection class that is empty and has the default initial capacity.

public CompileUnitCollection();

Initializes a new instance of the CompileUnitCollection class that contains elements copied from the specified CompileUnit array.

public CompileUnitCollection(CompileUnit[]);

Initializes a new instance of the CompileUnitCollection class that contains elements copied from the specified CompileUnitCollection.

public CompileUnitCollection(CompileUnitCollection);

protected CompileUnitCollection(Tag);

Initializes a new instance of the CompileUnitCollection class that has the specified initial capacity.

public CompileUnitCollection(int);

See Also

CompileUnitCollection Class | DDW.CSharp.Dom Namespace


CompileUnitCollection Constructor ()

Initializes a new instance of the CompileUnitCollection class that is empty and has the default initial capacity.

public CompileUnitCollection();

See Also

CompileUnitCollection Class | DDW.CSharp.Dom Namespace | CompileUnitCollection Constructor Overload List


CompileUnitCollection Constructor (Int32)

Initializes a new instance of the CompileUnitCollection class that has the specified initial capacity.

public CompileUnitCollection(
int capacity
);

Parameters

capacity
The number of elements that the new CompileUnitCollection is initially capable of storing.

See Also

CompileUnitCollection Class | DDW.CSharp.Dom Namespace | CompileUnitCollection Constructor Overload List


CompileUnitCollection Constructor (CompileUnitCollection)

Initializes a new instance of the CompileUnitCollection class that contains elements copied from the specified CompileUnitCollection.

public CompileUnitCollection(
CompileUnitCollection c
);

Parameters

c
The CompileUnitCollection whose elements are copied to the new collection.

See Also

CompileUnitCollection Class | DDW.CSharp.Dom Namespace | CompileUnitCollection Constructor Overload List


CompileUnitCollection Constructor (CompileUnit[])

Initializes a new instance of the CompileUnitCollection class that contains elements copied from the specified CompileUnit array.

public CompileUnitCollection(
CompileUnit[] a
);

Parameters

a
The CompileUnit array whose elements are copied to the new list.

See Also

CompileUnitCollection Class | DDW.CSharp.Dom Namespace | CompileUnitCollection Constructor Overload List


CompileUnitCollection Constructor (Tag)

protected CompileUnitCollection(
Tag t
);

See Also

CompileUnitCollection Class | DDW.CSharp.Dom Namespace | CompileUnitCollection Constructor Overload List


CompileUnitCollection Properties

The properties of the CompileUnitCollection class are listed below. For a complete list of CompileUnitCollection class members, see the CompileUnitCollection Members topic.

Public Instance Properties

Capacity | Gets or sets the number of elements the CompileUnitCollection can contain.
Count | Gets the number of elements actually contained in the CompileUnitCollection.
GraphType |
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the CompileUnit at the specified index.
LinePragma (inherited from CSharpGraph) |
SyncRoot | Gets an object that can be used to synchronize access to the collection.
Text |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

CompileUnitCollection Class | DDW.CSharp.Dom Namespace


Capacity Property

Goblin - A Platform for 3D AR and VR Applications

CompileUnitCollection.Capacity Property

Gets or sets the number of elements the CompileUnitCollection can contain.

public virtual int Capacity {get; set;}

See Also

CompileUnitCollection Class | DDW.CSharp.Dom Namespace


Count Property

Goblin - A Platform for 3D AR and VR Applications

CompileUnitCollection.Count Property

Gets the number of elements actually contained in the CompileUnitCollection.

public virtual int Count {get;}

Implements

ICollection.Count

See Also

CompileUnitCollection Class | DDW.CSharp.Dom Namespace


GraphType Property

Goblin - A Platform for 3D AR and VR Applications

CompileUnitCollection.GraphType Property

public override GraphTypes GraphType {get;}

Implements

IGraph.GraphType

See Also

CompileUnitCollection Class | DDW.CSharp.Dom Namespace


IsFixedSize Property

Goblin - A Platform for 3D AR and VR Applications

CompileUnitCollection.IsFixedSize Property

Gets a value indicating whether the collection has a fixed size.

public virtual bool IsFixedSize {get;}

Property Value

true if the collection has a fixed size; otherwise, false. The default is false

Implements

IList.IsFixedSize

See Also

CompileUnitCollection Class | DDW.CSharp.Dom Namespace


IsReadOnly Property

Goblin - A Platform for 3D AR and VR Applications

CompileUnitCollection.IsReadOnly Property

gets a value indicating whether the IList is read-only.

public virtual bool IsReadOnly {get;}

Property Value

true if the collection is read-only; otherwise, false. The default is false

Implements

IList.IsReadOnly

See Also

CompileUnitCollection Class | DDW.CSharp.Dom Namespace


IsSynchronized Property

Goblin - A Platform for 3D AR and VR Applications

CompileUnitCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread-safe).

public virtual bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

CompileUnitCollection Class | DDW.CSharp.Dom Namespace


Item Property

Goblin - A Platform for 3D AR and VR Applications

CompileUnitCollection.Item Property

Gets or sets the CompileUnit at the specified index.

public virtual CompileUnit this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

CompileUnitCollection Class | DDW.CSharp.Dom Namespace


SyncRoot Property

Goblin - A Platform for 3D AR and VR Applications

CompileUnitCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

public virtual object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

CompileUnitCollection Class | DDW.CSharp.Dom Namespace


Text Property

Goblin - A Platform for 3D AR and VR Applications

CompileUnitCollection.Text Property

public override string Text {get;}

Implements

IGraph.Text

See Also

CompileUnitCollection Class | DDW.CSharp.Dom Namespace


CompileUnitCollection Methods

The methods of the CompileUnitCollection class are listed below. For a complete list of CompileUnitCollection class members, see the CompileUnitCollection Members topic.

Public Static Methods

ReadOnly | Creates a read-only wrapper for a CompileUnitCollection instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a CompileUnitCollection instance.

Public Instance Methods

Add | Adds a CompileUnit to the end of the CompileUnitCollection.
AddRange | Overloaded. Adds the elements of a CompileUnit array to the current CompileUnitCollection.
Clear | Removes all elements from the CompileUnitCollection.
Clone | Creates a shallow copy of the CompileUnitCollection.
Contains | Determines whether a given CompileUnit is in the CompileUnitCollection.
CopyTo | Overloaded. Copies the entire CompileUnitCollection to a one-dimensional CompileUnit array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the CompileUnitCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the zero-based index of the first occurrence of a CompileUnit in the CompileUnitCollection.
Insert | Inserts an element into the CompileUnitCollection at the specified index.
Remove | Removes the first occurrence of a specific CompileUnit from the CompileUnitCollection.
RemoveAt | Removes the element at the specified index of the CompileUnitCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CompileUnitCollection Class | DDW.CSharp.Dom Namespace


CompileUnitCollection.Add Method

Adds a CompileUnit to the end of the CompileUnitCollection.

public virtual int Add(
CompileUnit item
);

Parameters

item
The CompileUnit to be added to the end of the CompileUnitCollection.

Return Value

The index at which the value has been added.

See Also

CompileUnitCollection Class | DDW.CSharp.Dom Namespace


AddRange Method

Goblin - A Platform for 3D AR and VR Applications

CompileUnitCollection.AddRange Method

Adds the elements of a CompileUnit array to the current CompileUnitCollection.

Overload List

Adds the elements of a CompileUnit array to the current CompileUnitCollection.

public virtual int AddRange(CompileUnit[]);

Adds the elements of another CompileUnitCollection to the current CompileUnitCollection.

public virtual int AddRange(CompileUnitCollection);

See Also

CompileUnitCollection Class | DDW.CSharp.Dom Namespace


CompileUnitCollection.AddRange Method (CompileUnit[])

Adds the elements of a CompileUnit array to the current CompileUnitCollection.

public virtual int AddRange(
CompileUnit[] x
);

Parameters

x
The CompileUnit array whose elements should be added to the end of the CompileUnitCollection.

Return Value

The new Count of the CompileUnitCollection.

See Also

CompileUnitCollection Class | DDW.CSharp.Dom Namespace | CompileUnitCollection.AddRange Overload List


CompileUnitCollection.AddRange Method (CompileUnitCollection)

Adds the elements of another CompileUnitCollection to the current CompileUnitCollection.

public virtual int AddRange(
CompileUnitCollection x
);

Parameters

x
The CompileUnitCollection whose elements should be added to the end of the current CompileUnitCollection.

Return Value

The new Count of the CompileUnitCollection.

See Also

CompileUnitCollection Class | DDW.CSharp.Dom Namespace | CompileUnitCollection.AddRange Overload List


CompileUnitCollection.Clear Method

Removes all elements from the CompileUnitCollection.

public virtual void Clear();

Implements

IList.Clear

See Also

CompileUnitCollection Class | DDW.CSharp.Dom Namespace


CompileUnitCollection.Clone Method

Creates a shallow copy of the CompileUnitCollection.

public virtual object Clone();

Implements

ICloneable.Clone

See Also

CompileUnitCollection Class | DDW.CSharp.Dom Namespace


CompileUnitCollection.Contains Method

Determines whether a given CompileUnit is in the CompileUnitCollection.

public virtual bool Contains(
CompileUnit item
);

Parameters

item
The CompileUnit to check for.

Return Value

true if item is found in the CompileUnitCollection; otherwise, false.

See Also

CompileUnitCollection Class | DDW.CSharp.Dom Namespace


CopyTo Method

Goblin - A Platform for 3D AR and VR Applications

CompileUnitCollection.CopyTo Method

Copies the entire CompileUnitCollection to a one-dimensional CompileUnit array.

Overload List

Copies the entire CompileUnitCollection to a one-dimensional CompileUnit array.

public virtual void CopyTo(CompileUnit[]);

Copies the entire CompileUnitCollection to a one-dimensional CompileUnit array, starting at the specified index of the target array.

public virtual void CopyTo(CompileUnit[],int);

See Also

CompileUnitCollection Class | DDW.CSharp.Dom Namespace


CompileUnitCollection.CopyTo Method (CompileUnit[])

Copies the entire CompileUnitCollection to a one-dimensional CompileUnit array.

public virtual void CopyTo(
CompileUnit[] array
);

Parameters

array
The one-dimensional CompileUnit array to copy to.

See Also

CompileUnitCollection Class | DDW.CSharp.Dom Namespace | CompileUnitCollection.CopyTo Overload List


CompileUnitCollection.CopyTo Method (CompileUnit[], Int32)

Copies the entire CompileUnitCollection to a one-dimensional CompileUnit array, starting at the specified index of the target array.

public virtual void CopyTo(
CompileUnit[] array,
int start
);

Parameters

array
The one-dimensional CompileUnit array to copy to.
start
The zero-based index in array at which copying begins.

See Also

CompileUnitCollection Class | DDW.CSharp.Dom Namespace | CompileUnitCollection.CopyTo Overload List


CompileUnitCollection.GetEnumerator Method

Returns an enumerator that can iterate through the CompileUnitCollection.

public virtual ICompileUnitCollectionEnumerator GetEnumerator();

Return Value

An Enumerator for the entire CompileUnitCollection.

See Also

CompileUnitCollection Class | DDW.CSharp.Dom Namespace


CompileUnitCollection.IndexOf Method

Returns the zero-based index of the first occurrence of a CompileUnit in the CompileUnitCollection.

public virtual int IndexOf(
CompileUnit item
);

Parameters

item
The CompileUnit to locate in the CompileUnitCollection.

Return Value

The zero-based index of the first occurrence of item in the entire CompileUnitCollection, if found; otherwise, -1.

See Also

CompileUnitCollection Class | DDW.CSharp.Dom Namespace


CompileUnitCollection.Insert Method

Inserts an element into the CompileUnitCollection at the specified index.

public virtual void Insert(
int index,
CompileUnit item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The CompileUnit to insert.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

CompileUnitCollection Class | DDW.CSharp.Dom Namespace


CompileUnitCollection.ReadOnly Method

Creates a read-only wrapper for a CompileUnitCollection instance.

public static CompileUnitCollection ReadOnly(
CompileUnitCollection list
);

Return Value

An CompileUnitCollection wrapper that is read-only.

See Also

CompileUnitCollection Class | DDW.CSharp.Dom Namespace


CompileUnitCollection.Remove Method

Removes the first occurrence of a specific CompileUnit from the CompileUnitCollection.

public virtual void Remove(
CompileUnit item
);

Parameters

item
The CompileUnit to remove from the CompileUnitCollection.

Exceptions

Exception Type | Condition
ArgumentException | The specified CompileUnit was not found in the CompileUnitCollection.

See Also

CompileUnitCollection Class | DDW.CSharp.Dom Namespace


CompileUnitCollection.RemoveAt Method

Removes the element at the specified index of the CompileUnitCollection.

public virtual void RemoveAt(
int index
);

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

CompileUnitCollection Class | DDW.CSharp.Dom Namespace


CompileUnitCollection.Synchronized Method

Creates a synchronized (thread-safe) wrapper for a CompileUnitCollection instance.

public static CompileUnitCollection Synchronized(
CompileUnitCollection list
);

Return Value

An CompileUnitCollection wrapper that is synchronized (thread-safe).

See Also

CompileUnitCollection Class | DDW.CSharp.Dom Namespace


CompileUnitCollection.TrimToSize Method

Sets the capacity to the actual number of elements.

public virtual void TrimToSize();

See Also

CompileUnitCollection Class | DDW.CSharp.Dom Namespace


CompileUnitCollection.ICompileUnitCollectionEnumerator Interface

Supports type-safe iteration over a CompileUnitCollection.

For a list of all members of this type, see CompileUnitCollection.ICompileUnitCollectionEnumerator Members.

public interface CompileUnitCollection.ICompileUnitCollectionEnumerator

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

CompileUnitCollection.ICompileUnitCollectionEnumerator Members | DDW.CSharp.Dom Namespace


CompileUnitCollection.ICompileUnitCollectionEnumerator Members

CompileUnitCollection.ICompileUnitCollectionEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

CompileUnitCollection.ICompileUnitCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


CompileUnitCollection.ICompileUnitCollectionEnumerator Properties

The properties of the CompileUnitCollection.ICompileUnitCollectionEnumerator interface are listed below. For a complete list of CompileUnitCollection.ICompileUnitCollectionEnumerator interface members, see the CompileUnitCollection.ICompileUnitCollectionEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

CompileUnitCollection.ICompileUnitCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


Current Property

Goblin - A Platform for 3D AR and VR Applications

CompileUnitCollection.ICompileUnitCollectionEnumerator.Current Property

Gets the current element in the collection.

CompileUnit Current {get;}

See Also

CompileUnitCollection.ICompileUnitCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


CompileUnitCollection.ICompileUnitCollectionEnumerator Methods

The methods of the CompileUnitCollection.ICompileUnitCollectionEnumerator interface are listed below. For a complete list of CompileUnitCollection.ICompileUnitCollectionEnumerator interface members, see the CompileUnitCollection.ICompileUnitCollectionEnumerator Members topic.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

CompileUnitCollection.ICompileUnitCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


CompileUnitCollection.ICompileUnitCollectionEnumerator.MoveNext Method

Advances the enumerator to the next element in the collection.

bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Exceptions

Exception Type | Condition
InvalidOperationException | The collection was modified after the enumerator was created.

See Also

CompileUnitCollection.ICompileUnitCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


CompileUnitCollection.ICompileUnitCollectionEnumerator.Reset Method

Sets the enumerator to its initial position, before the first element in the collection.

void Reset();

See Also

CompileUnitCollection.ICompileUnitCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


CompileUnitCollection.Tag Enumeration

protected enum CompileUnitCollection.Tag

Members

Member Name | Description
Default |

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

DDW.CSharp.Dom Namespace


ConstantDecl Class

A constant declartation.

For a list of all members of this type, see ConstantDecl Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.MemberDecl
DDW.CSharp.Dom.ConstantDecl

public class ConstantDecl : MemberDecl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

ConstantDecl Members | DDW.CSharp.Dom Namespace


ConstantDecl Members

ConstantDecl overview

Public Instance Constructors

ConstantDecl Constructor Initializes a new instance of the ConstantDecl class.

Public Instance Properties

Attributes (inherited from MemberDecl) | Gets or sets the modifier flags for this member (public, private etc).
Comments (inherited from MemberDecl) | Gets the collection of comments for this member.
CustomAttributes (inherited from MemberDecl) | Gets the collection of Custom Attributes used for this member (custom attributes are the ones declared between brackets, like [Flags]).
Delcarators | Gets the collection of declarators created in the field. Constants declarations can declare multiple variables at once, so this must be a collection.
LinePragma (inherited from CSharpGraph) |
MemberKind |
Type | Gets or sets the type of the constant. There can only be one type per declaration.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
VerifyModifiers (inherited from MemberDecl) |

See Also

ConstantDecl Class | DDW.CSharp.Dom Namespace


ConstantDecl Constructor

Initializes a new instance of the ConstantDecl class.

public ConstantDecl();

See Also

ConstantDecl Class | DDW.CSharp.Dom Namespace


ConstantDecl Properties

The properties of the ConstantDecl class are listed below. For a complete list of ConstantDecl class members, see the ConstantDecl Members topic.

Public Instance Properties

Attributes (inherited from MemberDecl) | Gets or sets the modifier flags for this member (public, private etc).
Comments (inherited from MemberDecl) | Gets the collection of comments for this member.
CustomAttributes (inherited from MemberDecl) | Gets the collection of Custom Attributes used for this member (custom attributes are the ones declared between brackets, like [Flags]).
Delcarators | Gets the collection of declarators created in the field. Constants declarations can declare multiple variables at once, so this must be a collection.
LinePragma (inherited from CSharpGraph) |
MemberKind |
Type | Gets or sets the type of the constant. There can only be one type per declaration.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

ConstantDecl Class | DDW.CSharp.Dom Namespace


Delcarators Property

Goblin - A Platform for 3D AR and VR Applications

ConstantDecl.Delcarators Property

Gets the collection of declarators created in the field. Constants declarations can declare multiple variables at once, so this must be a collection.

public DeclaratorCollection Delcarators {get;}

See Also

ConstantDecl Class | DDW.CSharp.Dom Namespace


MemberKind Property

Goblin - A Platform for 3D AR and VR Applications

ConstantDecl.MemberKind Property

public override MemberKind MemberKind {get;}

See Also

ConstantDecl Class | DDW.CSharp.Dom Namespace


Type Property

Goblin - A Platform for 3D AR and VR Applications

ConstantDecl.Type Property

Gets or sets the type of the constant. There can only be one type per declaration.

public TypeRef Type {get; set;}

See Also

ConstantDecl Class | DDW.CSharp.Dom Namespace


ConstantDeclStmt Class

A constant declaration statement.

For a list of all members of this type, see ConstantDeclStmt Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Statement
DDW.CSharp.Dom.ConstantDeclStmt

public class ConstantDeclStmt : Statement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

ConstantDeclStmt Members | DDW.CSharp.Dom Namespace


ConstantDeclStmt Members

ConstantDeclStmt overview

Public Instance Constructors

ConstantDeclStmt Constructor Initializes a new instance of the ConstantDeclStmt class.

Public Instance Properties

Delcarators | Gets the collection of declarators created. Constant declarations can declare multiple variables at once, so this must be a collection.
LinePragma (inherited from CSharpGraph) |
Type | Gets or sets the type of the constant. While one can declare multiple constant variables they must be of the same type - therefore this is not a collection.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConstantDeclStmt Class | DDW.CSharp.Dom Namespace


ConstantDeclStmt Constructor

Initializes a new instance of the ConstantDeclStmt class.

public ConstantDeclStmt();

See Also

ConstantDeclStmt Class | DDW.CSharp.Dom Namespace


ConstantDeclStmt Properties

The properties of the ConstantDeclStmt class are listed below. For a complete list of ConstantDeclStmt class members, see the ConstantDeclStmt Members topic.

Public Instance Properties

Delcarators | Gets the collection of declarators created. Constant declarations can declare multiple variables at once, so this must be a collection.
LinePragma (inherited from CSharpGraph) |
Type | Gets or sets the type of the constant. While one can declare multiple constant variables they must be of the same type - therefore this is not a collection.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

ConstantDeclStmt Class | DDW.CSharp.Dom Namespace


Delcarators Property

Goblin - A Platform for 3D AR and VR Applications

ConstantDeclStmt.Delcarators Property

Gets the collection of declarators created. Constant declarations can declare multiple variables at once, so this must be a collection.

public DeclaratorCollection Delcarators {get;}

See Also

ConstantDeclStmt Class | DDW.CSharp.Dom Namespace


Type Property

Goblin - A Platform for 3D AR and VR Applications

ConstantDeclStmt.Type Property

Gets or sets the type of the constant. While one can declare multiple constant variables they must be of the same type - therefore this is not a collection.

public TypeRef Type {get; set;}

See Also

ConstantDeclStmt Class | DDW.CSharp.Dom Namespace


ConstructorDecl Class

A constructor declartation.

For a list of all members of this type, see ConstructorDecl Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.MemberDecl
DDW.CSharp.Dom.ConstructorDecl

public class ConstructorDecl : MemberDecl, IDeclaration, IScope, IOverloadable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

ConstructorDecl Members | DDW.CSharp.Dom Namespace


ConstructorDecl Members

ConstructorDecl overview

Public Instance Constructors

ConstructorDecl Constructor Initializes a new instance of the ConstructorDecl class.

Public Instance Properties

Attributes (inherited from MemberDecl) | Gets or sets the modifier flags for this member (public, private etc).
BaseParameters | Gets a collection of parameters to be passed to the base class as the constructor is initialized (the parameters for a ':base()' call).
ChainParameters | Gets a collection of parameters to be passed to a separate overloaded constructor as this constructor is initialized (the parameters for a ':this()' call).
Comments (inherited from MemberDecl) | Gets the collection of comments for this member.
CustomAttributes (inherited from MemberDecl) | Gets the collection of Custom Attributes used for this member (custom attributes are the ones declared between brackets, like [Flags]).
Definition | Gets the (scoped) definition.
InvokeBase | Gets or sets a flag that indicates the constructor specifies which base class should be called and thus requires a base call - eg MyDerived():base(i).
InvokeChain | Gets or sets a flag that indicates the constructor calls a separate overloaded constructor before proceeding - eg MyDerived():this(i).
LinePragma (inherited from CSharpGraph) |
MemberKind |
Name | Gets or sets the name of the constructor (which matches the name of the class).
Parameters | Gets the collection of parameters for the constructor. Each of these hold information about the type, direction etc.
Scope |
Statements | Gets the collection of statements in the constructor.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
VerifyModifiers (inherited from MemberDecl) |

See Also

ConstructorDecl Class | DDW.CSharp.Dom Namespace


ConstructorDecl Constructor

Initializes a new instance of the ConstructorDecl class.

public ConstructorDecl();

See Also

ConstructorDecl Class | DDW.CSharp.Dom Namespace


ConstructorDecl Properties

The properties of the ConstructorDecl class are listed below. For a complete list of ConstructorDecl class members, see the ConstructorDecl Members topic.

Public Instance Properties

Attributes (inherited from MemberDecl) | Gets or sets the modifier flags for this member (public, private etc).
BaseParameters | Gets a collection of parameters to be passed to the base class as the constructor is initialized (the parameters for a ':base()' call).
ChainParameters | Gets a collection of parameters to be passed to a separate overloaded constructor as this constructor is initialized (the parameters for a ':this()' call).
Comments (inherited from MemberDecl) | Gets the collection of comments for this member.
CustomAttributes (inherited from MemberDecl) | Gets the collection of Custom Attributes used for this member (custom attributes are the ones declared between brackets, like [Flags]).
Definition | Gets the (scoped) definition.
InvokeBase | Gets or sets a flag that indicates the constructor specifies which base class should be called and thus requires a base call - eg MyDerived():base(i).
InvokeChain | Gets or sets a flag that indicates the constructor calls a separate overloaded constructor before proceeding - eg MyDerived():this(i).
LinePragma (inherited from CSharpGraph) |
MemberKind |
Name | Gets or sets the name of the constructor (which matches the name of the class).
Parameters | Gets the collection of parameters for the constructor. Each of these hold information about the type, direction etc.
Scope |
Statements | Gets the collection of statements in the constructor.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

ConstructorDecl Class | DDW.CSharp.Dom Namespace


BaseParameters Property

Goblin - A Platform for 3D AR and VR Applications

ConstructorDecl.BaseParameters Property

Gets a collection of parameters to be passed to the base class as the constructor is initialized (the parameters for a ':base()' call).

public ParamCollection BaseParameters {get;}

See Also

ConstructorDecl Class | DDW.CSharp.Dom Namespace


ChainParameters Property

Goblin - A Platform for 3D AR and VR Applications

ConstructorDecl.ChainParameters Property

Gets a collection of parameters to be passed to a separate overloaded constructor as this constructor is initialized (the parameters for a ':this()' call).

public ParamCollection ChainParameters {get;}

See Also

ConstructorDecl Class | DDW.CSharp.Dom Namespace


Definition Property

Goblin - A Platform for 3D AR and VR Applications

ConstructorDecl.Definition Property

Gets the (scoped) definition.

public DDW.CSharp.SymbolTable.IDefinition Definition {get;}

Implements

IDeclaration.Definition

See Also

ConstructorDecl Class | DDW.CSharp.Dom Namespace


InvokeBase Property

Goblin - A Platform for 3D AR and VR Applications

ConstructorDecl.InvokeBase Property

Gets or sets a flag that indicates the constructor specifies which base class should be called and thus requires a base call - eg MyDerived():base(i).

public bool InvokeBase {get; set;}

See Also

ConstructorDecl Class | DDW.CSharp.Dom Namespace


InvokeChain Property

Goblin - A Platform for 3D AR and VR Applications

ConstructorDecl.InvokeChain Property

Gets or sets a flag that indicates the constructor calls a separate overloaded constructor before proceeding - eg MyDerived():this(i).

public bool InvokeChain {get; set;}

See Also

ConstructorDecl Class | DDW.CSharp.Dom Namespace


MemberKind Property

Goblin - A Platform for 3D AR and VR Applications

ConstructorDecl.MemberKind Property

public override MemberKind MemberKind {get;}

See Also

ConstructorDecl Class | DDW.CSharp.Dom Namespace


Name Property

Goblin - A Platform for 3D AR and VR Applications

ConstructorDecl.Name Property

Gets or sets the name of the constructor (which matches the name of the class).

public string Name {get; set;}

See Also

ConstructorDecl Class | DDW.CSharp.Dom Namespace


Parameters Property

Goblin - A Platform for 3D AR and VR Applications

ConstructorDecl.Parameters Property

Gets the collection of parameters for the constructor. Each of these hold information about the type, direction etc.

public ParamDeclCollection Parameters {get;}

Implements

IOverloadable.Parameters

See Also

ConstructorDecl Class | DDW.CSharp.Dom Namespace


Scope Property

Goblin - A Platform for 3D AR and VR Applications

ConstructorDecl.Scope Property

public DDW.CSharp.SymbolTable.Scope Scope {get; set;}

Implements

IScope.Scope

See Also

ConstructorDecl Class | DDW.CSharp.Dom Namespace


Statements Property

Goblin - A Platform for 3D AR and VR Applications

ConstructorDecl.Statements Property

Gets the collection of statements in the constructor.

public StatementCollection Statements {get;}

See Also

ConstructorDecl Class | DDW.CSharp.Dom Namespace


ContinueStmt Class

A continue statement.

For a list of all members of this type, see ContinueStmt Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Statement
DDW.CSharp.Dom.ContinueStmt

public class ContinueStmt : Statement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

ContinueStmt Members | DDW.CSharp.Dom Namespace


ContinueStmt Members

ContinueStmt overview

Public Instance Constructors

ContinueStmt Constructor Initializes a new instance of the ContinueStmt class.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ContinueStmt Class | DDW.CSharp.Dom Namespace


ContinueStmt Constructor

Initializes a new instance of the ContinueStmt class.

public ContinueStmt();

See Also

ContinueStmt Class | DDW.CSharp.Dom Namespace


CreateDelegateExpr Class

An expression that creates a new delegate.

For a list of all members of this type, see CreateDelegateExpr Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Expression
DDW.CSharp.Dom.CreateDelegateExpr

public class CreateDelegateExpr : Expression

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

CreateDelegateExpr Members | DDW.CSharp.Dom Namespace


CreateDelegateExpr Members

CreateDelegateExpr overview

Public Instance Constructors

CreateDelegateExpr Constructor Initializes a new instance of the CreateDelegateExpr class.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
MethodName | Gets or sets the name of the method to 'delegate' to.
Target | Gets or sets the target object to which the delegate method belongs.
Type | Gets or sets the return type of the delegate. This may be 'void'.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CreateDelegateExpr Class | DDW.CSharp.Dom Namespace


CreateDelegateExpr Constructor

Initializes a new instance of the CreateDelegateExpr class.

public CreateDelegateExpr();

See Also

CreateDelegateExpr Class | DDW.CSharp.Dom Namespace


CreateDelegateExpr Properties

The properties of the CreateDelegateExpr class are listed below. For a complete list of CreateDelegateExpr class members, see the CreateDelegateExpr Members topic.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
MethodName | Gets or sets the name of the method to 'delegate' to.
Target | Gets or sets the target object to which the delegate method belongs.
Type | Gets or sets the return type of the delegate. This may be 'void'.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

CreateDelegateExpr Class | DDW.CSharp.Dom Namespace


MethodName Property

Goblin - A Platform for 3D AR and VR Applications

CreateDelegateExpr.MethodName Property

Gets or sets the name of the method to 'delegate' to.

public string MethodName {get; set;}

See Also

CreateDelegateExpr Class | DDW.CSharp.Dom Namespace


Target Property

Goblin - A Platform for 3D AR and VR Applications

CreateDelegateExpr.Target Property

Gets or sets the target object to which the delegate method belongs.

public Expression Target {get; set;}

See Also

CreateDelegateExpr Class | DDW.CSharp.Dom Namespace


Type Property

Goblin - A Platform for 3D AR and VR Applications

CreateDelegateExpr.Type Property

Gets or sets the return type of the delegate. This may be 'void'.

public TypeRef Type {get; set;}

See Also

CreateDelegateExpr Class | DDW.CSharp.Dom Namespace


CSharpGraph Class

An abstract base class for CSharpDom elements.

For a list of all members of this type, see CSharpGraph Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
Derived types

public abstract class CSharpGraph : IGraph

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

CSharpGraph Members | DDW.CSharp.Dom Namespace


CSharpGraph Members

CSharpGraph overview

Public Static Methods

GetTypeFromString

Public Instance Properties

GraphType |
LinePragma |
UserData | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

CSharpGraph Constructor Initializes a new instance of the CSharpGraph class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CSharpGraph Class | DDW.CSharp.Dom Namespace


CSharpGraph Constructor

Initializes a new instance of the CSharpGraph class.

protected CSharpGraph();

See Also

CSharpGraph Class | DDW.CSharp.Dom Namespace


CSharpGraph Properties

The properties of the CSharpGraph class are listed below. For a complete list of CSharpGraph class members, see the CSharpGraph Members topic.

Public Instance Properties

GraphType |
LinePragma |
UserData | Gets or sets the user-definable data for the current object.

See Also

CSharpGraph Class | DDW.CSharp.Dom Namespace


GraphType Property

Goblin - A Platform for 3D AR and VR Applications

CSharpGraph.GraphType Property

public virtual GraphTypes GraphType {get;}

Implements

IGraph.GraphType

See Also

CSharpGraph Class | DDW.CSharp.Dom Namespace


LinePragma Property

Goblin - A Platform for 3D AR and VR Applications

CSharpGraph.LinePragma Property

public LinePragma LinePragma {get;}

Implements

IGraph.LinePragma

See Also

CSharpGraph Class | DDW.CSharp.Dom Namespace


UserData Property

Goblin - A Platform for 3D AR and VR Applications

CSharpGraph.UserData Property

Gets or sets the user-definable data for the current object.

public System.Collections.IDictionary UserData {get; set;}

See Also

CSharpGraph Class | DDW.CSharp.Dom Namespace


CSharpGraph Methods

The methods of the CSharpGraph class are listed below. For a complete list of CSharpGraph class members, see the CSharpGraph Members topic.

Public Static Methods

GetTypeFromString

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CSharpGraph Class | DDW.CSharp.Dom Namespace


CSharpGraph.GetTypeFromString Method

public static Type GetTypeFromString(
string s
);

See Also

CSharpGraph Class | DDW.CSharp.Dom Namespace


CustomAttribute Class

An single attribute applied to a code element (eg. [Flags]). Note: multiple comma separated attributes declared in a single attribute element are separated into multiple attributes.

For a list of all members of this type, see CustomAttribute Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.CustomAttribute

public class CustomAttribute : CSharpGraph

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

CustomAttribute Members | DDW.CSharp.Dom Namespace


CustomAttribute Members

CustomAttribute overview

Public Static Methods

StringFromAttributeTarget

Public Instance Constructors

CustomAttribute Constructor Initializes a new instance of the CustomAttribute class.

Public Instance Properties

AttributeTarget | Gets or sets the target element that the attribute applies to.
LinePragma (inherited from CSharpGraph) |
Name | Gets or sets the name of the attribute.
Parameters | Gets the collection of parameters to be passed to the custom attribute.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CustomAttribute Class | DDW.CSharp.Dom Namespace


CustomAttribute Constructor

Initializes a new instance of the CustomAttribute class.

public CustomAttribute();

See Also

CustomAttribute Class | DDW.CSharp.Dom Namespace


CustomAttribute Properties

The properties of the CustomAttribute class are listed below. For a complete list of CustomAttribute class members, see the CustomAttribute Members topic.

Public Instance Properties

AttributeTarget | Gets or sets the target element that the attribute applies to.
LinePragma (inherited from CSharpGraph) |
Name | Gets or sets the name of the attribute.
Parameters | Gets the collection of parameters to be passed to the custom attribute.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

CustomAttribute Class | DDW.CSharp.Dom Namespace


AttributeTarget Property

Goblin - A Platform for 3D AR and VR Applications

CustomAttribute.AttributeTarget Property

Gets or sets the target element that the attribute applies to.

public AttributeTarget AttributeTarget {get; set;}

See Also

CustomAttribute Class | DDW.CSharp.Dom Namespace


Name Property

Goblin - A Platform for 3D AR and VR Applications

CustomAttribute.Name Property

Gets or sets the name of the attribute.

public string Name {get; set;}

See Also

CustomAttribute Class | DDW.CSharp.Dom Namespace


Parameters Property

Goblin - A Platform for 3D AR and VR Applications

CustomAttribute.Parameters Property

Gets the collection of parameters to be passed to the custom attribute.

public ExpressionCollection Parameters {get;}

See Also

CustomAttribute Class | DDW.CSharp.Dom Namespace


CustomAttribute Methods

The methods of the CustomAttribute class are listed below. For a complete list of CustomAttribute class members, see the CustomAttribute Members topic.

Public Static Methods

StringFromAttributeTarget

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CustomAttribute Class | DDW.CSharp.Dom Namespace


CustomAttribute.StringFromAttributeTarget Method

public static string StringFromAttributeTarget(
AttributeTarget at
);

See Also

CustomAttribute Class | DDW.CSharp.Dom Namespace


CustomAttributeCollection Class

A strongly-typed collection of CustomAttribute objects.

For a list of all members of this type, see CustomAttributeCollection Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.CustomAttributeCollection

public class CustomAttributeCollection : CSharpGraph, IList, ICollection, IEnumerable, ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

CustomAttributeCollection Members | DDW.CSharp.Dom Namespace


CustomAttributeCollection Members

CustomAttributeCollection overview

Public Static Methods

ReadOnly | Creates a read-only wrapper for a CustomAttributeCollection instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a CustomAttributeCollection instance.

Public Instance Constructors

CustomAttributeCollection Overloaded. Initializes a new instance of the CustomAttributeCollection class.

Public Instance Properties

Capacity | Gets or sets the number of elements the CustomAttributeCollection can contain.
Count | Gets the number of elements actually contained in the CustomAttributeCollection.
GraphType |
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the CustomAttribute at the specified index.
LinePragma (inherited from CSharpGraph) |
SyncRoot | Gets an object that can be used to synchronize access to the collection.
Text |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Add | Adds a CustomAttribute to the end of the CustomAttributeCollection.
AddRange | Overloaded. Adds the elements of a CustomAttribute array to the current CustomAttributeCollection.
Clear | Removes all elements from the CustomAttributeCollection.
Clone | Creates a shallow copy of the CustomAttributeCollection.
Contains | Determines whether a given CustomAttribute is in the CustomAttributeCollection.
CopyTo | Overloaded. Copies the entire CustomAttributeCollection to a one-dimensional CustomAttribute array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the CustomAttributeCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the zero-based index of the first occurrence of a CustomAttribute in the CustomAttributeCollection.
Insert | Inserts an element into the CustomAttributeCollection at the specified index.
Remove | Removes the first occurrence of a specific CustomAttribute from the CustomAttributeCollection.
RemoveAt | Removes the element at the specified index of the CustomAttributeCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Constructors

CustomAttributeCollection Overloaded. Initializes a new instance of the CustomAttributeCollection class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CustomAttributeCollection Class | DDW.CSharp.Dom Namespace


CustomAttributeCollection Constructor

Initializes a new instance of the CustomAttributeCollection class that is empty and has the default initial capacity.

Overload List

Initializes a new instance of the CustomAttributeCollection class that is empty and has the default initial capacity.

public CustomAttributeCollection();

Initializes a new instance of the CustomAttributeCollection class that contains elements copied from the specified CustomAttribute array.

public CustomAttributeCollection(CustomAttribute[]);

Initializes a new instance of the CustomAttributeCollection class that contains elements copied from the specified CustomAttributeCollection.

public CustomAttributeCollection(CustomAttributeCollection);

protected CustomAttributeCollection(Tag);

Initializes a new instance of the CustomAttributeCollection class that has the specified initial capacity.

public CustomAttributeCollection(int);

See Also

CustomAttributeCollection Class | DDW.CSharp.Dom Namespace


CustomAttributeCollection Constructor ()

Initializes a new instance of the CustomAttributeCollection class that is empty and has the default initial capacity.

public CustomAttributeCollection();

See Also

CustomAttributeCollection Class | DDW.CSharp.Dom Namespace | CustomAttributeCollection Constructor Overload List


CustomAttributeCollection Constructor (Int32)

Initializes a new instance of the CustomAttributeCollection class that has the specified initial capacity.

public CustomAttributeCollection(
int capacity
);

Parameters

capacity
The number of elements that the new CustomAttributeCollection is initially capable of storing.

See Also

CustomAttributeCollection Class | DDW.CSharp.Dom Namespace | CustomAttributeCollection Constructor Overload List


CustomAttributeCollection Constructor (CustomAttributeCollection)

Initializes a new instance of the CustomAttributeCollection class that contains elements copied from the specified CustomAttributeCollection.

public CustomAttributeCollection(
CustomAttributeCollection c
);

Parameters

c
The CustomAttributeCollection whose elements are copied to the new collection.

See Also

CustomAttributeCollection Class | DDW.CSharp.Dom Namespace | CustomAttributeCollection Constructor Overload List


CustomAttributeCollection Constructor (CustomAttribute[])

Initializes a new instance of the CustomAttributeCollection class that contains elements copied from the specified CustomAttribute array.

public CustomAttributeCollection(
CustomAttribute[] a
);

Parameters

a
The CustomAttribute array whose elements are copied to the new list.

See Also

CustomAttributeCollection Class | DDW.CSharp.Dom Namespace | CustomAttributeCollection Constructor Overload List


CustomAttributeCollection Constructor (Tag)

protected CustomAttributeCollection(
Tag t
);

See Also

CustomAttributeCollection Class | DDW.CSharp.Dom Namespace | CustomAttributeCollection Constructor Overload List


CustomAttributeCollection Properties

The properties of the CustomAttributeCollection class are listed below. For a complete list of CustomAttributeCollection class members, see the CustomAttributeCollection Members topic.

Public Instance Properties

Capacity | Gets or sets the number of elements the CustomAttributeCollection can contain.
Count | Gets the number of elements actually contained in the CustomAttributeCollection.
GraphType |
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the CustomAttribute at the specified index.
LinePragma (inherited from CSharpGraph) |
SyncRoot | Gets an object that can be used to synchronize access to the collection.
Text |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

CustomAttributeCollection Class | DDW.CSharp.Dom Namespace


Capacity Property

Goblin - A Platform for 3D AR and VR Applications

CustomAttributeCollection.Capacity Property

Gets or sets the number of elements the CustomAttributeCollection can contain.

public virtual int Capacity {get; set;}

See Also

CustomAttributeCollection Class | DDW.CSharp.Dom Namespace


Count Property

Goblin - A Platform for 3D AR and VR Applications

CustomAttributeCollection.Count Property

Gets the number of elements actually contained in the CustomAttributeCollection.

public virtual int Count {get;}

Implements

ICollection.Count

See Also

CustomAttributeCollection Class | DDW.CSharp.Dom Namespace


GraphType Property

Goblin - A Platform for 3D AR and VR Applications

CustomAttributeCollection.GraphType Property

public override GraphTypes GraphType {get;}

Implements

IGraph.GraphType

See Also

CustomAttributeCollection Class | DDW.CSharp.Dom Namespace


IsFixedSize Property

Goblin - A Platform for 3D AR and VR Applications

CustomAttributeCollection.IsFixedSize Property

Gets a value indicating whether the collection has a fixed size.

public virtual bool IsFixedSize {get;}

Property Value

true if the collection has a fixed size; otherwise, false. The default is false

Implements

IList.IsFixedSize

See Also

CustomAttributeCollection Class | DDW.CSharp.Dom Namespace


IsReadOnly Property

Goblin - A Platform for 3D AR and VR Applications

CustomAttributeCollection.IsReadOnly Property

gets a value indicating whether the IList is read-only.

public virtual bool IsReadOnly {get;}

Property Value

true if the collection is read-only; otherwise, false. The default is false

Implements

IList.IsReadOnly

See Also

CustomAttributeCollection Class | DDW.CSharp.Dom Namespace


IsSynchronized Property

Goblin - A Platform for 3D AR and VR Applications

CustomAttributeCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread-safe).

public virtual bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

CustomAttributeCollection Class | DDW.CSharp.Dom Namespace


Item Property

Goblin - A Platform for 3D AR and VR Applications

CustomAttributeCollection.Item Property

Gets or sets the CustomAttribute at the specified index.

public virtual CustomAttribute this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

CustomAttributeCollection Class | DDW.CSharp.Dom Namespace


SyncRoot Property

Goblin - A Platform for 3D AR and VR Applications

CustomAttributeCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

public virtual object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

CustomAttributeCollection Class | DDW.CSharp.Dom Namespace


Text Property

Goblin - A Platform for 3D AR and VR Applications

CustomAttributeCollection.Text Property

public override string Text {get;}

Implements

IGraph.Text

See Also

CustomAttributeCollection Class | DDW.CSharp.Dom Namespace


CustomAttributeCollection Methods

The methods of the CustomAttributeCollection class are listed below. For a complete list of CustomAttributeCollection class members, see the CustomAttributeCollection Members topic.

Public Static Methods

ReadOnly | Creates a read-only wrapper for a CustomAttributeCollection instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a CustomAttributeCollection instance.

Public Instance Methods

Add | Adds a CustomAttribute to the end of the CustomAttributeCollection.
AddRange | Overloaded. Adds the elements of a CustomAttribute array to the current CustomAttributeCollection.
Clear | Removes all elements from the CustomAttributeCollection.
Clone | Creates a shallow copy of the CustomAttributeCollection.
Contains | Determines whether a given CustomAttribute is in the CustomAttributeCollection.
CopyTo | Overloaded. Copies the entire CustomAttributeCollection to a one-dimensional CustomAttribute array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the CustomAttributeCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the zero-based index of the first occurrence of a CustomAttribute in the CustomAttributeCollection.
Insert | Inserts an element into the CustomAttributeCollection at the specified index.
Remove | Removes the first occurrence of a specific CustomAttribute from the CustomAttributeCollection.
RemoveAt | Removes the element at the specified index of the CustomAttributeCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CustomAttributeCollection Class | DDW.CSharp.Dom Namespace


CustomAttributeCollection.Add Method

Adds a CustomAttribute to the end of the CustomAttributeCollection.

public virtual int Add(
CustomAttribute item
);

Parameters

item
The CustomAttribute to be added to the end of the CustomAttributeCollection.

Return Value

The index at which the value has been added.

See Also

CustomAttributeCollection Class | DDW.CSharp.Dom Namespace


AddRange Method

Goblin - A Platform for 3D AR and VR Applications

CustomAttributeCollection.AddRange Method

Adds the elements of a CustomAttribute array to the current CustomAttributeCollection.

Overload List

Adds the elements of a CustomAttribute array to the current CustomAttributeCollection.

public virtual int AddRange(CustomAttribute[]);

Adds the elements of another CustomAttributeCollection to the current CustomAttributeCollection.

public virtual int AddRange(CustomAttributeCollection);

See Also

CustomAttributeCollection Class | DDW.CSharp.Dom Namespace


CustomAttributeCollection.AddRange Method (CustomAttribute[])

Adds the elements of a CustomAttribute array to the current CustomAttributeCollection.

public virtual int AddRange(
CustomAttribute[] x
);

Parameters

x
The CustomAttribute array whose elements should be added to the end of the CustomAttributeCollection.

Return Value

The new Count of the CustomAttributeCollection.

See Also

CustomAttributeCollection Class | DDW.CSharp.Dom Namespace | CustomAttributeCollection.AddRange Overload List


CustomAttributeCollection.AddRange Method (CustomAttributeCollection)

Adds the elements of another CustomAttributeCollection to the current CustomAttributeCollection.

public virtual int AddRange(
CustomAttributeCollection x
);

Parameters

x
The CustomAttributeCollection whose elements should be added to the end of the current CustomAttributeCollection.

Return Value

The new Count of the CustomAttributeCollection.

See Also

CustomAttributeCollection Class | DDW.CSharp.Dom Namespace | CustomAttributeCollection.AddRange Overload List


CustomAttributeCollection.Clear Method

Removes all elements from the CustomAttributeCollection.

public virtual void Clear();

Implements

IList.Clear

See Also

CustomAttributeCollection Class | DDW.CSharp.Dom Namespace


CustomAttributeCollection.Clone Method

Creates a shallow copy of the CustomAttributeCollection.

public virtual object Clone();

Implements

ICloneable.Clone

See Also

CustomAttributeCollection Class | DDW.CSharp.Dom Namespace


CustomAttributeCollection.Contains Method

Determines whether a given CustomAttribute is in the CustomAttributeCollection.

public virtual bool Contains(
CustomAttribute item
);

Parameters

item
The CustomAttribute to check for.

Return Value

true if item is found in the CustomAttributeCollection; otherwise, false.

See Also

CustomAttributeCollection Class | DDW.CSharp.Dom Namespace


CopyTo Method

Goblin - A Platform for 3D AR and VR Applications

CustomAttributeCollection.CopyTo Method

Copies the entire CustomAttributeCollection to a one-dimensional CustomAttribute array.

Overload List

Copies the entire CustomAttributeCollection to a one-dimensional CustomAttribute array.

public virtual void CopyTo(CustomAttribute[]);

Copies the entire CustomAttributeCollection to a one-dimensional CustomAttribute array, starting at the specified index of the target array.

public virtual void CopyTo(CustomAttribute[],int);

See Also

CustomAttributeCollection Class | DDW.CSharp.Dom Namespace


CustomAttributeCollection.CopyTo Method (CustomAttribute[])

Copies the entire CustomAttributeCollection to a one-dimensional CustomAttribute array.

public virtual void CopyTo(
CustomAttribute[] array
);

Parameters

array
The one-dimensional CustomAttribute array to copy to.

See Also

CustomAttributeCollection Class | DDW.CSharp.Dom Namespace | CustomAttributeCollection.CopyTo Overload List


CustomAttributeCollection.CopyTo Method (CustomAttribute[], Int32)

Copies the entire CustomAttributeCollection to a one-dimensional CustomAttribute array, starting at the specified index of the target array.

public virtual void CopyTo(
CustomAttribute[] array,
int start
);

Parameters

array
The one-dimensional CustomAttribute array to copy to.
start
The zero-based index in array at which copying begins.

See Also

CustomAttributeCollection Class | DDW.CSharp.Dom Namespace | CustomAttributeCollection.CopyTo Overload List


CustomAttributeCollection.GetEnumerator Method

Returns an enumerator that can iterate through the CustomAttributeCollection.

public virtual ICustomAttributeCollectionEnumerator GetEnumerator();

Return Value

An Enumerator for the entire CustomAttributeCollection.

See Also

CustomAttributeCollection Class | DDW.CSharp.Dom Namespace


CustomAttributeCollection.IndexOf Method

Returns the zero-based index of the first occurrence of a CustomAttribute in the CustomAttributeCollection.

public virtual int IndexOf(
CustomAttribute item
);

Parameters

item
The CustomAttribute to locate in the CustomAttributeCollection.

Return Value

The zero-based index of the first occurrence of item in the entire CustomAttributeCollection, if found; otherwise, -1.

See Also

CustomAttributeCollection Class | DDW.CSharp.Dom Namespace


CustomAttributeCollection.Insert Method

Inserts an element into the CustomAttributeCollection at the specified index.

public virtual void Insert(
int index,
CustomAttribute item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The CustomAttribute to insert.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

CustomAttributeCollection Class | DDW.CSharp.Dom Namespace


CustomAttributeCollection.ReadOnly Method

Creates a read-only wrapper for a CustomAttributeCollection instance.

public static CustomAttributeCollection ReadOnly(
CustomAttributeCollection list
);

Return Value

An CustomAttributeCollection wrapper that is read-only.

See Also

CustomAttributeCollection Class | DDW.CSharp.Dom Namespace


CustomAttributeCollection.Remove Method

Removes the first occurrence of a specific CustomAttribute from the CustomAttributeCollection.

public virtual void Remove(
CustomAttribute item
);

Parameters

item
The CustomAttribute to remove from the CustomAttributeCollection.

Exceptions

Exception Type | Condition
ArgumentException | The specified CustomAttribute was not found in the CustomAttributeCollection.

See Also

CustomAttributeCollection Class | DDW.CSharp.Dom Namespace


CustomAttributeCollection.RemoveAt Method

Removes the element at the specified index of the CustomAttributeCollection.

public virtual void RemoveAt(
int index
);

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

CustomAttributeCollection Class | DDW.CSharp.Dom Namespace


CustomAttributeCollection.Synchronized Method

Creates a synchronized (thread-safe) wrapper for a CustomAttributeCollection instance.

public static CustomAttributeCollection Synchronized(
CustomAttributeCollection list
);

Return Value

An CustomAttributeCollection wrapper that is synchronized (thread-safe).

See Also

CustomAttributeCollection Class | DDW.CSharp.Dom Namespace


CustomAttributeCollection.TrimToSize Method

Sets the capacity to the actual number of elements.

public virtual void TrimToSize();

See Also

CustomAttributeCollection Class | DDW.CSharp.Dom Namespace


CustomAttributeCollection.ICustomAttributeCollectionEnumerator Interface

Supports type-safe iteration over a CustomAttributeCollection.

For a list of all members of this type, see CustomAttributeCollection.ICustomAttributeCollectionEnumerator Members.

public interface CustomAttributeCollection.ICustomAttributeCollectionEnumerator

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

CustomAttributeCollection.ICustomAttributeCollectionEnumerator Members | DDW.CSharp.Dom Namespace


CustomAttributeCollection.ICustomAttributeCollectionEnumerator Members

CustomAttributeCollection.ICustomAttributeCollectionEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

CustomAttributeCollection.ICustomAttributeCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


CustomAttributeCollection.ICustomAttributeCollectionEnumerator Properties

The properties of the CustomAttributeCollection.ICustomAttributeCollectionEnumerator interface are listed below. For a complete list of CustomAttributeCollection.ICustomAttributeCollectionEnumerator interface members, see the CustomAttributeCollection.ICustomAttributeCollectionEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

CustomAttributeCollection.ICustomAttributeCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


Current Property

Goblin - A Platform for 3D AR and VR Applications

CustomAttributeCollection.ICustomAttributeCollectionEnumerator.Current Property

Gets the current element in the collection.

CustomAttribute Current {get;}

See Also

CustomAttributeCollection.ICustomAttributeCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


CustomAttributeCollection.ICustomAttributeCollectionEnumerator Methods

The methods of the CustomAttributeCollection.ICustomAttributeCollectionEnumerator interface are listed below. For a complete list of CustomAttributeCollection.ICustomAttributeCollectionEnumerator interface members, see the CustomAttributeCollection.ICustomAttributeCollectionEnumerator Members topic.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

CustomAttributeCollection.ICustomAttributeCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


CustomAttributeCollection.ICustomAttributeCollectionEnumerator.MoveNext Method

Advances the enumerator to the next element in the collection.

bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Exceptions

Exception Type | Condition
InvalidOperationException | The collection was modified after the enumerator was created.

See Also

CustomAttributeCollection.ICustomAttributeCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


CustomAttributeCollection.ICustomAttributeCollectionEnumerator.Reset Method

Sets the enumerator to its initial position, before the first element in the collection.

void Reset();

See Also

CustomAttributeCollection.ICustomAttributeCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


CustomAttributeCollection.Tag Enumeration

protected enum CustomAttributeCollection.Tag

Members

Member Name | Description
Default |

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

DDW.CSharp.Dom Namespace


Declarator Class

Code elements such as fields or events can declare multiple variables of the same type in one statement (int x=5, y=6, z=7;). Each of these are declarators.

For a list of all members of this type, see Declarator Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Declarator

public class Declarator : CSharpGraph, IDeclaration

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

Declarator Members | DDW.CSharp.Dom Namespace


Declarator Members

Declarator overview

Public Instance Constructors

Declarator Constructor Initializes a new instance of the Declarator class.

Public Instance Properties

Definition | Gets the (scoped) definition.
InitExpression | Gets or sets the inital value of the declarator.
LinePragma (inherited from CSharpGraph) |
Name | Gets or sets the name of the declarator.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Declarator Class | DDW.CSharp.Dom Namespace


Declarator Constructor

Initializes a new instance of the Declarator class.

public Declarator();

See Also

Declarator Class | DDW.CSharp.Dom Namespace


Declarator Properties

The properties of the Declarator class are listed below. For a complete list of Declarator class members, see the Declarator Members topic.

Public Instance Properties

Definition | Gets the (scoped) definition.
InitExpression | Gets or sets the inital value of the declarator.
LinePragma (inherited from CSharpGraph) |
Name | Gets or sets the name of the declarator.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

Declarator Class | DDW.CSharp.Dom Namespace


Definition Property

Goblin - A Platform for 3D AR and VR Applications

Declarator.Definition Property

Gets the (scoped) definition.

public DDW.CSharp.SymbolTable.IDefinition Definition {get;}

Implements

IDeclaration.Definition

See Also

Declarator Class | DDW.CSharp.Dom Namespace


InitExpression Property

Goblin - A Platform for 3D AR and VR Applications

Declarator.InitExpression Property

Gets or sets the inital value of the declarator.

public Expression InitExpression {get; set;}

See Also

Declarator Class | DDW.CSharp.Dom Namespace


Name Property

Goblin - A Platform for 3D AR and VR Applications

Declarator.Name Property

Gets or sets the name of the declarator.

public string Name {get; set;}

See Also

Declarator Class | DDW.CSharp.Dom Namespace


DeclaratorCollection Class

A strongly-typed collection of Declarator objects.

For a list of all members of this type, see DeclaratorCollection Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.DeclaratorCollection

public class DeclaratorCollection : CSharpGraph, IList, ICollection, IEnumerable, ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

DeclaratorCollection Members | DDW.CSharp.Dom Namespace


DeclaratorCollection Members

DeclaratorCollection overview

Public Static Methods

ReadOnly | Creates a read-only wrapper for a DeclaratorCollection instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a DeclaratorCollection instance.

Public Instance Constructors

DeclaratorCollection Overloaded. Initializes a new instance of the DeclaratorCollection class.

Public Instance Properties

Capacity | Gets or sets the number of elements the DeclaratorCollection can contain.
Count | Gets the number of elements actually contained in the DeclaratorCollection.
GraphType |
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the Declarator at the specified index.
LinePragma (inherited from CSharpGraph) |
SyncRoot | Gets an object that can be used to synchronize access to the collection.
Text |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Add | Adds a Declarator to the end of the DeclaratorCollection.
AddRange | Overloaded. Adds the elements of a Declarator array to the current DeclaratorCollection.
Clear | Removes all elements from the DeclaratorCollection.
Clone | Creates a shallow copy of the DeclaratorCollection.
Contains | Determines whether a given Declarator is in the DeclaratorCollection.
CopyTo | Overloaded. Copies the entire DeclaratorCollection to a one-dimensional Declarator array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the DeclaratorCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the zero-based index of the first occurrence of a Declarator in the DeclaratorCollection.
Insert | Inserts an element into the DeclaratorCollection at the specified index.
Remove | Removes the first occurrence of a specific Declarator from the DeclaratorCollection.
RemoveAt | Removes the element at the specified index of the DeclaratorCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Constructors

DeclaratorCollection Overloaded. Initializes a new instance of the DeclaratorCollection class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DeclaratorCollection Class | DDW.CSharp.Dom Namespace


DeclaratorCollection Constructor

Initializes a new instance of the DeclaratorCollection class that is empty and has the default initial capacity.

Overload List

Initializes a new instance of the DeclaratorCollection class that is empty and has the default initial capacity.

public DeclaratorCollection();

Initializes a new instance of the DeclaratorCollection class that contains elements copied from the specified Declarator array.

public DeclaratorCollection(Declarator[]);

Initializes a new instance of the DeclaratorCollection class that contains elements copied from the specified DeclaratorCollection.

public DeclaratorCollection(DeclaratorCollection);

protected DeclaratorCollection(Tag);

Initializes a new instance of the DeclaratorCollection class that has the specified initial capacity.

public DeclaratorCollection(int);

See Also

DeclaratorCollection Class | DDW.CSharp.Dom Namespace


DeclaratorCollection Constructor ()

Initializes a new instance of the DeclaratorCollection class that is empty and has the default initial capacity.

public DeclaratorCollection();

See Also

DeclaratorCollection Class | DDW.CSharp.Dom Namespace | DeclaratorCollection Constructor Overload List


DeclaratorCollection Constructor (Int32)

Initializes a new instance of the DeclaratorCollection class that has the specified initial capacity.

public DeclaratorCollection(
int capacity
);

Parameters

capacity
The number of elements that the new DeclaratorCollection is initially capable of storing.

See Also

DeclaratorCollection Class | DDW.CSharp.Dom Namespace | DeclaratorCollection Constructor Overload List


DeclaratorCollection Constructor (DeclaratorCollection)

Initializes a new instance of the DeclaratorCollection class that contains elements copied from the specified DeclaratorCollection.

public DeclaratorCollection(
DeclaratorCollection c
);

Parameters

c
The DeclaratorCollection whose elements are copied to the new collection.

See Also

DeclaratorCollection Class | DDW.CSharp.Dom Namespace | DeclaratorCollection Constructor Overload List


DeclaratorCollection Constructor (Declarator[])

Initializes a new instance of the DeclaratorCollection class that contains elements copied from the specified Declarator array.

public DeclaratorCollection(
Declarator[] a
);

Parameters

a
The Declarator array whose elements are copied to the new list.

See Also

DeclaratorCollection Class | DDW.CSharp.Dom Namespace | DeclaratorCollection Constructor Overload List


DeclaratorCollection Constructor (Tag)

protected DeclaratorCollection(
Tag t
);

See Also

DeclaratorCollection Class | DDW.CSharp.Dom Namespace | DeclaratorCollection Constructor Overload List


DeclaratorCollection Properties

The properties of the DeclaratorCollection class are listed below. For a complete list of DeclaratorCollection class members, see the DeclaratorCollection Members topic.

Public Instance Properties

Capacity | Gets or sets the number of elements the DeclaratorCollection can contain.
Count | Gets the number of elements actually contained in the DeclaratorCollection.
GraphType |
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the Declarator at the specified index.
LinePragma (inherited from CSharpGraph) |
SyncRoot | Gets an object that can be used to synchronize access to the collection.
Text |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

DeclaratorCollection Class | DDW.CSharp.Dom Namespace


Capacity Property

Goblin - A Platform for 3D AR and VR Applications

DeclaratorCollection.Capacity Property

Gets or sets the number of elements the DeclaratorCollection can contain.

public virtual int Capacity {get; set;}

See Also

DeclaratorCollection Class | DDW.CSharp.Dom Namespace


Count Property

Goblin - A Platform for 3D AR and VR Applications

DeclaratorCollection.Count Property

Gets the number of elements actually contained in the DeclaratorCollection.

public virtual int Count {get;}

Implements

ICollection.Count

See Also

DeclaratorCollection Class | DDW.CSharp.Dom Namespace


GraphType Property

Goblin - A Platform for 3D AR and VR Applications

DeclaratorCollection.GraphType Property

public override GraphTypes GraphType {get;}

Implements

IGraph.GraphType

See Also

DeclaratorCollection Class | DDW.CSharp.Dom Namespace


IsFixedSize Property

Goblin - A Platform for 3D AR and VR Applications

DeclaratorCollection.IsFixedSize Property

Gets a value indicating whether the collection has a fixed size.

public virtual bool IsFixedSize {get;}

Property Value

true if the collection has a fixed size; otherwise, false. The default is false

Implements

IList.IsFixedSize

See Also

DeclaratorCollection Class | DDW.CSharp.Dom Namespace


IsReadOnly Property

Goblin - A Platform for 3D AR and VR Applications

DeclaratorCollection.IsReadOnly Property

gets a value indicating whether the IList is read-only.

public virtual bool IsReadOnly {get;}

Property Value

true if the collection is read-only; otherwise, false. The default is false

Implements

IList.IsReadOnly

See Also

DeclaratorCollection Class | DDW.CSharp.Dom Namespace


IsSynchronized Property

Goblin - A Platform for 3D AR and VR Applications

DeclaratorCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread-safe).

public virtual bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

DeclaratorCollection Class | DDW.CSharp.Dom Namespace


Item Property

Goblin - A Platform for 3D AR and VR Applications

DeclaratorCollection.Item Property

Gets or sets the Declarator at the specified index.

public virtual Declarator this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

DeclaratorCollection Class | DDW.CSharp.Dom Namespace


SyncRoot Property

Goblin - A Platform for 3D AR and VR Applications

DeclaratorCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

public virtual object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

DeclaratorCollection Class | DDW.CSharp.Dom Namespace


Text Property

Goblin - A Platform for 3D AR and VR Applications

DeclaratorCollection.Text Property

public override string Text {get;}

Implements

IGraph.Text

See Also

DeclaratorCollection Class | DDW.CSharp.Dom Namespace


DeclaratorCollection Methods

The methods of the DeclaratorCollection class are listed below. For a complete list of DeclaratorCollection class members, see the DeclaratorCollection Members topic.

Public Static Methods

ReadOnly | Creates a read-only wrapper for a DeclaratorCollection instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a DeclaratorCollection instance.

Public Instance Methods

Add | Adds a Declarator to the end of the DeclaratorCollection.
AddRange | Overloaded. Adds the elements of a Declarator array to the current DeclaratorCollection.
Clear | Removes all elements from the DeclaratorCollection.
Clone | Creates a shallow copy of the DeclaratorCollection.
Contains | Determines whether a given Declarator is in the DeclaratorCollection.
CopyTo | Overloaded. Copies the entire DeclaratorCollection to a one-dimensional Declarator array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the DeclaratorCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the zero-based index of the first occurrence of a Declarator in the DeclaratorCollection.
Insert | Inserts an element into the DeclaratorCollection at the specified index.
Remove | Removes the first occurrence of a specific Declarator from the DeclaratorCollection.
RemoveAt | Removes the element at the specified index of the DeclaratorCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DeclaratorCollection Class | DDW.CSharp.Dom Namespace


DeclaratorCollection.Add Method

Adds a Declarator to the end of the DeclaratorCollection.

public virtual int Add(
Declarator item
);

Parameters

item
The Declarator to be added to the end of the DeclaratorCollection.

Return Value

The index at which the value has been added.

See Also

DeclaratorCollection Class | DDW.CSharp.Dom Namespace


AddRange Method

Goblin - A Platform for 3D AR and VR Applications

DeclaratorCollection.AddRange Method

Adds the elements of a Declarator array to the current DeclaratorCollection.

Overload List

Adds the elements of a Declarator array to the current DeclaratorCollection.

public virtual int AddRange(Declarator[]);

Adds the elements of another DeclaratorCollection to the current DeclaratorCollection.

public virtual int AddRange(DeclaratorCollection);

See Also

DeclaratorCollection Class | DDW.CSharp.Dom Namespace


DeclaratorCollection.AddRange Method (Declarator[])

Adds the elements of a Declarator array to the current DeclaratorCollection.

public virtual int AddRange(
Declarator[] x
);

Parameters

x
The Declarator array whose elements should be added to the end of the DeclaratorCollection.

Return Value

The new Count of the DeclaratorCollection.

See Also

DeclaratorCollection Class | DDW.CSharp.Dom Namespace | DeclaratorCollection.AddRange Overload List


DeclaratorCollection.AddRange Method (DeclaratorCollection)

Adds the elements of another DeclaratorCollection to the current DeclaratorCollection.

public virtual int AddRange(
DeclaratorCollection x
);

Parameters

x
The DeclaratorCollection whose elements should be added to the end of the current DeclaratorCollection.

Return Value

The new Count of the DeclaratorCollection.

See Also

DeclaratorCollection Class | DDW.CSharp.Dom Namespace | DeclaratorCollection.AddRange Overload List


DeclaratorCollection.Clear Method

Removes all elements from the DeclaratorCollection.

public virtual void Clear();

Implements

IList.Clear

See Also

DeclaratorCollection Class | DDW.CSharp.Dom Namespace


DeclaratorCollection.Clone Method

Creates a shallow copy of the DeclaratorCollection.

public virtual object Clone();

Implements

ICloneable.Clone

See Also

DeclaratorCollection Class | DDW.CSharp.Dom Namespace


DeclaratorCollection.Contains Method

Determines whether a given Declarator is in the DeclaratorCollection.

public virtual bool Contains(
Declarator item
);

Parameters

item
The Declarator to check for.

Return Value

true if item is found in the DeclaratorCollection; otherwise, false.

See Also

DeclaratorCollection Class | DDW.CSharp.Dom Namespace


CopyTo Method

Goblin - A Platform for 3D AR and VR Applications

DeclaratorCollection.CopyTo Method

Copies the entire DeclaratorCollection to a one-dimensional Declarator array.

Overload List

Copies the entire DeclaratorCollection to a one-dimensional Declarator array.

public virtual void CopyTo(Declarator[]);

Copies the entire DeclaratorCollection to a one-dimensional Declarator array, starting at the specified index of the target array.

public virtual void CopyTo(Declarator[],int);

See Also

DeclaratorCollection Class | DDW.CSharp.Dom Namespace


DeclaratorCollection.CopyTo Method (Declarator[])

Copies the entire DeclaratorCollection to a one-dimensional Declarator array.

public virtual void CopyTo(
Declarator[] array
);

Parameters

array
The one-dimensional Declarator array to copy to.

See Also

DeclaratorCollection Class | DDW.CSharp.Dom Namespace | DeclaratorCollection.CopyTo Overload List


DeclaratorCollection.CopyTo Method (Declarator[], Int32)

Copies the entire DeclaratorCollection to a one-dimensional Declarator array, starting at the specified index of the target array.

public virtual void CopyTo(
Declarator[] array,
int start
);

Parameters

array
The one-dimensional Declarator array to copy to.
start
The zero-based index in array at which copying begins.

See Also

DeclaratorCollection Class | DDW.CSharp.Dom Namespace | DeclaratorCollection.CopyTo Overload List


DeclaratorCollection.GetEnumerator Method

Returns an enumerator that can iterate through the DeclaratorCollection.

public virtual IDeclaratorCollectionEnumerator GetEnumerator();

Return Value

An Enumerator for the entire DeclaratorCollection.

See Also

DeclaratorCollection Class | DDW.CSharp.Dom Namespace


DeclaratorCollection.IndexOf Method

Returns the zero-based index of the first occurrence of a Declarator in the DeclaratorCollection.

public virtual int IndexOf(
Declarator item
);

Parameters

item
The Declarator to locate in the DeclaratorCollection.

Return Value

The zero-based index of the first occurrence of item in the entire DeclaratorCollection, if found; otherwise, -1.

See Also

DeclaratorCollection Class | DDW.CSharp.Dom Namespace


DeclaratorCollection.Insert Method

Inserts an element into the DeclaratorCollection at the specified index.

public virtual void Insert(
int index,
Declarator item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The Declarator to insert.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

DeclaratorCollection Class | DDW.CSharp.Dom Namespace


DeclaratorCollection.ReadOnly Method

Creates a read-only wrapper for a DeclaratorCollection instance.

public static DeclaratorCollection ReadOnly(
DeclaratorCollection list
);

Return Value

An DeclaratorCollection wrapper that is read-only.

See Also

DeclaratorCollection Class | DDW.CSharp.Dom Namespace


DeclaratorCollection.Remove Method

Removes the first occurrence of a specific Declarator from the DeclaratorCollection.

public virtual void Remove(
Declarator item
);

Parameters

item
The Declarator to remove from the DeclaratorCollection.

Exceptions

Exception Type | Condition
ArgumentException | The specified Declarator was not found in the DeclaratorCollection.

See Also

DeclaratorCollection Class | DDW.CSharp.Dom Namespace


DeclaratorCollection.RemoveAt Method

Removes the element at the specified index of the DeclaratorCollection.

public virtual void RemoveAt(
int index
);

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

DeclaratorCollection Class | DDW.CSharp.Dom Namespace


DeclaratorCollection.Synchronized Method

Creates a synchronized (thread-safe) wrapper for a DeclaratorCollection instance.

public static DeclaratorCollection Synchronized(
DeclaratorCollection list
);

Return Value

An DeclaratorCollection wrapper that is synchronized (thread-safe).

See Also

DeclaratorCollection Class | DDW.CSharp.Dom Namespace


DeclaratorCollection.TrimToSize Method

Sets the capacity to the actual number of elements.

public virtual void TrimToSize();

See Also

DeclaratorCollection Class | DDW.CSharp.Dom Namespace


DeclaratorCollection.IDeclaratorCollectionEnumerator Interface

Supports type-safe iteration over a DeclaratorCollection.

For a list of all members of this type, see DeclaratorCollection.IDeclaratorCollectionEnumerator Members.

public interface DeclaratorCollection.IDeclaratorCollectionEnumerator

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

DeclaratorCollection.IDeclaratorCollectionEnumerator Members | DDW.CSharp.Dom Namespace


DeclaratorCollection.IDeclaratorCollectionEnumerator Members

DeclaratorCollection.IDeclaratorCollectionEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

DeclaratorCollection.IDeclaratorCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


DeclaratorCollection.IDeclaratorCollectionEnumerator Properties

The properties of the DeclaratorCollection.IDeclaratorCollectionEnumerator interface are listed below. For a complete list of DeclaratorCollection.IDeclaratorCollectionEnumerator interface members, see the DeclaratorCollection.IDeclaratorCollectionEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

DeclaratorCollection.IDeclaratorCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


Current Property

Goblin - A Platform for 3D AR and VR Applications

DeclaratorCollection.IDeclaratorCollectionEnumerator.Current Property

Gets the current element in the collection.

Declarator Current {get;}

See Also

DeclaratorCollection.IDeclaratorCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


DeclaratorCollection.IDeclaratorCollectionEnumerator Methods

The methods of the DeclaratorCollection.IDeclaratorCollectionEnumerator interface are listed below. For a complete list of DeclaratorCollection.IDeclaratorCollectionEnumerator interface members, see the DeclaratorCollection.IDeclaratorCollectionEnumerator Members topic.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

DeclaratorCollection.IDeclaratorCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


DeclaratorCollection.IDeclaratorCollectionEnumerator.MoveNext Method

Advances the enumerator to the next element in the collection.

bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Exceptions

Exception Type | Condition
InvalidOperationException | The collection was modified after the enumerator was created.

See Also

DeclaratorCollection.IDeclaratorCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


DeclaratorCollection.IDeclaratorCollectionEnumerator.Reset Method

Sets the enumerator to its initial position, before the first element in the collection.

void Reset();

See Also

DeclaratorCollection.IDeclaratorCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


DeclaratorCollection.Tag Enumeration

protected enum DeclaratorCollection.Tag

Members

Member Name | Description
Default |

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

DDW.CSharp.Dom Namespace


DelegateDecl Class

A delegate declartation.

For a list of all members of this type, see DelegateDecl Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.MemberDecl
DDW.CSharp.Dom.TypeDecl
DDW.CSharp.Dom.DelegateDecl

public class DelegateDecl : TypeDecl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

DelegateDecl Members | DDW.CSharp.Dom Namespace


DelegateDecl Members

DelegateDecl overview

Public Instance Constructors

DelegateDecl Constructor Initializes a new instance of the DelegateDecl class.

Public Instance Properties

Attributes (inherited from MemberDecl) | Gets or sets the modifier flags for this member (public, private etc).
BaseTypes (inherited from TypeDecl) | Gets or sets the base types that are inherited by this type.
Comments (inherited from MemberDecl) | Gets the collection of comments for this member.
CustomAttributes (inherited from MemberDecl) | Gets the collection of Custom Attributes used for this member (custom attributes are the ones declared between brackets, like [Flags]).
Definition (inherited from TypeDecl) | Gets the (scoped) definition.
LinePragma (inherited from CSharpGraph) |
MemberKind (inherited from TypeDecl) |
Members (inherited from TypeDecl) | Gets a collection of type members in the current type (methods, fields etc.).
Name (inherited from TypeDecl) |
Parameters | Gets the collection of parameters for the delegate. Each of these hold information about the type, direction etc.
ReturnType | Gets or sets the return type of the delegate.
TypeAttributes (inherited from TypeDecl) | Gets or sets the modifiers for the type (public, sealed etc). These values can be or'ed with each other. This was derived from the CodeDom, it may be changed for something more suitable.
TypeKind |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

DistanceToType |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
VerifyModifiers (inherited from MemberDecl) |

See Also

DelegateDecl Class | DDW.CSharp.Dom Namespace


DelegateDecl Constructor

Initializes a new instance of the DelegateDecl class.

public DelegateDecl();

See Also

DelegateDecl Class | DDW.CSharp.Dom Namespace


DelegateDecl Properties

The properties of the DelegateDecl class are listed below. For a complete list of DelegateDecl class members, see the DelegateDecl Members topic.

Public Instance Properties

Attributes (inherited from MemberDecl) | Gets or sets the modifier flags for this member (public, private etc).
BaseTypes (inherited from TypeDecl) | Gets or sets the base types that are inherited by this type.
Comments (inherited from MemberDecl) | Gets the collection of comments for this member.
CustomAttributes (inherited from MemberDecl) | Gets the collection of Custom Attributes used for this member (custom attributes are the ones declared between brackets, like [Flags]).
Definition (inherited from TypeDecl) | Gets the (scoped) definition.
LinePragma (inherited from CSharpGraph) |
MemberKind (inherited from TypeDecl) |
Members (inherited from TypeDecl) | Gets a collection of type members in the current type (methods, fields etc.).
Name (inherited from TypeDecl) |
Parameters | Gets the collection of parameters for the delegate. Each of these hold information about the type, direction etc.
ReturnType | Gets or sets the return type of the delegate.
TypeAttributes (inherited from TypeDecl) | Gets or sets the modifiers for the type (public, sealed etc). These values can be or'ed with each other. This was derived from the CodeDom, it may be changed for something more suitable.
TypeKind |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

DelegateDecl Class | DDW.CSharp.Dom Namespace


Parameters Property

Goblin - A Platform for 3D AR and VR Applications

DelegateDecl.Parameters Property

Gets the collection of parameters for the delegate. Each of these hold information about the type, direction etc.

public ParamDeclCollection Parameters {get;}

See Also

DelegateDecl Class | DDW.CSharp.Dom Namespace


ReturnType Property

Goblin - A Platform for 3D AR and VR Applications

DelegateDecl.ReturnType Property

Gets or sets the return type of the delegate.

public TypeRef ReturnType {get; set;}

See Also

DelegateDecl Class | DDW.CSharp.Dom Namespace


TypeKind Property

Goblin - A Platform for 3D AR and VR Applications

DelegateDecl.TypeKind Property

public override TypeKind TypeKind {get;}

See Also

DelegateDecl Class | DDW.CSharp.Dom Namespace


DelegateDecl Methods

The methods of the DelegateDecl class are listed below. For a complete list of DelegateDecl class members, see the DelegateDecl Members topic.

Public Instance Methods

DistanceToType |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
VerifyModifiers (inherited from MemberDecl) |

See Also

DelegateDecl Class | DDW.CSharp.Dom Namespace


DelegateDecl.DistanceToType Method

public override int DistanceToType(
IDefinition baseType,
int distance
);

See Also

DelegateDecl Class | DDW.CSharp.Dom Namespace


DelegateInvokeExpr Class

Invokes a delegate.

For a list of all members of this type, see DelegateInvokeExpr Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Expression
DDW.CSharp.Dom.DelegateInvokeExpr

public class DelegateInvokeExpr : Expression

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

DelegateInvokeExpr Members | DDW.CSharp.Dom Namespace


DelegateInvokeExpr Members

DelegateInvokeExpr overview

Public Instance Constructors

DelegateInvokeExpr Constructor Initializes a new instance of the DelegateInvokeExpr class.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
Parameters | Gets the collection of parameters to be passed to the invoked method.
Target | Gets or sets a reference to the delegate being invoked.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DelegateInvokeExpr Class | DDW.CSharp.Dom Namespace


DelegateInvokeExpr Constructor

Initializes a new instance of the DelegateInvokeExpr class.

public DelegateInvokeExpr();

See Also

DelegateInvokeExpr Class | DDW.CSharp.Dom Namespace


DelegateInvokeExpr Properties

The properties of the DelegateInvokeExpr class are listed below. For a complete list of DelegateInvokeExpr class members, see the DelegateInvokeExpr Members topic.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
Parameters | Gets the collection of parameters to be passed to the invoked method.
Target | Gets or sets a reference to the delegate being invoked.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

DelegateInvokeExpr Class | DDW.CSharp.Dom Namespace


Parameters Property

Goblin - A Platform for 3D AR and VR Applications

DelegateInvokeExpr.Parameters Property

Gets the collection of parameters to be passed to the invoked method.

public ParamCollection Parameters {get;}

See Also

DelegateInvokeExpr Class | DDW.CSharp.Dom Namespace


Target Property

Goblin - A Platform for 3D AR and VR Applications

DelegateInvokeExpr.Target Property

Gets or sets a reference to the delegate being invoked.

public Expression Target {get; set;}

See Also

DelegateInvokeExpr Class | DDW.CSharp.Dom Namespace


DestructorDecl Class

A destructor declartation.

For a list of all members of this type, see DestructorDecl Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.MemberDecl
DDW.CSharp.Dom.DestructorDecl

public class DestructorDecl : MemberDecl, IDeclaration, IScope

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

DestructorDecl Members | DDW.CSharp.Dom Namespace


DestructorDecl Members

DestructorDecl overview

Public Instance Constructors

DestructorDecl Constructor Initializes a new instance of the DestructorDecl class.

Public Instance Properties

Attributes (inherited from MemberDecl) | Gets or sets the modifier flags for this member (public, private etc).
Comments (inherited from MemberDecl) | Gets the collection of comments for this member.
CustomAttributes (inherited from MemberDecl) | Gets the collection of Custom Attributes used for this member (custom attributes are the ones declared between brackets, like [Flags]).
Definition | Gets the (scoped) definition.
LinePragma (inherited from CSharpGraph) |
MemberKind |
Name | Gets or sets the name of the destructor. This does not include the tilde ('~') character, so it matches the class name.
Scope |
Statements | Gets the collection of statements in the destructor.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
VerifyModifiers (inherited from MemberDecl) |

See Also

DestructorDecl Class | DDW.CSharp.Dom Namespace


DestructorDecl Constructor

Initializes a new instance of the DestructorDecl class.

public DestructorDecl();

See Also

DestructorDecl Class | DDW.CSharp.Dom Namespace


DestructorDecl Properties

The properties of the DestructorDecl class are listed below. For a complete list of DestructorDecl class members, see the DestructorDecl Members topic.

Public Instance Properties

Attributes (inherited from MemberDecl) | Gets or sets the modifier flags for this member (public, private etc).
Comments (inherited from MemberDecl) | Gets the collection of comments for this member.
CustomAttributes (inherited from MemberDecl) | Gets the collection of Custom Attributes used for this member (custom attributes are the ones declared between brackets, like [Flags]).
Definition | Gets the (scoped) definition.
LinePragma (inherited from CSharpGraph) |
MemberKind |
Name | Gets or sets the name of the destructor. This does not include the tilde ('~') character, so it matches the class name.
Scope |
Statements | Gets the collection of statements in the destructor.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

DestructorDecl Class | DDW.CSharp.Dom Namespace


Definition Property

Goblin - A Platform for 3D AR and VR Applications

DestructorDecl.Definition Property

Gets the (scoped) definition.

public DDW.CSharp.SymbolTable.IDefinition Definition {get;}

Implements

IDeclaration.Definition

See Also

DestructorDecl Class | DDW.CSharp.Dom Namespace


MemberKind Property

Goblin - A Platform for 3D AR and VR Applications

DestructorDecl.MemberKind Property

public override MemberKind MemberKind {get;}

See Also

DestructorDecl Class | DDW.CSharp.Dom Namespace


Name Property

Goblin - A Platform for 3D AR and VR Applications

DestructorDecl.Name Property

Gets or sets the name of the destructor. This does not include the tilde ('~') character, so it matches the class name.

public string Name {get; set;}

See Also

DestructorDecl Class | DDW.CSharp.Dom Namespace


Scope Property

Goblin - A Platform for 3D AR and VR Applications

DestructorDecl.Scope Property

public DDW.CSharp.SymbolTable.Scope Scope {get; set;}

Implements

IScope.Scope

See Also

DestructorDecl Class | DDW.CSharp.Dom Namespace


Statements Property

Goblin - A Platform for 3D AR and VR Applications

DestructorDecl.Statements Property

Gets the collection of statements in the destructor.

public StatementCollection Statements {get;}

See Also

DestructorDecl Class | DDW.CSharp.Dom Namespace


EnumDecl Class

An enum declartation.

For a list of all members of this type, see EnumDecl Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.MemberDecl
DDW.CSharp.Dom.TypeDecl
DDW.CSharp.Dom.EnumDecl

public class EnumDecl : TypeDecl, IScope

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

EnumDecl Members | DDW.CSharp.Dom Namespace


EnumDecl Members

EnumDecl overview

Public Instance Constructors

EnumDecl Constructor Initializes a new instance of the EnumDecl class.

Public Instance Properties

Attributes (inherited from MemberDecl) | Gets or sets the modifier flags for this member (public, private etc).
BaseTypes (inherited from TypeDecl) | Gets or sets the base types that are inherited by this type.
Comments (inherited from MemberDecl) | Gets the collection of comments for this member.
CustomAttributes (inherited from MemberDecl) | Gets the collection of Custom Attributes used for this member (custom attributes are the ones declared between brackets, like [Flags]).
Definition (inherited from TypeDecl) | Gets the (scoped) definition.
LinePragma (inherited from CSharpGraph) |
MemberKind (inherited from TypeDecl) |
Members (inherited from TypeDecl) | Gets a collection of type members in the current type (methods, fields etc.).
Name (inherited from TypeDecl) |
Scope |
TypeAttributes (inherited from TypeDecl) | Gets or sets the modifiers for the type (public, sealed etc). These values can be or'ed with each other. This was derived from the CodeDom, it may be changed for something more suitable.
TypeKind |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

DistanceToType |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
VerifyModifiers (inherited from MemberDecl) |

See Also

EnumDecl Class | DDW.CSharp.Dom Namespace


EnumDecl Constructor

Initializes a new instance of the EnumDecl class.

public EnumDecl();

See Also

EnumDecl Class | DDW.CSharp.Dom Namespace


EnumDecl Properties

The properties of the EnumDecl class are listed below. For a complete list of EnumDecl class members, see the EnumDecl Members topic.

Public Instance Properties

Attributes (inherited from MemberDecl) | Gets or sets the modifier flags for this member (public, private etc).
BaseTypes (inherited from TypeDecl) | Gets or sets the base types that are inherited by this type.
Comments (inherited from MemberDecl) | Gets the collection of comments for this member.
CustomAttributes (inherited from MemberDecl) | Gets the collection of Custom Attributes used for this member (custom attributes are the ones declared between brackets, like [Flags]).
Definition (inherited from TypeDecl) | Gets the (scoped) definition.
LinePragma (inherited from CSharpGraph) |
MemberKind (inherited from TypeDecl) |
Members (inherited from TypeDecl) | Gets a collection of type members in the current type (methods, fields etc.).
Name (inherited from TypeDecl) |
Scope |
TypeAttributes (inherited from TypeDecl) | Gets or sets the modifiers for the type (public, sealed etc). These values can be or'ed with each other. This was derived from the CodeDom, it may be changed for something more suitable.
TypeKind |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

EnumDecl Class | DDW.CSharp.Dom Namespace


Scope Property

Goblin - A Platform for 3D AR and VR Applications

EnumDecl.Scope Property

public DDW.CSharp.SymbolTable.Scope Scope {get; set;}

Implements

IScope.Scope

See Also

EnumDecl Class | DDW.CSharp.Dom Namespace


TypeKind Property

Goblin - A Platform for 3D AR and VR Applications

EnumDecl.TypeKind Property

public override TypeKind TypeKind {get;}

See Also

EnumDecl Class | DDW.CSharp.Dom Namespace


EnumDecl Methods

The methods of the EnumDecl class are listed below. For a complete list of EnumDecl class members, see the EnumDecl Members topic.

Public Instance Methods

DistanceToType |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
VerifyModifiers (inherited from MemberDecl) |

See Also

EnumDecl Class | DDW.CSharp.Dom Namespace


EnumDecl.DistanceToType Method

public override int DistanceToType(
IDefinition baseType,
int distance
);

See Also

EnumDecl Class | DDW.CSharp.Dom Namespace


EnumMemberDecl Class

An enum declartation.

For a list of all members of this type, see EnumMemberDecl Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.MemberDecl
DDW.CSharp.Dom.EnumMemberDecl

public class EnumMemberDecl : MemberDecl, IDeclaration

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

EnumMemberDecl Members | DDW.CSharp.Dom Namespace


EnumMemberDecl Members

EnumMemberDecl overview

Public Instance Constructors

EnumMemberDecl Constructor Initializes a new instance of the EnumMemberDecl class.

Public Instance Properties

Attributes (inherited from MemberDecl) | Gets or sets the modifier flags for this member (public, private etc).
Comments (inherited from MemberDecl) | Gets the collection of comments for this member.
CustomAttributes (inherited from MemberDecl) | Gets the collection of Custom Attributes used for this member (custom attributes are the ones declared between brackets, like [Flags]).
Definition | Gets the (scoped) definition.
LinePragma (inherited from CSharpGraph) |
MemberKind |
Name | Gets or sets the name of the enum.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.
Value | Gets or sets the value of the enum member, if specified.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
VerifyModifiers (inherited from MemberDecl) |

See Also

EnumMemberDecl Class | DDW.CSharp.Dom Namespace


EnumMemberDecl Constructor

Initializes a new instance of the EnumMemberDecl class.

public EnumMemberDecl();

See Also

EnumMemberDecl Class | DDW.CSharp.Dom Namespace


EnumMemberDecl Properties

The properties of the EnumMemberDecl class are listed below. For a complete list of EnumMemberDecl class members, see the EnumMemberDecl Members topic.

Public Instance Properties

Attributes (inherited from MemberDecl) | Gets or sets the modifier flags for this member (public, private etc).
Comments (inherited from MemberDecl) | Gets the collection of comments for this member.
CustomAttributes (inherited from MemberDecl) | Gets the collection of Custom Attributes used for this member (custom attributes are the ones declared between brackets, like [Flags]).
Definition | Gets the (scoped) definition.
LinePragma (inherited from CSharpGraph) |
MemberKind |
Name | Gets or sets the name of the enum.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.
Value | Gets or sets the value of the enum member, if specified.

See Also

EnumMemberDecl Class | DDW.CSharp.Dom Namespace


Definition Property

Goblin - A Platform for 3D AR and VR Applications

EnumMemberDecl.Definition Property

Gets the (scoped) definition.

public DDW.CSharp.SymbolTable.IDefinition Definition {get;}

Implements

IDeclaration.Definition

See Also

EnumMemberDecl Class | DDW.CSharp.Dom Namespace


MemberKind Property

Goblin - A Platform for 3D AR and VR Applications

EnumMemberDecl.MemberKind Property

public override MemberKind MemberKind {get;}

See Also

EnumMemberDecl Class | DDW.CSharp.Dom Namespace


Name Property

Goblin - A Platform for 3D AR and VR Applications

EnumMemberDecl.Name Property

Gets or sets the name of the enum.

public string Name {get; set;}

See Also

EnumMemberDecl Class | DDW.CSharp.Dom Namespace


Value Property

Goblin - A Platform for 3D AR and VR Applications

EnumMemberDecl.Value Property

Gets or sets the value of the enum member, if specified.

public Expression Value {get; set;}

See Also

EnumMemberDecl Class | DDW.CSharp.Dom Namespace


EventDecl Class

An event declaration.

For a list of all members of this type, see EventDecl Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.MemberDecl
DDW.CSharp.Dom.EventDecl

public class EventDecl : MemberDecl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

EventDecl Members | DDW.CSharp.Dom Namespace


EventDecl Members

EventDecl overview

Public Instance Constructors

EventDecl Constructor Initializes a new instance of the EventDecl class.

Public Instance Properties

AddAccessor | Gets or sets the 'add' accessor for this property, if present. It is an error to have an add accessor without a remove accessor. This will not have an associated block if the property is declared as abstract or in an interface.
Attributes (inherited from MemberDecl) | Gets or sets the modifier flags for this member (public, private etc).
Comments (inherited from MemberDecl) | Gets the collection of comments for this member.
CustomAttributes (inherited from MemberDecl) | Gets the collection of Custom Attributes used for this member (custom attributes are the ones declared between brackets, like [Flags]).
Delcarators | Gets a declarator collection. Events can declare multiple variables (like fields) if no accessors are present, so this must be a collection. If accessors are present, the name will be stored in the first declarator, however in this case it may have an interface name prepended - thus it may be in dot syntax. The declarator expression is always ignored.
LinePragma (inherited from CSharpGraph) |
MemberKind |
RemoveAccessor | Gets or sets the 'remove' accessor for this property, if present. It is an error to have an add accessor without a remove accessor. This will not have an associated block if the property is declared as abstract or in an interface.
Type | Gets or sets the type of the event. This must be a delegate type.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.
UsesAccessors | Gets or sets the boolean value that indicates whether accessors are to be used. Setting this to false will not destroy the accessor values.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
VerifyModifiers (inherited from MemberDecl) |

See Also

EventDecl Class | DDW.CSharp.Dom Namespace


EventDecl Constructor

Initializes a new instance of the EventDecl class.

public EventDecl();

See Also

EventDecl Class | DDW.CSharp.Dom Namespace


EventDecl Properties

The properties of the EventDecl class are listed below. For a complete list of EventDecl class members, see the EventDecl Members topic.

Public Instance Properties

AddAccessor | Gets or sets the 'add' accessor for this property, if present. It is an error to have an add accessor without a remove accessor. This will not have an associated block if the property is declared as abstract or in an interface.
Attributes (inherited from MemberDecl) | Gets or sets the modifier flags for this member (public, private etc).
Comments (inherited from MemberDecl) | Gets the collection of comments for this member.
CustomAttributes (inherited from MemberDecl) | Gets the collection of Custom Attributes used for this member (custom attributes are the ones declared between brackets, like [Flags]).
Delcarators | Gets a declarator collection. Events can declare multiple variables (like fields) if no accessors are present, so this must be a collection. If accessors are present, the name will be stored in the first declarator, however in this case it may have an interface name prepended - thus it may be in dot syntax. The declarator expression is always ignored.
LinePragma (inherited from CSharpGraph) |
MemberKind |
RemoveAccessor | Gets or sets the 'remove' accessor for this property, if present. It is an error to have an add accessor without a remove accessor. This will not have an associated block if the property is declared as abstract or in an interface.
Type | Gets or sets the type of the event. This must be a delegate type.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.
UsesAccessors | Gets or sets the boolean value that indicates whether accessors are to be used. Setting this to false will not destroy the accessor values.

See Also

EventDecl Class | DDW.CSharp.Dom Namespace


AddAccessor Property

Goblin - A Platform for 3D AR and VR Applications

EventDecl.AddAccessor Property

Gets or sets the 'add' accessor for this property, if present. It is an error to have an add accessor without a remove accessor. This will not have an associated block if the property is declared as abstract or in an interface.

public AccessorDecl AddAccessor {get; set;}

See Also

EventDecl Class | DDW.CSharp.Dom Namespace


Delcarators Property

Goblin - A Platform for 3D AR and VR Applications

EventDecl.Delcarators Property

Gets a declarator collection. Events can declare multiple variables (like fields) if no accessors are present, so this must be a collection. If accessors are present, the name will be stored in the first declarator, however in this case it may have an interface name prepended - thus it may be in dot syntax. The declarator expression is always ignored.

public DeclaratorCollection Delcarators {get;}

See Also

EventDecl Class | DDW.CSharp.Dom Namespace


MemberKind Property

Goblin - A Platform for 3D AR and VR Applications

EventDecl.MemberKind Property

public override MemberKind MemberKind {get;}

See Also

EventDecl Class | DDW.CSharp.Dom Namespace


RemoveAccessor Property

Goblin - A Platform for 3D AR and VR Applications

EventDecl.RemoveAccessor Property

Gets or sets the 'remove' accessor for this property, if present. It is an error to have an add accessor without a remove accessor. This will not have an associated block if the property is declared as abstract or in an interface.

public AccessorDecl RemoveAccessor {get; set;}

See Also

EventDecl Class | DDW.CSharp.Dom Namespace


Type Property

Goblin - A Platform for 3D AR and VR Applications

EventDecl.Type Property

Gets or sets the type of the event. This must be a delegate type.

public TypeRef Type {get; set;}

See Also

EventDecl Class | DDW.CSharp.Dom Namespace


UsesAccessors Property

Goblin - A Platform for 3D AR and VR Applications

EventDecl.UsesAccessors Property

Gets or sets the boolean value that indicates whether accessors are to be used. Setting this to false will not destroy the accessor values.

public bool UsesAccessors {get; set;}

See Also

EventDecl Class | DDW.CSharp.Dom Namespace


EventRef Class

A reference to an event.

For a list of all members of this type, see EventRef Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Expression
DDW.CSharp.Dom.Reference
DDW.CSharp.Dom.EventRef

public class EventRef : Reference

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

EventRef Members | DDW.CSharp.Dom Namespace


EventRef Members

EventRef overview

Public Instance Constructors

EventRef Constructor Initializes a new instance of the EventRef class.

Public Instance Properties

EventName | Gets or sets the name of the event.
LinePragma (inherited from CSharpGraph) |
Target | Gets or sets the target object to which the event belongs.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EventRef Class | DDW.CSharp.Dom Namespace


EventRef Constructor

Initializes a new instance of the EventRef class.

public EventRef();

See Also

EventRef Class | DDW.CSharp.Dom Namespace


EventRef Properties

The properties of the EventRef class are listed below. For a complete list of EventRef class members, see the EventRef Members topic.

Public Instance Properties

EventName | Gets or sets the name of the event.
LinePragma (inherited from CSharpGraph) |
Target | Gets or sets the target object to which the event belongs.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

EventRef Class | DDW.CSharp.Dom Namespace


EventName Property

Goblin - A Platform for 3D AR and VR Applications

EventRef.EventName Property

Gets or sets the name of the event.

public string EventName {get; set;}

See Also

EventRef Class | DDW.CSharp.Dom Namespace


Target Property

Goblin - A Platform for 3D AR and VR Applications

EventRef.Target Property

Gets or sets the target object to which the event belongs.

public Expression Target {get; set;}

See Also

EventRef Class | DDW.CSharp.Dom Namespace


Expression Class

An abstract base class for expressions.

For a list of all members of this type, see Expression Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Expression
Derived types

public abstract class Expression : CSharpGraph

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

Expression Members | DDW.CSharp.Dom Namespace


Expression Members

Expression overview

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

Expression Constructor Initializes a new instance of the Expression class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Expression Class | DDW.CSharp.Dom Namespace


Expression Constructor

Initializes a new instance of the Expression class.

protected Expression();

See Also

Expression Class | DDW.CSharp.Dom Namespace


ExpressionCollection Class

A strongly-typed collection of Expression objects.

For a list of all members of this type, see ExpressionCollection Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.ExpressionCollection

public class ExpressionCollection : CSharpGraph, IList, ICollection, IEnumerable, ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

ExpressionCollection Members | DDW.CSharp.Dom Namespace


ExpressionCollection Members

ExpressionCollection overview

Public Static Methods

ReadOnly | Creates a read-only wrapper for a ExpressionCollection instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a ExpressionCollection instance.

Public Instance Constructors

ExpressionCollection Overloaded. Initializes a new instance of the ExpressionCollection class.

Public Instance Properties

Capacity | Gets or sets the number of elements the ExpressionCollection can contain.
Count | Gets the number of elements actually contained in the ExpressionCollection.
GraphType |
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the Expression at the specified index.
LinePragma (inherited from CSharpGraph) |
SyncRoot | Gets an object that can be used to synchronize access to the collection.
Text |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Add | Adds a Expression to the end of the ExpressionCollection.
AddRange | Overloaded. Adds the elements of a Expression array to the current ExpressionCollection.
Clear | Removes all elements from the ExpressionCollection.
Clone | Creates a shallow copy of the ExpressionCollection.
Contains | Determines whether a given Expression is in the ExpressionCollection.
CopyTo | Overloaded. Copies the entire ExpressionCollection to a one-dimensional Expression array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the ExpressionCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the zero-based index of the first occurrence of a Expression in the ExpressionCollection.
Insert | Inserts an element into the ExpressionCollection at the specified index.
Remove | Removes the first occurrence of a specific Expression from the ExpressionCollection.
RemoveAt | Removes the element at the specified index of the ExpressionCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Constructors

ExpressionCollection Overloaded. Initializes a new instance of the ExpressionCollection class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExpressionCollection Class | DDW.CSharp.Dom Namespace


ExpressionCollection Constructor

Initializes a new instance of the ExpressionCollection class that is empty and has the default initial capacity.

Overload List

Initializes a new instance of the ExpressionCollection class that is empty and has the default initial capacity.

public ExpressionCollection();

Initializes a new instance of the ExpressionCollection class that contains elements copied from the specified Expression array.

public ExpressionCollection(Expression[]);

Initializes a new instance of the ExpressionCollection class that contains elements copied from the specified ExpressionCollection.

public ExpressionCollection(ExpressionCollection);

protected ExpressionCollection(Tag);

Initializes a new instance of the ExpressionCollection class that has the specified initial capacity.

public ExpressionCollection(int);

See Also

ExpressionCollection Class | DDW.CSharp.Dom Namespace


ExpressionCollection Constructor ()

Initializes a new instance of the ExpressionCollection class that is empty and has the default initial capacity.

public ExpressionCollection();

See Also

ExpressionCollection Class | DDW.CSharp.Dom Namespace | ExpressionCollection Constructor Overload List


ExpressionCollection Constructor (Int32)

Initializes a new instance of the ExpressionCollection class that has the specified initial capacity.

public ExpressionCollection(
int capacity
);

Parameters

capacity
The number of elements that the new ExpressionCollection is initially capable of storing.

See Also

ExpressionCollection Class | DDW.CSharp.Dom Namespace | ExpressionCollection Constructor Overload List


ExpressionCollection Constructor (ExpressionCollection)

Initializes a new instance of the ExpressionCollection class that contains elements copied from the specified ExpressionCollection.

public ExpressionCollection(
ExpressionCollection c
);

Parameters

c
The ExpressionCollection whose elements are copied to the new collection.

See Also

ExpressionCollection Class | DDW.CSharp.Dom Namespace | ExpressionCollection Constructor Overload List


ExpressionCollection Constructor (Expression[])

Initializes a new instance of the ExpressionCollection class that contains elements copied from the specified Expression array.

public ExpressionCollection(
Expression[] a
);

Parameters

a
The Expression array whose elements are copied to the new list.

See Also

ExpressionCollection Class | DDW.CSharp.Dom Namespace | ExpressionCollection Constructor Overload List


ExpressionCollection Constructor (Tag)

protected ExpressionCollection(
Tag t
);

See Also

ExpressionCollection Class | DDW.CSharp.Dom Namespace | ExpressionCollection Constructor Overload List


ExpressionCollection Properties

The properties of the ExpressionCollection class are listed below. For a complete list of ExpressionCollection class members, see the ExpressionCollection Members topic.

Public Instance Properties

Capacity | Gets or sets the number of elements the ExpressionCollection can contain.
Count | Gets the number of elements actually contained in the ExpressionCollection.
GraphType |
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the Expression at the specified index.
LinePragma (inherited from CSharpGraph) |
SyncRoot | Gets an object that can be used to synchronize access to the collection.
Text |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

ExpressionCollection Class | DDW.CSharp.Dom Namespace


Capacity Property

Goblin - A Platform for 3D AR and VR Applications

ExpressionCollection.Capacity Property

Gets or sets the number of elements the ExpressionCollection can contain.

public virtual int Capacity {get; set;}

See Also

ExpressionCollection Class | DDW.CSharp.Dom Namespace


Count Property

Goblin - A Platform for 3D AR and VR Applications

ExpressionCollection.Count Property

Gets the number of elements actually contained in the ExpressionCollection.

public virtual int Count {get;}

Implements

ICollection.Count

See Also

ExpressionCollection Class | DDW.CSharp.Dom Namespace


GraphType Property

Goblin - A Platform for 3D AR and VR Applications

ExpressionCollection.GraphType Property

public override GraphTypes GraphType {get;}

Implements

IGraph.GraphType

See Also

ExpressionCollection Class | DDW.CSharp.Dom Namespace


IsFixedSize Property

Goblin - A Platform for 3D AR and VR Applications

ExpressionCollection.IsFixedSize Property

Gets a value indicating whether the collection has a fixed size.

public virtual bool IsFixedSize {get;}

Property Value

true if the collection has a fixed size; otherwise, false. The default is false

Implements

IList.IsFixedSize

See Also

ExpressionCollection Class | DDW.CSharp.Dom Namespace


IsReadOnly Property

Goblin - A Platform for 3D AR and VR Applications

ExpressionCollection.IsReadOnly Property

gets a value indicating whether the IList is read-only.

public virtual bool IsReadOnly {get;}

Property Value

true if the collection is read-only; otherwise, false. The default is false

Implements

IList.IsReadOnly

See Also

ExpressionCollection Class | DDW.CSharp.Dom Namespace


IsSynchronized Property

Goblin - A Platform for 3D AR and VR Applications

ExpressionCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread-safe).

public virtual bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

ExpressionCollection Class | DDW.CSharp.Dom Namespace


Item Property

Goblin - A Platform for 3D AR and VR Applications

ExpressionCollection.Item Property

Gets or sets the Expression at the specified index.

public virtual Expression this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

ExpressionCollection Class | DDW.CSharp.Dom Namespace


SyncRoot Property

Goblin - A Platform for 3D AR and VR Applications

ExpressionCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

public virtual object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

ExpressionCollection Class | DDW.CSharp.Dom Namespace


Text Property

Goblin - A Platform for 3D AR and VR Applications

ExpressionCollection.Text Property

public override string Text {get;}

Implements

IGraph.Text

See Also

ExpressionCollection Class | DDW.CSharp.Dom Namespace


ExpressionCollection Methods

The methods of the ExpressionCollection class are listed below. For a complete list of ExpressionCollection class members, see the ExpressionCollection Members topic.

Public Static Methods

ReadOnly | Creates a read-only wrapper for a ExpressionCollection instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a ExpressionCollection instance.

Public Instance Methods

Add | Adds a Expression to the end of the ExpressionCollection.
AddRange | Overloaded. Adds the elements of a Expression array to the current ExpressionCollection.
Clear | Removes all elements from the ExpressionCollection.
Clone | Creates a shallow copy of the ExpressionCollection.
Contains | Determines whether a given Expression is in the ExpressionCollection.
CopyTo | Overloaded. Copies the entire ExpressionCollection to a one-dimensional Expression array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the ExpressionCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the zero-based index of the first occurrence of a Expression in the ExpressionCollection.
Insert | Inserts an element into the ExpressionCollection at the specified index.
Remove | Removes the first occurrence of a specific Expression from the ExpressionCollection.
RemoveAt | Removes the element at the specified index of the ExpressionCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExpressionCollection Class | DDW.CSharp.Dom Namespace


ExpressionCollection.Add Method

Adds a Expression to the end of the ExpressionCollection.

public virtual int Add(
Expression item
);

Parameters

item
The Expression to be added to the end of the ExpressionCollection.

Return Value

The index at which the value has been added.

See Also

ExpressionCollection Class | DDW.CSharp.Dom Namespace


AddRange Method

Goblin - A Platform for 3D AR and VR Applications

ExpressionCollection.AddRange Method

Adds the elements of a Expression array to the current ExpressionCollection.

Overload List

Adds the elements of a Expression array to the current ExpressionCollection.

public virtual int AddRange(Expression[]);

Adds the elements of another ExpressionCollection to the current ExpressionCollection.

public virtual int AddRange(ExpressionCollection);

See Also

ExpressionCollection Class | DDW.CSharp.Dom Namespace


ExpressionCollection.AddRange Method (Expression[])

Adds the elements of a Expression array to the current ExpressionCollection.

public virtual int AddRange(
Expression[] x
);

Parameters

x
The Expression array whose elements should be added to the end of the ExpressionCollection.

Return Value

The new Count of the ExpressionCollection.

See Also

ExpressionCollection Class | DDW.CSharp.Dom Namespace | ExpressionCollection.AddRange Overload List


ExpressionCollection.AddRange Method (ExpressionCollection)

Adds the elements of another ExpressionCollection to the current ExpressionCollection.

public virtual int AddRange(
ExpressionCollection x
);

Parameters

x
The ExpressionCollection whose elements should be added to the end of the current ExpressionCollection.

Return Value

The new Count of the ExpressionCollection.

See Also

ExpressionCollection Class | DDW.CSharp.Dom Namespace | ExpressionCollection.AddRange Overload List


ExpressionCollection.Clear Method

Removes all elements from the ExpressionCollection.

public virtual void Clear();

Implements

IList.Clear

See Also

ExpressionCollection Class | DDW.CSharp.Dom Namespace


ExpressionCollection.Clone Method

Creates a shallow copy of the ExpressionCollection.

public virtual object Clone();

Implements

ICloneable.Clone

See Also

ExpressionCollection Class | DDW.CSharp.Dom Namespace


ExpressionCollection.Contains Method

Determines whether a given Expression is in the ExpressionCollection.

public virtual bool Contains(
Expression item
);

Parameters

item
The Expression to check for.

Return Value

true if item is found in the ExpressionCollection; otherwise, false.

See Also

ExpressionCollection Class | DDW.CSharp.Dom Namespace


CopyTo Method

Goblin - A Platform for 3D AR and VR Applications

ExpressionCollection.CopyTo Method

Copies the entire ExpressionCollection to a one-dimensional Expression array.

Overload List

Copies the entire ExpressionCollection to a one-dimensional Expression array.

public virtual void CopyTo(Expression[]);

Copies the entire ExpressionCollection to a one-dimensional Expression array, starting at the specified index of the target array.

public virtual void CopyTo(Expression[],int);

See Also

ExpressionCollection Class | DDW.CSharp.Dom Namespace


ExpressionCollection.CopyTo Method (Expression[])

Copies the entire ExpressionCollection to a one-dimensional Expression array.

public virtual void CopyTo(
Expression[] array
);

Parameters

array
The one-dimensional Expression array to copy to.

See Also

ExpressionCollection Class | DDW.CSharp.Dom Namespace | ExpressionCollection.CopyTo Overload List


ExpressionCollection.CopyTo Method (Expression[], Int32)

Copies the entire ExpressionCollection to a one-dimensional Expression array, starting at the specified index of the target array.

public virtual void CopyTo(
Expression[] array,
int start
);

Parameters

array
The one-dimensional Expression array to copy to.
start
The zero-based index in array at which copying begins.

See Also

ExpressionCollection Class | DDW.CSharp.Dom Namespace | ExpressionCollection.CopyTo Overload List


ExpressionCollection.GetEnumerator Method

Returns an enumerator that can iterate through the ExpressionCollection.

public virtual IExpressionCollectionEnumerator GetEnumerator();

Return Value

An Enumerator for the entire ExpressionCollection.

See Also

ExpressionCollection Class | DDW.CSharp.Dom Namespace


ExpressionCollection.IndexOf Method

Returns the zero-based index of the first occurrence of a Expression in the ExpressionCollection.

public virtual int IndexOf(
Expression item
);

Parameters

item
The Expression to locate in the ExpressionCollection.

Return Value

The zero-based index of the first occurrence of item in the entire ExpressionCollection, if found; otherwise, -1.

See Also

ExpressionCollection Class | DDW.CSharp.Dom Namespace


ExpressionCollection.Insert Method

Inserts an element into the ExpressionCollection at the specified index.

public virtual void Insert(
int index,
Expression item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The Expression to insert.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

ExpressionCollection Class | DDW.CSharp.Dom Namespace


ExpressionCollection.ReadOnly Method

Creates a read-only wrapper for a ExpressionCollection instance.

public static ExpressionCollection ReadOnly(
ExpressionCollection list
);

Return Value

An ExpressionCollection wrapper that is read-only.

See Also

ExpressionCollection Class | DDW.CSharp.Dom Namespace


ExpressionCollection.Remove Method

Removes the first occurrence of a specific Expression from the ExpressionCollection.

public virtual void Remove(
Expression item
);

Parameters

item
The Expression to remove from the ExpressionCollection.

Exceptions

Exception Type | Condition
ArgumentException | The specified Expression was not found in the ExpressionCollection.

See Also

ExpressionCollection Class | DDW.CSharp.Dom Namespace


ExpressionCollection.RemoveAt Method

Removes the element at the specified index of the ExpressionCollection.

public virtual void RemoveAt(
int index
);

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

ExpressionCollection Class | DDW.CSharp.Dom Namespace


ExpressionCollection.Synchronized Method

Creates a synchronized (thread-safe) wrapper for a ExpressionCollection instance.

public static ExpressionCollection Synchronized(
ExpressionCollection list
);

Return Value

An ExpressionCollection wrapper that is synchronized (thread-safe).

See Also

ExpressionCollection Class | DDW.CSharp.Dom Namespace


ExpressionCollection.TrimToSize Method

Sets the capacity to the actual number of elements.

public virtual void TrimToSize();

See Also

ExpressionCollection Class | DDW.CSharp.Dom Namespace


ExpressionCollection.IExpressionCollectionEnumerator Interface

Supports type-safe iteration over a ExpressionCollection.

For a list of all members of this type, see ExpressionCollection.IExpressionCollectionEnumerator Members.

public interface ExpressionCollection.IExpressionCollectionEnumerator

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

ExpressionCollection.IExpressionCollectionEnumerator Members | DDW.CSharp.Dom Namespace


ExpressionCollection.IExpressionCollectionEnumerator Members

ExpressionCollection.IExpressionCollectionEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

ExpressionCollection.IExpressionCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


ExpressionCollection.IExpressionCollectionEnumerator Properties

The properties of the ExpressionCollection.IExpressionCollectionEnumerator interface are listed below. For a complete list of ExpressionCollection.IExpressionCollectionEnumerator interface members, see the ExpressionCollection.IExpressionCollectionEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

ExpressionCollection.IExpressionCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


Current Property

Goblin - A Platform for 3D AR and VR Applications

ExpressionCollection.IExpressionCollectionEnumerator.Current Property

Gets the current element in the collection.

Expression Current {get;}

See Also

ExpressionCollection.IExpressionCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


ExpressionCollection.IExpressionCollectionEnumerator Methods

The methods of the ExpressionCollection.IExpressionCollectionEnumerator interface are listed below. For a complete list of ExpressionCollection.IExpressionCollectionEnumerator interface members, see the ExpressionCollection.IExpressionCollectionEnumerator Members topic.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

ExpressionCollection.IExpressionCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


ExpressionCollection.IExpressionCollectionEnumerator.MoveNext Method

Advances the enumerator to the next element in the collection.

bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Exceptions

Exception Type | Condition
InvalidOperationException | The collection was modified after the enumerator was created.

See Also

ExpressionCollection.IExpressionCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


ExpressionCollection.IExpressionCollectionEnumerator.Reset Method

Sets the enumerator to its initial position, before the first element in the collection.

void Reset();

See Also

ExpressionCollection.IExpressionCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


ExpressionCollection.Tag Enumeration

protected enum ExpressionCollection.Tag

Members

Member Name | Description
Default |

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

DDW.CSharp.Dom Namespace


ExprStmt Class

A code expression that can be treated as a code statement.

For a list of all members of this type, see ExprStmt Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Statement
DDW.CSharp.Dom.ExprStmt

public class ExprStmt : Statement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

ExprStmt Members | DDW.CSharp.Dom Namespace


ExprStmt Members

ExprStmt overview

Public Instance Constructors

ExprStmt Constructor Initializes a new instance of the ExprStmt class.

Public Instance Properties

Expression | Gets or sets the expression this statement encapsulates.
LinePragma (inherited from CSharpGraph) |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExprStmt Class | DDW.CSharp.Dom Namespace


ExprStmt Constructor

Initializes a new instance of the ExprStmt class.

public ExprStmt();

See Also

ExprStmt Class | DDW.CSharp.Dom Namespace


ExprStmt Properties

The properties of the ExprStmt class are listed below. For a complete list of ExprStmt class members, see the ExprStmt Members topic.

Public Instance Properties

Expression | Gets or sets the expression this statement encapsulates.
LinePragma (inherited from CSharpGraph) |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

ExprStmt Class | DDW.CSharp.Dom Namespace


Expression Property

Goblin - A Platform for 3D AR and VR Applications

ExprStmt.Expression Property

Gets or sets the expression this statement encapsulates.

public Expression Expression {get; set;}

See Also

ExprStmt Class | DDW.CSharp.Dom Namespace


FieldDecl Class

A field declaration.

For a list of all members of this type, see FieldDecl Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.MemberDecl
DDW.CSharp.Dom.FieldDecl

public class FieldDecl : MemberDecl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

FieldDecl Members | DDW.CSharp.Dom Namespace


FieldDecl Members

FieldDecl overview

Public Instance Constructors

FieldDecl Constructor Initializes a new instance of the FieldDecl class.

Public Instance Properties

Attributes (inherited from MemberDecl) | Gets or sets the modifier flags for this member (public, private etc).
Comments (inherited from MemberDecl) | Gets the collection of comments for this member.
CustomAttributes (inherited from MemberDecl) | Gets the collection of Custom Attributes used for this member (custom attributes are the ones declared between brackets, like [Flags]).
Delcarators | Gets the collection of declarators created in the field. Fields can declare multiple variables at once, so this must be a collection.
LinePragma (inherited from CSharpGraph) |
MemberKind |
Type | Gets or sets the type of the field declaration. While a field can declare multiple variables, they must be of the same type, so this is not a collection.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
VerifyModifiers (inherited from MemberDecl) |

See Also

FieldDecl Class | DDW.CSharp.Dom Namespace


FieldDecl Constructor

Initializes a new instance of the FieldDecl class.

public FieldDecl();

See Also

FieldDecl Class | DDW.CSharp.Dom Namespace


FieldDecl Properties

The properties of the FieldDecl class are listed below. For a complete list of FieldDecl class members, see the FieldDecl Members topic.

Public Instance Properties

Attributes (inherited from MemberDecl) | Gets or sets the modifier flags for this member (public, private etc).
Comments (inherited from MemberDecl) | Gets the collection of comments for this member.
CustomAttributes (inherited from MemberDecl) | Gets the collection of Custom Attributes used for this member (custom attributes are the ones declared between brackets, like [Flags]).
Delcarators | Gets the collection of declarators created in the field. Fields can declare multiple variables at once, so this must be a collection.
LinePragma (inherited from CSharpGraph) |
MemberKind |
Type | Gets or sets the type of the field declaration. While a field can declare multiple variables, they must be of the same type, so this is not a collection.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

FieldDecl Class | DDW.CSharp.Dom Namespace


Delcarators Property

Goblin - A Platform for 3D AR and VR Applications

FieldDecl.Delcarators Property

Gets the collection of declarators created in the field. Fields can declare multiple variables at once, so this must be a collection.

public DeclaratorCollection Delcarators {get;}

See Also

FieldDecl Class | DDW.CSharp.Dom Namespace


MemberKind Property

Goblin - A Platform for 3D AR and VR Applications

FieldDecl.MemberKind Property

public override MemberKind MemberKind {get;}

See Also

FieldDecl Class | DDW.CSharp.Dom Namespace


Type Property

Goblin - A Platform for 3D AR and VR Applications

FieldDecl.Type Property

Gets or sets the type of the field declaration. While a field can declare multiple variables, they must be of the same type, so this is not a collection.

public TypeRef Type {get; set;}

See Also

FieldDecl Class | DDW.CSharp.Dom Namespace


FieldRef Class

A reference to a field.

For a list of all members of this type, see FieldRef Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Expression
DDW.CSharp.Dom.Reference
DDW.CSharp.Dom.FieldRef

public class FieldRef : Reference

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

FieldRef Members | DDW.CSharp.Dom Namespace


FieldRef Members

FieldRef overview

Public Instance Constructors

FieldRef Constructor Initializes a new instance of the FieldRef class.

Public Instance Properties

FieldName | Gets or sets the name of the field.
LinePragma (inherited from CSharpGraph) |
Target | Gets or sets the target object to which the field belongs.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FieldRef Class | DDW.CSharp.Dom Namespace


FieldRef Constructor

Initializes a new instance of the FieldRef class.

public FieldRef();

See Also

FieldRef Class | DDW.CSharp.Dom Namespace


FieldRef Properties

The properties of the FieldRef class are listed below. For a complete list of FieldRef class members, see the FieldRef Members topic.

Public Instance Properties

FieldName | Gets or sets the name of the field.
LinePragma (inherited from CSharpGraph) |
Target | Gets or sets the target object to which the field belongs.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

FieldRef Class | DDW.CSharp.Dom Namespace


FieldName Property

Goblin - A Platform for 3D AR and VR Applications

FieldRef.FieldName Property

Gets or sets the name of the field.

public string FieldName {get; set;}

See Also

FieldRef Class | DDW.CSharp.Dom Namespace


Target Property

Goblin - A Platform for 3D AR and VR Applications

FieldRef.Target Property

Gets or sets the target object to which the field belongs.

public Expression Target {get; set;}

See Also

FieldRef Class | DDW.CSharp.Dom Namespace


ForEachStmt Class

A foreach statement that enumerates over a collection.

For a list of all members of this type, see ForEachStmt Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Statement
DDW.CSharp.Dom.ForEachStmt

public class ForEachStmt : Statement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

ForEachStmt Members | DDW.CSharp.Dom Namespace


ForEachStmt Members

ForEachStmt overview

Public Instance Constructors

ForEachStmt Constructor Initializes a new instance of the ForEachStmt class.

Public Instance Properties

Collection | Gets the collection that will be searched.
IterationType | Gets the type of iteration statement. This will always be 'IterationType.ForEach'.
LinePragma (inherited from CSharpGraph) |
Name | Gets or sets the name of the variable that holds the current enumeration value.
Statements | Gets the collection of statements in the loop.
Type | Gets or sets the type of the object to be found in the collection.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ForEachStmt Class | DDW.CSharp.Dom Namespace


ForEachStmt Constructor

Initializes a new instance of the ForEachStmt class.

public ForEachStmt();

See Also

ForEachStmt Class | DDW.CSharp.Dom Namespace


ForEachStmt Properties

The properties of the ForEachStmt class are listed below. For a complete list of ForEachStmt class members, see the ForEachStmt Members topic.

Public Instance Properties

Collection | Gets the collection that will be searched.
IterationType | Gets the type of iteration statement. This will always be 'IterationType.ForEach'.
LinePragma (inherited from CSharpGraph) |
Name | Gets or sets the name of the variable that holds the current enumeration value.
Statements | Gets the collection of statements in the loop.
Type | Gets or sets the type of the object to be found in the collection.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

ForEachStmt Class | DDW.CSharp.Dom Namespace


Collection Property

Goblin - A Platform for 3D AR and VR Applications

ForEachStmt.Collection Property

Gets the collection that will be searched.

public Expression Collection {get; set;}

See Also

ForEachStmt Class | DDW.CSharp.Dom Namespace


IterationType Property

Goblin - A Platform for 3D AR and VR Applications

ForEachStmt.IterationType Property

Gets the type of iteration statement. This will always be 'IterationType.ForEach'.

public IterationType IterationType {get;}

See Also

ForEachStmt Class | DDW.CSharp.Dom Namespace


Name Property

Goblin - A Platform for 3D AR and VR Applications

ForEachStmt.Name Property

Gets or sets the name of the variable that holds the current enumeration value.

public string Name {get; set;}

See Also

ForEachStmt Class | DDW.CSharp.Dom Namespace


Statements Property

Goblin - A Platform for 3D AR and VR Applications

ForEachStmt.Statements Property

Gets the collection of statements in the loop.

public StatementCollection Statements {get;}

See Also

ForEachStmt Class | DDW.CSharp.Dom Namespace


Type Property

Goblin - A Platform for 3D AR and VR Applications

ForEachStmt.Type Property

Gets or sets the type of the object to be found in the collection.

public TypeRef Type {get; set;}

See Also

ForEachStmt Class | DDW.CSharp.Dom Namespace


GotoStmt Class

A goto statement, jumps to a label or a case clause.

For a list of all members of this type, see GotoStmt Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Statement
DDW.CSharp.Dom.GotoStmt

public class GotoStmt : Statement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

GotoStmt Members | DDW.CSharp.Dom Namespace


GotoStmt Members

GotoStmt overview

Public Instance Constructors

GotoStmt Constructor Initializes a new instance of the GotoStmt class.

Public Instance Properties

CaseLabel | Gets or sets the case statement to jump to if this is inside a switch statement. The label holds the word 'case', so this is just the expression part.
Label | Gets or sets the label to jump to. If this jumps between cases, the label will be 'case' or 'default'.
LinePragma (inherited from CSharpGraph) |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GotoStmt Class | DDW.CSharp.Dom Namespace


GotoStmt Constructor

Initializes a new instance of the GotoStmt class.

public GotoStmt();

See Also

GotoStmt Class | DDW.CSharp.Dom Namespace


GotoStmt Properties

The properties of the GotoStmt class are listed below. For a complete list of GotoStmt class members, see the GotoStmt Members topic.

Public Instance Properties

CaseLabel | Gets or sets the case statement to jump to if this is inside a switch statement. The label holds the word 'case', so this is just the expression part.
Label | Gets or sets the label to jump to. If this jumps between cases, the label will be 'case' or 'default'.
LinePragma (inherited from CSharpGraph) |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

GotoStmt Class | DDW.CSharp.Dom Namespace


CaseLabel Property

Goblin - A Platform for 3D AR and VR Applications

GotoStmt.CaseLabel Property

Gets or sets the case statement to jump to if this is inside a switch statement. The label holds the word 'case', so this is just the expression part.

public Expression CaseLabel {get; set;}

See Also

GotoStmt Class | DDW.CSharp.Dom Namespace


Label Property

Goblin - A Platform for 3D AR and VR Applications

GotoStmt.Label Property

Gets or sets the label to jump to. If this jumps between cases, the label will be 'case' or 'default'.

public string Label {get; set;}

See Also

GotoStmt Class | DDW.CSharp.Dom Namespace


GraphTypes Enumeration

An enumeration of all CSharpDom types. Used to speed up and simplify reflection (each CSharp type has a 'GraphType' property).

public enum GraphTypes

Members

Member Name | Description
CSharpGraph |
CompileUnit |
Import |
NamespaceDecl |
MemberDecl |
MethodDecl |
FieldDecl |
PropertyDecl |
EventDecl |
ConstantDecl |
IndexerDecl |
OperatorDecl |
ConstructorDecl |
DestructorDecl |
AccessorDecl |
EnumMemberDecl |
TypeDecl |
ClassDecl |
InterfaceDecl |
StructDecl |
EnumDecl |
DelegateDecl |
Statement |
ExprStmt |
CommentStmt |
VariableDeclStmt |
ConstantDeclStmt |
IfStmt |
SwitchStmt |
Case |
IterationStmt |
ForEachStmt |
GotoStmt |
LabeledStmt |
ReturnStmt |
BreakStmt |
ContinueStmt |
CheckedStmt |
UncheckedStmt |
LockStmt |
UsingStmt |
ThrowStmt |
TryCatchFinallyStmt |
Catch |
AttachDelegateStmt |
RemoveDelegateStmt |
Expression |
AssignExpr |
UnaryExpr |
BinaryExpr |
TernaryExpr |
CastExpr |
SubExpr |
Reference |
UnknownReference |
ThisRef |
BaseRef |
PropertySetValueRef |
ArgumentRef |
LocalRef |
TypeOfExpr |
StaticRef |
FieldRef |
ArrayElementRef |
MethodRef |
PropertyRef |
EventRef |
MethodInvokeExpr |
PostfixExpr |
DelegateInvokeExpr |
IndexerRef |
MemberAccess |
ArrayCreateExpr |
ObjectCreateExpr |
CreateDelegateExpr |
PrimitiveExpr |
BooleanLiteral |
CharLiteral |
IntegerLiteral |
NullLiteral |
RealLiteral |
StringLiteral |
ArrayInitializer |
CustomAttribute |
TypeRef |
BuiltInType |
ParamDecl |
Param |
VariableDecl |
LinePragma |
Comment |
AssemblyReference |
RankSpecifier |
Declarator |
CompileUnitCollection |
ImportCollection |
NamespaceDeclCollection |
TypeDeclCollection |
MemberDeclCollection |
TypeRefCollection |
ParamCollection |
ParamDeclCollection |
StatementCollection |
CommentStmtCollection |
CatchCollection |
ExpressionCollection |
CustomAttributeCollection |
CaseCollection |
AssemblyReferenceCollection |
RankSpecifierCollection |
DeclaratorCollection |

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

DDW.CSharp.Dom Namespace


IDeclaration Interface

For a list of all members of this type, see IDeclaration Members.

DDW.CSharp.Dom.IDeclaration
DDW.CSharp.Dom.ISymbolRef

public interface IDeclaration

Types that implement IDeclaration

Type | Description
ArgumentRef | An argument reference.
ArrayElementRef | A reference to a specific element of an array.
BaseRef | A 'base' reference.
BuiltInType | A C# built in type.
ClassDecl | A class declartation.
ConstructorDecl | A constructor declartation.
Declarator | Code elements such as fields or events can declare multiple variables of the same type in one statement (int x=5, y=6, z=7;). Each of these are declarators.
DelegateDecl | A delegate declartation.
DestructorDecl | A destructor declartation.
EnumDecl | An enum declartation.
EnumMemberDecl | An enum declartation.
EventRef | A reference to an event.
FieldRef | A reference to a field.
IndexerDecl | An indexer declartation.
IndexerRef | A reference to a class indexer.
InterfaceDecl | An interface declartation.
LocalRef | A local reference.
MemberAccess | An expression that accesses a member of a variable (x.y).
MethodDecl | A method declaration.
MethodRef | A reference to a method.
NamespaceDecl | A namespace declaration.
OperatorDecl | An operator declartation.
ParamDecl | A parameter delaration.
PropertyDecl | A property declaration.
PropertyRef | A reference to a property.
PropertySetValueRef | A 'value' reference, used inside a set accessor.
Reference | A variable.
StructDecl | A struct declartation.
ThisRef | A 'this' reference.
TypeDecl | An abstract base class for types (classes, structs, interfaces etc).
TypeRef | A reference to a type (interface, class, struct, enum, delegate - this includes built in types).
UnknownReference | A variable who's type has not yet been determined.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

IDeclaration Members | DDW.CSharp.Dom Namespace


IDeclaration Members

IDeclaration overview

Public Instance Properties

Definition
GraphType

See Also

IDeclaration Interface | DDW.CSharp.Dom Namespace


IDeclaration Properties

The properties of the IDeclaration interface are listed below. For a complete list of IDeclaration interface members, see the IDeclaration Members topic.

Public Instance Properties

Definition
GraphType

See Also

IDeclaration Interface | DDW.CSharp.Dom Namespace


Definition Property

Goblin - A Platform for 3D AR and VR Applications

IDeclaration.Definition Property

DDW.CSharp.SymbolTable.IDefinition Definition {get;}

See Also

IDeclaration Interface | DDW.CSharp.Dom Namespace


GraphType Property

Goblin - A Platform for 3D AR and VR Applications

IDeclaration.GraphType Property

GraphTypes GraphType {get;}

See Also

IDeclaration Interface | DDW.CSharp.Dom Namespace


IfStmt Class

An if (conditional) statement.

For a list of all members of this type, see IfStmt Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Statement
DDW.CSharp.Dom.IfStmt

public class IfStmt : Statement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

IfStmt Members | DDW.CSharp.Dom Namespace


IfStmt Members

IfStmt overview

Public Instance Constructors

IfStmt Constructor Initializes a new instance of the IfStmt class.

Public Instance Properties

Condition | Gets or sets the condition to be tested.
FalseStatements | Gets or sets the statements to be executed if the condition is false.
LinePragma (inherited from CSharpGraph) |
TrueStatements | Gets or sets the statements to be executed if the condition is true.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IfStmt Class | DDW.CSharp.Dom Namespace


IfStmt Constructor

Initializes a new instance of the IfStmt class.

public IfStmt();

See Also

IfStmt Class | DDW.CSharp.Dom Namespace


IfStmt Properties

The properties of the IfStmt class are listed below. For a complete list of IfStmt class members, see the IfStmt Members topic.

Public Instance Properties

Condition | Gets or sets the condition to be tested.
FalseStatements | Gets or sets the statements to be executed if the condition is false.
LinePragma (inherited from CSharpGraph) |
TrueStatements | Gets or sets the statements to be executed if the condition is true.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

IfStmt Class | DDW.CSharp.Dom Namespace


Condition Property

Goblin - A Platform for 3D AR and VR Applications

IfStmt.Condition Property

Gets or sets the condition to be tested.

public Expression Condition {get; set;}

See Also

IfStmt Class | DDW.CSharp.Dom Namespace


FalseStatements Property

Goblin - A Platform for 3D AR and VR Applications

IfStmt.FalseStatements Property

Gets or sets the statements to be executed if the condition is false.

public StatementCollection FalseStatements {get;}

See Also

IfStmt Class | DDW.CSharp.Dom Namespace


TrueStatements Property

Goblin - A Platform for 3D AR and VR Applications

IfStmt.TrueStatements Property

Gets or sets the statements to be executed if the condition is true.

public StatementCollection TrueStatements {get;}

See Also

IfStmt Class | DDW.CSharp.Dom Namespace


IGraph Interface

An interface that all CSharpDom elements must implement.

For a list of all members of this type, see IGraph Members.

public interface IGraph

Types that implement IGraph

Type | Description
AccessorDecl | An accessor declartation.
ArgumentRef | An argument reference.
ArrayCreateExpr | An expression that creates a new array.
ArrayElementRef | A reference to a specific element of an array.
ArrayInitializer | An expression that initializes a new array being created (the {1,2,3} part).
AssemblyReference | A reference to an assembly. This is normally something on the command line.
AssemblyReferenceCollection | A strongly-typed collection of AssemblyReference objects.
AssignExpr | An assignment expression.
AttachDelegateStmt | Attaches a delegate to an event.
BaseRef | A 'base' reference.
BinaryExpr | A binary expression.
BooleanLiteral | A boolean literal.
BreakStmt | A break statement.
BuiltInType | A C# built in type.
Case | A case clause for a switch statement.
CaseCollection | A strongly-typed collection of Case objects.
CastExpr | A cast expression.
Catch | A catch clause.
CatchCollection | A strongly-typed collection of Catch objects.
CharLiteral | A character literal.
CheckedStmt | A checked statement - explicitly checks for overflow.
ClassDecl | A class declartation.
Comment | A comment that may be mixed in with other elements.
CommentStmt | A normal comment.
CommentStmtCollection | A strongly-typed collection of CommentStmt objects.
CompileUnit | A C# file level unit of code. This must be a complete C# file, snippets are not valid.
CompileUnitCollection | A strongly-typed collection of CompileUnit objects.
ConstantDecl | A constant declartation.
ConstantDeclStmt | A constant declaration statement.
ConstructorDecl | A constructor declartation.
ContinueStmt | A continue statement.
CreateDelegateExpr | An expression that creates a new delegate.
CSharpGraph | An abstract base class for CSharpDom elements.
CustomAttribute | An single attribute applied to a code element (eg. [Flags]). Note: multiple comma separated attributes declared in a single attribute element are separated into multiple attributes.
CustomAttributeCollection | A strongly-typed collection of CustomAttribute objects.
Declarator | Code elements such as fields or events can declare multiple variables of the same type in one statement (int x=5, y=6, z=7;). Each of these are declarators.
DeclaratorCollection | A strongly-typed collection of Declarator objects.
DelegateDecl | A delegate declartation.
DelegateInvokeExpr | Invokes a delegate.
DestructorDecl | A destructor declartation.
EnumDecl | An enum declartation.
EnumMemberDecl | An enum declartation.
EventDecl | An event declaration.
EventRef | A reference to an event.
Expression | An abstract base class for expressions.
ExpressionCollection | A strongly-typed collection of Expression objects.
ExprStmt | A code expression that can be treated as a code statement.
FieldDecl | A field declaration.
FieldRef | A reference to a field.
ForEachStmt | A foreach statement that enumerates over a collection.
GotoStmt | A goto statement, jumps to a label or a case clause.
IfStmt | An if (conditional) statement.
Import | An import declaration. This maps to the 'using' statement, so it can also be used to set aliases.
ImportCollection | A strongly-typed collection of Import objects.
IndexerDecl | An indexer declartation.
IndexerRef | A reference to a class indexer.
IntegerLiteral | An interger literal.
InterfaceDecl | An interface declartation.
IterationStmt | A loop construct. This can be a for, do or while loop, however foreach loops are treated separately (as a ForEachStmt).
LabeledStmt | A labeled statement that can be jumped to with a goto statement.
LocalRef | A local reference.
LockStmt | A lock statement.
MemberAccess | An expression that accesses a member of a variable (x.y).
MemberDecl | An abstract class for all types (class, struct...) and type members (method, field...).
MemberDeclCollection | A strongly-typed collection of MemberDecl objects.
MethodDecl | A method declaration.
MethodInvokeExpr | Invokes a method with the given parameters.
MethodRef | A reference to a method.
NamespaceDecl | A namespace declaration.
NamespaceDeclCollection | A strongly-typed collection of NamespaceDecl objects.
NullLiteral | A null literal.
ObjectCreateExpr | An expression that creates a new object.
OperatorDecl | An operator declartation.
Param | A parameter that will be passed to another code element.
ParamCollection | A strongly-typed collection of Param objects.
ParamDecl | A parameter delaration.
ParamDeclCollection | A strongly-typed collection of ParamDecl objects.
PostfixExpr | A postfix expression (x++, y--).
PrimitiveExpr | An abstract base class for primative types.
PropertyDecl | A property declaration.
PropertyRef | A reference to a property.
PropertySetValueRef | A 'value' reference, used inside a set accessor.
RankSpecifier | A rank specifier for an array. There can be more than one rank specifier in the case of a jagged array (x[][]).
RankSpecifierCollection | A strongly-typed collection of RankSpecifier objects.
RealLiteral | An real literal. Will be a floating point number.
Reference | A variable.
RemoveDelegateStmt | Removes a delegate from an event.
ReturnStmt | A return statement.
Statement | An abstract base class for statements.
StatementCollection | A strongly-typed collection of Statement objects.
StringLiteral | A string literal.
StructDecl | A struct declartation.
SubExpr | A sub (parenthesized) expression. This overrides regular operator precedence eg: (2+4)*6.
SwitchStmt | A switch statement.
TernaryExpr | A ternary (conditional) expression (bool ? expr : expr).
ThisRef | A 'this' reference.
ThrowStmt | A throw statement.
TryCatchFinallyStmt | A try, catch, finally construct.
TypeDecl | An abstract base class for types (classes, structs, interfaces etc).
TypeDeclCollection | A strongly-typed collection of TypeDecl objects.
TypeOfExpr | A 'typeof' expression.
TypeRef | A reference to a type (interface, class, struct, enum, delegate - this includes built in types).
TypeRefCollection | A strongly-typed collection of TypeRef objects.
UnaryExpr | A unary expression.
UncheckedStmt | An unchecked statement - explicitly ignores overflow.
UnknownReference | A variable who's type has not yet been determined.
UsingStmt | A using statement, aquires a resource that will be disposed at the end of the scope.
VariableDecl | A variable declaration.
VariableDeclStmt | A variable declaration statement.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

IGraph Members | DDW.CSharp.Dom Namespace


IGraph Members

IGraph overview

Public Instance Properties

GraphType
LinePragma

See Also

IGraph Interface | DDW.CSharp.Dom Namespace


IGraph Properties

The properties of the IGraph interface are listed below. For a complete list of IGraph interface members, see the IGraph Members topic.

Public Instance Properties

GraphType
LinePragma

See Also

IGraph Interface | DDW.CSharp.Dom Namespace


GraphType Property

Goblin - A Platform for 3D AR and VR Applications

IGraph.GraphType Property

GraphTypes GraphType {get;}

See Also

IGraph Interface | DDW.CSharp.Dom Namespace


LinePragma Property

Goblin - A Platform for 3D AR and VR Applications

IGraph.LinePragma Property

LinePragma LinePragma {get;}

See Also

IGraph Interface | DDW.CSharp.Dom Namespace


Import Class

An import declaration. This maps to the 'using' statement, so it can also be used to set aliases.

For a list of all members of this type, see Import Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Import

public class Import : CSharpGraph

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

Import Members | DDW.CSharp.Dom Namespace


Import Members

Import overview

Public Instance Constructors

Import Constructor Initializes a new instance of the Import class.

Public Instance Properties

Alias | Gets or sets the alias of the imported namespace, if present.
LinePragma (inherited from CSharpGraph) |
Namespace | Gets or sets the namespace to be imported or aliased.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Import Class | DDW.CSharp.Dom Namespace


Import Constructor

Initializes a new instance of the Import class.

public Import();

See Also

Import Class | DDW.CSharp.Dom Namespace


Import Properties

The properties of the Import class are listed below. For a complete list of Import class members, see the Import Members topic.

Public Instance Properties

Alias | Gets or sets the alias of the imported namespace, if present.
LinePragma (inherited from CSharpGraph) |
Namespace | Gets or sets the namespace to be imported or aliased.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

Import Class | DDW.CSharp.Dom Namespace


Alias Property

Goblin - A Platform for 3D AR and VR Applications

Import.Alias Property

Gets or sets the alias of the imported namespace, if present.

public string Alias {get; set;}

See Also

Import Class | DDW.CSharp.Dom Namespace


Namespace Property

Goblin - A Platform for 3D AR and VR Applications

Import.Namespace Property

Gets or sets the namespace to be imported or aliased.

public string Namespace {get; set;}

See Also

Import Class | DDW.CSharp.Dom Namespace


ImportCollection Class

A strongly-typed collection of Import objects.

For a list of all members of this type, see ImportCollection Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.ImportCollection

public class ImportCollection : CSharpGraph, IList, ICollection, IEnumerable, ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

ImportCollection Members | DDW.CSharp.Dom Namespace


ImportCollection Members

ImportCollection overview

Public Static Methods

ReadOnly | Creates a read-only wrapper for a ImportCollection instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a ImportCollection instance.

Public Instance Constructors

ImportCollection Overloaded. Initializes a new instance of the ImportCollection class.

Public Instance Properties

Capacity | Gets or sets the number of elements the ImportCollection can contain.
Count | Gets the number of elements actually contained in the ImportCollection.
GraphType |
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the Import at the specified index.
LinePragma (inherited from CSharpGraph) |
SyncRoot | Gets an object that can be used to synchronize access to the collection.
Text |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Add | Adds a Import to the end of the ImportCollection.
AddRange | Overloaded. Adds the elements of a Import array to the current ImportCollection.
Clear | Removes all elements from the ImportCollection.
Clone | Creates a shallow copy of the ImportCollection.
Contains | Determines whether a given Import is in the ImportCollection.
CopyTo | Overloaded. Copies the entire ImportCollection to a one-dimensional Import array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the ImportCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the zero-based index of the first occurrence of a Import in the ImportCollection.
Insert | Inserts an element into the ImportCollection at the specified index.
Remove | Removes the first occurrence of a specific Import from the ImportCollection.
RemoveAt | Removes the element at the specified index of the ImportCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Constructors

ImportCollection Overloaded. Initializes a new instance of the ImportCollection class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ImportCollection Class | DDW.CSharp.Dom Namespace


ImportCollection Constructor

Initializes a new instance of the ImportCollection class that is empty and has the default initial capacity.

Overload List

Initializes a new instance of the ImportCollection class that is empty and has the default initial capacity.

public ImportCollection();

Initializes a new instance of the ImportCollection class that contains elements copied from the specified Import array.

public ImportCollection(Import[]);

Initializes a new instance of the ImportCollection class that contains elements copied from the specified ImportCollection.

public ImportCollection(ImportCollection);

protected ImportCollection(Tag);

Initializes a new instance of the ImportCollection class that has the specified initial capacity.

public ImportCollection(int);

See Also

ImportCollection Class | DDW.CSharp.Dom Namespace


ImportCollection Constructor ()

Initializes a new instance of the ImportCollection class that is empty and has the default initial capacity.

public ImportCollection();

See Also

ImportCollection Class | DDW.CSharp.Dom Namespace | ImportCollection Constructor Overload List


ImportCollection Constructor (Int32)

Initializes a new instance of the ImportCollection class that has the specified initial capacity.

public ImportCollection(
int capacity
);

Parameters

capacity
The number of elements that the new ImportCollection is initially capable of storing.

See Also

ImportCollection Class | DDW.CSharp.Dom Namespace | ImportCollection Constructor Overload List


ImportCollection Constructor (ImportCollection)

Initializes a new instance of the ImportCollection class that contains elements copied from the specified ImportCollection.

public ImportCollection(
ImportCollection c
);

Parameters

c
The ImportCollection whose elements are copied to the new collection.

See Also

ImportCollection Class | DDW.CSharp.Dom Namespace | ImportCollection Constructor Overload List


ImportCollection Constructor (Import[])

Initializes a new instance of the ImportCollection class that contains elements copied from the specified Import array.

public ImportCollection(
Import[] a
);

Parameters

a
The Import array whose elements are copied to the new list.

See Also

ImportCollection Class | DDW.CSharp.Dom Namespace | ImportCollection Constructor Overload List


ImportCollection Constructor (Tag)

protected ImportCollection(
Tag t
);

See Also

ImportCollection Class | DDW.CSharp.Dom Namespace | ImportCollection Constructor Overload List


ImportCollection Properties

The properties of the ImportCollection class are listed below. For a complete list of ImportCollection class members, see the ImportCollection Members topic.

Public Instance Properties

Capacity | Gets or sets the number of elements the ImportCollection can contain.
Count | Gets the number of elements actually contained in the ImportCollection.
GraphType |
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the Import at the specified index.
LinePragma (inherited from CSharpGraph) |
SyncRoot | Gets an object that can be used to synchronize access to the collection.
Text |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

ImportCollection Class | DDW.CSharp.Dom Namespace


Capacity Property

Goblin - A Platform for 3D AR and VR Applications

ImportCollection.Capacity Property

Gets or sets the number of elements the ImportCollection can contain.

public virtual int Capacity {get; set;}

See Also

ImportCollection Class | DDW.CSharp.Dom Namespace


Count Property

Goblin - A Platform for 3D AR and VR Applications

ImportCollection.Count Property

Gets the number of elements actually contained in the ImportCollection.

public virtual int Count {get;}

Implements

ICollection.Count

See Also

ImportCollection Class | DDW.CSharp.Dom Namespace


GraphType Property

Goblin - A Platform for 3D AR and VR Applications

ImportCollection.GraphType Property

public override GraphTypes GraphType {get;}

Implements

IGraph.GraphType

See Also

ImportCollection Class | DDW.CSharp.Dom Namespace


IsFixedSize Property

Goblin - A Platform for 3D AR and VR Applications

ImportCollection.IsFixedSize Property

Gets a value indicating whether the collection has a fixed size.

public virtual bool IsFixedSize {get;}

Property Value

true if the collection has a fixed size; otherwise, false. The default is false

Implements

IList.IsFixedSize

See Also

ImportCollection Class | DDW.CSharp.Dom Namespace


IsReadOnly Property

Goblin - A Platform for 3D AR and VR Applications

ImportCollection.IsReadOnly Property

gets a value indicating whether the IList is read-only.

public virtual bool IsReadOnly {get;}

Property Value

true if the collection is read-only; otherwise, false. The default is false

Implements

IList.IsReadOnly

See Also

ImportCollection Class | DDW.CSharp.Dom Namespace


IsSynchronized Property

Goblin - A Platform for 3D AR and VR Applications

ImportCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread-safe).

public virtual bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

ImportCollection Class | DDW.CSharp.Dom Namespace


Item Property

Goblin - A Platform for 3D AR and VR Applications

ImportCollection.Item Property

Gets or sets the Import at the specified index.

public virtual Import this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

ImportCollection Class | DDW.CSharp.Dom Namespace


SyncRoot Property

Goblin - A Platform for 3D AR and VR Applications

ImportCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

public virtual object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

ImportCollection Class | DDW.CSharp.Dom Namespace


Text Property

Goblin - A Platform for 3D AR and VR Applications

ImportCollection.Text Property

public override string Text {get;}

Implements

IGraph.Text

See Also

ImportCollection Class | DDW.CSharp.Dom Namespace


ImportCollection Methods

The methods of the ImportCollection class are listed below. For a complete list of ImportCollection class members, see the ImportCollection Members topic.

Public Static Methods

ReadOnly | Creates a read-only wrapper for a ImportCollection instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a ImportCollection instance.

Public Instance Methods

Add | Adds a Import to the end of the ImportCollection.
AddRange | Overloaded. Adds the elements of a Import array to the current ImportCollection.
Clear | Removes all elements from the ImportCollection.
Clone | Creates a shallow copy of the ImportCollection.
Contains | Determines whether a given Import is in the ImportCollection.
CopyTo | Overloaded. Copies the entire ImportCollection to a one-dimensional Import array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the ImportCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the zero-based index of the first occurrence of a Import in the ImportCollection.
Insert | Inserts an element into the ImportCollection at the specified index.
Remove | Removes the first occurrence of a specific Import from the ImportCollection.
RemoveAt | Removes the element at the specified index of the ImportCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ImportCollection Class | DDW.CSharp.Dom Namespace


ImportCollection.Add Method

Adds a Import to the end of the ImportCollection.

public virtual int Add(
Import item
);

Parameters

item
The Import to be added to the end of the ImportCollection.

Return Value

The index at which the value has been added.

See Also

ImportCollection Class | DDW.CSharp.Dom Namespace


AddRange Method

Goblin - A Platform for 3D AR and VR Applications

ImportCollection.AddRange Method

Adds the elements of a Import array to the current ImportCollection.

Overload List

Adds the elements of a Import array to the current ImportCollection.

public virtual int AddRange(Import[]);

Adds the elements of another ImportCollection to the current ImportCollection.

public virtual int AddRange(ImportCollection);

See Also

ImportCollection Class | DDW.CSharp.Dom Namespace


ImportCollection.AddRange Method (Import[])

Adds the elements of a Import array to the current ImportCollection.

public virtual int AddRange(
Import[] x
);

Parameters

x
The Import array whose elements should be added to the end of the ImportCollection.

Return Value

The new Count of the ImportCollection.

See Also

ImportCollection Class | DDW.CSharp.Dom Namespace | ImportCollection.AddRange Overload List


ImportCollection.AddRange Method (ImportCollection)

Adds the elements of another ImportCollection to the current ImportCollection.

public virtual int AddRange(
ImportCollection x
);

Parameters

x
The ImportCollection whose elements should be added to the end of the current ImportCollection.

Return Value

The new Count of the ImportCollection.

See Also

ImportCollection Class | DDW.CSharp.Dom Namespace | ImportCollection.AddRange Overload List


ImportCollection.Clear Method

Removes all elements from the ImportCollection.

public virtual void Clear();

Implements

IList.Clear

See Also

ImportCollection Class | DDW.CSharp.Dom Namespace


ImportCollection.Clone Method

Creates a shallow copy of the ImportCollection.

public virtual object Clone();

Implements

ICloneable.Clone

See Also

ImportCollection Class | DDW.CSharp.Dom Namespace


ImportCollection.Contains Method

Determines whether a given Import is in the ImportCollection.

public virtual bool Contains(
Import item
);

Parameters

item
The Import to check for.

Return Value

true if item is found in the ImportCollection; otherwise, false.

See Also

ImportCollection Class | DDW.CSharp.Dom Namespace


CopyTo Method

Goblin - A Platform for 3D AR and VR Applications

ImportCollection.CopyTo Method

Copies the entire ImportCollection to a one-dimensional Import array.

Overload List

Copies the entire ImportCollection to a one-dimensional Import array.

public virtual void CopyTo(Import[]);

Copies the entire ImportCollection to a one-dimensional Import array, starting at the specified index of the target array.

public virtual void CopyTo(Import[],int);

See Also

ImportCollection Class | DDW.CSharp.Dom Namespace


ImportCollection.CopyTo Method (Import[])

Copies the entire ImportCollection to a one-dimensional Import array.

public virtual void CopyTo(
Import[] array
);

Parameters

array
The one-dimensional Import array to copy to.

See Also

ImportCollection Class | DDW.CSharp.Dom Namespace | ImportCollection.CopyTo Overload List


ImportCollection.CopyTo Method (Import[], Int32)

Copies the entire ImportCollection to a one-dimensional Import array, starting at the specified index of the target array.

public virtual void CopyTo(
Import[] array,
int start
);

Parameters

array
The one-dimensional Import array to copy to.
start
The zero-based index in array at which copying begins.

See Also

ImportCollection Class | DDW.CSharp.Dom Namespace | ImportCollection.CopyTo Overload List


ImportCollection.GetEnumerator Method

Returns an enumerator that can iterate through the ImportCollection.

public virtual IImportCollectionEnumerator GetEnumerator();

Return Value

An Enumerator for the entire ImportCollection.

See Also

ImportCollection Class | DDW.CSharp.Dom Namespace


ImportCollection.IndexOf Method

Returns the zero-based index of the first occurrence of a Import in the ImportCollection.

public virtual int IndexOf(
Import item
);

Parameters

item
The Import to locate in the ImportCollection.

Return Value

The zero-based index of the first occurrence of item in the entire ImportCollection, if found; otherwise, -1.

See Also

ImportCollection Class | DDW.CSharp.Dom Namespace


ImportCollection.Insert Method

Inserts an element into the ImportCollection at the specified index.

public virtual void Insert(
int index,
Import item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The Import to insert.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

ImportCollection Class | DDW.CSharp.Dom Namespace


ImportCollection.ReadOnly Method

Creates a read-only wrapper for a ImportCollection instance.

public static ImportCollection ReadOnly(
ImportCollection list
);

Return Value

An ImportCollection wrapper that is read-only.

See Also

ImportCollection Class | DDW.CSharp.Dom Namespace


ImportCollection.Remove Method

Removes the first occurrence of a specific Import from the ImportCollection.

public virtual void Remove(
Import item
);

Parameters

item
The Import to remove from the ImportCollection.

Exceptions

Exception Type | Condition
ArgumentException | The specified Import was not found in the ImportCollection.

See Also

ImportCollection Class | DDW.CSharp.Dom Namespace


ImportCollection.RemoveAt Method

Removes the element at the specified index of the ImportCollection.

public virtual void RemoveAt(
int index
);

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

ImportCollection Class | DDW.CSharp.Dom Namespace


ImportCollection.Synchronized Method

Creates a synchronized (thread-safe) wrapper for a ImportCollection instance.

public static ImportCollection Synchronized(
ImportCollection list
);

Return Value

An ImportCollection wrapper that is synchronized (thread-safe).

See Also

ImportCollection Class | DDW.CSharp.Dom Namespace


ImportCollection.TrimToSize Method

Sets the capacity to the actual number of elements.

public virtual void TrimToSize();

See Also

ImportCollection Class | DDW.CSharp.Dom Namespace


ImportCollection.IImportCollectionEnumerator Interface

Supports type-safe iteration over a ImportCollection.

For a list of all members of this type, see ImportCollection.IImportCollectionEnumerator Members.

public interface ImportCollection.IImportCollectionEnumerator

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

ImportCollection.IImportCollectionEnumerator Members | DDW.CSharp.Dom Namespace


ImportCollection.IImportCollectionEnumerator Members

ImportCollection.IImportCollectionEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

ImportCollection.IImportCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


ImportCollection.IImportCollectionEnumerator Properties

The properties of the ImportCollection.IImportCollectionEnumerator interface are listed below. For a complete list of ImportCollection.IImportCollectionEnumerator interface members, see the ImportCollection.IImportCollectionEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

ImportCollection.IImportCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


Current Property

Goblin - A Platform for 3D AR and VR Applications

ImportCollection.IImportCollectionEnumerator.Current Property

Gets the current element in the collection.

Import Current {get;}

See Also

ImportCollection.IImportCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


ImportCollection.IImportCollectionEnumerator Methods

The methods of the ImportCollection.IImportCollectionEnumerator interface are listed below. For a complete list of ImportCollection.IImportCollectionEnumerator interface members, see the ImportCollection.IImportCollectionEnumerator Members topic.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

ImportCollection.IImportCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


ImportCollection.IImportCollectionEnumerator.MoveNext Method

Advances the enumerator to the next element in the collection.

bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Exceptions

Exception Type | Condition
InvalidOperationException | The collection was modified after the enumerator was created.

See Also

ImportCollection.IImportCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


ImportCollection.IImportCollectionEnumerator.Reset Method

Sets the enumerator to its initial position, before the first element in the collection.

void Reset();

See Also

ImportCollection.IImportCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


ImportCollection.Tag Enumeration

protected enum ImportCollection.Tag

Members

Member Name | Description
Default |

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

DDW.CSharp.Dom Namespace


IndexerDecl Class

An indexer declartation.

For a list of all members of this type, see IndexerDecl Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.MemberDecl
DDW.CSharp.Dom.IndexerDecl

public class IndexerDecl : MemberDecl, IDeclaration, IScope, IOverloadable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

IndexerDecl Members | DDW.CSharp.Dom Namespace


IndexerDecl Members

IndexerDecl overview

Public Instance Constructors

IndexerDecl Constructor Initializes a new instance of the IndexerDecl class.

Public Instance Properties

Attributes (inherited from MemberDecl) | Gets or sets the modifier flags for this member (public, private etc).
Comments (inherited from MemberDecl) | Gets the collection of comments for this member.
CustomAttributes (inherited from MemberDecl) | Gets the collection of Custom Attributes used for this member (custom attributes are the ones declared between brackets, like [Flags]).
Definition | Gets the (scoped) definition.
GetAccessor | Gets or sets the 'get' accessor for the indexer. This will not have an associated block if the indexer is declared as abstract or in an interface.
HasGet | Gets or sets the boolean value that indicates whether a get accessor is to be used. Setting this to false will not destroy the GetAccessor value.
HasSet | Gets or sets the boolean value that indicates whether a set accessor is to be used. Setting this to false will not destroy the SetAccessor value.
InterfaceType | Gets or sets the interface type, if present. In the case of a class implementing multiple interfaces that require indexers, the interface type is prepended to 'this' (with the syntax IList.this).
LinePragma (inherited from CSharpGraph) |
MemberKind |
Name | Gets the name of the indexer (which is always 'Item').
Parameters | Gets the collection of parameters for the indexer. Each of these hold information about the type, direction etc.
Scope |
SetAccessor | Gets or sets the 'set' accessor for the indexer. This will not have an associated block if the indexer is declared as abstract or in an interface.
Type | Gets or sets the type of the indexer.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
VerifyModifiers (inherited from MemberDecl) |

See Also

IndexerDecl Class | DDW.CSharp.Dom Namespace


IndexerDecl Constructor

Initializes a new instance of the IndexerDecl class.

public IndexerDecl();

See Also

IndexerDecl Class | DDW.CSharp.Dom Namespace


IndexerDecl Properties

The properties of the IndexerDecl class are listed below. For a complete list of IndexerDecl class members, see the IndexerDecl Members topic.

Public Instance Properties

Attributes (inherited from MemberDecl) | Gets or sets the modifier flags for this member (public, private etc).
Comments (inherited from MemberDecl) | Gets the collection of comments for this member.
CustomAttributes (inherited from MemberDecl) | Gets the collection of Custom Attributes used for this member (custom attributes are the ones declared between brackets, like [Flags]).
Definition | Gets the (scoped) definition.
GetAccessor | Gets or sets the 'get' accessor for the indexer. This will not have an associated block if the indexer is declared as abstract or in an interface.
HasGet | Gets or sets the boolean value that indicates whether a get accessor is to be used. Setting this to false will not destroy the GetAccessor value.
HasSet | Gets or sets the boolean value that indicates whether a set accessor is to be used. Setting this to false will not destroy the SetAccessor value.
InterfaceType | Gets or sets the interface type, if present. In the case of a class implementing multiple interfaces that require indexers, the interface type is prepended to 'this' (with the syntax IList.this).
LinePragma (inherited from CSharpGraph) |
MemberKind |
Name | Gets the name of the indexer (which is always 'Item').
Parameters | Gets the collection of parameters for the indexer. Each of these hold information about the type, direction etc.
Scope |
SetAccessor | Gets or sets the 'set' accessor for the indexer. This will not have an associated block if the indexer is declared as abstract or in an interface.
Type | Gets or sets the type of the indexer.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

IndexerDecl Class | DDW.CSharp.Dom Namespace


Definition Property

Goblin - A Platform for 3D AR and VR Applications

IndexerDecl.Definition Property

Gets the (scoped) definition.

public DDW.CSharp.SymbolTable.IDefinition Definition {get;}

Implements

IDeclaration.Definition

See Also

IndexerDecl Class | DDW.CSharp.Dom Namespace


GetAccessor Property

Goblin - A Platform for 3D AR and VR Applications

IndexerDecl.GetAccessor Property

Gets or sets the 'get' accessor for the indexer. This will not have an associated block if the indexer is declared as abstract or in an interface.

public AccessorDecl GetAccessor {get; set;}

See Also

IndexerDecl Class | DDW.CSharp.Dom Namespace


HasGet Property

Goblin - A Platform for 3D AR and VR Applications

IndexerDecl.HasGet Property

Gets or sets the boolean value that indicates whether a get accessor is to be used. Setting this to false will not destroy the GetAccessor value.

public bool HasGet {get; set;}

See Also

IndexerDecl Class | DDW.CSharp.Dom Namespace


HasSet Property

Goblin - A Platform for 3D AR and VR Applications

IndexerDecl.HasSet Property

Gets or sets the boolean value that indicates whether a set accessor is to be used. Setting this to false will not destroy the SetAccessor value.

public bool HasSet {get; set;}

See Also

IndexerDecl Class | DDW.CSharp.Dom Namespace


InterfaceType Property

Goblin - A Platform for 3D AR and VR Applications

IndexerDecl.InterfaceType Property

Gets or sets the interface type, if present. In the case of a class implementing multiple interfaces that require indexers, the interface type is prepended to 'this' (with the syntax IList.this).

public TypeRef InterfaceType {get; set;}

See Also

IndexerDecl Class | DDW.CSharp.Dom Namespace


MemberKind Property

Goblin - A Platform for 3D AR and VR Applications

IndexerDecl.MemberKind Property

public override MemberKind MemberKind {get;}

See Also

IndexerDecl Class | DDW.CSharp.Dom Namespace


Name Property

Goblin - A Platform for 3D AR and VR Applications

IndexerDecl.Name Property

Gets the name of the indexer (which is always 'Item').

public string Name {get; set;}

See Also

IndexerDecl Class | DDW.CSharp.Dom Namespace


Parameters Property

Goblin - A Platform for 3D AR and VR Applications

IndexerDecl.Parameters Property

Gets the collection of parameters for the indexer. Each of these hold information about the type, direction etc.

public ParamDeclCollection Parameters {get;}

Implements

IOverloadable.Parameters

See Also

IndexerDecl Class | DDW.CSharp.Dom Namespace


Scope Property

Goblin - A Platform for 3D AR and VR Applications

IndexerDecl.Scope Property

public DDW.CSharp.SymbolTable.Scope Scope {get; set;}

Implements

IScope.Scope

See Also

IndexerDecl Class | DDW.CSharp.Dom Namespace


SetAccessor Property

Goblin - A Platform for 3D AR and VR Applications

IndexerDecl.SetAccessor Property

Gets or sets the 'set' accessor for the indexer. This will not have an associated block if the indexer is declared as abstract or in an interface.

public AccessorDecl SetAccessor {get; set;}

See Also

IndexerDecl Class | DDW.CSharp.Dom Namespace


Type Property

Goblin - A Platform for 3D AR and VR Applications

IndexerDecl.Type Property

Gets or sets the type of the indexer.

public TypeRef Type {get; set;}

See Also

IndexerDecl Class | DDW.CSharp.Dom Namespace


IndexerRef Class

A reference to a class indexer.

For a list of all members of this type, see IndexerRef Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Expression
DDW.CSharp.Dom.Reference
DDW.CSharp.Dom.IndexerRef

public class IndexerRef : Reference

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

IndexerRef Members | DDW.CSharp.Dom Namespace


IndexerRef Members

IndexerRef overview

Public Instance Constructors

IndexerRef Constructor Initializes a new instance of the IndexerRef class.

Public Instance Properties

Indices | Gets a collection of indexes that navigate to the indexer element. An indexer may be multi-dimensional ([,,]) so this must be a collection. Index zero represents the first dimension.
LinePragma (inherited from CSharpGraph) |
Target | Gets or sets a reference to the type of the indexer.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IndexerRef Class | DDW.CSharp.Dom Namespace


IndexerRef Constructor

Initializes a new instance of the IndexerRef class.

public IndexerRef();

See Also

IndexerRef Class | DDW.CSharp.Dom Namespace


IndexerRef Properties

The properties of the IndexerRef class are listed below. For a complete list of IndexerRef class members, see the IndexerRef Members topic.

Public Instance Properties

Indices | Gets a collection of indexes that navigate to the indexer element. An indexer may be multi-dimensional ([,,]) so this must be a collection. Index zero represents the first dimension.
LinePragma (inherited from CSharpGraph) |
Target | Gets or sets a reference to the type of the indexer.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

IndexerRef Class | DDW.CSharp.Dom Namespace


Indices Property

Goblin - A Platform for 3D AR and VR Applications

IndexerRef.Indices Property

Gets a collection of indexes that navigate to the indexer element. An indexer may be multi-dimensional ([,,]) so this must be a collection. Index zero represents the first dimension.

public ExpressionCollection Indices {get;}

See Also

IndexerRef Class | DDW.CSharp.Dom Namespace


Target Property

Goblin - A Platform for 3D AR and VR Applications

IndexerRef.Target Property

Gets or sets a reference to the type of the indexer.

public Expression Target {get; set;}

See Also

IndexerRef Class | DDW.CSharp.Dom Namespace


IntegerLiteral Class

An interger literal.

For a list of all members of this type, see IntegerLiteral Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Expression
DDW.CSharp.Dom.PrimitiveExpr
DDW.CSharp.Dom.IntegerLiteral

public class IntegerLiteral : PrimitiveExpr

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

IntegerLiteral Members | DDW.CSharp.Dom Namespace


IntegerLiteral Members

IntegerLiteral overview

Public Instance Constructors

IntegerLiteral Constructor Initializes a new instance of the IntegerLiteral class.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.
Value | Gets or sets the numeric value of this integer literal.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IntegerLiteral Class | DDW.CSharp.Dom Namespace


IntegerLiteral Constructor

Initializes a new instance of the IntegerLiteral class.

public IntegerLiteral();

See Also

IntegerLiteral Class | DDW.CSharp.Dom Namespace


IntegerLiteral Properties

The properties of the IntegerLiteral class are listed below. For a complete list of IntegerLiteral class members, see the IntegerLiteral Members topic.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.
Value | Gets or sets the numeric value of this integer literal.

See Also

IntegerLiteral Class | DDW.CSharp.Dom Namespace


Value Property

Goblin - A Platform for 3D AR and VR Applications

IntegerLiteral.Value Property

Gets or sets the numeric value of this integer literal.

public int Value {get; set;}

See Also

IntegerLiteral Class | DDW.CSharp.Dom Namespace


InterfaceDecl Class

An interface declartation.

For a list of all members of this type, see InterfaceDecl Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.MemberDecl
DDW.CSharp.Dom.TypeDecl
DDW.CSharp.Dom.InterfaceDecl

public class InterfaceDecl : TypeDecl, IScope

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

InterfaceDecl Members | DDW.CSharp.Dom Namespace


InterfaceDecl Members

InterfaceDecl overview

Public Instance Constructors

InterfaceDecl Constructor Initializes a new instance of the InterfaceDecl class.

Public Instance Properties

Attributes (inherited from MemberDecl) | Gets or sets the modifier flags for this member (public, private etc).
BaseTypes (inherited from TypeDecl) | Gets or sets the base types that are inherited by this type.
Comments (inherited from MemberDecl) | Gets the collection of comments for this member.
CustomAttributes (inherited from MemberDecl) | Gets the collection of Custom Attributes used for this member (custom attributes are the ones declared between brackets, like [Flags]).
Definition (inherited from TypeDecl) | Gets the (scoped) definition.
LinePragma (inherited from CSharpGraph) |
MemberKind (inherited from TypeDecl) |
Members (inherited from TypeDecl) | Gets a collection of type members in the current type (methods, fields etc.).
Name (inherited from TypeDecl) |
Scope |
TypeAttributes (inherited from TypeDecl) | Gets or sets the modifiers for the type (public, sealed etc). These values can be or'ed with each other. This was derived from the CodeDom, it may be changed for something more suitable.
TypeKind |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

DistanceToType |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
VerifyModifiers (inherited from MemberDecl) |

See Also

InterfaceDecl Class | DDW.CSharp.Dom Namespace


InterfaceDecl Constructor

Initializes a new instance of the InterfaceDecl class.

public InterfaceDecl();

See Also

InterfaceDecl Class | DDW.CSharp.Dom Namespace


InterfaceDecl Properties

The properties of the InterfaceDecl class are listed below. For a complete list of InterfaceDecl class members, see the InterfaceDecl Members topic.

Public Instance Properties

Attributes (inherited from MemberDecl) | Gets or sets the modifier flags for this member (public, private etc).
BaseTypes (inherited from TypeDecl) | Gets or sets the base types that are inherited by this type.
Comments (inherited from MemberDecl) | Gets the collection of comments for this member.
CustomAttributes (inherited from MemberDecl) | Gets the collection of Custom Attributes used for this member (custom attributes are the ones declared between brackets, like [Flags]).
Definition (inherited from TypeDecl) | Gets the (scoped) definition.
LinePragma (inherited from CSharpGraph) |
MemberKind (inherited from TypeDecl) |
Members (inherited from TypeDecl) | Gets a collection of type members in the current type (methods, fields etc.).
Name (inherited from TypeDecl) |
Scope |
TypeAttributes (inherited from TypeDecl) | Gets or sets the modifiers for the type (public, sealed etc). These values can be or'ed with each other. This was derived from the CodeDom, it may be changed for something more suitable.
TypeKind |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

InterfaceDecl Class | DDW.CSharp.Dom Namespace


Scope Property

Goblin - A Platform for 3D AR and VR Applications

InterfaceDecl.Scope Property

public DDW.CSharp.SymbolTable.Scope Scope {get; set;}

Implements

IScope.Scope

See Also

InterfaceDecl Class | DDW.CSharp.Dom Namespace


TypeKind Property

Goblin - A Platform for 3D AR and VR Applications

InterfaceDecl.TypeKind Property

public override TypeKind TypeKind {get;}

See Also

InterfaceDecl Class | DDW.CSharp.Dom Namespace


InterfaceDecl Methods

The methods of the InterfaceDecl class are listed below. For a complete list of InterfaceDecl class members, see the InterfaceDecl Members topic.

Public Instance Methods

DistanceToType |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
VerifyModifiers (inherited from MemberDecl) |

See Also

InterfaceDecl Class | DDW.CSharp.Dom Namespace


InterfaceDecl.DistanceToType Method

public override int DistanceToType(
IDefinition baseType,
int distance
);

See Also

InterfaceDecl Class | DDW.CSharp.Dom Namespace


IOverloadable Interface

For a list of all members of this type, see IOverloadable Members.

public interface IOverloadable

Types that implement IOverloadable

Type | Description
ConstructorDecl | A constructor declartation.
IndexerDecl | An indexer declartation.
MethodDecl | A method declaration.
OperatorDecl | An operator declartation.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

IOverloadable Members | DDW.CSharp.Dom Namespace


IOverloadable Members

IOverloadable overview

Public Instance Properties

HashText
Parameters

See Also

IOverloadable Interface | DDW.CSharp.Dom Namespace


IOverloadable Properties

The properties of the IOverloadable interface are listed below. For a complete list of IOverloadable interface members, see the IOverloadable Members topic.

Public Instance Properties

HashText
Parameters

See Also

IOverloadable Interface | DDW.CSharp.Dom Namespace


HashText Property

Goblin - A Platform for 3D AR and VR Applications

IOverloadable.HashText Property

string HashText {get;}

See Also

IOverloadable Interface | DDW.CSharp.Dom Namespace


Parameters Property

Goblin - A Platform for 3D AR and VR Applications

IOverloadable.Parameters Property

ParamDeclCollection Parameters {get;}

See Also

IOverloadable Interface | DDW.CSharp.Dom Namespace


IScope Interface

For a list of all members of this type, see IScope Members.

public interface IScope

Types that implement IScope

Type | Description
AccessorDecl | An accessor declartation.
ClassDecl | A class declartation.
CompileUnit | A C# file level unit of code. This must be a complete C# file, snippets are not valid.
ConstructorDecl | A constructor declartation.
DestructorDecl | A destructor declartation.
EnumDecl | An enum declartation.
IndexerDecl | An indexer declartation.
InterfaceDecl | An interface declartation.
MethodDecl | A method declaration.
NamespaceDecl | A namespace declaration.
OperatorDecl | An operator declartation.
StructDecl | A struct declartation.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

IScope Members | DDW.CSharp.Dom Namespace


IScope Members

IScope overview

Public Instance Properties

GraphType
Scope

See Also

IScope Interface | DDW.CSharp.Dom Namespace


IScope Properties

The properties of the IScope interface are listed below. For a complete list of IScope interface members, see the IScope Members topic.

Public Instance Properties

GraphType
Scope

See Also

IScope Interface | DDW.CSharp.Dom Namespace


GraphType Property

Goblin - A Platform for 3D AR and VR Applications

IScope.GraphType Property

GraphTypes GraphType {get;}

See Also

IScope Interface | DDW.CSharp.Dom Namespace


Scope Property

Goblin - A Platform for 3D AR and VR Applications

IScope.Scope Property

DDW.CSharp.SymbolTable.Scope Scope {get; set;}

See Also

IScope Interface | DDW.CSharp.Dom Namespace


ISymbolRef Interface

For a list of all members of this type, see ISymbolRef Members.

public interface ISymbolRef : IDeclaration

Types that implement ISymbolRef

Type | Description
ArgumentRef | An argument reference.
ArrayElementRef | A reference to a specific element of an array.
BaseRef | A 'base' reference.
BuiltInType | A C# built in type.
EventRef | A reference to an event.
FieldRef | A reference to a field.
IndexerRef | A reference to a class indexer.
LocalRef | A local reference.
MemberAccess | An expression that accesses a member of a variable (x.y).
MethodRef | A reference to a method.
PropertyRef | A reference to a property.
PropertySetValueRef | A 'value' reference, used inside a set accessor.
Reference | A variable.
ThisRef | A 'this' reference.
TypeRef | A reference to a type (interface, class, struct, enum, delegate - this includes built in types).
UnknownReference | A variable who's type has not yet been determined.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

ISymbolRef Members | DDW.CSharp.Dom Namespace


ISymbolRef Members

ISymbolRef overview

Public Instance Properties

Definition

See Also

ISymbolRef Interface | DDW.CSharp.Dom Namespace


ISymbolRef Properties

The properties of the ISymbolRef interface are listed below. For a complete list of ISymbolRef interface members, see the ISymbolRef Members topic.

Public Instance Properties

Definition

See Also

ISymbolRef Interface | DDW.CSharp.Dom Namespace


Definition Property

Goblin - A Platform for 3D AR and VR Applications

ISymbolRef.Definition Property

DDW.CSharp.SymbolTable.IDefinition Definition {get; set;}

See Also

ISymbolRef Interface | DDW.CSharp.Dom Namespace


IterationStmt Class

A loop construct. This can be a for, do or while loop, however foreach loops are treated separately (as a ForEachStmt).

For a list of all members of this type, see IterationStmt Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Statement
DDW.CSharp.Dom.IterationStmt

public class IterationStmt : Statement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

IterationStmt Members | DDW.CSharp.Dom Namespace


IterationStmt Members

IterationStmt overview

Public Instance Constructors

IterationStmt Constructor Initializes a new instance of the IterationStmt class.

Public Instance Properties

Increment | Gets a collection of statements that increments the loop.
Init | Gets a collection of statements that initalize the loop.
IterationType | Gets or sets the type of iteration (for, while, do). This is mostly useful when rebuilding code.
LinePragma (inherited from CSharpGraph) |
Statements | Gets the collection of statements that will be looped over.
Test | Gets or sets the test condition that determines if the loop will be terminated.
TestFirst | Gets or sets a flag that specifies the test happens at the start of a loop, like in a 'while' loop. 'For' and 'do' loops test at the end of the loop.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IterationStmt Class | DDW.CSharp.Dom Namespace


IterationStmt Constructor

Initializes a new instance of the IterationStmt class.

public IterationStmt();

See Also

IterationStmt Class | DDW.CSharp.Dom Namespace


IterationStmt Properties

The properties of the IterationStmt class are listed below. For a complete list of IterationStmt class members, see the IterationStmt Members topic.

Public Instance Properties

Increment | Gets a collection of statements that increments the loop.
Init | Gets a collection of statements that initalize the loop.
IterationType | Gets or sets the type of iteration (for, while, do). This is mostly useful when rebuilding code.
LinePragma (inherited from CSharpGraph) |
Statements | Gets the collection of statements that will be looped over.
Test | Gets or sets the test condition that determines if the loop will be terminated.
TestFirst | Gets or sets a flag that specifies the test happens at the start of a loop, like in a 'while' loop. 'For' and 'do' loops test at the end of the loop.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

IterationStmt Class | DDW.CSharp.Dom Namespace


Increment Property

Goblin - A Platform for 3D AR and VR Applications

IterationStmt.Increment Property

Gets a collection of statements that increments the loop.

public StatementCollection Increment {get;}

See Also

IterationStmt Class | DDW.CSharp.Dom Namespace


Init Property

Goblin - A Platform for 3D AR and VR Applications

IterationStmt.Init Property

Gets a collection of statements that initalize the loop.

public StatementCollection Init {get;}

See Also

IterationStmt Class | DDW.CSharp.Dom Namespace


IterationType Property

Goblin - A Platform for 3D AR and VR Applications

IterationStmt.IterationType Property

Gets or sets the type of iteration (for, while, do). This is mostly useful when rebuilding code.

public IterationType IterationType {get; set;}

See Also

IterationStmt Class | DDW.CSharp.Dom Namespace


Statements Property

Goblin - A Platform for 3D AR and VR Applications

IterationStmt.Statements Property

Gets the collection of statements that will be looped over.

public StatementCollection Statements {get;}

See Also

IterationStmt Class | DDW.CSharp.Dom Namespace


Test Property

Goblin - A Platform for 3D AR and VR Applications

IterationStmt.Test Property

Gets or sets the test condition that determines if the loop will be terminated.

public Expression Test {get; set;}

See Also

IterationStmt Class | DDW.CSharp.Dom Namespace


TestFirst Property

Goblin - A Platform for 3D AR and VR Applications

IterationStmt.TestFirst Property

Gets or sets a flag that specifies the test happens at the start of a loop, like in a 'while' loop. 'For' and 'do' loops test at the end of the loop.

public bool TestFirst {get;}

See Also

IterationStmt Class | DDW.CSharp.Dom Namespace


IterationType Enumeration

An enumeration of possible types of iterations (for, do, while, and foreach).

public enum IterationType

Members

Member Name | Description
For |
Do |
While |
ForEach |

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

DDW.CSharp.Dom Namespace


LabeledStmt Class

A labeled statement that can be jumped to with a goto statement.

For a list of all members of this type, see LabeledStmt Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Statement
DDW.CSharp.Dom.LabeledStmt

public class LabeledStmt : Statement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

LabeledStmt Members | DDW.CSharp.Dom Namespace


LabeledStmt Members

LabeledStmt overview

Public Instance Constructors

LabeledStmt Constructor Initializes a new instance of the LabeledStmt class.

Public Instance Properties

Label | Gets or sets the label text.
LinePragma (inherited from CSharpGraph) |
Statement | Gets or sets the statement the label is attached to.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LabeledStmt Class | DDW.CSharp.Dom Namespace


LabeledStmt Constructor

Initializes a new instance of the LabeledStmt class.

public LabeledStmt();

See Also

LabeledStmt Class | DDW.CSharp.Dom Namespace


LabeledStmt Properties

The properties of the LabeledStmt class are listed below. For a complete list of LabeledStmt class members, see the LabeledStmt Members topic.

Public Instance Properties

Label | Gets or sets the label text.
LinePragma (inherited from CSharpGraph) |
Statement | Gets or sets the statement the label is attached to.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

LabeledStmt Class | DDW.CSharp.Dom Namespace


Label Property

Goblin - A Platform for 3D AR and VR Applications

LabeledStmt.Label Property

Gets or sets the label text.

public string Label {get; set;}

See Also

LabeledStmt Class | DDW.CSharp.Dom Namespace


Statement Property

Goblin - A Platform for 3D AR and VR Applications

LabeledStmt.Statement Property

Gets or sets the statement the label is attached to.

public Statement Statement {get; set;}

See Also

LabeledStmt Class | DDW.CSharp.Dom Namespace | LabeledStmt.Statement Overload List


LinePragma Class

For a list of all members of this type, see LinePragma Members.

System.Object
DDW.CSharp.Dom.LinePragma

public class LinePragma

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

LinePragma Members | DDW.CSharp.Dom Namespace


LinePragma Members

LinePragma overview

Public Instance Constructors

LinePragma Constructor Initializes a new instance of the LinePragma class.

Public Instance Properties

Column
EndColumn
EndLine
FileName
Line

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LinePragma Class | DDW.CSharp.Dom Namespace


LinePragma Constructor

Initializes a new instance of the LinePragma class.

public LinePragma();

See Also

LinePragma Class | DDW.CSharp.Dom Namespace


LinePragma Properties

The properties of the LinePragma class are listed below. For a complete list of LinePragma class members, see the LinePragma Members topic.

Public Instance Properties

Column
EndColumn
EndLine
FileName
Line

See Also

LinePragma Class | DDW.CSharp.Dom Namespace


Column Property

Goblin - A Platform for 3D AR and VR Applications

LinePragma.Column Property

public int Column {get; set;}

See Also

LinePragma Class | DDW.CSharp.Dom Namespace


EndColumn Property

Goblin - A Platform for 3D AR and VR Applications

LinePragma.EndColumn Property

public int EndColumn {get; set;}

See Also

LinePragma Class | DDW.CSharp.Dom Namespace


EndLine Property

Goblin - A Platform for 3D AR and VR Applications

LinePragma.EndLine Property

public int EndLine {get; set;}

See Also

LinePragma Class | DDW.CSharp.Dom Namespace


FileName Property

Goblin - A Platform for 3D AR and VR Applications

LinePragma.FileName Property

public string FileName {get; set;}

See Also

LinePragma Class | DDW.CSharp.Dom Namespace


Line Property

Goblin - A Platform for 3D AR and VR Applications

LinePragma.Line Property

public int Line {get; set;}

See Also

LinePragma Class | DDW.CSharp.Dom Namespace


LinePragma Methods

The methods of the LinePragma class are listed below. For a complete list of LinePragma class members, see the LinePragma Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LinePragma Class | DDW.CSharp.Dom Namespace


LinePragma.ToString Method

public override string ToString();

See Also

LinePragma Class | DDW.CSharp.Dom Namespace


LocalRef Class

A local reference.

For a list of all members of this type, see LocalRef Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Expression
DDW.CSharp.Dom.Reference
DDW.CSharp.Dom.LocalRef

public class LocalRef : Reference

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

LocalRef Members | DDW.CSharp.Dom Namespace


LocalRef Members

LocalRef overview

Public Instance Constructors

LocalRef Constructor Initializes a new instance of the LocalRef class.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.
VariableName | Gets or sets the name of the variable.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LocalRef Class | DDW.CSharp.Dom Namespace


LocalRef Constructor

Initializes a new instance of the LocalRef class.

public LocalRef();

See Also

LocalRef Class | DDW.CSharp.Dom Namespace


LocalRef Properties

The properties of the LocalRef class are listed below. For a complete list of LocalRef class members, see the LocalRef Members topic.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.
VariableName | Gets or sets the name of the variable.

See Also

LocalRef Class | DDW.CSharp.Dom Namespace


VariableName Property

Goblin - A Platform for 3D AR and VR Applications

LocalRef.VariableName Property

Gets or sets the name of the variable.

public string VariableName {get; set;}

See Also

LocalRef Class | DDW.CSharp.Dom Namespace


LockStmt Class

A lock statement.

For a list of all members of this type, see LockStmt Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Statement
DDW.CSharp.Dom.LockStmt

public class LockStmt : Statement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

LockStmt Members | DDW.CSharp.Dom Namespace


LockStmt Members

LockStmt overview

Public Instance Constructors

LockStmt Constructor Initializes a new instance of the LockStmt class.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
Statements | Gets the collection of statements in the lock statement.
Target | Gets or sets the target to be locked for the duration of the statement block.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LockStmt Class | DDW.CSharp.Dom Namespace


LockStmt Constructor

Initializes a new instance of the LockStmt class.

public LockStmt();

See Also

LockStmt Class | DDW.CSharp.Dom Namespace


LockStmt Properties

The properties of the LockStmt class are listed below. For a complete list of LockStmt class members, see the LockStmt Members topic.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
Statements | Gets the collection of statements in the lock statement.
Target | Gets or sets the target to be locked for the duration of the statement block.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

LockStmt Class | DDW.CSharp.Dom Namespace


Statements Property

Goblin - A Platform for 3D AR and VR Applications

LockStmt.Statements Property

Gets the collection of statements in the lock statement.

public StatementCollection Statements {get;}

See Also

LockStmt Class | DDW.CSharp.Dom Namespace


Target Property

Goblin - A Platform for 3D AR and VR Applications

LockStmt.Target Property

Gets or sets the target to be locked for the duration of the statement block.

public Expression Target {get; set;}

See Also

LockStmt Class | DDW.CSharp.Dom Namespace


MemberAccess Class

An expression that accesses a member of a variable (x.y).

For a list of all members of this type, see MemberAccess Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Expression
DDW.CSharp.Dom.Reference
DDW.CSharp.Dom.MemberAccess

public class MemberAccess : Reference

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

MemberAccess Members | DDW.CSharp.Dom Namespace


MemberAccess Members

MemberAccess overview

Public Instance Constructors

MemberAccess Constructor Initializes a new instance of the MemberAccess class.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
MemberName | Gets or sets the name of the member to access.
Target | Gets or sets the target object to which the member being accessed belongs.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MemberAccess Class | DDW.CSharp.Dom Namespace


MemberAccess Constructor

Initializes a new instance of the MemberAccess class.

public MemberAccess();

See Also

MemberAccess Class | DDW.CSharp.Dom Namespace


MemberAccess Properties

The properties of the MemberAccess class are listed below. For a complete list of MemberAccess class members, see the MemberAccess Members topic.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
MemberName | Gets or sets the name of the member to access.
Target | Gets or sets the target object to which the member being accessed belongs.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

MemberAccess Class | DDW.CSharp.Dom Namespace


MemberName Property

Goblin - A Platform for 3D AR and VR Applications

MemberAccess.MemberName Property

Gets or sets the name of the member to access.

public string MemberName {get; set;}

See Also

MemberAccess Class | DDW.CSharp.Dom Namespace


Target Property

Goblin - A Platform for 3D AR and VR Applications

MemberAccess.Target Property

Gets or sets the target object to which the member being accessed belongs.

public Expression Target {get; set;}

See Also

MemberAccess Class | DDW.CSharp.Dom Namespace


MemberDecl Class

An abstract class for all types (class, struct...) and type members (method, field...).

For a list of all members of this type, see MemberDecl Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.MemberDecl
Derived types

public abstract class MemberDecl : CSharpGraph

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

MemberDecl Members | DDW.CSharp.Dom Namespace


MemberDecl Members

MemberDecl overview

Public Instance Properties

Attributes | Gets or sets the modifier flags for this member (public, private etc).
Comments | Gets the collection of comments for this member.
CustomAttributes | Gets the collection of Custom Attributes used for this member (custom attributes are the ones declared between brackets, like [Flags]).
GraphType (inherited from CSharpGraph) |
LinePragma (inherited from CSharpGraph) |
MemberKind |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

MemberDecl Constructor Initializes a new instance of the MemberDecl class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
VerifyModifiers |

See Also

MemberDecl Class | DDW.CSharp.Dom Namespace


MemberDecl Constructor

Initializes a new instance of the MemberDecl class.

protected MemberDecl();

See Also

MemberDecl Class | DDW.CSharp.Dom Namespace


MemberDecl Properties

The properties of the MemberDecl class are listed below. For a complete list of MemberDecl class members, see the MemberDecl Members topic.

Public Instance Properties

Attributes | Gets or sets the modifier flags for this member (public, private etc).
Comments | Gets the collection of comments for this member.
CustomAttributes | Gets the collection of Custom Attributes used for this member (custom attributes are the ones declared between brackets, like [Flags]).
GraphType (inherited from CSharpGraph) |
LinePragma (inherited from CSharpGraph) |
MemberKind |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

MemberDecl Class | DDW.CSharp.Dom Namespace


Attributes Property

Goblin - A Platform for 3D AR and VR Applications

MemberDecl.Attributes Property

Gets or sets the modifier flags for this member (public, private etc).

public Modifiers Attributes {get; set;}

See Also

MemberDecl Class | DDW.CSharp.Dom Namespace


Comments Property

Goblin - A Platform for 3D AR and VR Applications

MemberDecl.Comments Property

Gets the collection of comments for this member.

public CommentStmtCollection Comments {get;}

See Also

MemberDecl Class | DDW.CSharp.Dom Namespace


CustomAttributes Property

Goblin - A Platform for 3D AR and VR Applications

MemberDecl.CustomAttributes Property

Gets the collection of Custom Attributes used for this member (custom attributes are the ones declared between brackets, like [Flags]).

public CustomAttributeCollection CustomAttributes {get;}

See Also

MemberDecl Class | DDW.CSharp.Dom Namespace


MemberKind Property

Goblin - A Platform for 3D AR and VR Applications

MemberDecl.MemberKind Property

public abstract MemberKind MemberKind {get;}

See Also

MemberDecl Class | DDW.CSharp.Dom Namespace


MemberDecl Methods

The methods of the MemberDecl class are listed below. For a complete list of MemberDecl class members, see the MemberDecl Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
VerifyModifiers |

See Also

MemberDecl Class | DDW.CSharp.Dom Namespace


MemberDecl.VerifyModifiers Method

protected virtual bool VerifyModifiers();

See Also

MemberDecl Class | DDW.CSharp.Dom Namespace


MemberDeclCollection Class

A strongly-typed collection of MemberDecl objects.

For a list of all members of this type, see MemberDeclCollection Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.MemberDeclCollection

public class MemberDeclCollection : CSharpGraph, IList, ICollection, IEnumerable, ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

MemberDeclCollection Members | DDW.CSharp.Dom Namespace


MemberDeclCollection Members

MemberDeclCollection overview

Public Static Methods

ReadOnly | Creates a read-only wrapper for a MemberDeclCollection instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a MemberDeclCollection instance.

Public Instance Constructors

MemberDeclCollection Overloaded. Initializes a new instance of the MemberDeclCollection class.

Public Instance Properties

Capacity | Gets or sets the number of elements the MemberDeclCollection can contain.
Count | Gets the number of elements actually contained in the MemberDeclCollection.
GraphType |
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the MemberDecl at the specified index.
LinePragma (inherited from CSharpGraph) |
SyncRoot | Gets an object that can be used to synchronize access to the collection.
Text |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Add | Adds a MemberDecl to the end of the MemberDeclCollection.
AddRange | Overloaded. Adds the elements of a MemberDecl array to the current MemberDeclCollection.
Clear | Removes all elements from the MemberDeclCollection.
Clone | Creates a shallow copy of the MemberDeclCollection.
Contains | Determines whether a given MemberDecl is in the MemberDeclCollection.
CopyTo | Overloaded. Copies the entire MemberDeclCollection to a one-dimensional MemberDecl array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the MemberDeclCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the zero-based index of the first occurrence of a MemberDecl in the MemberDeclCollection.
Insert | Inserts an element into the MemberDeclCollection at the specified index.
Remove | Removes the first occurrence of a specific MemberDecl from the MemberDeclCollection.
RemoveAt | Removes the element at the specified index of the MemberDeclCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Constructors

MemberDeclCollection Overloaded. Initializes a new instance of the MemberDeclCollection class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MemberDeclCollection Class | DDW.CSharp.Dom Namespace


MemberDeclCollection Constructor

Initializes a new instance of the MemberDeclCollection class that is empty and has the default initial capacity.

Overload List

Initializes a new instance of the MemberDeclCollection class that is empty and has the default initial capacity.

public MemberDeclCollection();

Initializes a new instance of the MemberDeclCollection class that contains elements copied from the specified MemberDecl array.

public MemberDeclCollection(MemberDecl[]);

Initializes a new instance of the MemberDeclCollection class that contains elements copied from the specified MemberDeclCollection.

public MemberDeclCollection(MemberDeclCollection);

protected MemberDeclCollection(Tag);

Initializes a new instance of the MemberDeclCollection class that has the specified initial capacity.

public MemberDeclCollection(int);

See Also

MemberDeclCollection Class | DDW.CSharp.Dom Namespace


MemberDeclCollection Constructor ()

Initializes a new instance of the MemberDeclCollection class that is empty and has the default initial capacity.

public MemberDeclCollection();

See Also

MemberDeclCollection Class | DDW.CSharp.Dom Namespace | MemberDeclCollection Constructor Overload List


MemberDeclCollection Constructor (Int32)

Initializes a new instance of the MemberDeclCollection class that has the specified initial capacity.

public MemberDeclCollection(
int capacity
);

Parameters

capacity
The number of elements that the new MemberDeclCollection is initially capable of storing.

See Also

MemberDeclCollection Class | DDW.CSharp.Dom Namespace | MemberDeclCollection Constructor Overload List


MemberDeclCollection Constructor (MemberDeclCollection)

Initializes a new instance of the MemberDeclCollection class that contains elements copied from the specified MemberDeclCollection.

public MemberDeclCollection(
MemberDeclCollection c
);

Parameters

c
The MemberDeclCollection whose elements are copied to the new collection.

See Also

MemberDeclCollection Class | DDW.CSharp.Dom Namespace | MemberDeclCollection Constructor Overload List


MemberDeclCollection Constructor (MemberDecl[])

Initializes a new instance of the MemberDeclCollection class that contains elements copied from the specified MemberDecl array.

public MemberDeclCollection(
MemberDecl[] a
);

Parameters

a
The MemberDecl array whose elements are copied to the new list.

See Also

MemberDeclCollection Class | DDW.CSharp.Dom Namespace | MemberDeclCollection Constructor Overload List


MemberDeclCollection Constructor (Tag)

protected MemberDeclCollection(
Tag t
);

See Also

MemberDeclCollection Class | DDW.CSharp.Dom Namespace | MemberDeclCollection Constructor Overload List


MemberDeclCollection Properties

The properties of the MemberDeclCollection class are listed below. For a complete list of MemberDeclCollection class members, see the MemberDeclCollection Members topic.

Public Instance Properties

Capacity | Gets or sets the number of elements the MemberDeclCollection can contain.
Count | Gets the number of elements actually contained in the MemberDeclCollection.
GraphType |
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the MemberDecl at the specified index.
LinePragma (inherited from CSharpGraph) |
SyncRoot | Gets an object that can be used to synchronize access to the collection.
Text |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

MemberDeclCollection Class | DDW.CSharp.Dom Namespace


Capacity Property

Goblin - A Platform for 3D AR and VR Applications

MemberDeclCollection.Capacity Property

Gets or sets the number of elements the MemberDeclCollection can contain.

public virtual int Capacity {get; set;}

See Also

MemberDeclCollection Class | DDW.CSharp.Dom Namespace


Count Property

Goblin - A Platform for 3D AR and VR Applications

MemberDeclCollection.Count Property

Gets the number of elements actually contained in the MemberDeclCollection.

public virtual int Count {get;}

Implements

ICollection.Count

See Also

MemberDeclCollection Class | DDW.CSharp.Dom Namespace


GraphType Property

Goblin - A Platform for 3D AR and VR Applications

MemberDeclCollection.GraphType Property

public override GraphTypes GraphType {get;}

Implements

IGraph.GraphType

See Also

MemberDeclCollection Class | DDW.CSharp.Dom Namespace


IsFixedSize Property

Goblin - A Platform for 3D AR and VR Applications

MemberDeclCollection.IsFixedSize Property

Gets a value indicating whether the collection has a fixed size.

public virtual bool IsFixedSize {get;}

Property Value

true if the collection has a fixed size; otherwise, false. The default is false

Implements

IList.IsFixedSize

See Also

MemberDeclCollection Class | DDW.CSharp.Dom Namespace


IsReadOnly Property

Goblin - A Platform for 3D AR and VR Applications

MemberDeclCollection.IsReadOnly Property

gets a value indicating whether the IList is read-only.

public virtual bool IsReadOnly {get;}

Property Value

true if the collection is read-only; otherwise, false. The default is false

Implements

IList.IsReadOnly

See Also

MemberDeclCollection Class | DDW.CSharp.Dom Namespace


IsSynchronized Property

Goblin - A Platform for 3D AR and VR Applications

MemberDeclCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread-safe).

public virtual bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

MemberDeclCollection Class | DDW.CSharp.Dom Namespace


Item Property

Goblin - A Platform for 3D AR and VR Applications

MemberDeclCollection.Item Property

Gets or sets the MemberDecl at the specified index.

public virtual MemberDecl this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

MemberDeclCollection Class | DDW.CSharp.Dom Namespace


SyncRoot Property

Goblin - A Platform for 3D AR and VR Applications

MemberDeclCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

public virtual object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

MemberDeclCollection Class | DDW.CSharp.Dom Namespace


Text Property

Goblin - A Platform for 3D AR and VR Applications

MemberDeclCollection.Text Property

public override string Text {get;}

Implements

IGraph.Text

See Also

MemberDeclCollection Class | DDW.CSharp.Dom Namespace


MemberDeclCollection Methods

The methods of the MemberDeclCollection class are listed below. For a complete list of MemberDeclCollection class members, see the MemberDeclCollection Members topic.

Public Static Methods

ReadOnly | Creates a read-only wrapper for a MemberDeclCollection instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a MemberDeclCollection instance.

Public Instance Methods

Add | Adds a MemberDecl to the end of the MemberDeclCollection.
AddRange | Overloaded. Adds the elements of a MemberDecl array to the current MemberDeclCollection.
Clear | Removes all elements from the MemberDeclCollection.
Clone | Creates a shallow copy of the MemberDeclCollection.
Contains | Determines whether a given MemberDecl is in the MemberDeclCollection.
CopyTo | Overloaded. Copies the entire MemberDeclCollection to a one-dimensional MemberDecl array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the MemberDeclCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the zero-based index of the first occurrence of a MemberDecl in the MemberDeclCollection.
Insert | Inserts an element into the MemberDeclCollection at the specified index.
Remove | Removes the first occurrence of a specific MemberDecl from the MemberDeclCollection.
RemoveAt | Removes the element at the specified index of the MemberDeclCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MemberDeclCollection Class | DDW.CSharp.Dom Namespace


MemberDeclCollection.Add Method

Adds a MemberDecl to the end of the MemberDeclCollection.

public virtual int Add(
MemberDecl item
);

Parameters

item
The MemberDecl to be added to the end of the MemberDeclCollection.

Return Value

The index at which the value has been added.

See Also

MemberDeclCollection Class | DDW.CSharp.Dom Namespace


AddRange Method

Goblin - A Platform for 3D AR and VR Applications

MemberDeclCollection.AddRange Method

Adds the elements of a MemberDecl array to the current MemberDeclCollection.

Overload List

Adds the elements of a MemberDecl array to the current MemberDeclCollection.

public virtual int AddRange(MemberDecl[]);

Adds the elements of another MemberDeclCollection to the current MemberDeclCollection.

public virtual int AddRange(MemberDeclCollection);

See Also

MemberDeclCollection Class | DDW.CSharp.Dom Namespace


MemberDeclCollection.AddRange Method (MemberDecl[])

Adds the elements of a MemberDecl array to the current MemberDeclCollection.

public virtual int AddRange(
MemberDecl[] x
);

Parameters

x
The MemberDecl array whose elements should be added to the end of the MemberDeclCollection.

Return Value

The new Count of the MemberDeclCollection.

See Also

MemberDeclCollection Class | DDW.CSharp.Dom Namespace | MemberDeclCollection.AddRange Overload List


MemberDeclCollection.AddRange Method (MemberDeclCollection)

Adds the elements of another MemberDeclCollection to the current MemberDeclCollection.

public virtual int AddRange(
MemberDeclCollection x
);

Parameters

x
The MemberDeclCollection whose elements should be added to the end of the current MemberDeclCollection.

Return Value

The new Count of the MemberDeclCollection.

See Also

MemberDeclCollection Class | DDW.CSharp.Dom Namespace | MemberDeclCollection.AddRange Overload List


MemberDeclCollection.Clear Method

Removes all elements from the MemberDeclCollection.

public virtual void Clear();

Implements

IList.Clear

See Also

MemberDeclCollection Class | DDW.CSharp.Dom Namespace


MemberDeclCollection.Clone Method

Creates a shallow copy of the MemberDeclCollection.

public virtual object Clone();

Implements

ICloneable.Clone

See Also

MemberDeclCollection Class | DDW.CSharp.Dom Namespace


MemberDeclCollection.Contains Method

Determines whether a given MemberDecl is in the MemberDeclCollection.

public virtual bool Contains(
MemberDecl item
);

Parameters

item
The MemberDecl to check for.

Return Value

true if item is found in the MemberDeclCollection; otherwise, false.

See Also

MemberDeclCollection Class | DDW.CSharp.Dom Namespace


CopyTo Method

Goblin - A Platform for 3D AR and VR Applications

MemberDeclCollection.CopyTo Method

Copies the entire MemberDeclCollection to a one-dimensional MemberDecl array.

Overload List

Copies the entire MemberDeclCollection to a one-dimensional MemberDecl array.

public virtual void CopyTo(MemberDecl[]);

Copies the entire MemberDeclCollection to a one-dimensional MemberDecl array, starting at the specified index of the target array.

public virtual void CopyTo(MemberDecl[],int);

See Also

MemberDeclCollection Class | DDW.CSharp.Dom Namespace


MemberDeclCollection.CopyTo Method (MemberDecl[])

Copies the entire MemberDeclCollection to a one-dimensional MemberDecl array.

public virtual void CopyTo(
MemberDecl[] array
);

Parameters

array
The one-dimensional MemberDecl array to copy to.

See Also

MemberDeclCollection Class | DDW.CSharp.Dom Namespace | MemberDeclCollection.CopyTo Overload List


MemberDeclCollection.CopyTo Method (MemberDecl[], Int32)

Copies the entire MemberDeclCollection to a one-dimensional MemberDecl array, starting at the specified index of the target array.

public virtual void CopyTo(
MemberDecl[] array,
int start
);

Parameters

array
The one-dimensional MemberDecl array to copy to.
start
The zero-based index in array at which copying begins.

See Also

MemberDeclCollection Class | DDW.CSharp.Dom Namespace | MemberDeclCollection.CopyTo Overload List


MemberDeclCollection.GetEnumerator Method

Returns an enumerator that can iterate through the MemberDeclCollection.

public virtual IMemberDeclCollectionEnumerator GetEnumerator();

Return Value

An Enumerator for the entire MemberDeclCollection.

See Also

MemberDeclCollection Class | DDW.CSharp.Dom Namespace


MemberDeclCollection.IndexOf Method

Returns the zero-based index of the first occurrence of a MemberDecl in the MemberDeclCollection.

public virtual int IndexOf(
MemberDecl item
);

Parameters

item
The MemberDecl to locate in the MemberDeclCollection.

Return Value

The zero-based index of the first occurrence of item in the entire MemberDeclCollection, if found; otherwise, -1.

See Also

MemberDeclCollection Class | DDW.CSharp.Dom Namespace


MemberDeclCollection.Insert Method

Inserts an element into the MemberDeclCollection at the specified index.

public virtual void Insert(
int index,
MemberDecl item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The MemberDecl to insert.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

MemberDeclCollection Class | DDW.CSharp.Dom Namespace


MemberDeclCollection.ReadOnly Method

Creates a read-only wrapper for a MemberDeclCollection instance.

public static MemberDeclCollection ReadOnly(
MemberDeclCollection list
);

Return Value

An MemberDeclCollection wrapper that is read-only.

See Also

MemberDeclCollection Class | DDW.CSharp.Dom Namespace


MemberDeclCollection.Remove Method

Removes the first occurrence of a specific MemberDecl from the MemberDeclCollection.

public virtual void Remove(
MemberDecl item
);

Parameters

item
The MemberDecl to remove from the MemberDeclCollection.

Exceptions

Exception Type | Condition
ArgumentException | The specified MemberDecl was not found in the MemberDeclCollection.

See Also

MemberDeclCollection Class | DDW.CSharp.Dom Namespace


MemberDeclCollection.RemoveAt Method

Removes the element at the specified index of the MemberDeclCollection.

public virtual void RemoveAt(
int index
);

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

MemberDeclCollection Class | DDW.CSharp.Dom Namespace


MemberDeclCollection.Synchronized Method

Creates a synchronized (thread-safe) wrapper for a MemberDeclCollection instance.

public static MemberDeclCollection Synchronized(
MemberDeclCollection list
);

Return Value

An MemberDeclCollection wrapper that is synchronized (thread-safe).

See Also

MemberDeclCollection Class | DDW.CSharp.Dom Namespace


MemberDeclCollection.TrimToSize Method

Sets the capacity to the actual number of elements.

public virtual void TrimToSize();

See Also

MemberDeclCollection Class | DDW.CSharp.Dom Namespace


MemberDeclCollection.IMemberDeclCollectionEnumerator Interface

Supports type-safe iteration over a MemberDeclCollection.

For a list of all members of this type, see MemberDeclCollection.IMemberDeclCollectionEnumerator Members.

public interface MemberDeclCollection.IMemberDeclCollectionEnumerator

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

MemberDeclCollection.IMemberDeclCollectionEnumerator Members | DDW.CSharp.Dom Namespace


MemberDeclCollection.IMemberDeclCollectionEnumerator Members

MemberDeclCollection.IMemberDeclCollectionEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

MemberDeclCollection.IMemberDeclCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


MemberDeclCollection.IMemberDeclCollectionEnumerator Properties

The properties of the MemberDeclCollection.IMemberDeclCollectionEnumerator interface are listed below. For a complete list of MemberDeclCollection.IMemberDeclCollectionEnumerator interface members, see the MemberDeclCollection.IMemberDeclCollectionEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

MemberDeclCollection.IMemberDeclCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


Current Property

Goblin - A Platform for 3D AR and VR Applications

MemberDeclCollection.IMemberDeclCollectionEnumerator.Current Property

Gets the current element in the collection.

MemberDecl Current {get;}

See Also

MemberDeclCollection.IMemberDeclCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


MemberDeclCollection.IMemberDeclCollectionEnumerator Methods

The methods of the MemberDeclCollection.IMemberDeclCollectionEnumerator interface are listed below. For a complete list of MemberDeclCollection.IMemberDeclCollectionEnumerator interface members, see the MemberDeclCollection.IMemberDeclCollectionEnumerator Members topic.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

MemberDeclCollection.IMemberDeclCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


MemberDeclCollection.IMemberDeclCollectionEnumerator.MoveNext Method

Advances the enumerator to the next element in the collection.

bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Exceptions

Exception Type | Condition
InvalidOperationException | The collection was modified after the enumerator was created.

See Also

MemberDeclCollection.IMemberDeclCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


MemberDeclCollection.IMemberDeclCollectionEnumerator.Reset Method

Sets the enumerator to its initial position, before the first element in the collection.

void Reset();

See Also

MemberDeclCollection.IMemberDeclCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


MemberDeclCollection.Tag Enumeration

protected enum MemberDeclCollection.Tag

Members

Member Name | Description
Default |

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

DDW.CSharp.Dom Namespace


MemberKind Enumeration

An enumeration of possible type kinds (class, interface, enum etc).

public enum MemberKind

Members

Member Name | Description
Empty |
Method |
Field |
Property |
Event |
Constant |
Indexer |
Operator |
Constructor |
Destructor |
Accessor |
EnumMember |
Type |

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

DDW.CSharp.Dom Namespace


MethodDecl Class

A method declaration.

For a list of all members of this type, see MethodDecl Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.MemberDecl
DDW.CSharp.Dom.MethodDecl

public class MethodDecl : MemberDecl, IDeclaration, IScope, IOverloadable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

MethodDecl Members | DDW.CSharp.Dom Namespace


MethodDecl Members

MethodDecl overview

Public Instance Constructors

MethodDecl Constructor Initializes a new instance of the MethodDecl class.

Public Instance Properties

Attributes (inherited from MemberDecl) | Gets or sets the modifier flags for this member (public, private etc).
Comments (inherited from MemberDecl) | Gets the collection of comments for this member.
CustomAttributes (inherited from MemberDecl) | Gets the collection of Custom Attributes used for this member (custom attributes are the ones declared between brackets, like [Flags]).
Definition | Gets the (scoped) definition.
LinePragma (inherited from CSharpGraph) |
MemberKind |
Name | Gets or sets the name of the method. This may use dot syntax.
Parameters | Gets the collection of parameters for the method. Each of these hold information about the type, direction etc.
ReturnType | Gets or sets the return type of the method.
ReturnTypeCustomAttributes | Gets the collection of custom attributes that apply to the return type of the method.
Scope |
Statements | Gets the collection of statements in the method.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
VerifyModifiers (inherited from MemberDecl) |

See Also

MethodDecl Class | DDW.CSharp.Dom Namespace


MethodDecl Constructor

Initializes a new instance of the MethodDecl class.

public MethodDecl();

See Also

MethodDecl Class | DDW.CSharp.Dom Namespace


MethodDecl Properties

The properties of the MethodDecl class are listed below. For a complete list of MethodDecl class members, see the MethodDecl Members topic.

Public Instance Properties

Attributes (inherited from MemberDecl) | Gets or sets the modifier flags for this member (public, private etc).
Comments (inherited from MemberDecl) | Gets the collection of comments for this member.
CustomAttributes (inherited from MemberDecl) | Gets the collection of Custom Attributes used for this member (custom attributes are the ones declared between brackets, like [Flags]).
Definition | Gets the (scoped) definition.
LinePragma (inherited from CSharpGraph) |
MemberKind |
Name | Gets or sets the name of the method. This may use dot syntax.
Parameters | Gets the collection of parameters for the method. Each of these hold information about the type, direction etc.
ReturnType | Gets or sets the return type of the method.
ReturnTypeCustomAttributes | Gets the collection of custom attributes that apply to the return type of the method.
Scope |
Statements | Gets the collection of statements in the method.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

MethodDecl Class | DDW.CSharp.Dom Namespace


Definition Property

Goblin - A Platform for 3D AR and VR Applications

MethodDecl.Definition Property

Gets the (scoped) definition.

public DDW.CSharp.SymbolTable.IDefinition Definition {get;}

Implements

IDeclaration.Definition

See Also

MethodDecl Class | DDW.CSharp.Dom Namespace


MemberKind Property

Goblin - A Platform for 3D AR and VR Applications

MethodDecl.MemberKind Property

public override MemberKind MemberKind {get;}

See Also

MethodDecl Class | DDW.CSharp.Dom Namespace


Name Property

Goblin - A Platform for 3D AR and VR Applications

MethodDecl.Name Property

Gets or sets the name of the method. This may use dot syntax.

public string Name {get; set;}

See Also

MethodDecl Class | DDW.CSharp.Dom Namespace


Parameters Property

Goblin - A Platform for 3D AR and VR Applications

MethodDecl.Parameters Property

Gets the collection of parameters for the method. Each of these hold information about the type, direction etc.

public ParamDeclCollection Parameters {get;}

Implements

IOverloadable.Parameters

See Also

MethodDecl Class | DDW.CSharp.Dom Namespace


ReturnType Property

Goblin - A Platform for 3D AR and VR Applications

MethodDecl.ReturnType Property

Gets or sets the return type of the method.

public TypeRef ReturnType {get; set;}

See Also

MethodDecl Class | DDW.CSharp.Dom Namespace


ReturnTypeCustomAttributes Property

Goblin - A Platform for 3D AR and VR Applications

MethodDecl.ReturnTypeCustomAttributes Property

Gets the collection of custom attributes that apply to the return type of the method.

public CustomAttributeCollection ReturnTypeCustomAttributes {get;}

See Also

MethodDecl Class | DDW.CSharp.Dom Namespace


Scope Property

Goblin - A Platform for 3D AR and VR Applications

MethodDecl.Scope Property

public DDW.CSharp.SymbolTable.Scope Scope {get; set;}

Implements

IScope.Scope

See Also

MethodDecl Class | DDW.CSharp.Dom Namespace


Statements Property

Goblin - A Platform for 3D AR and VR Applications

MethodDecl.Statements Property

Gets the collection of statements in the method.

public StatementCollection Statements {get;}

See Also

MethodDecl Class | DDW.CSharp.Dom Namespace


MethodInvokeExpr Class

Invokes a method with the given parameters.

For a list of all members of this type, see MethodInvokeExpr Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Expression
DDW.CSharp.Dom.MethodInvokeExpr

public class MethodInvokeExpr : Expression

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

MethodInvokeExpr Members | DDW.CSharp.Dom Namespace


MethodInvokeExpr Members

MethodInvokeExpr overview

Public Instance Constructors

MethodInvokeExpr Constructor Initializes a new instance of the MethodInvokeExpr class.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
Parameters | Gets the collection of parameters to be passed to the invoked method.
Target | Gets or sets a reference to the method being invoked.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MethodInvokeExpr Class | DDW.CSharp.Dom Namespace


MethodInvokeExpr Constructor

Initializes a new instance of the MethodInvokeExpr class.

public MethodInvokeExpr();

See Also

MethodInvokeExpr Class | DDW.CSharp.Dom Namespace


MethodInvokeExpr Properties

The properties of the MethodInvokeExpr class are listed below. For a complete list of MethodInvokeExpr class members, see the MethodInvokeExpr Members topic.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
Parameters | Gets the collection of parameters to be passed to the invoked method.
Target | Gets or sets a reference to the method being invoked.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

MethodInvokeExpr Class | DDW.CSharp.Dom Namespace


Parameters Property

Goblin - A Platform for 3D AR and VR Applications

MethodInvokeExpr.Parameters Property

Gets the collection of parameters to be passed to the invoked method.

public ParamCollection Parameters {get;}

See Also

MethodInvokeExpr Class | DDW.CSharp.Dom Namespace


Target Property

Goblin - A Platform for 3D AR and VR Applications

MethodInvokeExpr.Target Property

Gets or sets a reference to the method being invoked.

public MethodRef Target {get; set;}

See Also

MethodInvokeExpr Class | DDW.CSharp.Dom Namespace


MethodRef Class

A reference to a method.

For a list of all members of this type, see MethodRef Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Expression
DDW.CSharp.Dom.Reference
DDW.CSharp.Dom.MethodRef

public class MethodRef : Reference

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

MethodRef Members | DDW.CSharp.Dom Namespace


MethodRef Members

MethodRef overview

Public Instance Constructors

MethodRef Constructor Initializes a new instance of the MethodRef class.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
MethodName | Gets or sets the name of the method.
Target | Gets or sets the target object to which the method belongs.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MethodRef Class | DDW.CSharp.Dom Namespace


MethodRef Constructor

Initializes a new instance of the MethodRef class.

public MethodRef();

See Also

MethodRef Class | DDW.CSharp.Dom Namespace


MethodRef Properties

The properties of the MethodRef class are listed below. For a complete list of MethodRef class members, see the MethodRef Members topic.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
MethodName | Gets or sets the name of the method.
Target | Gets or sets the target object to which the method belongs.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

MethodRef Class | DDW.CSharp.Dom Namespace


MethodName Property

Goblin - A Platform for 3D AR and VR Applications

MethodRef.MethodName Property

Gets or sets the name of the method.

public string MethodName {get; set;}

See Also

MethodRef Class | DDW.CSharp.Dom Namespace


Target Property

Goblin - A Platform for 3D AR and VR Applications

MethodRef.Target Property

Gets or sets the target object to which the method belongs.

public Expression Target {get; set;}

See Also

MethodRef Class | DDW.CSharp.Dom Namespace


Modifiers Enumeration

A bit field enumeration of the modifier attributes that can be applied to type members (eg. public, static, override etc).

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum Modifiers

Members

Member Name | Description | Value
Empty |  | 0
New |  | 1
Public |  | 2
Protected |  | 4
Internal |  | 8
Private |  | 16
Static |  | 32
Virtual |  | 64
Sealed |  | 128
Override |  | 256
Abstract |  | 512
Extern |  | 1024
Readonly |  | 2048
Volatile |  | 4096

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

DDW.CSharp.Dom Namespace


NamespaceDecl Class

A namespace declaration.

For a list of all members of this type, see NamespaceDecl Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.NamespaceDecl

public class NamespaceDecl : CSharpGraph, IScope, IDeclaration

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

NamespaceDecl Members | DDW.CSharp.Dom Namespace


NamespaceDecl Members

NamespaceDecl overview

Public Instance Constructors

NamespaceDecl Constructor Initializes a new instance of the NamespaceDecl class.

Public Instance Properties

Definition | Gets the (scoped) definition.
Imports | Gets the collection of imports ('using' declarations) for this namespace.
LinePragma (inherited from CSharpGraph) |
Name | Gets or sets the name of the namespace. This may use dot syntax.
Scope |
Types | A collection of types declared in this namespace (classes, interfaces, structs, etc).
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NamespaceDecl Class | DDW.CSharp.Dom Namespace


NamespaceDecl Constructor

Initializes a new instance of the NamespaceDecl class.

public NamespaceDecl();

See Also

NamespaceDecl Class | DDW.CSharp.Dom Namespace


NamespaceDecl Properties

The properties of the NamespaceDecl class are listed below. For a complete list of NamespaceDecl class members, see the NamespaceDecl Members topic.

Public Instance Properties

Definition | Gets the (scoped) definition.
Imports | Gets the collection of imports ('using' declarations) for this namespace.
LinePragma (inherited from CSharpGraph) |
Name | Gets or sets the name of the namespace. This may use dot syntax.
Scope |
Types | A collection of types declared in this namespace (classes, interfaces, structs, etc).
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

NamespaceDecl Class | DDW.CSharp.Dom Namespace


Definition Property

Goblin - A Platform for 3D AR and VR Applications

NamespaceDecl.Definition Property

Gets the (scoped) definition.

public DDW.CSharp.SymbolTable.IDefinition Definition {get;}

Implements

IDeclaration.Definition

See Also

NamespaceDecl Class | DDW.CSharp.Dom Namespace


Imports Property

Goblin - A Platform for 3D AR and VR Applications

NamespaceDecl.Imports Property

Gets the collection of imports ('using' declarations) for this namespace.

public ImportCollection Imports {get;}

See Also

NamespaceDecl Class | DDW.CSharp.Dom Namespace


Name Property

Goblin - A Platform for 3D AR and VR Applications

NamespaceDecl.Name Property

Gets or sets the name of the namespace. This may use dot syntax.

public string Name {get; set;}

See Also

NamespaceDecl Class | DDW.CSharp.Dom Namespace


Scope Property

Goblin - A Platform for 3D AR and VR Applications

NamespaceDecl.Scope Property

public DDW.CSharp.SymbolTable.Scope Scope {get; set;}

Implements

IScope.Scope

See Also

NamespaceDecl Class | DDW.CSharp.Dom Namespace


Types Property

Goblin - A Platform for 3D AR and VR Applications

NamespaceDecl.Types Property

A collection of types declared in this namespace (classes, interfaces, structs, etc).

public TypeDeclCollection Types {get; set;}

See Also

NamespaceDecl Class | DDW.CSharp.Dom Namespace


NamespaceDeclCollection Class

A strongly-typed collection of NamespaceDecl objects.

For a list of all members of this type, see NamespaceDeclCollection Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.NamespaceDeclCollection

public class NamespaceDeclCollection : CSharpGraph, IList, ICollection, IEnumerable, ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

NamespaceDeclCollection Members | DDW.CSharp.Dom Namespace


NamespaceDeclCollection Members

NamespaceDeclCollection overview

Public Static Methods

ReadOnly | Creates a read-only wrapper for a NamespaceDeclCollection instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a NamespaceDeclCollection instance.

Public Instance Constructors

NamespaceDeclCollection Overloaded. Initializes a new instance of the NamespaceDeclCollection class.

Public Instance Properties

Capacity | Gets or sets the number of elements the NamespaceDeclCollection can contain.
Count | Gets the number of elements actually contained in the NamespaceDeclCollection.
GraphType |
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the NamespaceDecl at the specified index.
LinePragma (inherited from CSharpGraph) |
SyncRoot | Gets an object that can be used to synchronize access to the collection.
Text |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Add | Adds a NamespaceDecl to the end of the NamespaceDeclCollection.
AddRange | Overloaded. Adds the elements of a NamespaceDecl array to the current NamespaceDeclCollection.
Clear | Removes all elements from the NamespaceDeclCollection.
Clone | Creates a shallow copy of the NamespaceDeclCollection.
Contains | Determines whether a given NamespaceDecl is in the NamespaceDeclCollection.
CopyTo | Overloaded. Copies the entire NamespaceDeclCollection to a one-dimensional NamespaceDecl array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the NamespaceDeclCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the zero-based index of the first occurrence of a NamespaceDecl in the NamespaceDeclCollection.
Insert | Inserts an element into the NamespaceDeclCollection at the specified index.
Remove | Removes the first occurrence of a specific NamespaceDecl from the NamespaceDeclCollection.
RemoveAt | Removes the element at the specified index of the NamespaceDeclCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Constructors

NamespaceDeclCollection Overloaded. Initializes a new instance of the NamespaceDeclCollection class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NamespaceDeclCollection Class | DDW.CSharp.Dom Namespace


NamespaceDeclCollection Constructor

Initializes a new instance of the NamespaceDeclCollection class that is empty and has the default initial capacity.

Overload List

Initializes a new instance of the NamespaceDeclCollection class that is empty and has the default initial capacity.

public NamespaceDeclCollection();

Initializes a new instance of the NamespaceDeclCollection class that contains elements copied from the specified NamespaceDecl array.

public NamespaceDeclCollection(NamespaceDecl[]);

Initializes a new instance of the NamespaceDeclCollection class that contains elements copied from the specified NamespaceDeclCollection.

public NamespaceDeclCollection(NamespaceDeclCollection);

protected NamespaceDeclCollection(Tag);

Initializes a new instance of the NamespaceDeclCollection class that has the specified initial capacity.

public NamespaceDeclCollection(int);

See Also

NamespaceDeclCollection Class | DDW.CSharp.Dom Namespace


NamespaceDeclCollection Constructor ()

Initializes a new instance of the NamespaceDeclCollection class that is empty and has the default initial capacity.

public NamespaceDeclCollection();

See Also

NamespaceDeclCollection Class | DDW.CSharp.Dom Namespace | NamespaceDeclCollection Constructor Overload List


NamespaceDeclCollection Constructor (Int32)

Initializes a new instance of the NamespaceDeclCollection class that has the specified initial capacity.

public NamespaceDeclCollection(
int capacity
);

Parameters

capacity
The number of elements that the new NamespaceDeclCollection is initially capable of storing.

See Also

NamespaceDeclCollection Class | DDW.CSharp.Dom Namespace | NamespaceDeclCollection Constructor Overload List


NamespaceDeclCollection Constructor (NamespaceDeclCollection)

Initializes a new instance of the NamespaceDeclCollection class that contains elements copied from the specified NamespaceDeclCollection.

public NamespaceDeclCollection(
NamespaceDeclCollection c
);

Parameters

c
The NamespaceDeclCollection whose elements are copied to the new collection.

See Also

NamespaceDeclCollection Class | DDW.CSharp.Dom Namespace | NamespaceDeclCollection Constructor Overload List


NamespaceDeclCollection Constructor (NamespaceDecl[])

Initializes a new instance of the NamespaceDeclCollection class that contains elements copied from the specified NamespaceDecl array.

public NamespaceDeclCollection(
NamespaceDecl[] a
);

Parameters

a
The NamespaceDecl array whose elements are copied to the new list.

See Also

NamespaceDeclCollection Class | DDW.CSharp.Dom Namespace | NamespaceDeclCollection Constructor Overload List


NamespaceDeclCollection Constructor (Tag)

protected NamespaceDeclCollection(
Tag t
);

See Also

NamespaceDeclCollection Class | DDW.CSharp.Dom Namespace | NamespaceDeclCollection Constructor Overload List


NamespaceDeclCollection Properties

The properties of the NamespaceDeclCollection class are listed below. For a complete list of NamespaceDeclCollection class members, see the NamespaceDeclCollection Members topic.

Public Instance Properties

Capacity | Gets or sets the number of elements the NamespaceDeclCollection can contain.
Count | Gets the number of elements actually contained in the NamespaceDeclCollection.
GraphType |
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the NamespaceDecl at the specified index.
LinePragma (inherited from CSharpGraph) |
SyncRoot | Gets an object that can be used to synchronize access to the collection.
Text |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

NamespaceDeclCollection Class | DDW.CSharp.Dom Namespace


Capacity Property

Goblin - A Platform for 3D AR and VR Applications

NamespaceDeclCollection.Capacity Property

Gets or sets the number of elements the NamespaceDeclCollection can contain.

public virtual int Capacity {get; set;}

See Also

NamespaceDeclCollection Class | DDW.CSharp.Dom Namespace


Count Property

Goblin - A Platform for 3D AR and VR Applications

NamespaceDeclCollection.Count Property

Gets the number of elements actually contained in the NamespaceDeclCollection.

public virtual int Count {get;}

Implements

ICollection.Count

See Also

NamespaceDeclCollection Class | DDW.CSharp.Dom Namespace


GraphType Property

Goblin - A Platform for 3D AR and VR Applications

NamespaceDeclCollection.GraphType Property

public override GraphTypes GraphType {get;}

Implements

IGraph.GraphType

See Also

NamespaceDeclCollection Class | DDW.CSharp.Dom Namespace


IsFixedSize Property

Goblin - A Platform for 3D AR and VR Applications

NamespaceDeclCollection.IsFixedSize Property

Gets a value indicating whether the collection has a fixed size.

public virtual bool IsFixedSize {get;}

Property Value

true if the collection has a fixed size; otherwise, false. The default is false

Implements

IList.IsFixedSize

See Also

NamespaceDeclCollection Class | DDW.CSharp.Dom Namespace


IsReadOnly Property

Goblin - A Platform for 3D AR and VR Applications

NamespaceDeclCollection.IsReadOnly Property

gets a value indicating whether the IList is read-only.

public virtual bool IsReadOnly {get;}

Property Value

true if the collection is read-only; otherwise, false. The default is false

Implements

IList.IsReadOnly

See Also

NamespaceDeclCollection Class | DDW.CSharp.Dom Namespace


IsSynchronized Property

Goblin - A Platform for 3D AR and VR Applications

NamespaceDeclCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread-safe).

public virtual bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

NamespaceDeclCollection Class | DDW.CSharp.Dom Namespace


Item Property

Goblin - A Platform for 3D AR and VR Applications

NamespaceDeclCollection.Item Property

Gets or sets the NamespaceDecl at the specified index.

public virtual NamespaceDecl this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

NamespaceDeclCollection Class | DDW.CSharp.Dom Namespace


SyncRoot Property

Goblin - A Platform for 3D AR and VR Applications

NamespaceDeclCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

public virtual object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

NamespaceDeclCollection Class | DDW.CSharp.Dom Namespace


Text Property

Goblin - A Platform for 3D AR and VR Applications

NamespaceDeclCollection.Text Property

public override string Text {get;}

Implements

IGraph.Text

See Also

NamespaceDeclCollection Class | DDW.CSharp.Dom Namespace


NamespaceDeclCollection Methods

The methods of the NamespaceDeclCollection class are listed below. For a complete list of NamespaceDeclCollection class members, see the NamespaceDeclCollection Members topic.

Public Static Methods

ReadOnly | Creates a read-only wrapper for a NamespaceDeclCollection instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a NamespaceDeclCollection instance.

Public Instance Methods

Add | Adds a NamespaceDecl to the end of the NamespaceDeclCollection.
AddRange | Overloaded. Adds the elements of a NamespaceDecl array to the current NamespaceDeclCollection.
Clear | Removes all elements from the NamespaceDeclCollection.
Clone | Creates a shallow copy of the NamespaceDeclCollection.
Contains | Determines whether a given NamespaceDecl is in the NamespaceDeclCollection.
CopyTo | Overloaded. Copies the entire NamespaceDeclCollection to a one-dimensional NamespaceDecl array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the NamespaceDeclCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the zero-based index of the first occurrence of a NamespaceDecl in the NamespaceDeclCollection.
Insert | Inserts an element into the NamespaceDeclCollection at the specified index.
Remove | Removes the first occurrence of a specific NamespaceDecl from the NamespaceDeclCollection.
RemoveAt | Removes the element at the specified index of the NamespaceDeclCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NamespaceDeclCollection Class | DDW.CSharp.Dom Namespace


NamespaceDeclCollection.Add Method

Adds a NamespaceDecl to the end of the NamespaceDeclCollection.

public virtual int Add(
NamespaceDecl item
);

Parameters

item
The NamespaceDecl to be added to the end of the NamespaceDeclCollection.

Return Value

The index at which the value has been added.

See Also

NamespaceDeclCollection Class | DDW.CSharp.Dom Namespace


AddRange Method

Goblin - A Platform for 3D AR and VR Applications

NamespaceDeclCollection.AddRange Method

Adds the elements of a NamespaceDecl array to the current NamespaceDeclCollection.

Overload List

Adds the elements of a NamespaceDecl array to the current NamespaceDeclCollection.

public virtual int AddRange(NamespaceDecl[]);

Adds the elements of another NamespaceDeclCollection to the current NamespaceDeclCollection.

public virtual int AddRange(NamespaceDeclCollection);

See Also

NamespaceDeclCollection Class | DDW.CSharp.Dom Namespace


NamespaceDeclCollection.AddRange Method (NamespaceDecl[])

Adds the elements of a NamespaceDecl array to the current NamespaceDeclCollection.

public virtual int AddRange(
NamespaceDecl[] x
);

Parameters

x
The NamespaceDecl array whose elements should be added to the end of the NamespaceDeclCollection.

Return Value

The new Count of the NamespaceDeclCollection.

See Also

NamespaceDeclCollection Class | DDW.CSharp.Dom Namespace | NamespaceDeclCollection.AddRange Overload List


NamespaceDeclCollection.AddRange Method (NamespaceDeclCollection)

Adds the elements of another NamespaceDeclCollection to the current NamespaceDeclCollection.

public virtual int AddRange(
NamespaceDeclCollection x
);

Parameters

x
The NamespaceDeclCollection whose elements should be added to the end of the current NamespaceDeclCollection.

Return Value

The new Count of the NamespaceDeclCollection.

See Also

NamespaceDeclCollection Class | DDW.CSharp.Dom Namespace | NamespaceDeclCollection.AddRange Overload List


NamespaceDeclCollection.Clear Method

Removes all elements from the NamespaceDeclCollection.

public virtual void Clear();

Implements

IList.Clear

See Also

NamespaceDeclCollection Class | DDW.CSharp.Dom Namespace


NamespaceDeclCollection.Clone Method

Creates a shallow copy of the NamespaceDeclCollection.

public virtual object Clone();

Implements

ICloneable.Clone

See Also

NamespaceDeclCollection Class | DDW.CSharp.Dom Namespace


NamespaceDeclCollection.Contains Method

Determines whether a given NamespaceDecl is in the NamespaceDeclCollection.

public virtual bool Contains(
NamespaceDecl item
);

Parameters

item
The NamespaceDecl to check for.

Return Value

true if item is found in the NamespaceDeclCollection; otherwise, false.

See Also

NamespaceDeclCollection Class | DDW.CSharp.Dom Namespace


CopyTo Method

Goblin - A Platform for 3D AR and VR Applications

NamespaceDeclCollection.CopyTo Method

Copies the entire NamespaceDeclCollection to a one-dimensional NamespaceDecl array.

Overload List

Copies the entire NamespaceDeclCollection to a one-dimensional NamespaceDecl array.

public virtual void CopyTo(NamespaceDecl[]);

Copies the entire NamespaceDeclCollection to a one-dimensional NamespaceDecl array, starting at the specified index of the target array.

public virtual void CopyTo(NamespaceDecl[],int);

See Also

NamespaceDeclCollection Class | DDW.CSharp.Dom Namespace


NamespaceDeclCollection.CopyTo Method (NamespaceDecl[])

Copies the entire NamespaceDeclCollection to a one-dimensional NamespaceDecl array.

public virtual void CopyTo(
NamespaceDecl[] array
);

Parameters

array
The one-dimensional NamespaceDecl array to copy to.

See Also

NamespaceDeclCollection Class | DDW.CSharp.Dom Namespace | NamespaceDeclCollection.CopyTo Overload List


NamespaceDeclCollection.CopyTo Method (NamespaceDecl[], Int32)

Copies the entire NamespaceDeclCollection to a one-dimensional NamespaceDecl array, starting at the specified index of the target array.

public virtual void CopyTo(
NamespaceDecl[] array,
int start
);

Parameters

array
The one-dimensional NamespaceDecl array to copy to.
start
The zero-based index in array at which copying begins.

See Also

NamespaceDeclCollection Class | DDW.CSharp.Dom Namespace | NamespaceDeclCollection.CopyTo Overload List


NamespaceDeclCollection.GetEnumerator Method

Returns an enumerator that can iterate through the NamespaceDeclCollection.

public virtual INamespaceDeclCollectionEnumerator GetEnumerator();

Return Value

An Enumerator for the entire NamespaceDeclCollection.

See Also

NamespaceDeclCollection Class | DDW.CSharp.Dom Namespace


NamespaceDeclCollection.IndexOf Method

Returns the zero-based index of the first occurrence of a NamespaceDecl in the NamespaceDeclCollection.

public virtual int IndexOf(
NamespaceDecl item
);

Parameters

item
The NamespaceDecl to locate in the NamespaceDeclCollection.

Return Value

The zero-based index of the first occurrence of item in the entire NamespaceDeclCollection, if found; otherwise, -1.

See Also

NamespaceDeclCollection Class | DDW.CSharp.Dom Namespace


NamespaceDeclCollection.Insert Method

Inserts an element into the NamespaceDeclCollection at the specified index.

public virtual void Insert(
int index,
NamespaceDecl item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The NamespaceDecl to insert.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

NamespaceDeclCollection Class | DDW.CSharp.Dom Namespace


NamespaceDeclCollection.ReadOnly Method

Creates a read-only wrapper for a NamespaceDeclCollection instance.

public static NamespaceDeclCollection ReadOnly(
NamespaceDeclCollection list
);

Return Value

An NamespaceDeclCollection wrapper that is read-only.

See Also

NamespaceDeclCollection Class | DDW.CSharp.Dom Namespace


NamespaceDeclCollection.Remove Method

Removes the first occurrence of a specific NamespaceDecl from the NamespaceDeclCollection.

public virtual void Remove(
NamespaceDecl item
);

Parameters

item
The NamespaceDecl to remove from the NamespaceDeclCollection.

Exceptions

Exception Type | Condition
ArgumentException | The specified NamespaceDecl was not found in the NamespaceDeclCollection.

See Also

NamespaceDeclCollection Class | DDW.CSharp.Dom Namespace


NamespaceDeclCollection.RemoveAt Method

Removes the element at the specified index of the NamespaceDeclCollection.

public virtual void RemoveAt(
int index
);

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

NamespaceDeclCollection Class | DDW.CSharp.Dom Namespace


NamespaceDeclCollection.Synchronized Method

Creates a synchronized (thread-safe) wrapper for a NamespaceDeclCollection instance.

public static NamespaceDeclCollection Synchronized(
NamespaceDeclCollection list
);

Return Value

An NamespaceDeclCollection wrapper that is synchronized (thread-safe).

See Also

NamespaceDeclCollection Class | DDW.CSharp.Dom Namespace


NamespaceDeclCollection.TrimToSize Method

Sets the capacity to the actual number of elements.

public virtual void TrimToSize();

See Also

NamespaceDeclCollection Class | DDW.CSharp.Dom Namespace


NamespaceDeclCollection.INamespaceDeclCollectionEnumerator Interface

Supports type-safe iteration over a NamespaceDeclCollection.

For a list of all members of this type, see NamespaceDeclCollection.INamespaceDeclCollectionEnumerator Members.

public interface NamespaceDeclCollection.INamespaceDeclCollectionEnumerator

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

NamespaceDeclCollection.INamespaceDeclCollectionEnumerator Members | DDW.CSharp.Dom Namespace


NamespaceDeclCollection.INamespaceDeclCollectionEnumerator Members

NamespaceDeclCollection.INamespaceDeclCollectionEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

NamespaceDeclCollection.INamespaceDeclCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


NamespaceDeclCollection.INamespaceDeclCollectionEnumerator Properties

The properties of the NamespaceDeclCollection.INamespaceDeclCollectionEnumerator interface are listed below. For a complete list of NamespaceDeclCollection.INamespaceDeclCollectionEnumerator interface members, see the NamespaceDeclCollection.INamespaceDeclCollectionEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

NamespaceDeclCollection.INamespaceDeclCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


Current Property

Goblin - A Platform for 3D AR and VR Applications

NamespaceDeclCollection.INamespaceDeclCollectionEnumerator.Current Property

Gets the current element in the collection.

NamespaceDecl Current {get;}

See Also

NamespaceDeclCollection.INamespaceDeclCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


NamespaceDeclCollection.INamespaceDeclCollectionEnumerator Methods

The methods of the NamespaceDeclCollection.INamespaceDeclCollectionEnumerator interface are listed below. For a complete list of NamespaceDeclCollection.INamespaceDeclCollectionEnumerator interface members, see the NamespaceDeclCollection.INamespaceDeclCollectionEnumerator Members topic.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

NamespaceDeclCollection.INamespaceDeclCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


NamespaceDeclCollection.INamespaceDeclCollectionEnumerator.MoveNext Method

Advances the enumerator to the next element in the collection.

bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Exceptions

Exception Type | Condition
InvalidOperationException | The collection was modified after the enumerator was created.

See Also

NamespaceDeclCollection.INamespaceDeclCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


NamespaceDeclCollection.INamespaceDeclCollectionEnumerator.Reset Method

Sets the enumerator to its initial position, before the first element in the collection.

void Reset();

See Also

NamespaceDeclCollection.INamespaceDeclCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


NamespaceDeclCollection.Tag Enumeration

protected enum NamespaceDeclCollection.Tag

Members

Member Name | Description
Default |

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

DDW.CSharp.Dom Namespace


NullLiteral Class

A null literal.

For a list of all members of this type, see NullLiteral Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Expression
DDW.CSharp.Dom.PrimitiveExpr
DDW.CSharp.Dom.NullLiteral

public class NullLiteral : PrimitiveExpr

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

NullLiteral Members | DDW.CSharp.Dom Namespace


NullLiteral Members

NullLiteral overview

Public Instance Constructors

NullLiteral Constructor Initializes a new instance of the NullLiteral class.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.
Value | Gets or sets a null value. Always will be null.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NullLiteral Class | DDW.CSharp.Dom Namespace


NullLiteral Constructor

Initializes a new instance of the NullLiteral class.

public NullLiteral();

See Also

NullLiteral Class | DDW.CSharp.Dom Namespace


NullLiteral Properties

The properties of the NullLiteral class are listed below. For a complete list of NullLiteral class members, see the NullLiteral Members topic.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.
Value | Gets or sets a null value. Always will be null.

See Also

NullLiteral Class | DDW.CSharp.Dom Namespace


Value Property

Goblin - A Platform for 3D AR and VR Applications

NullLiteral.Value Property

Gets or sets a null value. Always will be null.

public string Value {get; set;}

See Also

NullLiteral Class | DDW.CSharp.Dom Namespace


ObjectCreateExpr Class

An expression that creates a new object.

For a list of all members of this type, see ObjectCreateExpr Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Expression
DDW.CSharp.Dom.ObjectCreateExpr

public class ObjectCreateExpr : Expression

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

ObjectCreateExpr Members | DDW.CSharp.Dom Namespace


ObjectCreateExpr Members

ObjectCreateExpr overview

Public Instance Constructors

ObjectCreateExpr Constructor Initializes a new instance of the ObjectCreateExpr class.

Public Instance Properties

ConstructorDefinition | Gets or sets the matching constructor (in case of overload).
CreateType | Gets or sets the type of object to be created.
LinePragma (inherited from CSharpGraph) |
Parameters | Gets the collection of parameters to be passed to the object being created.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ObjectCreateExpr Class | DDW.CSharp.Dom Namespace


ObjectCreateExpr Constructor

Initializes a new instance of the ObjectCreateExpr class.

public ObjectCreateExpr();

See Also

ObjectCreateExpr Class | DDW.CSharp.Dom Namespace


ObjectCreateExpr Properties

The properties of the ObjectCreateExpr class are listed below. For a complete list of ObjectCreateExpr class members, see the ObjectCreateExpr Members topic.

Public Instance Properties

ConstructorDefinition | Gets or sets the matching constructor (in case of overload).
CreateType | Gets or sets the type of object to be created.
LinePragma (inherited from CSharpGraph) |
Parameters | Gets the collection of parameters to be passed to the object being created.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

ObjectCreateExpr Class | DDW.CSharp.Dom Namespace


ConstructorDefinition Property

Goblin - A Platform for 3D AR and VR Applications

ObjectCreateExpr.ConstructorDefinition Property

Gets or sets the matching constructor (in case of overload).

public DDW.CSharp.SymbolTable.IDefinition ConstructorDefinition {get; set;}

See Also

ObjectCreateExpr Class | DDW.CSharp.Dom Namespace


CreateType Property

Goblin - A Platform for 3D AR and VR Applications

ObjectCreateExpr.CreateType Property

Gets or sets the type of object to be created.

public TypeRef CreateType {get; set;}

See Also

ObjectCreateExpr Class | DDW.CSharp.Dom Namespace


Parameters Property

Goblin - A Platform for 3D AR and VR Applications

ObjectCreateExpr.Parameters Property

Gets the collection of parameters to be passed to the object being created.

public ParamCollection Parameters {get;}

See Also

ObjectCreateExpr Class | DDW.CSharp.Dom Namespace


OperatorDecl Class

An operator declartation.

For a list of all members of this type, see OperatorDecl Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.MemberDecl
DDW.CSharp.Dom.OperatorDecl

public class OperatorDecl : MemberDecl, IDeclaration, IScope, IOverloadable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

OperatorDecl Members | DDW.CSharp.Dom Namespace


OperatorDecl Members

OperatorDecl overview

Public Static Methods

OperatorFromString | A helper method that converts strings to operators. Note: the unary plus and negation strings should have a 'u' appened to differentiate them from addition and subtraction strings.
StringFromOperator | A helper method that converts operators to strings. Note: the unary plus and negation strings returned will NOT have a 'u' appened as that usually isn't desired.

Public Instance Constructors

OperatorDecl Constructor Initializes a new instance of the OperatorDecl class.

Public Instance Properties

Attributes (inherited from MemberDecl) | Gets or sets the modifier flags for this member (public, private etc).
Comments (inherited from MemberDecl) | Gets the collection of comments for this member.
CustomAttributes (inherited from MemberDecl) | Gets the collection of Custom Attributes used for this member (custom attributes are the ones declared between brackets, like [Flags]).
Definition | Gets the (scoped) definition.
FirstParameter | Gets or sets the first object in a unary, binary or conversion overload.
LinePragma (inherited from CSharpGraph) |
MemberKind |
Operator | Gets or sets the operator to overload. This can be 'explicit' or 'implicit' in the case of conversion.
Parameters | Gets the collection of parameters - this is actually just putting the first and second (if present) parameter into a collection.
Scope |
SecondParameter | Gets or sets the second object in a binary overload (not set for unary and conversion overloads).
Statements | Gets the collection of statements for the operator declaration.
Type | Gets or sets the type that the operator will affect.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
VerifyModifiers (inherited from MemberDecl) |

See Also

OperatorDecl Class | DDW.CSharp.Dom Namespace


OperatorDecl Constructor

Initializes a new instance of the OperatorDecl class.

public OperatorDecl();

See Also

OperatorDecl Class | DDW.CSharp.Dom Namespace


OperatorDecl Properties

The properties of the OperatorDecl class are listed below. For a complete list of OperatorDecl class members, see the OperatorDecl Members topic.

Public Instance Properties

Attributes (inherited from MemberDecl) | Gets or sets the modifier flags for this member (public, private etc).
Comments (inherited from MemberDecl) | Gets the collection of comments for this member.
CustomAttributes (inherited from MemberDecl) | Gets the collection of Custom Attributes used for this member (custom attributes are the ones declared between brackets, like [Flags]).
Definition | Gets the (scoped) definition.
FirstParameter | Gets or sets the first object in a unary, binary or conversion overload.
LinePragma (inherited from CSharpGraph) |
MemberKind |
Operator | Gets or sets the operator to overload. This can be 'explicit' or 'implicit' in the case of conversion.
Parameters | Gets the collection of parameters - this is actually just putting the first and second (if present) parameter into a collection.
Scope |
SecondParameter | Gets or sets the second object in a binary overload (not set for unary and conversion overloads).
Statements | Gets the collection of statements for the operator declaration.
Type | Gets or sets the type that the operator will affect.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

OperatorDecl Class | DDW.CSharp.Dom Namespace


Definition Property

Goblin - A Platform for 3D AR and VR Applications

OperatorDecl.Definition Property

Gets the (scoped) definition.

public DDW.CSharp.SymbolTable.IDefinition Definition {get;}

Implements

IDeclaration.Definition

See Also

OperatorDecl Class | DDW.CSharp.Dom Namespace


FirstParameter Property

Goblin - A Platform for 3D AR and VR Applications

OperatorDecl.FirstParameter Property

Gets or sets the first object in a unary, binary or conversion overload.

public ParamDecl FirstParameter {get; set;}

See Also

OperatorDecl Class | DDW.CSharp.Dom Namespace


MemberKind Property

Goblin - A Platform for 3D AR and VR Applications

OperatorDecl.MemberKind Property

public override MemberKind MemberKind {get;}

See Also

OperatorDecl Class | DDW.CSharp.Dom Namespace


Operator Property

Goblin - A Platform for 3D AR and VR Applications

OperatorDecl.Operator Property

Gets or sets the operator to overload. This can be 'explicit' or 'implicit' in the case of conversion.

public OverloadableOperator Operator {get; set;}

See Also

OperatorDecl Class | DDW.CSharp.Dom Namespace


Parameters Property

Goblin - A Platform for 3D AR and VR Applications

OperatorDecl.Parameters Property

Gets the collection of parameters - this is actually just putting the first and second (if present) parameter into a collection.

public ParamDeclCollection Parameters {get;}

Implements

IOverloadable.Parameters

See Also

OperatorDecl Class | DDW.CSharp.Dom Namespace


Scope Property

Goblin - A Platform for 3D AR and VR Applications

OperatorDecl.Scope Property

public DDW.CSharp.SymbolTable.Scope Scope {get; set;}

Implements

IScope.Scope

See Also

OperatorDecl Class | DDW.CSharp.Dom Namespace


SecondParameter Property

Goblin - A Platform for 3D AR and VR Applications

OperatorDecl.SecondParameter Property

Gets or sets the second object in a binary overload (not set for unary and conversion overloads).

public ParamDecl SecondParameter {get; set;}

See Also

OperatorDecl Class | DDW.CSharp.Dom Namespace


Statements Property

Goblin - A Platform for 3D AR and VR Applications

OperatorDecl.Statements Property

Gets the collection of statements for the operator declaration.

public StatementCollection Statements {get;}

See Also

OperatorDecl Class | DDW.CSharp.Dom Namespace


Type Property

Goblin - A Platform for 3D AR and VR Applications

OperatorDecl.Type Property

Gets or sets the type that the operator will affect.

public TypeRef Type {get; set;}

See Also

OperatorDecl Class | DDW.CSharp.Dom Namespace


OperatorDecl Methods

The methods of the OperatorDecl class are listed below. For a complete list of OperatorDecl class members, see the OperatorDecl Members topic.

Public Static Methods

OperatorFromString | A helper method that converts strings to operators. Note: the unary plus and negation strings should have a 'u' appened to differentiate them from addition and subtraction strings.
StringFromOperator | A helper method that converts operators to strings. Note: the unary plus and negation strings returned will NOT have a 'u' appened as that usually isn't desired.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
VerifyModifiers (inherited from MemberDecl) |

See Also

OperatorDecl Class | DDW.CSharp.Dom Namespace


OperatorDecl.OperatorFromString Method

A helper method that converts strings to operators. Note: the unary plus and negation strings should have a 'u' appened to differentiate them from addition and subtraction strings.

public static OverloadableOperator OperatorFromString(
string sop
);

Parameters

sop
String to convert to an OverloadableOperator.

Return Value

An OverloadableOperator.

See Also

OperatorDecl Class | DDW.CSharp.Dom Namespace


OperatorDecl.StringFromOperator Method

A helper method that converts operators to strings. Note: the unary plus and negation strings returned will NOT have a 'u' appened as that usually isn't desired.

public static string StringFromOperator(
OverloadableOperator sop
);

Parameters

sop
OverloadableOperator to be converted to text.

Return Value

A string representation of the input operator.

See Also

OperatorDecl Class | DDW.CSharp.Dom Namespace


OverloadableOperator Enumeration

An enumeration of possible overloadable operators (operators that can be redefined).

public enum OverloadableOperator

Members

Member Name | Description
Empty |
Implicit |
Explicit |
UnaryPlus |
UnaryNegation |
Not |
OnesComplement |
Increment |
Decrement |
True |
False |
Addition |
Subtraction |
Multiply |
Division |
Modulus |
BitwiseAnd |
BitwiseOr |
ExclusiveOr |
LeftShift |
RightShift |
Equality |
Inequality |
GreaterThan |
LessThan |
GreaterThanOrEqual |
LessThanOrEqual |

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

DDW.CSharp.Dom Namespace


Param Class

A parameter that will be passed to another code element.

For a list of all members of this type, see Param Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Param

public class Param : CSharpGraph

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

Param Members | DDW.CSharp.Dom Namespace


Param Members

Param overview

Public Instance Constructors

Param Constructor Initializes a new instance of the Param class.

Public Instance Properties

Direction | Gets or sets the direction of the parameter (ref or out).
LinePragma (inherited from CSharpGraph) |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.
Value | Gets or sets the value of the parameter.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Param Class | DDW.CSharp.Dom Namespace


Param Constructor

Initializes a new instance of the Param class.

public Param();

See Also

Param Class | DDW.CSharp.Dom Namespace


Param Properties

The properties of the Param class are listed below. For a complete list of Param class members, see the Param Members topic.

Public Instance Properties

Direction | Gets or sets the direction of the parameter (ref or out).
LinePragma (inherited from CSharpGraph) |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.
Value | Gets or sets the value of the parameter.

See Also

Param Class | DDW.CSharp.Dom Namespace


Direction Property

Goblin - A Platform for 3D AR and VR Applications

Param.Direction Property

Gets or sets the direction of the parameter (ref or out).

public ParamDirection Direction {get; set;}

See Also

Param Class | DDW.CSharp.Dom Namespace


Value Property

Goblin - A Platform for 3D AR and VR Applications

Param.Value Property

Gets or sets the value of the parameter.

public Expression Value {get; set;}

See Also

Param Class | DDW.CSharp.Dom Namespace


ParamCollection Class

A strongly-typed collection of Param objects.

For a list of all members of this type, see ParamCollection Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.ParamCollection

public class ParamCollection : CSharpGraph, IList, ICollection, IEnumerable, ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

ParamCollection Members | DDW.CSharp.Dom Namespace


ParamCollection Members

ParamCollection overview

Public Static Methods

ReadOnly | Creates a read-only wrapper for a ParamCollection instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a ParamCollection instance.

Public Instance Constructors

ParamCollection Overloaded. Initializes a new instance of the ParamCollection class.

Public Instance Properties

Capacity | Gets or sets the number of elements the ParamCollection can contain.
Count | Gets the number of elements actually contained in the ParamCollection.
GraphType |
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the Param at the specified index.
LinePragma (inherited from CSharpGraph) |
SyncRoot | Gets an object that can be used to synchronize access to the collection.
Text |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Add | Adds a Param to the end of the ParamCollection.
AddRange | Overloaded. Adds the elements of a Param array to the current ParamCollection.
Clear | Removes all elements from the ParamCollection.
Clone | Creates a shallow copy of the ParamCollection.
Contains | Determines whether a given Param is in the ParamCollection.
CopyTo | Overloaded. Copies the entire ParamCollection to a one-dimensional Param array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the ParamCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the zero-based index of the first occurrence of a Param in the ParamCollection.
Insert | Inserts an element into the ParamCollection at the specified index.
Remove | Removes the first occurrence of a specific Param from the ParamCollection.
RemoveAt | Removes the element at the specified index of the ParamCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Constructors

ParamCollection Overloaded. Initializes a new instance of the ParamCollection class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ParamCollection Class | DDW.CSharp.Dom Namespace


ParamCollection Constructor

Initializes a new instance of the ParamCollection class that is empty and has the default initial capacity.

Overload List

Initializes a new instance of the ParamCollection class that is empty and has the default initial capacity.

public ParamCollection();

Initializes a new instance of the ParamCollection class that contains elements copied from the specified Param array.

public ParamCollection(Param[]);

Initializes a new instance of the ParamCollection class that contains elements copied from the specified ParamCollection.

public ParamCollection(ParamCollection);

protected ParamCollection(Tag);

Initializes a new instance of the ParamCollection class that has the specified initial capacity.

public ParamCollection(int);

See Also

ParamCollection Class | DDW.CSharp.Dom Namespace


ParamCollection Constructor ()

Initializes a new instance of the ParamCollection class that is empty and has the default initial capacity.

public ParamCollection();

See Also

ParamCollection Class | DDW.CSharp.Dom Namespace | ParamCollection Constructor Overload List


ParamCollection Constructor (Int32)

Initializes a new instance of the ParamCollection class that has the specified initial capacity.

public ParamCollection(
int capacity
);

Parameters

capacity
The number of elements that the new ParamCollection is initially capable of storing.

See Also

ParamCollection Class | DDW.CSharp.Dom Namespace | ParamCollection Constructor Overload List


ParamCollection Constructor (ParamCollection)

Initializes a new instance of the ParamCollection class that contains elements copied from the specified ParamCollection.

public ParamCollection(
ParamCollection c
);

Parameters

c
The ParamCollection whose elements are copied to the new collection.

See Also

ParamCollection Class | DDW.CSharp.Dom Namespace | ParamCollection Constructor Overload List


ParamCollection Constructor (Param[])

Initializes a new instance of the ParamCollection class that contains elements copied from the specified Param array.

public ParamCollection(
Param[] a
);

Parameters

a
The Param array whose elements are copied to the new list.

See Also

ParamCollection Class | DDW.CSharp.Dom Namespace | ParamCollection Constructor Overload List


ParamCollection Constructor (Tag)

protected ParamCollection(
Tag t
);

See Also

ParamCollection Class | DDW.CSharp.Dom Namespace | ParamCollection Constructor Overload List


ParamCollection Properties

The properties of the ParamCollection class are listed below. For a complete list of ParamCollection class members, see the ParamCollection Members topic.

Public Instance Properties

Capacity | Gets or sets the number of elements the ParamCollection can contain.
Count | Gets the number of elements actually contained in the ParamCollection.
GraphType |
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the Param at the specified index.
LinePragma (inherited from CSharpGraph) |
SyncRoot | Gets an object that can be used to synchronize access to the collection.
Text |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

ParamCollection Class | DDW.CSharp.Dom Namespace


Capacity Property

Goblin - A Platform for 3D AR and VR Applications

ParamCollection.Capacity Property

Gets or sets the number of elements the ParamCollection can contain.

public virtual int Capacity {get; set;}

See Also

ParamCollection Class | DDW.CSharp.Dom Namespace


Count Property

Goblin - A Platform for 3D AR and VR Applications

ParamCollection.Count Property

Gets the number of elements actually contained in the ParamCollection.

public virtual int Count {get;}

Implements

ICollection.Count

See Also

ParamCollection Class | DDW.CSharp.Dom Namespace


GraphType Property

Goblin - A Platform for 3D AR and VR Applications

ParamCollection.GraphType Property

public override GraphTypes GraphType {get;}

Implements

IGraph.GraphType

See Also

ParamCollection Class | DDW.CSharp.Dom Namespace


IsFixedSize Property

Goblin - A Platform for 3D AR and VR Applications

ParamCollection.IsFixedSize Property

Gets a value indicating whether the collection has a fixed size.

public virtual bool IsFixedSize {get;}

Property Value

true if the collection has a fixed size; otherwise, false. The default is false

Implements

IList.IsFixedSize

See Also

ParamCollection Class | DDW.CSharp.Dom Namespace


IsReadOnly Property

Goblin - A Platform for 3D AR and VR Applications

ParamCollection.IsReadOnly Property

gets a value indicating whether the IList is read-only.

public virtual bool IsReadOnly {get;}

Property Value

true if the collection is read-only; otherwise, false. The default is false

Implements

IList.IsReadOnly

See Also

ParamCollection Class | DDW.CSharp.Dom Namespace


IsSynchronized Property

Goblin - A Platform for 3D AR and VR Applications

ParamCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread-safe).

public virtual bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

ParamCollection Class | DDW.CSharp.Dom Namespace


Item Property

Goblin - A Platform for 3D AR and VR Applications

ParamCollection.Item Property

Gets or sets the Param at the specified index.

public virtual Param this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

ParamCollection Class | DDW.CSharp.Dom Namespace


SyncRoot Property

Goblin - A Platform for 3D AR and VR Applications

ParamCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

public virtual object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

ParamCollection Class | DDW.CSharp.Dom Namespace


Text Property

Goblin - A Platform for 3D AR and VR Applications

ParamCollection.Text Property

public override string Text {get;}

Implements

IGraph.Text

See Also

ParamCollection Class | DDW.CSharp.Dom Namespace


ParamCollection Methods

The methods of the ParamCollection class are listed below. For a complete list of ParamCollection class members, see the ParamCollection Members topic.

Public Static Methods

ReadOnly | Creates a read-only wrapper for a ParamCollection instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a ParamCollection instance.

Public Instance Methods

Add | Adds a Param to the end of the ParamCollection.
AddRange | Overloaded. Adds the elements of a Param array to the current ParamCollection.
Clear | Removes all elements from the ParamCollection.
Clone | Creates a shallow copy of the ParamCollection.
Contains | Determines whether a given Param is in the ParamCollection.
CopyTo | Overloaded. Copies the entire ParamCollection to a one-dimensional Param array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the ParamCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the zero-based index of the first occurrence of a Param in the ParamCollection.
Insert | Inserts an element into the ParamCollection at the specified index.
Remove | Removes the first occurrence of a specific Param from the ParamCollection.
RemoveAt | Removes the element at the specified index of the ParamCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ParamCollection Class | DDW.CSharp.Dom Namespace


ParamCollection.Add Method

Adds a Param to the end of the ParamCollection.

public virtual int Add(
Param item
);

Parameters

item
The Param to be added to the end of the ParamCollection.

Return Value

The index at which the value has been added.

See Also

ParamCollection Class | DDW.CSharp.Dom Namespace


AddRange Method

Goblin - A Platform for 3D AR and VR Applications

ParamCollection.AddRange Method

Adds the elements of a Param array to the current ParamCollection.

Overload List

Adds the elements of a Param array to the current ParamCollection.

public virtual int AddRange(Param[]);

Adds the elements of another ParamCollection to the current ParamCollection.

public virtual int AddRange(ParamCollection);

See Also

ParamCollection Class | DDW.CSharp.Dom Namespace


ParamCollection.AddRange Method (Param[])

Adds the elements of a Param array to the current ParamCollection.

public virtual int AddRange(
Param[] x
);

Parameters

x
The Param array whose elements should be added to the end of the ParamCollection.

Return Value

The new Count of the ParamCollection.

See Also

ParamCollection Class | DDW.CSharp.Dom Namespace | ParamCollection.AddRange Overload List


ParamCollection.AddRange Method (ParamCollection)

Adds the elements of another ParamCollection to the current ParamCollection.

public virtual int AddRange(
ParamCollection x
);

Parameters

x
The ParamCollection whose elements should be added to the end of the current ParamCollection.

Return Value

The new Count of the ParamCollection.

See Also

ParamCollection Class | DDW.CSharp.Dom Namespace | ParamCollection.AddRange Overload List


ParamCollection.Clear Method

Removes all elements from the ParamCollection.

public virtual void Clear();

Implements

IList.Clear

See Also

ParamCollection Class | DDW.CSharp.Dom Namespace


ParamCollection.Clone Method

Creates a shallow copy of the ParamCollection.

public virtual object Clone();

Implements

ICloneable.Clone

See Also

ParamCollection Class | DDW.CSharp.Dom Namespace


ParamCollection.Contains Method

Determines whether a given Param is in the ParamCollection.

public virtual bool Contains(
Param item
);

Parameters

item
The Param to check for.

Return Value

true if item is found in the ParamCollection; otherwise, false.

See Also

ParamCollection Class | DDW.CSharp.Dom Namespace


CopyTo Method

Goblin - A Platform for 3D AR and VR Applications

ParamCollection.CopyTo Method

Copies the entire ParamCollection to a one-dimensional Param array.

Overload List

Copies the entire ParamCollection to a one-dimensional Param array.

public virtual void CopyTo(Param[]);

Copies the entire ParamCollection to a one-dimensional Param array, starting at the specified index of the target array.

public virtual void CopyTo(Param[],int);

See Also

ParamCollection Class | DDW.CSharp.Dom Namespace


ParamCollection.CopyTo Method (Param[])

Copies the entire ParamCollection to a one-dimensional Param array.

public virtual void CopyTo(
Param[] array
);

Parameters

array
The one-dimensional Param array to copy to.

See Also

ParamCollection Class | DDW.CSharp.Dom Namespace | ParamCollection.CopyTo Overload List


ParamCollection.CopyTo Method (Param[], Int32)

Copies the entire ParamCollection to a one-dimensional Param array, starting at the specified index of the target array.

public virtual void CopyTo(
Param[] array,
int start
);

Parameters

array
The one-dimensional Param array to copy to.
start
The zero-based index in array at which copying begins.

See Also

ParamCollection Class | DDW.CSharp.Dom Namespace | ParamCollection.CopyTo Overload List


ParamCollection.GetEnumerator Method

Returns an enumerator that can iterate through the ParamCollection.

public virtual IParamCollectionEnumerator GetEnumerator();

Return Value

An Enumerator for the entire ParamCollection.

See Also

ParamCollection Class | DDW.CSharp.Dom Namespace


ParamCollection.IndexOf Method

Returns the zero-based index of the first occurrence of a Param in the ParamCollection.

public virtual int IndexOf(
Param item
);

Parameters

item
The Param to locate in the ParamCollection.

Return Value

The zero-based index of the first occurrence of item in the entire ParamCollection, if found; otherwise, -1.

See Also

ParamCollection Class | DDW.CSharp.Dom Namespace


ParamCollection.Insert Method

Inserts an element into the ParamCollection at the specified index.

public virtual void Insert(
int index,
Param item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The Param to insert.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

ParamCollection Class | DDW.CSharp.Dom Namespace


ParamCollection.ReadOnly Method

Creates a read-only wrapper for a ParamCollection instance.

public static ParamCollection ReadOnly(
ParamCollection list
);

Return Value

An ParamCollection wrapper that is read-only.

See Also

ParamCollection Class | DDW.CSharp.Dom Namespace


ParamCollection.Remove Method

Removes the first occurrence of a specific Param from the ParamCollection.

public virtual void Remove(
Param item
);

Parameters

item
The Param to remove from the ParamCollection.

Exceptions

Exception Type | Condition
ArgumentException | The specified Param was not found in the ParamCollection.

See Also

ParamCollection Class | DDW.CSharp.Dom Namespace


ParamCollection.RemoveAt Method

Removes the element at the specified index of the ParamCollection.

public virtual void RemoveAt(
int index
);

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

ParamCollection Class | DDW.CSharp.Dom Namespace


ParamCollection.Synchronized Method

Creates a synchronized (thread-safe) wrapper for a ParamCollection instance.

public static ParamCollection Synchronized(
ParamCollection list
);

Return Value

An ParamCollection wrapper that is synchronized (thread-safe).

See Also

ParamCollection Class | DDW.CSharp.Dom Namespace


ParamCollection.TrimToSize Method

Sets the capacity to the actual number of elements.

public virtual void TrimToSize();

See Also

ParamCollection Class | DDW.CSharp.Dom Namespace


ParamCollection.IParamCollectionEnumerator Interface

Supports type-safe iteration over a ParamCollection.

For a list of all members of this type, see ParamCollection.IParamCollectionEnumerator Members.

public interface ParamCollection.IParamCollectionEnumerator

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

ParamCollection.IParamCollectionEnumerator Members | DDW.CSharp.Dom Namespace


ParamCollection.IParamCollectionEnumerator Members

ParamCollection.IParamCollectionEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

ParamCollection.IParamCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


ParamCollection.IParamCollectionEnumerator Properties

The properties of the ParamCollection.IParamCollectionEnumerator interface are listed below. For a complete list of ParamCollection.IParamCollectionEnumerator interface members, see the ParamCollection.IParamCollectionEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

ParamCollection.IParamCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


Current Property

Goblin - A Platform for 3D AR and VR Applications

ParamCollection.IParamCollectionEnumerator.Current Property

Gets the current element in the collection.

Param Current {get;}

See Also

ParamCollection.IParamCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


ParamCollection.IParamCollectionEnumerator Methods

The methods of the ParamCollection.IParamCollectionEnumerator interface are listed below. For a complete list of ParamCollection.IParamCollectionEnumerator interface members, see the ParamCollection.IParamCollectionEnumerator Members topic.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

ParamCollection.IParamCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


ParamCollection.IParamCollectionEnumerator.MoveNext Method

Advances the enumerator to the next element in the collection.

bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Exceptions

Exception Type | Condition
InvalidOperationException | The collection was modified after the enumerator was created.

See Also

ParamCollection.IParamCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


ParamCollection.IParamCollectionEnumerator.Reset Method

Sets the enumerator to its initial position, before the first element in the collection.

void Reset();

See Also

ParamCollection.IParamCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


ParamCollection.Tag Enumeration

protected enum ParamCollection.Tag

Members

Member Name | Description
Default |

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

DDW.CSharp.Dom Namespace


ParamDecl Class

A parameter delaration.

For a list of all members of this type, see ParamDecl Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.ParamDecl

public class ParamDecl : CSharpGraph, IDeclaration

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

ParamDecl Members | DDW.CSharp.Dom Namespace


ParamDecl Members

ParamDecl overview

Public Instance Constructors

ParamDecl Constructor Initializes a new instance of the ParamDecl class.

Public Instance Properties

CustomAttributes | Gets the collection of Custom Attributes used for the parameter (custom attributes are the ones declared between brackets, like [Flags]).
Definition | Gets the (scoped) definition.
Direction | Gets or sets the direction of the parameter (ref or out).
IsParams | Gets or sets a flag that indicates this parameter is a special 'params' array type.
LinePragma (inherited from CSharpGraph) |
Name | Gets or sets the name of the parameter.
Type | Gets or sets the type of the parameter.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ParamDecl Class | DDW.CSharp.Dom Namespace


ParamDecl Constructor

Initializes a new instance of the ParamDecl class.

public ParamDecl();

See Also

ParamDecl Class | DDW.CSharp.Dom Namespace


ParamDecl Properties

The properties of the ParamDecl class are listed below. For a complete list of ParamDecl class members, see the ParamDecl Members topic.

Public Instance Properties

CustomAttributes | Gets the collection of Custom Attributes used for the parameter (custom attributes are the ones declared between brackets, like [Flags]).
Definition | Gets the (scoped) definition.
Direction | Gets or sets the direction of the parameter (ref or out).
IsParams | Gets or sets a flag that indicates this parameter is a special 'params' array type.
LinePragma (inherited from CSharpGraph) |
Name | Gets or sets the name of the parameter.
Type | Gets or sets the type of the parameter.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

ParamDecl Class | DDW.CSharp.Dom Namespace


CustomAttributes Property

Goblin - A Platform for 3D AR and VR Applications

ParamDecl.CustomAttributes Property

Gets the collection of Custom Attributes used for the parameter (custom attributes are the ones declared between brackets, like [Flags]).

public CustomAttributeCollection CustomAttributes {get; set;}

See Also

ParamDecl Class | DDW.CSharp.Dom Namespace


Definition Property

Goblin - A Platform for 3D AR and VR Applications

ParamDecl.Definition Property

Gets the (scoped) definition.

public DDW.CSharp.SymbolTable.IDefinition Definition {get;}

Implements

IDeclaration.Definition

See Also

ParamDecl Class | DDW.CSharp.Dom Namespace


Direction Property

Goblin - A Platform for 3D AR and VR Applications

ParamDecl.Direction Property

Gets or sets the direction of the parameter (ref or out).

public ParamDirection Direction {get; set;}

See Also

ParamDecl Class | DDW.CSharp.Dom Namespace


IsParams Property

Goblin - A Platform for 3D AR and VR Applications

ParamDecl.IsParams Property

Gets or sets a flag that indicates this parameter is a special 'params' array type.

public bool IsParams {get; set;}

See Also

ParamDecl Class | DDW.CSharp.Dom Namespace


Name Property

Goblin - A Platform for 3D AR and VR Applications

ParamDecl.Name Property

Gets or sets the name of the parameter.

public string Name {get; set;}

See Also

ParamDecl Class | DDW.CSharp.Dom Namespace


Type Property

Goblin - A Platform for 3D AR and VR Applications

ParamDecl.Type Property

Gets or sets the type of the parameter.

public TypeRef Type {get; set;}

See Also

ParamDecl Class | DDW.CSharp.Dom Namespace


ParamDeclCollection Class

A strongly-typed collection of ParamDecl objects.

For a list of all members of this type, see ParamDeclCollection Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.ParamDeclCollection

public class ParamDeclCollection : CSharpGraph, IList, ICollection, IEnumerable, ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

ParamDeclCollection Members | DDW.CSharp.Dom Namespace


ParamDeclCollection Members

ParamDeclCollection overview

Public Static Methods

ReadOnly | Creates a read-only wrapper for a ParamDeclCollection instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a ParamDeclCollection instance.

Public Instance Constructors

ParamDeclCollection Overloaded. Initializes a new instance of the ParamDeclCollection class.

Public Instance Properties

Capacity | Gets or sets the number of elements the ParamDeclCollection can contain.
Count | Gets the number of elements actually contained in the ParamDeclCollection.
GraphType |
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the ParamDecl at the specified index.
LinePragma (inherited from CSharpGraph) |
SyncRoot | Gets an object that can be used to synchronize access to the collection.
Text |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Add | Adds a ParamDecl to the end of the ParamDeclCollection.
AddRange | Overloaded. Adds the elements of a ParamDecl array to the current ParamDeclCollection.
Clear | Removes all elements from the ParamDeclCollection.
Clone | Creates a shallow copy of the ParamDeclCollection.
Contains | Determines whether a given ParamDecl is in the ParamDeclCollection.
CopyTo | Overloaded. Copies the entire ParamDeclCollection to a one-dimensional ParamDecl array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the ParamDeclCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the zero-based index of the first occurrence of a ParamDecl in the ParamDeclCollection.
Insert | Inserts an element into the ParamDeclCollection at the specified index.
Remove | Removes the first occurrence of a specific ParamDecl from the ParamDeclCollection.
RemoveAt | Removes the element at the specified index of the ParamDeclCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Constructors

ParamDeclCollection Overloaded. Initializes a new instance of the ParamDeclCollection class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ParamDeclCollection Class | DDW.CSharp.Dom Namespace


ParamDeclCollection Constructor

Initializes a new instance of the ParamDeclCollection class that is empty and has the default initial capacity.

Overload List

Initializes a new instance of the ParamDeclCollection class that is empty and has the default initial capacity.

public ParamDeclCollection();

Initializes a new instance of the ParamDeclCollection class that contains elements copied from the specified ParamDecl array.

public ParamDeclCollection(ParamDecl[]);

Initializes a new instance of the ParamDeclCollection class that contains elements copied from the specified ParamDeclCollection.

public ParamDeclCollection(ParamDeclCollection);

protected ParamDeclCollection(Tag);

Initializes a new instance of the ParamDeclCollection class that has the specified initial capacity.

public ParamDeclCollection(int);

See Also

ParamDeclCollection Class | DDW.CSharp.Dom Namespace


ParamDeclCollection Constructor ()

Initializes a new instance of the ParamDeclCollection class that is empty and has the default initial capacity.

public ParamDeclCollection();

See Also

ParamDeclCollection Class | DDW.CSharp.Dom Namespace | ParamDeclCollection Constructor Overload List


ParamDeclCollection Constructor (Int32)

Initializes a new instance of the ParamDeclCollection class that has the specified initial capacity.

public ParamDeclCollection(
int capacity
);

Parameters

capacity
The number of elements that the new ParamDeclCollection is initially capable of storing.

See Also

ParamDeclCollection Class | DDW.CSharp.Dom Namespace | ParamDeclCollection Constructor Overload List


ParamDeclCollection Constructor (ParamDeclCollection)

Initializes a new instance of the ParamDeclCollection class that contains elements copied from the specified ParamDeclCollection.

public ParamDeclCollection(
ParamDeclCollection c
);

Parameters

c
The ParamDeclCollection whose elements are copied to the new collection.

See Also

ParamDeclCollection Class | DDW.CSharp.Dom Namespace | ParamDeclCollection Constructor Overload List


ParamDeclCollection Constructor (ParamDecl[])

Initializes a new instance of the ParamDeclCollection class that contains elements copied from the specified ParamDecl array.

public ParamDeclCollection(
ParamDecl[] a
);

Parameters

a
The ParamDecl array whose elements are copied to the new list.

See Also

ParamDeclCollection Class | DDW.CSharp.Dom Namespace | ParamDeclCollection Constructor Overload List


ParamDeclCollection Constructor (Tag)

protected ParamDeclCollection(
Tag t
);

See Also

ParamDeclCollection Class | DDW.CSharp.Dom Namespace | ParamDeclCollection Constructor Overload List


ParamDeclCollection Properties

The properties of the ParamDeclCollection class are listed below. For a complete list of ParamDeclCollection class members, see the ParamDeclCollection Members topic.

Public Instance Properties

Capacity | Gets or sets the number of elements the ParamDeclCollection can contain.
Count | Gets the number of elements actually contained in the ParamDeclCollection.
GraphType |
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the ParamDecl at the specified index.
LinePragma (inherited from CSharpGraph) |
SyncRoot | Gets an object that can be used to synchronize access to the collection.
Text |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

ParamDeclCollection Class | DDW.CSharp.Dom Namespace


Capacity Property

Goblin - A Platform for 3D AR and VR Applications

ParamDeclCollection.Capacity Property

Gets or sets the number of elements the ParamDeclCollection can contain.

public virtual int Capacity {get; set;}

See Also

ParamDeclCollection Class | DDW.CSharp.Dom Namespace


Count Property

Goblin - A Platform for 3D AR and VR Applications

ParamDeclCollection.Count Property

Gets the number of elements actually contained in the ParamDeclCollection.

public virtual int Count {get;}

Implements

ICollection.Count

See Also

ParamDeclCollection Class | DDW.CSharp.Dom Namespace


GraphType Property

Goblin - A Platform for 3D AR and VR Applications

ParamDeclCollection.GraphType Property

public override GraphTypes GraphType {get;}

Implements

IGraph.GraphType

See Also

ParamDeclCollection Class | DDW.CSharp.Dom Namespace


IsFixedSize Property

Goblin - A Platform for 3D AR and VR Applications

ParamDeclCollection.IsFixedSize Property

Gets a value indicating whether the collection has a fixed size.

public virtual bool IsFixedSize {get;}

Property Value

true if the collection has a fixed size; otherwise, false. The default is false

Implements

IList.IsFixedSize

See Also

ParamDeclCollection Class | DDW.CSharp.Dom Namespace


IsReadOnly Property

Goblin - A Platform for 3D AR and VR Applications

ParamDeclCollection.IsReadOnly Property

gets a value indicating whether the IList is read-only.

public virtual bool IsReadOnly {get;}

Property Value

true if the collection is read-only; otherwise, false. The default is false

Implements

IList.IsReadOnly

See Also

ParamDeclCollection Class | DDW.CSharp.Dom Namespace


IsSynchronized Property

Goblin - A Platform for 3D AR and VR Applications

ParamDeclCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread-safe).

public virtual bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

ParamDeclCollection Class | DDW.CSharp.Dom Namespace


Item Property

Goblin - A Platform for 3D AR and VR Applications

ParamDeclCollection.Item Property

Gets or sets the ParamDecl at the specified index.

public virtual ParamDecl this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

ParamDeclCollection Class | DDW.CSharp.Dom Namespace


SyncRoot Property

Goblin - A Platform for 3D AR and VR Applications

ParamDeclCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

public virtual object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

ParamDeclCollection Class | DDW.CSharp.Dom Namespace


Text Property

Goblin - A Platform for 3D AR and VR Applications

ParamDeclCollection.Text Property

public override string Text {get;}

Implements

IGraph.Text

See Also

ParamDeclCollection Class | DDW.CSharp.Dom Namespace


ParamDeclCollection Methods

The methods of the ParamDeclCollection class are listed below. For a complete list of ParamDeclCollection class members, see the ParamDeclCollection Members topic.

Public Static Methods

ReadOnly | Creates a read-only wrapper for a ParamDeclCollection instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a ParamDeclCollection instance.

Public Instance Methods

Add | Adds a ParamDecl to the end of the ParamDeclCollection.
AddRange | Overloaded. Adds the elements of a ParamDecl array to the current ParamDeclCollection.
Clear | Removes all elements from the ParamDeclCollection.
Clone | Creates a shallow copy of the ParamDeclCollection.
Contains | Determines whether a given ParamDecl is in the ParamDeclCollection.
CopyTo | Overloaded. Copies the entire ParamDeclCollection to a one-dimensional ParamDecl array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the ParamDeclCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the zero-based index of the first occurrence of a ParamDecl in the ParamDeclCollection.
Insert | Inserts an element into the ParamDeclCollection at the specified index.
Remove | Removes the first occurrence of a specific ParamDecl from the ParamDeclCollection.
RemoveAt | Removes the element at the specified index of the ParamDeclCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ParamDeclCollection Class | DDW.CSharp.Dom Namespace


ParamDeclCollection.Add Method

Adds a ParamDecl to the end of the ParamDeclCollection.

public virtual int Add(
ParamDecl item
);

Parameters

item
The ParamDecl to be added to the end of the ParamDeclCollection.

Return Value

The index at which the value has been added.

See Also

ParamDeclCollection Class | DDW.CSharp.Dom Namespace


AddRange Method

Goblin - A Platform for 3D AR and VR Applications

ParamDeclCollection.AddRange Method

Adds the elements of a ParamDecl array to the current ParamDeclCollection.

Overload List

Adds the elements of a ParamDecl array to the current ParamDeclCollection.

public virtual int AddRange(ParamDecl[]);

Adds the elements of another ParamDeclCollection to the current ParamDeclCollection.

public virtual int AddRange(ParamDeclCollection);

See Also

ParamDeclCollection Class | DDW.CSharp.Dom Namespace


ParamDeclCollection.AddRange Method (ParamDecl[])

Adds the elements of a ParamDecl array to the current ParamDeclCollection.

public virtual int AddRange(
ParamDecl[] x
);

Parameters

x
The ParamDecl array whose elements should be added to the end of the ParamDeclCollection.

Return Value

The new Count of the ParamDeclCollection.

See Also

ParamDeclCollection Class | DDW.CSharp.Dom Namespace | ParamDeclCollection.AddRange Overload List


ParamDeclCollection.AddRange Method (ParamDeclCollection)

Adds the elements of another ParamDeclCollection to the current ParamDeclCollection.

public virtual int AddRange(
ParamDeclCollection x
);

Parameters

x
The ParamDeclCollection whose elements should be added to the end of the current ParamDeclCollection.

Return Value

The new Count of the ParamDeclCollection.

See Also

ParamDeclCollection Class | DDW.CSharp.Dom Namespace | ParamDeclCollection.AddRange Overload List


ParamDeclCollection.Clear Method

Removes all elements from the ParamDeclCollection.

public virtual void Clear();

Implements

IList.Clear

See Also

ParamDeclCollection Class | DDW.CSharp.Dom Namespace


ParamDeclCollection.Clone Method

Creates a shallow copy of the ParamDeclCollection.

public virtual object Clone();

Implements

ICloneable.Clone

See Also

ParamDeclCollection Class | DDW.CSharp.Dom Namespace


ParamDeclCollection.Contains Method

Determines whether a given ParamDecl is in the ParamDeclCollection.

public virtual bool Contains(
ParamDecl item
);

Parameters

item
The ParamDecl to check for.

Return Value

true if item is found in the ParamDeclCollection; otherwise, false.

See Also

ParamDeclCollection Class | DDW.CSharp.Dom Namespace


CopyTo Method

Goblin - A Platform for 3D AR and VR Applications

ParamDeclCollection.CopyTo Method

Copies the entire ParamDeclCollection to a one-dimensional ParamDecl array.

Overload List

Copies the entire ParamDeclCollection to a one-dimensional ParamDecl array.

public virtual void CopyTo(ParamDecl[]);

Copies the entire ParamDeclCollection to a one-dimensional ParamDecl array, starting at the specified index of the target array.

public virtual void CopyTo(ParamDecl[],int);

See Also

ParamDeclCollection Class | DDW.CSharp.Dom Namespace


ParamDeclCollection.CopyTo Method (ParamDecl[])

Copies the entire ParamDeclCollection to a one-dimensional ParamDecl array.

public virtual void CopyTo(
ParamDecl[] array
);

Parameters

array
The one-dimensional ParamDecl array to copy to.

See Also

ParamDeclCollection Class | DDW.CSharp.Dom Namespace | ParamDeclCollection.CopyTo Overload List


ParamDeclCollection.CopyTo Method (ParamDecl[], Int32)

Copies the entire ParamDeclCollection to a one-dimensional ParamDecl array, starting at the specified index of the target array.

public virtual void CopyTo(
ParamDecl[] array,
int start
);

Parameters

array
The one-dimensional ParamDecl array to copy to.
start
The zero-based index in array at which copying begins.

See Also

ParamDeclCollection Class | DDW.CSharp.Dom Namespace | ParamDeclCollection.CopyTo Overload List


ParamDeclCollection.GetEnumerator Method

Returns an enumerator that can iterate through the ParamDeclCollection.

public virtual IParamDeclCollectionEnumerator GetEnumerator();

Return Value

An Enumerator for the entire ParamDeclCollection.

See Also

ParamDeclCollection Class | DDW.CSharp.Dom Namespace


ParamDeclCollection.IndexOf Method

Returns the zero-based index of the first occurrence of a ParamDecl in the ParamDeclCollection.

public virtual int IndexOf(
ParamDecl item
);

Parameters

item
The ParamDecl to locate in the ParamDeclCollection.

Return Value

The zero-based index of the first occurrence of item in the entire ParamDeclCollection, if found; otherwise, -1.

See Also

ParamDeclCollection Class | DDW.CSharp.Dom Namespace


ParamDeclCollection.Insert Method

Inserts an element into the ParamDeclCollection at the specified index.

public virtual void Insert(
int index,
ParamDecl item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The ParamDecl to insert.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

ParamDeclCollection Class | DDW.CSharp.Dom Namespace


ParamDeclCollection.ReadOnly Method

Creates a read-only wrapper for a ParamDeclCollection instance.

public static ParamDeclCollection ReadOnly(
ParamDeclCollection list
);

Return Value

An ParamDeclCollection wrapper that is read-only.

See Also

ParamDeclCollection Class | DDW.CSharp.Dom Namespace


ParamDeclCollection.Remove Method

Removes the first occurrence of a specific ParamDecl from the ParamDeclCollection.

public virtual void Remove(
ParamDecl item
);

Parameters

item
The ParamDecl to remove from the ParamDeclCollection.

Exceptions

Exception Type | Condition
ArgumentException | The specified ParamDecl was not found in the ParamDeclCollection.

See Also

ParamDeclCollection Class | DDW.CSharp.Dom Namespace


ParamDeclCollection.RemoveAt Method

Removes the element at the specified index of the ParamDeclCollection.

public virtual void RemoveAt(
int index
);

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

ParamDeclCollection Class | DDW.CSharp.Dom Namespace


ParamDeclCollection.Synchronized Method

Creates a synchronized (thread-safe) wrapper for a ParamDeclCollection instance.

public static ParamDeclCollection Synchronized(
ParamDeclCollection list
);

Return Value

An ParamDeclCollection wrapper that is synchronized (thread-safe).

See Also

ParamDeclCollection Class | DDW.CSharp.Dom Namespace


ParamDeclCollection.TrimToSize Method

Sets the capacity to the actual number of elements.

public virtual void TrimToSize();

See Also

ParamDeclCollection Class | DDW.CSharp.Dom Namespace


ParamDeclCollection.IParamDeclCollectionEnumerator Interface

Supports type-safe iteration over a ParamDeclCollection.

For a list of all members of this type, see ParamDeclCollection.IParamDeclCollectionEnumerator Members.

public interface ParamDeclCollection.IParamDeclCollectionEnumerator

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

ParamDeclCollection.IParamDeclCollectionEnumerator Members | DDW.CSharp.Dom Namespace


ParamDeclCollection.IParamDeclCollectionEnumerator Members

ParamDeclCollection.IParamDeclCollectionEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

ParamDeclCollection.IParamDeclCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


ParamDeclCollection.IParamDeclCollectionEnumerator Properties

The properties of the ParamDeclCollection.IParamDeclCollectionEnumerator interface are listed below. For a complete list of ParamDeclCollection.IParamDeclCollectionEnumerator interface members, see the ParamDeclCollection.IParamDeclCollectionEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

ParamDeclCollection.IParamDeclCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


Current Property

Goblin - A Platform for 3D AR and VR Applications

ParamDeclCollection.IParamDeclCollectionEnumerator.Current Property

Gets the current element in the collection.

ParamDecl Current {get;}

See Also

ParamDeclCollection.IParamDeclCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


ParamDeclCollection.IParamDeclCollectionEnumerator Methods

The methods of the ParamDeclCollection.IParamDeclCollectionEnumerator interface are listed below. For a complete list of ParamDeclCollection.IParamDeclCollectionEnumerator interface members, see the ParamDeclCollection.IParamDeclCollectionEnumerator Members topic.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

ParamDeclCollection.IParamDeclCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


ParamDeclCollection.IParamDeclCollectionEnumerator.MoveNext Method

Advances the enumerator to the next element in the collection.

bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Exceptions

Exception Type | Condition
InvalidOperationException | The collection was modified after the enumerator was created.

See Also

ParamDeclCollection.IParamDeclCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


ParamDeclCollection.IParamDeclCollectionEnumerator.Reset Method

Sets the enumerator to its initial position, before the first element in the collection.

void Reset();

See Also

ParamDeclCollection.IParamDeclCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


ParamDeclCollection.Tag Enumeration

protected enum ParamDeclCollection.Tag

Members

Member Name | Description
Default |

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

DDW.CSharp.Dom Namespace


ParamDirection Enumeration

An enumeration of possible parameter directions (ref or out).

public enum ParamDirection

Members

Member Name | Description
Value |
Ref |
Out |

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

DDW.CSharp.Dom Namespace


PostfixExpr Class

A postfix expression (x++, y--).

For a list of all members of this type, see PostfixExpr Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Expression
DDW.CSharp.Dom.PostfixExpr

public class PostfixExpr : Expression

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

PostfixExpr Members | DDW.CSharp.Dom Namespace


PostfixExpr Members

PostfixExpr overview

Public Instance Constructors

PostfixExpr Constructor Initializes a new instance of the PostfixExpr class.

Public Instance Properties

Left | Gets or sets the left side of the expression that the postfix affects.
LinePragma (inherited from CSharpGraph) |
Operator | Gets or sets the postfix operator (which can be either ++ or --).
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PostfixExpr Class | DDW.CSharp.Dom Namespace


PostfixExpr Constructor

Initializes a new instance of the PostfixExpr class.

public PostfixExpr();

See Also

PostfixExpr Class | DDW.CSharp.Dom Namespace


PostfixExpr Properties

The properties of the PostfixExpr class are listed below. For a complete list of PostfixExpr class members, see the PostfixExpr Members topic.

Public Instance Properties

Left | Gets or sets the left side of the expression that the postfix affects.
LinePragma (inherited from CSharpGraph) |
Operator | Gets or sets the postfix operator (which can be either ++ or --).
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

PostfixExpr Class | DDW.CSharp.Dom Namespace


Left Property

Goblin - A Platform for 3D AR and VR Applications

PostfixExpr.Left Property

Gets or sets the left side of the expression that the postfix affects.

public Expression Left {get; set;}

See Also

PostfixExpr Class | DDW.CSharp.Dom Namespace


Operator Property

Goblin - A Platform for 3D AR and VR Applications

PostfixExpr.Operator Property

Gets or sets the postfix operator (which can be either ++ or --).

public PostfixOperator Operator {get; set;}

See Also

PostfixExpr Class | DDW.CSharp.Dom Namespace


PostfixOperator Enumeration

An enumeration of possible postfix expression operators (++ and --).

public enum PostfixOperator

Members

Member Name | Description
Empty |
Increment |
Decrement |

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

DDW.CSharp.Dom Namespace


PrimitiveExpr Class

An abstract base class for primative types.

For a list of all members of this type, see PrimitiveExpr Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Expression
DDW.CSharp.Dom.PrimitiveExpr
Derived types

public abstract class PrimitiveExpr : Expression

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

PrimitiveExpr Members | DDW.CSharp.Dom Namespace


PrimitiveExpr Members

PrimitiveExpr overview

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

PrimitiveExpr Constructor Initializes a new instance of the PrimitiveExpr class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PrimitiveExpr Class | DDW.CSharp.Dom Namespace


PrimitiveExpr Constructor

Initializes a new instance of the PrimitiveExpr class.

protected PrimitiveExpr();

See Also

PrimitiveExpr Class | DDW.CSharp.Dom Namespace


PropertyDecl Class

A property declaration.

For a list of all members of this type, see PropertyDecl Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.MemberDecl
DDW.CSharp.Dom.PropertyDecl

public class PropertyDecl : MemberDecl, IDeclaration

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

PropertyDecl Members | DDW.CSharp.Dom Namespace


PropertyDecl Members

PropertyDecl overview

Public Instance Constructors

PropertyDecl Constructor Initializes a new instance of the PropertyDecl class.

Public Instance Properties

Attributes (inherited from MemberDecl) | Gets or sets the modifier flags for this member (public, private etc).
Comments (inherited from MemberDecl) | Gets the collection of comments for this member.
CustomAttributes (inherited from MemberDecl) | Gets the collection of Custom Attributes used for this member (custom attributes are the ones declared between brackets, like [Flags]).
Definition | Gets the (scoped) definition.
GetAccessor | Gets or sets the 'get' accessor for this property. This will not have an associated block if the property is declared as abstract or in an interface.
HasGet | Gets or sets the boolean value that indicates whether a get accessor is to be used.
HasSet | Gets or sets the boolean value that indicates whether a set accessor is to be used. Setting this to false will not destroy the SetAccessor value.
LinePragma (inherited from CSharpGraph) |
MemberKind |
Name | Gets or sets the name of the property. This may use dot syntax.
SetAccessor | Gets or sets the 'set' accessor for this property, if present. This will not have an associated block if the property is declared as abstract or in an interface.
Type | Gets or sets the type of the property.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
VerifyModifiers (inherited from MemberDecl) |

See Also

PropertyDecl Class | DDW.CSharp.Dom Namespace


PropertyDecl Constructor

Initializes a new instance of the PropertyDecl class.

public PropertyDecl();

See Also

PropertyDecl Class | DDW.CSharp.Dom Namespace


PropertyDecl Properties

The properties of the PropertyDecl class are listed below. For a complete list of PropertyDecl class members, see the PropertyDecl Members topic.

Public Instance Properties

Attributes (inherited from MemberDecl) | Gets or sets the modifier flags for this member (public, private etc).
Comments (inherited from MemberDecl) | Gets the collection of comments for this member.
CustomAttributes (inherited from MemberDecl) | Gets the collection of Custom Attributes used for this member (custom attributes are the ones declared between brackets, like [Flags]).
Definition | Gets the (scoped) definition.
GetAccessor | Gets or sets the 'get' accessor for this property. This will not have an associated block if the property is declared as abstract or in an interface.
HasGet | Gets or sets the boolean value that indicates whether a get accessor is to be used.
HasSet | Gets or sets the boolean value that indicates whether a set accessor is to be used. Setting this to false will not destroy the SetAccessor value.
LinePragma (inherited from CSharpGraph) |
MemberKind |
Name | Gets or sets the name of the property. This may use dot syntax.
SetAccessor | Gets or sets the 'set' accessor for this property, if present. This will not have an associated block if the property is declared as abstract or in an interface.
Type | Gets or sets the type of the property.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

PropertyDecl Class | DDW.CSharp.Dom Namespace


Definition Property

Goblin - A Platform for 3D AR and VR Applications

PropertyDecl.Definition Property

Gets the (scoped) definition.

public DDW.CSharp.SymbolTable.IDefinition Definition {get;}

Implements

IDeclaration.Definition

See Also

PropertyDecl Class | DDW.CSharp.Dom Namespace


GetAccessor Property

Goblin - A Platform for 3D AR and VR Applications

PropertyDecl.GetAccessor Property

Gets or sets the 'get' accessor for this property. This will not have an associated block if the property is declared as abstract or in an interface.

public AccessorDecl GetAccessor {get; set;}

See Also

PropertyDecl Class | DDW.CSharp.Dom Namespace


HasGet Property

Goblin - A Platform for 3D AR and VR Applications

PropertyDecl.HasGet Property

Gets or sets the boolean value that indicates whether a get accessor is to be used.

public bool HasGet {get; set;}

See Also

PropertyDecl Class | DDW.CSharp.Dom Namespace


HasSet Property

Goblin - A Platform for 3D AR and VR Applications

PropertyDecl.HasSet Property

Gets or sets the boolean value that indicates whether a set accessor is to be used. Setting this to false will not destroy the SetAccessor value.

public bool HasSet {get; set;}

See Also

PropertyDecl Class | DDW.CSharp.Dom Namespace


MemberKind Property

Goblin - A Platform for 3D AR and VR Applications

PropertyDecl.MemberKind Property

public override MemberKind MemberKind {get;}

See Also

PropertyDecl Class | DDW.CSharp.Dom Namespace


Name Property

Goblin - A Platform for 3D AR and VR Applications

PropertyDecl.Name Property

Gets or sets the name of the property. This may use dot syntax.

public string Name {get; set;}

See Also

PropertyDecl Class | DDW.CSharp.Dom Namespace


SetAccessor Property

Goblin - A Platform for 3D AR and VR Applications

PropertyDecl.SetAccessor Property

Gets or sets the 'set' accessor for this property, if present. This will not have an associated block if the property is declared as abstract or in an interface.

public AccessorDecl SetAccessor {get; set;}

See Also

PropertyDecl Class | DDW.CSharp.Dom Namespace


Type Property

Goblin - A Platform for 3D AR and VR Applications

PropertyDecl.Type Property

Gets or sets the type of the property.

public TypeRef Type {get; set;}

See Also

PropertyDecl Class | DDW.CSharp.Dom Namespace


PropertyRef Class

A reference to a property.

For a list of all members of this type, see PropertyRef Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Expression
DDW.CSharp.Dom.Reference
DDW.CSharp.Dom.PropertyRef

public class PropertyRef : Reference

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

PropertyRef Members | DDW.CSharp.Dom Namespace


PropertyRef Members

PropertyRef overview

Public Instance Constructors

PropertyRef Constructor Initializes a new instance of the PropertyRef class.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
PropertyName | Gets or sets the name of the property.
Target | Gets or sets the target object to which the property belongs.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PropertyRef Class | DDW.CSharp.Dom Namespace


PropertyRef Constructor

Initializes a new instance of the PropertyRef class.

public PropertyRef();

See Also

PropertyRef Class | DDW.CSharp.Dom Namespace


PropertyRef Properties

The properties of the PropertyRef class are listed below. For a complete list of PropertyRef class members, see the PropertyRef Members topic.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
PropertyName | Gets or sets the name of the property.
Target | Gets or sets the target object to which the property belongs.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

PropertyRef Class | DDW.CSharp.Dom Namespace


PropertyName Property

Goblin - A Platform for 3D AR and VR Applications

PropertyRef.PropertyName Property

Gets or sets the name of the property.

public string PropertyName {get; set;}

See Also

PropertyRef Class | DDW.CSharp.Dom Namespace


Target Property

Goblin - A Platform for 3D AR and VR Applications

PropertyRef.Target Property

Gets or sets the target object to which the property belongs.

public Expression Target {get; set;}

See Also

PropertyRef Class | DDW.CSharp.Dom Namespace


PropertySetValueRef Class

A 'value' reference, used inside a set accessor.

For a list of all members of this type, see PropertySetValueRef Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Expression
DDW.CSharp.Dom.Reference
DDW.CSharp.Dom.PropertySetValueRef

public class PropertySetValueRef : Reference

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

PropertySetValueRef Members | DDW.CSharp.Dom Namespace


PropertySetValueRef Members

PropertySetValueRef overview

Public Instance Constructors

PropertySetValueRef Constructor Initializes a new instance of the PropertySetValueRef class.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PropertySetValueRef Class | DDW.CSharp.Dom Namespace


PropertySetValueRef Constructor

Initializes a new instance of the PropertySetValueRef class.

public PropertySetValueRef();

See Also

PropertySetValueRef Class | DDW.CSharp.Dom Namespace


RankSpecifier Class

A rank specifier for an array. There can be more than one rank specifier in the case of a jagged array (x[][]).

For a list of all members of this type, see RankSpecifier Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.RankSpecifier

public class RankSpecifier : CSharpGraph

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

RankSpecifier Members | DDW.CSharp.Dom Namespace


RankSpecifier Members

RankSpecifier overview

Public Instance Constructors

RankSpecifier Constructor Initializes a new instance of the RankSpecifier class.

Public Instance Properties

Dimensions | Gets or set the number of dimensions in this rank specifier (eg. [,,] has three dimensions).
LinePragma (inherited from CSharpGraph) |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RankSpecifier Class | DDW.CSharp.Dom Namespace


RankSpecifier Constructor

Initializes a new instance of the RankSpecifier class.

public RankSpecifier();

See Also

RankSpecifier Class | DDW.CSharp.Dom Namespace


RankSpecifier Properties

The properties of the RankSpecifier class are listed below. For a complete list of RankSpecifier class members, see the RankSpecifier Members topic.

Public Instance Properties

Dimensions | Gets or set the number of dimensions in this rank specifier (eg. [,,] has three dimensions).
LinePragma (inherited from CSharpGraph) |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

RankSpecifier Class | DDW.CSharp.Dom Namespace


Dimensions Property

Goblin - A Platform for 3D AR and VR Applications

RankSpecifier.Dimensions Property

Gets or set the number of dimensions in this rank specifier (eg. [,,] has three dimensions).

public int Dimensions {get; set;}

See Also

RankSpecifier Class | DDW.CSharp.Dom Namespace


RankSpecifierCollection Class

A strongly-typed collection of RankSpecifier objects.

For a list of all members of this type, see RankSpecifierCollection Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.RankSpecifierCollection

public class RankSpecifierCollection : CSharpGraph, IList, ICollection, IEnumerable, ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

RankSpecifierCollection Members | DDW.CSharp.Dom Namespace


RankSpecifierCollection Members

RankSpecifierCollection overview

Public Static Methods

ReadOnly | Creates a read-only wrapper for a RankSpecifierCollection instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a RankSpecifierCollection instance.

Public Instance Constructors

RankSpecifierCollection Overloaded. Initializes a new instance of the RankSpecifierCollection class.

Public Instance Properties

Capacity | Gets or sets the number of elements the RankSpecifierCollection can contain.
Count | Gets the number of elements actually contained in the RankSpecifierCollection.
GraphType |
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the RankSpecifier at the specified index.
LinePragma (inherited from CSharpGraph) |
SyncRoot | Gets an object that can be used to synchronize access to the collection.
Text |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Add | Adds a RankSpecifier to the end of the RankSpecifierCollection.
AddRange | Overloaded. Adds the elements of a RankSpecifier array to the current RankSpecifierCollection.
Clear | Removes all elements from the RankSpecifierCollection.
Clone | Creates a shallow copy of the RankSpecifierCollection.
Contains | Determines whether a given RankSpecifier is in the RankSpecifierCollection.
CopyTo | Overloaded. Copies the entire RankSpecifierCollection to a one-dimensional RankSpecifier array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the RankSpecifierCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the zero-based index of the first occurrence of a RankSpecifier in the RankSpecifierCollection.
Insert | Inserts an element into the RankSpecifierCollection at the specified index.
Remove | Removes the first occurrence of a specific RankSpecifier from the RankSpecifierCollection.
RemoveAt | Removes the element at the specified index of the RankSpecifierCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Constructors

RankSpecifierCollection Overloaded. Initializes a new instance of the RankSpecifierCollection class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RankSpecifierCollection Class | DDW.CSharp.Dom Namespace


RankSpecifierCollection Constructor

Initializes a new instance of the RankSpecifierCollection class that is empty and has the default initial capacity.

Overload List

Initializes a new instance of the RankSpecifierCollection class that is empty and has the default initial capacity.

public RankSpecifierCollection();

Initializes a new instance of the RankSpecifierCollection class that contains elements copied from the specified RankSpecifier array.

public RankSpecifierCollection(RankSpecifier[]);

Initializes a new instance of the RankSpecifierCollection class that contains elements copied from the specified RankSpecifierCollection.

public RankSpecifierCollection(RankSpecifierCollection);

protected RankSpecifierCollection(Tag);

Initializes a new instance of the RankSpecifierCollection class that has the specified initial capacity.

public RankSpecifierCollection(int);

See Also

RankSpecifierCollection Class | DDW.CSharp.Dom Namespace


RankSpecifierCollection Constructor ()

Initializes a new instance of the RankSpecifierCollection class that is empty and has the default initial capacity.

public RankSpecifierCollection();

See Also

RankSpecifierCollection Class | DDW.CSharp.Dom Namespace | RankSpecifierCollection Constructor Overload List


RankSpecifierCollection Constructor (Int32)

Initializes a new instance of the RankSpecifierCollection class that has the specified initial capacity.

public RankSpecifierCollection(
int capacity
);

Parameters

capacity
The number of elements that the new RankSpecifierCollection is initially capable of storing.

See Also

RankSpecifierCollection Class | DDW.CSharp.Dom Namespace | RankSpecifierCollection Constructor Overload List


RankSpecifierCollection Constructor (RankSpecifierCollection)

Initializes a new instance of the RankSpecifierCollection class that contains elements copied from the specified RankSpecifierCollection.

public RankSpecifierCollection(
RankSpecifierCollection c
);

Parameters

c
The RankSpecifierCollection whose elements are copied to the new collection.

See Also

RankSpecifierCollection Class | DDW.CSharp.Dom Namespace | RankSpecifierCollection Constructor Overload List


RankSpecifierCollection Constructor (RankSpecifier[])

Initializes a new instance of the RankSpecifierCollection class that contains elements copied from the specified RankSpecifier array.

public RankSpecifierCollection(
RankSpecifier[] a
);

Parameters

a
The RankSpecifier array whose elements are copied to the new list.

See Also

RankSpecifierCollection Class | DDW.CSharp.Dom Namespace | RankSpecifierCollection Constructor Overload List


RankSpecifierCollection Constructor (Tag)

protected RankSpecifierCollection(
Tag t
);

See Also

RankSpecifierCollection Class | DDW.CSharp.Dom Namespace | RankSpecifierCollection Constructor Overload List


RankSpecifierCollection Properties

The properties of the RankSpecifierCollection class are listed below. For a complete list of RankSpecifierCollection class members, see the RankSpecifierCollection Members topic.

Public Instance Properties

Capacity | Gets or sets the number of elements the RankSpecifierCollection can contain.
Count | Gets the number of elements actually contained in the RankSpecifierCollection.
GraphType |
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the RankSpecifier at the specified index.
LinePragma (inherited from CSharpGraph) |
SyncRoot | Gets an object that can be used to synchronize access to the collection.
Text |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

RankSpecifierCollection Class | DDW.CSharp.Dom Namespace


Capacity Property

Goblin - A Platform for 3D AR and VR Applications

RankSpecifierCollection.Capacity Property

Gets or sets the number of elements the RankSpecifierCollection can contain.

public virtual int Capacity {get; set;}

See Also

RankSpecifierCollection Class | DDW.CSharp.Dom Namespace


Count Property

Goblin - A Platform for 3D AR and VR Applications

RankSpecifierCollection.Count Property

Gets the number of elements actually contained in the RankSpecifierCollection.

public virtual int Count {get;}

Implements

ICollection.Count

See Also

RankSpecifierCollection Class | DDW.CSharp.Dom Namespace


GraphType Property

Goblin - A Platform for 3D AR and VR Applications

RankSpecifierCollection.GraphType Property

public override GraphTypes GraphType {get;}

Implements

IGraph.GraphType

See Also

RankSpecifierCollection Class | DDW.CSharp.Dom Namespace


IsFixedSize Property

Goblin - A Platform for 3D AR and VR Applications

RankSpecifierCollection.IsFixedSize Property

Gets a value indicating whether the collection has a fixed size.

public virtual bool IsFixedSize {get;}

Property Value

true if the collection has a fixed size; otherwise, false. The default is false

Implements

IList.IsFixedSize

See Also

RankSpecifierCollection Class | DDW.CSharp.Dom Namespace


IsReadOnly Property

Goblin - A Platform for 3D AR and VR Applications

RankSpecifierCollection.IsReadOnly Property

gets a value indicating whether the IList is read-only.

public virtual bool IsReadOnly {get;}

Property Value

true if the collection is read-only; otherwise, false. The default is false

Implements

IList.IsReadOnly

See Also

RankSpecifierCollection Class | DDW.CSharp.Dom Namespace


IsSynchronized Property

Goblin - A Platform for 3D AR and VR Applications

RankSpecifierCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread-safe).

public virtual bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

RankSpecifierCollection Class | DDW.CSharp.Dom Namespace


Item Property

Goblin - A Platform for 3D AR and VR Applications

RankSpecifierCollection.Item Property

Gets or sets the RankSpecifier at the specified index.

public virtual RankSpecifier this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

RankSpecifierCollection Class | DDW.CSharp.Dom Namespace


SyncRoot Property

Goblin - A Platform for 3D AR and VR Applications

RankSpecifierCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

public virtual object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

RankSpecifierCollection Class | DDW.CSharp.Dom Namespace


Text Property

Goblin - A Platform for 3D AR and VR Applications

RankSpecifierCollection.Text Property

public override string Text {get;}

Implements

IGraph.Text

See Also

RankSpecifierCollection Class | DDW.CSharp.Dom Namespace


RankSpecifierCollection Methods

The methods of the RankSpecifierCollection class are listed below. For a complete list of RankSpecifierCollection class members, see the RankSpecifierCollection Members topic.

Public Static Methods

ReadOnly | Creates a read-only wrapper for a RankSpecifierCollection instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a RankSpecifierCollection instance.

Public Instance Methods

Add | Adds a RankSpecifier to the end of the RankSpecifierCollection.
AddRange | Overloaded. Adds the elements of a RankSpecifier array to the current RankSpecifierCollection.
Clear | Removes all elements from the RankSpecifierCollection.
Clone | Creates a shallow copy of the RankSpecifierCollection.
Contains | Determines whether a given RankSpecifier is in the RankSpecifierCollection.
CopyTo | Overloaded. Copies the entire RankSpecifierCollection to a one-dimensional RankSpecifier array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the RankSpecifierCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the zero-based index of the first occurrence of a RankSpecifier in the RankSpecifierCollection.
Insert | Inserts an element into the RankSpecifierCollection at the specified index.
Remove | Removes the first occurrence of a specific RankSpecifier from the RankSpecifierCollection.
RemoveAt | Removes the element at the specified index of the RankSpecifierCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RankSpecifierCollection Class | DDW.CSharp.Dom Namespace


RankSpecifierCollection.Add Method

Adds a RankSpecifier to the end of the RankSpecifierCollection.

public virtual int Add(
RankSpecifier item
);

Parameters

item
The RankSpecifier to be added to the end of the RankSpecifierCollection.

Return Value

The index at which the value has been added.

See Also

RankSpecifierCollection Class | DDW.CSharp.Dom Namespace


AddRange Method

Goblin - A Platform for 3D AR and VR Applications

RankSpecifierCollection.AddRange Method

Adds the elements of a RankSpecifier array to the current RankSpecifierCollection.

Overload List

Adds the elements of a RankSpecifier array to the current RankSpecifierCollection.

public virtual int AddRange(RankSpecifier[]);

Adds the elements of another RankSpecifierCollection to the current RankSpecifierCollection.

public virtual int AddRange(RankSpecifierCollection);

See Also

RankSpecifierCollection Class | DDW.CSharp.Dom Namespace


RankSpecifierCollection.AddRange Method (RankSpecifier[])

Adds the elements of a RankSpecifier array to the current RankSpecifierCollection.

public virtual int AddRange(
RankSpecifier[] x
);

Parameters

x
The RankSpecifier array whose elements should be added to the end of the RankSpecifierCollection.

Return Value

The new Count of the RankSpecifierCollection.

See Also

RankSpecifierCollection Class | DDW.CSharp.Dom Namespace | RankSpecifierCollection.AddRange Overload List


RankSpecifierCollection.AddRange Method (RankSpecifierCollection)

Adds the elements of another RankSpecifierCollection to the current RankSpecifierCollection.

public virtual int AddRange(
RankSpecifierCollection x
);

Parameters

x
The RankSpecifierCollection whose elements should be added to the end of the current RankSpecifierCollection.

Return Value

The new Count of the RankSpecifierCollection.

See Also

RankSpecifierCollection Class | DDW.CSharp.Dom Namespace | RankSpecifierCollection.AddRange Overload List


RankSpecifierCollection.Clear Method

Removes all elements from the RankSpecifierCollection.

public virtual void Clear();

Implements

IList.Clear

See Also

RankSpecifierCollection Class | DDW.CSharp.Dom Namespace


RankSpecifierCollection.Clone Method

Creates a shallow copy of the RankSpecifierCollection.

public virtual object Clone();

Implements

ICloneable.Clone

See Also

RankSpecifierCollection Class | DDW.CSharp.Dom Namespace


RankSpecifierCollection.Contains Method

Determines whether a given RankSpecifier is in the RankSpecifierCollection.

public virtual bool Contains(
RankSpecifier item
);

Parameters

item
The RankSpecifier to check for.

Return Value

true if item is found in the RankSpecifierCollection; otherwise, false.

See Also

RankSpecifierCollection Class | DDW.CSharp.Dom Namespace


CopyTo Method

Goblin - A Platform for 3D AR and VR Applications

RankSpecifierCollection.CopyTo Method

Copies the entire RankSpecifierCollection to a one-dimensional RankSpecifier array.

Overload List

Copies the entire RankSpecifierCollection to a one-dimensional RankSpecifier array.

public virtual void CopyTo(RankSpecifier[]);

Copies the entire RankSpecifierCollection to a one-dimensional RankSpecifier array, starting at the specified index of the target array.

public virtual void CopyTo(RankSpecifier[],int);

See Also

RankSpecifierCollection Class | DDW.CSharp.Dom Namespace


RankSpecifierCollection.CopyTo Method (RankSpecifier[])

Copies the entire RankSpecifierCollection to a one-dimensional RankSpecifier array.

public virtual void CopyTo(
RankSpecifier[] array
);

Parameters

array
The one-dimensional RankSpecifier array to copy to.

See Also

RankSpecifierCollection Class | DDW.CSharp.Dom Namespace | RankSpecifierCollection.CopyTo Overload List


RankSpecifierCollection.CopyTo Method (RankSpecifier[], Int32)

Copies the entire RankSpecifierCollection to a one-dimensional RankSpecifier array, starting at the specified index of the target array.

public virtual void CopyTo(
RankSpecifier[] array,
int start
);

Parameters

array
The one-dimensional RankSpecifier array to copy to.
start
The zero-based index in array at which copying begins.

See Also

RankSpecifierCollection Class | DDW.CSharp.Dom Namespace | RankSpecifierCollection.CopyTo Overload List


RankSpecifierCollection.GetEnumerator Method

Returns an enumerator that can iterate through the RankSpecifierCollection.

public virtual IRankCollectionEnumerator GetEnumerator();

Return Value

An Enumerator for the entire RankSpecifierCollection.

See Also

RankSpecifierCollection Class | DDW.CSharp.Dom Namespace


RankSpecifierCollection.IndexOf Method

Returns the zero-based index of the first occurrence of a RankSpecifier in the RankSpecifierCollection.

public virtual int IndexOf(
RankSpecifier item
);

Parameters

item
The RankSpecifier to locate in the RankSpecifierCollection.

Return Value

The zero-based index of the first occurrence of item in the entire RankSpecifierCollection, if found; otherwise, -1.

See Also

RankSpecifierCollection Class | DDW.CSharp.Dom Namespace


RankSpecifierCollection.Insert Method

Inserts an element into the RankSpecifierCollection at the specified index.

public virtual void Insert(
int index,
RankSpecifier item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The RankSpecifier to insert.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

RankSpecifierCollection Class | DDW.CSharp.Dom Namespace


RankSpecifierCollection.ReadOnly Method

Creates a read-only wrapper for a RankSpecifierCollection instance.

public static RankSpecifierCollection ReadOnly(
RankSpecifierCollection list
);

Return Value

An RankSpecifierCollection wrapper that is read-only.

See Also

RankSpecifierCollection Class | DDW.CSharp.Dom Namespace


RankSpecifierCollection.Remove Method

Removes the first occurrence of a specific RankSpecifier from the RankSpecifierCollection.

public virtual void Remove(
RankSpecifier item
);

Parameters

item
The RankSpecifier to remove from the RankSpecifierCollection.

Exceptions

Exception Type | Condition
ArgumentException | The specified RankSpecifier was not found in the RankSpecifierCollection.

See Also

RankSpecifierCollection Class | DDW.CSharp.Dom Namespace


RankSpecifierCollection.RemoveAt Method

Removes the element at the specified index of the RankSpecifierCollection.

public virtual void RemoveAt(
int index
);

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

RankSpecifierCollection Class | DDW.CSharp.Dom Namespace


RankSpecifierCollection.Synchronized Method

Creates a synchronized (thread-safe) wrapper for a RankSpecifierCollection instance.

public static RankSpecifierCollection Synchronized(
RankSpecifierCollection list
);

Return Value

An RankSpecifierCollection wrapper that is synchronized (thread-safe).

See Also

RankSpecifierCollection Class | DDW.CSharp.Dom Namespace


RankSpecifierCollection.TrimToSize Method

Sets the capacity to the actual number of elements.

public virtual void TrimToSize();

See Also

RankSpecifierCollection Class | DDW.CSharp.Dom Namespace


RankSpecifierCollection.IRankCollectionEnumerator Interface

Supports type-safe iteration over a RankSpecifierCollection.

For a list of all members of this type, see RankSpecifierCollection.IRankCollectionEnumerator Members.

public interface RankSpecifierCollection.IRankCollectionEnumerator

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

RankSpecifierCollection.IRankCollectionEnumerator Members | DDW.CSharp.Dom Namespace


RankSpecifierCollection.IRankCollectionEnumerator Members

RankSpecifierCollection.IRankCollectionEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

RankSpecifierCollection.IRankCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


RankSpecifierCollection.IRankCollectionEnumerator Properties

The properties of the RankSpecifierCollection.IRankCollectionEnumerator interface are listed below. For a complete list of RankSpecifierCollection.IRankCollectionEnumerator interface members, see the RankSpecifierCollection.IRankCollectionEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

RankSpecifierCollection.IRankCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


Current Property

Goblin - A Platform for 3D AR and VR Applications

RankSpecifierCollection.IRankCollectionEnumerator.Current Property

Gets the current element in the collection.

RankSpecifier Current {get;}

See Also

RankSpecifierCollection.IRankCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


RankSpecifierCollection.IRankCollectionEnumerator Methods

The methods of the RankSpecifierCollection.IRankCollectionEnumerator interface are listed below. For a complete list of RankSpecifierCollection.IRankCollectionEnumerator interface members, see the RankSpecifierCollection.IRankCollectionEnumerator Members topic.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

RankSpecifierCollection.IRankCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


RankSpecifierCollection.IRankCollectionEnumerator.MoveNext Method

Advances the enumerator to the next element in the collection.

bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Exceptions

Exception Type | Condition
InvalidOperationException | The collection was modified after the enumerator was created.

See Also

RankSpecifierCollection.IRankCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


RankSpecifierCollection.IRankCollectionEnumerator.Reset Method

Sets the enumerator to its initial position, before the first element in the collection.

void Reset();

See Also

RankSpecifierCollection.IRankCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


RankSpecifierCollection.Tag Enumeration

protected enum RankSpecifierCollection.Tag

Members

Member Name | Description
Default |

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

DDW.CSharp.Dom Namespace


RealLiteral Class

An real literal. Will be a floating point number.

For a list of all members of this type, see RealLiteral Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Expression
DDW.CSharp.Dom.PrimitiveExpr
DDW.CSharp.Dom.RealLiteral

public class RealLiteral : PrimitiveExpr

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

RealLiteral Members | DDW.CSharp.Dom Namespace


RealLiteral Members

RealLiteral overview

Public Instance Constructors

RealLiteral Constructor Initializes a new instance of the RealLiteral class.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.
Value | Gets or sets the floating point value of this real literal.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RealLiteral Class | DDW.CSharp.Dom Namespace


RealLiteral Constructor

Initializes a new instance of the RealLiteral class.

public RealLiteral();

See Also

RealLiteral Class | DDW.CSharp.Dom Namespace


RealLiteral Properties

The properties of the RealLiteral class are listed below. For a complete list of RealLiteral class members, see the RealLiteral Members topic.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.
Value | Gets or sets the floating point value of this real literal.

See Also

RealLiteral Class | DDW.CSharp.Dom Namespace


Value Property

Goblin - A Platform for 3D AR and VR Applications

RealLiteral.Value Property

Gets or sets the floating point value of this real literal.

public double Value {get; set;}

See Also

RealLiteral Class | DDW.CSharp.Dom Namespace


Reference Class

A variable.

For a list of all members of this type, see Reference Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Expression
DDW.CSharp.Dom.Reference
Derived types

public abstract class Reference : Expression, ISymbolRef, IDeclaration

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

Reference Members | DDW.CSharp.Dom Namespace


Reference Members

Reference overview

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

Reference Constructor Initializes a new instance of the Reference class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Reference Class | DDW.CSharp.Dom Namespace


Reference Constructor

Initializes a new instance of the Reference class.

protected Reference();

See Also

Reference Class | DDW.CSharp.Dom Namespace


RemoveDelegateStmt Class

Removes a delegate from an event.

For a list of all members of this type, see RemoveDelegateStmt Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Statement
DDW.CSharp.Dom.RemoveDelegateStmt

public class RemoveDelegateStmt : Statement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

RemoveDelegateStmt Members | DDW.CSharp.Dom Namespace


RemoveDelegateStmt Members

RemoveDelegateStmt overview

Public Instance Constructors

RemoveDelegateStmt Constructor Initializes a new instance of the RemoveDelegateStmt class.

Public Instance Properties

Event | Gets or sets the event to remove the delegate from.
LinePragma (inherited from CSharpGraph) |
Listener | Gets or sets the listener method to be detached.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RemoveDelegateStmt Class | DDW.CSharp.Dom Namespace


RemoveDelegateStmt Constructor

Initializes a new instance of the RemoveDelegateStmt class.

public RemoveDelegateStmt();

See Also

RemoveDelegateStmt Class | DDW.CSharp.Dom Namespace


RemoveDelegateStmt Properties

The properties of the RemoveDelegateStmt class are listed below. For a complete list of RemoveDelegateStmt class members, see the RemoveDelegateStmt Members topic.

Public Instance Properties

Event | Gets or sets the event to remove the delegate from.
LinePragma (inherited from CSharpGraph) |
Listener | Gets or sets the listener method to be detached.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

RemoveDelegateStmt Class | DDW.CSharp.Dom Namespace


Event Property

Goblin - A Platform for 3D AR and VR Applications

RemoveDelegateStmt.Event Property

Gets or sets the event to remove the delegate from.

public TypeRef Event {get; set;}

See Also

RemoveDelegateStmt Class | DDW.CSharp.Dom Namespace


Listener Property

Goblin - A Platform for 3D AR and VR Applications

RemoveDelegateStmt.Listener Property

Gets or sets the listener method to be detached.

public Expression Listener {get; set;}

See Also

RemoveDelegateStmt Class | DDW.CSharp.Dom Namespace


ReturnStmt Class

A return statement.

For a list of all members of this type, see ReturnStmt Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Statement
DDW.CSharp.Dom.ReturnStmt

public class ReturnStmt : Statement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

ReturnStmt Members | DDW.CSharp.Dom Namespace


ReturnStmt Members

ReturnStmt overview

Public Instance Constructors

ReturnStmt Constructor Initializes a new instance of the ReturnStmt class.

Public Instance Properties

Expression | Gets or sets the expression to be returned. Can be left empty for void returns.
LinePragma (inherited from CSharpGraph) |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ReturnStmt Class | DDW.CSharp.Dom Namespace


ReturnStmt Constructor

Initializes a new instance of the ReturnStmt class.

public ReturnStmt();

See Also

ReturnStmt Class | DDW.CSharp.Dom Namespace


ReturnStmt Properties

The properties of the ReturnStmt class are listed below. For a complete list of ReturnStmt class members, see the ReturnStmt Members topic.

Public Instance Properties

Expression | Gets or sets the expression to be returned. Can be left empty for void returns.
LinePragma (inherited from CSharpGraph) |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

ReturnStmt Class | DDW.CSharp.Dom Namespace


Expression Property

Goblin - A Platform for 3D AR and VR Applications

ReturnStmt.Expression Property

Gets or sets the expression to be returned. Can be left empty for void returns.

public Expression Expression {get; set;}

See Also

ReturnStmt Class | DDW.CSharp.Dom Namespace


Statement Class

An abstract base class for statements.

For a list of all members of this type, see Statement Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Statement
Derived types

public abstract class Statement : CSharpGraph

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

Statement Members | DDW.CSharp.Dom Namespace


Statement Members

Statement overview

Public Instance Properties

GraphType (inherited from CSharpGraph) |
LinePragma (inherited from CSharpGraph) |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

Statement Constructor Initializes a new instance of the Statement class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Statement Class | DDW.CSharp.Dom Namespace


Statement Constructor

Initializes a new instance of the Statement class.

protected Statement();

See Also

Statement Class | DDW.CSharp.Dom Namespace


StatementCollection Class

A strongly-typed collection of Statement objects.

For a list of all members of this type, see StatementCollection Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.StatementCollection

public class StatementCollection : CSharpGraph, IList, ICollection, IEnumerable, ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

StatementCollection Members | DDW.CSharp.Dom Namespace


StatementCollection Members

StatementCollection overview

Public Static Methods

ReadOnly | Creates a read-only wrapper for a StatementCollection instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a StatementCollection instance.

Public Instance Constructors

StatementCollection Overloaded. Initializes a new instance of the StatementCollection class.

Public Instance Properties

Capacity | Gets or sets the number of elements the StatementCollection can contain.
Count | Gets the number of elements actually contained in the StatementCollection.
GraphType |
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the Statement at the specified index.
LinePragma (inherited from CSharpGraph) |
SyncRoot | Gets an object that can be used to synchronize access to the collection.
Text |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Add | Adds a Statement to the end of the StatementCollection.
AddRange | Overloaded. Adds the elements of a Statement array to the current StatementCollection.
Clear | Removes all elements from the StatementCollection.
Clone | Creates a shallow copy of the StatementCollection.
Contains | Determines whether a given Statement is in the StatementCollection.
CopyTo | Overloaded. Copies the entire StatementCollection to a one-dimensional Statement array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the StatementCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the zero-based index of the first occurrence of a Statement in the StatementCollection.
Insert | Inserts an element into the StatementCollection at the specified index.
Remove | Removes the first occurrence of a specific Statement from the StatementCollection.
RemoveAt | Removes the element at the specified index of the StatementCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Constructors

StatementCollection Overloaded. Initializes a new instance of the StatementCollection class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StatementCollection Class | DDW.CSharp.Dom Namespace


StatementCollection Constructor

Initializes a new instance of the StatementCollection class that is empty and has the default initial capacity.

Overload List

Initializes a new instance of the StatementCollection class that is empty and has the default initial capacity.

public StatementCollection();

Initializes a new instance of the StatementCollection class that contains elements copied from the specified Statement array.

public StatementCollection(Statement[]);

Initializes a new instance of the StatementCollection class that contains elements copied from the specified StatementCollection.

public StatementCollection(StatementCollection);

protected StatementCollection(Tag);

Initializes a new instance of the StatementCollection class that has the specified initial capacity.

public StatementCollection(int);

See Also

StatementCollection Class | DDW.CSharp.Dom Namespace


StatementCollection Constructor ()

Initializes a new instance of the StatementCollection class that is empty and has the default initial capacity.

public StatementCollection();

See Also

StatementCollection Class | DDW.CSharp.Dom Namespace | StatementCollection Constructor Overload List


StatementCollection Constructor (Int32)

Initializes a new instance of the StatementCollection class that has the specified initial capacity.

public StatementCollection(
int capacity
);

Parameters

capacity
The number of elements that the new StatementCollection is initially capable of storing.

See Also

StatementCollection Class | DDW.CSharp.Dom Namespace | StatementCollection Constructor Overload List


StatementCollection Constructor (StatementCollection)

Initializes a new instance of the StatementCollection class that contains elements copied from the specified StatementCollection.

public StatementCollection(
StatementCollection c
);

Parameters

c
The StatementCollection whose elements are copied to the new collection.

See Also

StatementCollection Class | DDW.CSharp.Dom Namespace | StatementCollection Constructor Overload List


StatementCollection Constructor (Statement[])

Initializes a new instance of the StatementCollection class that contains elements copied from the specified Statement array.

public StatementCollection(
Statement[] a
);

Parameters

a
The Statement array whose elements are copied to the new list.

See Also

StatementCollection Class | DDW.CSharp.Dom Namespace | StatementCollection Constructor Overload List


StatementCollection Constructor (Tag)

protected StatementCollection(
Tag t
);

See Also

StatementCollection Class | DDW.CSharp.Dom Namespace | StatementCollection Constructor Overload List


StatementCollection Properties

The properties of the StatementCollection class are listed below. For a complete list of StatementCollection class members, see the StatementCollection Members topic.

Public Instance Properties

Capacity | Gets or sets the number of elements the StatementCollection can contain.
Count | Gets the number of elements actually contained in the StatementCollection.
GraphType |
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the Statement at the specified index.
LinePragma (inherited from CSharpGraph) |
SyncRoot | Gets an object that can be used to synchronize access to the collection.
Text |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

StatementCollection Class | DDW.CSharp.Dom Namespace


Capacity Property

Goblin - A Platform for 3D AR and VR Applications

StatementCollection.Capacity Property

Gets or sets the number of elements the StatementCollection can contain.

public virtual int Capacity {get; set;}

See Also

StatementCollection Class | DDW.CSharp.Dom Namespace


Count Property

Goblin - A Platform for 3D AR and VR Applications

StatementCollection.Count Property

Gets the number of elements actually contained in the StatementCollection.

public virtual int Count {get;}

Implements

ICollection.Count

See Also

StatementCollection Class | DDW.CSharp.Dom Namespace


GraphType Property

Goblin - A Platform for 3D AR and VR Applications

StatementCollection.GraphType Property

public override GraphTypes GraphType {get;}

Implements

IGraph.GraphType

See Also

StatementCollection Class | DDW.CSharp.Dom Namespace


IsFixedSize Property

Goblin - A Platform for 3D AR and VR Applications

StatementCollection.IsFixedSize Property

Gets a value indicating whether the collection has a fixed size.

public virtual bool IsFixedSize {get;}

Property Value

true if the collection has a fixed size; otherwise, false. The default is false

Implements

IList.IsFixedSize

See Also

StatementCollection Class | DDW.CSharp.Dom Namespace


IsReadOnly Property

Goblin - A Platform for 3D AR and VR Applications

StatementCollection.IsReadOnly Property

gets a value indicating whether the IList is read-only.

public virtual bool IsReadOnly {get;}

Property Value

true if the collection is read-only; otherwise, false. The default is false

Implements

IList.IsReadOnly

See Also

StatementCollection Class | DDW.CSharp.Dom Namespace


IsSynchronized Property

Goblin - A Platform for 3D AR and VR Applications

StatementCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread-safe).

public virtual bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

StatementCollection Class | DDW.CSharp.Dom Namespace


Item Property

Goblin - A Platform for 3D AR and VR Applications

StatementCollection.Item Property

Gets or sets the Statement at the specified index.

public virtual Statement this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

StatementCollection Class | DDW.CSharp.Dom Namespace


SyncRoot Property

Goblin - A Platform for 3D AR and VR Applications

StatementCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

public virtual object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

StatementCollection Class | DDW.CSharp.Dom Namespace


Text Property

Goblin - A Platform for 3D AR and VR Applications

StatementCollection.Text Property

public override string Text {get;}

Implements

IGraph.Text

See Also

StatementCollection Class | DDW.CSharp.Dom Namespace


StatementCollection Methods

The methods of the StatementCollection class are listed below. For a complete list of StatementCollection class members, see the StatementCollection Members topic.

Public Static Methods

ReadOnly | Creates a read-only wrapper for a StatementCollection instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a StatementCollection instance.

Public Instance Methods

Add | Adds a Statement to the end of the StatementCollection.
AddRange | Overloaded. Adds the elements of a Statement array to the current StatementCollection.
Clear | Removes all elements from the StatementCollection.
Clone | Creates a shallow copy of the StatementCollection.
Contains | Determines whether a given Statement is in the StatementCollection.
CopyTo | Overloaded. Copies the entire StatementCollection to a one-dimensional Statement array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the StatementCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the zero-based index of the first occurrence of a Statement in the StatementCollection.
Insert | Inserts an element into the StatementCollection at the specified index.
Remove | Removes the first occurrence of a specific Statement from the StatementCollection.
RemoveAt | Removes the element at the specified index of the StatementCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StatementCollection Class | DDW.CSharp.Dom Namespace


StatementCollection.Add Method

Adds a Statement to the end of the StatementCollection.

public virtual int Add(
Statement item
);

Parameters

item
The Statement to be added to the end of the StatementCollection.

Return Value

The index at which the value has been added.

See Also

StatementCollection Class | DDW.CSharp.Dom Namespace


AddRange Method

Goblin - A Platform for 3D AR and VR Applications

StatementCollection.AddRange Method

Adds the elements of a Statement array to the current StatementCollection.

Overload List

Adds the elements of a Statement array to the current StatementCollection.

public virtual int AddRange(Statement[]);

Adds the elements of another StatementCollection to the current StatementCollection.

public virtual int AddRange(StatementCollection);

See Also

StatementCollection Class | DDW.CSharp.Dom Namespace


StatementCollection.AddRange Method (Statement[])

Adds the elements of a Statement array to the current StatementCollection.

public virtual int AddRange(
Statement[] x
);

Parameters

x
The Statement array whose elements should be added to the end of the StatementCollection.

Return Value

The new Count of the StatementCollection.

See Also

StatementCollection Class | DDW.CSharp.Dom Namespace | StatementCollection.AddRange Overload List


StatementCollection.AddRange Method (StatementCollection)

Adds the elements of another StatementCollection to the current StatementCollection.

public virtual int AddRange(
StatementCollection x
);

Parameters

x
The StatementCollection whose elements should be added to the end of the current StatementCollection.

Return Value

The new Count of the StatementCollection.

See Also

StatementCollection Class | DDW.CSharp.Dom Namespace | StatementCollection.AddRange Overload List


StatementCollection.Clear Method

Removes all elements from the StatementCollection.

public virtual void Clear();

Implements

IList.Clear

See Also

StatementCollection Class | DDW.CSharp.Dom Namespace


StatementCollection.Clone Method

Creates a shallow copy of the StatementCollection.

public virtual object Clone();

Implements

ICloneable.Clone

See Also

StatementCollection Class | DDW.CSharp.Dom Namespace


StatementCollection.Contains Method

Determines whether a given Statement is in the StatementCollection.

public virtual bool Contains(
Statement item
);

Parameters

item
The Statement to check for.

Return Value

true if item is found in the StatementCollection; otherwise, false.

See Also

StatementCollection Class | DDW.CSharp.Dom Namespace


CopyTo Method

Goblin - A Platform for 3D AR and VR Applications

StatementCollection.CopyTo Method

Copies the entire StatementCollection to a one-dimensional Statement array.

Overload List

Copies the entire StatementCollection to a one-dimensional Statement array.

public virtual void CopyTo(Statement[]);

Copies the entire StatementCollection to a one-dimensional Statement array, starting at the specified index of the target array.

public virtual void CopyTo(Statement[],int);

See Also

StatementCollection Class | DDW.CSharp.Dom Namespace


StatementCollection.CopyTo Method (Statement[])

Copies the entire StatementCollection to a one-dimensional Statement array.

public virtual void CopyTo(
Statement[] array
);

Parameters

array
The one-dimensional Statement array to copy to.

See Also

StatementCollection Class | DDW.CSharp.Dom Namespace | StatementCollection.CopyTo Overload List


StatementCollection.CopyTo Method (Statement[], Int32)

Copies the entire StatementCollection to a one-dimensional Statement array, starting at the specified index of the target array.

public virtual void CopyTo(
Statement[] array,
int start
);

Parameters

array
The one-dimensional Statement array to copy to.
start
The zero-based index in array at which copying begins.

See Also

StatementCollection Class | DDW.CSharp.Dom Namespace | StatementCollection.CopyTo Overload List


StatementCollection.GetEnumerator Method

Returns an enumerator that can iterate through the StatementCollection.

public virtual IStatementCollectionEnumerator GetEnumerator();

Return Value

An Enumerator for the entire StatementCollection.

See Also

StatementCollection Class | DDW.CSharp.Dom Namespace


StatementCollection.IndexOf Method

Returns the zero-based index of the first occurrence of a Statement in the StatementCollection.

public virtual int IndexOf(
Statement item
);

Parameters

item
The Statement to locate in the StatementCollection.

Return Value

The zero-based index of the first occurrence of item in the entire StatementCollection, if found; otherwise, -1.

See Also

StatementCollection Class | DDW.CSharp.Dom Namespace


StatementCollection.Insert Method

Inserts an element into the StatementCollection at the specified index.

public virtual void Insert(
int index,
Statement item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The Statement to insert.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

StatementCollection Class | DDW.CSharp.Dom Namespace


StatementCollection.ReadOnly Method

Creates a read-only wrapper for a StatementCollection instance.

public static StatementCollection ReadOnly(
StatementCollection list
);

Return Value

An StatementCollection wrapper that is read-only.

See Also

StatementCollection Class | DDW.CSharp.Dom Namespace


StatementCollection.Remove Method

Removes the first occurrence of a specific Statement from the StatementCollection.

public virtual void Remove(
Statement item
);

Parameters

item
The Statement to remove from the StatementCollection.

Exceptions

Exception Type | Condition
ArgumentException | The specified Statement was not found in the StatementCollection.

See Also

StatementCollection Class | DDW.CSharp.Dom Namespace


StatementCollection.RemoveAt Method

Removes the element at the specified index of the StatementCollection.

public virtual void RemoveAt(
int index
);

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

StatementCollection Class | DDW.CSharp.Dom Namespace


StatementCollection.Synchronized Method

Creates a synchronized (thread-safe) wrapper for a StatementCollection instance.

public static StatementCollection Synchronized(
StatementCollection list
);

Return Value

An StatementCollection wrapper that is synchronized (thread-safe).

See Also

StatementCollection Class | DDW.CSharp.Dom Namespace


StatementCollection.TrimToSize Method

Sets the capacity to the actual number of elements.

public virtual void TrimToSize();

See Also

StatementCollection Class | DDW.CSharp.Dom Namespace


StatementCollection.IStatementCollectionEnumerator Interface

Supports type-safe iteration over a StatementCollection.

For a list of all members of this type, see StatementCollection.IStatementCollectionEnumerator Members.

public interface StatementCollection.IStatementCollectionEnumerator

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

StatementCollection.IStatementCollectionEnumerator Members | DDW.CSharp.Dom Namespace


StatementCollection.IStatementCollectionEnumerator Members

StatementCollection.IStatementCollectionEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

StatementCollection.IStatementCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


StatementCollection.IStatementCollectionEnumerator Properties

The properties of the StatementCollection.IStatementCollectionEnumerator interface are listed below. For a complete list of StatementCollection.IStatementCollectionEnumerator interface members, see the StatementCollection.IStatementCollectionEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

StatementCollection.IStatementCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


Current Property

Goblin - A Platform for 3D AR and VR Applications

StatementCollection.IStatementCollectionEnumerator.Current Property

Gets the current element in the collection.

Statement Current {get;}

See Also

StatementCollection.IStatementCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


StatementCollection.IStatementCollectionEnumerator Methods

The methods of the StatementCollection.IStatementCollectionEnumerator interface are listed below. For a complete list of StatementCollection.IStatementCollectionEnumerator interface members, see the StatementCollection.IStatementCollectionEnumerator Members topic.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

StatementCollection.IStatementCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


StatementCollection.IStatementCollectionEnumerator.MoveNext Method

Advances the enumerator to the next element in the collection.

bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Exceptions

Exception Type | Condition
InvalidOperationException | The collection was modified after the enumerator was created.

See Also

StatementCollection.IStatementCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


StatementCollection.IStatementCollectionEnumerator.Reset Method

Sets the enumerator to its initial position, before the first element in the collection.

void Reset();

See Also

StatementCollection.IStatementCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


StatementCollection.Tag Enumeration

protected enum StatementCollection.Tag

Members

Member Name | Description
Default |

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

DDW.CSharp.Dom Namespace


StringLiteral Class

A string literal.

For a list of all members of this type, see StringLiteral Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Expression
DDW.CSharp.Dom.PrimitiveExpr
DDW.CSharp.Dom.StringLiteral

public class StringLiteral : PrimitiveExpr

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

StringLiteral Members | DDW.CSharp.Dom Namespace


StringLiteral Members

StringLiteral overview

Public Instance Constructors

StringLiteral Constructor Initializes a new instance of the StringLiteral class.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.
Value | Gets or sets the string value of this string literal.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StringLiteral Class | DDW.CSharp.Dom Namespace


StringLiteral Constructor

Initializes a new instance of the StringLiteral class.

public StringLiteral();

See Also

StringLiteral Class | DDW.CSharp.Dom Namespace


StringLiteral Properties

The properties of the StringLiteral class are listed below. For a complete list of StringLiteral class members, see the StringLiteral Members topic.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.
Value | Gets or sets the string value of this string literal.

See Also

StringLiteral Class | DDW.CSharp.Dom Namespace


Value Property

Goblin - A Platform for 3D AR and VR Applications

StringLiteral.Value Property

Gets or sets the string value of this string literal.

public string Value {get; set;}

See Also

StringLiteral Class | DDW.CSharp.Dom Namespace


StructDecl Class

A struct declartation.

For a list of all members of this type, see StructDecl Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.MemberDecl
DDW.CSharp.Dom.TypeDecl
DDW.CSharp.Dom.StructDecl

public class StructDecl : TypeDecl, IScope

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

StructDecl Members | DDW.CSharp.Dom Namespace


StructDecl Members

StructDecl overview

Public Instance Constructors

StructDecl Constructor Initializes a new instance of the StructDecl class.

Public Instance Properties

Attributes (inherited from MemberDecl) | Gets or sets the modifier flags for this member (public, private etc).
BaseTypes (inherited from TypeDecl) | Gets or sets the base types that are inherited by this type.
Comments (inherited from MemberDecl) | Gets the collection of comments for this member.
Constructors |
CustomAttributes (inherited from MemberDecl) | Gets the collection of Custom Attributes used for this member (custom attributes are the ones declared between brackets, like [Flags]).
Definition (inherited from TypeDecl) | Gets the (scoped) definition.
LinePragma (inherited from CSharpGraph) |
MemberKind (inherited from TypeDecl) |
Members (inherited from TypeDecl) | Gets a collection of type members in the current type (methods, fields etc.).
Name (inherited from TypeDecl) |
Scope |
TypeAttributes (inherited from TypeDecl) | Gets or sets the modifiers for the type (public, sealed etc). These values can be or'ed with each other. This was derived from the CodeDom, it may be changed for something more suitable.
TypeKind |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

DistanceToType |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
VerifyModifiers (inherited from MemberDecl) |

See Also

StructDecl Class | DDW.CSharp.Dom Namespace


StructDecl Constructor

Initializes a new instance of the StructDecl class.

public StructDecl();

See Also

StructDecl Class | DDW.CSharp.Dom Namespace


StructDecl Properties

The properties of the StructDecl class are listed below. For a complete list of StructDecl class members, see the StructDecl Members topic.

Public Instance Properties

Attributes (inherited from MemberDecl) | Gets or sets the modifier flags for this member (public, private etc).
BaseTypes (inherited from TypeDecl) | Gets or sets the base types that are inherited by this type.
Comments (inherited from MemberDecl) | Gets the collection of comments for this member.
Constructors |
CustomAttributes (inherited from MemberDecl) | Gets the collection of Custom Attributes used for this member (custom attributes are the ones declared between brackets, like [Flags]).
Definition (inherited from TypeDecl) | Gets the (scoped) definition.
LinePragma (inherited from CSharpGraph) |
MemberKind (inherited from TypeDecl) |
Members (inherited from TypeDecl) | Gets a collection of type members in the current type (methods, fields etc.).
Name (inherited from TypeDecl) |
Scope |
TypeAttributes (inherited from TypeDecl) | Gets or sets the modifiers for the type (public, sealed etc). These values can be or'ed with each other. This was derived from the CodeDom, it may be changed for something more suitable.
TypeKind |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

StructDecl Class | DDW.CSharp.Dom Namespace


Constructors Property

Goblin - A Platform for 3D AR and VR Applications

StructDecl.Constructors Property

public DDW.CSharp.SymbolTable.OverloadableDefinition Constructors {get;}

See Also

StructDecl Class | DDW.CSharp.Dom Namespace


Scope Property

Goblin - A Platform for 3D AR and VR Applications

StructDecl.Scope Property

public DDW.CSharp.SymbolTable.Scope Scope {get; set;}

Implements

IScope.Scope

See Also

StructDecl Class | DDW.CSharp.Dom Namespace


TypeKind Property

Goblin - A Platform for 3D AR and VR Applications

StructDecl.TypeKind Property

public override TypeKind TypeKind {get;}

See Also

StructDecl Class | DDW.CSharp.Dom Namespace


StructDecl Methods

The methods of the StructDecl class are listed below. For a complete list of StructDecl class members, see the StructDecl Members topic.

Public Instance Methods

DistanceToType |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
VerifyModifiers (inherited from MemberDecl) |

See Also

StructDecl Class | DDW.CSharp.Dom Namespace


StructDecl.DistanceToType Method

public override int DistanceToType(
IDefinition baseType,
int distance
);

See Also

StructDecl Class | DDW.CSharp.Dom Namespace


SubExpr Class

A sub (parenthesized) expression. This overrides regular operator precedence eg: (2+4)*6.

For a list of all members of this type, see SubExpr Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Expression
DDW.CSharp.Dom.SubExpr

public class SubExpr : Expression

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

SubExpr Members | DDW.CSharp.Dom Namespace


SubExpr Members

SubExpr overview

Public Instance Constructors

SubExpr Constructor Initializes a new instance of the SubExpr class.

Public Instance Properties

Expression | The expression to be grouped.
LinePragma (inherited from CSharpGraph) |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SubExpr Class | DDW.CSharp.Dom Namespace


SubExpr Constructor

Initializes a new instance of the SubExpr class.

public SubExpr();

See Also

SubExpr Class | DDW.CSharp.Dom Namespace


SubExpr Properties

The properties of the SubExpr class are listed below. For a complete list of SubExpr class members, see the SubExpr Members topic.

Public Instance Properties

Expression | The expression to be grouped.
LinePragma (inherited from CSharpGraph) |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

SubExpr Class | DDW.CSharp.Dom Namespace


Expression Property

Goblin - A Platform for 3D AR and VR Applications

SubExpr.Expression Property

The expression to be grouped.

public Expression Expression {get; set;}

See Also

SubExpr Class | DDW.CSharp.Dom Namespace | SubExpr.Expression Overload List


SwitchStmt Class

A switch statement.

For a list of all members of this type, see SwitchStmt Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Statement
DDW.CSharp.Dom.SwitchStmt

public class SwitchStmt : Statement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

SwitchStmt Members | DDW.CSharp.Dom Namespace


SwitchStmt Members

SwitchStmt overview

Public Instance Constructors

SwitchStmt Constructor Initializes a new instance of the SwitchStmt class.

Public Instance Properties

Cases | Gets a collection of cases that will be called based on the condition.
Condition | Gets or sets the switch condition to be tested.
LinePragma (inherited from CSharpGraph) |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SwitchStmt Class | DDW.CSharp.Dom Namespace


SwitchStmt Constructor

Initializes a new instance of the SwitchStmt class.

public SwitchStmt();

See Also

SwitchStmt Class | DDW.CSharp.Dom Namespace


SwitchStmt Properties

The properties of the SwitchStmt class are listed below. For a complete list of SwitchStmt class members, see the SwitchStmt Members topic.

Public Instance Properties

Cases | Gets a collection of cases that will be called based on the condition.
Condition | Gets or sets the switch condition to be tested.
LinePragma (inherited from CSharpGraph) |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

SwitchStmt Class | DDW.CSharp.Dom Namespace


Cases Property

Goblin - A Platform for 3D AR and VR Applications

SwitchStmt.Cases Property

Gets a collection of cases that will be called based on the condition.

public CaseCollection Cases {get;}

See Also

SwitchStmt Class | DDW.CSharp.Dom Namespace


Condition Property

Goblin - A Platform for 3D AR and VR Applications

SwitchStmt.Condition Property

Gets or sets the switch condition to be tested.

public Expression Condition {get; set;}

See Also

SwitchStmt Class | DDW.CSharp.Dom Namespace


TernaryExpr Class

A ternary (conditional) expression (bool ? expr : expr).

For a list of all members of this type, see TernaryExpr Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Expression
DDW.CSharp.Dom.TernaryExpr

public class TernaryExpr : Expression

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

TernaryExpr Members | DDW.CSharp.Dom Namespace


TernaryExpr Members

TernaryExpr overview

Public Instance Constructors

TernaryExpr Constructor Initializes a new instance of the TernaryExpr class.

Public Instance Properties

False | Gets or sets the expression assign if the test resolves to 'false'.
LinePragma (inherited from CSharpGraph) |
Test | Gets or sets the expression to test.
True | Gets or sets the expression assign if the test resolves to 'true'.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TernaryExpr Class | DDW.CSharp.Dom Namespace


TernaryExpr Constructor

Initializes a new instance of the TernaryExpr class.

public TernaryExpr();

See Also

TernaryExpr Class | DDW.CSharp.Dom Namespace


TernaryExpr Properties

The properties of the TernaryExpr class are listed below. For a complete list of TernaryExpr class members, see the TernaryExpr Members topic.

Public Instance Properties

False | Gets or sets the expression assign if the test resolves to 'false'.
LinePragma (inherited from CSharpGraph) |
Test | Gets or sets the expression to test.
True | Gets or sets the expression assign if the test resolves to 'true'.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

TernaryExpr Class | DDW.CSharp.Dom Namespace


False Property

Goblin - A Platform for 3D AR and VR Applications

TernaryExpr.False Property

Gets or sets the expression assign if the test resolves to 'false'.

public Expression False {get; set;}

See Also

TernaryExpr Class | DDW.CSharp.Dom Namespace


Test Property

Goblin - A Platform for 3D AR and VR Applications

TernaryExpr.Test Property

Gets or sets the expression to test.

public Expression Test {get; set;}

See Also

TernaryExpr Class | DDW.CSharp.Dom Namespace


True Property

Goblin - A Platform for 3D AR and VR Applications

TernaryExpr.True Property

Gets or sets the expression assign if the test resolves to 'true'.

public Expression True {get; set;}

See Also

TernaryExpr Class | DDW.CSharp.Dom Namespace


ThisRef Class

A 'this' reference.

For a list of all members of this type, see ThisRef Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Expression
DDW.CSharp.Dom.Reference
DDW.CSharp.Dom.ThisRef

public class ThisRef : Reference

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

ThisRef Members | DDW.CSharp.Dom Namespace


ThisRef Members

ThisRef overview

Public Instance Constructors

ThisRef Constructor Initializes a new instance of the ThisRef class.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ThisRef Class | DDW.CSharp.Dom Namespace


ThisRef Constructor

Initializes a new instance of the ThisRef class.

public ThisRef();

See Also

ThisRef Class | DDW.CSharp.Dom Namespace


ThrowStmt Class

A throw statement.

For a list of all members of this type, see ThrowStmt Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Statement
DDW.CSharp.Dom.ThrowStmt

public class ThrowStmt : Statement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

ThrowStmt Members | DDW.CSharp.Dom Namespace


ThrowStmt Members

ThrowStmt overview

Public Instance Constructors

ThrowStmt Constructor Initializes a new instance of the ThrowStmt class.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
ToThrow | Gets or sets the exception that is thrown.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ThrowStmt Class | DDW.CSharp.Dom Namespace


ThrowStmt Constructor

Initializes a new instance of the ThrowStmt class.

public ThrowStmt();

See Also

ThrowStmt Class | DDW.CSharp.Dom Namespace


ThrowStmt Properties

The properties of the ThrowStmt class are listed below. For a complete list of ThrowStmt class members, see the ThrowStmt Members topic.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
ToThrow | Gets or sets the exception that is thrown.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

ThrowStmt Class | DDW.CSharp.Dom Namespace


ToThrow Property

Goblin - A Platform for 3D AR and VR Applications

ThrowStmt.ToThrow Property

Gets or sets the exception that is thrown.

public Expression ToThrow {get; set;}

See Also

ThrowStmt Class | DDW.CSharp.Dom Namespace


TryCatchFinallyStmt Class

A try, catch, finally construct.

For a list of all members of this type, see TryCatchFinallyStmt Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Statement
DDW.CSharp.Dom.TryCatchFinallyStmt

public class TryCatchFinallyStmt : Statement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

TryCatchFinallyStmt Members | DDW.CSharp.Dom Namespace


TryCatchFinallyStmt Members

TryCatchFinallyStmt overview

Public Instance Constructors

TryCatchFinallyStmt Constructor Initializes a new instance of the TryCatchFinallyStmt class.

Public Instance Properties

CatchClauses | Gets a collection of Catch clauses that will try to catch any exceptions thrown.
Finally | Gets a collection of statements that will always be executed (ermm, well, pretty well always).
LinePragma (inherited from CSharpGraph) |
Try | Gets a collection of statements to 'try'.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TryCatchFinallyStmt Class | DDW.CSharp.Dom Namespace


TryCatchFinallyStmt Constructor

Initializes a new instance of the TryCatchFinallyStmt class.

public TryCatchFinallyStmt();

See Also

TryCatchFinallyStmt Class | DDW.CSharp.Dom Namespace


TryCatchFinallyStmt Properties

The properties of the TryCatchFinallyStmt class are listed below. For a complete list of TryCatchFinallyStmt class members, see the TryCatchFinallyStmt Members topic.

Public Instance Properties

CatchClauses | Gets a collection of Catch clauses that will try to catch any exceptions thrown.
Finally | Gets a collection of statements that will always be executed (ermm, well, pretty well always).
LinePragma (inherited from CSharpGraph) |
Try | Gets a collection of statements to 'try'.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

TryCatchFinallyStmt Class | DDW.CSharp.Dom Namespace


CatchClauses Property

Goblin - A Platform for 3D AR and VR Applications

TryCatchFinallyStmt.CatchClauses Property

Gets a collection of Catch clauses that will try to catch any exceptions thrown.

public CatchCollection CatchClauses {get; set;}

See Also

TryCatchFinallyStmt Class | DDW.CSharp.Dom Namespace


Finally Property

Goblin - A Platform for 3D AR and VR Applications

TryCatchFinallyStmt.Finally Property

Gets a collection of statements that will always be executed (ermm, well, pretty well always).

public StatementCollection Finally {get;}

See Also

TryCatchFinallyStmt Class | DDW.CSharp.Dom Namespace


Try Property

Goblin - A Platform for 3D AR and VR Applications

TryCatchFinallyStmt.Try Property

Gets a collection of statements to 'try'.

public StatementCollection Try {get;}

See Also

TryCatchFinallyStmt Class | DDW.CSharp.Dom Namespace


TypeDecl Class

An abstract base class for types (classes, structs, interfaces etc).

For a list of all members of this type, see TypeDecl Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.MemberDecl
DDW.CSharp.Dom.TypeDecl
DDW.CSharp.Dom.ClassDecl
DDW.CSharp.Dom.DelegateDecl
DDW.CSharp.Dom.EnumDecl
DDW.CSharp.Dom.InterfaceDecl
DDW.CSharp.Dom.StructDecl

public abstract class TypeDecl : MemberDecl, IDeclaration

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

TypeDecl Members | DDW.CSharp.Dom Namespace


TypeDecl Members

TypeDecl overview

Public Instance Properties

Attributes (inherited from MemberDecl) | Gets or sets the modifier flags for this member (public, private etc).
BaseTypes | Gets or sets the base types that are inherited by this type.
Comments (inherited from MemberDecl) | Gets the collection of comments for this member.
CustomAttributes (inherited from MemberDecl) | Gets the collection of Custom Attributes used for this member (custom attributes are the ones declared between brackets, like [Flags]).
Definition | Gets the (scoped) definition.
GraphType (inherited from CSharpGraph) |
LinePragma (inherited from CSharpGraph) |
MemberKind |
Members | Gets a collection of type members in the current type (methods, fields etc.).
Name |
TypeAttributes | Gets or sets the modifiers for the type (public, sealed etc). These values can be or'ed with each other. This was derived from the CodeDom, it may be changed for something more suitable.
TypeKind |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

DistanceToType | Determines if this type is a subtype of the passed type.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

TypeDecl Constructor Initializes a new instance of the TypeDecl class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
VerifyModifiers (inherited from MemberDecl) |

See Also

TypeDecl Class | DDW.CSharp.Dom Namespace


TypeDecl Constructor

Initializes a new instance of the TypeDecl class.

protected TypeDecl();

See Also

TypeDecl Class | DDW.CSharp.Dom Namespace


TypeDecl Properties

The properties of the TypeDecl class are listed below. For a complete list of TypeDecl class members, see the TypeDecl Members topic.

Public Instance Properties

Attributes (inherited from MemberDecl) | Gets or sets the modifier flags for this member (public, private etc).
BaseTypes | Gets or sets the base types that are inherited by this type.
Comments (inherited from MemberDecl) | Gets the collection of comments for this member.
CustomAttributes (inherited from MemberDecl) | Gets the collection of Custom Attributes used for this member (custom attributes are the ones declared between brackets, like [Flags]).
Definition | Gets the (scoped) definition.
GraphType (inherited from CSharpGraph) |
LinePragma (inherited from CSharpGraph) |
MemberKind |
Members | Gets a collection of type members in the current type (methods, fields etc.).
Name |
TypeAttributes | Gets or sets the modifiers for the type (public, sealed etc). These values can be or'ed with each other. This was derived from the CodeDom, it may be changed for something more suitable.
TypeKind |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

TypeDecl Class | DDW.CSharp.Dom Namespace


BaseTypes Property

Goblin - A Platform for 3D AR and VR Applications

TypeDecl.BaseTypes Property

Gets or sets the base types that are inherited by this type.

public TypeRefCollection BaseTypes {get; set;}

See Also

TypeDecl Class | DDW.CSharp.Dom Namespace


Definition Property

Goblin - A Platform for 3D AR and VR Applications

TypeDecl.Definition Property

Gets the (scoped) definition.

public DDW.CSharp.SymbolTable.IDefinition Definition {get;}

Implements

IDeclaration.Definition

See Also

TypeDecl Class | DDW.CSharp.Dom Namespace


MemberKind Property

Goblin - A Platform for 3D AR and VR Applications

TypeDecl.MemberKind Property

public override MemberKind MemberKind {get;}

See Also

TypeDecl Class | DDW.CSharp.Dom Namespace


Members Property

Goblin - A Platform for 3D AR and VR Applications

TypeDecl.Members Property

Gets a collection of type members in the current type (methods, fields etc.).

public MemberDeclCollection Members {get;}

See Also

TypeDecl Class | DDW.CSharp.Dom Namespace


Name Property

Goblin - A Platform for 3D AR and VR Applications

TypeDecl.Name Property

public string Name {get; set;}

See Also

TypeDecl Class | DDW.CSharp.Dom Namespace


TypeAttributes Property

Goblin - A Platform for 3D AR and VR Applications

TypeDecl.TypeAttributes Property

Gets or sets the modifiers for the type (public, sealed etc). These values can be or'ed with each other. This was derived from the CodeDom, it may be changed for something more suitable.

public TypeModifiers TypeAttributes {get; set;}

See Also

TypeDecl Class | DDW.CSharp.Dom Namespace


TypeKind Property

Goblin - A Platform for 3D AR and VR Applications

TypeDecl.TypeKind Property

public abstract TypeKind TypeKind {get;}

See Also

TypeDecl Class | DDW.CSharp.Dom Namespace


TypeDecl Methods

The methods of the TypeDecl class are listed below. For a complete list of TypeDecl class members, see the TypeDecl Members topic.

Public Instance Methods

DistanceToType | Determines if this type is a subtype of the passed type.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
VerifyModifiers (inherited from MemberDecl) |

See Also

TypeDecl Class | DDW.CSharp.Dom Namespace


TypeDecl.DistanceToType Method

Determines if this type is a subtype of the passed type.

public abstract int DistanceToType(
IDefinition baseType,
int distance
);

Parameters

baseType
Base type to check.
distance

Return Value

True if this is a subtype.

See Also

TypeDecl Class | DDW.CSharp.Dom Namespace


TypeDeclCollection Class

A strongly-typed collection of TypeDecl objects.

For a list of all members of this type, see TypeDeclCollection Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.TypeDeclCollection

public class TypeDeclCollection : CSharpGraph, IList, ICollection, IEnumerable, ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

TypeDeclCollection Members | DDW.CSharp.Dom Namespace


TypeDeclCollection Members

TypeDeclCollection overview

Public Static Methods

ReadOnly | Creates a read-only wrapper for a TypeDeclCollection instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a TypeDeclCollection instance.

Public Instance Constructors

TypeDeclCollection Overloaded. Initializes a new instance of the TypeDeclCollection class.

Public Instance Properties

Capacity | Gets or sets the number of elements the TypeDeclCollection can contain.
Count | Gets the number of elements actually contained in the TypeDeclCollection.
GraphType |
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the TypeDecl at the specified index.
LinePragma (inherited from CSharpGraph) |
SyncRoot | Gets an object that can be used to synchronize access to the collection.
Text |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Add | Adds a TypeDecl to the end of the TypeDeclCollection.
AddRange | Overloaded. Adds the elements of a TypeDecl array to the current TypeDeclCollection.
Clear | Removes all elements from the TypeDeclCollection.
Clone | Creates a shallow copy of the TypeDeclCollection.
Contains | Determines whether a given TypeDecl is in the TypeDeclCollection.
CopyTo | Overloaded. Copies the entire TypeDeclCollection to a one-dimensional TypeDecl array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the TypeDeclCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the zero-based index of the first occurrence of a TypeDecl in the TypeDeclCollection.
Insert | Inserts an element into the TypeDeclCollection at the specified index.
Remove | Removes the first occurrence of a specific TypeDecl from the TypeDeclCollection.
RemoveAt | Removes the element at the specified index of the TypeDeclCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Constructors

TypeDeclCollection Overloaded. Initializes a new instance of the TypeDeclCollection class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TypeDeclCollection Class | DDW.CSharp.Dom Namespace


TypeDeclCollection Constructor

Initializes a new instance of the TypeDeclCollection class that is empty and has the default initial capacity.

Overload List

Initializes a new instance of the TypeDeclCollection class that is empty and has the default initial capacity.

public TypeDeclCollection();

Initializes a new instance of the TypeDeclCollection class that contains elements copied from the specified TypeDecl array.

public TypeDeclCollection(TypeDecl[]);

Initializes a new instance of the TypeDeclCollection class that contains elements copied from the specified TypeDeclCollection.

public TypeDeclCollection(TypeDeclCollection);

protected TypeDeclCollection(Tag);

Initializes a new instance of the TypeDeclCollection class that has the specified initial capacity.

public TypeDeclCollection(int);

See Also

TypeDeclCollection Class | DDW.CSharp.Dom Namespace


TypeDeclCollection Constructor ()

Initializes a new instance of the TypeDeclCollection class that is empty and has the default initial capacity.

public TypeDeclCollection();

See Also

TypeDeclCollection Class | DDW.CSharp.Dom Namespace | TypeDeclCollection Constructor Overload List


TypeDeclCollection Constructor (Int32)

Initializes a new instance of the TypeDeclCollection class that has the specified initial capacity.

public TypeDeclCollection(
int capacity
);

Parameters

capacity
The number of elements that the new TypeDeclCollection is initially capable of storing.

See Also

TypeDeclCollection Class | DDW.CSharp.Dom Namespace | TypeDeclCollection Constructor Overload List


TypeDeclCollection Constructor (TypeDeclCollection)

Initializes a new instance of the TypeDeclCollection class that contains elements copied from the specified TypeDeclCollection.

public TypeDeclCollection(
TypeDeclCollection c
);

Parameters

c
The TypeDeclCollection whose elements are copied to the new collection.

See Also

TypeDeclCollection Class | DDW.CSharp.Dom Namespace | TypeDeclCollection Constructor Overload List


TypeDeclCollection Constructor (TypeDecl[])

Initializes a new instance of the TypeDeclCollection class that contains elements copied from the specified TypeDecl array.

public TypeDeclCollection(
TypeDecl[] a
);

Parameters

a
The TypeDecl array whose elements are copied to the new list.

See Also

TypeDeclCollection Class | DDW.CSharp.Dom Namespace | TypeDeclCollection Constructor Overload List


TypeDeclCollection Constructor (Tag)

protected TypeDeclCollection(
Tag t
);

See Also

TypeDeclCollection Class | DDW.CSharp.Dom Namespace | TypeDeclCollection Constructor Overload List


TypeDeclCollection Properties

The properties of the TypeDeclCollection class are listed below. For a complete list of TypeDeclCollection class members, see the TypeDeclCollection Members topic.

Public Instance Properties

Capacity | Gets or sets the number of elements the TypeDeclCollection can contain.
Count | Gets the number of elements actually contained in the TypeDeclCollection.
GraphType |
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the TypeDecl at the specified index.
LinePragma (inherited from CSharpGraph) |
SyncRoot | Gets an object that can be used to synchronize access to the collection.
Text |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

TypeDeclCollection Class | DDW.CSharp.Dom Namespace


Capacity Property

Goblin - A Platform for 3D AR and VR Applications

TypeDeclCollection.Capacity Property

Gets or sets the number of elements the TypeDeclCollection can contain.

public virtual int Capacity {get; set;}

See Also

TypeDeclCollection Class | DDW.CSharp.Dom Namespace


Count Property

Goblin - A Platform for 3D AR and VR Applications

TypeDeclCollection.Count Property

Gets the number of elements actually contained in the TypeDeclCollection.

public virtual int Count {get;}

Implements

ICollection.Count

See Also

TypeDeclCollection Class | DDW.CSharp.Dom Namespace


GraphType Property

Goblin - A Platform for 3D AR and VR Applications

TypeDeclCollection.GraphType Property

public override GraphTypes GraphType {get;}

Implements

IGraph.GraphType

See Also

TypeDeclCollection Class | DDW.CSharp.Dom Namespace


IsFixedSize Property

Goblin - A Platform for 3D AR and VR Applications

TypeDeclCollection.IsFixedSize Property

Gets a value indicating whether the collection has a fixed size.

public virtual bool IsFixedSize {get;}

Property Value

true if the collection has a fixed size; otherwise, false. The default is false

Implements

IList.IsFixedSize

See Also

TypeDeclCollection Class | DDW.CSharp.Dom Namespace


IsReadOnly Property

Goblin - A Platform for 3D AR and VR Applications

TypeDeclCollection.IsReadOnly Property

gets a value indicating whether the IList is read-only.

public virtual bool IsReadOnly {get;}

Property Value

true if the collection is read-only; otherwise, false. The default is false

Implements

IList.IsReadOnly

See Also

TypeDeclCollection Class | DDW.CSharp.Dom Namespace


IsSynchronized Property

Goblin - A Platform for 3D AR and VR Applications

TypeDeclCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread-safe).

public virtual bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

TypeDeclCollection Class | DDW.CSharp.Dom Namespace


Item Property

Goblin - A Platform for 3D AR and VR Applications

TypeDeclCollection.Item Property

Gets or sets the TypeDecl at the specified index.

public virtual TypeDecl this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

TypeDeclCollection Class | DDW.CSharp.Dom Namespace


SyncRoot Property

Goblin - A Platform for 3D AR and VR Applications

TypeDeclCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

public virtual object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

TypeDeclCollection Class | DDW.CSharp.Dom Namespace


Text Property

Goblin - A Platform for 3D AR and VR Applications

TypeDeclCollection.Text Property

public override string Text {get;}

Implements

IGraph.Text

See Also

TypeDeclCollection Class | DDW.CSharp.Dom Namespace


TypeDeclCollection Methods

The methods of the TypeDeclCollection class are listed below. For a complete list of TypeDeclCollection class members, see the TypeDeclCollection Members topic.

Public Static Methods

ReadOnly | Creates a read-only wrapper for a TypeDeclCollection instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a TypeDeclCollection instance.

Public Instance Methods

Add | Adds a TypeDecl to the end of the TypeDeclCollection.
AddRange | Overloaded. Adds the elements of a TypeDecl array to the current TypeDeclCollection.
Clear | Removes all elements from the TypeDeclCollection.
Clone | Creates a shallow copy of the TypeDeclCollection.
Contains | Determines whether a given TypeDecl is in the TypeDeclCollection.
CopyTo | Overloaded. Copies the entire TypeDeclCollection to a one-dimensional TypeDecl array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the TypeDeclCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the zero-based index of the first occurrence of a TypeDecl in the TypeDeclCollection.
Insert | Inserts an element into the TypeDeclCollection at the specified index.
Remove | Removes the first occurrence of a specific TypeDecl from the TypeDeclCollection.
RemoveAt | Removes the element at the specified index of the TypeDeclCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TypeDeclCollection Class | DDW.CSharp.Dom Namespace


TypeDeclCollection.Add Method

Adds a TypeDecl to the end of the TypeDeclCollection.

public virtual int Add(
TypeDecl item
);

Parameters

item
The TypeDecl to be added to the end of the TypeDeclCollection.

Return Value

The index at which the value has been added.

See Also

TypeDeclCollection Class | DDW.CSharp.Dom Namespace


AddRange Method

Goblin - A Platform for 3D AR and VR Applications

TypeDeclCollection.AddRange Method

Adds the elements of a TypeDecl array to the current TypeDeclCollection.

Overload List

Adds the elements of a TypeDecl array to the current TypeDeclCollection.

public virtual int AddRange(TypeDecl[]);

Adds the elements of another TypeDeclCollection to the current TypeDeclCollection.

public virtual int AddRange(TypeDeclCollection);

See Also

TypeDeclCollection Class | DDW.CSharp.Dom Namespace


TypeDeclCollection.AddRange Method (TypeDecl[])

Adds the elements of a TypeDecl array to the current TypeDeclCollection.

public virtual int AddRange(
TypeDecl[] x
);

Parameters

x
The TypeDecl array whose elements should be added to the end of the TypeDeclCollection.

Return Value

The new Count of the TypeDeclCollection.

See Also

TypeDeclCollection Class | DDW.CSharp.Dom Namespace | TypeDeclCollection.AddRange Overload List


TypeDeclCollection.AddRange Method (TypeDeclCollection)

Adds the elements of another TypeDeclCollection to the current TypeDeclCollection.

public virtual int AddRange(
TypeDeclCollection x
);

Parameters

x
The TypeDeclCollection whose elements should be added to the end of the current TypeDeclCollection.

Return Value

The new Count of the TypeDeclCollection.

See Also

TypeDeclCollection Class | DDW.CSharp.Dom Namespace | TypeDeclCollection.AddRange Overload List


TypeDeclCollection.Clear Method

Removes all elements from the TypeDeclCollection.

public virtual void Clear();

Implements

IList.Clear

See Also

TypeDeclCollection Class | DDW.CSharp.Dom Namespace


TypeDeclCollection.Clone Method

Creates a shallow copy of the TypeDeclCollection.

public virtual object Clone();

Implements

ICloneable.Clone

See Also

TypeDeclCollection Class | DDW.CSharp.Dom Namespace


TypeDeclCollection.Contains Method

Determines whether a given TypeDecl is in the TypeDeclCollection.

public virtual bool Contains(
TypeDecl item
);

Parameters

item
The TypeDecl to check for.

Return Value

true if item is found in the TypeDeclCollection; otherwise, false.

See Also

TypeDeclCollection Class | DDW.CSharp.Dom Namespace


CopyTo Method

Goblin - A Platform for 3D AR and VR Applications

TypeDeclCollection.CopyTo Method

Copies the entire TypeDeclCollection to a one-dimensional TypeDecl array.

Overload List

Copies the entire TypeDeclCollection to a one-dimensional TypeDecl array.

public virtual void CopyTo(TypeDecl[]);

Copies the entire TypeDeclCollection to a one-dimensional TypeDecl array, starting at the specified index of the target array.

public virtual void CopyTo(TypeDecl[],int);

See Also

TypeDeclCollection Class | DDW.CSharp.Dom Namespace


TypeDeclCollection.CopyTo Method (TypeDecl[])

Copies the entire TypeDeclCollection to a one-dimensional TypeDecl array.

public virtual void CopyTo(
TypeDecl[] array
);

Parameters

array
The one-dimensional TypeDecl array to copy to.

See Also

TypeDeclCollection Class | DDW.CSharp.Dom Namespace | TypeDeclCollection.CopyTo Overload List


TypeDeclCollection.CopyTo Method (TypeDecl[], Int32)

Copies the entire TypeDeclCollection to a one-dimensional TypeDecl array, starting at the specified index of the target array.

public virtual void CopyTo(
TypeDecl[] array,
int start
);

Parameters

array
The one-dimensional TypeDecl array to copy to.
start
The zero-based index in array at which copying begins.

See Also

TypeDeclCollection Class | DDW.CSharp.Dom Namespace | TypeDeclCollection.CopyTo Overload List


TypeDeclCollection.GetEnumerator Method

Returns an enumerator that can iterate through the TypeDeclCollection.

public virtual ITypeDeclCollectionEnumerator GetEnumerator();

Return Value

An Enumerator for the entire TypeDeclCollection.

See Also

TypeDeclCollection Class | DDW.CSharp.Dom Namespace


TypeDeclCollection.IndexOf Method

Returns the zero-based index of the first occurrence of a TypeDecl in the TypeDeclCollection.

public virtual int IndexOf(
TypeDecl item
);

Parameters

item
The TypeDecl to locate in the TypeDeclCollection.

Return Value

The zero-based index of the first occurrence of item in the entire TypeDeclCollection, if found; otherwise, -1.

See Also

TypeDeclCollection Class | DDW.CSharp.Dom Namespace


TypeDeclCollection.Insert Method

Inserts an element into the TypeDeclCollection at the specified index.

public virtual void Insert(
int index,
TypeDecl item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The TypeDecl to insert.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

TypeDeclCollection Class | DDW.CSharp.Dom Namespace


TypeDeclCollection.ReadOnly Method

Creates a read-only wrapper for a TypeDeclCollection instance.

public static TypeDeclCollection ReadOnly(
TypeDeclCollection list
);

Return Value

An TypeDeclCollection wrapper that is read-only.

See Also

TypeDeclCollection Class | DDW.CSharp.Dom Namespace


TypeDeclCollection.Remove Method

Removes the first occurrence of a specific TypeDecl from the TypeDeclCollection.

public virtual void Remove(
TypeDecl item
);

Parameters

item
The TypeDecl to remove from the TypeDeclCollection.

Exceptions

Exception Type | Condition
ArgumentException | The specified TypeDecl was not found in the TypeDeclCollection.

See Also

TypeDeclCollection Class | DDW.CSharp.Dom Namespace


TypeDeclCollection.RemoveAt Method

Removes the element at the specified index of the TypeDeclCollection.

public virtual void RemoveAt(
int index
);

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

TypeDeclCollection Class | DDW.CSharp.Dom Namespace


TypeDeclCollection.Synchronized Method

Creates a synchronized (thread-safe) wrapper for a TypeDeclCollection instance.

public static TypeDeclCollection Synchronized(
TypeDeclCollection list
);

Return Value

An TypeDeclCollection wrapper that is synchronized (thread-safe).

See Also

TypeDeclCollection Class | DDW.CSharp.Dom Namespace


TypeDeclCollection.TrimToSize Method

Sets the capacity to the actual number of elements.

public virtual void TrimToSize();

See Also

TypeDeclCollection Class | DDW.CSharp.Dom Namespace


TypeDeclCollection.ITypeDeclCollectionEnumerator Interface

Supports type-safe iteration over a TypeDeclCollection.

For a list of all members of this type, see TypeDeclCollection.ITypeDeclCollectionEnumerator Members.

public interface TypeDeclCollection.ITypeDeclCollectionEnumerator

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

TypeDeclCollection.ITypeDeclCollectionEnumerator Members | DDW.CSharp.Dom Namespace


TypeDeclCollection.ITypeDeclCollectionEnumerator Members

TypeDeclCollection.ITypeDeclCollectionEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

TypeDeclCollection.ITypeDeclCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


TypeDeclCollection.ITypeDeclCollectionEnumerator Properties

The properties of the TypeDeclCollection.ITypeDeclCollectionEnumerator interface are listed below. For a complete list of TypeDeclCollection.ITypeDeclCollectionEnumerator interface members, see the TypeDeclCollection.ITypeDeclCollectionEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

TypeDeclCollection.ITypeDeclCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


Current Property

Goblin - A Platform for 3D AR and VR Applications

TypeDeclCollection.ITypeDeclCollectionEnumerator.Current Property

Gets the current element in the collection.

TypeDecl Current {get;}

See Also

TypeDeclCollection.ITypeDeclCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


TypeDeclCollection.ITypeDeclCollectionEnumerator Methods

The methods of the TypeDeclCollection.ITypeDeclCollectionEnumerator interface are listed below. For a complete list of TypeDeclCollection.ITypeDeclCollectionEnumerator interface members, see the TypeDeclCollection.ITypeDeclCollectionEnumerator Members topic.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

TypeDeclCollection.ITypeDeclCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


TypeDeclCollection.ITypeDeclCollectionEnumerator.MoveNext Method

Advances the enumerator to the next element in the collection.

bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Exceptions

Exception Type | Condition
InvalidOperationException | The collection was modified after the enumerator was created.

See Also

TypeDeclCollection.ITypeDeclCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


TypeDeclCollection.ITypeDeclCollectionEnumerator.Reset Method

Sets the enumerator to its initial position, before the first element in the collection.

void Reset();

See Also

TypeDeclCollection.ITypeDeclCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


TypeDeclCollection.Tag Enumeration

protected enum TypeDeclCollection.Tag

Members

Member Name | Description
Default |

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

DDW.CSharp.Dom Namespace


TypeKind Enumeration

An enumeration of possible type kinds (class, interface, enum etc).

public enum TypeKind

Members

Member Name | Description
Empty |
Class |
Interface |
Struct |
Enum |
Delegate |

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

DDW.CSharp.Dom Namespace


TypeModifiers Enumeration

A bit field enumeration of the modifier attributes that can be applied to types.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum TypeModifiers

Members

Member Name | Description | Value
Empty |  | 0
Class |  | 1
Interface |  | 2
Abstract |  | 4
Sealed |  | 8
Public |  | 16
NotPublic |  | 32
NestedPublic |  | 64
NestedPrivate |  | 128

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

DDW.CSharp.Dom Namespace


TypeOfExpr Class

A 'typeof' expression.

For a list of all members of this type, see TypeOfExpr Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Expression
DDW.CSharp.Dom.TypeOfExpr

public class TypeOfExpr : Expression

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

TypeOfExpr Members | DDW.CSharp.Dom Namespace


TypeOfExpr Members

TypeOfExpr overview

Public Instance Constructors

TypeOfExpr Constructor Initializes a new instance of the TypeOfExpr class.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
Type | Gets or sets the object who's type will be looked up.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TypeOfExpr Class | DDW.CSharp.Dom Namespace


TypeOfExpr Constructor

Initializes a new instance of the TypeOfExpr class.

public TypeOfExpr();

See Also

TypeOfExpr Class | DDW.CSharp.Dom Namespace


TypeOfExpr Properties

The properties of the TypeOfExpr class are listed below. For a complete list of TypeOfExpr class members, see the TypeOfExpr Members topic.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
Type | Gets or sets the object who's type will be looked up.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

TypeOfExpr Class | DDW.CSharp.Dom Namespace


Type Property

Goblin - A Platform for 3D AR and VR Applications

TypeOfExpr.Type Property

Gets or sets the object who's type will be looked up.

public TypeRef Type {get; set;}

See Also

TypeOfExpr Class | DDW.CSharp.Dom Namespace


TypeRef Class

A reference to a type (interface, class, struct, enum, delegate - this includes built in types).

For a list of all members of this type, see TypeRef Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.TypeRef

public class TypeRef : CSharpGraph, ISymbolRef, IDeclaration

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

TypeRef Members | DDW.CSharp.Dom Namespace


TypeRef Members

TypeRef overview

Public Instance Constructors

TypeRef Constructor Initializes a new instance of the TypeRef class.

Public Instance Properties

ArrayElementType | Gets or sets the base element type if this is an array reference.
ArrayRanks | Gets or sets the rank specifiers if this is an array reference. Rank specifiers are the [][] blocks in jagged arrays.
Definition | Gets or sets the definition of this type from the scope table.
LinePragma (inherited from CSharpGraph) |
TypeName | Gets or sets the name of the reference. If the Definition is not null and its Name is set it will get the name from there, otherwise it will store it internally as a string.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TypeRef Class | DDW.CSharp.Dom Namespace


TypeRef Constructor

Initializes a new instance of the TypeRef class.

public TypeRef();

See Also

TypeRef Class | DDW.CSharp.Dom Namespace


TypeRef Properties

The properties of the TypeRef class are listed below. For a complete list of TypeRef class members, see the TypeRef Members topic.

Public Instance Properties

ArrayElementType | Gets or sets the base element type if this is an array reference.
ArrayRanks | Gets or sets the rank specifiers if this is an array reference. Rank specifiers are the [][] blocks in jagged arrays.
Definition | Gets or sets the definition of this type from the scope table.
LinePragma (inherited from CSharpGraph) |
TypeName | Gets or sets the name of the reference. If the Definition is not null and its Name is set it will get the name from there, otherwise it will store it internally as a string.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

TypeRef Class | DDW.CSharp.Dom Namespace


ArrayElementType Property

Goblin - A Platform for 3D AR and VR Applications

TypeRef.ArrayElementType Property

Gets or sets the base element type if this is an array reference.

public TypeRef ArrayElementType {get; set;}

See Also

TypeRef Class | DDW.CSharp.Dom Namespace


ArrayRanks Property

Goblin - A Platform for 3D AR and VR Applications

TypeRef.ArrayRanks Property

Gets or sets the rank specifiers if this is an array reference. Rank specifiers are the [][] blocks in jagged arrays.

public RankSpecifierCollection ArrayRanks {get; set;}

See Also

TypeRef Class | DDW.CSharp.Dom Namespace


Definition Property

Goblin - A Platform for 3D AR and VR Applications

TypeRef.Definition Property

Gets or sets the definition of this type from the scope table.

public DDW.CSharp.SymbolTable.IDefinition Definition {get; set;}

Implements

IDeclaration.Definition

See Also

TypeRef Class | DDW.CSharp.Dom Namespace


TypeName Property

Goblin - A Platform for 3D AR and VR Applications

TypeRef.TypeName Property

Gets or sets the name of the reference. If the Definition is not null and its Name is set it will get the name from there, otherwise it will store it internally as a string.

public string TypeName {get; set;}

See Also

TypeRef Class | DDW.CSharp.Dom Namespace


TypeRefCollection Class

A strongly-typed collection of TypeRef objects.

For a list of all members of this type, see TypeRefCollection Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.TypeRefCollection

public class TypeRefCollection : CSharpGraph, IList, ICollection, IEnumerable, ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

TypeRefCollection Members | DDW.CSharp.Dom Namespace


TypeRefCollection Members

TypeRefCollection overview

Public Static Methods

ReadOnly | Creates a read-only wrapper for a TypeRefCollection instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a TypeRefCollection instance.

Public Instance Constructors

TypeRefCollection Overloaded. Initializes a new instance of the TypeRefCollection class.

Public Instance Properties

Capacity | Gets or sets the number of elements the TypeRefCollection can contain.
Count | Gets the number of elements actually contained in the TypeRefCollection.
GraphType |
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the TypeRef at the specified index.
LinePragma (inherited from CSharpGraph) |
SyncRoot | Gets an object that can be used to synchronize access to the collection.
Text |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Add | Adds a TypeRef to the end of the TypeRefCollection.
AddRange | Overloaded. Adds the elements of a TypeRef array to the current TypeRefCollection.
Clear | Removes all elements from the TypeRefCollection.
Clone | Creates a shallow copy of the TypeRefCollection.
Contains | Determines whether a given TypeRef is in the TypeRefCollection.
CopyTo | Overloaded. Copies the entire TypeRefCollection to a one-dimensional TypeRef array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the TypeRefCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the zero-based index of the first occurrence of a TypeRef in the TypeRefCollection.
Insert | Inserts an element into the TypeRefCollection at the specified index.
Remove | Removes the first occurrence of a specific TypeRef from the TypeRefCollection.
RemoveAt | Removes the element at the specified index of the TypeRefCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Constructors

TypeRefCollection Overloaded. Initializes a new instance of the TypeRefCollection class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TypeRefCollection Class | DDW.CSharp.Dom Namespace


TypeRefCollection Constructor

Initializes a new instance of the TypeRefCollection class that is empty and has the default initial capacity.

Overload List

Initializes a new instance of the TypeRefCollection class that is empty and has the default initial capacity.

public TypeRefCollection();

Initializes a new instance of the TypeRefCollection class that contains elements copied from the specified TypeRef array.

public TypeRefCollection(TypeRef[]);

Initializes a new instance of the TypeRefCollection class that contains elements copied from the specified TypeRefCollection.

public TypeRefCollection(TypeRefCollection);

protected TypeRefCollection(Tag);

Initializes a new instance of the TypeRefCollection class that has the specified initial capacity.

public TypeRefCollection(int);

See Also

TypeRefCollection Class | DDW.CSharp.Dom Namespace


TypeRefCollection Constructor ()

Initializes a new instance of the TypeRefCollection class that is empty and has the default initial capacity.

public TypeRefCollection();

See Also

TypeRefCollection Class | DDW.CSharp.Dom Namespace | TypeRefCollection Constructor Overload List


TypeRefCollection Constructor (Int32)

Initializes a new instance of the TypeRefCollection class that has the specified initial capacity.

public TypeRefCollection(
int capacity
);

Parameters

capacity
The number of elements that the new TypeRefCollection is initially capable of storing.

See Also

TypeRefCollection Class | DDW.CSharp.Dom Namespace | TypeRefCollection Constructor Overload List


TypeRefCollection Constructor (TypeRefCollection)

Initializes a new instance of the TypeRefCollection class that contains elements copied from the specified TypeRefCollection.

public TypeRefCollection(
TypeRefCollection c
);

Parameters

c
The TypeRefCollection whose elements are copied to the new collection.

See Also

TypeRefCollection Class | DDW.CSharp.Dom Namespace | TypeRefCollection Constructor Overload List


TypeRefCollection Constructor (TypeRef[])

Initializes a new instance of the TypeRefCollection class that contains elements copied from the specified TypeRef array.

public TypeRefCollection(
TypeRef[] a
);

Parameters

a
The TypeRef array whose elements are copied to the new list.

See Also

TypeRefCollection Class | DDW.CSharp.Dom Namespace | TypeRefCollection Constructor Overload List


TypeRefCollection Constructor (Tag)

protected TypeRefCollection(
Tag t
);

See Also

TypeRefCollection Class | DDW.CSharp.Dom Namespace | TypeRefCollection Constructor Overload List


TypeRefCollection Properties

The properties of the TypeRefCollection class are listed below. For a complete list of TypeRefCollection class members, see the TypeRefCollection Members topic.

Public Instance Properties

Capacity | Gets or sets the number of elements the TypeRefCollection can contain.
Count | Gets the number of elements actually contained in the TypeRefCollection.
GraphType |
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the TypeRef at the specified index.
LinePragma (inherited from CSharpGraph) |
SyncRoot | Gets an object that can be used to synchronize access to the collection.
Text |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

TypeRefCollection Class | DDW.CSharp.Dom Namespace


Capacity Property

Goblin - A Platform for 3D AR and VR Applications

TypeRefCollection.Capacity Property

Gets or sets the number of elements the TypeRefCollection can contain.

public virtual int Capacity {get; set;}

See Also

TypeRefCollection Class | DDW.CSharp.Dom Namespace


Count Property

Goblin - A Platform for 3D AR and VR Applications

TypeRefCollection.Count Property

Gets the number of elements actually contained in the TypeRefCollection.

public virtual int Count {get;}

Implements

ICollection.Count

See Also

TypeRefCollection Class | DDW.CSharp.Dom Namespace


GraphType Property

Goblin - A Platform for 3D AR and VR Applications

TypeRefCollection.GraphType Property

public override GraphTypes GraphType {get;}

Implements

IGraph.GraphType

See Also

TypeRefCollection Class | DDW.CSharp.Dom Namespace


IsFixedSize Property

Goblin - A Platform for 3D AR and VR Applications

TypeRefCollection.IsFixedSize Property

Gets a value indicating whether the collection has a fixed size.

public virtual bool IsFixedSize {get;}

Property Value

true if the collection has a fixed size; otherwise, false. The default is false

Implements

IList.IsFixedSize

See Also

TypeRefCollection Class | DDW.CSharp.Dom Namespace


IsReadOnly Property

Goblin - A Platform for 3D AR and VR Applications

TypeRefCollection.IsReadOnly Property

gets a value indicating whether the IList is read-only.

public virtual bool IsReadOnly {get;}

Property Value

true if the collection is read-only; otherwise, false. The default is false

Implements

IList.IsReadOnly

See Also

TypeRefCollection Class | DDW.CSharp.Dom Namespace


IsSynchronized Property

Goblin - A Platform for 3D AR and VR Applications

TypeRefCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread-safe).

public virtual bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

TypeRefCollection Class | DDW.CSharp.Dom Namespace


Item Property

Goblin - A Platform for 3D AR and VR Applications

TypeRefCollection.Item Property

Gets or sets the TypeRef at the specified index.

public virtual TypeRef this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

TypeRefCollection Class | DDW.CSharp.Dom Namespace


SyncRoot Property

Goblin - A Platform for 3D AR and VR Applications

TypeRefCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

public virtual object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

TypeRefCollection Class | DDW.CSharp.Dom Namespace


Text Property

Goblin - A Platform for 3D AR and VR Applications

TypeRefCollection.Text Property

public override string Text {get;}

Implements

IGraph.Text

See Also

TypeRefCollection Class | DDW.CSharp.Dom Namespace


TypeRefCollection Methods

The methods of the TypeRefCollection class are listed below. For a complete list of TypeRefCollection class members, see the TypeRefCollection Members topic.

Public Static Methods

ReadOnly | Creates a read-only wrapper for a TypeRefCollection instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a TypeRefCollection instance.

Public Instance Methods

Add | Adds a TypeRef to the end of the TypeRefCollection.
AddRange | Overloaded. Adds the elements of a TypeRef array to the current TypeRefCollection.
Clear | Removes all elements from the TypeRefCollection.
Clone | Creates a shallow copy of the TypeRefCollection.
Contains | Determines whether a given TypeRef is in the TypeRefCollection.
CopyTo | Overloaded. Copies the entire TypeRefCollection to a one-dimensional TypeRef array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the TypeRefCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the zero-based index of the first occurrence of a TypeRef in the TypeRefCollection.
Insert | Inserts an element into the TypeRefCollection at the specified index.
Remove | Removes the first occurrence of a specific TypeRef from the TypeRefCollection.
RemoveAt | Removes the element at the specified index of the TypeRefCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TypeRefCollection Class | DDW.CSharp.Dom Namespace


TypeRefCollection.Add Method

Adds a TypeRef to the end of the TypeRefCollection.

public virtual int Add(
TypeRef item
);

Parameters

item
The TypeRef to be added to the end of the TypeRefCollection.

Return Value

The index at which the value has been added.

See Also

TypeRefCollection Class | DDW.CSharp.Dom Namespace


AddRange Method

Goblin - A Platform for 3D AR and VR Applications

TypeRefCollection.AddRange Method

Adds the elements of a TypeRef array to the current TypeRefCollection.

Overload List

Adds the elements of a TypeRef array to the current TypeRefCollection.

public virtual int AddRange(TypeRef[]);

Adds the elements of another TypeRefCollection to the current TypeRefCollection.

public virtual int AddRange(TypeRefCollection);

See Also

TypeRefCollection Class | DDW.CSharp.Dom Namespace


TypeRefCollection.AddRange Method (TypeRef[])

Adds the elements of a TypeRef array to the current TypeRefCollection.

public virtual int AddRange(
TypeRef[] x
);

Parameters

x
The TypeRef array whose elements should be added to the end of the TypeRefCollection.

Return Value

The new Count of the TypeRefCollection.

See Also

TypeRefCollection Class | DDW.CSharp.Dom Namespace | TypeRefCollection.AddRange Overload List


TypeRefCollection.AddRange Method (TypeRefCollection)

Adds the elements of another TypeRefCollection to the current TypeRefCollection.

public virtual int AddRange(
TypeRefCollection x
);

Parameters

x
The TypeRefCollection whose elements should be added to the end of the current TypeRefCollection.

Return Value

The new Count of the TypeRefCollection.

See Also

TypeRefCollection Class | DDW.CSharp.Dom Namespace | TypeRefCollection.AddRange Overload List


TypeRefCollection.Clear Method

Removes all elements from the TypeRefCollection.

public virtual void Clear();

Implements

IList.Clear

See Also

TypeRefCollection Class | DDW.CSharp.Dom Namespace


TypeRefCollection.Clone Method

Creates a shallow copy of the TypeRefCollection.

public virtual object Clone();

Implements

ICloneable.Clone

See Also

TypeRefCollection Class | DDW.CSharp.Dom Namespace


TypeRefCollection.Contains Method

Determines whether a given TypeRef is in the TypeRefCollection.

public virtual bool Contains(
TypeRef item
);

Parameters

item
The TypeRef to check for.

Return Value

true if item is found in the TypeRefCollection; otherwise, false.

See Also

TypeRefCollection Class | DDW.CSharp.Dom Namespace


CopyTo Method

Goblin - A Platform for 3D AR and VR Applications

TypeRefCollection.CopyTo Method

Copies the entire TypeRefCollection to a one-dimensional TypeRef array.

Overload List

Copies the entire TypeRefCollection to a one-dimensional TypeRef array.

public virtual void CopyTo(TypeRef[]);

Copies the entire TypeRefCollection to a one-dimensional TypeRef array, starting at the specified index of the target array.

public virtual void CopyTo(TypeRef[],int);

See Also

TypeRefCollection Class | DDW.CSharp.Dom Namespace


TypeRefCollection.CopyTo Method (TypeRef[])

Copies the entire TypeRefCollection to a one-dimensional TypeRef array.

public virtual void CopyTo(
TypeRef[] array
);

Parameters

array
The one-dimensional TypeRef array to copy to.

See Also

TypeRefCollection Class | DDW.CSharp.Dom Namespace | TypeRefCollection.CopyTo Overload List


TypeRefCollection.CopyTo Method (TypeRef[], Int32)

Copies the entire TypeRefCollection to a one-dimensional TypeRef array, starting at the specified index of the target array.

public virtual void CopyTo(
TypeRef[] array,
int start
);

Parameters

array
The one-dimensional TypeRef array to copy to.
start
The zero-based index in array at which copying begins.

See Also

TypeRefCollection Class | DDW.CSharp.Dom Namespace | TypeRefCollection.CopyTo Overload List


TypeRefCollection.GetEnumerator Method

Returns an enumerator that can iterate through the TypeRefCollection.

public virtual ITypeRefCollectionEnumerator GetEnumerator();

Return Value

An Enumerator for the entire TypeRefCollection.

See Also

TypeRefCollection Class | DDW.CSharp.Dom Namespace


TypeRefCollection.IndexOf Method

Returns the zero-based index of the first occurrence of a TypeRef in the TypeRefCollection.

public virtual int IndexOf(
TypeRef item
);

Parameters

item
The TypeRef to locate in the TypeRefCollection.

Return Value

The zero-based index of the first occurrence of item in the entire TypeRefCollection, if found; otherwise, -1.

See Also

TypeRefCollection Class | DDW.CSharp.Dom Namespace


TypeRefCollection.Insert Method

Inserts an element into the TypeRefCollection at the specified index.

public virtual void Insert(
int index,
TypeRef item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The TypeRef to insert.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

TypeRefCollection Class | DDW.CSharp.Dom Namespace


TypeRefCollection.ReadOnly Method

Creates a read-only wrapper for a TypeRefCollection instance.

public static TypeRefCollection ReadOnly(
TypeRefCollection list
);

Return Value

An TypeRefCollection wrapper that is read-only.

See Also

TypeRefCollection Class | DDW.CSharp.Dom Namespace


TypeRefCollection.Remove Method

Removes the first occurrence of a specific TypeRef from the TypeRefCollection.

public virtual void Remove(
TypeRef item
);

Parameters

item
The TypeRef to remove from the TypeRefCollection.

Exceptions

Exception Type | Condition
ArgumentException | The specified TypeRef was not found in the TypeRefCollection.

See Also

TypeRefCollection Class | DDW.CSharp.Dom Namespace


TypeRefCollection.RemoveAt Method

Removes the element at the specified index of the TypeRefCollection.

public virtual void RemoveAt(
int index
);

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

TypeRefCollection Class | DDW.CSharp.Dom Namespace


TypeRefCollection.Synchronized Method

Creates a synchronized (thread-safe) wrapper for a TypeRefCollection instance.

public static TypeRefCollection Synchronized(
TypeRefCollection list
);

Return Value

An TypeRefCollection wrapper that is synchronized (thread-safe).

See Also

TypeRefCollection Class | DDW.CSharp.Dom Namespace


TypeRefCollection.TrimToSize Method

Sets the capacity to the actual number of elements.

public virtual void TrimToSize();

See Also

TypeRefCollection Class | DDW.CSharp.Dom Namespace


TypeRefCollection.ITypeRefCollectionEnumerator Interface

Supports type-safe iteration over a TypeRefCollection.

For a list of all members of this type, see TypeRefCollection.ITypeRefCollectionEnumerator Members.

public interface TypeRefCollection.ITypeRefCollectionEnumerator

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

TypeRefCollection.ITypeRefCollectionEnumerator Members | DDW.CSharp.Dom Namespace


TypeRefCollection.ITypeRefCollectionEnumerator Members

TypeRefCollection.ITypeRefCollectionEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

TypeRefCollection.ITypeRefCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


TypeRefCollection.ITypeRefCollectionEnumerator Properties

The properties of the TypeRefCollection.ITypeRefCollectionEnumerator interface are listed below. For a complete list of TypeRefCollection.ITypeRefCollectionEnumerator interface members, see the TypeRefCollection.ITypeRefCollectionEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

TypeRefCollection.ITypeRefCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


Current Property

Goblin - A Platform for 3D AR and VR Applications

TypeRefCollection.ITypeRefCollectionEnumerator.Current Property

Gets the current element in the collection.

TypeRef Current {get;}

See Also

TypeRefCollection.ITypeRefCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


TypeRefCollection.ITypeRefCollectionEnumerator Methods

The methods of the TypeRefCollection.ITypeRefCollectionEnumerator interface are listed below. For a complete list of TypeRefCollection.ITypeRefCollectionEnumerator interface members, see the TypeRefCollection.ITypeRefCollectionEnumerator Members topic.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

TypeRefCollection.ITypeRefCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


TypeRefCollection.ITypeRefCollectionEnumerator.MoveNext Method

Advances the enumerator to the next element in the collection.

bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Exceptions

Exception Type | Condition
InvalidOperationException | The collection was modified after the enumerator was created.

See Also

TypeRefCollection.ITypeRefCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


TypeRefCollection.ITypeRefCollectionEnumerator.Reset Method

Sets the enumerator to its initial position, before the first element in the collection.

void Reset();

See Also

TypeRefCollection.ITypeRefCollectionEnumerator Interface | DDW.CSharp.Dom Namespace


TypeRefCollection.Tag Enumeration

protected enum TypeRefCollection.Tag

Members

Member Name | Description
Default |

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

DDW.CSharp.Dom Namespace


UnaryExpr Class

A unary expression.

For a list of all members of this type, see UnaryExpr Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Expression
DDW.CSharp.Dom.UnaryExpr

public class UnaryExpr : Expression

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

UnaryExpr Members | DDW.CSharp.Dom Namespace


UnaryExpr Members

UnaryExpr overview

Public Static Methods

OperatorFromString | A helper method that returns the UnaryOperator from string input. Note: Plus and negation have a 'u' appended to differentiate them from add and subtract.
StringFromOperator | A helper method that returns a string (that would be used in C# code) from a UnaryOperator. Note: there is no 'u' appended for return plus and negation operators.

Public Instance Constructors

UnaryExpr Constructor Initializes a new instance of the UnaryExpr class.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
Operator | Gets or sets the unary operator.
Right | Gets or sets the right (and only) side of the unary expression.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UnaryExpr Class | DDW.CSharp.Dom Namespace


UnaryExpr Constructor

Initializes a new instance of the UnaryExpr class.

public UnaryExpr();

See Also

UnaryExpr Class | DDW.CSharp.Dom Namespace


UnaryExpr Properties

The properties of the UnaryExpr class are listed below. For a complete list of UnaryExpr class members, see the UnaryExpr Members topic.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
Operator | Gets or sets the unary operator.
Right | Gets or sets the right (and only) side of the unary expression.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

UnaryExpr Class | DDW.CSharp.Dom Namespace


Operator Property

Goblin - A Platform for 3D AR and VR Applications

UnaryExpr.Operator Property

Gets or sets the unary operator.

public UnaryOperator Operator {get; set;}

See Also

UnaryExpr Class | DDW.CSharp.Dom Namespace


Right Property

Goblin - A Platform for 3D AR and VR Applications

UnaryExpr.Right Property

Gets or sets the right (and only) side of the unary expression.

public Expression Right {get; set;}

See Also

UnaryExpr Class | DDW.CSharp.Dom Namespace


UnaryExpr Methods

The methods of the UnaryExpr class are listed below. For a complete list of UnaryExpr class members, see the UnaryExpr Members topic.

Public Static Methods

OperatorFromString | A helper method that returns the UnaryOperator from string input. Note: Plus and negation have a 'u' appended to differentiate them from add and subtract.
StringFromOperator | A helper method that returns a string (that would be used in C# code) from a UnaryOperator. Note: there is no 'u' appended for return plus and negation operators.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UnaryExpr Class | DDW.CSharp.Dom Namespace


UnaryExpr.OperatorFromString Method

A helper method that returns the UnaryOperator from string input. Note: Plus and negation have a 'u' appended to differentiate them from add and subtract.

public static UnaryOperator OperatorFromString(
string txt
);

Parameters

txt

Return Value

The resulting UnaryOperator.

See Also

UnaryExpr Class | DDW.CSharp.Dom Namespace


UnaryExpr.StringFromOperator Method

A helper method that returns a string (that would be used in C# code) from a UnaryOperator. Note: there is no 'u' appended for return plus and negation operators.

public static string StringFromOperator(
UnaryOperator uOpEnum
);

Parameters

uOpEnum

Return Value

The string representation.

See Also

UnaryExpr Class | DDW.CSharp.Dom Namespace


UnaryOperator Enumeration

An enumeration of possible unary expression operators.

public enum UnaryOperator

Members

Member Name | Description
Empty |
UnaryPlus |
UnaryNegation |
Not |
OnesComplement |
Pointer |
Increment |
Decrement |

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

DDW.CSharp.Dom Namespace


UncheckedStmt Class

An unchecked statement - explicitly ignores overflow.

For a list of all members of this type, see UncheckedStmt Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Statement
DDW.CSharp.Dom.UncheckedStmt

public class UncheckedStmt : Statement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

UncheckedStmt Members | DDW.CSharp.Dom Namespace


UncheckedStmt Members

UncheckedStmt overview

Public Instance Constructors

UncheckedStmt Constructor Initializes a new instance of the UncheckedStmt class.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
Statements | Gets the collection of statements in the unchecked statement.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UncheckedStmt Class | DDW.CSharp.Dom Namespace


UncheckedStmt Constructor

Initializes a new instance of the UncheckedStmt class.

public UncheckedStmt();

See Also

UncheckedStmt Class | DDW.CSharp.Dom Namespace


UncheckedStmt Properties

The properties of the UncheckedStmt class are listed below. For a complete list of UncheckedStmt class members, see the UncheckedStmt Members topic.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
Statements | Gets the collection of statements in the unchecked statement.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

UncheckedStmt Class | DDW.CSharp.Dom Namespace


Statements Property

Goblin - A Platform for 3D AR and VR Applications

UncheckedStmt.Statements Property

Gets the collection of statements in the unchecked statement.

public StatementCollection Statements {get;}

See Also

UncheckedStmt Class | DDW.CSharp.Dom Namespace


UnknownReference Class

A variable who's type has not yet been determined.

For a list of all members of this type, see UnknownReference Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Expression
DDW.CSharp.Dom.Reference
DDW.CSharp.Dom.UnknownReference

public class UnknownReference : Reference

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

UnknownReference Members | DDW.CSharp.Dom Namespace


UnknownReference Members

UnknownReference overview

Public Instance Constructors

UnknownReference Constructor Initializes a new instance of the UnknownReference class.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.
VariableName | Gets or sets the name of the variable.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UnknownReference Class | DDW.CSharp.Dom Namespace


UnknownReference Constructor

Initializes a new instance of the UnknownReference class.

public UnknownReference();

See Also

UnknownReference Class | DDW.CSharp.Dom Namespace


UnknownReference Properties

The properties of the UnknownReference class are listed below. For a complete list of UnknownReference class members, see the UnknownReference Members topic.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.
VariableName | Gets or sets the name of the variable.

See Also

UnknownReference Class | DDW.CSharp.Dom Namespace


VariableName Property

Goblin - A Platform for 3D AR and VR Applications

UnknownReference.VariableName Property

Gets or sets the name of the variable.

public string VariableName {get; set;}

See Also

UnknownReference Class | DDW.CSharp.Dom Namespace


UsingStmt Class

A using statement, aquires a resource that will be disposed at the end of the scope.

For a list of all members of this type, see UsingStmt Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Statement
DDW.CSharp.Dom.UsingStmt

public class UsingStmt : Statement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

UsingStmt Members | DDW.CSharp.Dom Namespace


UsingStmt Members

UsingStmt overview

Public Instance Constructors

UsingStmt Constructor Initializes a new instance of the UsingStmt class.

Public Instance Properties

Declaration | Gets or sets the resources declared, which will be disposed at the end of the statements block.
DeclaresResource | Gets a flag that determines if the using statement declares it's own resources.
LinePragma (inherited from CSharpGraph) |
Statements | Gets the collection of statements in the block of the using statement.
Target | Gets or sets the target resource to be used - use the target expression if the using statement doesn't declare it's own target(s). In the normal case, where the using statement declares it's resources, use the Declaration property.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UsingStmt Class | DDW.CSharp.Dom Namespace


UsingStmt Constructor

Initializes a new instance of the UsingStmt class.

public UsingStmt();

See Also

UsingStmt Class | DDW.CSharp.Dom Namespace


UsingStmt Properties

The properties of the UsingStmt class are listed below. For a complete list of UsingStmt class members, see the UsingStmt Members topic.

Public Instance Properties

Declaration | Gets or sets the resources declared, which will be disposed at the end of the statements block.
DeclaresResource | Gets a flag that determines if the using statement declares it's own resources.
LinePragma (inherited from CSharpGraph) |
Statements | Gets the collection of statements in the block of the using statement.
Target | Gets or sets the target resource to be used - use the target expression if the using statement doesn't declare it's own target(s). In the normal case, where the using statement declares it's resources, use the Declaration property.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

UsingStmt Class | DDW.CSharp.Dom Namespace


Declaration Property

Goblin - A Platform for 3D AR and VR Applications

UsingStmt.Declaration Property

Gets or sets the resources declared, which will be disposed at the end of the statements block.

public VariableDeclStmt Declaration {get; set;}

See Also

UsingStmt Class | DDW.CSharp.Dom Namespace


DeclaresResource Property

Goblin - A Platform for 3D AR and VR Applications

UsingStmt.DeclaresResource Property

Gets a flag that determines if the using statement declares it's own resources.

public bool DeclaresResource {get;}

See Also

UsingStmt Class | DDW.CSharp.Dom Namespace


Statements Property

Goblin - A Platform for 3D AR and VR Applications

UsingStmt.Statements Property

Gets the collection of statements in the block of the using statement.

public StatementCollection Statements {get;}

See Also

UsingStmt Class | DDW.CSharp.Dom Namespace


Target Property

Goblin - A Platform for 3D AR and VR Applications

UsingStmt.Target Property

Gets or sets the target resource to be used - use the target expression if the using statement doesn't declare it's own target(s). In the normal case, where the using statement declares it's resources, use the Declaration property.

public Expression Target {get; set;}

See Also

UsingStmt Class | DDW.CSharp.Dom Namespace


VariableDecl Class

A variable declaration.

For a list of all members of this type, see VariableDecl Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.VariableDecl

public class VariableDecl : CSharpGraph

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

VariableDecl Members | DDW.CSharp.Dom Namespace


VariableDecl Members

VariableDecl overview

Public Instance Constructors

VariableDecl Constructor Initializes a new instance of the VariableDecl class.

Public Instance Properties

LinePragma (inherited from CSharpGraph) |
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

VariableDecl Class | DDW.CSharp.Dom Namespace


VariableDecl Constructor

Initializes a new instance of the VariableDecl class.

public VariableDecl();

See Also

VariableDecl Class | DDW.CSharp.Dom Namespace


VariableDeclStmt Class

A variable declaration statement.

For a list of all members of this type, see VariableDeclStmt Members.

System.Object
DDW.CSharp.Dom.CSharpGraph
DDW.CSharp.Dom.Statement
DDW.CSharp.Dom.VariableDeclStmt

public class VariableDeclStmt : Statement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Dom

Assembly: CSharp (in CSharp.dll)

See Also

VariableDeclStmt Members | DDW.CSharp.Dom Namespace


VariableDeclStmt Members

VariableDeclStmt overview

Public Instance Constructors

VariableDeclStmt Constructor Initializes a new instance of the VariableDeclStmt class.

Public Instance Properties

Delcarators | Gets the collection of declarators created. Variable declarations can declare multiple variables at once, so this must be a collection.
DimensionCount | Gets or sets the number of dimensions if this is an array. Zero dimensions indicates this is not an array. The dimensions are represented by commas in C#, like [,,].
LinePragma (inherited from CSharpGraph) |
Type | Gets or sets the type of the variable. While one can declare multiple variables they must be of the same type - therefore this is not a collection.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

VariableDeclStmt Class | DDW.CSharp.Dom Namespace


VariableDeclStmt Constructor

Initializes a new instance of the VariableDeclStmt class.

public VariableDeclStmt();

See Also

VariableDeclStmt Class | DDW.CSharp.Dom Namespace


VariableDeclStmt Properties

The properties of the VariableDeclStmt class are listed below. For a complete list of VariableDeclStmt class members, see the VariableDeclStmt Members topic.

Public Instance Properties

Delcarators | Gets the collection of declarators created. Variable declarations can declare multiple variables at once, so this must be a collection.
DimensionCount | Gets or sets the number of dimensions if this is an array. Zero dimensions indicates this is not an array. The dimensions are represented by commas in C#, like [,,].
LinePragma (inherited from CSharpGraph) |
Type | Gets or sets the type of the variable. While one can declare multiple variables they must be of the same type - therefore this is not a collection.
UserData (inherited from CSharpGraph) | Gets or sets the user-definable data for the current object.

See Also

VariableDeclStmt Class | DDW.CSharp.Dom Namespace


Delcarators Property

Goblin - A Platform for 3D AR and VR Applications

VariableDeclStmt.Delcarators Property

Gets the collection of declarators created. Variable declarations can declare multiple variables at once, so this must be a collection.

public DeclaratorCollection Delcarators {get;}

See Also

VariableDeclStmt Class | DDW.CSharp.Dom Namespace


DimensionCount Property

Goblin - A Platform for 3D AR and VR Applications

VariableDeclStmt.DimensionCount Property

Gets or sets the number of dimensions if this is an array. Zero dimensions indicates this is not an array. The dimensions are represented by commas in C#, like [,,].

public int DimensionCount {get; set;}

See Also

VariableDeclStmt Class | DDW.CSharp.Dom Namespace


Type Property

Goblin - A Platform for 3D AR and VR Applications

VariableDeclStmt.Type Property

Gets or sets the type of the variable. While one can declare multiple variables they must be of the same type - therefore this is not a collection.

public TypeRef Type {get; set;}

See Also

VariableDeclStmt Class | DDW.CSharp.Dom Namespace


DDW.CSharp.Gen

Goblin - A Platform for 3D AR and VR Applications

DDW.CSharp.Gen Namespace

C# grammar (based on ecma-334 spec) -- Robin Debreuil Fri Mar 5, 2004 11:50 -- A (mostly) complete cs parser. It parses into a tree structure loosely based on the CodeDom. Does not yet do #if preprocessor segments, and no unsafe code (as of yet). You can test by downloading the CSharp.zip file and dragging cs files into CSharp.exe. The zip includes the grammar file, as well as the cs token classes (the grammar uses a heterogeneous tree, though that should be simple to turn off). -- permalink: http://www.debreuil.com/CSharp. TJP: copied src, exe to antlr.org and changed link as debreuil's links are dead.

Namespace hierarchy

Classes

Class | Description
CSharpGen |
LineWriter | Summary description for LineWriter.


CSharpGen Class

For a list of all members of this type, see CSharpGen Members.

System.Object
DDW.CSharp.Walk.GraphParserBase
DDW.CSharp.Gen.CSharpGen

public class CSharpGen : GraphParserBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Gen

Assembly: CSharp (in CSharp.dll)

See Also

CSharpGen Members | DDW.CSharp.Gen Namespace


CSharpGen Members

CSharpGen overview

Public Instance Constructors

CSharpGen Constructor

Public Instance Methods

Close |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Parse (inherited from GraphParserBase) |
ParseElement | Overloaded.
ToString |

Protected Instance Methods

BeginParse |
EndParse |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace


CSharpGen Constructor

public CSharpGen(
TextWriter tw
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace


CSharpGen Methods

The methods of the CSharpGen class are listed below. For a complete list of CSharpGen class members, see the CSharpGen Members topic.

Public Instance Methods

Close |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Parse (inherited from GraphParserBase) |
ParseElement | Overloaded.
ToString |

Protected Instance Methods

BeginParse |
EndParse |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace


CSharpGen.BeginParse Method

protected override void BeginParse(
IGraph gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace


CSharpGen.Close Method

public void Close();

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace


CSharpGen.EndParse Method

protected override void EndParse(
IGraph gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace


ParseElement Method

Goblin - A Platform for 3D AR and VR Applications

CSharpGen.ParseElement Method

Overload List

public override void ParseElement(AccessorDecl);

public override void ParseElement(AccessorModifiers);

public override void ParseElement(ArgumentRef);

public override void ParseElement(ArrayCreateExpr);

public override void ParseElement(ArrayElementRef);

public override void ParseElement(ArrayInitializer);

public override void ParseElement(AssemblyReference);

public override void ParseElement(AssemblyReferenceCollection);

public override void ParseElement(AssignExpr);

public override void ParseElement(AssignOperator);

public override void ParseElement(AttachDelegateStmt);

public override void ParseElement(AttributeTarget);

public override void ParseElement(BaseRef);

public override void ParseElement(BinaryExpr);

public override void ParseElement(BinaryOperator);

public override void ParseElement(BooleanLiteral);

public override void ParseElement(BreakStmt);

public override void ParseElement(BuiltInType);

public override void ParseElement(Case);

public override void ParseElement(CaseCollection);

public override void ParseElement(CastExpr);

public override void ParseElement(Catch);

public override void ParseElement(CatchCollection);

public override void ParseElement(CharLiteral);

public override void ParseElement(CheckedStmt);

public override void ParseElement(ClassDecl);

public override void ParseElement(Comment);

public override void ParseElement(CommentStmt);

public override void ParseElement(CommentStmtCollection);

public override void ParseElement(CompileUnit);

public override void ParseElement(CompileUnitCollection);

public override void ParseElement(ConstantDecl);

public override void ParseElement(ConstantDeclStmt);

public override void ParseElement(ConstructorDecl);

public override void ParseElement(ContinueStmt);

public override void ParseElement(CreateDelegateExpr);

public override void ParseElement(CustomAttribute);

public override void ParseElement(CustomAttributeCollection);

public override void ParseElement(Declarator);

public override void ParseElement(DeclaratorCollection);

public override void ParseElement(DelegateDecl);

public override void ParseElement(DelegateInvokeExpr);

public override void ParseElement(DestructorDecl);

public override void ParseElement(EnumDecl);

public override void ParseElement(EnumMemberDecl);

public override void ParseElement(EventDecl);

public override void ParseElement(EventRef);

public override void ParseElement(ExpressionCollection);

public override void ParseElement(ExprStmt);

public override void ParseElement(FieldDecl);

public override void ParseElement(FieldRef);

public override void ParseElement(ForEachStmt);

public override void ParseElement(GotoStmt);

public override void ParseElement(IfStmt);

public override void ParseElement(Import);

public override void ParseElement(ImportCollection);

public override void ParseElement(IndexerDecl);

public override void ParseElement(IndexerRef);

public override void ParseElement(IntegerLiteral);

public override void ParseElement(InterfaceDecl);

public override void ParseElement(IterationStmt);

public override void ParseElement(IterationType);

public override void ParseElement(LabeledStmt);

public override void ParseElement(LinePragma);

public override void ParseElement(LocalRef);

public override void ParseElement(LockStmt);

public override void ParseElement(MemberAccess);

public override void ParseElement(MemberDeclCollection);

public override void ParseElement(MethodDecl);

public override void ParseElement(MethodInvokeExpr);

public override void ParseElement(MethodRef);

public override void ParseElement(Modifiers);

public override void ParseElement(NamespaceDecl);

public override void ParseElement(NamespaceDeclCollection);

public override void ParseElement(NullLiteral);

public override void ParseElement(ObjectCreateExpr);

public override void ParseElement(OperatorDecl);

public override void ParseElement(OverloadableOperator);

public override void ParseElement(Param);

public override void ParseElement(ParamCollection);

public override void ParseElement(ParamDecl);

public override void ParseElement(ParamDeclCollection);

public override void ParseElement(ParamDirection);

public override void ParseElement(PostfixExpr);

public override void ParseElement(PostfixOperator);

public override void ParseElement(PropertyDecl);

public override void ParseElement(PropertyRef);

public override void ParseElement(PropertySetValueRef);

public override void ParseElement(RankSpecifier);

public override void ParseElement(RankSpecifierCollection);

public override void ParseElement(RealLiteral);

public override void ParseElement(RemoveDelegateStmt);

public override void ParseElement(ReturnStmt);

public override void ParseElement(StatementCollection);

public override void ParseElement(StringLiteral);

public override void ParseElement(StructDecl);

public override void ParseElement(SubExpr);

public override void ParseElement(SwitchStmt);

public override void ParseElement(TernaryExpr);

public override void ParseElement(ThisRef);

public override void ParseElement(ThrowStmt);

public override void ParseElement(TryCatchFinallyStmt);

public override void ParseElement(TypeDeclCollection);

public override void ParseElement(TypeModifiers);

public override void ParseElement(TypeOfExpr);

public override void ParseElement(TypeRef);

public override void ParseElement(TypeRefCollection);

public override void ParseElement(UnaryExpr);

public override void ParseElement(UnaryOperator);

public override void ParseElement(UncheckedStmt);

public override void ParseElement(UnknownReference);

public override void ParseElement(UsingStmt);

public override void ParseElement(VariableDecl);

public override void ParseElement(VariableDeclStmt);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace


CSharpGen.ParseElement Method (AccessorDecl)

public override void ParseElement(
AccessorDecl gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (AccessorModifiers)

public override void ParseElement(
AccessorModifiers gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (ArgumentRef)

public override void ParseElement(
ArgumentRef gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (ArrayCreateExpr)

public override void ParseElement(
ArrayCreateExpr gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (ArrayElementRef)

public override void ParseElement(
ArrayElementRef gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (ArrayInitializer)

public override void ParseElement(
ArrayInitializer gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (AssemblyReference)

public override void ParseElement(
AssemblyReference gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (AssemblyReferenceCollection)

public override void ParseElement(
AssemblyReferenceCollection gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (AssignExpr)

public override void ParseElement(
AssignExpr gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (AssignOperator)

public override void ParseElement(
AssignOperator gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (AttachDelegateStmt)

public override void ParseElement(
AttachDelegateStmt gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (AttributeTarget)

public override void ParseElement(
AttributeTarget gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (BaseRef)

public override void ParseElement(
BaseRef gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (BinaryExpr)

public override void ParseElement(
BinaryExpr gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (BinaryOperator)

public override void ParseElement(
BinaryOperator gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (BooleanLiteral)

public override void ParseElement(
BooleanLiteral gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (BreakStmt)

public override void ParseElement(
BreakStmt gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (BuiltInType)

public override void ParseElement(
BuiltInType gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (Case)

public override void ParseElement(
Case gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (CaseCollection)

public override void ParseElement(
CaseCollection gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (CastExpr)

public override void ParseElement(
CastExpr gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (Catch)

public override void ParseElement(
Catch gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (CatchCollection)

public override void ParseElement(
CatchCollection gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (CharLiteral)

public override void ParseElement(
CharLiteral gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (CheckedStmt)

public override void ParseElement(
CheckedStmt gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (ClassDecl)

public override void ParseElement(
ClassDecl gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (Comment)

public override void ParseElement(
Comment gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (CommentStmt)

public override void ParseElement(
CommentStmt gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (CommentStmtCollection)

public override void ParseElement(
CommentStmtCollection gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (CompileUnit)

public override void ParseElement(
CompileUnit gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (CompileUnitCollection)

public override void ParseElement(
CompileUnitCollection gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (ConstantDecl)

public override void ParseElement(
ConstantDecl gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (ConstantDeclStmt)

public override void ParseElement(
ConstantDeclStmt gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (ConstructorDecl)

public override void ParseElement(
ConstructorDecl gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (ContinueStmt)

public override void ParseElement(
ContinueStmt gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (CreateDelegateExpr)

public override void ParseElement(
CreateDelegateExpr gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (CustomAttribute)

public override void ParseElement(
CustomAttribute gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (CustomAttributeCollection)

public override void ParseElement(
CustomAttributeCollection gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (Declarator)

public override void ParseElement(
Declarator gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (DeclaratorCollection)

public override void ParseElement(
DeclaratorCollection gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (DelegateDecl)

public override void ParseElement(
DelegateDecl gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (DelegateInvokeExpr)

public override void ParseElement(
DelegateInvokeExpr gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (DestructorDecl)

public override void ParseElement(
DestructorDecl gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (EnumDecl)

public override void ParseElement(
EnumDecl gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (EnumMemberDecl)

public override void ParseElement(
EnumMemberDecl gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (EventDecl)

public override void ParseElement(
EventDecl gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (EventRef)

public override void ParseElement(
EventRef gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (ExpressionCollection)

public override void ParseElement(
ExpressionCollection gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (ExprStmt)

public override void ParseElement(
ExprStmt gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (FieldDecl)

public override void ParseElement(
FieldDecl gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (FieldRef)

public override void ParseElement(
FieldRef gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (ForEachStmt)

public override void ParseElement(
ForEachStmt gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (GotoStmt)

public override void ParseElement(
GotoStmt gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (IfStmt)

public override void ParseElement(
IfStmt gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (Import)

public override void ParseElement(
Import gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (ImportCollection)

public override void ParseElement(
ImportCollection gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (IndexerDecl)

public override void ParseElement(
IndexerDecl gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (IndexerRef)

public override void ParseElement(
IndexerRef gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (IntegerLiteral)

public override void ParseElement(
IntegerLiteral gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (InterfaceDecl)

public override void ParseElement(
InterfaceDecl gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (IterationStmt)

public override void ParseElement(
IterationStmt gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (IterationType)

public override void ParseElement(
IterationType gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (LabeledStmt)

public override void ParseElement(
LabeledStmt gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (LinePragma)

public override void ParseElement(
LinePragma gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (LocalRef)

public override void ParseElement(
LocalRef gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (LockStmt)

public override void ParseElement(
LockStmt gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (MemberAccess)

public override void ParseElement(
MemberAccess gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (MemberDeclCollection)

public override void ParseElement(
MemberDeclCollection gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (MethodDecl)

public override void ParseElement(
MethodDecl gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (MethodInvokeExpr)

public override void ParseElement(
MethodInvokeExpr gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (MethodRef)

public override void ParseElement(
MethodRef gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (Modifiers)

public override void ParseElement(
Modifiers gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (NamespaceDecl)

public override void ParseElement(
NamespaceDecl gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (NamespaceDeclCollection)

public override void ParseElement(
NamespaceDeclCollection gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (NullLiteral)

public override void ParseElement(
NullLiteral gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (ObjectCreateExpr)

public override void ParseElement(
ObjectCreateExpr gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (OperatorDecl)

public override void ParseElement(
OperatorDecl gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (OverloadableOperator)

public override void ParseElement(
OverloadableOperator gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (Param)

public override void ParseElement(
Param gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (ParamCollection)

public override void ParseElement(
ParamCollection gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (ParamDecl)

public override void ParseElement(
ParamDecl gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (ParamDeclCollection)

public override void ParseElement(
ParamDeclCollection gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (ParamDirection)

public override void ParseElement(
ParamDirection gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (PostfixExpr)

public override void ParseElement(
PostfixExpr gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (PostfixOperator)

public override void ParseElement(
PostfixOperator gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (PropertyDecl)

public override void ParseElement(
PropertyDecl gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (PropertyRef)

public override void ParseElement(
PropertyRef gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (PropertySetValueRef)

public override void ParseElement(
PropertySetValueRef gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (RankSpecifier)

public override void ParseElement(
RankSpecifier gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (RankSpecifierCollection)

public override void ParseElement(
RankSpecifierCollection gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (RealLiteral)

public override void ParseElement(
RealLiteral gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (RemoveDelegateStmt)

public override void ParseElement(
RemoveDelegateStmt gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (ReturnStmt)

public override void ParseElement(
ReturnStmt gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (StatementCollection)

public override void ParseElement(
StatementCollection gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (StringLiteral)

public override void ParseElement(
StringLiteral gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (StructDecl)

public override void ParseElement(
StructDecl gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (SubExpr)

public override void ParseElement(
SubExpr gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (SwitchStmt)

public override void ParseElement(
SwitchStmt gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (TernaryExpr)

public override void ParseElement(
TernaryExpr gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (ThisRef)

public override void ParseElement(
ThisRef gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (ThrowStmt)

public override void ParseElement(
ThrowStmt gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (TryCatchFinallyStmt)

public override void ParseElement(
TryCatchFinallyStmt gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (TypeDeclCollection)

public override void ParseElement(
TypeDeclCollection gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (TypeModifiers)

public override void ParseElement(
TypeModifiers gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (TypeOfExpr)

public override void ParseElement(
TypeOfExpr gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (TypeRef)

public override void ParseElement(
TypeRef gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (TypeRefCollection)

public override void ParseElement(
TypeRefCollection gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (UnaryExpr)

public override void ParseElement(
UnaryExpr gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (UnaryOperator)

public override void ParseElement(
UnaryOperator gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (UncheckedStmt)

public override void ParseElement(
UncheckedStmt gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (UnknownReference)

public override void ParseElement(
UnknownReference gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (UsingStmt)

public override void ParseElement(
UsingStmt gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (VariableDecl)

public override void ParseElement(
VariableDecl gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ParseElement Method (VariableDeclStmt)

public override void ParseElement(
VariableDeclStmt gr
);

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace | CSharpGen.ParseElement Overload List


CSharpGen.ToString Method

public override string ToString();

See Also

CSharpGen Class | DDW.CSharp.Gen Namespace


LineWriter Class

Summary description for LineWriter.

For a list of all members of this type, see LineWriter Members.

System.Object
DDW.CSharp.Gen.LineWriter

public class LineWriter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Gen

Assembly: CSharp (in CSharp.dll)

See Also

LineWriter Members | DDW.CSharp.Gen Namespace


LineWriter Members

LineWriter overview

Public Instance Constructors

LineWriter Constructor

Public Instance Properties

Column
Indent
Line

Public Instance Methods

Close |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
Write | Overloaded.
WriteLine | Overloaded.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LineWriter Class | DDW.CSharp.Gen Namespace


LineWriter Constructor

public LineWriter(
TextWriter tw
);

See Also

LineWriter Class | DDW.CSharp.Gen Namespace


LineWriter Properties

The properties of the LineWriter class are listed below. For a complete list of LineWriter class members, see the LineWriter Members topic.

Public Instance Properties

Column
Indent
Line

See Also

LineWriter Class | DDW.CSharp.Gen Namespace


Column Property

Goblin - A Platform for 3D AR and VR Applications

LineWriter.Column Property

public int Column {get;}

See Also

LineWriter Class | DDW.CSharp.Gen Namespace


Indent Property

Goblin - A Platform for 3D AR and VR Applications

LineWriter.Indent Property

public int Indent {get; set;}

See Also

LineWriter Class | DDW.CSharp.Gen Namespace


Line Property

Goblin - A Platform for 3D AR and VR Applications

LineWriter.Line Property

public int Line {get;}

See Also

LineWriter Class | DDW.CSharp.Gen Namespace


LineWriter Methods

The methods of the LineWriter class are listed below. For a complete list of LineWriter class members, see the LineWriter Members topic.

Public Instance Methods

Close |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
Write | Overloaded.
WriteLine | Overloaded.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LineWriter Class | DDW.CSharp.Gen Namespace


LineWriter.Close Method

public void Close();

See Also

LineWriter Class | DDW.CSharp.Gen Namespace


LineWriter.ToString Method

public override string ToString();

See Also

LineWriter Class | DDW.CSharp.Gen Namespace


Write Method

Goblin - A Platform for 3D AR and VR Applications

LineWriter.Write Method

Overload List

public void Write(int);

public void Write(string);

See Also

LineWriter Class | DDW.CSharp.Gen Namespace


LineWriter.Write Method (Int32)

public void Write(
int s
);

See Also

LineWriter Class | DDW.CSharp.Gen Namespace | LineWriter.Write Overload List


LineWriter.Write Method (String)

public void Write(
string s
);

See Also

LineWriter Class | DDW.CSharp.Gen Namespace | LineWriter.Write Overload List


WriteLine Method

Goblin - A Platform for 3D AR and VR Applications

LineWriter.WriteLine Method

Overload List

public void WriteLine(int);

public void WriteLine(string);

See Also

LineWriter Class | DDW.CSharp.Gen Namespace


LineWriter.WriteLine Method (Int32)

public void WriteLine(
int s
);

See Also

LineWriter Class | DDW.CSharp.Gen Namespace | LineWriter.WriteLine Overload List


LineWriter.WriteLine Method (String)

public void WriteLine(
string s
);

See Also

LineWriter Class | DDW.CSharp.Gen Namespace | LineWriter.WriteLine Overload List


DDW.CSharp.Parse

Goblin - A Platform for 3D AR and VR Applications

DDW.CSharp.Parse Namespace

C# grammar (based on ecma-334 spec) -- Robin Debreuil Fri Mar 5, 2004 11:50 -- A (mostly) complete cs parser. It parses into a tree structure loosely based on the CodeDom. Does not yet do #if preprocessor segments, and no unsafe code (as of yet). You can test by downloading the CSharp.zip file and dragging cs files into CSharp.exe. The zip includes the grammar file, as well as the cs token classes (the grammar uses a heterogeneous tree, though that should be simple to turn off). -- permalink: http://www.debreuil.com/CSharp. TJP: copied src, exe to antlr.org and changed link as debreuil's links are dead.

Namespace hierarchy

Classes

Class | Description
AccessorNode |
Arg |
ArgDirection |
Args |
ArrayCreateExpr |
ArrayInitExpr |
ArrayRankExpr |
AssignExpr |
AssignOp |
Attribution |
BaseRefExpr |
BaseTypes |
BinaryExpr |
BinaryOp |
BooleanLiteral |
BreakStmt |
BuiltInType |
CastExpr |
CatchClause |
CharLiteral |
CheckedExpr |
CheckedStmt |
ClassNode |
CommentNode |
CompileUnit |
ConstantDeclStmt |
ConstantNode |
ConstructorNode |
ContinueStmt |
CSharpAST | The base class for all custom ASTs.
CSharpLexer |
CSharpParser |
CSharpTokenTypes |
CustomAttribute |
CustomAttributes |
Declarator |
DeclArg |
DeclArgs |
DelegateNode |
DestructorNode |
EnumMemberNode |
EnumNode |
EventNode |
Expression |
Expressions |
ExprStmt |
FieldNode |
FinallyStmt |
ForEachStmt |
GotoStmt |
Ident |
IfStmt |
IncStmt |
IndexerExpr |
IndexerNode |
InitStmt |
IntegerLiteral |
InterfaceNode |
InvokeExpr |
IterationStmt |
LabeledStmt |
LineNumberAST |
LockStmt |
MemberAccessExpr |
Members |
MethodNode |
ModifierAttributes |
NamespaceNode |
NullLiteral |
ObjectCreateExpr |
Op |
OperatorNode |
PostfixExpr |
PrimaryExpression |
PrimaryFollowExpression |
PrimitiveExpr |
PropertyNode |
QualIdent |
RealLiteral |
ReturnStmt |
Statement |
Statements |
StringLiteral |
StructNode |
SubExpr |
SwitchSection |
SwitchStmt |
TernaryExpr |
TernaryOp |
ThisRefExpr |
ThrowStmt |
TryCatchFinallyStmt |
TryStmt |
TypeMemberNode | Abstract base class for member types (Class, Method, Prop..) Name Attributes CustomAttributes Comments
TypeNode |
TypeOfExpr |
TypeRef |
Types |
UnaryExpr |
UnaryOp |
UncheckedExpr |
UncheckedStmt |
UsingNode |
UsingStmt |
VariableDeclStmt |


AccessorNode Class

For a list of all members of this type, see AccessorNode Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.TypeMemberNode
DDW.CSharp.Parse.AccessorNode

public class AccessorNode : TypeMemberNode

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

AccessorNode Members | DDW.CSharp.Parse Namespace


AccessorNode Members

AccessorNode overview

Public Instance Constructors

AccessorNode Constructor Initializes a new instance of the AccessorNode class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetGraph (inherited from TypeMemberNode) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseModifiers (inherited from TypeMemberNode) |

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

AccessorNode Class | DDW.CSharp.Parse Namespace


AccessorNode Constructor

Initializes a new instance of the AccessorNode class.

public AccessorNode();

See Also

AccessorNode Class | DDW.CSharp.Parse Namespace


AccessorNode Methods

The methods of the AccessorNode class are listed below. For a complete list of AccessorNode class members, see the AccessorNode Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetGraph (inherited from TypeMemberNode) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseModifiers (inherited from TypeMemberNode) |

See Also

AccessorNode Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

AccessorNode.GetGraph Method

Overload List

public override IGraph GetGraph();

public AccessorDecl GetGraph(AccessorDecl);

Inherited from CSharpAST.

public virtual IGraph GetGraph(IGraph);

Inherited from TypeMemberNode.

public MemberDecl GetGraph(MemberDecl);

See Also

AccessorNode Class | DDW.CSharp.Parse Namespace


AccessorNode.GetGraph Method ()

public override IGraph GetGraph();

See Also

AccessorNode Class | DDW.CSharp.Parse Namespace | AccessorNode.GetGraph Overload List


AccessorNode.GetGraph Method (AccessorDecl)

public AccessorDecl GetGraph(
AccessorDecl graph
);

See Also

AccessorNode Class | DDW.CSharp.Parse Namespace | AccessorNode.GetGraph Overload List


Arg Class

For a list of all members of this type, see Arg Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Expression
DDW.CSharp.Parse.Arg

public class Arg : Expression

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

Arg Members | DDW.CSharp.Parse Namespace


Arg Members

Arg overview

Public Instance Constructors

Arg Constructor Initializes a new instance of the Arg class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

Arg Class | DDW.CSharp.Parse Namespace


Arg Constructor

Initializes a new instance of the Arg class.

public Arg();

See Also

Arg Class | DDW.CSharp.Parse Namespace


Arg Methods

The methods of the Arg class are listed below. For a complete list of Arg class members, see the Arg Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Arg Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

Arg.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from Expression.

public virtual IGraph GetGraph(IGraph);

public Param GetGraph(Param);

See Also

Arg Class | DDW.CSharp.Parse Namespace


Arg.GetGraph Method ()

public override IGraph GetGraph();

See Also

Arg Class | DDW.CSharp.Parse Namespace | Arg.GetGraph Overload List


Arg.GetGraph Method (Param)

public Param GetGraph(
Param graph
);

See Also

Arg Class | DDW.CSharp.Parse Namespace | Arg.GetGraph Overload List


ArgDirection Class

For a list of all members of this type, see ArgDirection Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.ArgDirection

public class ArgDirection : CSharpAST

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

ArgDirection Members | DDW.CSharp.Parse Namespace


ArgDirection Members

ArgDirection overview

Public Instance Constructors

ArgDirection Constructor Initializes a new instance of the ArgDirection class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

ArgDirection Class | DDW.CSharp.Parse Namespace


ArgDirection Constructor

Initializes a new instance of the ArgDirection class.

public ArgDirection();

See Also

ArgDirection Class | DDW.CSharp.Parse Namespace


ArgDirection Methods

The methods of the ArgDirection class are listed below. For a complete list of ArgDirection class members, see the ArgDirection Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ArgDirection Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

ArgDirection.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from CSharpAST.

public virtual IGraph GetGraph(IGraph);

See Also

ArgDirection Class | DDW.CSharp.Parse Namespace


ArgDirection.GetGraph Method ()

public override IGraph GetGraph();

See Also

ArgDirection Class | DDW.CSharp.Parse Namespace | ArgDirection.GetGraph Overload List


Args Class

For a list of all members of this type, see Args Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Args

public class Args : CSharpAST

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

Args Members | DDW.CSharp.Parse Namespace


Args Members

Args overview

Public Instance Constructors

Args Constructor Initializes a new instance of the Args class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

Args Class | DDW.CSharp.Parse Namespace


Args Constructor

Initializes a new instance of the Args class.

public Args();

See Also

Args Class | DDW.CSharp.Parse Namespace


Args Methods

The methods of the Args class are listed below. For a complete list of Args class members, see the Args Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Args Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

Args.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from CSharpAST.

public virtual IGraph GetGraph(IGraph);

public ParamCollection GetGraph(ParamCollection);

See Also

Args Class | DDW.CSharp.Parse Namespace


Args.GetGraph Method ()

public override IGraph GetGraph();

See Also

Args Class | DDW.CSharp.Parse Namespace | Args.GetGraph Overload List


Args.GetGraph Method (ParamCollection)

public ParamCollection GetGraph(
ParamCollection graph
);

See Also

Args Class | DDW.CSharp.Parse Namespace | Args.GetGraph Overload List


ArrayCreateExpr Class

For a list of all members of this type, see ArrayCreateExpr Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Expression
DDW.CSharp.Parse.PrimaryExpression
DDW.CSharp.Parse.ArrayCreateExpr

public class ArrayCreateExpr : PrimaryExpression

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

ArrayCreateExpr Members | DDW.CSharp.Parse Namespace


ArrayCreateExpr Members

ArrayCreateExpr overview

Public Instance Constructors

ArrayCreateExpr Constructor Initializes a new instance of the ArrayCreateExpr class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

ArrayCreateExpr Class | DDW.CSharp.Parse Namespace


ArrayCreateExpr Constructor

Initializes a new instance of the ArrayCreateExpr class.

public ArrayCreateExpr();

See Also

ArrayCreateExpr Class | DDW.CSharp.Parse Namespace


ArrayCreateExpr Methods

The methods of the ArrayCreateExpr class are listed below. For a complete list of ArrayCreateExpr class members, see the ArrayCreateExpr Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ArrayCreateExpr Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

ArrayCreateExpr.GetGraph Method

Overload List

public override IGraph GetGraph();

public ArrayCreateExpr GetGraph(ArrayCreateExpr);

Inherited from Expression.

public virtual IGraph GetGraph(IGraph);

See Also

ArrayCreateExpr Class | DDW.CSharp.Parse Namespace


ArrayCreateExpr.GetGraph Method ()

public override IGraph GetGraph();

See Also

ArrayCreateExpr Class | DDW.CSharp.Parse Namespace | ArrayCreateExpr.GetGraph Overload List


ArrayCreateExpr.GetGraph Method (ArrayCreateExpr)

public ArrayCreateExpr GetGraph(
ArrayCreateExpr graph
);

See Also

ArrayCreateExpr Class | DDW.CSharp.Parse Namespace | ArrayCreateExpr.GetGraph Overload List


ArrayInitExpr Class

For a list of all members of this type, see ArrayInitExpr Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Expression
DDW.CSharp.Parse.PrimaryExpression
DDW.CSharp.Parse.ArrayInitExpr

public class ArrayInitExpr : PrimaryExpression

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

ArrayInitExpr Members | DDW.CSharp.Parse Namespace


ArrayInitExpr Members

ArrayInitExpr overview

Public Instance Constructors

ArrayInitExpr Constructor Initializes a new instance of the ArrayInitExpr class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

ArrayInitExpr Class | DDW.CSharp.Parse Namespace


ArrayInitExpr Constructor

Initializes a new instance of the ArrayInitExpr class.

public ArrayInitExpr();

See Also

ArrayInitExpr Class | DDW.CSharp.Parse Namespace


ArrayInitExpr Methods

The methods of the ArrayInitExpr class are listed below. For a complete list of ArrayInitExpr class members, see the ArrayInitExpr Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ArrayInitExpr Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

ArrayInitExpr.GetGraph Method

Overload List

public override IGraph GetGraph();

public ArrayInitializer GetGraph(ArrayInitializer);

Inherited from Expression.

public virtual IGraph GetGraph(IGraph);

See Also

ArrayInitExpr Class | DDW.CSharp.Parse Namespace


ArrayInitExpr.GetGraph Method ()

public override IGraph GetGraph();

See Also

ArrayInitExpr Class | DDW.CSharp.Parse Namespace | ArrayInitExpr.GetGraph Overload List


ArrayInitExpr.GetGraph Method (ArrayInitializer)

public ArrayInitializer GetGraph(
ArrayInitializer graph
);

See Also

ArrayInitExpr Class | DDW.CSharp.Parse Namespace | ArrayInitExpr.GetGraph Overload List


ArrayRankExpr Class

For a list of all members of this type, see ArrayRankExpr Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Expression
DDW.CSharp.Parse.ArrayRankExpr

public class ArrayRankExpr : Expression

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

ArrayRankExpr Members | DDW.CSharp.Parse Namespace


ArrayRankExpr Members

ArrayRankExpr overview

Public Instance Constructors

ArrayRankExpr Constructor Initializes a new instance of the ArrayRankExpr class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

ArrayRankExpr Class | DDW.CSharp.Parse Namespace


ArrayRankExpr Constructor

Initializes a new instance of the ArrayRankExpr class.

public ArrayRankExpr();

See Also

ArrayRankExpr Class | DDW.CSharp.Parse Namespace


AssignExpr Class

For a list of all members of this type, see AssignExpr Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Expression
DDW.CSharp.Parse.AssignExpr

public class AssignExpr : Expression

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

AssignExpr Members | DDW.CSharp.Parse Namespace


AssignExpr Members

AssignExpr overview

Public Instance Constructors

AssignExpr Constructor Initializes a new instance of the AssignExpr class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

AssignExpr Class | DDW.CSharp.Parse Namespace


AssignExpr Constructor

Initializes a new instance of the AssignExpr class.

public AssignExpr();

See Also

AssignExpr Class | DDW.CSharp.Parse Namespace


AssignExpr Methods

The methods of the AssignExpr class are listed below. For a complete list of AssignExpr class members, see the AssignExpr Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AssignExpr Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

AssignExpr.GetGraph Method

Overload List

public override IGraph GetGraph();

public AssignExpr GetGraph(AssignExpr);

Inherited from Expression.

public virtual IGraph GetGraph(IGraph);

See Also

AssignExpr Class | DDW.CSharp.Parse Namespace


AssignExpr.GetGraph Method ()

public override IGraph GetGraph();

See Also

AssignExpr Class | DDW.CSharp.Parse Namespace | AssignExpr.GetGraph Overload List


AssignExpr.GetGraph Method (AssignExpr)

public AssignExpr GetGraph(
AssignExpr graph
);

See Also

AssignExpr Class | DDW.CSharp.Parse Namespace | AssignExpr.GetGraph Overload List


AssignOp Class

For a list of all members of this type, see AssignOp Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.AssignOp

public class AssignOp : CSharpAST

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

AssignOp Members | DDW.CSharp.Parse Namespace


AssignOp Members

AssignOp overview

Public Instance Constructors

AssignOp Constructor Initializes a new instance of the AssignOp class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

AssignOp Class | DDW.CSharp.Parse Namespace


AssignOp Constructor

Initializes a new instance of the AssignOp class.

public AssignOp();

See Also

AssignOp Class | DDW.CSharp.Parse Namespace


AssignOp Methods

The methods of the AssignOp class are listed below. For a complete list of AssignOp class members, see the AssignOp Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AssignOp Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

AssignOp.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from CSharpAST.

public virtual IGraph GetGraph(IGraph);

See Also

AssignOp Class | DDW.CSharp.Parse Namespace


AssignOp.GetGraph Method ()

public override IGraph GetGraph();

See Also

AssignOp Class | DDW.CSharp.Parse Namespace | AssignOp.GetGraph Overload List


Attribution Class

For a list of all members of this type, see Attribution Members.

System.Object
DDW.CSharp.Parse.Attribution

public class Attribution

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

Attribution Members | DDW.CSharp.Parse Namespace


Attribution Members

Attribution overview

Public Static Methods

AttributeExpressions |
ConvertDistance | Returns true if the origin type can auto convert to the target type.
CoverType | Returns the lowest common type of the two arguments, based on C#'s type conversion tables.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Attribution Class | DDW.CSharp.Parse Namespace


Attribution Methods

The methods of the Attribution class are listed below. For a complete list of Attribution class members, see the Attribution Members topic.

Public Static Methods

AttributeExpressions |
ConvertDistance | Returns true if the origin type can auto convert to the target type.
CoverType | Returns the lowest common type of the two arguments, based on C#'s type conversion tables.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Attribution Class | DDW.CSharp.Parse Namespace


Attribution.AttributeExpressions Method

public static void AttributeExpressions(
ExpressionRootCollection erc
);

See Also

Attribution Class | DDW.CSharp.Parse Namespace


Attribution.ConvertDistance Method

Returns true if the origin type can auto convert to the target type.

public static int ConvertDistance(
IDefinition origin,
IDefinition target
);

Parameters

origin
target

Return Value

The common type.

See Also

Attribution Class | DDW.CSharp.Parse Namespace


Attribution.CoverType Method

Returns the lowest common type of the two arguments, based on C#'s type conversion tables.

public static bool CoverType(
IDefinition type1,
IDefinition type2
);

Parameters

type1
First type to compare.
type2
Second type to compare.

Return Value

The common type.

See Also

Attribution Class | DDW.CSharp.Parse Namespace


BaseRefExpr Class

For a list of all members of this type, see BaseRefExpr Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Expression
DDW.CSharp.Parse.PrimaryExpression
DDW.CSharp.Parse.BaseRefExpr

public class BaseRefExpr : PrimaryExpression

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

BaseRefExpr Members | DDW.CSharp.Parse Namespace


BaseRefExpr Members

BaseRefExpr overview

Public Instance Constructors

BaseRefExpr Constructor Initializes a new instance of the BaseRefExpr class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

BaseRefExpr Class | DDW.CSharp.Parse Namespace


BaseRefExpr Constructor

Initializes a new instance of the BaseRefExpr class.

public BaseRefExpr();

See Also

BaseRefExpr Class | DDW.CSharp.Parse Namespace


BaseRefExpr Methods

The methods of the BaseRefExpr class are listed below. For a complete list of BaseRefExpr class members, see the BaseRefExpr Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BaseRefExpr Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

BaseRefExpr.GetGraph Method

Overload List

public override IGraph GetGraph();

public BaseRef GetGraph(BaseRef);

Inherited from Expression.

public virtual IGraph GetGraph(IGraph);

See Also

BaseRefExpr Class | DDW.CSharp.Parse Namespace


BaseRefExpr.GetGraph Method ()

public override IGraph GetGraph();

See Also

BaseRefExpr Class | DDW.CSharp.Parse Namespace | BaseRefExpr.GetGraph Overload List


BaseRefExpr.GetGraph Method (BaseRef)

public BaseRef GetGraph(
BaseRef graph
);

See Also

BaseRefExpr Class | DDW.CSharp.Parse Namespace | BaseRefExpr.GetGraph Overload List


BaseTypes Class

For a list of all members of this type, see BaseTypes Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.BaseTypes

public class BaseTypes : CSharpAST

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

BaseTypes Members | DDW.CSharp.Parse Namespace


BaseTypes Members

BaseTypes overview

Public Instance Constructors

BaseTypes Constructor Initializes a new instance of the BaseTypes class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

BaseTypes Class | DDW.CSharp.Parse Namespace


BaseTypes Constructor

Initializes a new instance of the BaseTypes class.

public BaseTypes();

See Also

BaseTypes Class | DDW.CSharp.Parse Namespace


BaseTypes Methods

The methods of the BaseTypes class are listed below. For a complete list of BaseTypes class members, see the BaseTypes Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BaseTypes Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

BaseTypes.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from CSharpAST.

public virtual IGraph GetGraph(IGraph);

public TypeRefCollection GetGraph(TypeRefCollection);

See Also

BaseTypes Class | DDW.CSharp.Parse Namespace


BaseTypes.GetGraph Method ()

public override IGraph GetGraph();

See Also

BaseTypes Class | DDW.CSharp.Parse Namespace | BaseTypes.GetGraph Overload List


BaseTypes.GetGraph Method (TypeRefCollection)

public TypeRefCollection GetGraph(
TypeRefCollection graph
);

See Also

BaseTypes Class | DDW.CSharp.Parse Namespace | BaseTypes.GetGraph Overload List


BinaryExpr Class

For a list of all members of this type, see BinaryExpr Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Expression
DDW.CSharp.Parse.BinaryExpr

public class BinaryExpr : Expression

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

BinaryExpr Members | DDW.CSharp.Parse Namespace


BinaryExpr Members

BinaryExpr overview

Public Instance Constructors

BinaryExpr Constructor Initializes a new instance of the BinaryExpr class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

BinaryExpr Class | DDW.CSharp.Parse Namespace


BinaryExpr Constructor

Initializes a new instance of the BinaryExpr class.

public BinaryExpr();

See Also

BinaryExpr Class | DDW.CSharp.Parse Namespace


BinaryExpr Methods

The methods of the BinaryExpr class are listed below. For a complete list of BinaryExpr class members, see the BinaryExpr Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BinaryExpr Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

BinaryExpr.GetGraph Method

Overload List

public override IGraph GetGraph();

public BinaryExpr GetGraph(BinaryExpr);

Inherited from Expression.

public virtual IGraph GetGraph(IGraph);

See Also

BinaryExpr Class | DDW.CSharp.Parse Namespace


BinaryExpr.GetGraph Method ()

public override IGraph GetGraph();

See Also

BinaryExpr Class | DDW.CSharp.Parse Namespace | BinaryExpr.GetGraph Overload List


BinaryExpr.GetGraph Method (BinaryExpr)

public BinaryExpr GetGraph(
BinaryExpr graph
);

See Also

BinaryExpr Class | DDW.CSharp.Parse Namespace | BinaryExpr.GetGraph Overload List


BinaryOp Class

For a list of all members of this type, see BinaryOp Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.BinaryOp

public class BinaryOp : CSharpAST

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

BinaryOp Members | DDW.CSharp.Parse Namespace


BinaryOp Members

BinaryOp overview

Public Instance Constructors

BinaryOp Constructor Initializes a new instance of the BinaryOp class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

BinaryOp Class | DDW.CSharp.Parse Namespace


BinaryOp Constructor

Initializes a new instance of the BinaryOp class.

public BinaryOp();

See Also

BinaryOp Class | DDW.CSharp.Parse Namespace


BinaryOp Methods

The methods of the BinaryOp class are listed below. For a complete list of BinaryOp class members, see the BinaryOp Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BinaryOp Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

BinaryOp.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from CSharpAST.

public virtual IGraph GetGraph(IGraph);

See Also

BinaryOp Class | DDW.CSharp.Parse Namespace


BinaryOp.GetGraph Method ()

public override IGraph GetGraph();

See Also

BinaryOp Class | DDW.CSharp.Parse Namespace | BinaryOp.GetGraph Overload List


BooleanLiteral Class

For a list of all members of this type, see BooleanLiteral Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Expression
DDW.CSharp.Parse.PrimaryExpression
DDW.CSharp.Parse.PrimitiveExpr
DDW.CSharp.Parse.BooleanLiteral

public class BooleanLiteral : PrimitiveExpr

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

BooleanLiteral Members | DDW.CSharp.Parse Namespace


BooleanLiteral Members

BooleanLiteral overview

Public Instance Constructors

BooleanLiteral Constructor Initializes a new instance of the BooleanLiteral class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

BooleanLiteral Class | DDW.CSharp.Parse Namespace


BooleanLiteral Constructor

Initializes a new instance of the BooleanLiteral class.

public BooleanLiteral();

See Also

BooleanLiteral Class | DDW.CSharp.Parse Namespace


BooleanLiteral Methods

The methods of the BooleanLiteral class are listed below. For a complete list of BooleanLiteral class members, see the BooleanLiteral Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BooleanLiteral Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

BooleanLiteral.GetGraph Method

Overload List

public override IGraph GetGraph();

public BooleanLiteral GetGraph(BooleanLiteral);

Inherited from Expression.

public virtual IGraph GetGraph(IGraph);

See Also

BooleanLiteral Class | DDW.CSharp.Parse Namespace


BooleanLiteral.GetGraph Method ()

public override IGraph GetGraph();

See Also

BooleanLiteral Class | DDW.CSharp.Parse Namespace | BooleanLiteral.GetGraph Overload List


BooleanLiteral.GetGraph Method (BooleanLiteral)

public BooleanLiteral GetGraph(
BooleanLiteral graph
);

See Also

BooleanLiteral Class | DDW.CSharp.Parse Namespace | BooleanLiteral.GetGraph Overload List


BreakStmt Class

For a list of all members of this type, see BreakStmt Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Statement
DDW.CSharp.Parse.BreakStmt

public class BreakStmt : Statement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

BreakStmt Members | DDW.CSharp.Parse Namespace


BreakStmt Members

BreakStmt overview

Public Instance Constructors

BreakStmt Constructor Initializes a new instance of the BreakStmt class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGraph (inherited from Statement) | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

BreakStmt Class | DDW.CSharp.Parse Namespace


BreakStmt Constructor

Initializes a new instance of the BreakStmt class.

public BreakStmt();

See Also

BreakStmt Class | DDW.CSharp.Parse Namespace


BreakStmt Methods

The methods of the BreakStmt class are listed below. For a complete list of BreakStmt class members, see the BreakStmt Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGraph (inherited from Statement) | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BreakStmt Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

BreakStmt.GetGraph Method

Overload List

public override IGraph GetGraph();

public BreakStmt GetGraph(BreakStmt);

Inherited from Statement.

protected virtual IGraph GetGraph(IGraph);

See Also

BreakStmt Class | DDW.CSharp.Parse Namespace


BreakStmt.GetGraph Method ()

public override IGraph GetGraph();

See Also

BreakStmt Class | DDW.CSharp.Parse Namespace | BreakStmt.GetGraph Overload List


BreakStmt.GetGraph Method (BreakStmt)

public BreakStmt GetGraph(
BreakStmt graph
);

See Also

BreakStmt Class | DDW.CSharp.Parse Namespace | BreakStmt.GetGraph Overload List


BuiltInType Class

For a list of all members of this type, see BuiltInType Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Expression
DDW.CSharp.Parse.PrimaryExpression
DDW.CSharp.Parse.BuiltInType

public class BuiltInType : PrimaryExpression

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

BuiltInType Members | DDW.CSharp.Parse Namespace


BuiltInType Members

BuiltInType overview

Public Instance Constructors

BuiltInType Constructor Initializes a new instance of the BuiltInType class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

BuiltInType Class | DDW.CSharp.Parse Namespace


BuiltInType Constructor

Initializes a new instance of the BuiltInType class.

public BuiltInType();

See Also

BuiltInType Class | DDW.CSharp.Parse Namespace


BuiltInType Methods

The methods of the BuiltInType class are listed below. For a complete list of BuiltInType class members, see the BuiltInType Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BuiltInType Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

BuiltInType.GetGraph Method

Overload List

public override IGraph GetGraph();

public BuiltInType GetGraph(BuiltInType);

Inherited from Expression.

public virtual IGraph GetGraph(IGraph);

See Also

BuiltInType Class | DDW.CSharp.Parse Namespace


BuiltInType.GetGraph Method ()

public override IGraph GetGraph();

See Also

BuiltInType Class | DDW.CSharp.Parse Namespace | BuiltInType.GetGraph Overload List


BuiltInType.GetGraph Method (BuiltInType)

public BuiltInType GetGraph(
BuiltInType graph
);

See Also

BuiltInType Class | DDW.CSharp.Parse Namespace | BuiltInType.GetGraph Overload List


CastExpr Class

For a list of all members of this type, see CastExpr Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Expression
DDW.CSharp.Parse.CastExpr

public class CastExpr : Expression

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

CastExpr Members | DDW.CSharp.Parse Namespace


CastExpr Members

CastExpr overview

Public Instance Constructors

CastExpr Constructor Initializes a new instance of the CastExpr class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

CastExpr Class | DDW.CSharp.Parse Namespace


CastExpr Constructor

Initializes a new instance of the CastExpr class.

public CastExpr();

See Also

CastExpr Class | DDW.CSharp.Parse Namespace


CastExpr Methods

The methods of the CastExpr class are listed below. For a complete list of CastExpr class members, see the CastExpr Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CastExpr Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

CastExpr.GetGraph Method

Overload List

public override IGraph GetGraph();

public CastExpr GetGraph(CastExpr);

Inherited from Expression.

public virtual IGraph GetGraph(IGraph);

See Also

CastExpr Class | DDW.CSharp.Parse Namespace


CastExpr.GetGraph Method ()

public override IGraph GetGraph();

See Also

CastExpr Class | DDW.CSharp.Parse Namespace | CastExpr.GetGraph Overload List


CastExpr.GetGraph Method (CastExpr)

public CastExpr GetGraph(
CastExpr graph
);

See Also

CastExpr Class | DDW.CSharp.Parse Namespace | CastExpr.GetGraph Overload List


CatchClause Class

For a list of all members of this type, see CatchClause Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Statement
DDW.CSharp.Parse.CatchClause

public class CatchClause : Statement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

CatchClause Members | DDW.CSharp.Parse Namespace


CatchClause Members

CatchClause overview

Public Instance Constructors

CatchClause Constructor Initializes a new instance of the CatchClause class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGraph (inherited from Statement) | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

CatchClause Class | DDW.CSharp.Parse Namespace


CatchClause Constructor

Initializes a new instance of the CatchClause class.

public CatchClause();

See Also

CatchClause Class | DDW.CSharp.Parse Namespace


CatchClause Methods

The methods of the CatchClause class are listed below. For a complete list of CatchClause class members, see the CatchClause Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGraph (inherited from Statement) | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CatchClause Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

CatchClause.GetGraph Method

Overload List

public override IGraph GetGraph();

public Catch GetGraph(Catch);

Inherited from Statement.

protected virtual IGraph GetGraph(IGraph);

See Also

CatchClause Class | DDW.CSharp.Parse Namespace


CatchClause.GetGraph Method ()

public override IGraph GetGraph();

See Also

CatchClause Class | DDW.CSharp.Parse Namespace | CatchClause.GetGraph Overload List


CatchClause.GetGraph Method (Catch)

public Catch GetGraph(
Catch graph
);

See Also

CatchClause Class | DDW.CSharp.Parse Namespace | CatchClause.GetGraph Overload List


CharLiteral Class

For a list of all members of this type, see CharLiteral Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Expression
DDW.CSharp.Parse.PrimaryExpression
DDW.CSharp.Parse.PrimitiveExpr
DDW.CSharp.Parse.CharLiteral

public class CharLiteral : PrimitiveExpr

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

CharLiteral Members | DDW.CSharp.Parse Namespace


CharLiteral Members

CharLiteral overview

Public Instance Constructors

CharLiteral Constructor Initializes a new instance of the CharLiteral class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

CharLiteral Class | DDW.CSharp.Parse Namespace


CharLiteral Constructor

Initializes a new instance of the CharLiteral class.

public CharLiteral();

See Also

CharLiteral Class | DDW.CSharp.Parse Namespace


CharLiteral Methods

The methods of the CharLiteral class are listed below. For a complete list of CharLiteral class members, see the CharLiteral Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CharLiteral Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

CharLiteral.GetGraph Method

Overload List

public override IGraph GetGraph();

public CharLiteral GetGraph(CharLiteral);

Inherited from Expression.

public virtual IGraph GetGraph(IGraph);

See Also

CharLiteral Class | DDW.CSharp.Parse Namespace


CharLiteral.GetGraph Method ()

public override IGraph GetGraph();

See Also

CharLiteral Class | DDW.CSharp.Parse Namespace | CharLiteral.GetGraph Overload List


CharLiteral.GetGraph Method (CharLiteral)

public CharLiteral GetGraph(
CharLiteral graph
);

See Also

CharLiteral Class | DDW.CSharp.Parse Namespace | CharLiteral.GetGraph Overload List


CheckedExpr Class

For a list of all members of this type, see CheckedExpr Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Expression
DDW.CSharp.Parse.PrimaryExpression
DDW.CSharp.Parse.CheckedExpr

public class CheckedExpr : PrimaryExpression

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

CheckedExpr Members | DDW.CSharp.Parse Namespace


CheckedExpr Members

CheckedExpr overview

Public Instance Constructors

CheckedExpr Constructor Initializes a new instance of the CheckedExpr class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

CheckedExpr Class | DDW.CSharp.Parse Namespace


CheckedExpr Constructor

Initializes a new instance of the CheckedExpr class.

public CheckedExpr();

See Also

CheckedExpr Class | DDW.CSharp.Parse Namespace


CheckedStmt Class

For a list of all members of this type, see CheckedStmt Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Statement
DDW.CSharp.Parse.CheckedStmt

public class CheckedStmt : Statement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

CheckedStmt Members | DDW.CSharp.Parse Namespace


CheckedStmt Members

CheckedStmt overview

Public Instance Constructors

CheckedStmt Constructor Initializes a new instance of the CheckedStmt class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGraph (inherited from Statement) | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

CheckedStmt Class | DDW.CSharp.Parse Namespace


CheckedStmt Constructor

Initializes a new instance of the CheckedStmt class.

public CheckedStmt();

See Also

CheckedStmt Class | DDW.CSharp.Parse Namespace


CheckedStmt Methods

The methods of the CheckedStmt class are listed below. For a complete list of CheckedStmt class members, see the CheckedStmt Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGraph (inherited from Statement) | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CheckedStmt Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

CheckedStmt.GetGraph Method

Overload List

public override IGraph GetGraph();

public CheckedStmt GetGraph(CheckedStmt);

Inherited from Statement.

protected virtual IGraph GetGraph(IGraph);

See Also

CheckedStmt Class | DDW.CSharp.Parse Namespace


CheckedStmt.GetGraph Method ()

public override IGraph GetGraph();

See Also

CheckedStmt Class | DDW.CSharp.Parse Namespace | CheckedStmt.GetGraph Overload List


CheckedStmt.GetGraph Method (CheckedStmt)

public CheckedStmt GetGraph(
CheckedStmt graph
);

See Also

CheckedStmt Class | DDW.CSharp.Parse Namespace | CheckedStmt.GetGraph Overload List


ClassNode Class

For a list of all members of this type, see ClassNode Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.TypeMemberNode
DDW.CSharp.Parse.TypeNode
DDW.CSharp.Parse.ClassNode

public class ClassNode : TypeNode

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

ClassNode Members | DDW.CSharp.Parse Namespace


ClassNode Members

ClassNode overview

Public Instance Constructors

ClassNode Constructor Initializes a new instance of the ClassNode class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetGraph (inherited from TypeNode) | Overloaded.
GetGraph (inherited from TypeMemberNode) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseModifiers (inherited from TypeMemberNode) |
ParseTypeModifiers (inherited from TypeNode) |

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

ClassNode Class | DDW.CSharp.Parse Namespace


ClassNode Constructor

Initializes a new instance of the ClassNode class.

public ClassNode();

See Also

ClassNode Class | DDW.CSharp.Parse Namespace


ClassNode Methods

The methods of the ClassNode class are listed below. For a complete list of ClassNode class members, see the ClassNode Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetGraph (inherited from TypeNode) | Overloaded.
GetGraph (inherited from TypeMemberNode) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseModifiers (inherited from TypeMemberNode) |
ParseTypeModifiers (inherited from TypeNode) |

See Also

ClassNode Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

ClassNode.GetGraph Method

Overload List

public override IGraph GetGraph();

public ClassDecl GetGraph(ClassDecl);

Inherited from CSharpAST.

public virtual IGraph GetGraph(IGraph);

Inherited from TypeMemberNode.

public MemberDecl GetGraph(MemberDecl);

Inherited from TypeNode.

public TypeDecl GetGraph(TypeDecl);

See Also

ClassNode Class | DDW.CSharp.Parse Namespace


ClassNode.GetGraph Method ()

public override IGraph GetGraph();

See Also

ClassNode Class | DDW.CSharp.Parse Namespace | ClassNode.GetGraph Overload List


ClassNode.GetGraph Method (ClassDecl)

public ClassDecl GetGraph(
ClassDecl graph
);

See Also

ClassNode Class | DDW.CSharp.Parse Namespace | ClassNode.GetGraph Overload List


CommentNode Class

For a list of all members of this type, see CommentNode Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Statement
DDW.CSharp.Parse.CommentNode

public class CommentNode : Statement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

CommentNode Members | DDW.CSharp.Parse Namespace


CommentNode Members

CommentNode overview

Public Instance Constructors

CommentNode Constructor Initializes a new instance of the CommentNode class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGraph (inherited from Statement) | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

CommentNode Class | DDW.CSharp.Parse Namespace


CommentNode Constructor

Initializes a new instance of the CommentNode class.

public CommentNode();

See Also

CommentNode Class | DDW.CSharp.Parse Namespace


CommentNode Methods

The methods of the CommentNode class are listed below. For a complete list of CommentNode class members, see the CommentNode Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGraph (inherited from Statement) | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CommentNode Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

CommentNode.GetGraph Method

Overload List

public override IGraph GetGraph();

public CommentStmt GetGraph(CommentStmt);

public CommentStmtCollection GetGraph(CommentStmtCollection);

Inherited from Statement.

protected virtual IGraph GetGraph(IGraph);

See Also

CommentNode Class | DDW.CSharp.Parse Namespace


CommentNode.GetGraph Method ()

public override IGraph GetGraph();

See Also

CommentNode Class | DDW.CSharp.Parse Namespace | CommentNode.GetGraph Overload List


CommentNode.GetGraph Method (CommentStmt)

public CommentStmt GetGraph(
CommentStmt graph
);

See Also

CommentNode Class | DDW.CSharp.Parse Namespace | CommentNode.GetGraph Overload List


CommentNode.GetGraph Method (CommentStmtCollection)

public CommentStmtCollection GetGraph(
CommentStmtCollection graph
);

See Also

CommentNode Class | DDW.CSharp.Parse Namespace | CommentNode.GetGraph Overload List


CompileUnit Class

For a list of all members of this type, see CompileUnit Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.CompileUnit

public class CompileUnit : CSharpAST

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

CompileUnit Members | DDW.CSharp.Parse Namespace


CompileUnit Members

CompileUnit overview

Public Instance Constructors

CompileUnit Constructor Initializes a new instance of the CompileUnit class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

CompileUnit Class | DDW.CSharp.Parse Namespace


CompileUnit Constructor

Initializes a new instance of the CompileUnit class.

public CompileUnit();

See Also

CompileUnit Class | DDW.CSharp.Parse Namespace


CompileUnit Methods

The methods of the CompileUnit class are listed below. For a complete list of CompileUnit class members, see the CompileUnit Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CompileUnit Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

CompileUnit.GetGraph Method

Overload List

public override IGraph GetGraph();

public CompileUnit GetGraph(CompileUnit);

Inherited from CSharpAST.

public virtual IGraph GetGraph(IGraph);

See Also

CompileUnit Class | DDW.CSharp.Parse Namespace


CompileUnit.GetGraph Method ()

public override IGraph GetGraph();

See Also

CompileUnit Class | DDW.CSharp.Parse Namespace | CompileUnit.GetGraph Overload List


CompileUnit.GetGraph Method (CompileUnit)

public CompileUnit GetGraph(
CompileUnit graph
);

See Also

CompileUnit Class | DDW.CSharp.Parse Namespace | CompileUnit.GetGraph Overload List


ConstantDeclStmt Class

For a list of all members of this type, see ConstantDeclStmt Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Statement
DDW.CSharp.Parse.ConstantDeclStmt

public class ConstantDeclStmt : Statement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

ConstantDeclStmt Members | DDW.CSharp.Parse Namespace


ConstantDeclStmt Members

ConstantDeclStmt overview

Public Instance Constructors

ConstantDeclStmt Constructor Initializes a new instance of the ConstantDeclStmt class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGraph (inherited from Statement) | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

ConstantDeclStmt Class | DDW.CSharp.Parse Namespace


ConstantDeclStmt Constructor

Initializes a new instance of the ConstantDeclStmt class.

public ConstantDeclStmt();

See Also

ConstantDeclStmt Class | DDW.CSharp.Parse Namespace


ConstantDeclStmt Methods

The methods of the ConstantDeclStmt class are listed below. For a complete list of ConstantDeclStmt class members, see the ConstantDeclStmt Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGraph (inherited from Statement) | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConstantDeclStmt Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

ConstantDeclStmt.GetGraph Method

Overload List

public override IGraph GetGraph();

public ConstantDeclStmt GetGraph(ConstantDeclStmt);

Inherited from Statement.

protected virtual IGraph GetGraph(IGraph);

See Also

ConstantDeclStmt Class | DDW.CSharp.Parse Namespace


ConstantDeclStmt.GetGraph Method ()

public override IGraph GetGraph();

See Also

ConstantDeclStmt Class | DDW.CSharp.Parse Namespace | ConstantDeclStmt.GetGraph Overload List


ConstantDeclStmt.GetGraph Method (ConstantDeclStmt)

public ConstantDeclStmt GetGraph(
ConstantDeclStmt graph
);

See Also

ConstantDeclStmt Class | DDW.CSharp.Parse Namespace | ConstantDeclStmt.GetGraph Overload List


ConstantNode Class

For a list of all members of this type, see ConstantNode Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.TypeMemberNode
DDW.CSharp.Parse.ConstantNode

public class ConstantNode : TypeMemberNode

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

ConstantNode Members | DDW.CSharp.Parse Namespace


ConstantNode Members

ConstantNode overview

Public Instance Constructors

ConstantNode Constructor Initializes a new instance of the ConstantNode class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetGraph (inherited from TypeMemberNode) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseModifiers (inherited from TypeMemberNode) |

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

ConstantNode Class | DDW.CSharp.Parse Namespace


ConstantNode Constructor

Initializes a new instance of the ConstantNode class.

public ConstantNode();

See Also

ConstantNode Class | DDW.CSharp.Parse Namespace


ConstantNode Methods

The methods of the ConstantNode class are listed below. For a complete list of ConstantNode class members, see the ConstantNode Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetGraph (inherited from TypeMemberNode) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseModifiers (inherited from TypeMemberNode) |

See Also

ConstantNode Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

ConstantNode.GetGraph Method

Overload List

public override IGraph GetGraph();

public ConstantDecl GetGraph(ConstantDecl);

Inherited from CSharpAST.

public virtual IGraph GetGraph(IGraph);

Inherited from TypeMemberNode.

public MemberDecl GetGraph(MemberDecl);

See Also

ConstantNode Class | DDW.CSharp.Parse Namespace


ConstantNode.GetGraph Method ()

public override IGraph GetGraph();

See Also

ConstantNode Class | DDW.CSharp.Parse Namespace | ConstantNode.GetGraph Overload List


ConstantNode.GetGraph Method (ConstantDecl)

public ConstantDecl GetGraph(
ConstantDecl graph
);

See Also

ConstantNode Class | DDW.CSharp.Parse Namespace | ConstantNode.GetGraph Overload List


ConstructorNode Class

For a list of all members of this type, see ConstructorNode Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.TypeMemberNode
DDW.CSharp.Parse.ConstructorNode

public class ConstructorNode : TypeMemberNode

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

ConstructorNode Members | DDW.CSharp.Parse Namespace


ConstructorNode Members

ConstructorNode overview

Public Instance Constructors

ConstructorNode Constructor Initializes a new instance of the ConstructorNode class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetGraph (inherited from TypeMemberNode) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseModifiers (inherited from TypeMemberNode) |

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

ConstructorNode Class | DDW.CSharp.Parse Namespace


ConstructorNode Constructor

Initializes a new instance of the ConstructorNode class.

public ConstructorNode();

See Also

ConstructorNode Class | DDW.CSharp.Parse Namespace


ConstructorNode Methods

The methods of the ConstructorNode class are listed below. For a complete list of ConstructorNode class members, see the ConstructorNode Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetGraph (inherited from TypeMemberNode) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseModifiers (inherited from TypeMemberNode) |

See Also

ConstructorNode Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

ConstructorNode.GetGraph Method

Overload List

public override IGraph GetGraph();

public ConstructorDecl GetGraph(ConstructorDecl);

Inherited from CSharpAST.

public virtual IGraph GetGraph(IGraph);

Inherited from TypeMemberNode.

public MemberDecl GetGraph(MemberDecl);

See Also

ConstructorNode Class | DDW.CSharp.Parse Namespace


ConstructorNode.GetGraph Method ()

public override IGraph GetGraph();

See Also

ConstructorNode Class | DDW.CSharp.Parse Namespace | ConstructorNode.GetGraph Overload List


ConstructorNode.GetGraph Method (ConstructorDecl)

public ConstructorDecl GetGraph(
ConstructorDecl graph
);

See Also

ConstructorNode Class | DDW.CSharp.Parse Namespace | ConstructorNode.GetGraph Overload List


ContinueStmt Class

For a list of all members of this type, see ContinueStmt Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Statement
DDW.CSharp.Parse.ContinueStmt

public class ContinueStmt : Statement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

ContinueStmt Members | DDW.CSharp.Parse Namespace


ContinueStmt Members

ContinueStmt overview

Public Instance Constructors

ContinueStmt Constructor Initializes a new instance of the ContinueStmt class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGraph (inherited from Statement) | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

ContinueStmt Class | DDW.CSharp.Parse Namespace


ContinueStmt Constructor

Initializes a new instance of the ContinueStmt class.

public ContinueStmt();

See Also

ContinueStmt Class | DDW.CSharp.Parse Namespace


ContinueStmt Methods

The methods of the ContinueStmt class are listed below. For a complete list of ContinueStmt class members, see the ContinueStmt Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGraph (inherited from Statement) | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ContinueStmt Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

ContinueStmt.GetGraph Method

Overload List

public override IGraph GetGraph();

public ContinueStmt GetGraph(ContinueStmt);

Inherited from Statement.

protected virtual IGraph GetGraph(IGraph);

See Also

ContinueStmt Class | DDW.CSharp.Parse Namespace


ContinueStmt.GetGraph Method ()

public override IGraph GetGraph();

See Also

ContinueStmt Class | DDW.CSharp.Parse Namespace | ContinueStmt.GetGraph Overload List


ContinueStmt.GetGraph Method (ContinueStmt)

public ContinueStmt GetGraph(
ContinueStmt graph
);

See Also

ContinueStmt Class | DDW.CSharp.Parse Namespace | ContinueStmt.GetGraph Overload List


CSharpAST Class

The base class for all custom ASTs.

For a list of all members of this type, see CSharpAST Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
Derived types

public class CSharpAST : BaseAST

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

CSharpAST Members | DDW.CSharp.Parse Namespace


CSharpAST Members

CSharpAST overview

Public Static Fields

defCount

Public Static Properties

CurrentScope |
GlobalScope |
ScopeTable |
SymbolTable | Stores un-attributed symbols until all types/vars are declared.

Public Static Methods

resetStatics

Public Instance Constructors

CSharpAST Overloaded. Initializes a new instance of the CSharpAST class.

Public Instance Properties

FileName |
LinePragma |
Text (inherited from antlr.BaseAST) |
Type | Gets or sets the Type of the node (TODO: make this enum)
UserData | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition |
addChild (inherited from antlr.BaseAST) |
AddDefinition |
AddRootExpression | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText |
getType |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize | Overloaded.
OpenBlockScope |
OpenScope | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText |
setType |
ToString |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType
isDirty
p_text

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

CSharpAST Class | DDW.CSharp.Parse Namespace


CSharpAST Constructor

Initializes a new instance of the CSharpAST class.

Overload List

Initializes a new instance of the CSharpAST class.

public CSharpAST();

Construct blank AST node using a token

public CSharpAST(Token);

See Also

CSharpAST Class | DDW.CSharp.Parse Namespace


CSharpAST Constructor ()

Initializes a new instance of the CSharpAST class.

public CSharpAST();

See Also

CSharpAST Class | DDW.CSharp.Parse Namespace | CSharpAST Constructor Overload List


CSharpAST Constructor (Token)

Construct blank AST node using a token

public CSharpAST(
Token tok
);

See Also

CSharpAST Class | DDW.CSharp.Parse Namespace | CSharpAST Constructor Overload List


CSharpAST Fields

The fields of the CSharpAST class are listed below. For a complete list of CSharpAST class members, see the CSharpAST Members topic.

Public Static Fields

defCount

Protected Instance Fields

curType
isDirty
p_text

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

CSharpAST Class | DDW.CSharp.Parse Namespace


CSharpAST.curType Field

protected TypeDecl curType;

See Also

CSharpAST Class | DDW.CSharp.Parse Namespace


CSharpAST.defCount Field

public static int defCount;

See Also

CSharpAST Class | DDW.CSharp.Parse Namespace


CSharpAST.isDirty Field

protected bool isDirty;

See Also

CSharpAST Class | DDW.CSharp.Parse Namespace


CSharpAST.p_text Field

protected string p_text;

See Also

CSharpAST Class | DDW.CSharp.Parse Namespace


CSharpAST Properties

The properties of the CSharpAST class are listed below. For a complete list of CSharpAST class members, see the CSharpAST Members topic.

Public Static Properties

CurrentScope |
GlobalScope |
ScopeTable |
SymbolTable | Stores un-attributed symbols until all types/vars are declared.

Public Instance Properties

FileName |
LinePragma |
Text (inherited from antlr.BaseAST) |
Type | Gets or sets the Type of the node (TODO: make this enum)
UserData | Gets or sets the user-definable data for the current object.

See Also

CSharpAST Class | DDW.CSharp.Parse Namespace


CurrentScope Property

Goblin - A Platform for 3D AR and VR Applications

CSharpAST.CurrentScope Property

public static DDW.CSharp.SymbolTable.Scope CurrentScope {get; set;}

See Also

CSharpAST Class | DDW.CSharp.Parse Namespace


FileName Property

Goblin - A Platform for 3D AR and VR Applications

CSharpAST.FileName Property

public string FileName {get; set;}

See Also

CSharpAST Class | DDW.CSharp.Parse Namespace


GlobalScope Property

Goblin - A Platform for 3D AR and VR Applications

CSharpAST.GlobalScope Property

public static DDW.CSharp.SymbolTable.AssemblyScope GlobalScope {get; set;}

See Also

CSharpAST Class | DDW.CSharp.Parse Namespace


LinePragma Property

Goblin - A Platform for 3D AR and VR Applications

CSharpAST.LinePragma Property

public DDW.CSharp.Dom.LinePragma LinePragma {get; set;}

See Also

CSharpAST Class | DDW.CSharp.Parse Namespace


ScopeTable Property

Goblin - A Platform for 3D AR and VR Applications

CSharpAST.ScopeTable Property

public static DDW.CSharp.SymbolTable.ScopeCollection ScopeTable {get;}

See Also

CSharpAST Class | DDW.CSharp.Parse Namespace


SymbolTable Property

Goblin - A Platform for 3D AR and VR Applications

CSharpAST.SymbolTable Property

Stores un-attributed symbols until all types/vars are declared.

public static DDW.CSharp.SymbolTable.DefinitionCollection SymbolTable {get;}

See Also

CSharpAST Class | DDW.CSharp.Parse Namespace


Type Property

Goblin - A Platform for 3D AR and VR Applications

CSharpAST.Type Property

Gets or sets the Type of the node (TODO: make this enum)

public override int Type {get; set;}

Implements

AST.Type

See Also

CSharpAST Class | DDW.CSharp.Parse Namespace


UserData Property

Goblin - A Platform for 3D AR and VR Applications

CSharpAST.UserData Property

Gets or sets the user-definable data for the current object.

public virtual System.Collections.IDictionary UserData {get; set;}

See Also

CSharpAST Class | DDW.CSharp.Parse Namespace


CSharpAST Methods

The methods of the CSharpAST class are listed below. For a complete list of CSharpAST class members, see the CSharpAST Members topic.

Public Static Methods

resetStatics

Public Instance Methods

AddBuiltInDefinition |
addChild (inherited from antlr.BaseAST) |
AddDefinition |
AddRootExpression | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText |
getType |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize | Overloaded.
OpenBlockScope |
OpenScope | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText |
setType |
ToString |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CSharpAST Class | DDW.CSharp.Parse Namespace


CSharpAST.AddBuiltInDefinition Method

public IDefinition AddBuiltInDefinition(
string name
);

See Also

CSharpAST Class | DDW.CSharp.Parse Namespace


CSharpAST.AddDefinition Method

public IDefinition AddDefinition(
IDeclaration dgraph,
string name,
IDeclaration type
);

See Also

CSharpAST Class | DDW.CSharp.Parse Namespace


CSharpAST.AddRootExpression Method

Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.

public void AddRootExpression(
Expression expr,
Type t,
string propName
);

See Also

CSharpAST Class | DDW.CSharp.Parse Namespace


CSharpAST.AddSymbol Method

Symbols are variables that refer to types, or type refs themselves.

public void AddSymbol(
ISymbolRef sgraph,
string name
);

See Also

CSharpAST Class | DDW.CSharp.Parse Namespace


CSharpAST.CloseScope Method

public void CloseScope();

See Also

CSharpAST Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

CSharpAST.GetGraph Method

Overload List

public virtual IGraph GetGraph();

public virtual IGraph GetGraph(IGraph);

See Also

CSharpAST Class | DDW.CSharp.Parse Namespace


CSharpAST.GetGraph Method ()

public virtual IGraph GetGraph();

See Also

CSharpAST Class | DDW.CSharp.Parse Namespace | CSharpAST.GetGraph Overload List


CSharpAST.GetGraph Method (IGraph)

public virtual IGraph GetGraph(
IGraph graph
);

See Also

CSharpAST Class | DDW.CSharp.Parse Namespace | CSharpAST.GetGraph Overload List


CSharpAST.getText Method

public override string getText();

Implements

AST.getText

See Also

CSharpAST Class | DDW.CSharp.Parse Namespace


CSharpAST.getType Method

public int getType();

See Also

CSharpAST Class | DDW.CSharp.Parse Namespace


initialize Method

Goblin - A Platform for 3D AR and VR Applications

CSharpAST.initialize Method

Overload List

public override void initialize(AST);

public override void initialize(Token);

public override void initialize(int,string);

See Also

CSharpAST Class | DDW.CSharp.Parse Namespace


CSharpAST.initialize Method (AST)

public override void initialize(
AST t
);

Implements

AST.initialize

See Also

CSharpAST Class | DDW.CSharp.Parse Namespace | CSharpAST.initialize Overload List


CSharpAST.initialize Method (Token)

public override void initialize(
Token tok
);

Implements

AST.initialize

See Also

CSharpAST Class | DDW.CSharp.Parse Namespace | CSharpAST.initialize Overload List


CSharpAST.initialize Method (Int32, String)

public override void initialize(
int t,
string txt
);

Implements

AST.initialize

See Also

CSharpAST Class | DDW.CSharp.Parse Namespace | CSharpAST.initialize Overload List


CSharpAST.OpenBlockScope Method

public Scope OpenBlockScope();

See Also

CSharpAST Class | DDW.CSharp.Parse Namespace


CSharpAST.OpenScope Method

Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).

public Scope OpenScope(
IScope graph
);

Parameters

graph
The current graph element.

Return Value

Returns a reference to the newly created scope.

See Also

CSharpAST Class | DDW.CSharp.Parse Namespace


CSharpAST.resetStatics Method

public static void resetStatics();

See Also

CSharpAST Class | DDW.CSharp.Parse Namespace


CSharpAST.ResolveExpressions Method

Determines all the return types of expressions, needed for resolving overloads.

public void ResolveExpressions();

See Also

CSharpAST Class | DDW.CSharp.Parse Namespace


CSharpAST.ResolveSymbols Method

Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.

public bool ResolveSymbols();

See Also

CSharpAST Class | DDW.CSharp.Parse Namespace


CSharpAST.setText Method

public override void setText(
string text_
);

Implements

AST.setText

See Also

CSharpAST Class | DDW.CSharp.Parse Namespace


CSharpAST.setType Method

public override void setType(
int ttype_
);

Implements

AST.setType

See Also

CSharpAST Class | DDW.CSharp.Parse Namespace


CSharpAST.ToString Method

public override string ToString();

Implements

AST.ToString

See Also

CSharpAST Class | DDW.CSharp.Parse Namespace


CSharpLexer Class

For a list of all members of this type, see CSharpLexer Members.

System.Object
antlr.CharScanner
DDW.CSharp.Parse.CSharpLexer

public class CSharpLexer : CharScanner

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

CSharpLexer Members | DDW.CSharp.Parse Namespace


CSharpLexer Members

CSharpLexer overview

Public Static Fields

ABSTRACT
AccessorNode
Arg
ArgDirection
Args
ArrayCreateExpr
ArrayInitExpr
ArrayRankExpr
AS
ASSEMBLY
ASSIGN
AssignExpr
BAND
BAND_ASN
BASE
BaseRefExpr
BaseTypes
BinaryExpr
BNOT
BOOL
BooleanLiteral
BOR
BOR_ASN
BREAK
BreakStmt
BSR
BSR_ASN
BuiltInType
BXOR
BXOR_ASN
BYTE
CASE
CastExpr
CATCH
CatchClause
CHAR
CHARACTER
CHARACTER_LITERAL
CharLiteral
CHECKED
CheckedExpr
CheckedStmt
CLASS
ClassNode
COLON
COMMA
CommentNode
CompileUnit
CONDITIONAL_SYMBOL
CONST
ConstantDeclStmt
ConstantNode
ConstructorNode
CONTINUE
ContinueStmt
CustomAttribute
CustomAttributes
DEC
DECIMAL
DECIMAL_DIGIT
Declarator
DeclArg
DeclArgs
DEFAULT
DELEGATE
DelegateNode
DELIMITED_COMMENT
DestructorNode
DIV
DIV_ASN
DO
DOT
DOUBLE
ELSE
ENUM
EnumMemberNode
EnumNode
EOF
EQUAL
EVENT
EventNode
EXPLICIT
EXPONENT_PART
Expression
Expressions
ExprStmt
EXTERN
FALSE
FIELD
FieldNode
FINALLY
FinallyStmt
FIXED
FLOAT
FOR
FOREACH
ForEachStmt
GE
GOTO
GotoStmt
GTHAN
HASH
HEX_DIGIT
HEXADECIMAL_ESCAPE_SEQUENCE
HEXADECIMAL_INTEGER_LITERAL
Ident
IDENTIFIER
IDENTIFIER_PART_CHARACTER
IDENTIFIER_START_CHARACTER
IF
IfStmt
IMPLICIT
IN
INC
IncStmt
IndexerExpr
IndexerNode
InitStmt
INT
INTEGER_LITERAL
INTEGER_TYPE_SUFFIX
IntegerLiteral
INTERFACE
InterfaceNode
INTERNAL
InvokeExpr
IS
IterationStmt
LabeledStmt
LAND
LBRACE
LBRACK
LE
LNOT
LOCK
LockStmt
LONG
LOR
LPAREN
LTHAN
MemberAccessExpr
Members
METHOD
MethodNode
MINUS
MINUS_ASN
MOD
MOD_ASN
ModifierAttributes
MODULE
NAMESPACE
NamespaceNode
NEW
NEW_LINE
NEW_LINE_CHARACTER
NOT_EQUAL
NOT_NEW_LINE
NULL
NULL_TREE_LOOKAHEAD
NullLiteral
NUMERIC_LITERAL
OBJECT
ObjectCreateExpr
Op
OPERATOR
OperatorNode
OUT
OVERRIDE
PARAM
PARAMS
PLUS
PLUS_ASN
PostfixExpr
PP_DECLARATION
PP_DIRECTIVE
PP_MESSAGE
PP_NEW_LINE
PP_REGION
PP_WHITESPACE
PPT_DEFINE
PPT_END_REGION
PPT_REGION
PPT_UNDEF
PrimaryExpression
PrimitiveExpr
PRIVATE
PROPERTY
PropertyNode
PROTECTED
PUBLIC
QualIdent
QUESTION
QUOTE
RBRACE
RBRACK
READONLY
REAL_LITERAL
REAL_TYPE_SUFFIX
RealLiteral
REF
REGULAR_STRING_LITERAL
REGULAR_STRING_LITERAL_CHARACTER
RETURN
ReturnStmt
RPAREN
SBYTE
SEALED
SEMI
SHORT
SIGN
SIMPLE_ESCAPE_SEQUENCE
SINGLE_CHARACTER
SINGLE_LINE_COMMENT
SINGLE_REGULAR_STRING_LITERAL_CHARACTER
SIZEOF
SL
SL_ASN
SR
SR_ASN
STACKALLOC
STAR
STAR_ASN
Statements
STATIC
STRING
STRING_LITERAL
StringLiteral
STRUCT
StructNode
SubExpr
SWITCH
SwitchSection
SwitchStmt
TernaryExpr
THIS
ThisRefExpr
THROW
ThrowStmt
tokenSet_0_
tokenSet_1_
tokenSet_10_
tokenSet_11_
tokenSet_12_
tokenSet_13_
tokenSet_14_
tokenSet_15_
tokenSet_16_
tokenSet_2_
tokenSet_3_
tokenSet_4_
tokenSet_5_
tokenSet_6_
tokenSet_7_
tokenSet_8_
tokenSet_9_
TRUE
TRY
TryCatchFinallyStmt
TryStmt
TYPE
TYPEOF
TypeOfExpr
TypeRef
Types
UINT
ULONG
UnaryExpr
UNCHECKED
UncheckedExpr
UncheckedStmt
UNICODE_ESCAPE_SEQUENCE
UNSAFE
USHORT
USING
UsingNode
UsingStmt
VariableDeclStmt
VERBATIM_STRING_LITERAL
VIRTUAL
VOID
VOLATILE
WHILE
WHITESPACE

Public Instance Constructors

CSharpLexer Overloaded. Initializes a new instance of the CSharpLexer class.

Public Instance Methods

append (inherited from antlr.CharScanner) | Overloaded.
commit (inherited from antlr.CharScanner) |
consume (inherited from antlr.CharScanner) |
consumeUntil (inherited from antlr.CharScanner) | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
getCaseSensitive (inherited from antlr.CharScanner) |
getCaseSensitiveLiterals (inherited from antlr.CharScanner) |
getColumn (inherited from antlr.CharScanner) |
getCommitToPath (inherited from antlr.CharScanner) |
getFilename (inherited from antlr.CharScanner) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
getInputBuffer (inherited from antlr.CharScanner) |
getInputState (inherited from antlr.CharScanner) |
getLine (inherited from antlr.CharScanner) |
getTabSize (inherited from antlr.CharScanner) |
getText (inherited from antlr.CharScanner) |
getTokenObject (inherited from antlr.CharScanner) |
GetType (inherited from Object) | Gets the Type of the current instance.
LA (inherited from antlr.CharScanner) |
mark (inherited from antlr.CharScanner) |
mASSIGN |
match (inherited from antlr.CharScanner) | Overloaded.
matchNot (inherited from antlr.CharScanner) | Overloaded.
matchRange (inherited from antlr.CharScanner) | Overloaded.
mBAND |
mBAND_ASN |
mBNOT |
mBOR |
mBOR_ASN |
mBSR |
mBSR_ASN |
mBXOR |
mBXOR_ASN |
mCHARACTER_LITERAL |
mCOLON |
mCOMMA |
mDEC |
mDELIMITED_COMMENT |
mDIV |
mDIV_ASN |
mEQUAL |
mGE |
mGTHAN |
mHASH |
mHEXADECIMAL_INTEGER_LITERAL |
mIDENTIFIER |
mINC |
mLAND |
mLBRACE |
mLBRACK |
mLE |
mLNOT |
mLOR |
mLPAREN |
mLTHAN |
mMINUS |
mMINUS_ASN |
mMOD |
mMOD_ASN |
mNOT_EQUAL |
mNUMERIC_LITERAL |
mPLUS |
mPLUS_ASN |
mPP_DIRECTIVE |
mQUESTION |
mQUOTE |
mRBRACE |
mRBRACK |
mRPAREN |
mSEMI |
mSINGLE_LINE_COMMENT |
mSL |
mSL_ASN |
mSR |
mSR_ASN |
mSTAR |
mSTAR_ASN |
mSTRING_LITERAL |
mUNICODE_ESCAPE_SEQUENCE |
mWHITESPACE |
newline (inherited from antlr.CharScanner) |
nextToken |
panic (inherited from antlr.CharScanner) | Overloaded.
reportError (inherited from antlr.CharScanner) | Overloaded.
reportWarning (inherited from antlr.CharScanner) |
resetText (inherited from antlr.CharScanner) |
rewind (inherited from antlr.CharScanner) |
setCaseSensitive (inherited from antlr.CharScanner) |
setColumn (inherited from antlr.CharScanner) |
setCommitToPath (inherited from antlr.CharScanner) |
setFilename (inherited from antlr.CharScanner) |
setInputState (inherited from antlr.CharScanner) |
setLine (inherited from antlr.CharScanner) |
setTabSize (inherited from antlr.CharScanner) |
setText (inherited from antlr.CharScanner) |
setTokenObjectClass (inherited from antlr.CharScanner) |
tab (inherited from antlr.CharScanner) |
testLiteralsTable (inherited from antlr.CharScanner) | Overloaded.
toLower (inherited from antlr.CharScanner) |
ToString (inherited from Object) | Returns a String that represents the current Object.
traceIn (inherited from antlr.CharScanner) |
traceIndent (inherited from antlr.CharScanner) |
traceOut (inherited from antlr.CharScanner) |
uponEOF (inherited from antlr.CharScanner) |

Public Instance Events

CharLA (inherited from antlr.CharScanner)
ConsumedChar (inherited from antlr.CharScanner)
Done (inherited from antlr.CharScanner)
EnterRule (inherited from antlr.CharScanner)
ErrorReported (inherited from antlr.CharScanner)
ExitRule (inherited from antlr.CharScanner)
HitNewLine (inherited from antlr.CharScanner)
MatchedChar (inherited from antlr.CharScanner)
MatchedNotChar (inherited from antlr.CharScanner)
MisMatchedChar (inherited from antlr.CharScanner)
MisMatchedNotChar (inherited from antlr.CharScanner)
SemPredEvaluated (inherited from antlr.CharScanner)
SynPredFailed (inherited from antlr.CharScanner)
SynPredStarted (inherited from antlr.CharScanner)
SynPredSucceeded (inherited from antlr.CharScanner)
WarningReported (inherited from antlr.CharScanner)

Protected Instance Fields

tokenObjectType (inherited from antlr.CharScanner)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
mCHARACTER |
mCONDITIONAL_SYMBOL |
mDECIMAL_DIGIT |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
mEXPONENT_PART |
mHEX_DIGIT |
mHEXADECIMAL_ESCAPE_SEQUENCE |
mIDENTIFIER_PART_CHARACTER |
mIDENTIFIER_START_CHARACTER |
mINTEGER_TYPE_SUFFIX |
mNEW_LINE |
mNEW_LINE_CHARACTER |
mNOT_NEW_LINE |
mPP_DECLARATION |
mPP_MESSAGE |
mPP_NEW_LINE |
mPP_REGION |
mPP_WHITESPACE |
mPPT_DEFINE |
mPPT_END_REGION |
mPPT_REGION |
mPPT_UNDEF |
mREAL_TYPE_SUFFIX |
mREGULAR_STRING_LITERAL |
mREGULAR_STRING_LITERAL_CHARACTER |
mSIGN |
mSIMPLE_ESCAPE_SEQUENCE |
mSINGLE_CHARACTER |
mSINGLE_REGULAR_STRING_LITERAL_CHARACTER |
mVERBATIM_STRING_LITERAL |

Protected Internal Instance Fields

caseSensitive (inherited from antlr.CharScanner)
caseSensitiveLiterals (inherited from antlr.CharScanner)
commitToPath (inherited from antlr.CharScanner)
inputState (inherited from antlr.CharScanner)
literals (inherited from antlr.CharScanner)
returnToken_ (inherited from antlr.CharScanner)
saveConsumedInput (inherited from antlr.CharScanner)
tabsize (inherited from antlr.CharScanner)
text (inherited from antlr.CharScanner)
tokenObjectTypeName (inherited from antlr.CharScanner)
traceDepth (inherited from antlr.CharScanner)

Protected Internal Instance Properties

Events (inherited from antlr.CharScanner)

Protected Internal Instance Methods

makeToken (inherited from antlr.CharScanner)

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer Constructor

Overload List

public CSharpLexer(InputBuffer);

public CSharpLexer(LexerSharedInputState);

public CSharpLexer(Stream);

public CSharpLexer(TextReader);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer Constructor (Stream)

public CSharpLexer(
Stream ins
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace | CSharpLexer Constructor Overload List


CSharpLexer Constructor (TextReader)

public CSharpLexer(
TextReader r
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace | CSharpLexer Constructor Overload List


CSharpLexer Constructor (InputBuffer)

public CSharpLexer(
InputBuffer ib
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace | CSharpLexer Constructor Overload List


CSharpLexer Constructor (LexerSharedInputState)

public CSharpLexer(
LexerSharedInputState state
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace | CSharpLexer Constructor Overload List


CSharpLexer Fields

The fields of the CSharpLexer class are listed below. For a complete list of CSharpLexer class members, see the CSharpLexer Members topic.

Public Static Fields

ABSTRACT
AccessorNode
Arg
ArgDirection
Args
ArrayCreateExpr
ArrayInitExpr
ArrayRankExpr
AS
ASSEMBLY
ASSIGN
AssignExpr
BAND
BAND_ASN
BASE
BaseRefExpr
BaseTypes
BinaryExpr
BNOT
BOOL
BooleanLiteral
BOR
BOR_ASN
BREAK
BreakStmt
BSR
BSR_ASN
BuiltInType
BXOR
BXOR_ASN
BYTE
CASE
CastExpr
CATCH
CatchClause
CHAR
CHARACTER
CHARACTER_LITERAL
CharLiteral
CHECKED
CheckedExpr
CheckedStmt
CLASS
ClassNode
COLON
COMMA
CommentNode
CompileUnit
CONDITIONAL_SYMBOL
CONST
ConstantDeclStmt
ConstantNode
ConstructorNode
CONTINUE
ContinueStmt
CustomAttribute
CustomAttributes
DEC
DECIMAL
DECIMAL_DIGIT
Declarator
DeclArg
DeclArgs
DEFAULT
DELEGATE
DelegateNode
DELIMITED_COMMENT
DestructorNode
DIV
DIV_ASN
DO
DOT
DOUBLE
ELSE
ENUM
EnumMemberNode
EnumNode
EOF
EQUAL
EVENT
EventNode
EXPLICIT
EXPONENT_PART
Expression
Expressions
ExprStmt
EXTERN
FALSE
FIELD
FieldNode
FINALLY
FinallyStmt
FIXED
FLOAT
FOR
FOREACH
ForEachStmt
GE
GOTO
GotoStmt
GTHAN
HASH
HEX_DIGIT
HEXADECIMAL_ESCAPE_SEQUENCE
HEXADECIMAL_INTEGER_LITERAL
Ident
IDENTIFIER
IDENTIFIER_PART_CHARACTER
IDENTIFIER_START_CHARACTER
IF
IfStmt
IMPLICIT
IN
INC
IncStmt
IndexerExpr
IndexerNode
InitStmt
INT
INTEGER_LITERAL
INTEGER_TYPE_SUFFIX
IntegerLiteral
INTERFACE
InterfaceNode
INTERNAL
InvokeExpr
IS
IterationStmt
LabeledStmt
LAND
LBRACE
LBRACK
LE
LNOT
LOCK
LockStmt
LONG
LOR
LPAREN
LTHAN
MemberAccessExpr
Members
METHOD
MethodNode
MINUS
MINUS_ASN
MOD
MOD_ASN
ModifierAttributes
MODULE
NAMESPACE
NamespaceNode
NEW
NEW_LINE
NEW_LINE_CHARACTER
NOT_EQUAL
NOT_NEW_LINE
NULL
NULL_TREE_LOOKAHEAD
NullLiteral
NUMERIC_LITERAL
OBJECT
ObjectCreateExpr
Op
OPERATOR
OperatorNode
OUT
OVERRIDE
PARAM
PARAMS
PLUS
PLUS_ASN
PostfixExpr
PP_DECLARATION
PP_DIRECTIVE
PP_MESSAGE
PP_NEW_LINE
PP_REGION
PP_WHITESPACE
PPT_DEFINE
PPT_END_REGION
PPT_REGION
PPT_UNDEF
PrimaryExpression
PrimitiveExpr
PRIVATE
PROPERTY
PropertyNode
PROTECTED
PUBLIC
QualIdent
QUESTION
QUOTE
RBRACE
RBRACK
READONLY
REAL_LITERAL
REAL_TYPE_SUFFIX
RealLiteral
REF
REGULAR_STRING_LITERAL
REGULAR_STRING_LITERAL_CHARACTER
RETURN
ReturnStmt
RPAREN
SBYTE
SEALED
SEMI
SHORT
SIGN
SIMPLE_ESCAPE_SEQUENCE
SINGLE_CHARACTER
SINGLE_LINE_COMMENT
SINGLE_REGULAR_STRING_LITERAL_CHARACTER
SIZEOF
SL
SL_ASN
SR
SR_ASN
STACKALLOC
STAR
STAR_ASN
Statements
STATIC
STRING
STRING_LITERAL
StringLiteral
STRUCT
StructNode
SubExpr
SWITCH
SwitchSection
SwitchStmt
TernaryExpr
THIS
ThisRefExpr
THROW
ThrowStmt
tokenSet_0_
tokenSet_1_
tokenSet_10_
tokenSet_11_
tokenSet_12_
tokenSet_13_
tokenSet_14_
tokenSet_15_
tokenSet_16_
tokenSet_2_
tokenSet_3_
tokenSet_4_
tokenSet_5_
tokenSet_6_
tokenSet_7_
tokenSet_8_
tokenSet_9_
TRUE
TRY
TryCatchFinallyStmt
TryStmt
TYPE
TYPEOF
TypeOfExpr
TypeRef
Types
UINT
ULONG
UnaryExpr
UNCHECKED
UncheckedExpr
UncheckedStmt
UNICODE_ESCAPE_SEQUENCE
UNSAFE
USHORT
USING
UsingNode
UsingStmt
VariableDeclStmt
VERBATIM_STRING_LITERAL
VIRTUAL
VOID
VOLATILE
WHILE
WHITESPACE

Protected Instance Fields

tokenObjectType (inherited from antlr.CharScanner)

Protected Internal Instance Fields

caseSensitive (inherited from antlr.CharScanner)
caseSensitiveLiterals (inherited from antlr.CharScanner)
commitToPath (inherited from antlr.CharScanner)
inputState (inherited from antlr.CharScanner)
literals (inherited from antlr.CharScanner)
returnToken_ (inherited from antlr.CharScanner)
saveConsumedInput (inherited from antlr.CharScanner)
tabsize (inherited from antlr.CharScanner)
text (inherited from antlr.CharScanner)
tokenObjectTypeName (inherited from antlr.CharScanner)
traceDepth (inherited from antlr.CharScanner)

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.ABSTRACT Field

public const int ABSTRACT = 201;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.AccessorNode Field

public const int AccessorNode = 30;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.Arg Field

public const int Arg = 37;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.ArgDirection Field

public const int ArgDirection = 40;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.Args Field

public const int Args = 36;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.ArrayCreateExpr Field

public const int ArrayCreateExpr = 80;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.ArrayInitExpr Field

public const int ArrayInitExpr = 89;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.ArrayRankExpr Field

public const int ArrayRankExpr = 88;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.AS Field

public const int AS = 150;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.ASSEMBLY Field

public const int ASSEMBLY = 220;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.ASSIGN Field

public const int ASSIGN = 160;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.AssignExpr Field

public const int AssignExpr = 76;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.BAND Field

public const int BAND = 153;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.BAND_ASN Field

public const int BAND_ASN = 166;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.BASE Field

public const int BASE = 128;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.BaseRefExpr Field

public const int BaseRefExpr = 74;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.BaseTypes Field

public const int BaseTypes = 12;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.BinaryExpr Field

public const int BinaryExpr = 78;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.BNOT Field

public const int BNOT = 139;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.BOOL Field

public const int BOOL = 109;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.BooleanLiteral Field

public const int BooleanLiteral = 13;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.BOR Field

public const int BOR = 155;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.BOR_ASN Field

public const int BOR_ASN = 167;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.BREAK Field

public const int BREAK = 185;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.BreakStmt Field

public const int BreakStmt = 57;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.BSR Field

public const int BSR = 253;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.BSR_ASN Field

public const int BSR_ASN = 254;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.BuiltInType Field

public const int BuiltInType = 35;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.BXOR Field

public const int BXOR = 154;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.BXOR_ASN Field

public const int BXOR_ASN = 168;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.BYTE Field

public const int BYTE = 112;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.CASE Field

public const int CASE = 178;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.CastExpr Field

public const int CastExpr = 72;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.CATCH Field

public const int CATCH = 193;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.CatchClause Field

public const int CatchClause = 46;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.CHAR Field

public const int CHAR = 119;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.CHARACTER Field

public const int CHARACTER = 245;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.CHARACTER_LITERAL Field

public const int CHARACTER_LITERAL = 101;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.CharLiteral Field

public const int CharLiteral = 16;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.CHECKED Field

public const int CHECKED = 134;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.CheckedExpr Field

public const int CheckedExpr = 84;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.CheckedStmt Field

public const int CheckedStmt = 60;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.CLASS Field

public const int CLASS = 196;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.ClassNode Field

public const int ClassNode = 7;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.COLON Field

public const int COLON = 159;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.COMMA Field

public const int COMMA = 123;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.CommentNode Field

public const int CommentNode = 43;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.CompileUnit Field

public const int CompileUnit = 4;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.CONDITIONAL_SYMBOL Field

public const int CONDITIONAL_SYMBOL = 263;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.CONST Field

public const int CONST = 174;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.ConstantDeclStmt Field

public const int ConstantDeclStmt = 66;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.ConstantNode Field

public const int ConstantNode = 25;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.ConstructorNode Field

public const int ConstructorNode = 28;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.CONTINUE Field

public const int CONTINUE = 186;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.ContinueStmt Field

public const int ContinueStmt = 58;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.CustomAttribute Field

public const int CustomAttribute = 93;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.CustomAttributes Field

public const int CustomAttributes = 92;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.DEC Field

public const int DEC = 130;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.DECIMAL Field

public const int DECIMAL = 110;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.DECIMAL_DIGIT Field

public const int DECIMAL_DIGIT = 239;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.Declarator Field

public const int Declarator = 91;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.DeclArg Field

public const int DeclArg = 39;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.DeclArgs Field

public const int DeclArgs = 38;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.DEFAULT Field

public const int DEFAULT = 179;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.DELEGATE Field

public const int DELEGATE = 219;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.DelegateNode Field

public const int DelegateNode = 11;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.DELIMITED_COMMENT Field

public const int DELIMITED_COMMENT = 97;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.DestructorNode Field

public const int DestructorNode = 29;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.DIV Field

public const int DIV = 141;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.DIV_ASN Field

public const int DIV_ASN = 164;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.DO Field

public const int DO = 181;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.DOT Field

public const int DOT = 106;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.DOUBLE Field

public const int DOUBLE = 121;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.ELSE Field

public const int ELSE = 176;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.ENUM Field

public const int ENUM = 218;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.EnumMemberNode Field

public const int EnumMemberNode = 31;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.EnumNode Field

public const int EnumNode = 10;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.EOF Field

public const int EOF = 1;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.EQUAL Field

public const int EQUAL = 151;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.EVENT Field

public const int EVENT = 212;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.EventNode Field

public const int EventNode = 24;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.EXPLICIT Field

public const int EXPLICIT = 215;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.EXPONENT_PART Field

public const int EXPONENT_PART = 242;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.Expression Field

public const int Expression = 68;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.Expressions Field

public const int Expressions = 67;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.ExprStmt Field

public const int ExprStmt = 42;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.EXTERN Field

public const int EXTERN = 208;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.FALSE Field

public const int FALSE = 104;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.FIELD Field

public const int FIELD = 221;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.FieldNode Field

public const int FieldNode = 22;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.FINALLY Field

public const int FINALLY = 194;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.FinallyStmt Field

public const int FinallyStmt = 47;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.FIXED Field

public const int FIXED = 229;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.FLOAT Field

public const int FLOAT = 120;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.FOR Field

public const int FOR = 182;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.FOREACH Field

public const int FOREACH = 183;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.ForEachStmt Field

public const int ForEachStmt = 54;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.GE Field

public const int GE = 148;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.GOTO Field

public const int GOTO = 187;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.GotoStmt Field

public const int GotoStmt = 55;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.GTHAN Field

public const int GTHAN = 146;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.HASH Field

public const int HASH = 255;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.HEX_DIGIT Field

public const int HEX_DIGIT = 241;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.HEXADECIMAL_ESCAPE_SEQUENCE Field

public const int HEXADECIMAL_ESCAPE_SEQUENCE = 248;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.HEXADECIMAL_INTEGER_LITERAL Field

public const int HEXADECIMAL_INTEGER_LITERAL = 99;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.Ident Field

public const int Ident = 32;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.IDENTIFIER Field

public const int IDENTIFIER = 95;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.IDENTIFIER_PART_CHARACTER Field

public const int IDENTIFIER_PART_CHARACTER = 237;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.IDENTIFIER_START_CHARACTER Field

public const int IDENTIFIER_START_CHARACTER = 236;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.IF Field

public const int IF = 175;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.IfStmt Field

public const int IfStmt = 48;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.IMPLICIT Field

public const int IMPLICIT = 214;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.IN Field

public const int IN = 184;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.INC Field

public const int INC = 129;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.IncStmt Field

public const int IncStmt = 53;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.IndexerExpr Field

public const int IndexerExpr = 87;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.IndexerNode Field

public const int IndexerNode = 26;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.InitStmt Field

public const int InitStmt = 52;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.INT Field

public const int INT = 115;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.INTEGER_LITERAL Field

public const int INTEGER_LITERAL = 98;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.INTEGER_TYPE_SUFFIX Field

public const int INTEGER_TYPE_SUFFIX = 240;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.IntegerLiteral Field

public const int IntegerLiteral = 14;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.INTERFACE Field

public const int INTERFACE = 217;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.InterfaceNode Field

public const int InterfaceNode = 8;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.INTERNAL Field

public const int INTERNAL = 199;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.InvokeExpr Field

public const int InvokeExpr = 86;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.IS Field

public const int IS = 149;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.IterationStmt Field

public const int IterationStmt = 51;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.LabeledStmt Field

public const int LabeledStmt = 64;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.LAND Field

public const int LAND = 156;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.LBRACE Field

public const int LBRACE = 171;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.LBRACK Field

public const int LBRACK = 122;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.LE Field

public const int LE = 147;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.LNOT Field

public const int LNOT = 138;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.LOCK Field

public const int LOCK = 190;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.LockStmt Field

public const int LockStmt = 62;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.LONG Field

public const int LONG = 117;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.LOR Field

public const int LOR = 157;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.LPAREN Field

public const int LPAREN = 125;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.LTHAN Field

public const int LTHAN = 145;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.MemberAccessExpr Field

public const int MemberAccessExpr = 75;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.Members Field

public const int Members = 20;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.METHOD Field

public const int METHOD = 222;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.MethodNode Field

public const int MethodNode = 21;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.MINUS Field

public const int MINUS = 137;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.MINUS_ASN Field

public const int MINUS_ASN = 162;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.MOD Field

public const int MOD = 142;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.MOD_ASN Field

public const int MOD_ASN = 165;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.ModifierAttributes Field

public const int ModifierAttributes = 94;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.MODULE Field

public const int MODULE = 223;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.NAMESPACE Field

public const int NAMESPACE = 195;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.NamespaceNode Field

public const int NamespaceNode = 6;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.NEW Field

public const int NEW = 131;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.NEW_LINE Field

public const int NEW_LINE = 231;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.NEW_LINE_CHARACTER Field

public const int NEW_LINE_CHARACTER = 232;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.NOT_EQUAL Field

public const int NOT_EQUAL = 152;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.NOT_NEW_LINE Field

public const int NOT_NEW_LINE = 233;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.NULL Field

public const int NULL = 105;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.NULL_TREE_LOOKAHEAD Field

public const int NULL_TREE_LOOKAHEAD = 3;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.NullLiteral Field

public const int NullLiteral = 18;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.NUMERIC_LITERAL Field

public const int NUMERIC_LITERAL = 238;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.OBJECT Field

public const int OBJECT = 107;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.ObjectCreateExpr Field

public const int ObjectCreateExpr = 81;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.Op Field

public const int Op = 90;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.OPERATOR Field

public const int OPERATOR = 213;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.OperatorNode Field

public const int OperatorNode = 27;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.OUT Field

public const int OUT = 211;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.OVERRIDE Field

public const int OVERRIDE = 207;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.PARAM Field

public const int PARAM = 224;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.PARAMS Field

public const int PARAMS = 209;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.PLUS Field

public const int PLUS = 136;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.PLUS_ASN Field

public const int PLUS_ASN = 161;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.PostfixExpr Field

public const int PostfixExpr = 83;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.PP_DECLARATION Field

public const int PP_DECLARATION = 260;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.PP_DIRECTIVE Field

public const int PP_DIRECTIVE = 259;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.PP_MESSAGE Field

public const int PP_MESSAGE = 262;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.PP_NEW_LINE Field

public const int PP_NEW_LINE = 257;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.PP_REGION Field

public const int PP_REGION = 261;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.PP_WHITESPACE Field

public const int PP_WHITESPACE = 258;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.PPT_DEFINE Field

public const int PPT_DEFINE = 264;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.PPT_END_REGION Field

public const int PPT_END_REGION = 267;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.PPT_REGION Field

public const int PPT_REGION = 266;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.PPT_UNDEF Field

public const int PPT_UNDEF = 265;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.PrimaryExpression Field

public const int PrimaryExpression = 69;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.PrimitiveExpr Field

public const int PrimitiveExpr = 71;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.PRIVATE Field

public const int PRIVATE = 200;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.PROPERTY Field

public const int PROPERTY = 225;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.PropertyNode Field

public const int PropertyNode = 23;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.PROTECTED Field

public const int PROTECTED = 198;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.PUBLIC Field

public const int PUBLIC = 197;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.QualIdent Field

public const int QualIdent = 33;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.QUESTION Field

public const int QUESTION = 158;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.QUOTE Field

public const int QUOTE = 256;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.RBRACE Field

public const int RBRACE = 172;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.RBRACK Field

public const int RBRACK = 124;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.READONLY Field

public const int READONLY = 204;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.REAL_LITERAL Field

public const int REAL_LITERAL = 100;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.REAL_TYPE_SUFFIX Field

public const int REAL_TYPE_SUFFIX = 244;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.RealLiteral Field

public const int RealLiteral = 15;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.REF Field

public const int REF = 210;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.REGULAR_STRING_LITERAL Field

public const int REGULAR_STRING_LITERAL = 249;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.REGULAR_STRING_LITERAL_CHARACTER Field

public const int REGULAR_STRING_LITERAL_CHARACTER = 250;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.RETURN Field

public const int RETURN = 188;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.ReturnStmt Field

public const int ReturnStmt = 56;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.RPAREN Field

public const int RPAREN = 126;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.SBYTE Field

public const int SBYTE = 111;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.SEALED Field

public const int SEALED = 202;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.SEMI Field

public const int SEMI = 173;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.SHORT Field

public const int SHORT = 113;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.SIGN Field

public const int SIGN = 243;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.SIMPLE_ESCAPE_SEQUENCE Field

public const int SIMPLE_ESCAPE_SEQUENCE = 247;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.SINGLE_CHARACTER Field

public const int SINGLE_CHARACTER = 246;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.SINGLE_LINE_COMMENT Field

public const int SINGLE_LINE_COMMENT = 96;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.SINGLE_REGULAR_STRING_LITERAL_CHARACTER Field

public const int SINGLE_REGULAR_STRING_LITERAL_CHARACTER = 251;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.SIZEOF Field

public const int SIZEOF = 227;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.SL Field

public const int SL = 143;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.SL_ASN Field

public const int SL_ASN = 169;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.SR Field

public const int SR = 144;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.SR_ASN Field

public const int SR_ASN = 170;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.STACKALLOC Field

public const int STACKALLOC = 228;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.STAR Field

public const int STAR = 140;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.STAR_ASN Field

public const int STAR_ASN = 163;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.Statements Field

public const int Statements = 41;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.STATIC Field

public const int STATIC = 203;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.STRING Field

public const int STRING = 108;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.STRING_LITERAL Field

public const int STRING_LITERAL = 102;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.StringLiteral Field

public const int StringLiteral = 17;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.STRUCT Field

public const int STRUCT = 216;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.StructNode Field

public const int StructNode = 9;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.SubExpr Field

public const int SubExpr = 70;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.SWITCH Field

public const int SWITCH = 177;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.SwitchSection Field

public const int SwitchSection = 50;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.SwitchStmt Field

public const int SwitchStmt = 49;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.TernaryExpr Field

public const int TernaryExpr = 79;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.THIS Field

public const int THIS = 127;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.ThisRefExpr Field

public const int ThisRefExpr = 73;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.THROW Field

public const int THROW = 189;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.ThrowStmt Field

public const int ThrowStmt = 59;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.tokenSet_0_ Field

public static readonly BitSet tokenSet_0_;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.tokenSet_1_ Field

public static readonly BitSet tokenSet_1_;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.tokenSet_10_ Field

public static readonly BitSet tokenSet_10_;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.tokenSet_11_ Field

public static readonly BitSet tokenSet_11_;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.tokenSet_12_ Field

public static readonly BitSet tokenSet_12_;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.tokenSet_13_ Field

public static readonly BitSet tokenSet_13_;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.tokenSet_14_ Field

public static readonly BitSet tokenSet_14_;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.tokenSet_15_ Field

public static readonly BitSet tokenSet_15_;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.tokenSet_16_ Field

public static readonly BitSet tokenSet_16_;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.tokenSet_2_ Field

public static readonly BitSet tokenSet_2_;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.tokenSet_3_ Field

public static readonly BitSet tokenSet_3_;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.tokenSet_4_ Field

public static readonly BitSet tokenSet_4_;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.tokenSet_5_ Field

public static readonly BitSet tokenSet_5_;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.tokenSet_6_ Field

public static readonly BitSet tokenSet_6_;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.tokenSet_7_ Field

public static readonly BitSet tokenSet_7_;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.tokenSet_8_ Field

public static readonly BitSet tokenSet_8_;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.tokenSet_9_ Field

public static readonly BitSet tokenSet_9_;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.TRUE Field

public const int TRUE = 103;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.TRY Field

public const int TRY = 192;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.TryCatchFinallyStmt Field

public const int TryCatchFinallyStmt = 44;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.TryStmt Field

public const int TryStmt = 45;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.TYPE Field

public const int TYPE = 226;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.TYPEOF Field

public const int TYPEOF = 132;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.TypeOfExpr Field

public const int TypeOfExpr = 82;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.TypeRef Field

public const int TypeRef = 34;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.Types Field

public const int Types = 19;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.UINT Field

public const int UINT = 116;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.ULONG Field

public const int ULONG = 118;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.UnaryExpr Field

public const int UnaryExpr = 77;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.UNCHECKED Field

public const int UNCHECKED = 135;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.UncheckedExpr Field

public const int UncheckedExpr = 85;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.UncheckedStmt Field

public const int UncheckedStmt = 61;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.UNICODE_ESCAPE_SEQUENCE Field

public const int UNICODE_ESCAPE_SEQUENCE = 235;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.UNSAFE Field

public const int UNSAFE = 230;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.USHORT Field

public const int USHORT = 114;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.USING Field

public const int USING = 191;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.UsingNode Field

public const int UsingNode = 5;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.UsingStmt Field

public const int UsingStmt = 63;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.VariableDeclStmt Field

public const int VariableDeclStmt = 65;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.VERBATIM_STRING_LITERAL Field

public const int VERBATIM_STRING_LITERAL = 252;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.VIRTUAL Field

public const int VIRTUAL = 206;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.VOID Field

public const int VOID = 133;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.VOLATILE Field

public const int VOLATILE = 205;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.WHILE Field

public const int WHILE = 180;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.WHITESPACE Field

public const int WHITESPACE = 234;

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer Methods

The methods of the CSharpLexer class are listed below. For a complete list of CSharpLexer class members, see the CSharpLexer Members topic.

Public Instance Methods

append (inherited from antlr.CharScanner) | Overloaded.
commit (inherited from antlr.CharScanner) |
consume (inherited from antlr.CharScanner) |
consumeUntil (inherited from antlr.CharScanner) | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
getCaseSensitive (inherited from antlr.CharScanner) |
getCaseSensitiveLiterals (inherited from antlr.CharScanner) |
getColumn (inherited from antlr.CharScanner) |
getCommitToPath (inherited from antlr.CharScanner) |
getFilename (inherited from antlr.CharScanner) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
getInputBuffer (inherited from antlr.CharScanner) |
getInputState (inherited from antlr.CharScanner) |
getLine (inherited from antlr.CharScanner) |
getTabSize (inherited from antlr.CharScanner) |
getText (inherited from antlr.CharScanner) |
getTokenObject (inherited from antlr.CharScanner) |
GetType (inherited from Object) | Gets the Type of the current instance.
LA (inherited from antlr.CharScanner) |
mark (inherited from antlr.CharScanner) |
mASSIGN |
match (inherited from antlr.CharScanner) | Overloaded.
matchNot (inherited from antlr.CharScanner) | Overloaded.
matchRange (inherited from antlr.CharScanner) | Overloaded.
mBAND |
mBAND_ASN |
mBNOT |
mBOR |
mBOR_ASN |
mBSR |
mBSR_ASN |
mBXOR |
mBXOR_ASN |
mCHARACTER_LITERAL |
mCOLON |
mCOMMA |
mDEC |
mDELIMITED_COMMENT |
mDIV |
mDIV_ASN |
mEQUAL |
mGE |
mGTHAN |
mHASH |
mHEXADECIMAL_INTEGER_LITERAL |
mIDENTIFIER |
mINC |
mLAND |
mLBRACE |
mLBRACK |
mLE |
mLNOT |
mLOR |
mLPAREN |
mLTHAN |
mMINUS |
mMINUS_ASN |
mMOD |
mMOD_ASN |
mNOT_EQUAL |
mNUMERIC_LITERAL |
mPLUS |
mPLUS_ASN |
mPP_DIRECTIVE |
mQUESTION |
mQUOTE |
mRBRACE |
mRBRACK |
mRPAREN |
mSEMI |
mSINGLE_LINE_COMMENT |
mSL |
mSL_ASN |
mSR |
mSR_ASN |
mSTAR |
mSTAR_ASN |
mSTRING_LITERAL |
mUNICODE_ESCAPE_SEQUENCE |
mWHITESPACE |
newline (inherited from antlr.CharScanner) |
nextToken |
panic (inherited from antlr.CharScanner) | Overloaded.
reportError (inherited from antlr.CharScanner) | Overloaded.
reportWarning (inherited from antlr.CharScanner) |
resetText (inherited from antlr.CharScanner) |
rewind (inherited from antlr.CharScanner) |
setCaseSensitive (inherited from antlr.CharScanner) |
setColumn (inherited from antlr.CharScanner) |
setCommitToPath (inherited from antlr.CharScanner) |
setFilename (inherited from antlr.CharScanner) |
setInputState (inherited from antlr.CharScanner) |
setLine (inherited from antlr.CharScanner) |
setTabSize (inherited from antlr.CharScanner) |
setText (inherited from antlr.CharScanner) |
setTokenObjectClass (inherited from antlr.CharScanner) |
tab (inherited from antlr.CharScanner) |
testLiteralsTable (inherited from antlr.CharScanner) | Overloaded.
toLower (inherited from antlr.CharScanner) |
ToString (inherited from Object) | Returns a String that represents the current Object.
traceIn (inherited from antlr.CharScanner) |
traceIndent (inherited from antlr.CharScanner) |
traceOut (inherited from antlr.CharScanner) |
uponEOF (inherited from antlr.CharScanner) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
mCHARACTER |
mCONDITIONAL_SYMBOL |
mDECIMAL_DIGIT |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
mEXPONENT_PART |
mHEX_DIGIT |
mHEXADECIMAL_ESCAPE_SEQUENCE |
mIDENTIFIER_PART_CHARACTER |
mIDENTIFIER_START_CHARACTER |
mINTEGER_TYPE_SUFFIX |
mNEW_LINE |
mNEW_LINE_CHARACTER |
mNOT_NEW_LINE |
mPP_DECLARATION |
mPP_MESSAGE |
mPP_NEW_LINE |
mPP_REGION |
mPP_WHITESPACE |
mPPT_DEFINE |
mPPT_END_REGION |
mPPT_REGION |
mPPT_UNDEF |
mREAL_TYPE_SUFFIX |
mREGULAR_STRING_LITERAL |
mREGULAR_STRING_LITERAL_CHARACTER |
mSIGN |
mSIMPLE_ESCAPE_SEQUENCE |
mSINGLE_CHARACTER |
mSINGLE_REGULAR_STRING_LITERAL_CHARACTER |
mVERBATIM_STRING_LITERAL |

Protected Internal Instance Methods

makeToken (inherited from antlr.CharScanner)

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mASSIGN Method

public void mASSIGN(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mBAND Method

public void mBAND(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mBAND_ASN Method

public void mBAND_ASN(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mBNOT Method

public void mBNOT(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mBOR Method

public void mBOR(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mBOR_ASN Method

public void mBOR_ASN(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mBSR Method

public void mBSR(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mBSR_ASN Method

public void mBSR_ASN(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mBXOR Method

public void mBXOR(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mBXOR_ASN Method

public void mBXOR_ASN(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mCHARACTER Method

protected void mCHARACTER(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mCHARACTER_LITERAL Method

public void mCHARACTER_LITERAL(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mCOLON Method

public void mCOLON(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mCOMMA Method

public void mCOMMA(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mCONDITIONAL_SYMBOL Method

protected void mCONDITIONAL_SYMBOL(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mDEC Method

public void mDEC(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mDECIMAL_DIGIT Method

protected void mDECIMAL_DIGIT(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mDELIMITED_COMMENT Method

public void mDELIMITED_COMMENT(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mDIV Method

public void mDIV(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mDIV_ASN Method

public void mDIV_ASN(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mEQUAL Method

public void mEQUAL(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mEXPONENT_PART Method

protected void mEXPONENT_PART(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mGE Method

public void mGE(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mGTHAN Method

public void mGTHAN(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mHASH Method

public void mHASH(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mHEX_DIGIT Method

protected void mHEX_DIGIT(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mHEXADECIMAL_ESCAPE_SEQUENCE Method

protected void mHEXADECIMAL_ESCAPE_SEQUENCE(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mHEXADECIMAL_INTEGER_LITERAL Method

public void mHEXADECIMAL_INTEGER_LITERAL(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mIDENTIFIER Method

public void mIDENTIFIER(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mIDENTIFIER_PART_CHARACTER Method

protected void mIDENTIFIER_PART_CHARACTER(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mIDENTIFIER_START_CHARACTER Method

protected void mIDENTIFIER_START_CHARACTER(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mINC Method

public void mINC(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mINTEGER_TYPE_SUFFIX Method

protected void mINTEGER_TYPE_SUFFIX(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mLAND Method

public void mLAND(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mLBRACE Method

public void mLBRACE(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mLBRACK Method

public void mLBRACK(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mLE Method

public void mLE(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mLNOT Method

public void mLNOT(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mLOR Method

public void mLOR(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mLPAREN Method

public void mLPAREN(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mLTHAN Method

public void mLTHAN(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mMINUS Method

public void mMINUS(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mMINUS_ASN Method

public void mMINUS_ASN(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mMOD Method

public void mMOD(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mMOD_ASN Method

public void mMOD_ASN(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mNEW_LINE Method

protected void mNEW_LINE(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mNEW_LINE_CHARACTER Method

protected void mNEW_LINE_CHARACTER(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mNOT_EQUAL Method

public void mNOT_EQUAL(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mNOT_NEW_LINE Method

protected void mNOT_NEW_LINE(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mNUMERIC_LITERAL Method

public void mNUMERIC_LITERAL(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mPLUS Method

public void mPLUS(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mPLUS_ASN Method

public void mPLUS_ASN(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mPP_DECLARATION Method

protected void mPP_DECLARATION(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mPP_DIRECTIVE Method

public void mPP_DIRECTIVE(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mPP_MESSAGE Method

protected void mPP_MESSAGE(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mPP_NEW_LINE Method

protected void mPP_NEW_LINE(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mPP_REGION Method

protected void mPP_REGION(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mPP_WHITESPACE Method

protected void mPP_WHITESPACE(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mPPT_DEFINE Method

protected void mPPT_DEFINE(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mPPT_END_REGION Method

protected void mPPT_END_REGION(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mPPT_REGION Method

protected void mPPT_REGION(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mPPT_UNDEF Method

protected void mPPT_UNDEF(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mQUESTION Method

public void mQUESTION(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mQUOTE Method

public void mQUOTE(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mRBRACE Method

public void mRBRACE(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mRBRACK Method

public void mRBRACK(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mREAL_TYPE_SUFFIX Method

protected void mREAL_TYPE_SUFFIX(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mREGULAR_STRING_LITERAL Method

protected void mREGULAR_STRING_LITERAL(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mREGULAR_STRING_LITERAL_CHARACTER Method

protected void mREGULAR_STRING_LITERAL_CHARACTER(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mRPAREN Method

public void mRPAREN(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mSEMI Method

public void mSEMI(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mSIGN Method

protected void mSIGN(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mSIMPLE_ESCAPE_SEQUENCE Method

protected void mSIMPLE_ESCAPE_SEQUENCE(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mSINGLE_CHARACTER Method

protected void mSINGLE_CHARACTER(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mSINGLE_LINE_COMMENT Method

public void mSINGLE_LINE_COMMENT(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mSINGLE_REGULAR_STRING_LITERAL_CHARACTER Method

protected void mSINGLE_REGULAR_STRING_LITERAL_CHARACTER(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mSL Method

public void mSL(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mSL_ASN Method

public void mSL_ASN(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mSR Method

public void mSR(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mSR_ASN Method

public void mSR_ASN(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mSTAR Method

public void mSTAR(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mSTAR_ASN Method

public void mSTAR_ASN(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mSTRING_LITERAL Method

public void mSTRING_LITERAL(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mUNICODE_ESCAPE_SEQUENCE Method

public void mUNICODE_ESCAPE_SEQUENCE(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mVERBATIM_STRING_LITERAL Method

protected void mVERBATIM_STRING_LITERAL(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.mWHITESPACE Method

public void mWHITESPACE(
bool _createToken
);

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpLexer.nextToken Method

new public Token nextToken();

Implements

TokenStream.nextToken

See Also

CSharpLexer Class | DDW.CSharp.Parse Namespace


CSharpParser Class

For a list of all members of this type, see CSharpParser Members.

System.Object
antlr.Parser
antlr.LLkParser
DDW.CSharp.Parse.CSharpParser

public class CSharpParser : LLkParser

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

CSharpParser Members | DDW.CSharp.Parse Namespace


CSharpParser Members

CSharpParser overview

Public Static Fields

ABSTRACT
AccessorNode
Arg
ArgDirection
Args
ArrayCreateExpr
ArrayInitExpr
ArrayRankExpr
AS
ASSEMBLY
ASSIGN
AssignExpr
BAND
BAND_ASN
BASE
BaseRefExpr
BaseTypes
BinaryExpr
BNOT
BOOL
BooleanLiteral
BOR
BOR_ASN
BREAK
BreakStmt
BSR
BSR_ASN
BuiltInType
BXOR
BXOR_ASN
BYTE
CASE
CastExpr
CATCH
CatchClause
CHAR
CHARACTER
CHARACTER_LITERAL
CharLiteral
CHECKED
CheckedExpr
CheckedStmt
CLASS
ClassNode
COLON
COMMA
CommentNode
CompileUnit
CONDITIONAL_SYMBOL
CONST
ConstantDeclStmt
ConstantNode
ConstructorNode
CONTINUE
ContinueStmt
CustomAttribute
CustomAttributes
DEC
DECIMAL
DECIMAL_DIGIT
Declarator
DeclArg
DeclArgs
DEFAULT
DELEGATE
DelegateNode
DELIMITED_COMMENT
DestructorNode
DIV
DIV_ASN
DO
DOT
DOUBLE
ELSE
ENUM
EnumMemberNode
EnumNode
EOF
EQUAL
EVENT
EventNode
EXPLICIT
EXPONENT_PART
Expression
Expressions
ExprStmt
EXTERN
FALSE
FIELD
FieldNode
FINALLY
FinallyStmt
FIXED
FLOAT
FOR
FOREACH
ForEachStmt
GE
GOTO
GotoStmt
GTHAN
HASH
HEX_DIGIT
HEXADECIMAL_ESCAPE_SEQUENCE
HEXADECIMAL_INTEGER_LITERAL
Ident
IDENTIFIER
IDENTIFIER_PART_CHARACTER
IDENTIFIER_START_CHARACTER
IF
IfStmt
IMPLICIT
IN
INC
IncStmt
IndexerExpr
IndexerNode
InitStmt
INT
INTEGER_LITERAL
INTEGER_TYPE_SUFFIX
IntegerLiteral
INTERFACE
InterfaceNode
INTERNAL
InvokeExpr
IS
IterationStmt
LabeledStmt
LAND
LBRACE
LBRACK
LE
LNOT
LOCK
LockStmt
LONG
LOR
LPAREN
LTHAN
MemberAccessExpr
Members
METHOD
MethodNode
MINUS
MINUS_ASN
MOD
MOD_ASN
ModifierAttributes
MODULE
NAMESPACE
NamespaceNode
NEW
NEW_LINE
NEW_LINE_CHARACTER
NOT_EQUAL
NOT_NEW_LINE
NULL
NULL_TREE_LOOKAHEAD
NullLiteral
NUMERIC_LITERAL
OBJECT
ObjectCreateExpr
Op
OPERATOR
OperatorNode
OUT
OVERRIDE
PARAM
PARAMS
PLUS
PLUS_ASN
PostfixExpr
PP_DECLARATION
PP_DIRECTIVE
PP_MESSAGE
PP_NEW_LINE
PP_REGION
PP_WHITESPACE
PPT_DEFINE
PPT_END_REGION
PPT_REGION
PPT_UNDEF
PrimaryExpression
PrimitiveExpr
PRIVATE
PROPERTY
PropertyNode
PROTECTED
PUBLIC
QualIdent
QUESTION
QUOTE
RBRACE
RBRACK
READONLY
REAL_LITERAL
REAL_TYPE_SUFFIX
RealLiteral
REF
REGULAR_STRING_LITERAL
REGULAR_STRING_LITERAL_CHARACTER
RETURN
ReturnStmt
RPAREN
SBYTE
SEALED
SEMI
SHORT
SIGN
SIMPLE_ESCAPE_SEQUENCE
SINGLE_CHARACTER
SINGLE_LINE_COMMENT
SINGLE_REGULAR_STRING_LITERAL_CHARACTER
SIZEOF
SL
SL_ASN
SR
SR_ASN
STACKALLOC
STAR
STAR_ASN
Statements
STATIC
STRING
STRING_LITERAL
StringLiteral
STRUCT
StructNode
SubExpr
SWITCH
SwitchSection
SwitchStmt
TernaryExpr
THIS
ThisRefExpr
THROW
ThrowStmt
tokenNames_
tokenSet_0_
tokenSet_1_
tokenSet_10_
tokenSet_100_
tokenSet_101_
tokenSet_102_
tokenSet_103_
tokenSet_104_
tokenSet_105_
tokenSet_106_
tokenSet_107_
tokenSet_108_
tokenSet_109_
tokenSet_11_
tokenSet_110_
tokenSet_111_
tokenSet_112_
tokenSet_113_
tokenSet_114_
tokenSet_115_
tokenSet_116_
tokenSet_117_
tokenSet_118_
tokenSet_119_
tokenSet_12_
tokenSet_120_
tokenSet_121_
tokenSet_122_
tokenSet_123_
tokenSet_124_
tokenSet_125_
tokenSet_126_
tokenSet_127_
tokenSet_128_
tokenSet_129_
tokenSet_13_
tokenSet_130_
tokenSet_131_
tokenSet_132_
tokenSet_133_
tokenSet_134_
tokenSet_135_
tokenSet_136_
tokenSet_137_
tokenSet_14_
tokenSet_15_
tokenSet_16_
tokenSet_17_
tokenSet_18_
tokenSet_19_
tokenSet_2_
tokenSet_20_
tokenSet_21_
tokenSet_22_
tokenSet_23_
tokenSet_24_
tokenSet_25_
tokenSet_26_
tokenSet_27_
tokenSet_28_
tokenSet_29_
tokenSet_3_
tokenSet_30_
tokenSet_31_
tokenSet_32_
tokenSet_33_
tokenSet_34_
tokenSet_35_
tokenSet_36_
tokenSet_37_
tokenSet_38_
tokenSet_39_
tokenSet_4_
tokenSet_40_
tokenSet_41_
tokenSet_42_
tokenSet_43_
tokenSet_44_
tokenSet_45_
tokenSet_46_
tokenSet_47_
tokenSet_48_
tokenSet_49_
tokenSet_5_
tokenSet_50_
tokenSet_51_
tokenSet_52_
tokenSet_53_
tokenSet_54_
tokenSet_55_
tokenSet_56_
tokenSet_57_
tokenSet_58_
tokenSet_59_
tokenSet_6_
tokenSet_60_
tokenSet_61_
tokenSet_62_
tokenSet_63_
tokenSet_64_
tokenSet_65_
tokenSet_66_
tokenSet_67_
tokenSet_68_
tokenSet_69_
tokenSet_7_
tokenSet_70_
tokenSet_71_
tokenSet_72_
tokenSet_73_
tokenSet_74_
tokenSet_75_
tokenSet_76_
tokenSet_77_
tokenSet_78_
tokenSet_79_
tokenSet_8_
tokenSet_80_
tokenSet_81_
tokenSet_82_
tokenSet_83_
tokenSet_84_
tokenSet_85_
tokenSet_86_
tokenSet_87_
tokenSet_88_
tokenSet_89_
tokenSet_9_
tokenSet_90_
tokenSet_91_
tokenSet_92_
tokenSet_93_
tokenSet_94_
tokenSet_95_
tokenSet_96_
tokenSet_97_
tokenSet_98_
tokenSet_99_
TRUE
TRY
TryCatchFinallyStmt
TryStmt
TYPE
TYPEOF
TypeOfExpr
TypeRef
Types
UINT
ULONG
UnaryExpr
UNCHECKED
UncheckedExpr
UncheckedStmt
UNICODE_ESCAPE_SEQUENCE
UNSAFE
USHORT
USING
UsingNode
UsingStmt
VariableDeclStmt
VERBATIM_STRING_LITERAL
VIRTUAL
VOID
VOLATILE
WHILE
WHITESPACE

Public Static Methods

initializeASTFactory

Public Instance Constructors

CSharpParser Overloaded. Initializes a new instance of the CSharpParser class.

Public Instance Methods

accessible_predefined_types |
accessor_body |
accessor_declaration |
accessor_declarations |
accessor_modifier |
additive_expression |
additive_op |
addMessageListener (inherited from antlr.Parser) |
addParserListener (inherited from antlr.Parser) |
addParserMatchListener (inherited from antlr.Parser) |
addParserTokenListener (inherited from antlr.Parser) |
addSemanticPredicateListener (inherited from antlr.Parser) |
addSyntacticPredicateListener (inherited from antlr.Parser) |
addTraceListener (inherited from antlr.Parser) |
and_expression |
annotated_statement_expression |
argument |
argument_list |
array_creation_expression |
array_initializer |
array_rank |
array_type |
assignment |
assignment_operator |
attribute |
attribute_argument |
attribute_argument_list |
attribute_arguments |
attribute_list |
attribute_section |
attribute_target |
attributes |
base_access |
binary_operator_declarator |
block |
boolean_expression |
boolean_literal |
break_statement |
cast_expression |
catch_clause |
catch_clauses |
checked_expression |
checked_statement |
class_base |
class_body |
class_declaration |
class_member_declaration |
class_modifiers |
class_type |
comment |
compilation_unit |
conditional_and_expression |
conditional_expression |
conditional_or_expression |
constant_declaration |
constant_declarator |
constant_declarators |
constant_expression |
constant_modifiers |
constructor_body |
constructor_declaration |
constructor_declarator |
constructor_init_modifiers |
constructor_initializer |
constructor_modifiers |
consume (inherited from antlr.LLkParser) |
consumeUntil (inherited from antlr.Parser) | Overloaded.
continue_statement |
conversion_classification |
conversion_operator_declarator |
declaration_statement |
delegate_declaration |
delegate_modifiers |
delegate_type |
destructor_body |
destructor_declaration |
do_statement |
element_access |
embedded_statement |
empty_statement |
enum_base |
enum_body |
enum_declaration |
enum_member_declaration |
enum_modifiers |
equality_expression |
equality_op |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
event_accessor_block |
event_accessor_declaration |
event_accessor_declarations |
event_accessor_modifiers |
event_declaration |
event_modifiers |
exclusive_or_expression |
expression |
expression_list |
expression_statement |
field_declaration |
field_modifiers |
finally_clause |
floating_point_type |
for_condition |
for_initializer |
for_iterator |
for_statement |
foreach_statement |
formal_parameter_list |
getAST (inherited from antlr.Parser) |
getASTFactory (inherited from antlr.Parser) |
getFilename (inherited from antlr.Parser) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
getInputState (inherited from antlr.Parser) |
getTokenName (inherited from antlr.Parser) |
getTokenNames (inherited from antlr.Parser) |
GetType (inherited from Object) | Gets the Type of the current instance.
global_attributes |
goto_statement |
identifier |
if_statement |
inclusive_or_expression |
indexer_declaration |
indexer_declarator |
indexer_modifiers |
integral_type |
interface_accessor |
interface_accessors |
interface_base |
interface_body |
interface_declaration |
interface_event_declaration |
interface_indexer_declaration |
interface_member_declaration |
interface_method_declaration |
interface_modifiers |
interface_property_declaration |
interface_type |
invocation_expression |
isDebugMode (inherited from antlr.Parser) |
iteration_statement |
jump_statement |
LA (inherited from antlr.LLkParser) |
labeled_statement |
literal |
local_constant_declaration |
local_variable_declaration |
local_variable_declarator |
local_variable_declarators |
local_variable_initializer |
lock_statement |
LT (inherited from antlr.LLkParser) |
mark (inherited from antlr.Parser) |
match (inherited from antlr.Parser) | Overloaded.
matchNot (inherited from antlr.Parser) |
member_access |
member_name |
method_body |
method_declaration |
method_header |
method_modifiers |
method_parameter |
multiplicative_expression |
multiplicative_op |
namespace_body |
namespace_declaration |
namespace_member_declaration |
namespace_name |
namespace_or_type_name |
non_array_type |
null_literal |
numeric_type |
object_creation_expression |
operator_body |
operator_declaration |
operator_declarator |
operator_modifiers |
overloadable_binary_operator |
overloadable_unary_operator |
parameter_direction |
parenthesized_expression |
postfix_expression |
postfix_op |
pre_decrement_expression |
pre_increment_expression |
predefined_type_access |
primary_expression |
primary_start |
property_declaration |
property_modifiers |
qualified_identifier |
rank_specifiers |
reference_type |
relational_expression |
relational_op |
removeMessageListener (inherited from antlr.Parser) |
removeParserListener (inherited from antlr.Parser) |
removeParserMatchListener (inherited from antlr.Parser) |
removeParserTokenListener (inherited from antlr.Parser) |
removeSemanticPredicateListener (inherited from antlr.Parser) |
removeSyntacticPredicateListener (inherited from antlr.Parser) |
removeTraceListener (inherited from antlr.Parser) |
reportError (inherited from antlr.Parser) | Overloaded.
reportWarning (inherited from antlr.Parser) |
resource_acquisition |
return_statement |
return_type |
rewind (inherited from antlr.Parser) |
selection_statement |
setASTFactory (inherited from antlr.Parser) |
setASTNodeClass (inherited from antlr.Parser) |
setASTNodeType (inherited from antlr.Parser) | Obsolete.
setDebugMode (inherited from antlr.Parser) |
setFilename (inherited from antlr.Parser) |
setIgnoreInvalidDebugCalls (inherited from antlr.Parser) |
setInputState (inherited from antlr.Parser) |
setTokenBuffer (inherited from antlr.Parser) |
shift_expression |
shift_op |
simple_name |
simple_type |
sizeof_expression |
statement |
statement_expression |
statement_expression_list |
statement_list |
static_constructor_body |
static_constructor_declaration |
static_constructor_modifiers |
struct_body |
struct_declaration |
struct_interfaces |
struct_member_declaration |
struct_modifiers |
struct_type |
switch_block |
switch_cases |
switch_label |
switch_section |
switch_statement |
this_access |
throw_statement |
ToString (inherited from Object) | Returns a String that represents the current Object.
traceIn (inherited from antlr.LLkParser) |
traceIndent (inherited from antlr.Parser) |
traceOut (inherited from antlr.LLkParser) |
try_statement |
type |
type_comp_op |
type_declaration |
type_name |
typeof_expression |
typeof_types |
uanry_op |
unary_expression |
unary_operator_declarator |
unchecked_expression |
unchecked_statement |
using_directive |
using_statement |
value_type |
variable_declarator |
variable_declarators |
variable_initializer |
variable_reference |
while_statement |

Public Instance Events

ConsumedToken (inherited from antlr.Parser)
Done (inherited from antlr.Parser)
EnterRule (inherited from antlr.Parser)
ErrorReported (inherited from antlr.Parser)
ExitRule (inherited from antlr.Parser)
MatchedNotToken (inherited from antlr.Parser)
MatchedToken (inherited from antlr.Parser)
MisMatchedNotToken (inherited from antlr.Parser)
MisMatchedToken (inherited from antlr.Parser)
SemPredEvaluated (inherited from antlr.Parser)
SynPredFailed (inherited from antlr.Parser)
SynPredStarted (inherited from antlr.Parser)
SynPredSucceeded (inherited from antlr.Parser)
TokenLA (inherited from antlr.Parser)
WarningReported (inherited from antlr.Parser)

Protected Instance Constructors

CSharpParser Overloaded. Initializes a new instance of the CSharpParser class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
initialize |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

astFactory (inherited from antlr.Parser)
inputState (inherited from antlr.Parser)
returnAST (inherited from antlr.Parser)
tokenNames (inherited from antlr.Parser)
traceDepth (inherited from antlr.Parser)

Protected Internal Instance Properties

Events (inherited from antlr.Parser)

Protected Internal Instance Methods

defaultDebuggingSetup (inherited from antlr.Parser)

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser Constructor

Overload List

public CSharpParser(ParserSharedInputState);

public CSharpParser(TokenBuffer);

protected CSharpParser(TokenBuffer,int);

public CSharpParser(TokenStream);

protected CSharpParser(TokenStream,int);

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser Constructor (TokenBuffer, Int32)

protected CSharpParser(
TokenBuffer tokenBuf,
int k
);

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace | CSharpParser Constructor Overload List


CSharpParser Constructor (TokenBuffer)

public CSharpParser(
TokenBuffer tokenBuf
);

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace | CSharpParser Constructor Overload List


CSharpParser Constructor (TokenStream, Int32)

protected CSharpParser(
TokenStream lexer,
int k
);

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace | CSharpParser Constructor Overload List


CSharpParser Constructor (TokenStream)

public CSharpParser(
TokenStream lexer
);

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace | CSharpParser Constructor Overload List


CSharpParser Constructor (ParserSharedInputState)

public CSharpParser(
ParserSharedInputState state
);

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace | CSharpParser Constructor Overload List


CSharpParser Fields

The fields of the CSharpParser class are listed below. For a complete list of CSharpParser class members, see the CSharpParser Members topic.

Public Static Fields

ABSTRACT
AccessorNode
Arg
ArgDirection
Args
ArrayCreateExpr
ArrayInitExpr
ArrayRankExpr
AS
ASSEMBLY
ASSIGN
AssignExpr
BAND
BAND_ASN
BASE
BaseRefExpr
BaseTypes
BinaryExpr
BNOT
BOOL
BooleanLiteral
BOR
BOR_ASN
BREAK
BreakStmt
BSR
BSR_ASN
BuiltInType
BXOR
BXOR_ASN
BYTE
CASE
CastExpr
CATCH
CatchClause
CHAR
CHARACTER
CHARACTER_LITERAL
CharLiteral
CHECKED
CheckedExpr
CheckedStmt
CLASS
ClassNode
COLON
COMMA
CommentNode
CompileUnit
CONDITIONAL_SYMBOL
CONST
ConstantDeclStmt
ConstantNode
ConstructorNode
CONTINUE
ContinueStmt
CustomAttribute
CustomAttributes
DEC
DECIMAL
DECIMAL_DIGIT
Declarator
DeclArg
DeclArgs
DEFAULT
DELEGATE
DelegateNode
DELIMITED_COMMENT
DestructorNode
DIV
DIV_ASN
DO
DOT
DOUBLE
ELSE
ENUM
EnumMemberNode
EnumNode
EOF
EQUAL
EVENT
EventNode
EXPLICIT
EXPONENT_PART
Expression
Expressions
ExprStmt
EXTERN
FALSE
FIELD
FieldNode
FINALLY
FinallyStmt
FIXED
FLOAT
FOR
FOREACH
ForEachStmt
GE
GOTO
GotoStmt
GTHAN
HASH
HEX_DIGIT
HEXADECIMAL_ESCAPE_SEQUENCE
HEXADECIMAL_INTEGER_LITERAL
Ident
IDENTIFIER
IDENTIFIER_PART_CHARACTER
IDENTIFIER_START_CHARACTER
IF
IfStmt
IMPLICIT
IN
INC
IncStmt
IndexerExpr
IndexerNode
InitStmt
INT
INTEGER_LITERAL
INTEGER_TYPE_SUFFIX
IntegerLiteral
INTERFACE
InterfaceNode
INTERNAL
InvokeExpr
IS
IterationStmt
LabeledStmt
LAND
LBRACE
LBRACK
LE
LNOT
LOCK
LockStmt
LONG
LOR
LPAREN
LTHAN
MemberAccessExpr
Members
METHOD
MethodNode
MINUS
MINUS_ASN
MOD
MOD_ASN
ModifierAttributes
MODULE
NAMESPACE
NamespaceNode
NEW
NEW_LINE
NEW_LINE_CHARACTER
NOT_EQUAL
NOT_NEW_LINE
NULL
NULL_TREE_LOOKAHEAD
NullLiteral
NUMERIC_LITERAL
OBJECT
ObjectCreateExpr
Op
OPERATOR
OperatorNode
OUT
OVERRIDE
PARAM
PARAMS
PLUS
PLUS_ASN
PostfixExpr
PP_DECLARATION
PP_DIRECTIVE
PP_MESSAGE
PP_NEW_LINE
PP_REGION
PP_WHITESPACE
PPT_DEFINE
PPT_END_REGION
PPT_REGION
PPT_UNDEF
PrimaryExpression
PrimitiveExpr
PRIVATE
PROPERTY
PropertyNode
PROTECTED
PUBLIC
QualIdent
QUESTION
QUOTE
RBRACE
RBRACK
READONLY
REAL_LITERAL
REAL_TYPE_SUFFIX
RealLiteral
REF
REGULAR_STRING_LITERAL
REGULAR_STRING_LITERAL_CHARACTER
RETURN
ReturnStmt
RPAREN
SBYTE
SEALED
SEMI
SHORT
SIGN
SIMPLE_ESCAPE_SEQUENCE
SINGLE_CHARACTER
SINGLE_LINE_COMMENT
SINGLE_REGULAR_STRING_LITERAL_CHARACTER
SIZEOF
SL
SL_ASN
SR
SR_ASN
STACKALLOC
STAR
STAR_ASN
Statements
STATIC
STRING
STRING_LITERAL
StringLiteral
STRUCT
StructNode
SubExpr
SWITCH
SwitchSection
SwitchStmt
TernaryExpr
THIS
ThisRefExpr
THROW
ThrowStmt
tokenNames_
tokenSet_0_
tokenSet_1_
tokenSet_10_
tokenSet_100_
tokenSet_101_
tokenSet_102_
tokenSet_103_
tokenSet_104_
tokenSet_105_
tokenSet_106_
tokenSet_107_
tokenSet_108_
tokenSet_109_
tokenSet_11_
tokenSet_110_
tokenSet_111_
tokenSet_112_
tokenSet_113_
tokenSet_114_
tokenSet_115_
tokenSet_116_
tokenSet_117_
tokenSet_118_
tokenSet_119_
tokenSet_12_
tokenSet_120_
tokenSet_121_
tokenSet_122_
tokenSet_123_
tokenSet_124_
tokenSet_125_
tokenSet_126_
tokenSet_127_
tokenSet_128_
tokenSet_129_
tokenSet_13_
tokenSet_130_
tokenSet_131_
tokenSet_132_
tokenSet_133_
tokenSet_134_
tokenSet_135_
tokenSet_136_
tokenSet_137_
tokenSet_14_
tokenSet_15_
tokenSet_16_
tokenSet_17_
tokenSet_18_
tokenSet_19_
tokenSet_2_
tokenSet_20_
tokenSet_21_
tokenSet_22_
tokenSet_23_
tokenSet_24_
tokenSet_25_
tokenSet_26_
tokenSet_27_
tokenSet_28_
tokenSet_29_
tokenSet_3_
tokenSet_30_
tokenSet_31_
tokenSet_32_
tokenSet_33_
tokenSet_34_
tokenSet_35_
tokenSet_36_
tokenSet_37_
tokenSet_38_
tokenSet_39_
tokenSet_4_
tokenSet_40_
tokenSet_41_
tokenSet_42_
tokenSet_43_
tokenSet_44_
tokenSet_45_
tokenSet_46_
tokenSet_47_
tokenSet_48_
tokenSet_49_
tokenSet_5_
tokenSet_50_
tokenSet_51_
tokenSet_52_
tokenSet_53_
tokenSet_54_
tokenSet_55_
tokenSet_56_
tokenSet_57_
tokenSet_58_
tokenSet_59_
tokenSet_6_
tokenSet_60_
tokenSet_61_
tokenSet_62_
tokenSet_63_
tokenSet_64_
tokenSet_65_
tokenSet_66_
tokenSet_67_
tokenSet_68_
tokenSet_69_
tokenSet_7_
tokenSet_70_
tokenSet_71_
tokenSet_72_
tokenSet_73_
tokenSet_74_
tokenSet_75_
tokenSet_76_
tokenSet_77_
tokenSet_78_
tokenSet_79_
tokenSet_8_
tokenSet_80_
tokenSet_81_
tokenSet_82_
tokenSet_83_
tokenSet_84_
tokenSet_85_
tokenSet_86_
tokenSet_87_
tokenSet_88_
tokenSet_89_
tokenSet_9_
tokenSet_90_
tokenSet_91_
tokenSet_92_
tokenSet_93_
tokenSet_94_
tokenSet_95_
tokenSet_96_
tokenSet_97_
tokenSet_98_
tokenSet_99_
TRUE
TRY
TryCatchFinallyStmt
TryStmt
TYPE
TYPEOF
TypeOfExpr
TypeRef
Types
UINT
ULONG
UnaryExpr
UNCHECKED
UncheckedExpr
UncheckedStmt
UNICODE_ESCAPE_SEQUENCE
UNSAFE
USHORT
USING
UsingNode
UsingStmt
VariableDeclStmt
VERBATIM_STRING_LITERAL
VIRTUAL
VOID
VOLATILE
WHILE
WHITESPACE

Protected Internal Instance Fields

astFactory (inherited from antlr.Parser)
inputState (inherited from antlr.Parser)
returnAST (inherited from antlr.Parser)
tokenNames (inherited from antlr.Parser)
traceDepth (inherited from antlr.Parser)

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.ABSTRACT Field

public const int ABSTRACT = 201;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.AccessorNode Field

public const int AccessorNode = 30;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.Arg Field

public const int Arg = 37;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.ArgDirection Field

public const int ArgDirection = 40;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.Args Field

public const int Args = 36;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.ArrayCreateExpr Field

public const int ArrayCreateExpr = 80;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.ArrayInitExpr Field

public const int ArrayInitExpr = 89;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.ArrayRankExpr Field

public const int ArrayRankExpr = 88;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.AS Field

public const int AS = 150;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.ASSEMBLY Field

public const int ASSEMBLY = 220;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.ASSIGN Field

public const int ASSIGN = 160;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.AssignExpr Field

public const int AssignExpr = 76;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.BAND Field

public const int BAND = 153;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.BAND_ASN Field

public const int BAND_ASN = 166;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.BASE Field

public const int BASE = 128;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.BaseRefExpr Field

public const int BaseRefExpr = 74;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.BaseTypes Field

public const int BaseTypes = 12;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.BinaryExpr Field

public const int BinaryExpr = 78;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.BNOT Field

public const int BNOT = 139;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.BOOL Field

public const int BOOL = 109;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.BooleanLiteral Field

public const int BooleanLiteral = 13;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.BOR Field

public const int BOR = 155;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.BOR_ASN Field

public const int BOR_ASN = 167;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.BREAK Field

public const int BREAK = 185;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.BreakStmt Field

public const int BreakStmt = 57;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.BSR Field

public const int BSR = 253;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.BSR_ASN Field

public const int BSR_ASN = 254;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.BuiltInType Field

public const int BuiltInType = 35;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.BXOR Field

public const int BXOR = 154;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.BXOR_ASN Field

public const int BXOR_ASN = 168;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.BYTE Field

public const int BYTE = 112;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.CASE Field

public const int CASE = 178;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.CastExpr Field

public const int CastExpr = 72;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.CATCH Field

public const int CATCH = 193;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.CatchClause Field

public const int CatchClause = 46;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.CHAR Field

public const int CHAR = 119;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.CHARACTER Field

public const int CHARACTER = 245;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.CHARACTER_LITERAL Field

public const int CHARACTER_LITERAL = 101;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.CharLiteral Field

public const int CharLiteral = 16;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.CHECKED Field

public const int CHECKED = 134;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.CheckedExpr Field

public const int CheckedExpr = 84;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.CheckedStmt Field

public const int CheckedStmt = 60;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.CLASS Field

public const int CLASS = 196;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.ClassNode Field

public const int ClassNode = 7;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.COLON Field

public const int COLON = 159;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.COMMA Field

public const int COMMA = 123;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.CommentNode Field

public const int CommentNode = 43;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.CompileUnit Field

public const int CompileUnit = 4;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.CONDITIONAL_SYMBOL Field

public const int CONDITIONAL_SYMBOL = 263;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.CONST Field

public const int CONST = 174;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.ConstantDeclStmt Field

public const int ConstantDeclStmt = 66;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.ConstantNode Field

public const int ConstantNode = 25;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.ConstructorNode Field

public const int ConstructorNode = 28;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.CONTINUE Field

public const int CONTINUE = 186;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.ContinueStmt Field

public const int ContinueStmt = 58;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.CustomAttribute Field

public const int CustomAttribute = 93;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.CustomAttributes Field

public const int CustomAttributes = 92;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.DEC Field

public const int DEC = 130;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.DECIMAL Field

public const int DECIMAL = 110;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.DECIMAL_DIGIT Field

public const int DECIMAL_DIGIT = 239;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.Declarator Field

public const int Declarator = 91;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.DeclArg Field

public const int DeclArg = 39;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.DeclArgs Field

public const int DeclArgs = 38;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.DEFAULT Field

public const int DEFAULT = 179;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.DELEGATE Field

public const int DELEGATE = 219;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.DelegateNode Field

public const int DelegateNode = 11;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.DELIMITED_COMMENT Field

public const int DELIMITED_COMMENT = 97;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.DestructorNode Field

public const int DestructorNode = 29;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.DIV Field

public const int DIV = 141;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.DIV_ASN Field

public const int DIV_ASN = 164;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.DO Field

public const int DO = 181;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.DOT Field

public const int DOT = 106;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.DOUBLE Field

public const int DOUBLE = 121;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.ELSE Field

public const int ELSE = 176;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.ENUM Field

public const int ENUM = 218;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.EnumMemberNode Field

public const int EnumMemberNode = 31;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.EnumNode Field

public const int EnumNode = 10;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.EOF Field

public const int EOF = 1;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.EQUAL Field

public const int EQUAL = 151;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.EVENT Field

public const int EVENT = 212;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.EventNode Field

public const int EventNode = 24;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.EXPLICIT Field

public const int EXPLICIT = 215;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.EXPONENT_PART Field

public const int EXPONENT_PART = 242;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.expression Method

public void expression();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.Expressions Field

public const int Expressions = 67;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.ExprStmt Field

public const int ExprStmt = 42;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.EXTERN Field

public const int EXTERN = 208;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.FALSE Field

public const int FALSE = 104;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.FIELD Field

public const int FIELD = 221;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.FieldNode Field

public const int FieldNode = 22;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.FINALLY Field

public const int FINALLY = 194;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.FinallyStmt Field

public const int FinallyStmt = 47;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.FIXED Field

public const int FIXED = 229;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.FLOAT Field

public const int FLOAT = 120;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.FOR Field

public const int FOR = 182;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.FOREACH Field

public const int FOREACH = 183;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.ForEachStmt Field

public const int ForEachStmt = 54;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.GE Field

public const int GE = 148;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.GOTO Field

public const int GOTO = 187;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.GotoStmt Field

public const int GotoStmt = 55;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.GTHAN Field

public const int GTHAN = 146;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.HASH Field

public const int HASH = 255;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.HEX_DIGIT Field

public const int HEX_DIGIT = 241;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.HEXADECIMAL_ESCAPE_SEQUENCE Field

public const int HEXADECIMAL_ESCAPE_SEQUENCE = 248;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.HEXADECIMAL_INTEGER_LITERAL Field

public const int HEXADECIMAL_INTEGER_LITERAL = 99;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.Ident Field

public const int Ident = 32;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.identifier Method

public void identifier();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.IDENTIFIER_PART_CHARACTER Field

public const int IDENTIFIER_PART_CHARACTER = 237;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.IDENTIFIER_START_CHARACTER Field

public const int IDENTIFIER_START_CHARACTER = 236;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.IF Field

public const int IF = 175;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.IfStmt Field

public const int IfStmt = 48;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.IMPLICIT Field

public const int IMPLICIT = 214;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.IN Field

public const int IN = 184;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.INC Field

public const int INC = 129;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.IncStmt Field

public const int IncStmt = 53;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.IndexerExpr Field

public const int IndexerExpr = 87;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.IndexerNode Field

public const int IndexerNode = 26;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.InitStmt Field

public const int InitStmt = 52;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.INT Field

public const int INT = 115;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.INTEGER_LITERAL Field

public const int INTEGER_LITERAL = 98;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.INTEGER_TYPE_SUFFIX Field

public const int INTEGER_TYPE_SUFFIX = 240;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.IntegerLiteral Field

public const int IntegerLiteral = 14;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.INTERFACE Field

public const int INTERFACE = 217;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.InterfaceNode Field

public const int InterfaceNode = 8;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.INTERNAL Field

public const int INTERNAL = 199;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.InvokeExpr Field

public const int InvokeExpr = 86;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.IS Field

public const int IS = 149;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.IterationStmt Field

public const int IterationStmt = 51;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.LabeledStmt Field

public const int LabeledStmt = 64;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.LAND Field

public const int LAND = 156;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.LBRACE Field

public const int LBRACE = 171;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.LBRACK Field

public const int LBRACK = 122;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.LE Field

public const int LE = 147;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.LNOT Field

public const int LNOT = 138;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.LOCK Field

public const int LOCK = 190;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.LockStmt Field

public const int LockStmt = 62;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.LONG Field

public const int LONG = 117;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.LOR Field

public const int LOR = 157;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.LPAREN Field

public const int LPAREN = 125;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.LTHAN Field

public const int LTHAN = 145;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.MemberAccessExpr Field

public const int MemberAccessExpr = 75;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.Members Field

public const int Members = 20;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.METHOD Field

public const int METHOD = 222;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.MethodNode Field

public const int MethodNode = 21;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.MINUS Field

public const int MINUS = 137;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.MINUS_ASN Field

public const int MINUS_ASN = 162;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.MOD Field

public const int MOD = 142;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.MOD_ASN Field

public const int MOD_ASN = 165;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.ModifierAttributes Field

public const int ModifierAttributes = 94;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.MODULE Field

public const int MODULE = 223;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.NAMESPACE Field

public const int NAMESPACE = 195;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.NamespaceNode Field

public const int NamespaceNode = 6;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.NEW Field

public const int NEW = 131;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.NEW_LINE Field

public const int NEW_LINE = 231;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.NEW_LINE_CHARACTER Field

public const int NEW_LINE_CHARACTER = 232;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.NOT_EQUAL Field

public const int NOT_EQUAL = 152;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.NOT_NEW_LINE Field

public const int NOT_NEW_LINE = 233;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.NULL Field

public const int NULL = 105;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.NULL_TREE_LOOKAHEAD Field

public const int NULL_TREE_LOOKAHEAD = 3;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.NullLiteral Field

public const int NullLiteral = 18;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.NUMERIC_LITERAL Field

public const int NUMERIC_LITERAL = 238;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.OBJECT Field

public const int OBJECT = 107;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.ObjectCreateExpr Field

public const int ObjectCreateExpr = 81;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.Op Field

public const int Op = 90;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.OPERATOR Field

public const int OPERATOR = 213;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.OperatorNode Field

public const int OperatorNode = 27;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.OUT Field

public const int OUT = 211;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.OVERRIDE Field

public const int OVERRIDE = 207;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.PARAM Field

public const int PARAM = 224;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.PARAMS Field

public const int PARAMS = 209;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.PLUS Field

public const int PLUS = 136;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.PLUS_ASN Field

public const int PLUS_ASN = 161;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.PostfixExpr Field

public const int PostfixExpr = 83;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.PP_DECLARATION Field

public const int PP_DECLARATION = 260;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.PP_DIRECTIVE Field

public const int PP_DIRECTIVE = 259;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.PP_MESSAGE Field

public const int PP_MESSAGE = 262;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.PP_NEW_LINE Field

public const int PP_NEW_LINE = 257;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.PP_REGION Field

public const int PP_REGION = 261;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.PP_WHITESPACE Field

public const int PP_WHITESPACE = 258;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.PPT_DEFINE Field

public const int PPT_DEFINE = 264;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.PPT_END_REGION Field

public const int PPT_END_REGION = 267;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.PPT_REGION Field

public const int PPT_REGION = 266;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.PPT_UNDEF Field

public const int PPT_UNDEF = 265;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.PrimaryExpression Field

public const int PrimaryExpression = 69;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.PrimitiveExpr Field

public const int PrimitiveExpr = 71;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.PRIVATE Field

public const int PRIVATE = 200;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.PROPERTY Field

public const int PROPERTY = 225;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.PropertyNode Field

public const int PropertyNode = 23;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.PROTECTED Field

public const int PROTECTED = 198;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.PUBLIC Field

public const int PUBLIC = 197;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.QualIdent Field

public const int QualIdent = 33;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.QUESTION Field

public const int QUESTION = 158;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.QUOTE Field

public const int QUOTE = 256;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.RBRACE Field

public const int RBRACE = 172;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.RBRACK Field

public const int RBRACK = 124;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.READONLY Field

public const int READONLY = 204;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.REAL_LITERAL Field

public const int REAL_LITERAL = 100;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.REAL_TYPE_SUFFIX Field

public const int REAL_TYPE_SUFFIX = 244;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.RealLiteral Field

public const int RealLiteral = 15;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.REF Field

public const int REF = 210;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.REGULAR_STRING_LITERAL Field

public const int REGULAR_STRING_LITERAL = 249;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.REGULAR_STRING_LITERAL_CHARACTER Field

public const int REGULAR_STRING_LITERAL_CHARACTER = 250;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.RETURN Field

public const int RETURN = 188;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.ReturnStmt Field

public const int ReturnStmt = 56;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.RPAREN Field

public const int RPAREN = 126;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.SBYTE Field

public const int SBYTE = 111;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.SEALED Field

public const int SEALED = 202;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.SEMI Field

public const int SEMI = 173;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.SHORT Field

public const int SHORT = 113;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.SIGN Field

public const int SIGN = 243;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.SIMPLE_ESCAPE_SEQUENCE Field

public const int SIMPLE_ESCAPE_SEQUENCE = 247;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.SINGLE_CHARACTER Field

public const int SINGLE_CHARACTER = 246;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.SINGLE_LINE_COMMENT Field

public const int SINGLE_LINE_COMMENT = 96;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.SINGLE_REGULAR_STRING_LITERAL_CHARACTER Field

public const int SINGLE_REGULAR_STRING_LITERAL_CHARACTER = 251;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.SIZEOF Field

public const int SIZEOF = 227;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.SL Field

public const int SL = 143;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.SL_ASN Field

public const int SL_ASN = 169;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.SR Field

public const int SR = 144;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.SR_ASN Field

public const int SR_ASN = 170;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.STACKALLOC Field

public const int STACKALLOC = 228;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.STAR Field

public const int STAR = 140;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.STAR_ASN Field

public const int STAR_ASN = 163;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.Statements Field

public const int Statements = 41;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.STATIC Field

public const int STATIC = 203;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.STRING Field

public const int STRING = 108;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.STRING_LITERAL Field

public const int STRING_LITERAL = 102;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.StringLiteral Field

public const int StringLiteral = 17;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.STRUCT Field

public const int STRUCT = 216;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.StructNode Field

public const int StructNode = 9;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.SubExpr Field

public const int SubExpr = 70;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.SWITCH Field

public const int SWITCH = 177;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.SwitchSection Field

public const int SwitchSection = 50;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.SwitchStmt Field

public const int SwitchStmt = 49;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.TernaryExpr Field

public const int TernaryExpr = 79;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.THIS Field

public const int THIS = 127;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.ThisRefExpr Field

public const int ThisRefExpr = 73;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.THROW Field

public const int THROW = 189;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.ThrowStmt Field

public const int ThrowStmt = 59;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenNames_ Field

public static readonly string[] tokenNames_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_0_ Field

public static readonly BitSet tokenSet_0_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_1_ Field

public static readonly BitSet tokenSet_1_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_10_ Field

public static readonly BitSet tokenSet_10_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_100_ Field

public static readonly BitSet tokenSet_100_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_101_ Field

public static readonly BitSet tokenSet_101_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_102_ Field

public static readonly BitSet tokenSet_102_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_103_ Field

public static readonly BitSet tokenSet_103_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_104_ Field

public static readonly BitSet tokenSet_104_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_105_ Field

public static readonly BitSet tokenSet_105_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_106_ Field

public static readonly BitSet tokenSet_106_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_107_ Field

public static readonly BitSet tokenSet_107_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_108_ Field

public static readonly BitSet tokenSet_108_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_109_ Field

public static readonly BitSet tokenSet_109_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_11_ Field

public static readonly BitSet tokenSet_11_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_110_ Field

public static readonly BitSet tokenSet_110_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_111_ Field

public static readonly BitSet tokenSet_111_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_112_ Field

public static readonly BitSet tokenSet_112_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_113_ Field

public static readonly BitSet tokenSet_113_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_114_ Field

public static readonly BitSet tokenSet_114_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_115_ Field

public static readonly BitSet tokenSet_115_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_116_ Field

public static readonly BitSet tokenSet_116_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_117_ Field

public static readonly BitSet tokenSet_117_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_118_ Field

public static readonly BitSet tokenSet_118_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_119_ Field

public static readonly BitSet tokenSet_119_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_12_ Field

public static readonly BitSet tokenSet_12_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_120_ Field

public static readonly BitSet tokenSet_120_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_121_ Field

public static readonly BitSet tokenSet_121_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_122_ Field

public static readonly BitSet tokenSet_122_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_123_ Field

public static readonly BitSet tokenSet_123_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_124_ Field

public static readonly BitSet tokenSet_124_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_125_ Field

public static readonly BitSet tokenSet_125_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_126_ Field

public static readonly BitSet tokenSet_126_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_127_ Field

public static readonly BitSet tokenSet_127_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_128_ Field

public static readonly BitSet tokenSet_128_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_129_ Field

public static readonly BitSet tokenSet_129_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_13_ Field

public static readonly BitSet tokenSet_13_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_130_ Field

public static readonly BitSet tokenSet_130_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_131_ Field

public static readonly BitSet tokenSet_131_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_132_ Field

public static readonly BitSet tokenSet_132_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_133_ Field

public static readonly BitSet tokenSet_133_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_134_ Field

public static readonly BitSet tokenSet_134_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_135_ Field

public static readonly BitSet tokenSet_135_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_136_ Field

public static readonly BitSet tokenSet_136_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_137_ Field

public static readonly BitSet tokenSet_137_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_14_ Field

public static readonly BitSet tokenSet_14_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_15_ Field

public static readonly BitSet tokenSet_15_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_16_ Field

public static readonly BitSet tokenSet_16_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_17_ Field

public static readonly BitSet tokenSet_17_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_18_ Field

public static readonly BitSet tokenSet_18_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_19_ Field

public static readonly BitSet tokenSet_19_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_2_ Field

public static readonly BitSet tokenSet_2_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_20_ Field

public static readonly BitSet tokenSet_20_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_21_ Field

public static readonly BitSet tokenSet_21_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_22_ Field

public static readonly BitSet tokenSet_22_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_23_ Field

public static readonly BitSet tokenSet_23_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_24_ Field

public static readonly BitSet tokenSet_24_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_25_ Field

public static readonly BitSet tokenSet_25_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_26_ Field

public static readonly BitSet tokenSet_26_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_27_ Field

public static readonly BitSet tokenSet_27_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_28_ Field

public static readonly BitSet tokenSet_28_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_29_ Field

public static readonly BitSet tokenSet_29_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_3_ Field

public static readonly BitSet tokenSet_3_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_30_ Field

public static readonly BitSet tokenSet_30_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_31_ Field

public static readonly BitSet tokenSet_31_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_32_ Field

public static readonly BitSet tokenSet_32_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_33_ Field

public static readonly BitSet tokenSet_33_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_34_ Field

public static readonly BitSet tokenSet_34_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_35_ Field

public static readonly BitSet tokenSet_35_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_36_ Field

public static readonly BitSet tokenSet_36_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_37_ Field

public static readonly BitSet tokenSet_37_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_38_ Field

public static readonly BitSet tokenSet_38_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_39_ Field

public static readonly BitSet tokenSet_39_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_4_ Field

public static readonly BitSet tokenSet_4_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_40_ Field

public static readonly BitSet tokenSet_40_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_41_ Field

public static readonly BitSet tokenSet_41_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_42_ Field

public static readonly BitSet tokenSet_42_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_43_ Field

public static readonly BitSet tokenSet_43_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_44_ Field

public static readonly BitSet tokenSet_44_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_45_ Field

public static readonly BitSet tokenSet_45_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_46_ Field

public static readonly BitSet tokenSet_46_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_47_ Field

public static readonly BitSet tokenSet_47_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_48_ Field

public static readonly BitSet tokenSet_48_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_49_ Field

public static readonly BitSet tokenSet_49_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_5_ Field

public static readonly BitSet tokenSet_5_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_50_ Field

public static readonly BitSet tokenSet_50_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_51_ Field

public static readonly BitSet tokenSet_51_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_52_ Field

public static readonly BitSet tokenSet_52_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_53_ Field

public static readonly BitSet tokenSet_53_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_54_ Field

public static readonly BitSet tokenSet_54_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_55_ Field

public static readonly BitSet tokenSet_55_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_56_ Field

public static readonly BitSet tokenSet_56_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_57_ Field

public static readonly BitSet tokenSet_57_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_58_ Field

public static readonly BitSet tokenSet_58_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_59_ Field

public static readonly BitSet tokenSet_59_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_6_ Field

public static readonly BitSet tokenSet_6_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_60_ Field

public static readonly BitSet tokenSet_60_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_61_ Field

public static readonly BitSet tokenSet_61_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_62_ Field

public static readonly BitSet tokenSet_62_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_63_ Field

public static readonly BitSet tokenSet_63_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_64_ Field

public static readonly BitSet tokenSet_64_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_65_ Field

public static readonly BitSet tokenSet_65_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_66_ Field

public static readonly BitSet tokenSet_66_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_67_ Field

public static readonly BitSet tokenSet_67_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_68_ Field

public static readonly BitSet tokenSet_68_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_69_ Field

public static readonly BitSet tokenSet_69_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_7_ Field

public static readonly BitSet tokenSet_7_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_70_ Field

public static readonly BitSet tokenSet_70_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_71_ Field

public static readonly BitSet tokenSet_71_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_72_ Field

public static readonly BitSet tokenSet_72_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_73_ Field

public static readonly BitSet tokenSet_73_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_74_ Field

public static readonly BitSet tokenSet_74_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_75_ Field

public static readonly BitSet tokenSet_75_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_76_ Field

public static readonly BitSet tokenSet_76_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_77_ Field

public static readonly BitSet tokenSet_77_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_78_ Field

public static readonly BitSet tokenSet_78_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_79_ Field

public static readonly BitSet tokenSet_79_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_8_ Field

public static readonly BitSet tokenSet_8_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_80_ Field

public static readonly BitSet tokenSet_80_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_81_ Field

public static readonly BitSet tokenSet_81_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_82_ Field

public static readonly BitSet tokenSet_82_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_83_ Field

public static readonly BitSet tokenSet_83_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_84_ Field

public static readonly BitSet tokenSet_84_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_85_ Field

public static readonly BitSet tokenSet_85_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_86_ Field

public static readonly BitSet tokenSet_86_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_87_ Field

public static readonly BitSet tokenSet_87_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_88_ Field

public static readonly BitSet tokenSet_88_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_89_ Field

public static readonly BitSet tokenSet_89_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_9_ Field

public static readonly BitSet tokenSet_9_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_90_ Field

public static readonly BitSet tokenSet_90_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_91_ Field

public static readonly BitSet tokenSet_91_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_92_ Field

public static readonly BitSet tokenSet_92_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_93_ Field

public static readonly BitSet tokenSet_93_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_94_ Field

public static readonly BitSet tokenSet_94_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_95_ Field

public static readonly BitSet tokenSet_95_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_96_ Field

public static readonly BitSet tokenSet_96_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_97_ Field

public static readonly BitSet tokenSet_97_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_98_ Field

public static readonly BitSet tokenSet_98_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.tokenSet_99_ Field

public static readonly BitSet tokenSet_99_;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.TRUE Field

public const int TRUE = 103;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.TRY Field

public const int TRY = 192;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.TryCatchFinallyStmt Field

public const int TryCatchFinallyStmt = 44;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.TryStmt Field

public const int TryStmt = 45;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.type Method

public void type();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.TYPEOF Field

public const int TYPEOF = 132;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.TypeOfExpr Field

public const int TypeOfExpr = 82;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.TypeRef Field

public const int TypeRef = 34;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.Types Field

public const int Types = 19;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.UINT Field

public const int UINT = 116;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.ULONG Field

public const int ULONG = 118;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.UnaryExpr Field

public const int UnaryExpr = 77;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.UNCHECKED Field

public const int UNCHECKED = 135;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.UncheckedExpr Field

public const int UncheckedExpr = 85;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.UncheckedStmt Field

public const int UncheckedStmt = 61;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.UNICODE_ESCAPE_SEQUENCE Field

public const int UNICODE_ESCAPE_SEQUENCE = 235;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.UNSAFE Field

public const int UNSAFE = 230;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.USHORT Field

public const int USHORT = 114;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.USING Field

public const int USING = 191;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.UsingNode Field

public const int UsingNode = 5;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.UsingStmt Field

public const int UsingStmt = 63;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.VariableDeclStmt Field

public const int VariableDeclStmt = 65;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.VERBATIM_STRING_LITERAL Field

public const int VERBATIM_STRING_LITERAL = 252;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.VIRTUAL Field

public const int VIRTUAL = 206;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.VOID Field

public const int VOID = 133;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.VOLATILE Field

public const int VOLATILE = 205;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.WHILE Field

public const int WHILE = 180;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.WHITESPACE Field

public const int WHITESPACE = 234;

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser Methods

The methods of the CSharpParser class are listed below. For a complete list of CSharpParser class members, see the CSharpParser Members topic.

Public Static Methods

initializeASTFactory

Public Instance Methods

accessible_predefined_types |
accessor_body |
accessor_declaration |
accessor_declarations |
accessor_modifier |
additive_expression |
additive_op |
addMessageListener (inherited from antlr.Parser) |
addParserListener (inherited from antlr.Parser) |
addParserMatchListener (inherited from antlr.Parser) |
addParserTokenListener (inherited from antlr.Parser) |
addSemanticPredicateListener (inherited from antlr.Parser) |
addSyntacticPredicateListener (inherited from antlr.Parser) |
addTraceListener (inherited from antlr.Parser) |
and_expression |
annotated_statement_expression |
argument |
argument_list |
array_creation_expression |
array_initializer |
array_rank |
array_type |
assignment |
assignment_operator |
attribute |
attribute_argument |
attribute_argument_list |
attribute_arguments |
attribute_list |
attribute_section |
attribute_target |
attributes |
base_access |
binary_operator_declarator |
block |
boolean_expression |
boolean_literal |
break_statement |
cast_expression |
catch_clause |
catch_clauses |
checked_expression |
checked_statement |
class_base |
class_body |
class_declaration |
class_member_declaration |
class_modifiers |
class_type |
comment |
compilation_unit |
conditional_and_expression |
conditional_expression |
conditional_or_expression |
constant_declaration |
constant_declarator |
constant_declarators |
constant_expression |
constant_modifiers |
constructor_body |
constructor_declaration |
constructor_declarator |
constructor_init_modifiers |
constructor_initializer |
constructor_modifiers |
consume (inherited from antlr.LLkParser) |
consumeUntil (inherited from antlr.Parser) | Overloaded.
continue_statement |
conversion_classification |
conversion_operator_declarator |
declaration_statement |
delegate_declaration |
delegate_modifiers |
delegate_type |
destructor_body |
destructor_declaration |
do_statement |
element_access |
embedded_statement |
empty_statement |
enum_base |
enum_body |
enum_declaration |
enum_member_declaration |
enum_modifiers |
equality_expression |
equality_op |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
event_accessor_block |
event_accessor_declaration |
event_accessor_declarations |
event_accessor_modifiers |
event_declaration |
event_modifiers |
exclusive_or_expression |
expression |
expression_list |
expression_statement |
field_declaration |
field_modifiers |
finally_clause |
floating_point_type |
for_condition |
for_initializer |
for_iterator |
for_statement |
foreach_statement |
formal_parameter_list |
getAST (inherited from antlr.Parser) |
getASTFactory (inherited from antlr.Parser) |
getFilename (inherited from antlr.Parser) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
getInputState (inherited from antlr.Parser) |
getTokenName (inherited from antlr.Parser) |
getTokenNames (inherited from antlr.Parser) |
GetType (inherited from Object) | Gets the Type of the current instance.
global_attributes |
goto_statement |
identifier |
if_statement |
inclusive_or_expression |
indexer_declaration |
indexer_declarator |
indexer_modifiers |
integral_type |
interface_accessor |
interface_accessors |
interface_base |
interface_body |
interface_declaration |
interface_event_declaration |
interface_indexer_declaration |
interface_member_declaration |
interface_method_declaration |
interface_modifiers |
interface_property_declaration |
interface_type |
invocation_expression |
isDebugMode (inherited from antlr.Parser) |
iteration_statement |
jump_statement |
LA (inherited from antlr.LLkParser) |
labeled_statement |
literal |
local_constant_declaration |
local_variable_declaration |
local_variable_declarator |
local_variable_declarators |
local_variable_initializer |
lock_statement |
LT (inherited from antlr.LLkParser) |
mark (inherited from antlr.Parser) |
match (inherited from antlr.Parser) | Overloaded.
matchNot (inherited from antlr.Parser) |
member_access |
member_name |
method_body |
method_declaration |
method_header |
method_modifiers |
method_parameter |
multiplicative_expression |
multiplicative_op |
namespace_body |
namespace_declaration |
namespace_member_declaration |
namespace_name |
namespace_or_type_name |
non_array_type |
null_literal |
numeric_type |
object_creation_expression |
operator_body |
operator_declaration |
operator_declarator |
operator_modifiers |
overloadable_binary_operator |
overloadable_unary_operator |
parameter_direction |
parenthesized_expression |
postfix_expression |
postfix_op |
pre_decrement_expression |
pre_increment_expression |
predefined_type_access |
primary_expression |
primary_start |
property_declaration |
property_modifiers |
qualified_identifier |
rank_specifiers |
reference_type |
relational_expression |
relational_op |
removeMessageListener (inherited from antlr.Parser) |
removeParserListener (inherited from antlr.Parser) |
removeParserMatchListener (inherited from antlr.Parser) |
removeParserTokenListener (inherited from antlr.Parser) |
removeSemanticPredicateListener (inherited from antlr.Parser) |
removeSyntacticPredicateListener (inherited from antlr.Parser) |
removeTraceListener (inherited from antlr.Parser) |
reportError (inherited from antlr.Parser) | Overloaded.
reportWarning (inherited from antlr.Parser) |
resource_acquisition |
return_statement |
return_type |
rewind (inherited from antlr.Parser) |
selection_statement |
setASTFactory (inherited from antlr.Parser) |
setASTNodeClass (inherited from antlr.Parser) |
setASTNodeType (inherited from antlr.Parser) | Obsolete.
setDebugMode (inherited from antlr.Parser) |
setFilename (inherited from antlr.Parser) |
setIgnoreInvalidDebugCalls (inherited from antlr.Parser) |
setInputState (inherited from antlr.Parser) |
setTokenBuffer (inherited from antlr.Parser) |
shift_expression |
shift_op |
simple_name |
simple_type |
sizeof_expression |
statement |
statement_expression |
statement_expression_list |
statement_list |
static_constructor_body |
static_constructor_declaration |
static_constructor_modifiers |
struct_body |
struct_declaration |
struct_interfaces |
struct_member_declaration |
struct_modifiers |
struct_type |
switch_block |
switch_cases |
switch_label |
switch_section |
switch_statement |
this_access |
throw_statement |
ToString (inherited from Object) | Returns a String that represents the current Object.
traceIn (inherited from antlr.LLkParser) |
traceIndent (inherited from antlr.Parser) |
traceOut (inherited from antlr.LLkParser) |
try_statement |
type |
type_comp_op |
type_declaration |
type_name |
typeof_expression |
typeof_types |
uanry_op |
unary_expression |
unary_operator_declarator |
unchecked_expression |
unchecked_statement |
using_directive |
using_statement |
value_type |
variable_declarator |
variable_declarators |
variable_initializer |
variable_reference |
while_statement |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
initialize |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

defaultDebuggingSetup (inherited from antlr.Parser)

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.accessible_predefined_types Method

public void accessible_predefined_types();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.accessor_body Method

public void accessor_body();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.accessor_declaration Method

public void accessor_declaration();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.accessor_declarations Method

public void accessor_declarations();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.accessor_modifier Method

public void accessor_modifier();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.additive_expression Method

public void additive_expression();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.additive_op Method

public void additive_op();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.and_expression Method

public void and_expression();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.annotated_statement_expression Method

public void annotated_statement_expression();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.argument Method

public void argument();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.argument_list Method

public void argument_list();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.array_creation_expression Method

public void array_creation_expression();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.array_initializer Method

public void array_initializer();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.array_rank Method

public void array_rank();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.array_type Method

public void array_type();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.assignment Method

public void assignment();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.assignment_operator Method

public void assignment_operator();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.attribute Method

public void attribute();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.attribute_argument Method

public void attribute_argument();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.attribute_argument_list Method

public void attribute_argument_list();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.attribute_arguments Method

public void attribute_arguments();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.attribute_list Method

public void attribute_list();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.attribute_section Method

public void attribute_section();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.attribute_target Method

public void attribute_target();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.attributes Method

public void attributes();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.base_access Method

public void base_access();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.binary_operator_declarator Method

public void binary_operator_declarator();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.block Method

public void block();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.boolean_expression Method

public void boolean_expression();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.boolean_literal Method

public void boolean_literal();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.break_statement Method

public void break_statement();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.cast_expression Method

public void cast_expression();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.catch_clause Method

public void catch_clause();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.catch_clauses Method

public void catch_clauses();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.checked_expression Method

public void checked_expression();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.checked_statement Method

public void checked_statement();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.class_base Method

public void class_base();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.class_body Method

public void class_body();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.class_declaration Method

public void class_declaration();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.class_member_declaration Method

public void class_member_declaration();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.class_modifiers Method

public void class_modifiers();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.class_type Method

public void class_type();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.comment Method

public void comment();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.compilation_unit Method

public void compilation_unit();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.conditional_and_expression Method

public void conditional_and_expression();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.conditional_expression Method

public void conditional_expression();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.conditional_or_expression Method

public void conditional_or_expression();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.constant_declaration Method

public void constant_declaration();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.constant_declarator Method

public void constant_declarator();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.constant_declarators Method

public void constant_declarators();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.constant_expression Method

public void constant_expression();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.constant_modifiers Method

public void constant_modifiers();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.constructor_body Method

public void constructor_body();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.constructor_declaration Method

public void constructor_declaration();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.constructor_declarator Method

public void constructor_declarator();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.constructor_init_modifiers Method

public void constructor_init_modifiers();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.constructor_initializer Method

public void constructor_initializer();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.constructor_modifiers Method

public void constructor_modifiers();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.continue_statement Method

public void continue_statement();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.conversion_classification Method

public void conversion_classification();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.conversion_operator_declarator Method

public void conversion_operator_declarator();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.declaration_statement Method

public void declaration_statement();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.delegate_declaration Method

public void delegate_declaration();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.delegate_modifiers Method

public void delegate_modifiers();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.delegate_type Method

public void delegate_type();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.destructor_body Method

public void destructor_body();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.destructor_declaration Method

public void destructor_declaration();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.do_statement Method

public void do_statement();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.element_access Method

public void element_access();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.embedded_statement Method

public void embedded_statement();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.empty_statement Method

public void empty_statement();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.enum_base Method

public void enum_base();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.enum_body Method

public void enum_body();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.enum_declaration Method

public void enum_declaration();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.enum_member_declaration Method

public void enum_member_declaration();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.enum_modifiers Method

public void enum_modifiers();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.equality_expression Method

public void equality_expression();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.equality_op Method

public void equality_op();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.event_accessor_block Method

public void event_accessor_block();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.event_accessor_declaration Method

public void event_accessor_declaration();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.event_accessor_declarations Method

public void event_accessor_declarations();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.event_accessor_modifiers Method

public void event_accessor_modifiers();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.event_declaration Method

public void event_declaration();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.event_modifiers Method

public void event_modifiers();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.exclusive_or_expression Method

public void exclusive_or_expression();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.expression_list Method

public void expression_list();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.expression_statement Method

public void expression_statement();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.field_declaration Method

public void field_declaration();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.field_modifiers Method

public void field_modifiers();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.finally_clause Method

public void finally_clause();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.floating_point_type Method

public void floating_point_type();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.for_condition Method

public void for_condition();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.for_initializer Method

public void for_initializer();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.for_iterator Method

public void for_iterator();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.for_statement Method

public void for_statement();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.foreach_statement Method

public void foreach_statement();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.formal_parameter_list Method

public void formal_parameter_list();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.global_attributes Method

public void global_attributes();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.goto_statement Method

public void goto_statement();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.if_statement Method

public void if_statement();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.inclusive_or_expression Method

public void inclusive_or_expression();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.indexer_declaration Method

public void indexer_declaration();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.indexer_declarator Method

public void indexer_declarator();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.indexer_modifiers Method

public void indexer_modifiers();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.initialize Method

protected void initialize();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.initializeASTFactory Method

public static void initializeASTFactory(
ASTFactory factory
);

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.integral_type Method

public void integral_type();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.interface_accessor Method

public void interface_accessor();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.interface_accessors Method

public void interface_accessors();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.interface_base Method

public void interface_base();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.interface_body Method

public void interface_body();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.interface_declaration Method

public void interface_declaration();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.interface_event_declaration Method

public void interface_event_declaration();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.interface_indexer_declaration Method

public void interface_indexer_declaration();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.interface_member_declaration Method

public void interface_member_declaration();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.interface_method_declaration Method

public void interface_method_declaration();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.interface_modifiers Method

public void interface_modifiers();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.interface_property_declaration Method

public void interface_property_declaration();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.interface_type Method

public void interface_type();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.invocation_expression Method

public void invocation_expression();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.iteration_statement Method

public void iteration_statement();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.jump_statement Method

public void jump_statement();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.labeled_statement Method

public void labeled_statement();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.literal Method

public void literal();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.local_constant_declaration Method

public void local_constant_declaration();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.local_variable_declaration Method

public void local_variable_declaration();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.local_variable_declarator Method

public void local_variable_declarator();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.local_variable_declarators Method

public void local_variable_declarators();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.local_variable_initializer Method

public void local_variable_initializer();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.lock_statement Method

public void lock_statement();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.member_access Method

public void member_access();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.member_name Method

public void member_name();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.method_body Method

public void method_body();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.method_declaration Method

public void method_declaration();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.method_header Method

public void method_header();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.method_modifiers Method

public void method_modifiers();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.method_parameter Method

public void method_parameter();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.multiplicative_expression Method

public void multiplicative_expression();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.multiplicative_op Method

public void multiplicative_op();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.namespace_body Method

public void namespace_body();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.namespace_declaration Method

public void namespace_declaration();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.namespace_member_declaration Method

public void namespace_member_declaration();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.namespace_name Method

public void namespace_name();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.namespace_or_type_name Method

public void namespace_or_type_name();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.non_array_type Method

public void non_array_type();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.null_literal Method

public void null_literal();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.numeric_type Method

public void numeric_type();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.object_creation_expression Method

public void object_creation_expression();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.operator_body Method

public void operator_body();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.operator_declaration Method

public void operator_declaration();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.operator_declarator Method

public void operator_declarator();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.operator_modifiers Method

public void operator_modifiers();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.overloadable_binary_operator Method

public void overloadable_binary_operator();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.overloadable_unary_operator Method

public void overloadable_unary_operator();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.parameter_direction Method

public void parameter_direction();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.parenthesized_expression Method

public void parenthesized_expression();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.postfix_expression Method

public void postfix_expression();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.postfix_op Method

public void postfix_op();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.pre_decrement_expression Method

public void pre_decrement_expression();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.pre_increment_expression Method

public void pre_increment_expression();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.predefined_type_access Method

public void predefined_type_access();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.primary_expression Method

public void primary_expression();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.primary_start Method

public void primary_start();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.property_declaration Method

public void property_declaration();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.property_modifiers Method

public void property_modifiers();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.qualified_identifier Method

public void qualified_identifier();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.rank_specifiers Method

public void rank_specifiers();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.reference_type Method

public void reference_type();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.relational_expression Method

public void relational_expression();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.relational_op Method

public void relational_op();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.resource_acquisition Method

public void resource_acquisition();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.return_statement Method

public void return_statement();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.return_type Method

public void return_type();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.selection_statement Method

public void selection_statement();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.shift_expression Method

public void shift_expression();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.shift_op Method

public void shift_op();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.simple_name Method

public void simple_name();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.simple_type Method

public void simple_type();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.sizeof_expression Method

public void sizeof_expression();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.statement Method

public void statement();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.statement_expression Method

public void statement_expression();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.statement_expression_list Method

public void statement_expression_list();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.statement_list Method

public void statement_list();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.static_constructor_body Method

public void static_constructor_body();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.static_constructor_declaration Method

public void static_constructor_declaration();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.static_constructor_modifiers Method

public void static_constructor_modifiers();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.struct_body Method

public void struct_body();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.struct_declaration Method

public void struct_declaration();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.struct_interfaces Method

public void struct_interfaces();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.struct_member_declaration Method

public void struct_member_declaration();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.struct_modifiers Method

public void struct_modifiers();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.struct_type Method

public void struct_type();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.switch_block Method

public void switch_block();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.switch_cases Method

public void switch_cases();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.switch_label Method

public void switch_label();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.switch_section Method

public void switch_section();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.switch_statement Method

public void switch_statement();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.this_access Method

public void this_access();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.throw_statement Method

public void throw_statement();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.try_statement Method

public void try_statement();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.type_comp_op Method

public void type_comp_op();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.type_declaration Method

public void type_declaration();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.type_name Method

public void type_name();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.typeof_expression Method

public void typeof_expression();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.typeof_types Method

public void typeof_types();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.uanry_op Method

public void uanry_op();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.unary_expression Method

public void unary_expression();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.unary_operator_declarator Method

public void unary_operator_declarator();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.unchecked_expression Method

public void unchecked_expression();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.unchecked_statement Method

public void unchecked_statement();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.using_directive Method

public void using_directive();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.using_statement Method

public void using_statement();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.value_type Method

public void value_type();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.variable_declarator Method

public void variable_declarator();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.variable_declarators Method

public void variable_declarators();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.variable_initializer Method

public void variable_initializer();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.variable_reference Method

public void variable_reference();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpParser.while_statement Method

public void while_statement();

See Also

CSharpParser Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes Class

For a list of all members of this type, see CSharpTokenTypes Members.

System.Object
DDW.CSharp.Parse.CSharpTokenTypes

public class CSharpTokenTypes

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

CSharpTokenTypes Members | DDW.CSharp.Parse Namespace


CSharpTokenTypes Members

CSharpTokenTypes overview

Public Static Fields

ABSTRACT
AccessorNode
Arg
ArgDirection
Args
ArrayCreateExpr
ArrayInitExpr
ArrayRankExpr
AS
ASSEMBLY
ASSIGN
AssignExpr
BAND
BAND_ASN
BASE
BaseRefExpr
BaseTypes
BinaryExpr
BNOT
BOOL
BooleanLiteral
BOR
BOR_ASN
BREAK
BreakStmt
BSR
BSR_ASN
BuiltInType
BXOR
BXOR_ASN
BYTE
CASE
CastExpr
CATCH
CatchClause
CHAR
CHARACTER
CHARACTER_LITERAL
CharLiteral
CHECKED
CheckedExpr
CheckedStmt
CLASS
ClassNode
COLON
COMMA
CommentNode
CompileUnit
CONDITIONAL_SYMBOL
CONST
ConstantDeclStmt
ConstantNode
ConstructorNode
CONTINUE
ContinueStmt
CustomAttribute
CustomAttributes
DEC
DECIMAL
DECIMAL_DIGIT
Declarator
DeclArg
DeclArgs
DEFAULT
DELEGATE
DelegateNode
DELIMITED_COMMENT
DestructorNode
DIV
DIV_ASN
DO
DOT
DOUBLE
ELSE
ENUM
EnumMemberNode
EnumNode
EOF
EQUAL
EVENT
EventNode
EXPLICIT
EXPONENT_PART
Expression
Expressions
ExprStmt
EXTERN
FALSE
FIELD
FieldNode
FINALLY
FinallyStmt
FIXED
FLOAT
FOR
FOREACH
ForEachStmt
GE
GOTO
GotoStmt
GTHAN
HASH
HEX_DIGIT
HEXADECIMAL_ESCAPE_SEQUENCE
HEXADECIMAL_INTEGER_LITERAL
Ident
IDENTIFIER
IDENTIFIER_PART_CHARACTER
IDENTIFIER_START_CHARACTER
IF
IfStmt
IMPLICIT
IN
INC
IncStmt
IndexerExpr
IndexerNode
InitStmt
INT
INTEGER_LITERAL
INTEGER_TYPE_SUFFIX
IntegerLiteral
INTERFACE
InterfaceNode
INTERNAL
InvokeExpr
IS
IterationStmt
LabeledStmt
LAND
LBRACE
LBRACK
LE
LNOT
LOCK
LockStmt
LONG
LOR
LPAREN
LTHAN
MemberAccessExpr
Members
METHOD
MethodNode
MINUS
MINUS_ASN
MOD
MOD_ASN
ModifierAttributes
MODULE
NAMESPACE
NamespaceNode
NEW
NEW_LINE
NEW_LINE_CHARACTER
NOT_EQUAL
NOT_NEW_LINE
NULL
NULL_TREE_LOOKAHEAD
NullLiteral
NUMERIC_LITERAL
OBJECT
ObjectCreateExpr
Op
OPERATOR
OperatorNode
OUT
OVERRIDE
PARAM
PARAMS
PLUS
PLUS_ASN
PostfixExpr
PP_DECLARATION
PP_DIRECTIVE
PP_MESSAGE
PP_NEW_LINE
PP_REGION
PP_WHITESPACE
PPT_DEFINE
PPT_END_REGION
PPT_REGION
PPT_UNDEF
PrimaryExpression
PrimitiveExpr
PRIVATE
PROPERTY
PropertyNode
PROTECTED
PUBLIC
QualIdent
QUESTION
QUOTE
RBRACE
RBRACK
READONLY
REAL_LITERAL
REAL_TYPE_SUFFIX
RealLiteral
REF
REGULAR_STRING_LITERAL
REGULAR_STRING_LITERAL_CHARACTER
RETURN
ReturnStmt
RPAREN
SBYTE
SEALED
SEMI
SHORT
SIGN
SIMPLE_ESCAPE_SEQUENCE
SINGLE_CHARACTER
SINGLE_LINE_COMMENT
SINGLE_REGULAR_STRING_LITERAL_CHARACTER
SIZEOF
SL
SL_ASN
SR
SR_ASN
STACKALLOC
STAR
STAR_ASN
Statements
STATIC
STRING
STRING_LITERAL
StringLiteral
STRUCT
StructNode
SubExpr
SWITCH
SwitchSection
SwitchStmt
TernaryExpr
THIS
ThisRefExpr
THROW
ThrowStmt
TRUE
TRY
TryCatchFinallyStmt
TryStmt
TYPE
TYPEOF
TypeOfExpr
TypeRef
Types
UINT
ULONG
UnaryExpr
UNCHECKED
UncheckedExpr
UncheckedStmt
UNICODE_ESCAPE_SEQUENCE
UNSAFE
USHORT
USING
UsingNode
UsingStmt
VariableDeclStmt
VERBATIM_STRING_LITERAL
VIRTUAL
VOID
VOLATILE
WHILE
WHITESPACE

Public Instance Constructors

CSharpTokenTypes Constructor Initializes a new instance of the CSharpTokenTypes class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes Constructor

Initializes a new instance of the CSharpTokenTypes class.

public CSharpTokenTypes();

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes Fields

The fields of the CSharpTokenTypes class are listed below. For a complete list of CSharpTokenTypes class members, see the CSharpTokenTypes Members topic.

Public Static Fields

ABSTRACT
AccessorNode
Arg
ArgDirection
Args
ArrayCreateExpr
ArrayInitExpr
ArrayRankExpr
AS
ASSEMBLY
ASSIGN
AssignExpr
BAND
BAND_ASN
BASE
BaseRefExpr
BaseTypes
BinaryExpr
BNOT
BOOL
BooleanLiteral
BOR
BOR_ASN
BREAK
BreakStmt
BSR
BSR_ASN
BuiltInType
BXOR
BXOR_ASN
BYTE
CASE
CastExpr
CATCH
CatchClause
CHAR
CHARACTER
CHARACTER_LITERAL
CharLiteral
CHECKED
CheckedExpr
CheckedStmt
CLASS
ClassNode
COLON
COMMA
CommentNode
CompileUnit
CONDITIONAL_SYMBOL
CONST
ConstantDeclStmt
ConstantNode
ConstructorNode
CONTINUE
ContinueStmt
CustomAttribute
CustomAttributes
DEC
DECIMAL
DECIMAL_DIGIT
Declarator
DeclArg
DeclArgs
DEFAULT
DELEGATE
DelegateNode
DELIMITED_COMMENT
DestructorNode
DIV
DIV_ASN
DO
DOT
DOUBLE
ELSE
ENUM
EnumMemberNode
EnumNode
EOF
EQUAL
EVENT
EventNode
EXPLICIT
EXPONENT_PART
Expression
Expressions
ExprStmt
EXTERN
FALSE
FIELD
FieldNode
FINALLY
FinallyStmt
FIXED
FLOAT
FOR
FOREACH
ForEachStmt
GE
GOTO
GotoStmt
GTHAN
HASH
HEX_DIGIT
HEXADECIMAL_ESCAPE_SEQUENCE
HEXADECIMAL_INTEGER_LITERAL
Ident
IDENTIFIER
IDENTIFIER_PART_CHARACTER
IDENTIFIER_START_CHARACTER
IF
IfStmt
IMPLICIT
IN
INC
IncStmt
IndexerExpr
IndexerNode
InitStmt
INT
INTEGER_LITERAL
INTEGER_TYPE_SUFFIX
IntegerLiteral
INTERFACE
InterfaceNode
INTERNAL
InvokeExpr
IS
IterationStmt
LabeledStmt
LAND
LBRACE
LBRACK
LE
LNOT
LOCK
LockStmt
LONG
LOR
LPAREN
LTHAN
MemberAccessExpr
Members
METHOD
MethodNode
MINUS
MINUS_ASN
MOD
MOD_ASN
ModifierAttributes
MODULE
NAMESPACE
NamespaceNode
NEW
NEW_LINE
NEW_LINE_CHARACTER
NOT_EQUAL
NOT_NEW_LINE
NULL
NULL_TREE_LOOKAHEAD
NullLiteral
NUMERIC_LITERAL
OBJECT
ObjectCreateExpr
Op
OPERATOR
OperatorNode
OUT
OVERRIDE
PARAM
PARAMS
PLUS
PLUS_ASN
PostfixExpr
PP_DECLARATION
PP_DIRECTIVE
PP_MESSAGE
PP_NEW_LINE
PP_REGION
PP_WHITESPACE
PPT_DEFINE
PPT_END_REGION
PPT_REGION
PPT_UNDEF
PrimaryExpression
PrimitiveExpr
PRIVATE
PROPERTY
PropertyNode
PROTECTED
PUBLIC
QualIdent
QUESTION
QUOTE
RBRACE
RBRACK
READONLY
REAL_LITERAL
REAL_TYPE_SUFFIX
RealLiteral
REF
REGULAR_STRING_LITERAL
REGULAR_STRING_LITERAL_CHARACTER
RETURN
ReturnStmt
RPAREN
SBYTE
SEALED
SEMI
SHORT
SIGN
SIMPLE_ESCAPE_SEQUENCE
SINGLE_CHARACTER
SINGLE_LINE_COMMENT
SINGLE_REGULAR_STRING_LITERAL_CHARACTER
SIZEOF
SL
SL_ASN
SR
SR_ASN
STACKALLOC
STAR
STAR_ASN
Statements
STATIC
STRING
STRING_LITERAL
StringLiteral
STRUCT
StructNode
SubExpr
SWITCH
SwitchSection
SwitchStmt
TernaryExpr
THIS
ThisRefExpr
THROW
ThrowStmt
TRUE
TRY
TryCatchFinallyStmt
TryStmt
TYPE
TYPEOF
TypeOfExpr
TypeRef
Types
UINT
ULONG
UnaryExpr
UNCHECKED
UncheckedExpr
UncheckedStmt
UNICODE_ESCAPE_SEQUENCE
UNSAFE
USHORT
USING
UsingNode
UsingStmt
VariableDeclStmt
VERBATIM_STRING_LITERAL
VIRTUAL
VOID
VOLATILE
WHILE
WHITESPACE

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.ABSTRACT Field

public const int ABSTRACT = 201;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.AccessorNode Field

public const int AccessorNode = 30;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.Arg Field

public const int Arg = 37;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.ArgDirection Field

public const int ArgDirection = 40;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.Args Field

public const int Args = 36;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.ArrayCreateExpr Field

public const int ArrayCreateExpr = 80;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.ArrayInitExpr Field

public const int ArrayInitExpr = 89;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.ArrayRankExpr Field

public const int ArrayRankExpr = 88;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.AS Field

public const int AS = 150;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.ASSEMBLY Field

public const int ASSEMBLY = 220;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.ASSIGN Field

public const int ASSIGN = 160;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.AssignExpr Field

public const int AssignExpr = 76;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.BAND Field

public const int BAND = 153;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.BAND_ASN Field

public const int BAND_ASN = 166;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.BASE Field

public const int BASE = 128;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.BaseRefExpr Field

public const int BaseRefExpr = 74;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.BaseTypes Field

public const int BaseTypes = 12;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.BinaryExpr Field

public const int BinaryExpr = 78;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.BNOT Field

public const int BNOT = 139;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.BOOL Field

public const int BOOL = 109;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.BooleanLiteral Field

public const int BooleanLiteral = 13;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.BOR Field

public const int BOR = 155;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.BOR_ASN Field

public const int BOR_ASN = 167;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.BREAK Field

public const int BREAK = 185;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.BreakStmt Field

public const int BreakStmt = 57;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.BSR Field

public const int BSR = 253;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.BSR_ASN Field

public const int BSR_ASN = 254;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.BuiltInType Field

public const int BuiltInType = 35;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.BXOR Field

public const int BXOR = 154;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.BXOR_ASN Field

public const int BXOR_ASN = 168;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.BYTE Field

public const int BYTE = 112;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.CASE Field

public const int CASE = 178;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.CastExpr Field

public const int CastExpr = 72;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.CATCH Field

public const int CATCH = 193;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.CatchClause Field

public const int CatchClause = 46;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.CHAR Field

public const int CHAR = 119;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.CHARACTER Field

public const int CHARACTER = 245;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.CHARACTER_LITERAL Field

public const int CHARACTER_LITERAL = 101;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.CharLiteral Field

public const int CharLiteral = 16;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.CHECKED Field

public const int CHECKED = 134;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.CheckedExpr Field

public const int CheckedExpr = 84;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.CheckedStmt Field

public const int CheckedStmt = 60;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.CLASS Field

public const int CLASS = 196;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.ClassNode Field

public const int ClassNode = 7;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.COLON Field

public const int COLON = 159;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.COMMA Field

public const int COMMA = 123;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.CommentNode Field

public const int CommentNode = 43;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.CompileUnit Field

public const int CompileUnit = 4;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.CONDITIONAL_SYMBOL Field

public const int CONDITIONAL_SYMBOL = 263;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.CONST Field

public const int CONST = 174;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.ConstantDeclStmt Field

public const int ConstantDeclStmt = 66;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.ConstantNode Field

public const int ConstantNode = 25;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.ConstructorNode Field

public const int ConstructorNode = 28;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.CONTINUE Field

public const int CONTINUE = 186;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.ContinueStmt Field

public const int ContinueStmt = 58;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.CustomAttribute Field

public const int CustomAttribute = 93;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.CustomAttributes Field

public const int CustomAttributes = 92;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.DEC Field

public const int DEC = 130;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.DECIMAL Field

public const int DECIMAL = 110;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.DECIMAL_DIGIT Field

public const int DECIMAL_DIGIT = 239;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.Declarator Field

public const int Declarator = 91;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.DeclArg Field

public const int DeclArg = 39;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.DeclArgs Field

public const int DeclArgs = 38;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.DEFAULT Field

public const int DEFAULT = 179;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.DELEGATE Field

public const int DELEGATE = 219;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.DelegateNode Field

public const int DelegateNode = 11;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.DELIMITED_COMMENT Field

public const int DELIMITED_COMMENT = 97;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.DestructorNode Field

public const int DestructorNode = 29;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.DIV Field

public const int DIV = 141;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.DIV_ASN Field

public const int DIV_ASN = 164;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.DO Field

public const int DO = 181;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.DOT Field

public const int DOT = 106;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.DOUBLE Field

public const int DOUBLE = 121;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.ELSE Field

public const int ELSE = 176;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.ENUM Field

public const int ENUM = 218;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.EnumMemberNode Field

public const int EnumMemberNode = 31;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.EnumNode Field

public const int EnumNode = 10;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.EOF Field

public const int EOF = 1;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.EQUAL Field

public const int EQUAL = 151;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.EVENT Field

public const int EVENT = 212;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.EventNode Field

public const int EventNode = 24;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.EXPLICIT Field

public const int EXPLICIT = 215;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.EXPONENT_PART Field

public const int EXPONENT_PART = 242;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.Expression Field

public const int Expression = 68;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.Expressions Field

public const int Expressions = 67;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.ExprStmt Field

public const int ExprStmt = 42;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.EXTERN Field

public const int EXTERN = 208;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.FALSE Field

public const int FALSE = 104;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.FIELD Field

public const int FIELD = 221;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.FieldNode Field

public const int FieldNode = 22;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.FINALLY Field

public const int FINALLY = 194;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.FinallyStmt Field

public const int FinallyStmt = 47;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.FIXED Field

public const int FIXED = 229;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.FLOAT Field

public const int FLOAT = 120;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.FOR Field

public const int FOR = 182;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.FOREACH Field

public const int FOREACH = 183;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.ForEachStmt Field

public const int ForEachStmt = 54;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.GE Field

public const int GE = 148;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.GOTO Field

public const int GOTO = 187;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.GotoStmt Field

public const int GotoStmt = 55;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.GTHAN Field

public const int GTHAN = 146;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.HASH Field

public const int HASH = 255;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.HEX_DIGIT Field

public const int HEX_DIGIT = 241;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.HEXADECIMAL_ESCAPE_SEQUENCE Field

public const int HEXADECIMAL_ESCAPE_SEQUENCE = 248;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.HEXADECIMAL_INTEGER_LITERAL Field

public const int HEXADECIMAL_INTEGER_LITERAL = 99;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.Ident Field

public const int Ident = 32;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.IDENTIFIER Field

public const int IDENTIFIER = 95;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.IDENTIFIER_PART_CHARACTER Field

public const int IDENTIFIER_PART_CHARACTER = 237;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.IDENTIFIER_START_CHARACTER Field

public const int IDENTIFIER_START_CHARACTER = 236;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.IF Field

public const int IF = 175;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.IfStmt Field

public const int IfStmt = 48;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.IMPLICIT Field

public const int IMPLICIT = 214;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.IN Field

public const int IN = 184;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.INC Field

public const int INC = 129;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.IncStmt Field

public const int IncStmt = 53;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.IndexerExpr Field

public const int IndexerExpr = 87;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.IndexerNode Field

public const int IndexerNode = 26;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.InitStmt Field

public const int InitStmt = 52;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.INT Field

public const int INT = 115;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.INTEGER_LITERAL Field

public const int INTEGER_LITERAL = 98;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.INTEGER_TYPE_SUFFIX Field

public const int INTEGER_TYPE_SUFFIX = 240;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.IntegerLiteral Field

public const int IntegerLiteral = 14;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.INTERFACE Field

public const int INTERFACE = 217;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.InterfaceNode Field

public const int InterfaceNode = 8;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.INTERNAL Field

public const int INTERNAL = 199;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.InvokeExpr Field

public const int InvokeExpr = 86;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.IS Field

public const int IS = 149;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.IterationStmt Field

public const int IterationStmt = 51;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.LabeledStmt Field

public const int LabeledStmt = 64;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.LAND Field

public const int LAND = 156;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.LBRACE Field

public const int LBRACE = 171;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.LBRACK Field

public const int LBRACK = 122;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.LE Field

public const int LE = 147;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.LNOT Field

public const int LNOT = 138;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.LOCK Field

public const int LOCK = 190;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.LockStmt Field

public const int LockStmt = 62;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.LONG Field

public const int LONG = 117;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.LOR Field

public const int LOR = 157;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.LPAREN Field

public const int LPAREN = 125;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.LTHAN Field

public const int LTHAN = 145;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.MemberAccessExpr Field

public const int MemberAccessExpr = 75;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.Members Field

public const int Members = 20;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.METHOD Field

public const int METHOD = 222;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.MethodNode Field

public const int MethodNode = 21;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.MINUS Field

public const int MINUS = 137;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.MINUS_ASN Field

public const int MINUS_ASN = 162;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.MOD Field

public const int MOD = 142;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.MOD_ASN Field

public const int MOD_ASN = 165;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.ModifierAttributes Field

public const int ModifierAttributes = 94;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.MODULE Field

public const int MODULE = 223;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.NAMESPACE Field

public const int NAMESPACE = 195;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.NamespaceNode Field

public const int NamespaceNode = 6;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.NEW Field

public const int NEW = 131;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.NEW_LINE Field

public const int NEW_LINE = 231;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.NEW_LINE_CHARACTER Field

public const int NEW_LINE_CHARACTER = 232;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.NOT_EQUAL Field

public const int NOT_EQUAL = 152;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.NOT_NEW_LINE Field

public const int NOT_NEW_LINE = 233;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.NULL Field

public const int NULL = 105;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.NULL_TREE_LOOKAHEAD Field

public const int NULL_TREE_LOOKAHEAD = 3;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.NullLiteral Field

public const int NullLiteral = 18;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.NUMERIC_LITERAL Field

public const int NUMERIC_LITERAL = 238;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.OBJECT Field

public const int OBJECT = 107;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.ObjectCreateExpr Field

public const int ObjectCreateExpr = 81;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.Op Field

public const int Op = 90;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.OPERATOR Field

public const int OPERATOR = 213;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.OperatorNode Field

public const int OperatorNode = 27;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.OUT Field

public const int OUT = 211;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.OVERRIDE Field

public const int OVERRIDE = 207;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.PARAM Field

public const int PARAM = 224;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.PARAMS Field

public const int PARAMS = 209;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.PLUS Field

public const int PLUS = 136;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.PLUS_ASN Field

public const int PLUS_ASN = 161;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.PostfixExpr Field

public const int PostfixExpr = 83;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.PP_DECLARATION Field

public const int PP_DECLARATION = 260;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.PP_DIRECTIVE Field

public const int PP_DIRECTIVE = 259;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.PP_MESSAGE Field

public const int PP_MESSAGE = 262;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.PP_NEW_LINE Field

public const int PP_NEW_LINE = 257;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.PP_REGION Field

public const int PP_REGION = 261;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.PP_WHITESPACE Field

public const int PP_WHITESPACE = 258;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.PPT_DEFINE Field

public const int PPT_DEFINE = 264;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.PPT_END_REGION Field

public const int PPT_END_REGION = 267;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.PPT_REGION Field

public const int PPT_REGION = 266;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.PPT_UNDEF Field

public const int PPT_UNDEF = 265;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.PrimaryExpression Field

public const int PrimaryExpression = 69;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.PrimitiveExpr Field

public const int PrimitiveExpr = 71;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.PRIVATE Field

public const int PRIVATE = 200;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.PROPERTY Field

public const int PROPERTY = 225;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.PropertyNode Field

public const int PropertyNode = 23;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.PROTECTED Field

public const int PROTECTED = 198;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.PUBLIC Field

public const int PUBLIC = 197;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.QualIdent Field

public const int QualIdent = 33;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.QUESTION Field

public const int QUESTION = 158;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.QUOTE Field

public const int QUOTE = 256;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.RBRACE Field

public const int RBRACE = 172;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.RBRACK Field

public const int RBRACK = 124;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.READONLY Field

public const int READONLY = 204;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.REAL_LITERAL Field

public const int REAL_LITERAL = 100;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.REAL_TYPE_SUFFIX Field

public const int REAL_TYPE_SUFFIX = 244;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.RealLiteral Field

public const int RealLiteral = 15;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.REF Field

public const int REF = 210;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.REGULAR_STRING_LITERAL Field

public const int REGULAR_STRING_LITERAL = 249;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.REGULAR_STRING_LITERAL_CHARACTER Field

public const int REGULAR_STRING_LITERAL_CHARACTER = 250;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.RETURN Field

public const int RETURN = 188;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.ReturnStmt Field

public const int ReturnStmt = 56;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.RPAREN Field

public const int RPAREN = 126;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.SBYTE Field

public const int SBYTE = 111;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.SEALED Field

public const int SEALED = 202;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.SEMI Field

public const int SEMI = 173;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.SHORT Field

public const int SHORT = 113;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.SIGN Field

public const int SIGN = 243;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.SIMPLE_ESCAPE_SEQUENCE Field

public const int SIMPLE_ESCAPE_SEQUENCE = 247;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.SINGLE_CHARACTER Field

public const int SINGLE_CHARACTER = 246;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.SINGLE_LINE_COMMENT Field

public const int SINGLE_LINE_COMMENT = 96;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.SINGLE_REGULAR_STRING_LITERAL_CHARACTER Field

public const int SINGLE_REGULAR_STRING_LITERAL_CHARACTER = 251;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.SIZEOF Field

public const int SIZEOF = 227;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.SL Field

public const int SL = 143;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.SL_ASN Field

public const int SL_ASN = 169;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.SR Field

public const int SR = 144;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.SR_ASN Field

public const int SR_ASN = 170;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.STACKALLOC Field

public const int STACKALLOC = 228;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.STAR Field

public const int STAR = 140;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.STAR_ASN Field

public const int STAR_ASN = 163;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.Statements Field

public const int Statements = 41;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.STATIC Field

public const int STATIC = 203;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.STRING Field

public const int STRING = 108;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.STRING_LITERAL Field

public const int STRING_LITERAL = 102;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.StringLiteral Field

public const int StringLiteral = 17;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.STRUCT Field

public const int STRUCT = 216;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.StructNode Field

public const int StructNode = 9;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.SubExpr Field

public const int SubExpr = 70;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.SWITCH Field

public const int SWITCH = 177;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.SwitchSection Field

public const int SwitchSection = 50;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.SwitchStmt Field

public const int SwitchStmt = 49;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.TernaryExpr Field

public const int TernaryExpr = 79;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.THIS Field

public const int THIS = 127;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.ThisRefExpr Field

public const int ThisRefExpr = 73;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.THROW Field

public const int THROW = 189;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.ThrowStmt Field

public const int ThrowStmt = 59;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.TRUE Field

public const int TRUE = 103;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.TRY Field

public const int TRY = 192;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.TryCatchFinallyStmt Field

public const int TryCatchFinallyStmt = 44;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.TryStmt Field

public const int TryStmt = 45;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.TYPE Field

public const int TYPE = 226;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.TYPEOF Field

public const int TYPEOF = 132;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.TypeOfExpr Field

public const int TypeOfExpr = 82;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.TypeRef Field

public const int TypeRef = 34;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.Types Field

public const int Types = 19;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.UINT Field

public const int UINT = 116;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.ULONG Field

public const int ULONG = 118;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.UnaryExpr Field

public const int UnaryExpr = 77;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.UNCHECKED Field

public const int UNCHECKED = 135;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.UncheckedExpr Field

public const int UncheckedExpr = 85;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.UncheckedStmt Field

public const int UncheckedStmt = 61;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.UNICODE_ESCAPE_SEQUENCE Field

public const int UNICODE_ESCAPE_SEQUENCE = 235;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.UNSAFE Field

public const int UNSAFE = 230;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.USHORT Field

public const int USHORT = 114;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.USING Field

public const int USING = 191;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.UsingNode Field

public const int UsingNode = 5;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.UsingStmt Field

public const int UsingStmt = 63;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.VariableDeclStmt Field

public const int VariableDeclStmt = 65;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.VERBATIM_STRING_LITERAL Field

public const int VERBATIM_STRING_LITERAL = 252;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.VIRTUAL Field

public const int VIRTUAL = 206;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.VOID Field

public const int VOID = 133;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.VOLATILE Field

public const int VOLATILE = 205;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.WHILE Field

public const int WHILE = 180;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CSharpTokenTypes.WHITESPACE Field

public const int WHITESPACE = 234;

See Also

CSharpTokenTypes Class | DDW.CSharp.Parse Namespace


CustomAttribute Class

For a list of all members of this type, see CustomAttribute Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.CustomAttribute

public class CustomAttribute : CSharpAST

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

CustomAttribute Members | DDW.CSharp.Parse Namespace


CustomAttribute Members

CustomAttribute overview

Public Static Methods

ParseTarget

Public Instance Constructors

CustomAttribute Constructor Initializes a new instance of the CustomAttribute class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

CustomAttribute Class | DDW.CSharp.Parse Namespace


CustomAttribute Constructor

Initializes a new instance of the CustomAttribute class.

public CustomAttribute();

See Also

CustomAttribute Class | DDW.CSharp.Parse Namespace


CustomAttribute Methods

The methods of the CustomAttribute class are listed below. For a complete list of CustomAttribute class members, see the CustomAttribute Members topic.

Public Static Methods

ParseTarget

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CustomAttribute Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

CustomAttribute.GetGraph Method

Overload List

public override IGraph GetGraph();

public CustomAttribute GetGraph(CustomAttribute);

Inherited from CSharpAST.

public virtual IGraph GetGraph(IGraph);

See Also

CustomAttribute Class | DDW.CSharp.Parse Namespace


CustomAttribute.GetGraph Method ()

public override IGraph GetGraph();

See Also

CustomAttribute Class | DDW.CSharp.Parse Namespace | CustomAttribute.GetGraph Overload List


CustomAttribute.GetGraph Method (CustomAttribute)

public CustomAttribute GetGraph(
CustomAttribute graph
);

See Also

CustomAttribute Class | DDW.CSharp.Parse Namespace | CustomAttribute.GetGraph Overload List


CustomAttribute.ParseTarget Method

public static AttributeTarget ParseTarget(
string name
);

See Also

CustomAttribute Class | DDW.CSharp.Parse Namespace


CustomAttributes Class

For a list of all members of this type, see CustomAttributes Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.CustomAttributes

public class CustomAttributes : CSharpAST

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

CustomAttributes Members | DDW.CSharp.Parse Namespace


CustomAttributes Members

CustomAttributes overview

Public Instance Constructors

CustomAttributes Constructor Initializes a new instance of the CustomAttributes class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

CustomAttributes Class | DDW.CSharp.Parse Namespace


CustomAttributes Constructor

Initializes a new instance of the CustomAttributes class.

public CustomAttributes();

See Also

CustomAttributes Class | DDW.CSharp.Parse Namespace


CustomAttributes Methods

The methods of the CustomAttributes class are listed below. For a complete list of CustomAttributes class members, see the CustomAttributes Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CustomAttributes Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

CustomAttributes.GetGraph Method

Overload List

public override IGraph GetGraph();

public CustomAttributeCollection GetGraph(CustomAttributeCollection);

Inherited from CSharpAST.

public virtual IGraph GetGraph(IGraph);

See Also

CustomAttributes Class | DDW.CSharp.Parse Namespace


CustomAttributes.GetGraph Method ()

public override IGraph GetGraph();

See Also

CustomAttributes Class | DDW.CSharp.Parse Namespace | CustomAttributes.GetGraph Overload List


CustomAttributes.GetGraph Method (CustomAttributeCollection)

public CustomAttributeCollection GetGraph(
CustomAttributeCollection graph
);

See Also

CustomAttributes Class | DDW.CSharp.Parse Namespace | CustomAttributes.GetGraph Overload List


Declarator Class

For a list of all members of this type, see Declarator Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Declarator

public class Declarator : CSharpAST

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

Declarator Members | DDW.CSharp.Parse Namespace


Declarator Members

Declarator overview

Public Instance Constructors

Declarator Constructor Initializes a new instance of the Declarator class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

Declarator Class | DDW.CSharp.Parse Namespace


Declarator Constructor

Initializes a new instance of the Declarator class.

public Declarator();

See Also

Declarator Class | DDW.CSharp.Parse Namespace


Declarator Methods

The methods of the Declarator class are listed below. For a complete list of Declarator class members, see the Declarator Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Declarator Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

Declarator.GetGraph Method

Overload List

public override IGraph GetGraph();

public DeclaratorCollection GetGraph(DeclaratorCollection);

Inherited from CSharpAST.

public virtual IGraph GetGraph(IGraph);

See Also

Declarator Class | DDW.CSharp.Parse Namespace


Declarator.GetGraph Method ()

public override IGraph GetGraph();

See Also

Declarator Class | DDW.CSharp.Parse Namespace | Declarator.GetGraph Overload List


Declarator.GetGraph Method (DeclaratorCollection)

public DeclaratorCollection GetGraph(
DeclaratorCollection graph
);

See Also

Declarator Class | DDW.CSharp.Parse Namespace | Declarator.GetGraph Overload List


DeclArg Class

For a list of all members of this type, see DeclArg Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Expression
DDW.CSharp.Parse.DeclArg

public class DeclArg : Expression

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

DeclArg Members | DDW.CSharp.Parse Namespace


DeclArg Members

DeclArg overview

Public Instance Constructors

DeclArg Constructor Initializes a new instance of the DeclArg class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

DeclArg Class | DDW.CSharp.Parse Namespace


DeclArg Constructor

Initializes a new instance of the DeclArg class.

public DeclArg();

See Also

DeclArg Class | DDW.CSharp.Parse Namespace


DeclArg Methods

The methods of the DeclArg class are listed below. For a complete list of DeclArg class members, see the DeclArg Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DeclArg Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

DeclArg.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from Expression.

public virtual IGraph GetGraph(IGraph);

public ParamDecl GetGraph(ParamDecl);

See Also

DeclArg Class | DDW.CSharp.Parse Namespace


DeclArg.GetGraph Method ()

public override IGraph GetGraph();

See Also

DeclArg Class | DDW.CSharp.Parse Namespace | DeclArg.GetGraph Overload List


DeclArg.GetGraph Method (ParamDecl)

public ParamDecl GetGraph(
ParamDecl graph
);

See Also

DeclArg Class | DDW.CSharp.Parse Namespace | DeclArg.GetGraph Overload List


DeclArgs Class

For a list of all members of this type, see DeclArgs Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.DeclArgs

public class DeclArgs : CSharpAST

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

DeclArgs Members | DDW.CSharp.Parse Namespace


DeclArgs Members

DeclArgs overview

Public Instance Constructors

DeclArgs Constructor Initializes a new instance of the DeclArgs class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

DeclArgs Class | DDW.CSharp.Parse Namespace


DeclArgs Constructor

Initializes a new instance of the DeclArgs class.

public DeclArgs();

See Also

DeclArgs Class | DDW.CSharp.Parse Namespace


DeclArgs Methods

The methods of the DeclArgs class are listed below. For a complete list of DeclArgs class members, see the DeclArgs Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DeclArgs Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

DeclArgs.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from CSharpAST.

public virtual IGraph GetGraph(IGraph);

public ParamDeclCollection GetGraph(ParamDeclCollection);

See Also

DeclArgs Class | DDW.CSharp.Parse Namespace


DeclArgs.GetGraph Method ()

public override IGraph GetGraph();

See Also

DeclArgs Class | DDW.CSharp.Parse Namespace | DeclArgs.GetGraph Overload List


DeclArgs.GetGraph Method (ParamDeclCollection)

public ParamDeclCollection GetGraph(
ParamDeclCollection graph
);

See Also

DeclArgs Class | DDW.CSharp.Parse Namespace | DeclArgs.GetGraph Overload List


DelegateNode Class

For a list of all members of this type, see DelegateNode Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.TypeMemberNode
DDW.CSharp.Parse.TypeNode
DDW.CSharp.Parse.DelegateNode

public class DelegateNode : TypeNode

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

DelegateNode Members | DDW.CSharp.Parse Namespace


DelegateNode Members

DelegateNode overview

Public Instance Constructors

DelegateNode Constructor Initializes a new instance of the DelegateNode class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetGraph (inherited from TypeNode) | Overloaded.
GetGraph (inherited from TypeMemberNode) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseModifiers (inherited from TypeMemberNode) |
ParseTypeModifiers (inherited from TypeNode) |

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

DelegateNode Class | DDW.CSharp.Parse Namespace


DelegateNode Constructor

Initializes a new instance of the DelegateNode class.

public DelegateNode();

See Also

DelegateNode Class | DDW.CSharp.Parse Namespace


DelegateNode Methods

The methods of the DelegateNode class are listed below. For a complete list of DelegateNode class members, see the DelegateNode Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetGraph (inherited from TypeNode) | Overloaded.
GetGraph (inherited from TypeMemberNode) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseModifiers (inherited from TypeMemberNode) |
ParseTypeModifiers (inherited from TypeNode) |

See Also

DelegateNode Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

DelegateNode.GetGraph Method

Overload List

public override IGraph GetGraph();

public DelegateDecl GetGraph(DelegateDecl);

Inherited from CSharpAST.

public virtual IGraph GetGraph(IGraph);

Inherited from TypeMemberNode.

public MemberDecl GetGraph(MemberDecl);

Inherited from TypeNode.

public TypeDecl GetGraph(TypeDecl);

See Also

DelegateNode Class | DDW.CSharp.Parse Namespace


DelegateNode.GetGraph Method ()

public override IGraph GetGraph();

See Also

DelegateNode Class | DDW.CSharp.Parse Namespace | DelegateNode.GetGraph Overload List


DelegateNode.GetGraph Method (DelegateDecl)

public DelegateDecl GetGraph(
DelegateDecl graph
);

See Also

DelegateNode Class | DDW.CSharp.Parse Namespace | DelegateNode.GetGraph Overload List


DestructorNode Class

For a list of all members of this type, see DestructorNode Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.TypeMemberNode
DDW.CSharp.Parse.DestructorNode

public class DestructorNode : TypeMemberNode

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

DestructorNode Members | DDW.CSharp.Parse Namespace


DestructorNode Members

DestructorNode overview

Public Instance Constructors

DestructorNode Constructor Initializes a new instance of the DestructorNode class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetGraph (inherited from TypeMemberNode) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseModifiers (inherited from TypeMemberNode) |

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

DestructorNode Class | DDW.CSharp.Parse Namespace


DestructorNode Constructor

Initializes a new instance of the DestructorNode class.

public DestructorNode();

See Also

DestructorNode Class | DDW.CSharp.Parse Namespace


DestructorNode Methods

The methods of the DestructorNode class are listed below. For a complete list of DestructorNode class members, see the DestructorNode Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetGraph (inherited from TypeMemberNode) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseModifiers (inherited from TypeMemberNode) |

See Also

DestructorNode Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

DestructorNode.GetGraph Method

Overload List

public override IGraph GetGraph();

public DestructorDecl GetGraph(DestructorDecl);

Inherited from CSharpAST.

public virtual IGraph GetGraph(IGraph);

Inherited from TypeMemberNode.

public MemberDecl GetGraph(MemberDecl);

See Also

DestructorNode Class | DDW.CSharp.Parse Namespace


DestructorNode.GetGraph Method ()

public override IGraph GetGraph();

See Also

DestructorNode Class | DDW.CSharp.Parse Namespace | DestructorNode.GetGraph Overload List


DestructorNode.GetGraph Method (DestructorDecl)

public DestructorDecl GetGraph(
DestructorDecl graph
);

See Also

DestructorNode Class | DDW.CSharp.Parse Namespace | DestructorNode.GetGraph Overload List


EnumMemberNode Class

For a list of all members of this type, see EnumMemberNode Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.TypeMemberNode
DDW.CSharp.Parse.EnumMemberNode

public class EnumMemberNode : TypeMemberNode

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

EnumMemberNode Members | DDW.CSharp.Parse Namespace


EnumMemberNode Members

EnumMemberNode overview

Public Instance Constructors

EnumMemberNode Constructor Initializes a new instance of the EnumMemberNode class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetGraph (inherited from TypeMemberNode) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseModifiers (inherited from TypeMemberNode) |

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

EnumMemberNode Class | DDW.CSharp.Parse Namespace


EnumMemberNode Constructor

Initializes a new instance of the EnumMemberNode class.

public EnumMemberNode();

See Also

EnumMemberNode Class | DDW.CSharp.Parse Namespace


EnumMemberNode Methods

The methods of the EnumMemberNode class are listed below. For a complete list of EnumMemberNode class members, see the EnumMemberNode Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetGraph (inherited from TypeMemberNode) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseModifiers (inherited from TypeMemberNode) |

See Also

EnumMemberNode Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

EnumMemberNode.GetGraph Method

Overload List

public override IGraph GetGraph();

public EnumMemberDecl GetGraph(EnumMemberDecl);

Inherited from CSharpAST.

public virtual IGraph GetGraph(IGraph);

Inherited from TypeMemberNode.

public MemberDecl GetGraph(MemberDecl);

See Also

EnumMemberNode Class | DDW.CSharp.Parse Namespace


EnumMemberNode.GetGraph Method ()

public override IGraph GetGraph();

See Also

EnumMemberNode Class | DDW.CSharp.Parse Namespace | EnumMemberNode.GetGraph Overload List


EnumMemberNode.GetGraph Method (EnumMemberDecl)

public EnumMemberDecl GetGraph(
EnumMemberDecl graph
);

See Also

EnumMemberNode Class | DDW.CSharp.Parse Namespace | EnumMemberNode.GetGraph Overload List


EnumNode Class

For a list of all members of this type, see EnumNode Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.TypeMemberNode
DDW.CSharp.Parse.TypeNode
DDW.CSharp.Parse.EnumNode

public class EnumNode : TypeNode

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

EnumNode Members | DDW.CSharp.Parse Namespace


EnumNode Members

EnumNode overview

Public Instance Constructors

EnumNode Constructor Initializes a new instance of the EnumNode class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetGraph (inherited from TypeNode) | Overloaded.
GetGraph (inherited from TypeMemberNode) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseModifiers (inherited from TypeMemberNode) |
ParseTypeModifiers (inherited from TypeNode) |

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

EnumNode Class | DDW.CSharp.Parse Namespace


EnumNode Constructor

Initializes a new instance of the EnumNode class.

public EnumNode();

See Also

EnumNode Class | DDW.CSharp.Parse Namespace


EnumNode Methods

The methods of the EnumNode class are listed below. For a complete list of EnumNode class members, see the EnumNode Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetGraph (inherited from TypeNode) | Overloaded.
GetGraph (inherited from TypeMemberNode) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseModifiers (inherited from TypeMemberNode) |
ParseTypeModifiers (inherited from TypeNode) |

See Also

EnumNode Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

EnumNode.GetGraph Method

Overload List

public override IGraph GetGraph();

public EnumDecl GetGraph(EnumDecl);

Inherited from CSharpAST.

public virtual IGraph GetGraph(IGraph);

Inherited from TypeMemberNode.

public MemberDecl GetGraph(MemberDecl);

Inherited from TypeNode.

public TypeDecl GetGraph(TypeDecl);

See Also

EnumNode Class | DDW.CSharp.Parse Namespace


EnumNode.GetGraph Method ()

public override IGraph GetGraph();

See Also

EnumNode Class | DDW.CSharp.Parse Namespace | EnumNode.GetGraph Overload List


EnumNode.GetGraph Method (EnumDecl)

public EnumDecl GetGraph(
EnumDecl graph
);

See Also

EnumNode Class | DDW.CSharp.Parse Namespace | EnumNode.GetGraph Overload List


EventNode Class

For a list of all members of this type, see EventNode Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.TypeMemberNode
DDW.CSharp.Parse.EventNode

public class EventNode : TypeMemberNode

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

EventNode Members | DDW.CSharp.Parse Namespace


EventNode Members

EventNode overview

Public Instance Constructors

EventNode Constructor Initializes a new instance of the EventNode class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetGraph (inherited from TypeMemberNode) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseModifiers (inherited from TypeMemberNode) |

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

EventNode Class | DDW.CSharp.Parse Namespace


EventNode Constructor

Initializes a new instance of the EventNode class.

public EventNode();

See Also

EventNode Class | DDW.CSharp.Parse Namespace


EventNode Methods

The methods of the EventNode class are listed below. For a complete list of EventNode class members, see the EventNode Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetGraph (inherited from TypeMemberNode) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseModifiers (inherited from TypeMemberNode) |

See Also

EventNode Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

EventNode.GetGraph Method

Overload List

public override IGraph GetGraph();

public EventDecl GetGraph(EventDecl);

Inherited from CSharpAST.

public virtual IGraph GetGraph(IGraph);

Inherited from TypeMemberNode.

public MemberDecl GetGraph(MemberDecl);

See Also

EventNode Class | DDW.CSharp.Parse Namespace


EventNode.GetGraph Method ()

public override IGraph GetGraph();

See Also

EventNode Class | DDW.CSharp.Parse Namespace | EventNode.GetGraph Overload List


EventNode.GetGraph Method (EventDecl)

public EventDecl GetGraph(
EventDecl graph
);

See Also

EventNode Class | DDW.CSharp.Parse Namespace | EventNode.GetGraph Overload List


Expression Class

For a list of all members of this type, see Expression Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Expression
Derived types

public class Expression : CSharpAST

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

Expression Members | DDW.CSharp.Parse Namespace


Expression Members

Expression overview

Public Static Methods

Parse

Public Instance Constructors

Expression Constructor Initializes a new instance of the Expression class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

Expression Class | DDW.CSharp.Parse Namespace


Expression Constructor

Initializes a new instance of the Expression class.

public Expression();

See Also

Expression Class | DDW.CSharp.Parse Namespace


Expression Methods

The methods of the Expression class are listed below. For a complete list of Expression class members, see the Expression Members topic.

Public Static Methods

Parse

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Expression Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

Expression.GetGraph Method

Overload List

public override IGraph GetGraph();

new public virtual IGraph GetGraph(IGraph);

See Also

Expression Class | DDW.CSharp.Parse Namespace


Expression.GetGraph Method ()

public override IGraph GetGraph();

See Also

Expression Class | DDW.CSharp.Parse Namespace | Expression.GetGraph Overload List


Expression.GetGraph Method (IGraph)

new public virtual IGraph GetGraph(
IGraph graph
);

See Also

Expression Class | DDW.CSharp.Parse Namespace | Expression.GetGraph Overload List


Expression.Parse Method

public static Expression Parse(
Expression tok
);

See Also

Expression Class | DDW.CSharp.Parse Namespace


Expressions Class

For a list of all members of this type, see Expressions Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Expressions

public class Expressions : CSharpAST

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

Expressions Members | DDW.CSharp.Parse Namespace


Expressions Members

Expressions overview

Public Instance Constructors

Expressions Constructor Initializes a new instance of the Expressions class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

Expressions Class | DDW.CSharp.Parse Namespace


Expressions Constructor

Initializes a new instance of the Expressions class.

public Expressions();

See Also

Expressions Class | DDW.CSharp.Parse Namespace


Expressions Methods

The methods of the Expressions class are listed below. For a complete list of Expressions class members, see the Expressions Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Expressions Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

Expressions.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from CSharpAST.

public virtual IGraph GetGraph(IGraph);

See Also

Expressions Class | DDW.CSharp.Parse Namespace


Expressions.GetGraph Method ()

public override IGraph GetGraph();

See Also

Expressions Class | DDW.CSharp.Parse Namespace | Expressions.GetGraph Overload List


ExprStmt Class

For a list of all members of this type, see ExprStmt Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Statement
DDW.CSharp.Parse.ExprStmt

public class ExprStmt : Statement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

ExprStmt Members | DDW.CSharp.Parse Namespace


ExprStmt Members

ExprStmt overview

Public Instance Constructors

ExprStmt Constructor Initializes a new instance of the ExprStmt class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGraph (inherited from Statement) | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

ExprStmt Class | DDW.CSharp.Parse Namespace


ExprStmt Constructor

Initializes a new instance of the ExprStmt class.

public ExprStmt();

See Also

ExprStmt Class | DDW.CSharp.Parse Namespace


ExprStmt Methods

The methods of the ExprStmt class are listed below. For a complete list of ExprStmt class members, see the ExprStmt Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGraph (inherited from Statement) | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExprStmt Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

ExprStmt.GetGraph Method

Overload List

public override IGraph GetGraph();

public ExprStmt GetGraph(ExprStmt);

Inherited from Statement.

protected virtual IGraph GetGraph(IGraph);

See Also

ExprStmt Class | DDW.CSharp.Parse Namespace


ExprStmt.GetGraph Method ()

public override IGraph GetGraph();

See Also

ExprStmt Class | DDW.CSharp.Parse Namespace | ExprStmt.GetGraph Overload List


ExprStmt.GetGraph Method (ExprStmt)

public ExprStmt GetGraph(
ExprStmt graph
);

See Also

ExprStmt Class | DDW.CSharp.Parse Namespace | ExprStmt.GetGraph Overload List


FieldNode Class

For a list of all members of this type, see FieldNode Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.TypeMemberNode
DDW.CSharp.Parse.FieldNode

public class FieldNode : TypeMemberNode

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

FieldNode Members | DDW.CSharp.Parse Namespace


FieldNode Members

FieldNode overview

Public Instance Constructors

FieldNode Constructor Initializes a new instance of the FieldNode class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetGraph (inherited from TypeMemberNode) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseModifiers (inherited from TypeMemberNode) |

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

FieldNode Class | DDW.CSharp.Parse Namespace


FieldNode Constructor

Initializes a new instance of the FieldNode class.

public FieldNode();

See Also

FieldNode Class | DDW.CSharp.Parse Namespace


FieldNode Methods

The methods of the FieldNode class are listed below. For a complete list of FieldNode class members, see the FieldNode Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetGraph (inherited from TypeMemberNode) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseModifiers (inherited from TypeMemberNode) |

See Also

FieldNode Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

FieldNode.GetGraph Method

Overload List

public override IGraph GetGraph();

public FieldDecl GetGraph(FieldDecl);

Inherited from CSharpAST.

public virtual IGraph GetGraph(IGraph);

Inherited from TypeMemberNode.

public MemberDecl GetGraph(MemberDecl);

See Also

FieldNode Class | DDW.CSharp.Parse Namespace


FieldNode.GetGraph Method ()

public override IGraph GetGraph();

See Also

FieldNode Class | DDW.CSharp.Parse Namespace | FieldNode.GetGraph Overload List


FieldNode.GetGraph Method (FieldDecl)

public FieldDecl GetGraph(
FieldDecl graph
);

See Also

FieldNode Class | DDW.CSharp.Parse Namespace | FieldNode.GetGraph Overload List


FinallyStmt Class

For a list of all members of this type, see FinallyStmt Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.FinallyStmt

public class FinallyStmt : CSharpAST

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

FinallyStmt Members | DDW.CSharp.Parse Namespace


FinallyStmt Members

FinallyStmt overview

Public Instance Constructors

FinallyStmt Constructor Initializes a new instance of the FinallyStmt class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

FinallyStmt Class | DDW.CSharp.Parse Namespace


FinallyStmt Constructor

Initializes a new instance of the FinallyStmt class.

public FinallyStmt();

See Also

FinallyStmt Class | DDW.CSharp.Parse Namespace


FinallyStmt Methods

The methods of the FinallyStmt class are listed below. For a complete list of FinallyStmt class members, see the FinallyStmt Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FinallyStmt Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

FinallyStmt.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from CSharpAST.

public virtual IGraph GetGraph(IGraph);

See Also

FinallyStmt Class | DDW.CSharp.Parse Namespace


FinallyStmt.GetGraph Method ()

public override IGraph GetGraph();

See Also

FinallyStmt Class | DDW.CSharp.Parse Namespace | FinallyStmt.GetGraph Overload List


ForEachStmt Class

For a list of all members of this type, see ForEachStmt Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Statement
DDW.CSharp.Parse.ForEachStmt

public class ForEachStmt : Statement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

ForEachStmt Members | DDW.CSharp.Parse Namespace


ForEachStmt Members

ForEachStmt overview

Public Instance Constructors

ForEachStmt Constructor Initializes a new instance of the ForEachStmt class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGraph (inherited from Statement) | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

ForEachStmt Class | DDW.CSharp.Parse Namespace


ForEachStmt Constructor

Initializes a new instance of the ForEachStmt class.

public ForEachStmt();

See Also

ForEachStmt Class | DDW.CSharp.Parse Namespace


ForEachStmt Methods

The methods of the ForEachStmt class are listed below. For a complete list of ForEachStmt class members, see the ForEachStmt Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGraph (inherited from Statement) | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ForEachStmt Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

ForEachStmt.GetGraph Method

Overload List

public override IGraph GetGraph();

public ForEachStmt GetGraph(ForEachStmt);

Inherited from Statement.

protected virtual IGraph GetGraph(IGraph);

See Also

ForEachStmt Class | DDW.CSharp.Parse Namespace


ForEachStmt.GetGraph Method ()

public override IGraph GetGraph();

See Also

ForEachStmt Class | DDW.CSharp.Parse Namespace | ForEachStmt.GetGraph Overload List


ForEachStmt.GetGraph Method (ForEachStmt)

public ForEachStmt GetGraph(
ForEachStmt graph
);

See Also

ForEachStmt Class | DDW.CSharp.Parse Namespace | ForEachStmt.GetGraph Overload List


GotoStmt Class

For a list of all members of this type, see GotoStmt Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Statement
DDW.CSharp.Parse.GotoStmt

public class GotoStmt : Statement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

GotoStmt Members | DDW.CSharp.Parse Namespace


GotoStmt Members

GotoStmt overview

Public Instance Constructors

GotoStmt Constructor Initializes a new instance of the GotoStmt class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGraph (inherited from Statement) | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

GotoStmt Class | DDW.CSharp.Parse Namespace


GotoStmt Constructor

Initializes a new instance of the GotoStmt class.

public GotoStmt();

See Also

GotoStmt Class | DDW.CSharp.Parse Namespace


GotoStmt Methods

The methods of the GotoStmt class are listed below. For a complete list of GotoStmt class members, see the GotoStmt Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGraph (inherited from Statement) | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GotoStmt Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

GotoStmt.GetGraph Method

Overload List

public override IGraph GetGraph();

public GotoStmt GetGraph(GotoStmt);

Inherited from Statement.

protected virtual IGraph GetGraph(IGraph);

See Also

GotoStmt Class | DDW.CSharp.Parse Namespace


GotoStmt.GetGraph Method ()

public override IGraph GetGraph();

See Also

GotoStmt Class | DDW.CSharp.Parse Namespace | GotoStmt.GetGraph Overload List


GotoStmt.GetGraph Method (GotoStmt)

public GotoStmt GetGraph(
GotoStmt graph
);

See Also

GotoStmt Class | DDW.CSharp.Parse Namespace | GotoStmt.GetGraph Overload List


Ident Class

For a list of all members of this type, see Ident Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Expression
DDW.CSharp.Parse.PrimaryExpression
DDW.CSharp.Parse.Ident

public class Ident : PrimaryExpression

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

Ident Members | DDW.CSharp.Parse Namespace


Ident Members

Ident overview

Public Instance Constructors

Ident Constructor Initializes a new instance of the Ident class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

Ident Class | DDW.CSharp.Parse Namespace


Ident Constructor

Initializes a new instance of the Ident class.

public Ident();

See Also

Ident Class | DDW.CSharp.Parse Namespace


Ident Methods

The methods of the Ident class are listed below. For a complete list of Ident class members, see the Ident Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Ident Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

Ident.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from Expression.

public virtual IGraph GetGraph(IGraph);

See Also

Ident Class | DDW.CSharp.Parse Namespace


Ident.GetGraph Method ()

public override IGraph GetGraph();

See Also

Ident Class | DDW.CSharp.Parse Namespace | Ident.GetGraph Overload List


IfStmt Class

For a list of all members of this type, see IfStmt Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Statement
DDW.CSharp.Parse.IfStmt

public class IfStmt : Statement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

IfStmt Members | DDW.CSharp.Parse Namespace


IfStmt Members

IfStmt overview

Public Instance Constructors

IfStmt Constructor Initializes a new instance of the IfStmt class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGraph (inherited from Statement) | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

IfStmt Class | DDW.CSharp.Parse Namespace


IfStmt Constructor

Initializes a new instance of the IfStmt class.

public IfStmt();

See Also

IfStmt Class | DDW.CSharp.Parse Namespace


IfStmt Methods

The methods of the IfStmt class are listed below. For a complete list of IfStmt class members, see the IfStmt Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGraph (inherited from Statement) | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IfStmt Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

IfStmt.GetGraph Method

Overload List

public override IGraph GetGraph();

public IfStmt GetGraph(IfStmt);

Inherited from Statement.

protected virtual IGraph GetGraph(IGraph);

See Also

IfStmt Class | DDW.CSharp.Parse Namespace


IfStmt.GetGraph Method ()

public override IGraph GetGraph();

See Also

IfStmt Class | DDW.CSharp.Parse Namespace | IfStmt.GetGraph Overload List


IfStmt.GetGraph Method (IfStmt)

public IfStmt GetGraph(
IfStmt graph
);

See Also

IfStmt Class | DDW.CSharp.Parse Namespace | IfStmt.GetGraph Overload List


IncStmt Class

For a list of all members of this type, see IncStmt Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Statements
DDW.CSharp.Parse.IncStmt

public class IncStmt : Statements

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

IncStmt Members | DDW.CSharp.Parse Namespace


IncStmt Members

IncStmt overview

Public Instance Constructors

IncStmt Constructor Initializes a new instance of the IncStmt class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph (inherited from Statements) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

IncStmt Class | DDW.CSharp.Parse Namespace


IncStmt Constructor

Initializes a new instance of the IncStmt class.

public IncStmt();

See Also

IncStmt Class | DDW.CSharp.Parse Namespace


IndexerExpr Class

For a list of all members of this type, see IndexerExpr Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Expression
DDW.CSharp.Parse.PrimaryFollowExpression
DDW.CSharp.Parse.IndexerExpr

public class IndexerExpr : PrimaryFollowExpression

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

IndexerExpr Members | DDW.CSharp.Parse Namespace


IndexerExpr Members

IndexerExpr overview

Public Instance Constructors

IndexerExpr Constructor Initializes a new instance of the IndexerExpr class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
ParseIndexerExpr |
ParseIndexerSizes |
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

IndexerExpr Class | DDW.CSharp.Parse Namespace


IndexerExpr Constructor

Initializes a new instance of the IndexerExpr class.

public IndexerExpr();

See Also

IndexerExpr Class | DDW.CSharp.Parse Namespace


IndexerExpr Methods

The methods of the IndexerExpr class are listed below. For a complete list of IndexerExpr class members, see the IndexerExpr Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
ParseIndexerExpr |
ParseIndexerSizes |
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IndexerExpr Class | DDW.CSharp.Parse Namespace


IndexerExpr.ParseIndexerExpr Method

public IndexerRef ParseIndexerExpr(
Expression targ
);

See Also

IndexerExpr Class | DDW.CSharp.Parse Namespace


IndexerExpr.ParseIndexerSizes Method

public void ParseIndexerSizes(
ExpressionCollection col
);

See Also

IndexerExpr Class | DDW.CSharp.Parse Namespace


IndexerNode Class

For a list of all members of this type, see IndexerNode Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.TypeMemberNode
DDW.CSharp.Parse.IndexerNode

public class IndexerNode : TypeMemberNode

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

IndexerNode Members | DDW.CSharp.Parse Namespace


IndexerNode Members

IndexerNode overview

Public Instance Constructors

IndexerNode Constructor Initializes a new instance of the IndexerNode class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetGraph (inherited from TypeMemberNode) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseModifiers (inherited from TypeMemberNode) |

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

IndexerNode Class | DDW.CSharp.Parse Namespace


IndexerNode Constructor

Initializes a new instance of the IndexerNode class.

public IndexerNode();

See Also

IndexerNode Class | DDW.CSharp.Parse Namespace


IndexerNode Methods

The methods of the IndexerNode class are listed below. For a complete list of IndexerNode class members, see the IndexerNode Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetGraph (inherited from TypeMemberNode) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseModifiers (inherited from TypeMemberNode) |

See Also

IndexerNode Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

IndexerNode.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from CSharpAST.

public virtual IGraph GetGraph(IGraph);

public IndexerDecl GetGraph(IndexerDecl);

Inherited from TypeMemberNode.

public MemberDecl GetGraph(MemberDecl);

See Also

IndexerNode Class | DDW.CSharp.Parse Namespace


IndexerNode.GetGraph Method ()

public override IGraph GetGraph();

See Also

IndexerNode Class | DDW.CSharp.Parse Namespace | IndexerNode.GetGraph Overload List


IndexerNode.GetGraph Method (IndexerDecl)

public IndexerDecl GetGraph(
IndexerDecl graph
);

See Also

IndexerNode Class | DDW.CSharp.Parse Namespace | IndexerNode.GetGraph Overload List


InitStmt Class

For a list of all members of this type, see InitStmt Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Statements
DDW.CSharp.Parse.InitStmt

public class InitStmt : Statements

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

InitStmt Members | DDW.CSharp.Parse Namespace


InitStmt Members

InitStmt overview

Public Instance Constructors

InitStmt Constructor Initializes a new instance of the InitStmt class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph (inherited from Statements) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

InitStmt Class | DDW.CSharp.Parse Namespace


InitStmt Constructor

Initializes a new instance of the InitStmt class.

public InitStmt();

See Also

InitStmt Class | DDW.CSharp.Parse Namespace


IntegerLiteral Class

For a list of all members of this type, see IntegerLiteral Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Expression
DDW.CSharp.Parse.PrimaryExpression
DDW.CSharp.Parse.PrimitiveExpr
DDW.CSharp.Parse.IntegerLiteral

public class IntegerLiteral : PrimitiveExpr

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

IntegerLiteral Members | DDW.CSharp.Parse Namespace


IntegerLiteral Members

IntegerLiteral overview

Public Instance Constructors

IntegerLiteral Constructor Initializes a new instance of the IntegerLiteral class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

IntegerLiteral Class | DDW.CSharp.Parse Namespace


IntegerLiteral Constructor

Initializes a new instance of the IntegerLiteral class.

public IntegerLiteral();

See Also

IntegerLiteral Class | DDW.CSharp.Parse Namespace


IntegerLiteral Methods

The methods of the IntegerLiteral class are listed below. For a complete list of IntegerLiteral class members, see the IntegerLiteral Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IntegerLiteral Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

IntegerLiteral.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from Expression.

public virtual IGraph GetGraph(IGraph);

public IntegerLiteral GetGraph(IntegerLiteral);

See Also

IntegerLiteral Class | DDW.CSharp.Parse Namespace


IntegerLiteral.GetGraph Method ()

public override IGraph GetGraph();

See Also

IntegerLiteral Class | DDW.CSharp.Parse Namespace | IntegerLiteral.GetGraph Overload List


IntegerLiteral.GetGraph Method (IntegerLiteral)

public IntegerLiteral GetGraph(
IntegerLiteral graph
);

See Also

IntegerLiteral Class | DDW.CSharp.Parse Namespace | IntegerLiteral.GetGraph Overload List


InterfaceNode Class

For a list of all members of this type, see InterfaceNode Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.TypeMemberNode
DDW.CSharp.Parse.TypeNode
DDW.CSharp.Parse.InterfaceNode

public class InterfaceNode : TypeNode

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

InterfaceNode Members | DDW.CSharp.Parse Namespace


InterfaceNode Members

InterfaceNode overview

Public Instance Constructors

InterfaceNode Constructor Initializes a new instance of the InterfaceNode class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetGraph (inherited from TypeNode) | Overloaded.
GetGraph (inherited from TypeMemberNode) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseModifiers (inherited from TypeMemberNode) |
ParseTypeModifiers (inherited from TypeNode) |

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

InterfaceNode Class | DDW.CSharp.Parse Namespace


InterfaceNode Constructor

Initializes a new instance of the InterfaceNode class.

public InterfaceNode();

See Also

InterfaceNode Class | DDW.CSharp.Parse Namespace


InterfaceNode Methods

The methods of the InterfaceNode class are listed below. For a complete list of InterfaceNode class members, see the InterfaceNode Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetGraph (inherited from TypeNode) | Overloaded.
GetGraph (inherited from TypeMemberNode) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseModifiers (inherited from TypeMemberNode) |
ParseTypeModifiers (inherited from TypeNode) |

See Also

InterfaceNode Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

InterfaceNode.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from CSharpAST.

public virtual IGraph GetGraph(IGraph);

public InterfaceDecl GetGraph(InterfaceDecl);

Inherited from TypeMemberNode.

public MemberDecl GetGraph(MemberDecl);

Inherited from TypeNode.

public TypeDecl GetGraph(TypeDecl);

See Also

InterfaceNode Class | DDW.CSharp.Parse Namespace


InterfaceNode.GetGraph Method ()

public override IGraph GetGraph();

See Also

InterfaceNode Class | DDW.CSharp.Parse Namespace | InterfaceNode.GetGraph Overload List


InterfaceNode.GetGraph Method (InterfaceDecl)

public InterfaceDecl GetGraph(
InterfaceDecl graph
);

See Also

InterfaceNode Class | DDW.CSharp.Parse Namespace | InterfaceNode.GetGraph Overload List


InvokeExpr Class

For a list of all members of this type, see InvokeExpr Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Expression
DDW.CSharp.Parse.PrimaryFollowExpression
DDW.CSharp.Parse.InvokeExpr

public class InvokeExpr : PrimaryFollowExpression

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

InvokeExpr Members | DDW.CSharp.Parse Namespace


InvokeExpr Members

InvokeExpr overview

Public Instance Constructors

InvokeExpr Constructor Initializes a new instance of the InvokeExpr class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
ParseInvoke |
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

InvokeExpr Class | DDW.CSharp.Parse Namespace


InvokeExpr Constructor

Initializes a new instance of the InvokeExpr class.

public InvokeExpr();

See Also

InvokeExpr Class | DDW.CSharp.Parse Namespace


InvokeExpr Methods

The methods of the InvokeExpr class are listed below. For a complete list of InvokeExpr class members, see the InvokeExpr Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
ParseInvoke |
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InvokeExpr Class | DDW.CSharp.Parse Namespace


InvokeExpr.ParseInvoke Method

public MethodInvokeExpr ParseInvoke(
Expression targ
);

See Also

InvokeExpr Class | DDW.CSharp.Parse Namespace


IterationStmt Class

For a list of all members of this type, see IterationStmt Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Statement
DDW.CSharp.Parse.IterationStmt

public class IterationStmt : Statement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

IterationStmt Members | DDW.CSharp.Parse Namespace


IterationStmt Members

IterationStmt overview

Public Instance Constructors

IterationStmt Constructor Initializes a new instance of the IterationStmt class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGraph (inherited from Statement) | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

IterationStmt Class | DDW.CSharp.Parse Namespace


IterationStmt Constructor

Initializes a new instance of the IterationStmt class.

public IterationStmt();

See Also

IterationStmt Class | DDW.CSharp.Parse Namespace


IterationStmt Methods

The methods of the IterationStmt class are listed below. For a complete list of IterationStmt class members, see the IterationStmt Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGraph (inherited from Statement) | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IterationStmt Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

IterationStmt.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from Statement.

protected virtual IGraph GetGraph(IGraph);

public IterationStmt GetGraph(IterationStmt);

See Also

IterationStmt Class | DDW.CSharp.Parse Namespace


IterationStmt.GetGraph Method ()

public override IGraph GetGraph();

See Also

IterationStmt Class | DDW.CSharp.Parse Namespace | IterationStmt.GetGraph Overload List


IterationStmt.GetGraph Method (IterationStmt)

public IterationStmt GetGraph(
IterationStmt graph
);

See Also

IterationStmt Class | DDW.CSharp.Parse Namespace | IterationStmt.GetGraph Overload List


LabeledStmt Class

For a list of all members of this type, see LabeledStmt Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Statement
DDW.CSharp.Parse.LabeledStmt

public class LabeledStmt : Statement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

LabeledStmt Members | DDW.CSharp.Parse Namespace


LabeledStmt Members

LabeledStmt overview

Public Instance Constructors

LabeledStmt Constructor Initializes a new instance of the LabeledStmt class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGraph (inherited from Statement) | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

LabeledStmt Class | DDW.CSharp.Parse Namespace


LabeledStmt Constructor

Initializes a new instance of the LabeledStmt class.

public LabeledStmt();

See Also

LabeledStmt Class | DDW.CSharp.Parse Namespace


LabeledStmt Methods

The methods of the LabeledStmt class are listed below. For a complete list of LabeledStmt class members, see the LabeledStmt Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGraph (inherited from Statement) | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LabeledStmt Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

LabeledStmt.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from Statement.

protected virtual IGraph GetGraph(IGraph);

public LabeledStmt GetGraph(LabeledStmt);

See Also

LabeledStmt Class | DDW.CSharp.Parse Namespace


LabeledStmt.GetGraph Method ()

public override IGraph GetGraph();

See Also

LabeledStmt Class | DDW.CSharp.Parse Namespace | LabeledStmt.GetGraph Overload List


LabeledStmt.GetGraph Method (LabeledStmt)

public LabeledStmt GetGraph(
LabeledStmt graph
);

See Also

LabeledStmt Class | DDW.CSharp.Parse Namespace | LabeledStmt.GetGraph Overload List


LineNumberAST Class

For a list of all members of this type, see LineNumberAST Members.

System.Object
antlr.BaseAST
antlr.CommonAST
DDW.CSharp.Parse.LineNumberAST

public class LineNumberAST : CommonAST

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

LineNumberAST Members | DDW.CSharp.Parse Namespace


LineNumberAST Members

LineNumberAST overview

Public Instance Constructors

LineNumberAST Overloaded. Initializes a new instance of the LineNumberAST class.

Public Instance Properties

Text (inherited from antlr.BaseAST)
Type (inherited from antlr.CommonAST)

Public Instance Methods

addChild (inherited from antlr.BaseAST) |
Clone (inherited from antlr.CommonAST) | Obsolete.
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from antlr.CommonAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize | Overloaded.
initialize (inherited from antlr.CommonAST) | Overloaded.
removeChildren (inherited from antlr.BaseAST) |
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from antlr.CommonAST) |
setType (inherited from antlr.CommonAST) |
ToString (inherited from antlr.BaseAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

LineNumberAST Class | DDW.CSharp.Parse Namespace


LineNumberAST Constructor

Initializes a new instance of the LineNumberAST class.

Overload List

Initializes a new instance of the LineNumberAST class.

public LineNumberAST();

public LineNumberAST(Token);

See Also

LineNumberAST Class | DDW.CSharp.Parse Namespace


LineNumberAST Constructor ()

Initializes a new instance of the LineNumberAST class.

public LineNumberAST();

See Also

LineNumberAST Class | DDW.CSharp.Parse Namespace | LineNumberAST Constructor Overload List


LineNumberAST Constructor (Token)

public LineNumberAST(
Token tok
);

See Also

LineNumberAST Class | DDW.CSharp.Parse Namespace | LineNumberAST Constructor Overload List


LineNumberAST Methods

The methods of the LineNumberAST class are listed below. For a complete list of LineNumberAST class members, see the LineNumberAST Members topic.

Public Instance Methods

addChild (inherited from antlr.BaseAST) |
Clone (inherited from antlr.CommonAST) | Obsolete.
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from antlr.CommonAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize | Overloaded.
initialize (inherited from antlr.CommonAST) | Overloaded.
removeChildren (inherited from antlr.BaseAST) |
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from antlr.CommonAST) |
setType (inherited from antlr.CommonAST) |
ToString (inherited from antlr.BaseAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LineNumberAST Class | DDW.CSharp.Parse Namespace


initialize Method

Goblin - A Platform for 3D AR and VR Applications

LineNumberAST.initialize Method

Overload List

public override void initialize(AST);

public override void initialize(Token);

Inherited from CommonAST.

public override void initialize(int,string);

See Also

LineNumberAST Class | DDW.CSharp.Parse Namespace


LineNumberAST.initialize Method (AST)

public override void initialize(
AST t
);

Implements

AST.initialize

See Also

LineNumberAST Class | DDW.CSharp.Parse Namespace | LineNumberAST.initialize Overload List


LineNumberAST.initialize Method (Token)

public override void initialize(
Token tok
);

Implements

AST.initialize

See Also

LineNumberAST Class | DDW.CSharp.Parse Namespace | LineNumberAST.initialize Overload List


LockStmt Class

For a list of all members of this type, see LockStmt Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Statement
DDW.CSharp.Parse.LockStmt

public class LockStmt : Statement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

LockStmt Members | DDW.CSharp.Parse Namespace


LockStmt Members

LockStmt overview

Public Instance Constructors

LockStmt Constructor Initializes a new instance of the LockStmt class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGraph (inherited from Statement) | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

LockStmt Class | DDW.CSharp.Parse Namespace


LockStmt Constructor

Initializes a new instance of the LockStmt class.

public LockStmt();

See Also

LockStmt Class | DDW.CSharp.Parse Namespace


LockStmt Methods

The methods of the LockStmt class are listed below. For a complete list of LockStmt class members, see the LockStmt Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGraph (inherited from Statement) | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LockStmt Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

LockStmt.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from Statement.

protected virtual IGraph GetGraph(IGraph);

public LockStmt GetGraph(LockStmt);

See Also

LockStmt Class | DDW.CSharp.Parse Namespace


LockStmt.GetGraph Method ()

public override IGraph GetGraph();

See Also

LockStmt Class | DDW.CSharp.Parse Namespace | LockStmt.GetGraph Overload List


LockStmt.GetGraph Method (LockStmt)

public LockStmt GetGraph(
LockStmt graph
);

See Also

LockStmt Class | DDW.CSharp.Parse Namespace | LockStmt.GetGraph Overload List


MemberAccessExpr Class

For a list of all members of this type, see MemberAccessExpr Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Expression
DDW.CSharp.Parse.PrimaryFollowExpression
DDW.CSharp.Parse.MemberAccessExpr

public class MemberAccessExpr : PrimaryFollowExpression

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

MemberAccessExpr Members | DDW.CSharp.Parse Namespace


MemberAccessExpr Members

MemberAccessExpr overview

Public Instance Constructors

MemberAccessExpr Constructor Initializes a new instance of the MemberAccessExpr class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
ParseMemberAccess |
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

MemberAccessExpr Class | DDW.CSharp.Parse Namespace


MemberAccessExpr Constructor

Initializes a new instance of the MemberAccessExpr class.

public MemberAccessExpr();

See Also

MemberAccessExpr Class | DDW.CSharp.Parse Namespace


MemberAccessExpr Methods

The methods of the MemberAccessExpr class are listed below. For a complete list of MemberAccessExpr class members, see the MemberAccessExpr Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
ParseMemberAccess |
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MemberAccessExpr Class | DDW.CSharp.Parse Namespace


MemberAccessExpr.ParseMemberAccess Method

public MemberAccess ParseMemberAccess(
Expression targ
);

See Also

MemberAccessExpr Class | DDW.CSharp.Parse Namespace


Members Class

For a list of all members of this type, see Members Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Members

public class Members : CSharpAST

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

Members Members | DDW.CSharp.Parse Namespace


Members Members

Members overview

Public Instance Constructors

Members Constructor Initializes a new instance of the Members class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

Members Class | DDW.CSharp.Parse Namespace


Members Constructor

Initializes a new instance of the Members class.

public Members();

See Also

Members Class | DDW.CSharp.Parse Namespace


Members Methods

The methods of the Members class are listed below. For a complete list of Members class members, see the Members Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Members Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

Members.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from CSharpAST.

public virtual IGraph GetGraph(IGraph);

public MemberDeclCollection GetGraph(MemberDeclCollection);

See Also

Members Class | DDW.CSharp.Parse Namespace


Members.GetGraph Method ()

public override IGraph GetGraph();

See Also

Members Class | DDW.CSharp.Parse Namespace | Members.GetGraph Overload List


Members.GetGraph Method (MemberDeclCollection)

public MemberDeclCollection GetGraph(
MemberDeclCollection graph
);

See Also

Members Class | DDW.CSharp.Parse Namespace | Members.GetGraph Overload List


MethodNode Class

For a list of all members of this type, see MethodNode Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.TypeMemberNode
DDW.CSharp.Parse.MethodNode

public class MethodNode : TypeMemberNode

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

MethodNode Members | DDW.CSharp.Parse Namespace


MethodNode Members

MethodNode overview

Public Instance Constructors

MethodNode Constructor Initializes a new instance of the MethodNode class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetGraph (inherited from TypeMemberNode) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseModifiers (inherited from TypeMemberNode) |

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

MethodNode Class | DDW.CSharp.Parse Namespace


MethodNode Constructor

Initializes a new instance of the MethodNode class.

public MethodNode();

See Also

MethodNode Class | DDW.CSharp.Parse Namespace


MethodNode Methods

The methods of the MethodNode class are listed below. For a complete list of MethodNode class members, see the MethodNode Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetGraph (inherited from TypeMemberNode) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseModifiers (inherited from TypeMemberNode) |

See Also

MethodNode Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

MethodNode.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from CSharpAST.

public virtual IGraph GetGraph(IGraph);

Inherited from TypeMemberNode.

public MemberDecl GetGraph(MemberDecl);

public MethodDecl GetGraph(MethodDecl);

See Also

MethodNode Class | DDW.CSharp.Parse Namespace


MethodNode.GetGraph Method ()

public override IGraph GetGraph();

See Also

MethodNode Class | DDW.CSharp.Parse Namespace | MethodNode.GetGraph Overload List


MethodNode.GetGraph Method (MethodDecl)

public MethodDecl GetGraph(
MethodDecl graph
);

See Also

MethodNode Class | DDW.CSharp.Parse Namespace | MethodNode.GetGraph Overload List


ModifierAttributes Class

For a list of all members of this type, see ModifierAttributes Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.ModifierAttributes

public class ModifierAttributes : CSharpAST

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

ModifierAttributes Members | DDW.CSharp.Parse Namespace


ModifierAttributes Members

ModifierAttributes overview

Public Instance Constructors

ModifierAttributes Constructor Initializes a new instance of the ModifierAttributes class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

ModifierAttributes Class | DDW.CSharp.Parse Namespace


ModifierAttributes Constructor

Initializes a new instance of the ModifierAttributes class.

public ModifierAttributes();

See Also

ModifierAttributes Class | DDW.CSharp.Parse Namespace


ModifierAttributes Methods

The methods of the ModifierAttributes class are listed below. For a complete list of ModifierAttributes class members, see the ModifierAttributes Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ModifierAttributes Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

ModifierAttributes.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from CSharpAST.

public virtual IGraph GetGraph(IGraph);

See Also

ModifierAttributes Class | DDW.CSharp.Parse Namespace


ModifierAttributes.GetGraph Method ()

public override IGraph GetGraph();

See Also

ModifierAttributes Class | DDW.CSharp.Parse Namespace | ModifierAttributes.GetGraph Overload List


NamespaceNode Class

For a list of all members of this type, see NamespaceNode Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.NamespaceNode

public class NamespaceNode : CSharpAST

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

NamespaceNode Members | DDW.CSharp.Parse Namespace


NamespaceNode Members

NamespaceNode overview

Public Instance Constructors

NamespaceNode Constructor Initializes a new instance of the NamespaceNode class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

NamespaceNode Class | DDW.CSharp.Parse Namespace


NamespaceNode Constructor

Initializes a new instance of the NamespaceNode class.

public NamespaceNode();

See Also

NamespaceNode Class | DDW.CSharp.Parse Namespace


NamespaceNode Methods

The methods of the NamespaceNode class are listed below. For a complete list of NamespaceNode class members, see the NamespaceNode Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NamespaceNode Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

NamespaceNode.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from CSharpAST.

public virtual IGraph GetGraph(IGraph);

public NamespaceDecl GetGraph(NamespaceDecl);

See Also

NamespaceNode Class | DDW.CSharp.Parse Namespace


NamespaceNode.GetGraph Method ()

public override IGraph GetGraph();

See Also

NamespaceNode Class | DDW.CSharp.Parse Namespace | NamespaceNode.GetGraph Overload List


NamespaceNode.GetGraph Method (NamespaceDecl)

public NamespaceDecl GetGraph(
NamespaceDecl graph
);

See Also

NamespaceNode Class | DDW.CSharp.Parse Namespace | NamespaceNode.GetGraph Overload List


NullLiteral Class

For a list of all members of this type, see NullLiteral Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Expression
DDW.CSharp.Parse.PrimaryExpression
DDW.CSharp.Parse.PrimitiveExpr
DDW.CSharp.Parse.NullLiteral

public class NullLiteral : PrimitiveExpr

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

NullLiteral Members | DDW.CSharp.Parse Namespace


NullLiteral Members

NullLiteral overview

Public Instance Constructors

NullLiteral Constructor Initializes a new instance of the NullLiteral class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

NullLiteral Class | DDW.CSharp.Parse Namespace


NullLiteral Constructor

Initializes a new instance of the NullLiteral class.

public NullLiteral();

See Also

NullLiteral Class | DDW.CSharp.Parse Namespace


NullLiteral Methods

The methods of the NullLiteral class are listed below. For a complete list of NullLiteral class members, see the NullLiteral Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NullLiteral Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

NullLiteral.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from Expression.

public virtual IGraph GetGraph(IGraph);

public NullLiteral GetGraph(NullLiteral);

See Also

NullLiteral Class | DDW.CSharp.Parse Namespace


NullLiteral.GetGraph Method ()

public override IGraph GetGraph();

See Also

NullLiteral Class | DDW.CSharp.Parse Namespace | NullLiteral.GetGraph Overload List


NullLiteral.GetGraph Method (NullLiteral)

public NullLiteral GetGraph(
NullLiteral graph
);

See Also

NullLiteral Class | DDW.CSharp.Parse Namespace | NullLiteral.GetGraph Overload List


ObjectCreateExpr Class

For a list of all members of this type, see ObjectCreateExpr Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Expression
DDW.CSharp.Parse.PrimaryExpression
DDW.CSharp.Parse.ObjectCreateExpr

public class ObjectCreateExpr : PrimaryExpression

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

ObjectCreateExpr Members | DDW.CSharp.Parse Namespace


ObjectCreateExpr Members

ObjectCreateExpr overview

Public Instance Constructors

ObjectCreateExpr Constructor Initializes a new instance of the ObjectCreateExpr class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

ObjectCreateExpr Class | DDW.CSharp.Parse Namespace


ObjectCreateExpr Constructor

Initializes a new instance of the ObjectCreateExpr class.

public ObjectCreateExpr();

See Also

ObjectCreateExpr Class | DDW.CSharp.Parse Namespace


ObjectCreateExpr Methods

The methods of the ObjectCreateExpr class are listed below. For a complete list of ObjectCreateExpr class members, see the ObjectCreateExpr Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ObjectCreateExpr Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

ObjectCreateExpr.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from Expression.

public virtual IGraph GetGraph(IGraph);

public ObjectCreateExpr GetGraph(ObjectCreateExpr);

See Also

ObjectCreateExpr Class | DDW.CSharp.Parse Namespace


ObjectCreateExpr.GetGraph Method ()

public override IGraph GetGraph();

See Also

ObjectCreateExpr Class | DDW.CSharp.Parse Namespace | ObjectCreateExpr.GetGraph Overload List


ObjectCreateExpr.GetGraph Method (ObjectCreateExpr)

public ObjectCreateExpr GetGraph(
ObjectCreateExpr graph
);

See Also

ObjectCreateExpr Class | DDW.CSharp.Parse Namespace | ObjectCreateExpr.GetGraph Overload List


Op Class

For a list of all members of this type, see Op Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Op

public class Op : CSharpAST

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

Op Members | DDW.CSharp.Parse Namespace


Op Members

Op overview

Public Instance Constructors

Op Constructor Initializes a new instance of the Op class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

Op Class | DDW.CSharp.Parse Namespace


Op Constructor

Initializes a new instance of the Op class.

public Op();

See Also

Op Class | DDW.CSharp.Parse Namespace


Op Methods

The methods of the Op class are listed below. For a complete list of Op class members, see the Op Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Op Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

Op.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from CSharpAST.

public virtual IGraph GetGraph(IGraph);

See Also

Op Class | DDW.CSharp.Parse Namespace


Op.GetGraph Method ()

public override IGraph GetGraph();

See Also

Op Class | DDW.CSharp.Parse Namespace | Op.GetGraph Overload List


OperatorNode Class

For a list of all members of this type, see OperatorNode Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.TypeMemberNode
DDW.CSharp.Parse.OperatorNode

public class OperatorNode : TypeMemberNode

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

OperatorNode Members | DDW.CSharp.Parse Namespace


OperatorNode Members

OperatorNode overview

Public Instance Constructors

OperatorNode Constructor Initializes a new instance of the OperatorNode class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetGraph (inherited from TypeMemberNode) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseModifiers (inherited from TypeMemberNode) |

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

OperatorNode Class | DDW.CSharp.Parse Namespace


OperatorNode Constructor

Initializes a new instance of the OperatorNode class.

public OperatorNode();

See Also

OperatorNode Class | DDW.CSharp.Parse Namespace


OperatorNode Methods

The methods of the OperatorNode class are listed below. For a complete list of OperatorNode class members, see the OperatorNode Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetGraph (inherited from TypeMemberNode) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseModifiers (inherited from TypeMemberNode) |

See Also

OperatorNode Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

OperatorNode.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from CSharpAST.

public virtual IGraph GetGraph(IGraph);

Inherited from TypeMemberNode.

public MemberDecl GetGraph(MemberDecl);

public OperatorDecl GetGraph(OperatorDecl);

See Also

OperatorNode Class | DDW.CSharp.Parse Namespace


OperatorNode.GetGraph Method ()

public override IGraph GetGraph();

See Also

OperatorNode Class | DDW.CSharp.Parse Namespace | OperatorNode.GetGraph Overload List


OperatorNode.GetGraph Method (OperatorDecl)

public OperatorDecl GetGraph(
OperatorDecl graph
);

See Also

OperatorNode Class | DDW.CSharp.Parse Namespace | OperatorNode.GetGraph Overload List


PostfixExpr Class

For a list of all members of this type, see PostfixExpr Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Expression
DDW.CSharp.Parse.PrimaryFollowExpression
DDW.CSharp.Parse.PostfixExpr

public class PostfixExpr : PrimaryFollowExpression

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

PostfixExpr Members | DDW.CSharp.Parse Namespace


PostfixExpr Members

PostfixExpr overview

Public Instance Constructors

PostfixExpr Constructor Initializes a new instance of the PostfixExpr class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
ParsePostfixExpr |
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

PostfixExpr Class | DDW.CSharp.Parse Namespace


PostfixExpr Constructor

Initializes a new instance of the PostfixExpr class.

public PostfixExpr();

See Also

PostfixExpr Class | DDW.CSharp.Parse Namespace


PostfixExpr Methods

The methods of the PostfixExpr class are listed below. For a complete list of PostfixExpr class members, see the PostfixExpr Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
ParsePostfixExpr |
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PostfixExpr Class | DDW.CSharp.Parse Namespace


PostfixExpr.ParsePostfixExpr Method

public PostfixExpr ParsePostfixExpr(
Expression targ
);

See Also

PostfixExpr Class | DDW.CSharp.Parse Namespace


PrimaryExpression Class

For a list of all members of this type, see PrimaryExpression Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Expression
DDW.CSharp.Parse.PrimaryExpression
Derived types

public class PrimaryExpression : Expression

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

PrimaryExpression Members | DDW.CSharp.Parse Namespace


PrimaryExpression Members

PrimaryExpression overview

Public Static Methods

ParsePrimaryExpr

Public Instance Constructors

PrimaryExpression Constructor Initializes a new instance of the PrimaryExpression class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

PrimaryExpression Class | DDW.CSharp.Parse Namespace


PrimaryExpression Constructor

Initializes a new instance of the PrimaryExpression class.

public PrimaryExpression();

See Also

PrimaryExpression Class | DDW.CSharp.Parse Namespace


PrimaryExpression Methods

The methods of the PrimaryExpression class are listed below. For a complete list of PrimaryExpression class members, see the PrimaryExpression Members topic.

Public Static Methods

ParsePrimaryExpr

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PrimaryExpression Class | DDW.CSharp.Parse Namespace


PrimaryExpression.ParsePrimaryExpr Method

public static Expression ParsePrimaryExpr(
Expression tok
);

See Also

PrimaryExpression Class | DDW.CSharp.Parse Namespace


PrimaryFollowExpression Class

For a list of all members of this type, see PrimaryFollowExpression Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Expression
DDW.CSharp.Parse.PrimaryFollowExpression
DDW.CSharp.Parse.IndexerExpr
DDW.CSharp.Parse.InvokeExpr
DDW.CSharp.Parse.MemberAccessExpr
DDW.CSharp.Parse.PostfixExpr

public class PrimaryFollowExpression : Expression

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

PrimaryFollowExpression Members | DDW.CSharp.Parse Namespace


PrimaryFollowExpression Members

PrimaryFollowExpression overview

Public Static Methods

ParseFollow

Public Instance Constructors

PrimaryFollowExpression Constructor Initializes a new instance of the PrimaryFollowExpression class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

PrimaryFollowExpression Class | DDW.CSharp.Parse Namespace


PrimaryFollowExpression Constructor

Initializes a new instance of the PrimaryFollowExpression class.

public PrimaryFollowExpression();

See Also

PrimaryFollowExpression Class | DDW.CSharp.Parse Namespace


PrimaryFollowExpression Methods

The methods of the PrimaryFollowExpression class are listed below. For a complete list of PrimaryFollowExpression class members, see the PrimaryFollowExpression Members topic.

Public Static Methods

ParseFollow

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PrimaryFollowExpression Class | DDW.CSharp.Parse Namespace


PrimaryFollowExpression.ParseFollow Method

public static Expression ParseFollow(
Expression tok,
Expression target
);

See Also

PrimaryFollowExpression Class | DDW.CSharp.Parse Namespace


PrimitiveExpr Class

For a list of all members of this type, see PrimitiveExpr Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Expression
DDW.CSharp.Parse.PrimaryExpression
DDW.CSharp.Parse.PrimitiveExpr
Derived types

public class PrimitiveExpr : PrimaryExpression

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

PrimitiveExpr Members | DDW.CSharp.Parse Namespace


PrimitiveExpr Members

PrimitiveExpr overview

Public Instance Constructors

PrimitiveExpr Constructor Initializes a new instance of the PrimitiveExpr class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

PrimitiveExpr Class | DDW.CSharp.Parse Namespace


PrimitiveExpr Constructor

Initializes a new instance of the PrimitiveExpr class.

public PrimitiveExpr();

See Also

PrimitiveExpr Class | DDW.CSharp.Parse Namespace


PropertyNode Class

For a list of all members of this type, see PropertyNode Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.TypeMemberNode
DDW.CSharp.Parse.PropertyNode

public class PropertyNode : TypeMemberNode

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

PropertyNode Members | DDW.CSharp.Parse Namespace


PropertyNode Members

PropertyNode overview

Public Instance Constructors

PropertyNode Constructor Initializes a new instance of the PropertyNode class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetGraph (inherited from TypeMemberNode) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseModifiers (inherited from TypeMemberNode) |

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

PropertyNode Class | DDW.CSharp.Parse Namespace


PropertyNode Constructor

Initializes a new instance of the PropertyNode class.

public PropertyNode();

See Also

PropertyNode Class | DDW.CSharp.Parse Namespace


PropertyNode Methods

The methods of the PropertyNode class are listed below. For a complete list of PropertyNode class members, see the PropertyNode Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetGraph (inherited from TypeMemberNode) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseModifiers (inherited from TypeMemberNode) |

See Also

PropertyNode Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

PropertyNode.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from CSharpAST.

public virtual IGraph GetGraph(IGraph);

Inherited from TypeMemberNode.

public MemberDecl GetGraph(MemberDecl);

public PropertyDecl GetGraph(PropertyDecl);

See Also

PropertyNode Class | DDW.CSharp.Parse Namespace


PropertyNode.GetGraph Method ()

public override IGraph GetGraph();

See Also

PropertyNode Class | DDW.CSharp.Parse Namespace | PropertyNode.GetGraph Overload List


PropertyNode.GetGraph Method (PropertyDecl)

public PropertyDecl GetGraph(
PropertyDecl graph
);

See Also

PropertyNode Class | DDW.CSharp.Parse Namespace | PropertyNode.GetGraph Overload List


QualIdent Class

For a list of all members of this type, see QualIdent Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Expression
DDW.CSharp.Parse.QualIdent

public class QualIdent : Expression

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

QualIdent Members | DDW.CSharp.Parse Namespace


QualIdent Members

QualIdent overview

Public Static Methods

GetFullName

Public Instance Constructors

QualIdent Constructor Initializes a new instance of the QualIdent class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

QualIdent Class | DDW.CSharp.Parse Namespace


QualIdent Constructor

Initializes a new instance of the QualIdent class.

public QualIdent();

See Also

QualIdent Class | DDW.CSharp.Parse Namespace


QualIdent Methods

The methods of the QualIdent class are listed below. For a complete list of QualIdent class members, see the QualIdent Members topic.

Public Static Methods

GetFullName

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

QualIdent Class | DDW.CSharp.Parse Namespace


QualIdent.GetFullName Method

public static string GetFullName(
QualIdent qiTok
);

See Also

QualIdent Class | DDW.CSharp.Parse Namespace


RealLiteral Class

For a list of all members of this type, see RealLiteral Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Expression
DDW.CSharp.Parse.PrimaryExpression
DDW.CSharp.Parse.PrimitiveExpr
DDW.CSharp.Parse.RealLiteral

public class RealLiteral : PrimitiveExpr

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

RealLiteral Members | DDW.CSharp.Parse Namespace


RealLiteral Members

RealLiteral overview

Public Instance Constructors

RealLiteral Constructor Initializes a new instance of the RealLiteral class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

RealLiteral Class | DDW.CSharp.Parse Namespace


RealLiteral Constructor

Initializes a new instance of the RealLiteral class.

public RealLiteral();

See Also

RealLiteral Class | DDW.CSharp.Parse Namespace


RealLiteral Methods

The methods of the RealLiteral class are listed below. For a complete list of RealLiteral class members, see the RealLiteral Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RealLiteral Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

RealLiteral.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from Expression.

public virtual IGraph GetGraph(IGraph);

public RealLiteral GetGraph(RealLiteral);

See Also

RealLiteral Class | DDW.CSharp.Parse Namespace


RealLiteral.GetGraph Method ()

public override IGraph GetGraph();

See Also

RealLiteral Class | DDW.CSharp.Parse Namespace | RealLiteral.GetGraph Overload List


RealLiteral.GetGraph Method (RealLiteral)

public RealLiteral GetGraph(
RealLiteral graph
);

See Also

RealLiteral Class | DDW.CSharp.Parse Namespace | RealLiteral.GetGraph Overload List


ReturnStmt Class

For a list of all members of this type, see ReturnStmt Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Statement
DDW.CSharp.Parse.ReturnStmt

public class ReturnStmt : Statement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

ReturnStmt Members | DDW.CSharp.Parse Namespace


ReturnStmt Members

ReturnStmt overview

Public Instance Constructors

ReturnStmt Constructor Initializes a new instance of the ReturnStmt class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGraph (inherited from Statement) | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

ReturnStmt Class | DDW.CSharp.Parse Namespace


ReturnStmt Constructor

Initializes a new instance of the ReturnStmt class.

public ReturnStmt();

See Also

ReturnStmt Class | DDW.CSharp.Parse Namespace


ReturnStmt Methods

The methods of the ReturnStmt class are listed below. For a complete list of ReturnStmt class members, see the ReturnStmt Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGraph (inherited from Statement) | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ReturnStmt Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

ReturnStmt.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from Statement.

protected virtual IGraph GetGraph(IGraph);

public ReturnStmt GetGraph(ReturnStmt);

See Also

ReturnStmt Class | DDW.CSharp.Parse Namespace


ReturnStmt.GetGraph Method ()

public override IGraph GetGraph();

See Also

ReturnStmt Class | DDW.CSharp.Parse Namespace | ReturnStmt.GetGraph Overload List


ReturnStmt.GetGraph Method (ReturnStmt)

public ReturnStmt GetGraph(
ReturnStmt graph
);

See Also

ReturnStmt Class | DDW.CSharp.Parse Namespace | ReturnStmt.GetGraph Overload List


Statement Class

For a list of all members of this type, see Statement Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Statement
Derived types

public class Statement : CSharpAST

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

Statement Members | DDW.CSharp.Parse Namespace


Statement Members

Statement overview

Public Static Methods

ParseStatement

Public Instance Constructors

Statement Constructor Initializes a new instance of the Statement class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGraph | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

Statement Class | DDW.CSharp.Parse Namespace


Statement Constructor

Initializes a new instance of the Statement class.

public Statement();

See Also

Statement Class | DDW.CSharp.Parse Namespace


Statement Methods

The methods of the Statement class are listed below. For a complete list of Statement class members, see the Statement Members topic.

Public Static Methods

ParseStatement

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGraph | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Statement Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

Statement.GetGraph Method

Overload List

public override IGraph GetGraph();

new protected virtual IGraph GetGraph(IGraph);

See Also

Statement Class | DDW.CSharp.Parse Namespace


Statement.GetGraph Method ()

public override IGraph GetGraph();

See Also

Statement Class | DDW.CSharp.Parse Namespace | Statement.GetGraph Overload List


Statement.GetGraph Method (IGraph)

new protected virtual IGraph GetGraph(
IGraph graph
);

See Also

Statement Class | DDW.CSharp.Parse Namespace | Statement.GetGraph Overload List


Statement.ParseStatement Method

public static Statement ParseStatement(
Statement tok
);

See Also

Statement Class | DDW.CSharp.Parse Namespace


Statements Class

For a list of all members of this type, see Statements Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Statements
DDW.CSharp.Parse.IncStmt
DDW.CSharp.Parse.InitStmt

public class Statements : CSharpAST

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

Statements Members | DDW.CSharp.Parse Namespace


Statements Members

Statements overview

Public Instance Constructors

Statements Constructor Initializes a new instance of the Statements class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

Statements Class | DDW.CSharp.Parse Namespace


Statements Constructor

Initializes a new instance of the Statements class.

public Statements();

See Also

Statements Class | DDW.CSharp.Parse Namespace


Statements Methods

The methods of the Statements class are listed below. For a complete list of Statements class members, see the Statements Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Statements Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

Statements.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from CSharpAST.

public virtual IGraph GetGraph(IGraph);

public StatementCollection GetGraph(StatementCollection);

See Also

Statements Class | DDW.CSharp.Parse Namespace


Statements.GetGraph Method ()

public override IGraph GetGraph();

See Also

Statements Class | DDW.CSharp.Parse Namespace | Statements.GetGraph Overload List


Statements.GetGraph Method (StatementCollection)

public StatementCollection GetGraph(
StatementCollection graph
);

See Also

Statements Class | DDW.CSharp.Parse Namespace | Statements.GetGraph Overload List


StringLiteral Class

For a list of all members of this type, see StringLiteral Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Expression
DDW.CSharp.Parse.PrimaryExpression
DDW.CSharp.Parse.PrimitiveExpr
DDW.CSharp.Parse.StringLiteral

public class StringLiteral : PrimitiveExpr

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

StringLiteral Members | DDW.CSharp.Parse Namespace


StringLiteral Members

StringLiteral overview

Public Instance Constructors

StringLiteral Constructor Initializes a new instance of the StringLiteral class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

StringLiteral Class | DDW.CSharp.Parse Namespace


StringLiteral Constructor

Initializes a new instance of the StringLiteral class.

public StringLiteral();

See Also

StringLiteral Class | DDW.CSharp.Parse Namespace


StringLiteral Methods

The methods of the StringLiteral class are listed below. For a complete list of StringLiteral class members, see the StringLiteral Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StringLiteral Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

StringLiteral.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from Expression.

public virtual IGraph GetGraph(IGraph);

public StringLiteral GetGraph(StringLiteral);

See Also

StringLiteral Class | DDW.CSharp.Parse Namespace


StringLiteral.GetGraph Method ()

public override IGraph GetGraph();

See Also

StringLiteral Class | DDW.CSharp.Parse Namespace | StringLiteral.GetGraph Overload List


StringLiteral.GetGraph Method (StringLiteral)

public StringLiteral GetGraph(
StringLiteral graph
);

See Also

StringLiteral Class | DDW.CSharp.Parse Namespace | StringLiteral.GetGraph Overload List


StructNode Class

For a list of all members of this type, see StructNode Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.TypeMemberNode
DDW.CSharp.Parse.TypeNode
DDW.CSharp.Parse.StructNode

public class StructNode : TypeNode

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

StructNode Members | DDW.CSharp.Parse Namespace


StructNode Members

StructNode overview

Public Instance Constructors

StructNode Constructor Initializes a new instance of the StructNode class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetGraph (inherited from TypeNode) | Overloaded.
GetGraph (inherited from TypeMemberNode) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseModifiers (inherited from TypeMemberNode) |
ParseTypeModifiers (inherited from TypeNode) |

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

StructNode Class | DDW.CSharp.Parse Namespace


StructNode Constructor

Initializes a new instance of the StructNode class.

public StructNode();

See Also

StructNode Class | DDW.CSharp.Parse Namespace


StructNode Methods

The methods of the StructNode class are listed below. For a complete list of StructNode class members, see the StructNode Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetGraph (inherited from TypeNode) | Overloaded.
GetGraph (inherited from TypeMemberNode) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseModifiers (inherited from TypeMemberNode) |
ParseTypeModifiers (inherited from TypeNode) |

See Also

StructNode Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

StructNode.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from CSharpAST.

public virtual IGraph GetGraph(IGraph);

Inherited from TypeMemberNode.

public MemberDecl GetGraph(MemberDecl);

public StructDecl GetGraph(StructDecl);

Inherited from TypeNode.

public TypeDecl GetGraph(TypeDecl);

See Also

StructNode Class | DDW.CSharp.Parse Namespace


StructNode.GetGraph Method ()

public override IGraph GetGraph();

See Also

StructNode Class | DDW.CSharp.Parse Namespace | StructNode.GetGraph Overload List


StructNode.GetGraph Method (StructDecl)

public StructDecl GetGraph(
StructDecl graph
);

See Also

StructNode Class | DDW.CSharp.Parse Namespace | StructNode.GetGraph Overload List


SubExpr Class

For a list of all members of this type, see SubExpr Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Expression
DDW.CSharp.Parse.SubExpr

public class SubExpr : Expression

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

SubExpr Members | DDW.CSharp.Parse Namespace


SubExpr Members

SubExpr overview

Public Instance Constructors

SubExpr Constructor Initializes a new instance of the SubExpr class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

SubExpr Class | DDW.CSharp.Parse Namespace


SubExpr Constructor

Initializes a new instance of the SubExpr class.

public SubExpr();

See Also

SubExpr Class | DDW.CSharp.Parse Namespace


SubExpr Methods

The methods of the SubExpr class are listed below. For a complete list of SubExpr class members, see the SubExpr Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SubExpr Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

SubExpr.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from Expression.

public virtual IGraph GetGraph(IGraph);

public SubExpr GetGraph(SubExpr);

See Also

SubExpr Class | DDW.CSharp.Parse Namespace


SubExpr.GetGraph Method ()

public override IGraph GetGraph();

See Also

SubExpr Class | DDW.CSharp.Parse Namespace | SubExpr.GetGraph Overload List


SubExpr.GetGraph Method (SubExpr)

public SubExpr GetGraph(
SubExpr graph
);

See Also

SubExpr Class | DDW.CSharp.Parse Namespace | SubExpr.GetGraph Overload List


SwitchSection Class

For a list of all members of this type, see SwitchSection Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.SwitchSection

public class SwitchSection : CSharpAST

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

SwitchSection Members | DDW.CSharp.Parse Namespace


SwitchSection Members

SwitchSection overview

Public Instance Constructors

SwitchSection Constructor Initializes a new instance of the SwitchSection class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

SwitchSection Class | DDW.CSharp.Parse Namespace


SwitchSection Constructor

Initializes a new instance of the SwitchSection class.

public SwitchSection();

See Also

SwitchSection Class | DDW.CSharp.Parse Namespace


SwitchSection Methods

The methods of the SwitchSection class are listed below. For a complete list of SwitchSection class members, see the SwitchSection Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SwitchSection Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

SwitchSection.GetGraph Method

Overload List

public override IGraph GetGraph();

public Case GetGraph(Case);

Inherited from CSharpAST.

public virtual IGraph GetGraph(IGraph);

See Also

SwitchSection Class | DDW.CSharp.Parse Namespace


SwitchSection.GetGraph Method ()

public override IGraph GetGraph();

See Also

SwitchSection Class | DDW.CSharp.Parse Namespace | SwitchSection.GetGraph Overload List


SwitchSection.GetGraph Method (Case)

public Case GetGraph(
Case graph
);

See Also

SwitchSection Class | DDW.CSharp.Parse Namespace | SwitchSection.GetGraph Overload List


SwitchStmt Class

For a list of all members of this type, see SwitchStmt Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Statement
DDW.CSharp.Parse.SwitchStmt

public class SwitchStmt : Statement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

SwitchStmt Members | DDW.CSharp.Parse Namespace


SwitchStmt Members

SwitchStmt overview

Public Instance Constructors

SwitchStmt Constructor Initializes a new instance of the SwitchStmt class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGraph (inherited from Statement) | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

SwitchStmt Class | DDW.CSharp.Parse Namespace


SwitchStmt Constructor

Initializes a new instance of the SwitchStmt class.

public SwitchStmt();

See Also

SwitchStmt Class | DDW.CSharp.Parse Namespace


SwitchStmt Methods

The methods of the SwitchStmt class are listed below. For a complete list of SwitchStmt class members, see the SwitchStmt Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGraph (inherited from Statement) | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SwitchStmt Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

SwitchStmt.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from Statement.

protected virtual IGraph GetGraph(IGraph);

public SwitchStmt GetGraph(SwitchStmt);

See Also

SwitchStmt Class | DDW.CSharp.Parse Namespace


SwitchStmt.GetGraph Method ()

public override IGraph GetGraph();

See Also

SwitchStmt Class | DDW.CSharp.Parse Namespace | SwitchStmt.GetGraph Overload List


SwitchStmt.GetGraph Method (SwitchStmt)

public SwitchStmt GetGraph(
SwitchStmt graph
);

See Also

SwitchStmt Class | DDW.CSharp.Parse Namespace | SwitchStmt.GetGraph Overload List


TernaryExpr Class

For a list of all members of this type, see TernaryExpr Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Expression
DDW.CSharp.Parse.TernaryExpr

public class TernaryExpr : Expression

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

TernaryExpr Members | DDW.CSharp.Parse Namespace


TernaryExpr Members

TernaryExpr overview

Public Instance Constructors

TernaryExpr Constructor Initializes a new instance of the TernaryExpr class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

TernaryExpr Class | DDW.CSharp.Parse Namespace


TernaryExpr Constructor

Initializes a new instance of the TernaryExpr class.

public TernaryExpr();

See Also

TernaryExpr Class | DDW.CSharp.Parse Namespace


TernaryExpr Methods

The methods of the TernaryExpr class are listed below. For a complete list of TernaryExpr class members, see the TernaryExpr Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TernaryExpr Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

TernaryExpr.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from Expression.

public virtual IGraph GetGraph(IGraph);

public TernaryExpr GetGraph(TernaryExpr);

See Also

TernaryExpr Class | DDW.CSharp.Parse Namespace


TernaryExpr.GetGraph Method ()

public override IGraph GetGraph();

See Also

TernaryExpr Class | DDW.CSharp.Parse Namespace | TernaryExpr.GetGraph Overload List


TernaryExpr.GetGraph Method (TernaryExpr)

public TernaryExpr GetGraph(
TernaryExpr graph
);

See Also

TernaryExpr Class | DDW.CSharp.Parse Namespace | TernaryExpr.GetGraph Overload List


TernaryOp Class

For a list of all members of this type, see TernaryOp Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.TernaryOp

public class TernaryOp : CSharpAST

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

TernaryOp Members | DDW.CSharp.Parse Namespace


TernaryOp Members

TernaryOp overview

Public Instance Constructors

TernaryOp Constructor Initializes a new instance of the TernaryOp class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

TernaryOp Class | DDW.CSharp.Parse Namespace


TernaryOp Constructor

Initializes a new instance of the TernaryOp class.

public TernaryOp();

See Also

TernaryOp Class | DDW.CSharp.Parse Namespace


TernaryOp Methods

The methods of the TernaryOp class are listed below. For a complete list of TernaryOp class members, see the TernaryOp Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TernaryOp Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

TernaryOp.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from CSharpAST.

public virtual IGraph GetGraph(IGraph);

See Also

TernaryOp Class | DDW.CSharp.Parse Namespace


TernaryOp.GetGraph Method ()

public override IGraph GetGraph();

See Also

TernaryOp Class | DDW.CSharp.Parse Namespace | TernaryOp.GetGraph Overload List


ThisRefExpr Class

For a list of all members of this type, see ThisRefExpr Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Expression
DDW.CSharp.Parse.PrimaryExpression
DDW.CSharp.Parse.ThisRefExpr

public class ThisRefExpr : PrimaryExpression

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

ThisRefExpr Members | DDW.CSharp.Parse Namespace


ThisRefExpr Members

ThisRefExpr overview

Public Instance Constructors

ThisRefExpr Constructor Initializes a new instance of the ThisRefExpr class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

ThisRefExpr Class | DDW.CSharp.Parse Namespace


ThisRefExpr Constructor

Initializes a new instance of the ThisRefExpr class.

public ThisRefExpr();

See Also

ThisRefExpr Class | DDW.CSharp.Parse Namespace


ThisRefExpr Methods

The methods of the ThisRefExpr class are listed below. For a complete list of ThisRefExpr class members, see the ThisRefExpr Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ThisRefExpr Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

ThisRefExpr.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from Expression.

public virtual IGraph GetGraph(IGraph);

public ThisRef GetGraph(ThisRef);

See Also

ThisRefExpr Class | DDW.CSharp.Parse Namespace


ThisRefExpr.GetGraph Method ()

public override IGraph GetGraph();

See Also

ThisRefExpr Class | DDW.CSharp.Parse Namespace | ThisRefExpr.GetGraph Overload List


ThisRefExpr.GetGraph Method (ThisRef)

public ThisRef GetGraph(
ThisRef graph
);

See Also

ThisRefExpr Class | DDW.CSharp.Parse Namespace | ThisRefExpr.GetGraph Overload List


ThrowStmt Class

For a list of all members of this type, see ThrowStmt Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Statement
DDW.CSharp.Parse.ThrowStmt

public class ThrowStmt : Statement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

ThrowStmt Members | DDW.CSharp.Parse Namespace


ThrowStmt Members

ThrowStmt overview

Public Instance Constructors

ThrowStmt Constructor Initializes a new instance of the ThrowStmt class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGraph (inherited from Statement) | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

ThrowStmt Class | DDW.CSharp.Parse Namespace


ThrowStmt Constructor

Initializes a new instance of the ThrowStmt class.

public ThrowStmt();

See Also

ThrowStmt Class | DDW.CSharp.Parse Namespace


ThrowStmt Methods

The methods of the ThrowStmt class are listed below. For a complete list of ThrowStmt class members, see the ThrowStmt Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGraph (inherited from Statement) | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ThrowStmt Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

ThrowStmt.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from Statement.

protected virtual IGraph GetGraph(IGraph);

public ThrowStmt GetGraph(ThrowStmt);

See Also

ThrowStmt Class | DDW.CSharp.Parse Namespace


ThrowStmt.GetGraph Method ()

public override IGraph GetGraph();

See Also

ThrowStmt Class | DDW.CSharp.Parse Namespace | ThrowStmt.GetGraph Overload List


ThrowStmt.GetGraph Method (ThrowStmt)

public ThrowStmt GetGraph(
ThrowStmt graph
);

See Also

ThrowStmt Class | DDW.CSharp.Parse Namespace | ThrowStmt.GetGraph Overload List


TryCatchFinallyStmt Class

For a list of all members of this type, see TryCatchFinallyStmt Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Statement
DDW.CSharp.Parse.TryCatchFinallyStmt

public class TryCatchFinallyStmt : Statement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

TryCatchFinallyStmt Members | DDW.CSharp.Parse Namespace


TryCatchFinallyStmt Members

TryCatchFinallyStmt overview

Public Instance Constructors

TryCatchFinallyStmt Constructor Initializes a new instance of the TryCatchFinallyStmt class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGraph (inherited from Statement) | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

TryCatchFinallyStmt Class | DDW.CSharp.Parse Namespace


TryCatchFinallyStmt Constructor

Initializes a new instance of the TryCatchFinallyStmt class.

public TryCatchFinallyStmt();

See Also

TryCatchFinallyStmt Class | DDW.CSharp.Parse Namespace


TryCatchFinallyStmt Methods

The methods of the TryCatchFinallyStmt class are listed below. For a complete list of TryCatchFinallyStmt class members, see the TryCatchFinallyStmt Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGraph (inherited from Statement) | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TryCatchFinallyStmt Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

TryCatchFinallyStmt.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from Statement.

protected virtual IGraph GetGraph(IGraph);

public TryCatchFinallyStmt GetGraph(TryCatchFinallyStmt);

See Also

TryCatchFinallyStmt Class | DDW.CSharp.Parse Namespace


TryCatchFinallyStmt.GetGraph Method ()

public override IGraph GetGraph();

See Also

TryCatchFinallyStmt Class | DDW.CSharp.Parse Namespace | TryCatchFinallyStmt.GetGraph Overload List


TryCatchFinallyStmt.GetGraph Method (TryCatchFinallyStmt)

public TryCatchFinallyStmt GetGraph(
TryCatchFinallyStmt graph
);

See Also

TryCatchFinallyStmt Class | DDW.CSharp.Parse Namespace | TryCatchFinallyStmt.GetGraph Overload List


TryStmt Class

For a list of all members of this type, see TryStmt Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.TryStmt

public class TryStmt : CSharpAST

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

TryStmt Members | DDW.CSharp.Parse Namespace


TryStmt Members

TryStmt overview

Public Instance Constructors

TryStmt Constructor Initializes a new instance of the TryStmt class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

TryStmt Class | DDW.CSharp.Parse Namespace


TryStmt Constructor

Initializes a new instance of the TryStmt class.

public TryStmt();

See Also

TryStmt Class | DDW.CSharp.Parse Namespace


TryStmt Methods

The methods of the TryStmt class are listed below. For a complete list of TryStmt class members, see the TryStmt Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TryStmt Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

TryStmt.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from CSharpAST.

public virtual IGraph GetGraph(IGraph);

See Also

TryStmt Class | DDW.CSharp.Parse Namespace


TryStmt.GetGraph Method ()

public override IGraph GetGraph();

See Also

TryStmt Class | DDW.CSharp.Parse Namespace | TryStmt.GetGraph Overload List


TypeMemberNode Class

Abstract base class for member types (Class, Method, Prop..) Name Attributes CustomAttributes Comments

For a list of all members of this type, see TypeMemberNode Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.TypeMemberNode
Derived types

public abstract class TypeMemberNode : CSharpAST

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

TypeMemberNode Members | DDW.CSharp.Parse Namespace


TypeMemberNode Members

TypeMemberNode overview

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Constructors

TypeMemberNode Constructor Initializes a new instance of the TypeMemberNode class.

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseModifiers |

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

TypeMemberNode Class | DDW.CSharp.Parse Namespace


TypeMemberNode Constructor

Initializes a new instance of the TypeMemberNode class.

protected TypeMemberNode();

See Also

TypeMemberNode Class | DDW.CSharp.Parse Namespace


TypeMemberNode Methods

The methods of the TypeMemberNode class are listed below. For a complete list of TypeMemberNode class members, see the TypeMemberNode Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseModifiers |

See Also

TypeMemberNode Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

TypeMemberNode.GetGraph Method

Overload List

Inherited from CSharpAST.

public virtual IGraph GetGraph();

Inherited from CSharpAST.

public virtual IGraph GetGraph(IGraph);

public MemberDecl GetGraph(MemberDecl);

See Also

TypeMemberNode Class | DDW.CSharp.Parse Namespace


TypeMemberNode.GetGraph Method (MemberDecl)

public MemberDecl GetGraph(
MemberDecl graph
);

See Also

TypeMemberNode Class | DDW.CSharp.Parse Namespace | TypeMemberNode.GetGraph Overload List


TypeMemberNode.ParseModifiers Method

protected Modifiers ParseModifiers(
ModifierAttributes tok
);

See Also

TypeMemberNode Class | DDW.CSharp.Parse Namespace


TypeNode Class

For a list of all members of this type, see TypeNode Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.TypeMemberNode
DDW.CSharp.Parse.TypeNode
DDW.CSharp.Parse.ClassNode
DDW.CSharp.Parse.DelegateNode
DDW.CSharp.Parse.EnumNode
DDW.CSharp.Parse.InterfaceNode
DDW.CSharp.Parse.StructNode

public abstract class TypeNode : TypeMemberNode

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

TypeNode Members | DDW.CSharp.Parse Namespace


TypeNode Members

TypeNode overview

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetGraph (inherited from TypeMemberNode) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Constructors

TypeNode Constructor Initializes a new instance of the TypeNode class.

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseModifiers (inherited from TypeMemberNode) |
ParseTypeModifiers |

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

TypeNode Class | DDW.CSharp.Parse Namespace


TypeNode Constructor

Initializes a new instance of the TypeNode class.

protected TypeNode();

See Also

TypeNode Class | DDW.CSharp.Parse Namespace


TypeNode Methods

The methods of the TypeNode class are listed below. For a complete list of TypeNode class members, see the TypeNode Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetGraph (inherited from TypeMemberNode) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
ParseModifiers (inherited from TypeMemberNode) |
ParseTypeModifiers |

See Also

TypeNode Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

TypeNode.GetGraph Method

Overload List

Inherited from CSharpAST.

public virtual IGraph GetGraph();

Inherited from CSharpAST.

public virtual IGraph GetGraph(IGraph);

Inherited from TypeMemberNode.

public MemberDecl GetGraph(MemberDecl);

public TypeDecl GetGraph(TypeDecl);

See Also

TypeNode Class | DDW.CSharp.Parse Namespace


TypeNode.GetGraph Method (TypeDecl)

public TypeDecl GetGraph(
TypeDecl graph
);

See Also

TypeNode Class | DDW.CSharp.Parse Namespace | TypeNode.GetGraph Overload List


TypeNode.ParseTypeModifiers Method

protected TypeModifiers ParseTypeModifiers(
ModifierAttributes tok
);

See Also

TypeNode Class | DDW.CSharp.Parse Namespace


TypeOfExpr Class

For a list of all members of this type, see TypeOfExpr Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Expression
DDW.CSharp.Parse.PrimaryExpression
DDW.CSharp.Parse.TypeOfExpr

public class TypeOfExpr : PrimaryExpression

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

TypeOfExpr Members | DDW.CSharp.Parse Namespace


TypeOfExpr Members

TypeOfExpr overview

Public Instance Constructors

TypeOfExpr Constructor Initializes a new instance of the TypeOfExpr class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

TypeOfExpr Class | DDW.CSharp.Parse Namespace


TypeOfExpr Constructor

Initializes a new instance of the TypeOfExpr class.

public TypeOfExpr();

See Also

TypeOfExpr Class | DDW.CSharp.Parse Namespace


TypeOfExpr Methods

The methods of the TypeOfExpr class are listed below. For a complete list of TypeOfExpr class members, see the TypeOfExpr Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TypeOfExpr Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

TypeOfExpr.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from Expression.

public virtual IGraph GetGraph(IGraph);

public TypeOfExpr GetGraph(TypeOfExpr);

See Also

TypeOfExpr Class | DDW.CSharp.Parse Namespace


TypeOfExpr.GetGraph Method ()

public override IGraph GetGraph();

See Also

TypeOfExpr Class | DDW.CSharp.Parse Namespace | TypeOfExpr.GetGraph Overload List


TypeOfExpr.GetGraph Method (TypeOfExpr)

public TypeOfExpr GetGraph(
TypeOfExpr graph
);

See Also

TypeOfExpr Class | DDW.CSharp.Parse Namespace | TypeOfExpr.GetGraph Overload List


TypeRef Class

For a list of all members of this type, see TypeRef Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Expression
DDW.CSharp.Parse.TypeRef

public class TypeRef : Expression

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

TypeRef Members | DDW.CSharp.Parse Namespace


TypeRef Members

TypeRef overview

Public Instance Constructors

TypeRef Constructor Initializes a new instance of the TypeRef class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

TypeRef Class | DDW.CSharp.Parse Namespace


TypeRef Constructor

Initializes a new instance of the TypeRef class.

public TypeRef();

See Also

TypeRef Class | DDW.CSharp.Parse Namespace


TypeRef Methods

The methods of the TypeRef class are listed below. For a complete list of TypeRef class members, see the TypeRef Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TypeRef Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

TypeRef.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from Expression.

public virtual IGraph GetGraph(IGraph);

public TypeRef GetGraph(TypeRef);

See Also

TypeRef Class | DDW.CSharp.Parse Namespace


TypeRef.GetGraph Method ()

public override IGraph GetGraph();

See Also

TypeRef Class | DDW.CSharp.Parse Namespace | TypeRef.GetGraph Overload List


TypeRef.GetGraph Method (TypeRef)

public TypeRef GetGraph(
TypeRef graph
);

See Also

TypeRef Class | DDW.CSharp.Parse Namespace | TypeRef.GetGraph Overload List


Types Class

For a list of all members of this type, see Types Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Types

public class Types : CSharpAST

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

Types Members | DDW.CSharp.Parse Namespace


Types Members

Types overview

Public Static Methods

ParseTypesIntoNamespace

Public Instance Constructors

Types Constructor Initializes a new instance of the Types class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

Types Class | DDW.CSharp.Parse Namespace


Types Constructor

Initializes a new instance of the Types class.

public Types();

See Also

Types Class | DDW.CSharp.Parse Namespace


Types Methods

The methods of the Types class are listed below. For a complete list of Types class members, see the Types Members topic.

Public Static Methods

ParseTypesIntoNamespace

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Types Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

Types.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from CSharpAST.

public virtual IGraph GetGraph(IGraph);

public TypeDeclCollection GetGraph(TypeDeclCollection);

See Also

Types Class | DDW.CSharp.Parse Namespace


Types.GetGraph Method ()

public override IGraph GetGraph();

See Also

Types Class | DDW.CSharp.Parse Namespace | Types.GetGraph Overload List


Types.GetGraph Method (TypeDeclCollection)

public TypeDeclCollection GetGraph(
TypeDeclCollection graph
);

See Also

Types Class | DDW.CSharp.Parse Namespace | Types.GetGraph Overload List


Types.ParseTypesIntoNamespace Method

public static void ParseTypesIntoNamespace(
AST tok,
NamespaceDecl graph
);

See Also

Types Class | DDW.CSharp.Parse Namespace


UnaryExpr Class

For a list of all members of this type, see UnaryExpr Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Expression
DDW.CSharp.Parse.UnaryExpr

public class UnaryExpr : Expression

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

UnaryExpr Members | DDW.CSharp.Parse Namespace


UnaryExpr Members

UnaryExpr overview

Public Instance Constructors

UnaryExpr Constructor Initializes a new instance of the UnaryExpr class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

UnaryExpr Class | DDW.CSharp.Parse Namespace


UnaryExpr Constructor

Initializes a new instance of the UnaryExpr class.

public UnaryExpr();

See Also

UnaryExpr Class | DDW.CSharp.Parse Namespace


UnaryExpr Methods

The methods of the UnaryExpr class are listed below. For a complete list of UnaryExpr class members, see the UnaryExpr Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UnaryExpr Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

UnaryExpr.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from Expression.

public virtual IGraph GetGraph(IGraph);

public UnaryExpr GetGraph(UnaryExpr);

See Also

UnaryExpr Class | DDW.CSharp.Parse Namespace


UnaryExpr.GetGraph Method ()

public override IGraph GetGraph();

See Also

UnaryExpr Class | DDW.CSharp.Parse Namespace | UnaryExpr.GetGraph Overload List


UnaryExpr.GetGraph Method (UnaryExpr)

public UnaryExpr GetGraph(
UnaryExpr graph
);

See Also

UnaryExpr Class | DDW.CSharp.Parse Namespace | UnaryExpr.GetGraph Overload List


UnaryOp Class

For a list of all members of this type, see UnaryOp Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.UnaryOp

public class UnaryOp : CSharpAST

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

UnaryOp Members | DDW.CSharp.Parse Namespace


UnaryOp Members

UnaryOp overview

Public Instance Constructors

UnaryOp Constructor Initializes a new instance of the UnaryOp class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

UnaryOp Class | DDW.CSharp.Parse Namespace


UnaryOp Constructor

Initializes a new instance of the UnaryOp class.

public UnaryOp();

See Also

UnaryOp Class | DDW.CSharp.Parse Namespace


UnaryOp Methods

The methods of the UnaryOp class are listed below. For a complete list of UnaryOp class members, see the UnaryOp Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UnaryOp Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

UnaryOp.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from CSharpAST.

public virtual IGraph GetGraph(IGraph);

See Also

UnaryOp Class | DDW.CSharp.Parse Namespace


UnaryOp.GetGraph Method ()

public override IGraph GetGraph();

See Also

UnaryOp Class | DDW.CSharp.Parse Namespace | UnaryOp.GetGraph Overload List


UncheckedExpr Class

For a list of all members of this type, see UncheckedExpr Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Expression
DDW.CSharp.Parse.PrimaryExpression
DDW.CSharp.Parse.UncheckedExpr

public class UncheckedExpr : PrimaryExpression

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

UncheckedExpr Members | DDW.CSharp.Parse Namespace


UncheckedExpr Members

UncheckedExpr overview

Public Instance Constructors

UncheckedExpr Constructor Initializes a new instance of the UncheckedExpr class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from Expression) | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

UncheckedExpr Class | DDW.CSharp.Parse Namespace


UncheckedExpr Constructor

Initializes a new instance of the UncheckedExpr class.

public UncheckedExpr();

See Also

UncheckedExpr Class | DDW.CSharp.Parse Namespace


UncheckedStmt Class

For a list of all members of this type, see UncheckedStmt Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Statement
DDW.CSharp.Parse.UncheckedStmt

public class UncheckedStmt : Statement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

UncheckedStmt Members | DDW.CSharp.Parse Namespace


UncheckedStmt Members

UncheckedStmt overview

Public Instance Constructors

UncheckedStmt Constructor Initializes a new instance of the UncheckedStmt class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGraph (inherited from Statement) | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

UncheckedStmt Class | DDW.CSharp.Parse Namespace


UncheckedStmt Constructor

Initializes a new instance of the UncheckedStmt class.

public UncheckedStmt();

See Also

UncheckedStmt Class | DDW.CSharp.Parse Namespace


UncheckedStmt Methods

The methods of the UncheckedStmt class are listed below. For a complete list of UncheckedStmt class members, see the UncheckedStmt Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGraph (inherited from Statement) | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UncheckedStmt Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

UncheckedStmt.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from Statement.

protected virtual IGraph GetGraph(IGraph);

public UncheckedStmt GetGraph(UncheckedStmt);

See Also

UncheckedStmt Class | DDW.CSharp.Parse Namespace


UncheckedStmt.GetGraph Method ()

public override IGraph GetGraph();

See Also

UncheckedStmt Class | DDW.CSharp.Parse Namespace | UncheckedStmt.GetGraph Overload List


UncheckedStmt.GetGraph Method (UncheckedStmt)

public UncheckedStmt GetGraph(
UncheckedStmt graph
);

See Also

UncheckedStmt Class | DDW.CSharp.Parse Namespace | UncheckedStmt.GetGraph Overload List


UsingNode Class

For a list of all members of this type, see UsingNode Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.UsingNode

public class UsingNode : CSharpAST

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

UsingNode Members | DDW.CSharp.Parse Namespace


UsingNode Members

UsingNode overview

Public Instance Constructors

UsingNode Constructor Initializes a new instance of the UsingNode class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

UsingNode Class | DDW.CSharp.Parse Namespace


UsingNode Constructor

Initializes a new instance of the UsingNode class.

public UsingNode();

See Also

UsingNode Class | DDW.CSharp.Parse Namespace


UsingNode Methods

The methods of the UsingNode class are listed below. For a complete list of UsingNode class members, see the UsingNode Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph (inherited from CSharpAST) | Overloaded.
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UsingNode Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

UsingNode.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from CSharpAST.

public virtual IGraph GetGraph(IGraph);

public Import GetGraph(Import);

See Also

UsingNode Class | DDW.CSharp.Parse Namespace


UsingNode.GetGraph Method ()

public override IGraph GetGraph();

See Also

UsingNode Class | DDW.CSharp.Parse Namespace | UsingNode.GetGraph Overload List


UsingNode.GetGraph Method (Import)

public Import GetGraph(
Import graph
);

See Also

UsingNode Class | DDW.CSharp.Parse Namespace | UsingNode.GetGraph Overload List


UsingStmt Class

For a list of all members of this type, see UsingStmt Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Statement
DDW.CSharp.Parse.UsingStmt

public class UsingStmt : Statement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

UsingStmt Members | DDW.CSharp.Parse Namespace


UsingStmt Members

UsingStmt overview

Public Instance Constructors

UsingStmt Constructor Initializes a new instance of the UsingStmt class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGraph (inherited from Statement) | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

UsingStmt Class | DDW.CSharp.Parse Namespace


UsingStmt Constructor

Initializes a new instance of the UsingStmt class.

public UsingStmt();

See Also

UsingStmt Class | DDW.CSharp.Parse Namespace


UsingStmt Methods

The methods of the UsingStmt class are listed below. For a complete list of UsingStmt class members, see the UsingStmt Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGraph (inherited from Statement) | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UsingStmt Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

UsingStmt.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from Statement.

protected virtual IGraph GetGraph(IGraph);

public UsingStmt GetGraph(UsingStmt);

See Also

UsingStmt Class | DDW.CSharp.Parse Namespace


UsingStmt.GetGraph Method ()

public override IGraph GetGraph();

See Also

UsingStmt Class | DDW.CSharp.Parse Namespace | UsingStmt.GetGraph Overload List


UsingStmt.GetGraph Method (UsingStmt)

public UsingStmt GetGraph(
UsingStmt graph
);

See Also

UsingStmt Class | DDW.CSharp.Parse Namespace | UsingStmt.GetGraph Overload List


VariableDeclStmt Class

For a list of all members of this type, see VariableDeclStmt Members.

System.Object
antlr.BaseAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.Statement
DDW.CSharp.Parse.VariableDeclStmt

public class VariableDeclStmt : Statement

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Parse

Assembly: CSharp (in CSharp.dll)

See Also

VariableDeclStmt Members | DDW.CSharp.Parse Namespace


VariableDeclStmt Members

VariableDeclStmt overview

Public Instance Constructors

VariableDeclStmt Constructor Initializes a new instance of the VariableDeclStmt class.

Public Instance Properties

FileName (inherited from CSharpAST) |
LinePragma (inherited from CSharpAST) |
Text (inherited from antlr.BaseAST) |
Type (inherited from CSharpAST) | Gets or sets the Type of the node (TODO: make this enum)
UserData (inherited from CSharpAST) | Gets or sets the user-definable data for the current object.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Fields

curType (inherited from CSharpAST)
isDirty (inherited from CSharpAST)
p_text (inherited from CSharpAST)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGraph (inherited from Statement) | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

down (inherited from antlr.BaseAST)
right (inherited from antlr.BaseAST)

See Also

VariableDeclStmt Class | DDW.CSharp.Parse Namespace


VariableDeclStmt Constructor

Initializes a new instance of the VariableDeclStmt class.

public VariableDeclStmt();

See Also

VariableDeclStmt Class | DDW.CSharp.Parse Namespace


VariableDeclStmt Methods

The methods of the VariableDeclStmt class are listed below. For a complete list of VariableDeclStmt class members, see the VariableDeclStmt Members topic.

Public Instance Methods

AddBuiltInDefinition (inherited from CSharpAST) |
addChild (inherited from antlr.BaseAST) |
AddDefinition (inherited from CSharpAST) |
AddRootExpression (inherited from CSharpAST) | Stores root expressions (right sides, args, etc) to make expr exprAttr quicker.
AddSymbol (inherited from CSharpAST) | Symbols are variables that refer to types, or type refs themselves.
Clone (inherited from antlr.BaseAST) | Obsolete.
CloseScope (inherited from CSharpAST) |
Equals (inherited from antlr.BaseAST) | Overloaded.
EqualsList (inherited from antlr.BaseAST) |
EqualsListPartial (inherited from antlr.BaseAST) |
EqualsTree (inherited from antlr.BaseAST) |
EqualsTreePartial (inherited from antlr.BaseAST) |
findAll (inherited from antlr.BaseAST) |
findAllPartial (inherited from antlr.BaseAST) |
getFirstChild (inherited from antlr.BaseAST) |
GetGraph | Overloaded.
GetHashCode (inherited from antlr.BaseAST) |
getNextSibling (inherited from antlr.BaseAST) |
getNumberOfChildren (inherited from antlr.BaseAST) |
getText (inherited from CSharpAST) |
getType (inherited from CSharpAST) |
GetType (inherited from Object) | Gets the Type of the current instance.
initialize (inherited from CSharpAST) | Overloaded.
OpenBlockScope (inherited from CSharpAST) |
OpenScope (inherited from CSharpAST) | Creates a new scope and sets it as the current scope. This will also add a definition to the parent scope if needed (in case of eg Class or Namespace, but not eg block or compile unit).
removeChildren (inherited from antlr.BaseAST) |
ResolveExpressions (inherited from CSharpAST) | Determines all the return types of expressions, needed for resolving overloads.
ResolveSymbols (inherited from CSharpAST) | Attributes all the stored symbols - only call once all definitions are parsed. This will clear the symbol table once its contents are attributed.
setFirstChild (inherited from antlr.BaseAST) |
setNextSibling (inherited from antlr.BaseAST) |
setText (inherited from CSharpAST) |
setType (inherited from CSharpAST) |
ToString (inherited from CSharpAST) |
ToStringList (inherited from antlr.BaseAST) |
ToStringTree (inherited from antlr.BaseAST) | Overloaded.
xmlSerialize (inherited from antlr.BaseAST) |
xmlSerializeNode (inherited from antlr.BaseAST) |
xmlSerializeRootClose (inherited from antlr.BaseAST) |
xmlSerializeRootOpen (inherited from antlr.BaseAST) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetGraph (inherited from Statement) | Overloaded.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

VariableDeclStmt Class | DDW.CSharp.Parse Namespace


GetGraph Method

Goblin - A Platform for 3D AR and VR Applications

VariableDeclStmt.GetGraph Method

Overload List

public override IGraph GetGraph();

Inherited from Statement.

protected virtual IGraph GetGraph(IGraph);

public VariableDeclStmt GetGraph(VariableDeclStmt);

See Also

VariableDeclStmt Class | DDW.CSharp.Parse Namespace


VariableDeclStmt.GetGraph Method ()

public override IGraph GetGraph();

See Also

VariableDeclStmt Class | DDW.CSharp.Parse Namespace | VariableDeclStmt.GetGraph Overload List


VariableDeclStmt.GetGraph Method (VariableDeclStmt)

public VariableDeclStmt GetGraph(
VariableDeclStmt graph
);

See Also

VariableDeclStmt Class | DDW.CSharp.Parse Namespace | VariableDeclStmt.GetGraph Overload List


DDW.CSharp.SymbolTable

Goblin - A Platform for 3D AR and VR Applications

DDW.CSharp.SymbolTable Namespace

C# grammar (based on ecma-334 spec) -- Robin Debreuil Fri Mar 5, 2004 11:50 -- A (mostly) complete cs parser. It parses into a tree structure loosely based on the CodeDom. Does not yet do #if preprocessor segments, and no unsafe code (as of yet). You can test by downloading the CSharp.zip file and dragging cs files into CSharp.exe. The zip includes the grammar file, as well as the cs token classes (the grammar uses a heterogeneous tree, though that should be simple to turn off). -- permalink: http://www.debreuil.com/CSharp. TJP: copied src, exe to antlr.org and changed link as debreuil's links are dead.

Namespace hierarchy

Classes

Class | Description
AssemblyScope |
BlockScope |
BuiltInDefinition | Base class for Definitions. Definitions may be variables, or scopes that have names.
Definition | Base class for Definitions. Definitions may be variables, or scopes that have names.
DefinitionCollection | A strongly-typed collection of IDefinition objects.
ExpressionRoot |
ExpressionRootCollection | A strongly-typed collection of ExpressionRoot objects.
MemberScope |
NamespaceScope |
OverloadableDefinition | Base class for Definitions. Definitions may be variables, or scopes that have names.
Scope |
ScopeCollection | A strongly-typed collection of Scope objects.
Symbol |
TypeScope |
TypeScopeCollection | A strongly-typed collection of TypeScope objects.

Interfaces

Interface | Description
DefinitionCollection.IDefinitionCollectionEnumerator | Supports type-safe iteration over a DefinitionCollection.
ExpressionRootCollection.IExpressionRootCollectionEnumerator | Supports type-safe iteration over a ExpressionRootCollection.
IDefinition | Interface for Defintions. Definitions may be variable declarations, or scope declarations that have names (like types or methods, but not blocks or accessors). Note: With members that can declare multiple types at once, like fields or events, the declarator is the IDefinition.
INamedScope | Interface used to differentiate between named scopes (ns, types, members) and unnamed (asm, block).
ISymbol |
ScopeCollection.IScopeCollectionEnumerator | Supports type-safe iteration over a ScopeCollection.
TypeScopeCollection.ITypeScopeCollectionEnumerator | Supports type-safe iteration over a TypeScopeCollection.

Enumerations

Enumeration | Description
DefinitionCollection.Tag |
ExpressionRootCollection.Tag |
LiteralType | An enumeration of the built in types, from 'lowest' to 'highest'.
ScopeCollection.Tag |
TypeScopeCollection.Tag |


AssemblyScope Class

For a list of all members of this type, see AssemblyScope Members.

System.Object
DDW.CSharp.SymbolTable.Scope
DDW.CSharp.SymbolTable.AssemblyScope

public class AssemblyScope : Scope

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.SymbolTable

Assembly: CSharp (in CSharp.dll)

See Also

AssemblyScope Members | DDW.CSharp.SymbolTable Namespace


AssemblyScope Members

AssemblyScope overview

Public Instance Constructors

AssemblyScope Constructor Initializes a new instance of the AssemblyScope class.

Public Instance Properties

ChildScopes (inherited from Scope) |
DefinitionTable (inherited from Scope) | Gets the hashtable that stored the declared symbol definitions.
EnclosingScope (inherited from Scope) | Gets or sets the enclosing scope of the scope.
Version |

Public Instance Methods

Add (inherited from Scope) |
AddRange (inherited from Scope) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Insert (inherited from Scope) |
Lookup (inherited from Scope) |
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate (inherited from Scope) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AssemblyScope Class | DDW.CSharp.SymbolTable Namespace


AssemblyScope Constructor

Initializes a new instance of the AssemblyScope class.

public AssemblyScope();

See Also

AssemblyScope Class | DDW.CSharp.SymbolTable Namespace


AssemblyScope Properties

The properties of the AssemblyScope class are listed below. For a complete list of AssemblyScope class members, see the AssemblyScope Members topic.

Public Instance Properties

ChildScopes (inherited from Scope) |
DefinitionTable (inherited from Scope) | Gets the hashtable that stored the declared symbol definitions.
EnclosingScope (inherited from Scope) | Gets or sets the enclosing scope of the scope.
Version |

See Also

AssemblyScope Class | DDW.CSharp.SymbolTable Namespace


Version Property

Goblin - A Platform for 3D AR and VR Applications

AssemblyScope.Version Property

public string Version {get; set;}

See Also

AssemblyScope Class | DDW.CSharp.SymbolTable Namespace


BlockScope Class

For a list of all members of this type, see BlockScope Members.

System.Object
DDW.CSharp.SymbolTable.Scope
DDW.CSharp.SymbolTable.BlockScope

public class BlockScope : Scope

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.SymbolTable

Assembly: CSharp (in CSharp.dll)

See Also

BlockScope Members | DDW.CSharp.SymbolTable Namespace


BlockScope Members

BlockScope overview

Public Instance Constructors

BlockScope Constructor Initializes a new instance of the BlockScope class.

Public Instance Properties

ChildScopes (inherited from Scope) |
DefinitionTable (inherited from Scope) | Gets the hashtable that stored the declared symbol definitions.
EnclosingScope (inherited from Scope) | Gets or sets the enclosing scope of the scope.

Public Instance Methods

Add (inherited from Scope) |
AddRange (inherited from Scope) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Insert (inherited from Scope) |
Lookup (inherited from Scope) |
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate (inherited from Scope) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BlockScope Class | DDW.CSharp.SymbolTable Namespace


BlockScope Constructor

Initializes a new instance of the BlockScope class.

public BlockScope();

See Also

BlockScope Class | DDW.CSharp.SymbolTable Namespace


BuiltInDefinition Class

Base class for Definitions. Definitions may be variables, or scopes that have names.

For a list of all members of this type, see BuiltInDefinition Members.

System.Object
DDW.CSharp.SymbolTable.Definition
DDW.CSharp.SymbolTable.BuiltInDefinition

public class BuiltInDefinition : Definition

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.SymbolTable

Assembly: CSharp (in CSharp.dll)

See Also

BuiltInDefinition Members | DDW.CSharp.SymbolTable Namespace


BuiltInDefinition Members

BuiltInDefinition overview

Public Instance Constructors

BuiltInDefinition Constructor Initializes a new instance of the BuiltInDefinition class.

Public Instance Fields

SbyteDecl

Public Instance Properties

FullName (inherited from Definition) | Gets the full name of the scope (namespace.class.member...).
Id (inherited from Definition) |
LiteralType | Gets or sets the literal type of this built in type.
Name | Gets or sets the name of the built in type.
Scope (inherited from Definition) | Gets or sets the scope of the definition.
SourceGraph (inherited from Definition) | Link to the defining element.
Type (inherited from Definition) | Link to the defining type. Actual types just return a ref to themselves.

Public Instance Methods

ConvertDistance |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Definition) | Gets the hash of this defintion. The hash is made from the full path.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Definition) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BuiltInDefinition Class | DDW.CSharp.SymbolTable Namespace


BuiltInDefinition Constructor

Initializes a new instance of the BuiltInDefinition class.

public BuiltInDefinition();

See Also

BuiltInDefinition Class | DDW.CSharp.SymbolTable Namespace


BuiltInDefinition Fields

The fields of the BuiltInDefinition class are listed below. For a complete list of BuiltInDefinition class members, see the BuiltInDefinition Members topic.

Public Instance Fields

SbyteDecl

See Also

BuiltInDefinition Class | DDW.CSharp.SymbolTable Namespace


BuiltInDefinition.SbyteDecl Field

public StructDecl SbyteDecl;

See Also

BuiltInDefinition Class | DDW.CSharp.SymbolTable Namespace


BuiltInDefinition Properties

The properties of the BuiltInDefinition class are listed below. For a complete list of BuiltInDefinition class members, see the BuiltInDefinition Members topic.

Public Instance Properties

FullName (inherited from Definition) | Gets the full name of the scope (namespace.class.member...).
Id (inherited from Definition) |
LiteralType | Gets or sets the literal type of this built in type.
Name | Gets or sets the name of the built in type.
Scope (inherited from Definition) | Gets or sets the scope of the definition.
SourceGraph (inherited from Definition) | Link to the defining element.
Type (inherited from Definition) | Link to the defining type. Actual types just return a ref to themselves.

See Also

BuiltInDefinition Class | DDW.CSharp.SymbolTable Namespace


LiteralType Property

Goblin - A Platform for 3D AR and VR Applications

BuiltInDefinition.LiteralType Property

Gets or sets the literal type of this built in type.

public LiteralType LiteralType {get; set;}

See Also

BuiltInDefinition Class | DDW.CSharp.SymbolTable Namespace


Name Property

Goblin - A Platform for 3D AR and VR Applications

BuiltInDefinition.Name Property

Gets or sets the name of the built in type.

public override string Name {get; set;}

Implements

IDefinition.Name

See Also

BuiltInDefinition Class | DDW.CSharp.SymbolTable Namespace


BuiltInDefinition Methods

The methods of the BuiltInDefinition class are listed below. For a complete list of BuiltInDefinition class members, see the BuiltInDefinition Members topic.

Public Instance Methods

ConvertDistance |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Definition) | Gets the hash of this defintion. The hash is made from the full path.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Definition) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BuiltInDefinition Class | DDW.CSharp.SymbolTable Namespace


BuiltInDefinition.ConvertDistance Method

public int ConvertDistance(
LiteralType destinationType
);

See Also

BuiltInDefinition Class | DDW.CSharp.SymbolTable Namespace


Definition Class

Base class for Definitions. Definitions may be variables, or scopes that have names.

For a list of all members of this type, see Definition Members.

System.Object
DDW.CSharp.SymbolTable.Definition
DDW.CSharp.SymbolTable.BuiltInDefinition
DDW.CSharp.SymbolTable.OverloadableDefinition
DDW.CSharp.SymbolTable.Symbol

public class Definition : IDefinition

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.SymbolTable

Assembly: CSharp (in CSharp.dll)

See Also

Definition Members | DDW.CSharp.SymbolTable Namespace


Definition Members

Definition overview

Public Instance Constructors

Definition Constructor Initializes a new instance of the Definition class.

Public Instance Properties

FullName | Gets the full name of the scope (namespace.class.member...).
Id |
Name | Gets or sets the given name of the Definition.
Scope | Gets or sets the scope of the definition.
SourceGraph | Link to the defining element.
Type | Link to the defining type. Actual types just return a ref to themselves.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode | Gets the hash of this defintion. The hash is made from the full path.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Definition Class | DDW.CSharp.SymbolTable Namespace


Definition Constructor

Initializes a new instance of the Definition class.

public Definition();

See Also

Definition Class | DDW.CSharp.SymbolTable Namespace


Definition Properties

The properties of the Definition class are listed below. For a complete list of Definition class members, see the Definition Members topic.

Public Instance Properties

FullName | Gets the full name of the scope (namespace.class.member...).
Id |
Name | Gets or sets the given name of the Definition.
Scope | Gets or sets the scope of the definition.
SourceGraph | Link to the defining element.
Type | Link to the defining type. Actual types just return a ref to themselves.

See Also

Definition Class | DDW.CSharp.SymbolTable Namespace


FullName Property

Goblin - A Platform for 3D AR and VR Applications

Definition.FullName Property

Gets the full name of the scope (namespace.class.member...).

public string FullName {get;}

Implements

IDefinition.FullName

See Also

Definition Class | DDW.CSharp.SymbolTable Namespace


Id Property

Goblin - A Platform for 3D AR and VR Applications

Definition.Id Property

public int Id {get; set;}

Implements

IDefinition.Id

See Also

Definition Class | DDW.CSharp.SymbolTable Namespace


Name Property

Goblin - A Platform for 3D AR and VR Applications

Definition.Name Property

Gets or sets the given name of the Definition.

public virtual string Name {get; set;}

Implements

IDefinition.Name

See Also

Definition Class | DDW.CSharp.SymbolTable Namespace


Scope Property

Goblin - A Platform for 3D AR and VR Applications

Definition.Scope Property

Gets or sets the scope of the definition.

public Scope Scope {get; set;}

Implements

IDefinition.Scope

See Also

Definition Class | DDW.CSharp.SymbolTable Namespace


SourceGraph Property

Goblin - A Platform for 3D AR and VR Applications

Definition.SourceGraph Property

Link to the defining element.

public DDW.CSharp.Dom.IDeclaration SourceGraph {get; set;}

Implements

IDefinition.SourceGraph

See Also

Definition Class | DDW.CSharp.SymbolTable Namespace


Type Property

Goblin - A Platform for 3D AR and VR Applications

Definition.Type Property

Link to the defining type. Actual types just return a ref to themselves.

public DDW.CSharp.Dom.IDeclaration Type {get; set;}

Implements

IDefinition.Type

See Also

Definition Class | DDW.CSharp.SymbolTable Namespace


Definition Methods

The methods of the Definition class are listed below. For a complete list of Definition class members, see the Definition Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode | Gets the hash of this defintion. The hash is made from the full path.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Definition Class | DDW.CSharp.SymbolTable Namespace


Definition.GetHashCode Method

Gets the hash of this defintion. The hash is made from the full path.

public override int GetHashCode();

See Also

Definition Class | DDW.CSharp.SymbolTable Namespace


Definition.ToString Method

public override string ToString();

See Also

Definition Class | DDW.CSharp.SymbolTable Namespace


DefinitionCollection Class

A strongly-typed collection of IDefinition objects.

For a list of all members of this type, see DefinitionCollection Members.

System.Object
DDW.CSharp.SymbolTable.DefinitionCollection

public class DefinitionCollection : IList, ICollection, IEnumerable, ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.SymbolTable

Assembly: CSharp (in CSharp.dll)

See Also

DefinitionCollection Members | DDW.CSharp.SymbolTable Namespace


DefinitionCollection Members

DefinitionCollection overview

Public Static Methods

ReadOnly | Creates a read-only wrapper for a DefinitionCollection instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a DefinitionCollection instance.

Public Instance Constructors

DefinitionCollection Overloaded. Initializes a new instance of the DefinitionCollection class.

Public Instance Properties

Capacity | Gets or sets the number of elements the DefinitionCollection can contain.
Count | Gets the number of elements actually contained in the DefinitionCollection.
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the IDefinition at the specified index.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds a IDefinition to the end of the DefinitionCollection.
AddRange | Overloaded. Adds the elements of a IDefinition array to the current DefinitionCollection.
Clear | Removes all elements from the DefinitionCollection.
Clone | Creates a shallow copy of the DefinitionCollection.
Contains | Determines whether a given IDefinition is in the DefinitionCollection.
CopyTo | Overloaded. Copies the entire DefinitionCollection to a one-dimensional IDefinition array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the DefinitionCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the zero-based index of the first occurrence of a IDefinition in the DefinitionCollection.
Insert | Inserts an element into the DefinitionCollection at the specified index.
Remove | Removes the first occurrence of a specific IDefinition from the DefinitionCollection.
RemoveAt | Removes the element at the specified index of the DefinitionCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Constructors

DefinitionCollection Overloaded. Initializes a new instance of the DefinitionCollection class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DefinitionCollection Class | DDW.CSharp.SymbolTable Namespace


DefinitionCollection Constructor

Initializes a new instance of the DefinitionCollection class that is empty and has the default initial capacity.

Overload List

Initializes a new instance of the DefinitionCollection class that is empty and has the default initial capacity.

public DefinitionCollection();

Initializes a new instance of the DefinitionCollection class that contains elements copied from the specified DefinitionCollection.

public DefinitionCollection(DefinitionCollection);

protected DefinitionCollection(Tag);

Initializes a new instance of the DefinitionCollection class that contains elements copied from the specified IDefinition array.

public DefinitionCollection(IDefinition[]);

Initializes a new instance of the DefinitionCollection class that has the specified initial capacity.

public DefinitionCollection(int);

See Also

DefinitionCollection Class | DDW.CSharp.SymbolTable Namespace


DefinitionCollection Constructor ()

Initializes a new instance of the DefinitionCollection class that is empty and has the default initial capacity.

public DefinitionCollection();

See Also

DefinitionCollection Class | DDW.CSharp.SymbolTable Namespace | DefinitionCollection Constructor Overload List


DefinitionCollection Constructor (Int32)

Initializes a new instance of the DefinitionCollection class that has the specified initial capacity.

public DefinitionCollection(
int capacity
);

Parameters

capacity
The number of elements that the new DefinitionCollection is initially capable of storing.

See Also

DefinitionCollection Class | DDW.CSharp.SymbolTable Namespace | DefinitionCollection Constructor Overload List


DefinitionCollection Constructor (DefinitionCollection)

Initializes a new instance of the DefinitionCollection class that contains elements copied from the specified DefinitionCollection.

public DefinitionCollection(
DefinitionCollection c
);

Parameters

c
The DefinitionCollection whose elements are copied to the new collection.

See Also

DefinitionCollection Class | DDW.CSharp.SymbolTable Namespace | DefinitionCollection Constructor Overload List


DefinitionCollection Constructor (IDefinition[])

Initializes a new instance of the DefinitionCollection class that contains elements copied from the specified IDefinition array.

public DefinitionCollection(
IDefinition[] a
);

Parameters

a
The IDefinition array whose elements are copied to the new list.

See Also

DefinitionCollection Class | DDW.CSharp.SymbolTable Namespace | DefinitionCollection Constructor Overload List


DefinitionCollection Constructor (Tag)

protected DefinitionCollection(
Tag t
);

See Also

DefinitionCollection Class | DDW.CSharp.SymbolTable Namespace | DefinitionCollection Constructor Overload List


DefinitionCollection Properties

The properties of the DefinitionCollection class are listed below. For a complete list of DefinitionCollection class members, see the DefinitionCollection Members topic.

Public Instance Properties

Capacity | Gets or sets the number of elements the DefinitionCollection can contain.
Count | Gets the number of elements actually contained in the DefinitionCollection.
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the IDefinition at the specified index.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

DefinitionCollection Class | DDW.CSharp.SymbolTable Namespace


Capacity Property

Goblin - A Platform for 3D AR and VR Applications

DefinitionCollection.Capacity Property

Gets or sets the number of elements the DefinitionCollection can contain.

public virtual int Capacity {get; set;}

See Also

DefinitionCollection Class | DDW.CSharp.SymbolTable Namespace


Count Property

Goblin - A Platform for 3D AR and VR Applications

DefinitionCollection.Count Property

Gets the number of elements actually contained in the DefinitionCollection.

public virtual int Count {get;}

Implements

ICollection.Count

See Also

DefinitionCollection Class | DDW.CSharp.SymbolTable Namespace


IsFixedSize Property

Goblin - A Platform for 3D AR and VR Applications

DefinitionCollection.IsFixedSize Property

Gets a value indicating whether the collection has a fixed size.

public virtual bool IsFixedSize {get;}

Property Value

true if the collection has a fixed size; otherwise, false. The default is false

Implements

IList.IsFixedSize

See Also

DefinitionCollection Class | DDW.CSharp.SymbolTable Namespace


IsReadOnly Property

Goblin - A Platform for 3D AR and VR Applications

DefinitionCollection.IsReadOnly Property

gets a value indicating whether the IList is read-only.

public virtual bool IsReadOnly {get;}

Property Value

true if the collection is read-only; otherwise, false. The default is false

Implements

IList.IsReadOnly

See Also

DefinitionCollection Class | DDW.CSharp.SymbolTable Namespace


IsSynchronized Property

Goblin - A Platform for 3D AR and VR Applications

DefinitionCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread-safe).

public virtual bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

DefinitionCollection Class | DDW.CSharp.SymbolTable Namespace


Item Property

Goblin - A Platform for 3D AR and VR Applications

DefinitionCollection.Item Property

Gets or sets the IDefinition at the specified index.

public virtual IDefinition this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

DefinitionCollection Class | DDW.CSharp.SymbolTable Namespace


SyncRoot Property

Goblin - A Platform for 3D AR and VR Applications

DefinitionCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

public virtual object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

DefinitionCollection Class | DDW.CSharp.SymbolTable Namespace


DefinitionCollection Methods

The methods of the DefinitionCollection class are listed below. For a complete list of DefinitionCollection class members, see the DefinitionCollection Members topic.

Public Static Methods

ReadOnly | Creates a read-only wrapper for a DefinitionCollection instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a DefinitionCollection instance.

Public Instance Methods

Add | Adds a IDefinition to the end of the DefinitionCollection.
AddRange | Overloaded. Adds the elements of a IDefinition array to the current DefinitionCollection.
Clear | Removes all elements from the DefinitionCollection.
Clone | Creates a shallow copy of the DefinitionCollection.
Contains | Determines whether a given IDefinition is in the DefinitionCollection.
CopyTo | Overloaded. Copies the entire DefinitionCollection to a one-dimensional IDefinition array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the DefinitionCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the zero-based index of the first occurrence of a IDefinition in the DefinitionCollection.
Insert | Inserts an element into the DefinitionCollection at the specified index.
Remove | Removes the first occurrence of a specific IDefinition from the DefinitionCollection.
RemoveAt | Removes the element at the specified index of the DefinitionCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DefinitionCollection Class | DDW.CSharp.SymbolTable Namespace


DefinitionCollection.Add Method

Adds a IDefinition to the end of the DefinitionCollection.

public virtual int Add(
IDefinition item
);

Parameters

item
The IDefinition to be added to the end of the DefinitionCollection.

Return Value

The index at which the value has been added.

See Also

DefinitionCollection Class | DDW.CSharp.SymbolTable Namespace


AddRange Method

Goblin - A Platform for 3D AR and VR Applications

DefinitionCollection.AddRange Method

Adds the elements of another DefinitionCollection to the current DefinitionCollection.

Overload List

Adds the elements of another DefinitionCollection to the current DefinitionCollection.

public virtual int AddRange(DefinitionCollection);

Adds the elements of a IDefinition array to the current DefinitionCollection.

public virtual int AddRange(IDefinition[]);

See Also

DefinitionCollection Class | DDW.CSharp.SymbolTable Namespace


DefinitionCollection.AddRange Method (DefinitionCollection)

Adds the elements of another DefinitionCollection to the current DefinitionCollection.

public virtual int AddRange(
DefinitionCollection x
);

Parameters

x
The DefinitionCollection whose elements should be added to the end of the current DefinitionCollection.

Return Value

The new Count of the DefinitionCollection.

See Also

DefinitionCollection Class | DDW.CSharp.SymbolTable Namespace | DefinitionCollection.AddRange Overload List


DefinitionCollection.AddRange Method (IDefinition[])

Adds the elements of a IDefinition array to the current DefinitionCollection.

public virtual int AddRange(
IDefinition[] x
);

Parameters

x
The IDefinition array whose elements should be added to the end of the DefinitionCollection.

Return Value

The new Count of the DefinitionCollection.

See Also

DefinitionCollection Class | DDW.CSharp.SymbolTable Namespace | DefinitionCollection.AddRange Overload List


DefinitionCollection.Clear Method

Removes all elements from the DefinitionCollection.

public virtual void Clear();

Implements

IList.Clear

See Also

DefinitionCollection Class | DDW.CSharp.SymbolTable Namespace


DefinitionCollection.Clone Method

Creates a shallow copy of the DefinitionCollection.

public virtual object Clone();

Implements

ICloneable.Clone

See Also

DefinitionCollection Class | DDW.CSharp.SymbolTable Namespace


DefinitionCollection.Contains Method

Determines whether a given IDefinition is in the DefinitionCollection.

public virtual bool Contains(
IDefinition item
);

Parameters

item
The IDefinition to check for.

Return Value

true if item is found in the DefinitionCollection; otherwise, false.

See Also

DefinitionCollection Class | DDW.CSharp.SymbolTable Namespace


CopyTo Method

Goblin - A Platform for 3D AR and VR Applications

DefinitionCollection.CopyTo Method

Copies the entire DefinitionCollection to a one-dimensional IDefinition array.

Overload List

Copies the entire DefinitionCollection to a one-dimensional IDefinition array.

public virtual void CopyTo(IDefinition[]);

Copies the entire DefinitionCollection to a one-dimensional IDefinition array, starting at the specified index of the target array.

public virtual void CopyTo(IDefinition[],int);

See Also

DefinitionCollection Class | DDW.CSharp.SymbolTable Namespace


DefinitionCollection.CopyTo Method (IDefinition[])

Copies the entire DefinitionCollection to a one-dimensional IDefinition array.

public virtual void CopyTo(
IDefinition[] array
);

Parameters

array
The one-dimensional IDefinition array to copy to.

See Also

DefinitionCollection Class | DDW.CSharp.SymbolTable Namespace | DefinitionCollection.CopyTo Overload List


DefinitionCollection.CopyTo Method (IDefinition[], Int32)

Copies the entire DefinitionCollection to a one-dimensional IDefinition array, starting at the specified index of the target array.

public virtual void CopyTo(
IDefinition[] array,
int start
);

Parameters

array
The one-dimensional IDefinition array to copy to.
start
The zero-based index in array at which copying begins.

See Also

DefinitionCollection Class | DDW.CSharp.SymbolTable Namespace | DefinitionCollection.CopyTo Overload List


DefinitionCollection.GetEnumerator Method

Returns an enumerator that can iterate through the DefinitionCollection.

public virtual IDefinitionCollectionEnumerator GetEnumerator();

Return Value

An Enumerator for the entire DefinitionCollection.

See Also

DefinitionCollection Class | DDW.CSharp.SymbolTable Namespace


DefinitionCollection.IndexOf Method

Returns the zero-based index of the first occurrence of a IDefinition in the DefinitionCollection.

public virtual int IndexOf(
IDefinition item
);

Parameters

item
The IDefinition to locate in the DefinitionCollection.

Return Value

The zero-based index of the first occurrence of item in the entire DefinitionCollection, if found; otherwise, -1.

See Also

DefinitionCollection Class | DDW.CSharp.SymbolTable Namespace


DefinitionCollection.Insert Method

Inserts an element into the DefinitionCollection at the specified index.

public virtual void Insert(
int index,
IDefinition item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The IDefinition to insert.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

DefinitionCollection Class | DDW.CSharp.SymbolTable Namespace


DefinitionCollection.ReadOnly Method

Creates a read-only wrapper for a DefinitionCollection instance.

public static DefinitionCollection ReadOnly(
DefinitionCollection list
);

Return Value

An DefinitionCollection wrapper that is read-only.

See Also

DefinitionCollection Class | DDW.CSharp.SymbolTable Namespace


DefinitionCollection.Remove Method

Removes the first occurrence of a specific IDefinition from the DefinitionCollection.

public virtual void Remove(
IDefinition item
);

Parameters

item
The IDefinition to remove from the DefinitionCollection.

Exceptions

Exception Type | Condition
ArgumentException | The specified IDefinition was not found in the DefinitionCollection.

See Also

DefinitionCollection Class | DDW.CSharp.SymbolTable Namespace


DefinitionCollection.RemoveAt Method

Removes the element at the specified index of the DefinitionCollection.

public virtual void RemoveAt(
int index
);

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

DefinitionCollection Class | DDW.CSharp.SymbolTable Namespace


DefinitionCollection.Synchronized Method

Creates a synchronized (thread-safe) wrapper for a DefinitionCollection instance.

public static DefinitionCollection Synchronized(
DefinitionCollection list
);

Return Value

An DefinitionCollection wrapper that is synchronized (thread-safe).

See Also

DefinitionCollection Class | DDW.CSharp.SymbolTable Namespace


DefinitionCollection.TrimToSize Method

Sets the capacity to the actual number of elements.

public virtual void TrimToSize();

See Also

DefinitionCollection Class | DDW.CSharp.SymbolTable Namespace


DefinitionCollection.IDefinitionCollectionEnumerator Interface

Supports type-safe iteration over a DefinitionCollection.

For a list of all members of this type, see DefinitionCollection.IDefinitionCollectionEnumerator Members.

public interface DefinitionCollection.IDefinitionCollectionEnumerator

Requirements

Namespace: DDW.CSharp.SymbolTable

Assembly: CSharp (in CSharp.dll)

See Also

DefinitionCollection.IDefinitionCollectionEnumerator Members | DDW.CSharp.SymbolTable Namespace


DefinitionCollection.IDefinitionCollectionEnumerator Members

DefinitionCollection.IDefinitionCollectionEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

DefinitionCollection.IDefinitionCollectionEnumerator Interface | DDW.CSharp.SymbolTable Namespace


DefinitionCollection.IDefinitionCollectionEnumerator Properties

The properties of the DefinitionCollection.IDefinitionCollectionEnumerator interface are listed below. For a complete list of DefinitionCollection.IDefinitionCollectionEnumerator interface members, see the DefinitionCollection.IDefinitionCollectionEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

DefinitionCollection.IDefinitionCollectionEnumerator Interface | DDW.CSharp.SymbolTable Namespace


Current Property

Goblin - A Platform for 3D AR and VR Applications

DefinitionCollection.IDefinitionCollectionEnumerator.Current Property

Gets the current element in the collection.

IDefinition Current {get;}

See Also

DefinitionCollection.IDefinitionCollectionEnumerator Interface | DDW.CSharp.SymbolTable Namespace


DefinitionCollection.IDefinitionCollectionEnumerator Methods

The methods of the DefinitionCollection.IDefinitionCollectionEnumerator interface are listed below. For a complete list of DefinitionCollection.IDefinitionCollectionEnumerator interface members, see the DefinitionCollection.IDefinitionCollectionEnumerator Members topic.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

DefinitionCollection.IDefinitionCollectionEnumerator Interface | DDW.CSharp.SymbolTable Namespace


DefinitionCollection.IDefinitionCollectionEnumerator.MoveNext Method

Advances the enumerator to the next element in the collection.

bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Exceptions

Exception Type | Condition
InvalidOperationException | The collection was modified after the enumerator was created.

See Also

DefinitionCollection.IDefinitionCollectionEnumerator Interface | DDW.CSharp.SymbolTable Namespace


DefinitionCollection.IDefinitionCollectionEnumerator.Reset Method

Sets the enumerator to its initial position, before the first element in the collection.

void Reset();

See Also

DefinitionCollection.IDefinitionCollectionEnumerator Interface | DDW.CSharp.SymbolTable Namespace


DefinitionCollection.Tag Enumeration

protected enum DefinitionCollection.Tag

Members

Member Name | Description
Default |

Requirements

Namespace: DDW.CSharp.SymbolTable

Assembly: CSharp (in CSharp.dll)

See Also

DDW.CSharp.SymbolTable Namespace


ExpressionRoot Class

For a list of all members of this type, see ExpressionRoot Members.

System.Object
DDW.CSharp.SymbolTable.ExpressionRoot

public class ExpressionRoot

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.SymbolTable

Assembly: CSharp (in CSharp.dll)

See Also

ExpressionRoot Members | DDW.CSharp.SymbolTable Namespace


ExpressionRoot Members

ExpressionRoot overview

Public Instance Constructors

ExpressionRoot Constructor Initializes a new instance of the ExpressionRoot class.

Public Instance Fields

Expression
Instance
PropertyName

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ReplaceExpression |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExpressionRoot Class | DDW.CSharp.SymbolTable Namespace


ExpressionRoot Constructor

Initializes a new instance of the ExpressionRoot class.

public ExpressionRoot();

See Also

ExpressionRoot Class | DDW.CSharp.SymbolTable Namespace


ExpressionRoot Fields

The fields of the ExpressionRoot class are listed below. For a complete list of ExpressionRoot class members, see the ExpressionRoot Members topic.

Public Instance Fields

Expression
Instance
PropertyName

See Also

ExpressionRoot Class | DDW.CSharp.SymbolTable Namespace


ExpressionRoot.Expression Field

public Expression Expression;

See Also

ExpressionRoot Class | DDW.CSharp.SymbolTable Namespace


ExpressionRoot.Instance Field

public Type Instance;

See Also

ExpressionRoot Class | DDW.CSharp.SymbolTable Namespace


ExpressionRoot.PropertyName Field

public string PropertyName;

See Also

ExpressionRoot Class | DDW.CSharp.SymbolTable Namespace


ExpressionRoot Methods

The methods of the ExpressionRoot class are listed below. For a complete list of ExpressionRoot class members, see the ExpressionRoot Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ReplaceExpression |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExpressionRoot Class | DDW.CSharp.SymbolTable Namespace


ExpressionRoot.ReplaceExpression Method

public void ReplaceExpression(
Expression ex
);

See Also

ExpressionRoot Class | DDW.CSharp.SymbolTable Namespace


ExpressionRootCollection Class

A strongly-typed collection of ExpressionRoot objects.

For a list of all members of this type, see ExpressionRootCollection Members.

System.Object
DDW.CSharp.SymbolTable.ExpressionRootCollection

public class ExpressionRootCollection : IList, ICollection, IEnumerable, ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.SymbolTable

Assembly: CSharp (in CSharp.dll)

See Also

ExpressionRootCollection Members | DDW.CSharp.SymbolTable Namespace


ExpressionRootCollection Members

ExpressionRootCollection overview

Public Static Methods

ReadOnly | Creates a read-only wrapper for a ExpressionRootCollection instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a ExpressionRootCollection instance.

Public Instance Constructors

ExpressionRootCollection Overloaded. Initializes a new instance of the ExpressionRootCollection class.

Public Instance Properties

Capacity | Gets or sets the number of elements the ExpressionRootCollection can contain.
Count | Gets the number of elements actually contained in the ExpressionRootCollection.
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the ExpressionRoot at the specified index.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds a ExpressionRoot to the end of the ExpressionRootCollection.
AddRange | Overloaded. Adds the elements of a ExpressionRoot array to the current ExpressionRootCollection.
Clear | Removes all elements from the ExpressionRootCollection.
Clone | Creates a shallow copy of the ExpressionRootCollection.
Contains | Determines whether a given ExpressionRoot is in the ExpressionRootCollection.
CopyTo | Overloaded. Copies the entire ExpressionRootCollection to a one-dimensional ExpressionRoot array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the ExpressionRootCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the zero-based index of the first occurrence of a ExpressionRoot in the ExpressionRootCollection.
Insert | Inserts an element into the ExpressionRootCollection at the specified index.
Remove | Removes the first occurrence of a specific ExpressionRoot from the ExpressionRootCollection.
RemoveAt | Removes the element at the specified index of the ExpressionRootCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Constructors

ExpressionRootCollection Overloaded. Initializes a new instance of the ExpressionRootCollection class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExpressionRootCollection Class | DDW.CSharp.SymbolTable Namespace


ExpressionRootCollection Constructor

Initializes a new instance of the ExpressionRootCollection class that is empty and has the default initial capacity.

Overload List

Initializes a new instance of the ExpressionRootCollection class that is empty and has the default initial capacity.

public ExpressionRootCollection();

Initializes a new instance of the ExpressionRootCollection class that contains elements copied from the specified ExpressionRoot array.

public ExpressionRootCollection(ExpressionRoot[]);

Initializes a new instance of the ExpressionRootCollection class that contains elements copied from the specified ExpressionRootCollection.

public ExpressionRootCollection(ExpressionRootCollection);

protected ExpressionRootCollection(Tag);

Initializes a new instance of the ExpressionRootCollection class that has the specified initial capacity.

public ExpressionRootCollection(int);

See Also

ExpressionRootCollection Class | DDW.CSharp.SymbolTable Namespace


ExpressionRootCollection Constructor ()

Initializes a new instance of the ExpressionRootCollection class that is empty and has the default initial capacity.

public ExpressionRootCollection();

See Also

ExpressionRootCollection Class | DDW.CSharp.SymbolTable Namespace | ExpressionRootCollection Constructor Overload List


ExpressionRootCollection Constructor (Int32)

Initializes a new instance of the ExpressionRootCollection class that has the specified initial capacity.

public ExpressionRootCollection(
int capacity
);

Parameters

capacity
The number of elements that the new ExpressionRootCollection is initially capable of storing.

See Also

ExpressionRootCollection Class | DDW.CSharp.SymbolTable Namespace | ExpressionRootCollection Constructor Overload List


ExpressionRootCollection Constructor (ExpressionRootCollection)

Initializes a new instance of the ExpressionRootCollection class that contains elements copied from the specified ExpressionRootCollection.

public ExpressionRootCollection(
ExpressionRootCollection c
);

Parameters

c
The ExpressionRootCollection whose elements are copied to the new collection.

See Also

ExpressionRootCollection Class | DDW.CSharp.SymbolTable Namespace | ExpressionRootCollection Constructor Overload List


ExpressionRootCollection Constructor (ExpressionRoot[])

Initializes a new instance of the ExpressionRootCollection class that contains elements copied from the specified ExpressionRoot array.

public ExpressionRootCollection(
ExpressionRoot[] a
);

Parameters

a
The ExpressionRoot array whose elements are copied to the new list.

See Also

ExpressionRootCollection Class | DDW.CSharp.SymbolTable Namespace | ExpressionRootCollection Constructor Overload List


ExpressionRootCollection Constructor (Tag)

protected ExpressionRootCollection(
Tag t
);

See Also

ExpressionRootCollection Class | DDW.CSharp.SymbolTable Namespace | ExpressionRootCollection Constructor Overload List


ExpressionRootCollection Properties

The properties of the ExpressionRootCollection class are listed below. For a complete list of ExpressionRootCollection class members, see the ExpressionRootCollection Members topic.

Public Instance Properties

Capacity | Gets or sets the number of elements the ExpressionRootCollection can contain.
Count | Gets the number of elements actually contained in the ExpressionRootCollection.
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the ExpressionRoot at the specified index.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

ExpressionRootCollection Class | DDW.CSharp.SymbolTable Namespace


Capacity Property

Goblin - A Platform for 3D AR and VR Applications

ExpressionRootCollection.Capacity Property

Gets or sets the number of elements the ExpressionRootCollection can contain.

public virtual int Capacity {get; set;}

See Also

ExpressionRootCollection Class | DDW.CSharp.SymbolTable Namespace


Count Property

Goblin - A Platform for 3D AR and VR Applications

ExpressionRootCollection.Count Property

Gets the number of elements actually contained in the ExpressionRootCollection.

public virtual int Count {get;}

Implements

ICollection.Count

See Also

ExpressionRootCollection Class | DDW.CSharp.SymbolTable Namespace


IsFixedSize Property

Goblin - A Platform for 3D AR and VR Applications

ExpressionRootCollection.IsFixedSize Property

Gets a value indicating whether the collection has a fixed size.

public virtual bool IsFixedSize {get;}

Property Value

true if the collection has a fixed size; otherwise, false. The default is false

Implements

IList.IsFixedSize

See Also

ExpressionRootCollection Class | DDW.CSharp.SymbolTable Namespace


IsReadOnly Property

Goblin - A Platform for 3D AR and VR Applications

ExpressionRootCollection.IsReadOnly Property

gets a value indicating whether the IList is read-only.

public virtual bool IsReadOnly {get;}

Property Value

true if the collection is read-only; otherwise, false. The default is false

Implements

IList.IsReadOnly

See Also

ExpressionRootCollection Class | DDW.CSharp.SymbolTable Namespace


IsSynchronized Property

Goblin - A Platform for 3D AR and VR Applications

ExpressionRootCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread-safe).

public virtual bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

ExpressionRootCollection Class | DDW.CSharp.SymbolTable Namespace


Item Property

Goblin - A Platform for 3D AR and VR Applications

ExpressionRootCollection.Item Property

Gets or sets the ExpressionRoot at the specified index.

public virtual ExpressionRoot this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

ExpressionRootCollection Class | DDW.CSharp.SymbolTable Namespace


SyncRoot Property

Goblin - A Platform for 3D AR and VR Applications

ExpressionRootCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

public virtual object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

ExpressionRootCollection Class | DDW.CSharp.SymbolTable Namespace


ExpressionRootCollection Methods

The methods of the ExpressionRootCollection class are listed below. For a complete list of ExpressionRootCollection class members, see the ExpressionRootCollection Members topic.

Public Static Methods

ReadOnly | Creates a read-only wrapper for a ExpressionRootCollection instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a ExpressionRootCollection instance.

Public Instance Methods

Add | Adds a ExpressionRoot to the end of the ExpressionRootCollection.
AddRange | Overloaded. Adds the elements of a ExpressionRoot array to the current ExpressionRootCollection.
Clear | Removes all elements from the ExpressionRootCollection.
Clone | Creates a shallow copy of the ExpressionRootCollection.
Contains | Determines whether a given ExpressionRoot is in the ExpressionRootCollection.
CopyTo | Overloaded. Copies the entire ExpressionRootCollection to a one-dimensional ExpressionRoot array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the ExpressionRootCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the zero-based index of the first occurrence of a ExpressionRoot in the ExpressionRootCollection.
Insert | Inserts an element into the ExpressionRootCollection at the specified index.
Remove | Removes the first occurrence of a specific ExpressionRoot from the ExpressionRootCollection.
RemoveAt | Removes the element at the specified index of the ExpressionRootCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExpressionRootCollection Class | DDW.CSharp.SymbolTable Namespace


ExpressionRootCollection.Add Method

Adds a ExpressionRoot to the end of the ExpressionRootCollection.

public virtual int Add(
ExpressionRoot item
);

Parameters

item
The ExpressionRoot to be added to the end of the ExpressionRootCollection.

Return Value

The index at which the value has been added.

See Also

ExpressionRootCollection Class | DDW.CSharp.SymbolTable Namespace


AddRange Method

Goblin - A Platform for 3D AR and VR Applications

ExpressionRootCollection.AddRange Method

Adds the elements of a ExpressionRoot array to the current ExpressionRootCollection.

Overload List

Adds the elements of a ExpressionRoot array to the current ExpressionRootCollection.

public virtual int AddRange(ExpressionRoot[]);

Adds the elements of another ExpressionRootCollection to the current ExpressionRootCollection.

public virtual int AddRange(ExpressionRootCollection);

See Also

ExpressionRootCollection Class | DDW.CSharp.SymbolTable Namespace


ExpressionRootCollection.AddRange Method (ExpressionRoot[])

Adds the elements of a ExpressionRoot array to the current ExpressionRootCollection.

public virtual int AddRange(
ExpressionRoot[] x
);

Parameters

x
The ExpressionRoot array whose elements should be added to the end of the ExpressionRootCollection.

Return Value

The new Count of the ExpressionRootCollection.

See Also

ExpressionRootCollection Class | DDW.CSharp.SymbolTable Namespace | ExpressionRootCollection.AddRange Overload List


ExpressionRootCollection.AddRange Method (ExpressionRootCollection)

Adds the elements of another ExpressionRootCollection to the current ExpressionRootCollection.

public virtual int AddRange(
ExpressionRootCollection x
);

Parameters

x
The ExpressionRootCollection whose elements should be added to the end of the current ExpressionRootCollection.

Return Value

The new Count of the ExpressionRootCollection.

See Also

ExpressionRootCollection Class | DDW.CSharp.SymbolTable Namespace | ExpressionRootCollection.AddRange Overload List


ExpressionRootCollection.Clear Method

Removes all elements from the ExpressionRootCollection.

public virtual void Clear();

Implements

IList.Clear

See Also

ExpressionRootCollection Class | DDW.CSharp.SymbolTable Namespace


ExpressionRootCollection.Clone Method

Creates a shallow copy of the ExpressionRootCollection.

public virtual object Clone();

Implements

ICloneable.Clone

See Also

ExpressionRootCollection Class | DDW.CSharp.SymbolTable Namespace


ExpressionRootCollection.Contains Method

Determines whether a given ExpressionRoot is in the ExpressionRootCollection.

public virtual bool Contains(
ExpressionRoot item
);

Parameters

item
The ExpressionRoot to check for.

Return Value

true if item is found in the ExpressionRootCollection; otherwise, false.

See Also

ExpressionRootCollection Class | DDW.CSharp.SymbolTable Namespace


CopyTo Method

Goblin - A Platform for 3D AR and VR Applications

ExpressionRootCollection.CopyTo Method

Copies the entire ExpressionRootCollection to a one-dimensional ExpressionRoot array.

Overload List

Copies the entire ExpressionRootCollection to a one-dimensional ExpressionRoot array.

public virtual void CopyTo(ExpressionRoot[]);

Copies the entire ExpressionRootCollection to a one-dimensional ExpressionRoot array, starting at the specified index of the target array.

public virtual void CopyTo(ExpressionRoot[],int);

See Also

ExpressionRootCollection Class | DDW.CSharp.SymbolTable Namespace


ExpressionRootCollection.CopyTo Method (ExpressionRoot[])

Copies the entire ExpressionRootCollection to a one-dimensional ExpressionRoot array.

public virtual void CopyTo(
ExpressionRoot[] array
);

Parameters

array
The one-dimensional ExpressionRoot array to copy to.

See Also

ExpressionRootCollection Class | DDW.CSharp.SymbolTable Namespace | ExpressionRootCollection.CopyTo Overload List


ExpressionRootCollection.CopyTo Method (ExpressionRoot[], Int32)

Copies the entire ExpressionRootCollection to a one-dimensional ExpressionRoot array, starting at the specified index of the target array.

public virtual void CopyTo(
ExpressionRoot[] array,
int start
);

Parameters

array
The one-dimensional ExpressionRoot array to copy to.
start
The zero-based index in array at which copying begins.

See Also

ExpressionRootCollection Class | DDW.CSharp.SymbolTable Namespace | ExpressionRootCollection.CopyTo Overload List


ExpressionRootCollection.GetEnumerator Method

Returns an enumerator that can iterate through the ExpressionRootCollection.

public virtual IExpressionRootCollectionEnumerator GetEnumerator();

Return Value

An Enumerator for the entire ExpressionRootCollection.

See Also

ExpressionRootCollection Class | DDW.CSharp.SymbolTable Namespace


ExpressionRootCollection.IndexOf Method

Returns the zero-based index of the first occurrence of a ExpressionRoot in the ExpressionRootCollection.

public virtual int IndexOf(
ExpressionRoot item
);

Parameters

item
The ExpressionRoot to locate in the ExpressionRootCollection.

Return Value

The zero-based index of the first occurrence of item in the entire ExpressionRootCollection, if found; otherwise, -1.

See Also

ExpressionRootCollection Class | DDW.CSharp.SymbolTable Namespace


ExpressionRootCollection.Insert Method

Inserts an element into the ExpressionRootCollection at the specified index.

public virtual void Insert(
int index,
ExpressionRoot item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The ExpressionRoot to insert.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

ExpressionRootCollection Class | DDW.CSharp.SymbolTable Namespace


ExpressionRootCollection.ReadOnly Method

Creates a read-only wrapper for a ExpressionRootCollection instance.

public static ExpressionRootCollection ReadOnly(
ExpressionRootCollection list
);

Return Value

An ExpressionRootCollection wrapper that is read-only.

See Also

ExpressionRootCollection Class | DDW.CSharp.SymbolTable Namespace


ExpressionRootCollection.Remove Method

Removes the first occurrence of a specific ExpressionRoot from the ExpressionRootCollection.

public virtual void Remove(
ExpressionRoot item
);

Parameters

item
The ExpressionRoot to remove from the ExpressionRootCollection.

Exceptions

Exception Type | Condition
ArgumentException | The specified ExpressionRoot was not found in the ExpressionRootCollection.

See Also

ExpressionRootCollection Class | DDW.CSharp.SymbolTable Namespace


ExpressionRootCollection.RemoveAt Method

Removes the element at the specified index of the ExpressionRootCollection.

public virtual void RemoveAt(
int index
);

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

ExpressionRootCollection Class | DDW.CSharp.SymbolTable Namespace


ExpressionRootCollection.Synchronized Method

Creates a synchronized (thread-safe) wrapper for a ExpressionRootCollection instance.

public static ExpressionRootCollection Synchronized(
ExpressionRootCollection list
);

Return Value

An ExpressionRootCollection wrapper that is synchronized (thread-safe).

See Also

ExpressionRootCollection Class | DDW.CSharp.SymbolTable Namespace


ExpressionRootCollection.TrimToSize Method

Sets the capacity to the actual number of elements.

public virtual void TrimToSize();

See Also

ExpressionRootCollection Class | DDW.CSharp.SymbolTable Namespace


ExpressionRootCollection.IExpressionRootCollectionEnumerator Interface

Supports type-safe iteration over a ExpressionRootCollection.

For a list of all members of this type, see ExpressionRootCollection.IExpressionRootCollectionEnumerator Members.

public interface ExpressionRootCollection.IExpressionRootCollectionEnumerator

Requirements

Namespace: DDW.CSharp.SymbolTable

Assembly: CSharp (in CSharp.dll)

See Also

ExpressionRootCollection.IExpressionRootCollectionEnumerator Members | DDW.CSharp.SymbolTable Namespace


ExpressionRootCollection.IExpressionRootCollectionEnumerator Members

ExpressionRootCollection.IExpressionRootCollectionEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

ExpressionRootCollection.IExpressionRootCollectionEnumerator Interface | DDW.CSharp.SymbolTable Namespace


ExpressionRootCollection.IExpressionRootCollectionEnumerator Properties

The properties of the ExpressionRootCollection.IExpressionRootCollectionEnumerator interface are listed below. For a complete list of ExpressionRootCollection.IExpressionRootCollectionEnumerator interface members, see the ExpressionRootCollection.IExpressionRootCollectionEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

ExpressionRootCollection.IExpressionRootCollectionEnumerator Interface | DDW.CSharp.SymbolTable Namespace


Current Property

Goblin - A Platform for 3D AR and VR Applications

ExpressionRootCollection.IExpressionRootCollectionEnumerator.Current Property

Gets the current element in the collection.

ExpressionRoot Current {get;}

See Also

ExpressionRootCollection.IExpressionRootCollectionEnumerator Interface | DDW.CSharp.SymbolTable Namespace


ExpressionRootCollection.IExpressionRootCollectionEnumerator Methods

The methods of the ExpressionRootCollection.IExpressionRootCollectionEnumerator interface are listed below. For a complete list of ExpressionRootCollection.IExpressionRootCollectionEnumerator interface members, see the ExpressionRootCollection.IExpressionRootCollectionEnumerator Members topic.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

ExpressionRootCollection.IExpressionRootCollectionEnumerator Interface | DDW.CSharp.SymbolTable Namespace


ExpressionRootCollection.IExpressionRootCollectionEnumerator.MoveNext Method

Advances the enumerator to the next element in the collection.

bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Exceptions

Exception Type | Condition
InvalidOperationException | The collection was modified after the enumerator was created.

See Also

ExpressionRootCollection.IExpressionRootCollectionEnumerator Interface | DDW.CSharp.SymbolTable Namespace


ExpressionRootCollection.IExpressionRootCollectionEnumerator.Reset Method

Sets the enumerator to its initial position, before the first element in the collection.

void Reset();

See Also

ExpressionRootCollection.IExpressionRootCollectionEnumerator Interface | DDW.CSharp.SymbolTable Namespace


ExpressionRootCollection.Tag Enumeration

protected enum ExpressionRootCollection.Tag

Members

Member Name | Description
Default |

Requirements

Namespace: DDW.CSharp.SymbolTable

Assembly: CSharp (in CSharp.dll)

See Also

DDW.CSharp.SymbolTable Namespace


IDefinition Interface

Interface for Defintions. Definitions may be variable declarations, or scope declarations that have names (like types or methods, but not blocks or accessors). Note: With members that can declare multiple types at once, like fields or events, the declarator is the IDefinition.

For a list of all members of this type, see IDefinition Members.

DDW.CSharp.SymbolTable.IDefinition
DDW.CSharp.SymbolTable.ISymbol

public interface IDefinition

Types that implement IDefinition

Type | Description
BuiltInDefinition | Base class for Definitions. Definitions may be variables, or scopes that have names.
Definition | Base class for Definitions. Definitions may be variables, or scopes that have names.
OverloadableDefinition | Base class for Definitions. Definitions may be variables, or scopes that have names.
Symbol |

Requirements

Namespace: DDW.CSharp.SymbolTable

Assembly: CSharp (in CSharp.dll)

See Also

IDefinition Members | DDW.CSharp.SymbolTable Namespace


IDefinition Members

IDefinition overview

Public Instance Properties

FullName
Id
Name
Scope
SourceGraph
Type

See Also

IDefinition Interface | DDW.CSharp.SymbolTable Namespace


IDefinition Properties

The properties of the IDefinition interface are listed below. For a complete list of IDefinition interface members, see the IDefinition Members topic.

Public Instance Properties

FullName
Id
Name
Scope
SourceGraph
Type

See Also

IDefinition Interface | DDW.CSharp.SymbolTable Namespace


FullName Property

Goblin - A Platform for 3D AR and VR Applications

IDefinition.FullName Property

string FullName {get;}

See Also

IDefinition Interface | DDW.CSharp.SymbolTable Namespace


Id Property

Goblin - A Platform for 3D AR and VR Applications

IDefinition.Id Property

int Id {get; set;}

See Also

IDefinition Interface | DDW.CSharp.SymbolTable Namespace


Name Property

Goblin - A Platform for 3D AR and VR Applications

IDefinition.Name Property

string Name {get; set;}

See Also

IDefinition Interface | DDW.CSharp.SymbolTable Namespace


Scope Property

Goblin - A Platform for 3D AR and VR Applications

IDefinition.Scope Property

Scope Scope {get; set;}

See Also

IDefinition Interface | DDW.CSharp.SymbolTable Namespace


SourceGraph Property

Goblin - A Platform for 3D AR and VR Applications

IDefinition.SourceGraph Property

DDW.CSharp.Dom.IDeclaration SourceGraph {get; set;}

See Also

IDefinition Interface | DDW.CSharp.SymbolTable Namespace


Type Property

Goblin - A Platform for 3D AR and VR Applications

IDefinition.Type Property

DDW.CSharp.Dom.IDeclaration Type {get; set;}

See Also

IDefinition Interface | DDW.CSharp.SymbolTable Namespace


INamedScope Interface

Interface used to differentiate between named scopes (ns, types, members) and unnamed (asm, block).

For a list of all members of this type, see INamedScope Members.

public interface INamedScope

Types that implement INamedScope

Type | Description
MemberScope |
NamespaceScope |
TypeScope |

Requirements

Namespace: DDW.CSharp.SymbolTable

Assembly: CSharp (in CSharp.dll)

See Also

INamedScope Members | DDW.CSharp.SymbolTable Namespace


INamedScope Members

INamedScope overview

Public Instance Properties

Definition

See Also

INamedScope Interface | DDW.CSharp.SymbolTable Namespace


INamedScope Properties

The properties of the INamedScope interface are listed below. For a complete list of INamedScope interface members, see the INamedScope Members topic.

Public Instance Properties

Definition

See Also

INamedScope Interface | DDW.CSharp.SymbolTable Namespace


Definition Property

Goblin - A Platform for 3D AR and VR Applications

INamedScope.Definition Property

IDefinition Definition {get; set;}

See Also

INamedScope Interface | DDW.CSharp.SymbolTable Namespace


ISymbol Interface

For a list of all members of this type, see ISymbol Members.

public interface ISymbol : IDefinition

Types that implement ISymbol

Type | Description
Symbol |

Requirements

Namespace: DDW.CSharp.SymbolTable

Assembly: CSharp (in CSharp.dll)

See Also

ISymbol Members | DDW.CSharp.SymbolTable Namespace


ISymbol Members

ISymbol overview

Public Instance Properties

ActualType
DeclaredType

See Also

ISymbol Interface | DDW.CSharp.SymbolTable Namespace


ISymbol Properties

The properties of the ISymbol interface are listed below. For a complete list of ISymbol interface members, see the ISymbol Members topic.

Public Instance Properties

ActualType
DeclaredType

See Also

ISymbol Interface | DDW.CSharp.SymbolTable Namespace


ActualType Property

Goblin - A Platform for 3D AR and VR Applications

ISymbol.ActualType Property

IDefinition ActualType {get; set;}

See Also

ISymbol Interface | DDW.CSharp.SymbolTable Namespace


DeclaredType Property

Goblin - A Platform for 3D AR and VR Applications

ISymbol.DeclaredType Property

IDefinition DeclaredType {get; set;}

See Also

ISymbol Interface | DDW.CSharp.SymbolTable Namespace


LiteralType Enumeration

An enumeration of the built in types, from 'lowest' to 'highest'.

public enum LiteralType

Members

Member Name | Description
Void |
Null |
Bool |
Sbyte |
Byte |
Short |
Ushort |
Char |
Int |
Uint |
Long |
Ulong |
Float |
Double |
Decimal |
String |
Object |

Requirements

Namespace: DDW.CSharp.SymbolTable

Assembly: CSharp (in CSharp.dll)

See Also

DDW.CSharp.SymbolTable Namespace


MemberScope Class

For a list of all members of this type, see MemberScope Members.

System.Object
DDW.CSharp.SymbolTable.Scope
DDW.CSharp.SymbolTable.MemberScope

public class MemberScope : Scope, INamedScope

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.SymbolTable

Assembly: CSharp (in CSharp.dll)

See Also

MemberScope Members | DDW.CSharp.SymbolTable Namespace


MemberScope Members

MemberScope overview

Public Instance Constructors

MemberScope Constructor Initializes a new instance of the MemberScope class.

Public Instance Properties

ChildScopes (inherited from Scope) |
Definition | Gets or sets the definition of this (named) scope.
DefinitionTable (inherited from Scope) | Gets the hashtable that stored the declared symbol definitions.
EnclosingScope (inherited from Scope) | Gets or sets the enclosing scope of the scope.
MemberKind |
Modifiers |
Parameters |

Public Instance Methods

Add (inherited from Scope) |
AddRange (inherited from Scope) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Insert (inherited from Scope) |
Lookup (inherited from Scope) |
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate (inherited from Scope) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MemberScope Class | DDW.CSharp.SymbolTable Namespace


MemberScope Constructor

Initializes a new instance of the MemberScope class.

public MemberScope();

See Also

MemberScope Class | DDW.CSharp.SymbolTable Namespace


MemberScope Properties

The properties of the MemberScope class are listed below. For a complete list of MemberScope class members, see the MemberScope Members topic.

Public Instance Properties

ChildScopes (inherited from Scope) |
Definition | Gets or sets the definition of this (named) scope.
DefinitionTable (inherited from Scope) | Gets the hashtable that stored the declared symbol definitions.
EnclosingScope (inherited from Scope) | Gets or sets the enclosing scope of the scope.
MemberKind |
Modifiers |
Parameters |

See Also

MemberScope Class | DDW.CSharp.SymbolTable Namespace


Definition Property

Goblin - A Platform for 3D AR and VR Applications

MemberScope.Definition Property

Gets or sets the definition of this (named) scope.

public IDefinition Definition {get; set;}

Implements

INamedScope.Definition

See Also

MemberScope Class | DDW.CSharp.SymbolTable Namespace


MemberKind Property

Goblin - A Platform for 3D AR and VR Applications

MemberScope.MemberKind Property

public DDW.CSharp.Dom.MemberKind MemberKind {get; set;}

See Also

MemberScope Class | DDW.CSharp.SymbolTable Namespace


Modifiers Property

Goblin - A Platform for 3D AR and VR Applications

MemberScope.Modifiers Property

public DDW.CSharp.Dom.Modifiers Modifiers {get; set;}

See Also

MemberScope Class | DDW.CSharp.SymbolTable Namespace


Parameters Property

Goblin - A Platform for 3D AR and VR Applications

MemberScope.Parameters Property

public DefinitionCollection Parameters {get; set;}

See Also

MemberScope Class | DDW.CSharp.SymbolTable Namespace


NamespaceScope Class

For a list of all members of this type, see NamespaceScope Members.

System.Object
DDW.CSharp.SymbolTable.Scope
DDW.CSharp.SymbolTable.NamespaceScope

public class NamespaceScope : Scope, INamedScope

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.SymbolTable

Assembly: CSharp (in CSharp.dll)

See Also

NamespaceScope Members | DDW.CSharp.SymbolTable Namespace


NamespaceScope Members

NamespaceScope overview

Public Instance Constructors

NamespaceScope Constructor Initializes a new instance of the NamespaceScope class.

Public Instance Properties

ChildScopes (inherited from Scope) |
Definition | Gets or sets the definition of this (named) scope.
DefinitionTable (inherited from Scope) | Gets the hashtable that stored the declared symbol definitions.
EnclosingScope (inherited from Scope) | Gets or sets the enclosing scope of the scope.
Imports |

Public Instance Methods

Add (inherited from Scope) |
AddRange (inherited from Scope) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Insert (inherited from Scope) |
Lookup (inherited from Scope) |
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate (inherited from Scope) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NamespaceScope Class | DDW.CSharp.SymbolTable Namespace


NamespaceScope Constructor

Initializes a new instance of the NamespaceScope class.

public NamespaceScope();

See Also

NamespaceScope Class | DDW.CSharp.SymbolTable Namespace


NamespaceScope Properties

The properties of the NamespaceScope class are listed below. For a complete list of NamespaceScope class members, see the NamespaceScope Members topic.

Public Instance Properties

ChildScopes (inherited from Scope) |
Definition | Gets or sets the definition of this (named) scope.
DefinitionTable (inherited from Scope) | Gets the hashtable that stored the declared symbol definitions.
EnclosingScope (inherited from Scope) | Gets or sets the enclosing scope of the scope.
Imports |

See Also

NamespaceScope Class | DDW.CSharp.SymbolTable Namespace


Definition Property

Goblin - A Platform for 3D AR and VR Applications

NamespaceScope.Definition Property

Gets or sets the definition of this (named) scope.

public IDefinition Definition {get; set;}

Implements

INamedScope.Definition

See Also

NamespaceScope Class | DDW.CSharp.SymbolTable Namespace


Imports Property

Goblin - A Platform for 3D AR and VR Applications

NamespaceScope.Imports Property

public ScopeCollection Imports {get;}

See Also

NamespaceScope Class | DDW.CSharp.SymbolTable Namespace


OverloadableDefinition Class

Base class for Definitions. Definitions may be variables, or scopes that have names.

For a list of all members of this type, see OverloadableDefinition Members.

System.Object
DDW.CSharp.SymbolTable.Definition
DDW.CSharp.SymbolTable.OverloadableDefinition

public class OverloadableDefinition : Definition

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.SymbolTable

Assembly: CSharp (in CSharp.dll)

See Also

OverloadableDefinition Members | DDW.CSharp.SymbolTable Namespace


OverloadableDefinition Members

OverloadableDefinition overview

Public Instance Constructors

OverloadableDefinition Constructor Initializes a new instance of the OverloadableDefinition class.

Public Instance Properties

Definitions | Gets the collection of Definitions that share the same name but use different arguments in the same scope (eg that are overloaded).
FullName (inherited from Definition) | Gets the full name of the scope (namespace.class.member...).
Id (inherited from Definition) |
Name (inherited from Definition) | Gets or sets the given name of the Definition.
Scope (inherited from Definition) | Gets or sets the scope of the definition.
SourceGraph (inherited from Definition) | Link to the defining element.
Type (inherited from Definition) | Link to the defining type. Actual types just return a ref to themselves.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Definition) | Gets the hash of this defintion. The hash is made from the full path.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Definition) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OverloadableDefinition Class | DDW.CSharp.SymbolTable Namespace


OverloadableDefinition Constructor

Initializes a new instance of the OverloadableDefinition class.

public OverloadableDefinition();

See Also

OverloadableDefinition Class | DDW.CSharp.SymbolTable Namespace


OverloadableDefinition Properties

The properties of the OverloadableDefinition class are listed below. For a complete list of OverloadableDefinition class members, see the OverloadableDefinition Members topic.

Public Instance Properties

Definitions | Gets the collection of Definitions that share the same name but use different arguments in the same scope (eg that are overloaded).
FullName (inherited from Definition) | Gets the full name of the scope (namespace.class.member...).
Id (inherited from Definition) |
Name (inherited from Definition) | Gets or sets the given name of the Definition.
Scope (inherited from Definition) | Gets or sets the scope of the definition.
SourceGraph (inherited from Definition) | Link to the defining element.
Type (inherited from Definition) | Link to the defining type. Actual types just return a ref to themselves.

See Also

OverloadableDefinition Class | DDW.CSharp.SymbolTable Namespace


Definitions Property

Goblin - A Platform for 3D AR and VR Applications

OverloadableDefinition.Definitions Property

Gets the collection of Definitions that share the same name but use different arguments in the same scope (eg that are overloaded).

public DefinitionCollection Definitions {get;}

See Also

OverloadableDefinition Class | DDW.CSharp.SymbolTable Namespace


Scope Class

For a list of all members of this type, see Scope Members.

System.Object
DDW.CSharp.SymbolTable.Scope
DDW.CSharp.SymbolTable.AssemblyScope
DDW.CSharp.SymbolTable.BlockScope
DDW.CSharp.SymbolTable.MemberScope
DDW.CSharp.SymbolTable.NamespaceScope
DDW.CSharp.SymbolTable.TypeScope

public abstract class Scope

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.SymbolTable

Assembly: CSharp (in CSharp.dll)

See Also

Scope Members | DDW.CSharp.SymbolTable Namespace


Scope Members

Scope overview

Public Instance Properties

ChildScopes |
DefinitionTable | Gets the hashtable that stored the declared symbol definitions.
EnclosingScope | Gets or sets the enclosing scope of the scope.

Public Instance Methods

Add |
AddRange |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Insert |
Lookup |
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate |

Protected Instance Constructors

Scope Constructor Initializes a new instance of the Scope class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Scope Class | DDW.CSharp.SymbolTable Namespace


Scope Constructor

Initializes a new instance of the Scope class.

protected Scope();

See Also

Scope Class | DDW.CSharp.SymbolTable Namespace


Scope Properties

The properties of the Scope class are listed below. For a complete list of Scope class members, see the Scope Members topic.

Public Instance Properties

ChildScopes |
DefinitionTable | Gets the hashtable that stored the declared symbol definitions.
EnclosingScope | Gets or sets the enclosing scope of the scope.

See Also

Scope Class | DDW.CSharp.SymbolTable Namespace


ChildScopes Property

Goblin - A Platform for 3D AR and VR Applications

Scope.ChildScopes Property

public ScopeCollection ChildScopes {get; set;}

See Also

Scope Class | DDW.CSharp.SymbolTable Namespace


DefinitionTable Property

Goblin - A Platform for 3D AR and VR Applications

Scope.DefinitionTable Property

Gets the hashtable that stored the declared symbol definitions.

public System.Collections.Hashtable DefinitionTable {get;}

See Also

Scope Class | DDW.CSharp.SymbolTable Namespace


EnclosingScope Property

Goblin - A Platform for 3D AR and VR Applications

Scope.EnclosingScope Property

Gets or sets the enclosing scope of the scope.

public Scope EnclosingScope {get; set;}

See Also

Scope Class | DDW.CSharp.SymbolTable Namespace


Scope Methods

The methods of the Scope class are listed below. For a complete list of Scope class members, see the Scope Members topic.

Public Instance Methods

Add |
AddRange |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Insert |
Lookup |
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Scope Class | DDW.CSharp.SymbolTable Namespace


Scope.Add Method

public void Add(
IDefinition d,
string name
);

See Also

Scope Class | DDW.CSharp.SymbolTable Namespace


Scope.AddRange Method

public void AddRange(
DefinitionCollection dc
);

See Also

Scope Class | DDW.CSharp.SymbolTable Namespace


Scope.Insert Method

public Definition Insert(
string s
);

See Also

Scope Class | DDW.CSharp.SymbolTable Namespace


Scope.Lookup Method

public Definition Lookup(
string s
);

See Also

Scope Class | DDW.CSharp.SymbolTable Namespace


Scope.Validate Method

public bool Validate();

See Also

Scope Class | DDW.CSharp.SymbolTable Namespace


ScopeCollection Class

A strongly-typed collection of Scope objects.

For a list of all members of this type, see ScopeCollection Members.

System.Object
DDW.CSharp.SymbolTable.ScopeCollection

public class ScopeCollection : IList, ICollection, IEnumerable, ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.SymbolTable

Assembly: CSharp (in CSharp.dll)

See Also

ScopeCollection Members | DDW.CSharp.SymbolTable Namespace


ScopeCollection Members

ScopeCollection overview

Public Static Methods

ReadOnly | Creates a read-only wrapper for a ScopeCollection instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a ScopeCollection instance.

Public Instance Constructors

ScopeCollection Overloaded. Initializes a new instance of the ScopeCollection class.

Public Instance Properties

Capacity | Gets or sets the number of elements the ScopeCollection can contain.
Count | Gets the number of elements actually contained in the ScopeCollection.
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the Scope at the specified index.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds a Scope to the end of the ScopeCollection.
AddRange | Overloaded. Adds the elements of a Scope array to the current ScopeCollection.
Clear | Removes all elements from the ScopeCollection.
Clone | Creates a shallow copy of the ScopeCollection.
Contains | Determines whether a given Scope is in the ScopeCollection.
CopyTo | Overloaded. Copies the entire ScopeCollection to a one-dimensional Scope array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the ScopeCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the zero-based index of the first occurrence of a Scope in the ScopeCollection.
Insert | Inserts an element into the ScopeCollection at the specified index.
Remove | Removes the first occurrence of a specific Scope from the ScopeCollection.
RemoveAt | Removes the element at the specified index of the ScopeCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Constructors

ScopeCollection Overloaded. Initializes a new instance of the ScopeCollection class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ScopeCollection Class | DDW.CSharp.SymbolTable Namespace


ScopeCollection Constructor

Initializes a new instance of the ScopeCollection class that is empty and has the default initial capacity.

Overload List

Initializes a new instance of the ScopeCollection class that is empty and has the default initial capacity.

public ScopeCollection();

Initializes a new instance of the ScopeCollection class that contains elements copied from the specified Scope array.

public ScopeCollection(Scope[]);

Initializes a new instance of the ScopeCollection class that contains elements copied from the specified ScopeCollection.

public ScopeCollection(ScopeCollection);

protected ScopeCollection(Tag);

Initializes a new instance of the ScopeCollection class that has the specified initial capacity.

public ScopeCollection(int);

See Also

ScopeCollection Class | DDW.CSharp.SymbolTable Namespace


ScopeCollection Constructor ()

Initializes a new instance of the ScopeCollection class that is empty and has the default initial capacity.

public ScopeCollection();

See Also

ScopeCollection Class | DDW.CSharp.SymbolTable Namespace | ScopeCollection Constructor Overload List


ScopeCollection Constructor (Int32)

Initializes a new instance of the ScopeCollection class that has the specified initial capacity.

public ScopeCollection(
int capacity
);

Parameters

capacity
The number of elements that the new ScopeCollection is initially capable of storing.

See Also

ScopeCollection Class | DDW.CSharp.SymbolTable Namespace | ScopeCollection Constructor Overload List


ScopeCollection Constructor (ScopeCollection)

Initializes a new instance of the ScopeCollection class that contains elements copied from the specified ScopeCollection.

public ScopeCollection(
ScopeCollection c
);

Parameters

c
The ScopeCollection whose elements are copied to the new collection.

See Also

ScopeCollection Class | DDW.CSharp.SymbolTable Namespace | ScopeCollection Constructor Overload List


ScopeCollection Constructor (Scope[])

Initializes a new instance of the ScopeCollection class that contains elements copied from the specified Scope array.

public ScopeCollection(
Scope[] a
);

Parameters

a
The Scope array whose elements are copied to the new list.

See Also

ScopeCollection Class | DDW.CSharp.SymbolTable Namespace | ScopeCollection Constructor Overload List


ScopeCollection Constructor (Tag)

protected ScopeCollection(
Tag t
);

See Also

ScopeCollection Class | DDW.CSharp.SymbolTable Namespace | ScopeCollection Constructor Overload List


ScopeCollection Properties

The properties of the ScopeCollection class are listed below. For a complete list of ScopeCollection class members, see the ScopeCollection Members topic.

Public Instance Properties

Capacity | Gets or sets the number of elements the ScopeCollection can contain.
Count | Gets the number of elements actually contained in the ScopeCollection.
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the Scope at the specified index.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

ScopeCollection Class | DDW.CSharp.SymbolTable Namespace


Capacity Property

Goblin - A Platform for 3D AR and VR Applications

ScopeCollection.Capacity Property

Gets or sets the number of elements the ScopeCollection can contain.

public virtual int Capacity {get; set;}

See Also

ScopeCollection Class | DDW.CSharp.SymbolTable Namespace


Count Property

Goblin - A Platform for 3D AR and VR Applications

ScopeCollection.Count Property

Gets the number of elements actually contained in the ScopeCollection.

public virtual int Count {get;}

Implements

ICollection.Count

See Also

ScopeCollection Class | DDW.CSharp.SymbolTable Namespace


IsFixedSize Property

Goblin - A Platform for 3D AR and VR Applications

ScopeCollection.IsFixedSize Property

Gets a value indicating whether the collection has a fixed size.

public virtual bool IsFixedSize {get;}

Property Value

true if the collection has a fixed size; otherwise, false. The default is false

Implements

IList.IsFixedSize

See Also

ScopeCollection Class | DDW.CSharp.SymbolTable Namespace


IsReadOnly Property

Goblin - A Platform for 3D AR and VR Applications

ScopeCollection.IsReadOnly Property

gets a value indicating whether the IList is read-only.

public virtual bool IsReadOnly {get;}

Property Value

true if the collection is read-only; otherwise, false. The default is false

Implements

IList.IsReadOnly

See Also

ScopeCollection Class | DDW.CSharp.SymbolTable Namespace


IsSynchronized Property

Goblin - A Platform for 3D AR and VR Applications

ScopeCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread-safe).

public virtual bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

ScopeCollection Class | DDW.CSharp.SymbolTable Namespace


Item Property

Goblin - A Platform for 3D AR and VR Applications

ScopeCollection.Item Property

Gets or sets the Scope at the specified index.

public virtual Scope this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

ScopeCollection Class | DDW.CSharp.SymbolTable Namespace


SyncRoot Property

Goblin - A Platform for 3D AR and VR Applications

ScopeCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

public virtual object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

ScopeCollection Class | DDW.CSharp.SymbolTable Namespace


ScopeCollection Methods

The methods of the ScopeCollection class are listed below. For a complete list of ScopeCollection class members, see the ScopeCollection Members topic.

Public Static Methods

ReadOnly | Creates a read-only wrapper for a ScopeCollection instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a ScopeCollection instance.

Public Instance Methods

Add | Adds a Scope to the end of the ScopeCollection.
AddRange | Overloaded. Adds the elements of a Scope array to the current ScopeCollection.
Clear | Removes all elements from the ScopeCollection.
Clone | Creates a shallow copy of the ScopeCollection.
Contains | Determines whether a given Scope is in the ScopeCollection.
CopyTo | Overloaded. Copies the entire ScopeCollection to a one-dimensional Scope array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the ScopeCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the zero-based index of the first occurrence of a Scope in the ScopeCollection.
Insert | Inserts an element into the ScopeCollection at the specified index.
Remove | Removes the first occurrence of a specific Scope from the ScopeCollection.
RemoveAt | Removes the element at the specified index of the ScopeCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ScopeCollection Class | DDW.CSharp.SymbolTable Namespace


ScopeCollection.Add Method

Adds a Scope to the end of the ScopeCollection.

public virtual int Add(
Scope item
);

Parameters

item
The Scope to be added to the end of the ScopeCollection.

Return Value

The index at which the value has been added.

See Also

ScopeCollection Class | DDW.CSharp.SymbolTable Namespace


AddRange Method

Goblin - A Platform for 3D AR and VR Applications

ScopeCollection.AddRange Method

Adds the elements of a Scope array to the current ScopeCollection.

Overload List

Adds the elements of a Scope array to the current ScopeCollection.

public virtual int AddRange(Scope[]);

Adds the elements of another ScopeCollection to the current ScopeCollection.

public virtual int AddRange(ScopeCollection);

See Also

ScopeCollection Class | DDW.CSharp.SymbolTable Namespace


ScopeCollection.AddRange Method (Scope[])

Adds the elements of a Scope array to the current ScopeCollection.

public virtual int AddRange(
Scope[] x
);

Parameters

x
The Scope array whose elements should be added to the end of the ScopeCollection.

Return Value

The new Count of the ScopeCollection.

See Also

ScopeCollection Class | DDW.CSharp.SymbolTable Namespace | ScopeCollection.AddRange Overload List


ScopeCollection.AddRange Method (ScopeCollection)

Adds the elements of another ScopeCollection to the current ScopeCollection.

public virtual int AddRange(
ScopeCollection x
);

Parameters

x
The ScopeCollection whose elements should be added to the end of the current ScopeCollection.

Return Value

The new Count of the ScopeCollection.

See Also

ScopeCollection Class | DDW.CSharp.SymbolTable Namespace | ScopeCollection.AddRange Overload List


ScopeCollection.Clear Method

Removes all elements from the ScopeCollection.

public virtual void Clear();

Implements

IList.Clear

See Also

ScopeCollection Class | DDW.CSharp.SymbolTable Namespace


ScopeCollection.Clone Method

Creates a shallow copy of the ScopeCollection.

public virtual object Clone();

Implements

ICloneable.Clone

See Also

ScopeCollection Class | DDW.CSharp.SymbolTable Namespace


ScopeCollection.Contains Method

Determines whether a given Scope is in the ScopeCollection.

public virtual bool Contains(
Scope item
);

Parameters

item
The Scope to check for.

Return Value

true if item is found in the ScopeCollection; otherwise, false.

See Also

ScopeCollection Class | DDW.CSharp.SymbolTable Namespace


CopyTo Method

Goblin - A Platform for 3D AR and VR Applications

ScopeCollection.CopyTo Method

Copies the entire ScopeCollection to a one-dimensional Scope array.

Overload List

Copies the entire ScopeCollection to a one-dimensional Scope array.

public virtual void CopyTo(Scope[]);

Copies the entire ScopeCollection to a one-dimensional Scope array, starting at the specified index of the target array.

public virtual void CopyTo(Scope[],int);

See Also

ScopeCollection Class | DDW.CSharp.SymbolTable Namespace


ScopeCollection.CopyTo Method (Scope[])

Copies the entire ScopeCollection to a one-dimensional Scope array.

public virtual void CopyTo(
Scope[] array
);

Parameters

array
The one-dimensional Scope array to copy to.

See Also

ScopeCollection Class | DDW.CSharp.SymbolTable Namespace | ScopeCollection.CopyTo Overload List


ScopeCollection.CopyTo Method (Scope[], Int32)

Copies the entire ScopeCollection to a one-dimensional Scope array, starting at the specified index of the target array.

public virtual void CopyTo(
Scope[] array,
int start
);

Parameters

array
The one-dimensional Scope array to copy to.
start
The zero-based index in array at which copying begins.

See Also

ScopeCollection Class | DDW.CSharp.SymbolTable Namespace | ScopeCollection.CopyTo Overload List


ScopeCollection.GetEnumerator Method

Returns an enumerator that can iterate through the ScopeCollection.

public virtual IScopeCollectionEnumerator GetEnumerator();

Return Value

An Enumerator for the entire ScopeCollection.

See Also

ScopeCollection Class | DDW.CSharp.SymbolTable Namespace


ScopeCollection.IndexOf Method

Returns the zero-based index of the first occurrence of a Scope in the ScopeCollection.

public virtual int IndexOf(
Scope item
);

Parameters

item
The Scope to locate in the ScopeCollection.

Return Value

The zero-based index of the first occurrence of item in the entire ScopeCollection, if found; otherwise, -1.

See Also

ScopeCollection Class | DDW.CSharp.SymbolTable Namespace


ScopeCollection.Insert Method

Inserts an element into the ScopeCollection at the specified index.

public virtual void Insert(
int index,
Scope item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The Scope to insert.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

ScopeCollection Class | DDW.CSharp.SymbolTable Namespace


ScopeCollection.ReadOnly Method

Creates a read-only wrapper for a ScopeCollection instance.

public static ScopeCollection ReadOnly(
ScopeCollection list
);

Return Value

An ScopeCollection wrapper that is read-only.

See Also

ScopeCollection Class | DDW.CSharp.SymbolTable Namespace


ScopeCollection.Remove Method

Removes the first occurrence of a specific Scope from the ScopeCollection.

public virtual void Remove(
Scope item
);

Parameters

item
The Scope to remove from the ScopeCollection.

Exceptions

Exception Type | Condition
ArgumentException | The specified Scope was not found in the ScopeCollection.

See Also

ScopeCollection Class | DDW.CSharp.SymbolTable Namespace


ScopeCollection.RemoveAt Method

Removes the element at the specified index of the ScopeCollection.

public virtual void RemoveAt(
int index
);

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

ScopeCollection Class | DDW.CSharp.SymbolTable Namespace


ScopeCollection.Synchronized Method

Creates a synchronized (thread-safe) wrapper for a ScopeCollection instance.

public static ScopeCollection Synchronized(
ScopeCollection list
);

Return Value

An ScopeCollection wrapper that is synchronized (thread-safe).

See Also

ScopeCollection Class | DDW.CSharp.SymbolTable Namespace


ScopeCollection.TrimToSize Method

Sets the capacity to the actual number of elements.

public virtual void TrimToSize();

See Also

ScopeCollection Class | DDW.CSharp.SymbolTable Namespace


ScopeCollection.IScopeCollectionEnumerator Interface

Supports type-safe iteration over a ScopeCollection.

For a list of all members of this type, see ScopeCollection.IScopeCollectionEnumerator Members.

public interface ScopeCollection.IScopeCollectionEnumerator

Requirements

Namespace: DDW.CSharp.SymbolTable

Assembly: CSharp (in CSharp.dll)

See Also

ScopeCollection.IScopeCollectionEnumerator Members | DDW.CSharp.SymbolTable Namespace


ScopeCollection.IScopeCollectionEnumerator Members

ScopeCollection.IScopeCollectionEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

ScopeCollection.IScopeCollectionEnumerator Interface | DDW.CSharp.SymbolTable Namespace


ScopeCollection.IScopeCollectionEnumerator Properties

The properties of the ScopeCollection.IScopeCollectionEnumerator interface are listed below. For a complete list of ScopeCollection.IScopeCollectionEnumerator interface members, see the ScopeCollection.IScopeCollectionEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

ScopeCollection.IScopeCollectionEnumerator Interface | DDW.CSharp.SymbolTable Namespace


Current Property

Goblin - A Platform for 3D AR and VR Applications

ScopeCollection.IScopeCollectionEnumerator.Current Property

Gets the current element in the collection.

Scope Current {get;}

See Also

ScopeCollection.IScopeCollectionEnumerator Interface | DDW.CSharp.SymbolTable Namespace


ScopeCollection.IScopeCollectionEnumerator Methods

The methods of the ScopeCollection.IScopeCollectionEnumerator interface are listed below. For a complete list of ScopeCollection.IScopeCollectionEnumerator interface members, see the ScopeCollection.IScopeCollectionEnumerator Members topic.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

ScopeCollection.IScopeCollectionEnumerator Interface | DDW.CSharp.SymbolTable Namespace


ScopeCollection.IScopeCollectionEnumerator.MoveNext Method

Advances the enumerator to the next element in the collection.

bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Exceptions

Exception Type | Condition
InvalidOperationException | The collection was modified after the enumerator was created.

See Also

ScopeCollection.IScopeCollectionEnumerator Interface | DDW.CSharp.SymbolTable Namespace


ScopeCollection.IScopeCollectionEnumerator.Reset Method

Sets the enumerator to its initial position, before the first element in the collection.

void Reset();

See Also

ScopeCollection.IScopeCollectionEnumerator Interface | DDW.CSharp.SymbolTable Namespace


ScopeCollection.Tag Enumeration

protected enum ScopeCollection.Tag

Members

Member Name | Description
Default |

Requirements

Namespace: DDW.CSharp.SymbolTable

Assembly: CSharp (in CSharp.dll)

See Also

DDW.CSharp.SymbolTable Namespace


Symbol Class

For a list of all members of this type, see Symbol Members.

System.Object
DDW.CSharp.SymbolTable.Definition
DDW.CSharp.SymbolTable.Symbol

public class Symbol : Definition, ISymbol

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.SymbolTable

Assembly: CSharp (in CSharp.dll)

See Also

Symbol Members | DDW.CSharp.SymbolTable Namespace


Symbol Members

Symbol overview

Public Instance Constructors

Symbol Constructor Initializes a new instance of the Symbol class.

Public Instance Properties

ActualType | Gets or sets the declared type of the symbol.
DeclaredType | Gets or sets the declared type of the symbol.
FullName (inherited from Definition) | Gets the full name of the scope (namespace.class.member...).
Id (inherited from Definition) |
Name (inherited from Definition) | Gets or sets the given name of the Definition.
Scope (inherited from Definition) | Gets or sets the scope of the definition.
SourceGraph (inherited from Definition) | Link to the defining element.
Type (inherited from Definition) | Link to the defining type. Actual types just return a ref to themselves.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Definition) | Gets the hash of this defintion. The hash is made from the full path.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Definition) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Symbol Class | DDW.CSharp.SymbolTable Namespace


Symbol Constructor

Initializes a new instance of the Symbol class.

public Symbol();

See Also

Symbol Class | DDW.CSharp.SymbolTable Namespace


Symbol Properties

The properties of the Symbol class are listed below. For a complete list of Symbol class members, see the Symbol Members topic.

Public Instance Properties

ActualType | Gets or sets the declared type of the symbol.
DeclaredType | Gets or sets the declared type of the symbol.
FullName (inherited from Definition) | Gets the full name of the scope (namespace.class.member...).
Id (inherited from Definition) |
Name (inherited from Definition) | Gets or sets the given name of the Definition.
Scope (inherited from Definition) | Gets or sets the scope of the definition.
SourceGraph (inherited from Definition) | Link to the defining element.
Type (inherited from Definition) | Link to the defining type. Actual types just return a ref to themselves.

See Also

Symbol Class | DDW.CSharp.SymbolTable Namespace


ActualType Property

Goblin - A Platform for 3D AR and VR Applications

Symbol.ActualType Property

Gets or sets the declared type of the symbol.

public IDefinition ActualType {get; set;}

Implements

ISymbol.ActualType

See Also

Symbol Class | DDW.CSharp.SymbolTable Namespace


DeclaredType Property

Goblin - A Platform for 3D AR and VR Applications

Symbol.DeclaredType Property

Gets or sets the declared type of the symbol.

public IDefinition DeclaredType {get; set;}

Implements

ISymbol.DeclaredType

See Also

Symbol Class | DDW.CSharp.SymbolTable Namespace


TypeScope Class

For a list of all members of this type, see TypeScope Members.

System.Object
DDW.CSharp.SymbolTable.Scope
DDW.CSharp.SymbolTable.TypeScope

public class TypeScope : Scope, INamedScope

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.SymbolTable

Assembly: CSharp (in CSharp.dll)

See Also

TypeScope Members | DDW.CSharp.SymbolTable Namespace


TypeScope Members

TypeScope overview

Public Instance Constructors

TypeScope Constructor Initializes a new instance of the TypeScope class.

Public Instance Properties

ChildScopes (inherited from Scope) |
Definition | Gets or sets the definition of this (named) scope.
DefinitionTable (inherited from Scope) | Gets the hashtable that stored the declared symbol definitions.
EnclosingScope (inherited from Scope) | Gets or sets the enclosing scope of the scope.
Imports |
Modifiers |
TypeKind |

Public Instance Methods

Add (inherited from Scope) |
AddRange (inherited from Scope) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Insert (inherited from Scope) |
Lookup (inherited from Scope) |
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate (inherited from Scope) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TypeScope Class | DDW.CSharp.SymbolTable Namespace


TypeScope Constructor

Initializes a new instance of the TypeScope class.

public TypeScope();

See Also

TypeScope Class | DDW.CSharp.SymbolTable Namespace


TypeScope Properties

The properties of the TypeScope class are listed below. For a complete list of TypeScope class members, see the TypeScope Members topic.

Public Instance Properties

ChildScopes (inherited from Scope) |
Definition | Gets or sets the definition of this (named) scope.
DefinitionTable (inherited from Scope) | Gets the hashtable that stored the declared symbol definitions.
EnclosingScope (inherited from Scope) | Gets or sets the enclosing scope of the scope.
Imports |
Modifiers |
TypeKind |

See Also

TypeScope Class | DDW.CSharp.SymbolTable Namespace


Definition Property

Goblin - A Platform for 3D AR and VR Applications

TypeScope.Definition Property

Gets or sets the definition of this (named) scope.

public IDefinition Definition {get; set;}

Implements

INamedScope.Definition

See Also

TypeScope Class | DDW.CSharp.SymbolTable Namespace


Imports Property

Goblin - A Platform for 3D AR and VR Applications

TypeScope.Imports Property

public ScopeCollection Imports {get;}

See Also

TypeScope Class | DDW.CSharp.SymbolTable Namespace


Modifiers Property

Goblin - A Platform for 3D AR and VR Applications

TypeScope.Modifiers Property

public DDW.CSharp.Dom.Modifiers Modifiers {get; set;}

See Also

TypeScope Class | DDW.CSharp.SymbolTable Namespace


TypeKind Property

Goblin - A Platform for 3D AR and VR Applications

TypeScope.TypeKind Property

public DDW.CSharp.Dom.TypeKind TypeKind {get; set;}

See Also

TypeScope Class | DDW.CSharp.SymbolTable Namespace


TypeScopeCollection Class

A strongly-typed collection of TypeScope objects.

For a list of all members of this type, see TypeScopeCollection Members.

System.Object
DDW.CSharp.SymbolTable.TypeScopeCollection

public class TypeScopeCollection : IList, ICollection, IEnumerable, ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.SymbolTable

Assembly: CSharp (in CSharp.dll)

See Also

TypeScopeCollection Members | DDW.CSharp.SymbolTable Namespace


TypeScopeCollection Members

TypeScopeCollection overview

Public Static Methods

ReadOnly | Creates a read-only wrapper for a TypeScopeCollection instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a TypeScopeCollection instance.

Public Instance Constructors

TypeScopeCollection Overloaded. Initializes a new instance of the TypeScopeCollection class.

Public Instance Properties

Capacity | Gets or sets the number of elements the TypeScopeCollection can contain.
Count | Gets the number of elements actually contained in the TypeScopeCollection.
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the TypeScope at the specified index.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds a TypeScope to the end of the TypeScopeCollection.
AddRange | Overloaded. Adds the elements of a TypeScope array to the current TypeScopeCollection.
Clear | Removes all elements from the TypeScopeCollection.
Clone | Creates a shallow copy of the TypeScopeCollection.
Contains | Determines whether a given TypeScope is in the TypeScopeCollection.
CopyTo | Overloaded. Copies the entire TypeScopeCollection to a one-dimensional TypeScope array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the TypeScopeCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the zero-based index of the first occurrence of a TypeScope in the TypeScopeCollection.
Insert | Inserts an element into the TypeScopeCollection at the specified index.
Remove | Removes the first occurrence of a specific TypeScope from the TypeScopeCollection.
RemoveAt | Removes the element at the specified index of the TypeScopeCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Constructors

TypeScopeCollection Overloaded. Initializes a new instance of the TypeScopeCollection class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TypeScopeCollection Class | DDW.CSharp.SymbolTable Namespace


TypeScopeCollection Constructor

Initializes a new instance of the TypeScopeCollection class that is empty and has the default initial capacity.

Overload List

Initializes a new instance of the TypeScopeCollection class that is empty and has the default initial capacity.

public TypeScopeCollection();

Initializes a new instance of the TypeScopeCollection class that contains elements copied from the specified TypeScope array.

public TypeScopeCollection(TypeScope[]);

Initializes a new instance of the TypeScopeCollection class that contains elements copied from the specified TypeScopeCollection.

public TypeScopeCollection(TypeScopeCollection);

protected TypeScopeCollection(Tag);

Initializes a new instance of the TypeScopeCollection class that has the specified initial capacity.

public TypeScopeCollection(int);

See Also

TypeScopeCollection Class | DDW.CSharp.SymbolTable Namespace


TypeScopeCollection Constructor ()

Initializes a new instance of the TypeScopeCollection class that is empty and has the default initial capacity.

public TypeScopeCollection();

See Also

TypeScopeCollection Class | DDW.CSharp.SymbolTable Namespace | TypeScopeCollection Constructor Overload List


TypeScopeCollection Constructor (Int32)

Initializes a new instance of the TypeScopeCollection class that has the specified initial capacity.

public TypeScopeCollection(
int capacity
);

Parameters

capacity
The number of elements that the new TypeScopeCollection is initially capable of storing.

See Also

TypeScopeCollection Class | DDW.CSharp.SymbolTable Namespace | TypeScopeCollection Constructor Overload List


TypeScopeCollection Constructor (TypeScopeCollection)

Initializes a new instance of the TypeScopeCollection class that contains elements copied from the specified TypeScopeCollection.

public TypeScopeCollection(
TypeScopeCollection c
);

Parameters

c
The TypeScopeCollection whose elements are copied to the new collection.

See Also

TypeScopeCollection Class | DDW.CSharp.SymbolTable Namespace | TypeScopeCollection Constructor Overload List


TypeScopeCollection Constructor (TypeScope[])

Initializes a new instance of the TypeScopeCollection class that contains elements copied from the specified TypeScope array.

public TypeScopeCollection(
TypeScope[] a
);

Parameters

a
The TypeScope array whose elements are copied to the new list.

See Also

TypeScopeCollection Class | DDW.CSharp.SymbolTable Namespace | TypeScopeCollection Constructor Overload List


TypeScopeCollection Constructor (Tag)

protected TypeScopeCollection(
Tag t
);

See Also

TypeScopeCollection Class | DDW.CSharp.SymbolTable Namespace | TypeScopeCollection Constructor Overload List


TypeScopeCollection Properties

The properties of the TypeScopeCollection class are listed below. For a complete list of TypeScopeCollection class members, see the TypeScopeCollection Members topic.

Public Instance Properties

Capacity | Gets or sets the number of elements the TypeScopeCollection can contain.
Count | Gets the number of elements actually contained in the TypeScopeCollection.
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the TypeScope at the specified index.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

TypeScopeCollection Class | DDW.CSharp.SymbolTable Namespace


Capacity Property

Goblin - A Platform for 3D AR and VR Applications

TypeScopeCollection.Capacity Property

Gets or sets the number of elements the TypeScopeCollection can contain.

public virtual int Capacity {get; set;}

See Also

TypeScopeCollection Class | DDW.CSharp.SymbolTable Namespace


Count Property

Goblin - A Platform for 3D AR and VR Applications

TypeScopeCollection.Count Property

Gets the number of elements actually contained in the TypeScopeCollection.

public virtual int Count {get;}

Implements

ICollection.Count

See Also

TypeScopeCollection Class | DDW.CSharp.SymbolTable Namespace


IsFixedSize Property

Goblin - A Platform for 3D AR and VR Applications

TypeScopeCollection.IsFixedSize Property

Gets a value indicating whether the collection has a fixed size.

public virtual bool IsFixedSize {get;}

Property Value

true if the collection has a fixed size; otherwise, false. The default is false

Implements

IList.IsFixedSize

See Also

TypeScopeCollection Class | DDW.CSharp.SymbolTable Namespace


IsReadOnly Property

Goblin - A Platform for 3D AR and VR Applications

TypeScopeCollection.IsReadOnly Property

gets a value indicating whether the IList is read-only.

public virtual bool IsReadOnly {get;}

Property Value

true if the collection is read-only; otherwise, false. The default is false

Implements

IList.IsReadOnly

See Also

TypeScopeCollection Class | DDW.CSharp.SymbolTable Namespace


IsSynchronized Property

Goblin - A Platform for 3D AR and VR Applications

TypeScopeCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread-safe).

public virtual bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

TypeScopeCollection Class | DDW.CSharp.SymbolTable Namespace


Item Property

Goblin - A Platform for 3D AR and VR Applications

TypeScopeCollection.Item Property

Gets or sets the TypeScope at the specified index.

public virtual TypeScope this[
int index
] {get; set;}

Parameters

index
The zero-based index of the element to get or set.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

TypeScopeCollection Class | DDW.CSharp.SymbolTable Namespace


SyncRoot Property

Goblin - A Platform for 3D AR and VR Applications

TypeScopeCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

public virtual object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

TypeScopeCollection Class | DDW.CSharp.SymbolTable Namespace


TypeScopeCollection Methods

The methods of the TypeScopeCollection class are listed below. For a complete list of TypeScopeCollection class members, see the TypeScopeCollection Members topic.

Public Static Methods

ReadOnly | Creates a read-only wrapper for a TypeScopeCollection instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a TypeScopeCollection instance.

Public Instance Methods

Add | Adds a TypeScope to the end of the TypeScopeCollection.
AddRange | Overloaded. Adds the elements of a TypeScope array to the current TypeScopeCollection.
Clear | Removes all elements from the TypeScopeCollection.
Clone | Creates a shallow copy of the TypeScopeCollection.
Contains | Determines whether a given TypeScope is in the TypeScopeCollection.
CopyTo | Overloaded. Copies the entire TypeScopeCollection to a one-dimensional TypeScope array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that can iterate through the TypeScopeCollection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf | Returns the zero-based index of the first occurrence of a TypeScope in the TypeScopeCollection.
Insert | Inserts an element into the TypeScopeCollection at the specified index.
Remove | Removes the first occurrence of a specific TypeScope from the TypeScopeCollection.
RemoveAt | Removes the element at the specified index of the TypeScopeCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TypeScopeCollection Class | DDW.CSharp.SymbolTable Namespace


TypeScopeCollection.Add Method

Adds a TypeScope to the end of the TypeScopeCollection.

public virtual int Add(
TypeScope item
);

Parameters

item
The TypeScope to be added to the end of the TypeScopeCollection.

Return Value

The index at which the value has been added.

See Also

TypeScopeCollection Class | DDW.CSharp.SymbolTable Namespace


AddRange Method

Goblin - A Platform for 3D AR and VR Applications

TypeScopeCollection.AddRange Method

Adds the elements of a TypeScope array to the current TypeScopeCollection.

Overload List

Adds the elements of a TypeScope array to the current TypeScopeCollection.

public virtual int AddRange(TypeScope[]);

Adds the elements of another TypeScopeCollection to the current TypeScopeCollection.

public virtual int AddRange(TypeScopeCollection);

See Also

TypeScopeCollection Class | DDW.CSharp.SymbolTable Namespace


TypeScopeCollection.AddRange Method (TypeScope[])

Adds the elements of a TypeScope array to the current TypeScopeCollection.

public virtual int AddRange(
TypeScope[] x
);

Parameters

x
The TypeScope array whose elements should be added to the end of the TypeScopeCollection.

Return Value

The new Count of the TypeScopeCollection.

See Also

TypeScopeCollection Class | DDW.CSharp.SymbolTable Namespace | TypeScopeCollection.AddRange Overload List


TypeScopeCollection.AddRange Method (TypeScopeCollection)

Adds the elements of another TypeScopeCollection to the current TypeScopeCollection.

public virtual int AddRange(
TypeScopeCollection x
);

Parameters

x
The TypeScopeCollection whose elements should be added to the end of the current TypeScopeCollection.

Return Value

The new Count of the TypeScopeCollection.

See Also

TypeScopeCollection Class | DDW.CSharp.SymbolTable Namespace | TypeScopeCollection.AddRange Overload List


TypeScopeCollection.Clear Method

Removes all elements from the TypeScopeCollection.

public virtual void Clear();

Implements

IList.Clear

See Also

TypeScopeCollection Class | DDW.CSharp.SymbolTable Namespace


TypeScopeCollection.Clone Method

Creates a shallow copy of the TypeScopeCollection.

public virtual object Clone();

Implements

ICloneable.Clone

See Also

TypeScopeCollection Class | DDW.CSharp.SymbolTable Namespace


TypeScopeCollection.Contains Method

Determines whether a given TypeScope is in the TypeScopeCollection.

public virtual bool Contains(
TypeScope item
);

Parameters

item
The TypeScope to check for.

Return Value

true if item is found in the TypeScopeCollection; otherwise, false.

See Also

TypeScopeCollection Class | DDW.CSharp.SymbolTable Namespace


CopyTo Method

Goblin - A Platform for 3D AR and VR Applications

TypeScopeCollection.CopyTo Method

Copies the entire TypeScopeCollection to a one-dimensional TypeScope array.

Overload List

Copies the entire TypeScopeCollection to a one-dimensional TypeScope array.

public virtual void CopyTo(TypeScope[]);

Copies the entire TypeScopeCollection to a one-dimensional TypeScope array, starting at the specified index of the target array.

public virtual void CopyTo(TypeScope[],int);

See Also

TypeScopeCollection Class | DDW.CSharp.SymbolTable Namespace


TypeScopeCollection.CopyTo Method (TypeScope[])

Copies the entire TypeScopeCollection to a one-dimensional TypeScope array.

public virtual void CopyTo(
TypeScope[] array
);

Parameters

array
The one-dimensional TypeScope array to copy to.

See Also

TypeScopeCollection Class | DDW.CSharp.SymbolTable Namespace | TypeScopeCollection.CopyTo Overload List


TypeScopeCollection.CopyTo Method (TypeScope[], Int32)

Copies the entire TypeScopeCollection to a one-dimensional TypeScope array, starting at the specified index of the target array.

public virtual void CopyTo(
TypeScope[] array,
int start
);

Parameters

array
The one-dimensional TypeScope array to copy to.
start
The zero-based index in array at which copying begins.

See Also

TypeScopeCollection Class | DDW.CSharp.SymbolTable Namespace | TypeScopeCollection.CopyTo Overload List


TypeScopeCollection.GetEnumerator Method

Returns an enumerator that can iterate through the TypeScopeCollection.

public virtual ITypeScopeCollectionEnumerator GetEnumerator();

Return Value

An Enumerator for the entire TypeScopeCollection.

See Also

TypeScopeCollection Class | DDW.CSharp.SymbolTable Namespace


TypeScopeCollection.IndexOf Method

Returns the zero-based index of the first occurrence of a TypeScope in the TypeScopeCollection.

public virtual int IndexOf(
TypeScope item
);

Parameters

item
The TypeScope to locate in the TypeScopeCollection.

Return Value

The zero-based index of the first occurrence of item in the entire TypeScopeCollection, if found; otherwise, -1.

See Also

TypeScopeCollection Class | DDW.CSharp.SymbolTable Namespace


TypeScopeCollection.Insert Method

Inserts an element into the TypeScopeCollection at the specified index.

public virtual void Insert(
int index,
TypeScope item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The TypeScope to insert.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

TypeScopeCollection Class | DDW.CSharp.SymbolTable Namespace


TypeScopeCollection.ReadOnly Method

Creates a read-only wrapper for a TypeScopeCollection instance.

public static TypeScopeCollection ReadOnly(
TypeScopeCollection list
);

Return Value

An TypeScopeCollection wrapper that is read-only.

See Also

TypeScopeCollection Class | DDW.CSharp.SymbolTable Namespace


TypeScopeCollection.Remove Method

Removes the first occurrence of a specific TypeScope from the TypeScopeCollection.

public virtual void Remove(
TypeScope item
);

Parameters

item
The TypeScope to remove from the TypeScopeCollection.

Exceptions

Exception Type | Condition
ArgumentException | The specified TypeScope was not found in the TypeScopeCollection.

See Also

TypeScopeCollection Class | DDW.CSharp.SymbolTable Namespace


TypeScopeCollection.RemoveAt Method

Removes the element at the specified index of the TypeScopeCollection.

public virtual void RemoveAt(
int index
);

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

TypeScopeCollection Class | DDW.CSharp.SymbolTable Namespace


TypeScopeCollection.Synchronized Method

Creates a synchronized (thread-safe) wrapper for a TypeScopeCollection instance.

public static TypeScopeCollection Synchronized(
TypeScopeCollection list
);

Return Value

An TypeScopeCollection wrapper that is synchronized (thread-safe).

See Also

TypeScopeCollection Class | DDW.CSharp.SymbolTable Namespace


TypeScopeCollection.TrimToSize Method

Sets the capacity to the actual number of elements.

public virtual void TrimToSize();

See Also

TypeScopeCollection Class | DDW.CSharp.SymbolTable Namespace


TypeScopeCollection.ITypeScopeCollectionEnumerator Interface

Supports type-safe iteration over a TypeScopeCollection.

For a list of all members of this type, see TypeScopeCollection.ITypeScopeCollectionEnumerator Members.

public interface TypeScopeCollection.ITypeScopeCollectionEnumerator

Requirements

Namespace: DDW.CSharp.SymbolTable

Assembly: CSharp (in CSharp.dll)

See Also

TypeScopeCollection.ITypeScopeCollectionEnumerator Members | DDW.CSharp.SymbolTable Namespace


TypeScopeCollection.ITypeScopeCollectionEnumerator Members

TypeScopeCollection.ITypeScopeCollectionEnumerator overview

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

TypeScopeCollection.ITypeScopeCollectionEnumerator Interface | DDW.CSharp.SymbolTable Namespace


TypeScopeCollection.ITypeScopeCollectionEnumerator Properties

The properties of the TypeScopeCollection.ITypeScopeCollectionEnumerator interface are listed below. For a complete list of TypeScopeCollection.ITypeScopeCollectionEnumerator interface members, see the TypeScopeCollection.ITypeScopeCollectionEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

TypeScopeCollection.ITypeScopeCollectionEnumerator Interface | DDW.CSharp.SymbolTable Namespace


Current Property

Goblin - A Platform for 3D AR and VR Applications

TypeScopeCollection.ITypeScopeCollectionEnumerator.Current Property

Gets the current element in the collection.

TypeScope Current {get;}

See Also

TypeScopeCollection.ITypeScopeCollectionEnumerator Interface | DDW.CSharp.SymbolTable Namespace


TypeScopeCollection.ITypeScopeCollectionEnumerator Methods

The methods of the TypeScopeCollection.ITypeScopeCollectionEnumerator interface are listed below. For a complete list of TypeScopeCollection.ITypeScopeCollectionEnumerator interface members, see the TypeScopeCollection.ITypeScopeCollectionEnumerator Members topic.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

TypeScopeCollection.ITypeScopeCollectionEnumerator Interface | DDW.CSharp.SymbolTable Namespace


TypeScopeCollection.ITypeScopeCollectionEnumerator.MoveNext Method

Advances the enumerator to the next element in the collection.

bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Exceptions

Exception Type | Condition
InvalidOperationException | The collection was modified after the enumerator was created.

See Also

TypeScopeCollection.ITypeScopeCollectionEnumerator Interface | DDW.CSharp.SymbolTable Namespace


TypeScopeCollection.ITypeScopeCollectionEnumerator.Reset Method

Sets the enumerator to its initial position, before the first element in the collection.

void Reset();

See Also

TypeScopeCollection.ITypeScopeCollectionEnumerator Interface | DDW.CSharp.SymbolTable Namespace


TypeScopeCollection.Tag Enumeration

protected enum TypeScopeCollection.Tag

Members

Member Name | Description
Default |

Requirements

Namespace: DDW.CSharp.SymbolTable

Assembly: CSharp (in CSharp.dll)

See Also

DDW.CSharp.SymbolTable Namespace


DDW.CSharp.Walk

Goblin - A Platform for 3D AR and VR Applications

DDW.CSharp.Walk Namespace

C# grammar (based on ecma-334 spec) -- Robin Debreuil Fri Mar 5, 2004 11:50 -- A (mostly) complete cs parser. It parses into a tree structure loosely based on the CodeDom. Does not yet do #if preprocessor segments, and no unsafe code (as of yet). You can test by downloading the CSharp.zip file and dragging cs files into CSharp.exe. The zip includes the grammar file, as well as the cs token classes (the grammar uses a heterogeneous tree, though that should be simple to turn off). -- permalink: http://www.debreuil.com/CSharp. TJP: copied src, exe to antlr.org and changed link as debreuil's links are dead.

Namespace hierarchy

Classes

Class | Description
GraphParserBase |
PropertyWalker |
PropertyWalkerBase |
PropertyWalkerTest |

Interfaces

Interface | Description
IGraphVisitor |


GraphParserBase Class

For a list of all members of this type, see GraphParserBase Members.

System.Object
DDW.CSharp.Walk.GraphParserBase
DDW.CSharp.Gen.CSharpGen

public abstract class GraphParserBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Walk

Assembly: CSharp (in CSharp.dll)

See Also

GraphParserBase Members | DDW.CSharp.Walk Namespace


GraphParserBase Members

GraphParserBase overview

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Parse |
ParseElement | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

GraphParserBase Constructor Initializes a new instance of the GraphParserBase class.

Protected Instance Methods

BeginParse |
EndParse |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace


GraphParserBase Constructor

Initializes a new instance of the GraphParserBase class.

protected GraphParserBase();

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace


GraphParserBase Methods

The methods of the GraphParserBase class are listed below. For a complete list of GraphParserBase class members, see the GraphParserBase Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Parse |
ParseElement | Overloaded.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

BeginParse |
EndParse |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace


GraphParserBase.BeginParse Method

protected virtual void BeginParse(
IGraph gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace


GraphParserBase.EndParse Method

protected virtual void EndParse(
IGraph gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace


GraphParserBase.Parse Method

public virtual void Parse(
IGraph ig
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace


ParseElement Method

Goblin - A Platform for 3D AR and VR Applications

GraphParserBase.ParseElement Method

Overload List

public abstract void ParseElement(AccessorDecl);

public abstract void ParseElement(AccessorModifiers);

public abstract void ParseElement(ArgumentRef);

public abstract void ParseElement(ArrayCreateExpr);

public abstract void ParseElement(ArrayElementRef);

public abstract void ParseElement(ArrayInitializer);

public abstract void ParseElement(AssemblyReference);

public abstract void ParseElement(AssemblyReferenceCollection);

public abstract void ParseElement(AssignExpr);

public abstract void ParseElement(AssignOperator);

public abstract void ParseElement(AttachDelegateStmt);

public abstract void ParseElement(AttributeTarget);

public abstract void ParseElement(BaseRef);

public abstract void ParseElement(BinaryExpr);

public abstract void ParseElement(BinaryOperator);

public abstract void ParseElement(BooleanLiteral);

public abstract void ParseElement(BreakStmt);

public abstract void ParseElement(BuiltInType);

public abstract void ParseElement(Case);

public abstract void ParseElement(CaseCollection);

public abstract void ParseElement(CastExpr);

public abstract void ParseElement(Catch);

public abstract void ParseElement(CatchCollection);

public abstract void ParseElement(CharLiteral);

public abstract void ParseElement(CheckedStmt);

public abstract void ParseElement(ClassDecl);

public abstract void ParseElement(Comment);

public abstract void ParseElement(CommentStmt);

public abstract void ParseElement(CommentStmtCollection);

public abstract void ParseElement(CompileUnit);

public abstract void ParseElement(CompileUnitCollection);

public abstract void ParseElement(ConstantDecl);

public abstract void ParseElement(ConstantDeclStmt);

public abstract void ParseElement(ConstructorDecl);

public abstract void ParseElement(ContinueStmt);

public abstract void ParseElement(CreateDelegateExpr);

public abstract void ParseElement(CustomAttribute);

public abstract void ParseElement(CustomAttributeCollection);

public abstract void ParseElement(Declarator);

public abstract void ParseElement(DeclaratorCollection);

public abstract void ParseElement(DelegateDecl);

public abstract void ParseElement(DelegateInvokeExpr);

public abstract void ParseElement(DestructorDecl);

public abstract void ParseElement(EnumDecl);

public abstract void ParseElement(EnumMemberDecl);

public abstract void ParseElement(EventDecl);

public abstract void ParseElement(EventRef);

public abstract void ParseElement(ExpressionCollection);

public abstract void ParseElement(ExprStmt);

public abstract void ParseElement(FieldDecl);

public abstract void ParseElement(FieldRef);

public abstract void ParseElement(ForEachStmt);

public abstract void ParseElement(GotoStmt);

public abstract void ParseElement(IfStmt);

public abstract void ParseElement(Import);

public abstract void ParseElement(ImportCollection);

public abstract void ParseElement(IndexerDecl);

public abstract void ParseElement(IndexerRef);

public abstract void ParseElement(IntegerLiteral);

public abstract void ParseElement(InterfaceDecl);

public abstract void ParseElement(IterationStmt);

public abstract void ParseElement(IterationType);

public abstract void ParseElement(LabeledStmt);

public abstract void ParseElement(LinePragma);

public abstract void ParseElement(LocalRef);

public abstract void ParseElement(LockStmt);

public abstract void ParseElement(MemberAccess);

public abstract void ParseElement(MemberDeclCollection);

public abstract void ParseElement(MethodDecl);

public abstract void ParseElement(MethodInvokeExpr);

public abstract void ParseElement(MethodRef);

public abstract void ParseElement(Modifiers);

public abstract void ParseElement(NamespaceDecl);

public abstract void ParseElement(NamespaceDeclCollection);

public abstract void ParseElement(NullLiteral);

public abstract void ParseElement(ObjectCreateExpr);

public abstract void ParseElement(OperatorDecl);

public abstract void ParseElement(OverloadableOperator);

public abstract void ParseElement(Param);

public abstract void ParseElement(ParamCollection);

public abstract void ParseElement(ParamDecl);

public abstract void ParseElement(ParamDeclCollection);

public abstract void ParseElement(ParamDirection);

public abstract void ParseElement(PostfixExpr);

public abstract void ParseElement(PostfixOperator);

public abstract void ParseElement(PropertyDecl);

public abstract void ParseElement(PropertyRef);

public abstract void ParseElement(PropertySetValueRef);

public abstract void ParseElement(RankSpecifier);

public abstract void ParseElement(RankSpecifierCollection);

public abstract void ParseElement(RealLiteral);

public abstract void ParseElement(RemoveDelegateStmt);

public abstract void ParseElement(ReturnStmt);

public abstract void ParseElement(StatementCollection);

public abstract void ParseElement(StringLiteral);

public abstract void ParseElement(StructDecl);

public abstract void ParseElement(SubExpr);

public abstract void ParseElement(SwitchStmt);

public abstract void ParseElement(TernaryExpr);

public abstract void ParseElement(ThisRef);

public abstract void ParseElement(ThrowStmt);

public abstract void ParseElement(TryCatchFinallyStmt);

public abstract void ParseElement(TypeDeclCollection);

public abstract void ParseElement(TypeModifiers);

public abstract void ParseElement(TypeOfExpr);

public abstract void ParseElement(TypeRef);

public abstract void ParseElement(TypeRefCollection);

public abstract void ParseElement(UnaryExpr);

public abstract void ParseElement(UnaryOperator);

public abstract void ParseElement(UncheckedStmt);

public abstract void ParseElement(UnknownReference);

public abstract void ParseElement(UsingStmt);

public abstract void ParseElement(VariableDecl);

public abstract void ParseElement(VariableDeclStmt);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace


GraphParserBase.ParseElement Method (AccessorDecl)

public abstract void ParseElement(
AccessorDecl gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (AccessorModifiers)

public abstract void ParseElement(
AccessorModifiers gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (ArgumentRef)

public abstract void ParseElement(
ArgumentRef gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (ArrayCreateExpr)

public abstract void ParseElement(
ArrayCreateExpr gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (ArrayElementRef)

public abstract void ParseElement(
ArrayElementRef gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (ArrayInitializer)

public abstract void ParseElement(
ArrayInitializer gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (AssemblyReference)

public abstract void ParseElement(
AssemblyReference gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (AssemblyReferenceCollection)

public abstract void ParseElement(
AssemblyReferenceCollection gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (AssignExpr)

public abstract void ParseElement(
AssignExpr gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (AssignOperator)

public abstract void ParseElement(
AssignOperator gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (AttachDelegateStmt)

public abstract void ParseElement(
AttachDelegateStmt gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (AttributeTarget)

public abstract void ParseElement(
AttributeTarget gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (BaseRef)

public abstract void ParseElement(
BaseRef gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (BinaryExpr)

public abstract void ParseElement(
BinaryExpr gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (BinaryOperator)

public abstract void ParseElement(
BinaryOperator gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (BooleanLiteral)

public abstract void ParseElement(
BooleanLiteral gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (BreakStmt)

public abstract void ParseElement(
BreakStmt gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (BuiltInType)

public abstract void ParseElement(
BuiltInType gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (Case)

public abstract void ParseElement(
Case gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (CaseCollection)

public abstract void ParseElement(
CaseCollection gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (CastExpr)

public abstract void ParseElement(
CastExpr gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (Catch)

public abstract void ParseElement(
Catch gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (CatchCollection)

public abstract void ParseElement(
CatchCollection gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (CharLiteral)

public abstract void ParseElement(
CharLiteral gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (CheckedStmt)

public abstract void ParseElement(
CheckedStmt gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (ClassDecl)

public abstract void ParseElement(
ClassDecl gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (Comment)

public abstract void ParseElement(
Comment gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (CommentStmt)

public abstract void ParseElement(
CommentStmt gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (CommentStmtCollection)

public abstract void ParseElement(
CommentStmtCollection gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (CompileUnit)

public abstract void ParseElement(
CompileUnit gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (CompileUnitCollection)

public abstract void ParseElement(
CompileUnitCollection gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (ConstantDecl)

public abstract void ParseElement(
ConstantDecl gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (ConstantDeclStmt)

public abstract void ParseElement(
ConstantDeclStmt gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (ConstructorDecl)

public abstract void ParseElement(
ConstructorDecl gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (ContinueStmt)

public abstract void ParseElement(
ContinueStmt gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (CreateDelegateExpr)

public abstract void ParseElement(
CreateDelegateExpr gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (CustomAttribute)

public abstract void ParseElement(
CustomAttribute gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (CustomAttributeCollection)

public abstract void ParseElement(
CustomAttributeCollection gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (Declarator)

public abstract void ParseElement(
Declarator gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (DeclaratorCollection)

public abstract void ParseElement(
DeclaratorCollection gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (DelegateDecl)

public abstract void ParseElement(
DelegateDecl gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (DelegateInvokeExpr)

public abstract void ParseElement(
DelegateInvokeExpr gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (DestructorDecl)

public abstract void ParseElement(
DestructorDecl gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (EnumDecl)

public abstract void ParseElement(
EnumDecl gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (EnumMemberDecl)

public abstract void ParseElement(
EnumMemberDecl gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (EventDecl)

public abstract void ParseElement(
EventDecl gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (EventRef)

public abstract void ParseElement(
EventRef gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (ExpressionCollection)

public abstract void ParseElement(
ExpressionCollection gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (ExprStmt)

public abstract void ParseElement(
ExprStmt gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (FieldDecl)

public abstract void ParseElement(
FieldDecl gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (FieldRef)

public abstract void ParseElement(
FieldRef gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (ForEachStmt)

public abstract void ParseElement(
ForEachStmt gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (GotoStmt)

public abstract void ParseElement(
GotoStmt gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (IfStmt)

public abstract void ParseElement(
IfStmt gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (Import)

public abstract void ParseElement(
Import gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (ImportCollection)

public abstract void ParseElement(
ImportCollection gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (IndexerDecl)

public abstract void ParseElement(
IndexerDecl gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (IndexerRef)

public abstract void ParseElement(
IndexerRef gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (IntegerLiteral)

public abstract void ParseElement(
IntegerLiteral gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (InterfaceDecl)

public abstract void ParseElement(
InterfaceDecl gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (IterationStmt)

public abstract void ParseElement(
IterationStmt gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (IterationType)

public abstract void ParseElement(
IterationType gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (LabeledStmt)

public abstract void ParseElement(
LabeledStmt gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (LinePragma)

public abstract void ParseElement(
LinePragma gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (LocalRef)

public abstract void ParseElement(
LocalRef gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (LockStmt)

public abstract void ParseElement(
LockStmt gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (MemberAccess)

public abstract void ParseElement(
MemberAccess gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (MemberDeclCollection)

public abstract void ParseElement(
MemberDeclCollection gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (MethodDecl)

public abstract void ParseElement(
MethodDecl gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (MethodInvokeExpr)

public abstract void ParseElement(
MethodInvokeExpr gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (MethodRef)

public abstract void ParseElement(
MethodRef gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (Modifiers)

public abstract void ParseElement(
Modifiers gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (NamespaceDecl)

public abstract void ParseElement(
NamespaceDecl gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (NamespaceDeclCollection)

public abstract void ParseElement(
NamespaceDeclCollection gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (NullLiteral)

public abstract void ParseElement(
NullLiteral gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (ObjectCreateExpr)

public abstract void ParseElement(
ObjectCreateExpr gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (OperatorDecl)

public abstract void ParseElement(
OperatorDecl gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (OverloadableOperator)

public abstract void ParseElement(
OverloadableOperator gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (Param)

public abstract void ParseElement(
Param gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (ParamCollection)

public abstract void ParseElement(
ParamCollection gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (ParamDecl)

public abstract void ParseElement(
ParamDecl gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (ParamDeclCollection)

public abstract void ParseElement(
ParamDeclCollection gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (ParamDirection)

public abstract void ParseElement(
ParamDirection gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (PostfixExpr)

public abstract void ParseElement(
PostfixExpr gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (PostfixOperator)

public abstract void ParseElement(
PostfixOperator gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (PropertyDecl)

public abstract void ParseElement(
PropertyDecl gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (PropertyRef)

public abstract void ParseElement(
PropertyRef gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (PropertySetValueRef)

public abstract void ParseElement(
PropertySetValueRef gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (RankSpecifier)

public abstract void ParseElement(
RankSpecifier gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (RankSpecifierCollection)

public abstract void ParseElement(
RankSpecifierCollection gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (RealLiteral)

public abstract void ParseElement(
RealLiteral gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (RemoveDelegateStmt)

public abstract void ParseElement(
RemoveDelegateStmt gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (ReturnStmt)

public abstract void ParseElement(
ReturnStmt gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (StatementCollection)

public abstract void ParseElement(
StatementCollection gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (StringLiteral)

public abstract void ParseElement(
StringLiteral gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (StructDecl)

public abstract void ParseElement(
StructDecl gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (SubExpr)

public abstract void ParseElement(
SubExpr gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (SwitchStmt)

public abstract void ParseElement(
SwitchStmt gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (TernaryExpr)

public abstract void ParseElement(
TernaryExpr gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (ThisRef)

public abstract void ParseElement(
ThisRef gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (ThrowStmt)

public abstract void ParseElement(
ThrowStmt gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (TryCatchFinallyStmt)

public abstract void ParseElement(
TryCatchFinallyStmt gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (TypeDeclCollection)

public abstract void ParseElement(
TypeDeclCollection gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (TypeModifiers)

public abstract void ParseElement(
TypeModifiers gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (TypeOfExpr)

public abstract void ParseElement(
TypeOfExpr gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (TypeRef)

public abstract void ParseElement(
TypeRef gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (TypeRefCollection)

public abstract void ParseElement(
TypeRefCollection gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (UnaryExpr)

public abstract void ParseElement(
UnaryExpr gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (UnaryOperator)

public abstract void ParseElement(
UnaryOperator gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (UncheckedStmt)

public abstract void ParseElement(
UncheckedStmt gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (UnknownReference)

public abstract void ParseElement(
UnknownReference gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (UsingStmt)

public abstract void ParseElement(
UsingStmt gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (VariableDecl)

public abstract void ParseElement(
VariableDecl gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


GraphParserBase.ParseElement Method (VariableDeclStmt)

public abstract void ParseElement(
VariableDeclStmt gr
);

See Also

GraphParserBase Class | DDW.CSharp.Walk Namespace | GraphParserBase.ParseElement Overload List


IGraphVisitor Interface

For a list of all members of this type, see IGraphVisitor Members.

public interface IGraphVisitor

Types that implement IGraphVisitor

Type | Description
PropertyWalkerBase |
PropertyWalkerTest |

Requirements

Namespace: DDW.CSharp.Walk

Assembly: CSharp (in CSharp.dll)

See Also

IGraphVisitor Members | DDW.CSharp.Walk Namespace


IGraphVisitor Members

IGraphVisitor overview

Public Instance Properties

BaseElement
IgnoreEmpty
IsCollection
IsProperty
NestingLevel
PropertyInfo
PropertyValue

Public Instance Methods

VisitCallback

See Also

IGraphVisitor Interface | DDW.CSharp.Walk Namespace


IGraphVisitor Properties

The properties of the IGraphVisitor interface are listed below. For a complete list of IGraphVisitor interface members, see the IGraphVisitor Members topic.

Public Instance Properties

BaseElement
IgnoreEmpty
IsCollection
IsProperty
NestingLevel
PropertyInfo
PropertyValue

See Also

IGraphVisitor Interface | DDW.CSharp.Walk Namespace


BaseElement Property

Goblin - A Platform for 3D AR and VR Applications

IGraphVisitor.BaseElement Property

DDW.CSharp.Dom.IGraph BaseElement {get; set;}

See Also

IGraphVisitor Interface | DDW.CSharp.Walk Namespace


IgnoreEmpty Property

Goblin - A Platform for 3D AR and VR Applications

IGraphVisitor.IgnoreEmpty Property

bool IgnoreEmpty {get; set;}

See Also

IGraphVisitor Interface | DDW.CSharp.Walk Namespace


IsCollection Property

Goblin - A Platform for 3D AR and VR Applications

IGraphVisitor.IsCollection Property

bool IsCollection {get; set;}

See Also

IGraphVisitor Interface | DDW.CSharp.Walk Namespace


IsProperty Property

Goblin - A Platform for 3D AR and VR Applications

IGraphVisitor.IsProperty Property

bool IsProperty {get;}

See Also

IGraphVisitor Interface | DDW.CSharp.Walk Namespace


NestingLevel Property

Goblin - A Platform for 3D AR and VR Applications

IGraphVisitor.NestingLevel Property

int NestingLevel {get; set;}

See Also

IGraphVisitor Interface | DDW.CSharp.Walk Namespace


PropertyInfo Property

Goblin - A Platform for 3D AR and VR Applications

IGraphVisitor.PropertyInfo Property

System.Reflection.MemberInfo PropertyInfo {get; set;}

See Also

IGraphVisitor Interface | DDW.CSharp.Walk Namespace


PropertyValue Property

Goblin - A Platform for 3D AR and VR Applications

IGraphVisitor.PropertyValue Property

object PropertyValue {get; set;}

See Also

IGraphVisitor Interface | DDW.CSharp.Walk Namespace


IGraphVisitor Methods

The methods of the IGraphVisitor interface are listed below. For a complete list of IGraphVisitor interface members, see the IGraphVisitor Members topic.

Public Instance Methods

VisitCallback

See Also

IGraphVisitor Interface | DDW.CSharp.Walk Namespace


IGraphVisitor.VisitCallback Method

void VisitCallback();

See Also

IGraphVisitor Interface | DDW.CSharp.Walk Namespace


PropertyWalker Class

For a list of all members of this type, see PropertyWalker Members.

System.Object
DDW.CSharp.Walk.PropertyWalker

public class PropertyWalker

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Walk

Assembly: CSharp (in CSharp.dll)

See Also

PropertyWalker Members | DDW.CSharp.Walk Namespace


PropertyWalker Members

PropertyWalker overview

Public Static Methods

MemberFilter
Walk

Public Instance Constructors

PropertyWalker Constructor Initializes a new instance of the PropertyWalker class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PropertyWalker Class | DDW.CSharp.Walk Namespace


PropertyWalker Constructor

Initializes a new instance of the PropertyWalker class.

public PropertyWalker();

See Also

PropertyWalker Class | DDW.CSharp.Walk Namespace


PropertyWalker Methods

The methods of the PropertyWalker class are listed below. For a complete list of PropertyWalker class members, see the PropertyWalker Members topic.

Public Static Methods

MemberFilter
Walk

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PropertyWalker Class | DDW.CSharp.Walk Namespace


PropertyWalker.MemberFilter Method

public static bool MemberFilter(
MemberInfo objMemberInfo,
object objSearch
);

See Also

PropertyWalker Class | DDW.CSharp.Walk Namespace


PropertyWalker.Walk Method

public static void Walk(
IGraph element,
IGraphVisitor gv
);

See Also

PropertyWalker Class | DDW.CSharp.Walk Namespace


PropertyWalkerBase Class

For a list of all members of this type, see PropertyWalkerBase Members.

System.Object
DDW.CSharp.Walk.PropertyWalkerBase
DDW.CSharp.Walk.PropertyWalkerTest

public class PropertyWalkerBase : IGraphVisitor

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Walk

Assembly: CSharp (in CSharp.dll)

See Also

PropertyWalkerBase Members | DDW.CSharp.Walk Namespace


PropertyWalkerBase Members

PropertyWalkerBase overview

Public Instance Constructors

PropertyWalkerBase Constructor Initializes a new instance of the PropertyWalkerBase class.

Public Instance Properties

BaseElement
IgnoreEmpty
IsCollection
IsProperty
NestingLevel
PropertyInfo
PropertyValue

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
VisitCallback |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PropertyWalkerBase Class | DDW.CSharp.Walk Namespace


PropertyWalkerBase Constructor

Initializes a new instance of the PropertyWalkerBase class.

public PropertyWalkerBase();

See Also

PropertyWalkerBase Class | DDW.CSharp.Walk Namespace


PropertyWalkerBase Properties

The properties of the PropertyWalkerBase class are listed below. For a complete list of PropertyWalkerBase class members, see the PropertyWalkerBase Members topic.

Public Instance Properties

BaseElement
IgnoreEmpty
IsCollection
IsProperty
NestingLevel
PropertyInfo
PropertyValue

See Also

PropertyWalkerBase Class | DDW.CSharp.Walk Namespace


BaseElement Property

Goblin - A Platform for 3D AR and VR Applications

PropertyWalkerBase.BaseElement Property

public DDW.CSharp.Dom.IGraph BaseElement {get; set;}

Implements

IGraphVisitor.BaseElement

See Also

PropertyWalkerBase Class | DDW.CSharp.Walk Namespace


IgnoreEmpty Property

Goblin - A Platform for 3D AR and VR Applications

PropertyWalkerBase.IgnoreEmpty Property

public bool IgnoreEmpty {get; set;}

Implements

IGraphVisitor.IgnoreEmpty

See Also

PropertyWalkerBase Class | DDW.CSharp.Walk Namespace


IsCollection Property

Goblin - A Platform for 3D AR and VR Applications

PropertyWalkerBase.IsCollection Property

public bool IsCollection {get; set;}

Implements

IGraphVisitor.IsCollection

See Also

PropertyWalkerBase Class | DDW.CSharp.Walk Namespace


IsProperty Property

Goblin - A Platform for 3D AR and VR Applications

PropertyWalkerBase.IsProperty Property

public bool IsProperty {get;}

Implements

IGraphVisitor.IsProperty

See Also

PropertyWalkerBase Class | DDW.CSharp.Walk Namespace


NestingLevel Property

Goblin - A Platform for 3D AR and VR Applications

PropertyWalkerBase.NestingLevel Property

public int NestingLevel {get; set;}

Implements

IGraphVisitor.NestingLevel

See Also

PropertyWalkerBase Class | DDW.CSharp.Walk Namespace


PropertyInfo Property

Goblin - A Platform for 3D AR and VR Applications

PropertyWalkerBase.PropertyInfo Property

public System.Reflection.MemberInfo PropertyInfo {get; set;}

Implements

IGraphVisitor.PropertyInfo

See Also

PropertyWalkerBase Class | DDW.CSharp.Walk Namespace


PropertyValue Property

Goblin - A Platform for 3D AR and VR Applications

PropertyWalkerBase.PropertyValue Property

public object PropertyValue {get; set;}

Implements

IGraphVisitor.PropertyValue

See Also

PropertyWalkerBase Class | DDW.CSharp.Walk Namespace


PropertyWalkerBase Methods

The methods of the PropertyWalkerBase class are listed below. For a complete list of PropertyWalkerBase class members, see the PropertyWalkerBase Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
VisitCallback |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PropertyWalkerBase Class | DDW.CSharp.Walk Namespace


PropertyWalkerBase.VisitCallback Method

public virtual void VisitCallback();

Implements

IGraphVisitor.VisitCallback

See Also

PropertyWalkerBase Class | DDW.CSharp.Walk Namespace


PropertyWalkerTest Class

For a list of all members of this type, see PropertyWalkerTest Members.

System.Object
DDW.CSharp.Walk.PropertyWalkerBase
DDW.CSharp.Walk.PropertyWalkerTest

public class PropertyWalkerTest : PropertyWalkerBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: DDW.CSharp.Walk

Assembly: CSharp (in CSharp.dll)

See Also

PropertyWalkerTest Members | DDW.CSharp.Walk Namespace


PropertyWalkerTest Members

PropertyWalkerTest overview

Public Instance Constructors

PropertyWalkerTest Constructor Initializes a new instance of the PropertyWalkerTest class.

Public Instance Properties

BaseElement (inherited from PropertyWalkerBase)
IgnoreEmpty (inherited from PropertyWalkerBase)
IsCollection (inherited from PropertyWalkerBase)
IsProperty (inherited from PropertyWalkerBase)
NestingLevel (inherited from PropertyWalkerBase)
PropertyInfo (inherited from PropertyWalkerBase)
PropertyValue (inherited from PropertyWalkerBase)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
VisitCallback |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PropertyWalkerTest Class | DDW.CSharp.Walk Namespace


PropertyWalkerTest Constructor

Initializes a new instance of the PropertyWalkerTest class.

public PropertyWalkerTest();

See Also

PropertyWalkerTest Class | DDW.CSharp.Walk Namespace


PropertyWalkerTest Methods

The methods of the PropertyWalkerTest class are listed below. For a complete list of PropertyWalkerTest class members, see the PropertyWalkerTest Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString |
VisitCallback |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PropertyWalkerTest Class | DDW.CSharp.Walk Namespace


PropertyWalkerTest.ToString Method

public override string ToString();

See Also

PropertyWalkerTest Class | DDW.CSharp.Walk Namespace


PropertyWalkerTest.VisitCallback Method

public override void VisitCallback();

Implements

IGraphVisitor.VisitCallback

See Also

PropertyWalkerTest Class | DDW.CSharp.Walk Namespace


EnC.Watcher

Goblin - A Platform for 3D AR and VR Applications

EnC.Watcher Namespace

Console application that is launched by the Patcher hook DLL. Monitors a list of source files specified by Patcher and rebuilds the assembly if the source files change. Supports any .NET language but has only been tested with C#, VB.NET, and JScript.NET.

Namespace hierarchy

Classes

Class | Description
AspectRule |
AspectRules |
AspectRulesFile |
DynModule | Watches a module's source files and recompiles the module if they change.
EnCProcess | Summary description for EnCProcess.
EnCSocketServer | Summary description for EnCSocketServer.
FileWatcherCollection |
Helper | Holder of some helper functions.
IGraphMatch |
MyFileWatcher |
MyTrace | Summary description for MyTrace.
Pointcut |

Delegates

Delegate | Description
ModuleDelegate |
MyFileWatcher.OnChangedDelegate |
OnCompilerOptionFound |
OnModuleUpdatedDelegate |
ShutdownDelegate |


AspectRule Class

For a list of all members of this type, see AspectRule Members.

System.Object
EnC.Watcher.AspectRule

public class AspectRule

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: EnC.Watcher

Assembly: Watcher (in Watcher.exe)

See Also

AspectRule Members | EnC.Watcher Namespace


AspectRule Members

AspectRule overview

Public Static Methods

findElements
findMethod
MemberFilter

Public Instance Constructors

AspectRule Constructor Initializes a new instance of the AspectRule class.

Public Instance Fields

className
namespaceName
pointcuts
sources

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
init |
instrument |
instrumentAfter |
instrumentAround |
instrumentBefore |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AspectRule Class | EnC.Watcher Namespace


AspectRule Constructor

Initializes a new instance of the AspectRule class.

public AspectRule();

See Also

AspectRule Class | EnC.Watcher Namespace


AspectRule Fields

The fields of the AspectRule class are listed below. For a complete list of AspectRule class members, see the AspectRule Members topic.

Public Instance Fields

className
namespaceName
pointcuts
sources

See Also

AspectRule Class | EnC.Watcher Namespace


AspectRule.className Field

public string className;

See Also

AspectRule Class | EnC.Watcher Namespace


AspectRule.namespaceName Field

public string namespaceName;

See Also

AspectRule Class | EnC.Watcher Namespace


AspectRule.pointcuts Field

public Pointcut[] pointcuts;

See Also

AspectRule Class | EnC.Watcher Namespace


AspectRule.sources Field

public string sources;

See Also

AspectRule Class | EnC.Watcher Namespace


AspectRule Methods

The methods of the AspectRule class are listed below. For a complete list of AspectRule class members, see the AspectRule Members topic.

Public Static Methods

findElements
findMethod
MemberFilter

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
init |
instrument |
instrumentAfter |
instrumentAround |
instrumentBefore |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AspectRule Class | EnC.Watcher Namespace


AspectRule.findElements Method

public static int findElements(
IGraph parent,
IGraph element,
GraphTypes elemType,
string pattern,
ArrayList matches
);

See Also

AspectRule Class | EnC.Watcher Namespace


AspectRule.findMethod Method

public static MethodDecl findMethod(
IGraph element,
string methodName
);

See Also

AspectRule Class | EnC.Watcher Namespace


AspectRule.init Method

public void init();

See Also

AspectRule Class | EnC.Watcher Namespace


AspectRule.instrument Method

public int instrument(
IGraph ig
);

See Also

AspectRule Class | EnC.Watcher Namespace


AspectRule.instrumentAfter Method

public bool instrumentAfter(
IGraph ig
);

See Also

AspectRule Class | EnC.Watcher Namespace


AspectRule.instrumentAround Method

public bool instrumentAround(
IGraph ig
);

See Also

AspectRule Class | EnC.Watcher Namespace


AspectRule.instrumentBefore Method

public bool instrumentBefore(
IGraph ig
);

See Also

AspectRule Class | EnC.Watcher Namespace


AspectRule.MemberFilter Method

public static bool MemberFilter(
MemberInfo objMemberInfo,
object objSearch
);

See Also

AspectRule Class | EnC.Watcher Namespace


AspectRules Class

For a list of all members of this type, see AspectRules Members.

System.Object
EnC.Watcher.AspectRules

public class AspectRules

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: EnC.Watcher

Assembly: Watcher (in Watcher.exe)

See Also

AspectRules Members | EnC.Watcher Namespace


AspectRules Members

AspectRules overview

Public Static Methods

load

Public Instance Constructors

AspectRules Constructor Initializes a new instance of the AspectRules class.

Public Instance Fields

enableWeaving
rules

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
init |
instrument |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AspectRules Class | EnC.Watcher Namespace


AspectRules Constructor

Initializes a new instance of the AspectRules class.

public AspectRules();

See Also

AspectRules Class | EnC.Watcher Namespace


AspectRules Fields

The fields of the AspectRules class are listed below. For a complete list of AspectRules class members, see the AspectRules Members topic.

Public Instance Fields

enableWeaving
rules

See Also

AspectRules Class | EnC.Watcher Namespace


AspectRules.enableWeaving Field

public bool enableWeaving;

See Also

AspectRules Class | EnC.Watcher Namespace


AspectRules.rules Field

public AspectRule[] rules;

See Also

AspectRules Class | EnC.Watcher Namespace


AspectRules Methods

The methods of the AspectRules class are listed below. For a complete list of AspectRules class members, see the AspectRules Members topic.

Public Static Methods

load

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
init |
instrument |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AspectRules Class | EnC.Watcher Namespace


AspectRules.init Method

public void init();

See Also

AspectRules Class | EnC.Watcher Namespace


AspectRules.instrument Method

public void instrument(
IGraph ig
);

See Also

AspectRules Class | EnC.Watcher Namespace


AspectRules.load Method

public static AspectRules load(
string path
);

See Also

AspectRules Class | EnC.Watcher Namespace


AspectRulesFile Class

For a list of all members of this type, see AspectRulesFile Members.

System.Object
EnC.Watcher.FileWatcherCollection
EnC.Watcher.AspectRulesFile

public class AspectRulesFile : FileWatcherCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: EnC.Watcher

Assembly: Watcher (in Watcher.exe)

See Also

AspectRulesFile Members | EnC.Watcher Namespace


AspectRulesFile Members

AspectRulesFile overview

Public Instance Constructors

AspectRulesFile Constructor Initializes a new instance of the AspectRulesFile class.

Public Instance Properties

Enabled

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
instrument |
registerForChanges (inherited from FileWatcherCollection) | Registers a file to be watched.
setFileChangedDelegate | Sets the callback used to notify when a module has been recompiled.
ToString (inherited from Object) | Returns a String that represents the current Object.
unregisterForChanges (inherited from FileWatcherCollection) | Unregisters a file so its not watched anymore.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnFileChanged | Internal callback called by MyFileWatcher when a file is changed.

See Also

AspectRulesFile Class | EnC.Watcher Namespace


AspectRulesFile Constructor

Initializes a new instance of the AspectRulesFile class.

public AspectRulesFile();

See Also

AspectRulesFile Class | EnC.Watcher Namespace


AspectRulesFile Properties

The properties of the AspectRulesFile class are listed below. For a complete list of AspectRulesFile class members, see the AspectRulesFile Members topic.

Public Instance Properties

Enabled

See Also

AspectRulesFile Class | EnC.Watcher Namespace


Enabled Property

Goblin - A Platform for 3D AR and VR Applications

AspectRulesFile.Enabled Property

public bool Enabled {get;}

See Also

AspectRulesFile Class | EnC.Watcher Namespace


AspectRulesFile Methods

The methods of the AspectRulesFile class are listed below. For a complete list of AspectRulesFile class members, see the AspectRulesFile Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
instrument |
registerForChanges (inherited from FileWatcherCollection) | Registers a file to be watched.
setFileChangedDelegate | Sets the callback used to notify when a module has been recompiled.
ToString (inherited from Object) | Returns a String that represents the current Object.
unregisterForChanges (inherited from FileWatcherCollection) | Unregisters a file so its not watched anymore.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnFileChanged | Internal callback called by MyFileWatcher when a file is changed.

See Also

AspectRulesFile Class | EnC.Watcher Namespace


AspectRulesFile.instrument Method

public void instrument(
IGraph ig
);

Parameters

ig

See Also

AspectRulesFile Class | EnC.Watcher Namespace | instrument


AspectRulesFile.OnFileChanged Method

Internal callback called by MyFileWatcher when a file is changed.

protected override void OnFileChanged(
string path
);

Parameters

path
Path of changed file.

See Also

AspectRulesFile Class | EnC.Watcher Namespace


AspectRulesFile.setFileChangedDelegate Method

Sets the callback used to notify when a module has been recompiled.

public void setFileChangedDelegate(
OnChangedDelegate onFileChangedDelegate_ForClients
);

Parameters

onFileChangedDelegate_ForClients

See Also

AspectRulesFile Class | EnC.Watcher Namespace


DynModule Class

Watches a module's source files and recompiles the module if they change.

For a list of all members of this type, see DynModule Members.

System.Object
EnC.Watcher.FileWatcherCollection
EnC.Watcher.DynModule

public class DynModule : FileWatcherCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Aspects described in AspectRules.xml are weaved into the source files according to the aspect rules. Changes made to any of the aspect source files or AspectRules.xml will also trigger reloading the aspects, reweaving, and recompiling.

Requirements

Namespace: EnC.Watcher

Assembly: Watcher (in Watcher.exe)

See Also

DynModule Members | EnC.Watcher Namespace


DynModule Members

DynModule overview

Public Instance Constructors

DynModule Constructor Creates a dynamic module. Must call init() or readFromSocket() to initialize.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
init | Initializes the dynamic module.
readFromSocket | Reads initialization data from TCP/IP message sent from Patcher.
registerForChanges (inherited from FileWatcherCollection) | Registers a file to be watched.
setModuleUpdatedCallback | Sets the callback used to notify when a module has been recompiled.
ToString (inherited from Object) | Returns a String that represents the current Object.
unregisterForChanges (inherited from FileWatcherCollection) | Unregisters a file so its not watched anymore.
weaveAndCompile | Weaves aspects into the module source code and then compiles the weaved module.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnFileChanged | Internal callback called by MyFileWatcher when a file is changed.

See Also

DynModule Class | EnC.Watcher Namespace


DynModule Constructor

Creates a dynamic module. Must call init() or readFromSocket() to initialize.

public DynModule();

See Also

DynModule Class | EnC.Watcher Namespace


DynModule Methods

The methods of the DynModule class are listed below. For a complete list of DynModule class members, see the DynModule Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
init | Initializes the dynamic module.
readFromSocket | Reads initialization data from TCP/IP message sent from Patcher.
registerForChanges (inherited from FileWatcherCollection) | Registers a file to be watched.
setModuleUpdatedCallback | Sets the callback used to notify when a module has been recompiled.
ToString (inherited from Object) | Returns a String that represents the current Object.
unregisterForChanges (inherited from FileWatcherCollection) | Unregisters a file so its not watched anymore.
weaveAndCompile | Weaves aspects into the module source code and then compiles the weaved module.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnFileChanged | Internal callback called by MyFileWatcher when a file is changed.

See Also

DynModule Class | EnC.Watcher Namespace


DynModule.init Method

Initializes the dynamic module.

public void init(
uint moduleID,
string pathToOrigModule,
string compilerName,
string compilerOptions,
bool debugBuild,
string[] sources
);

Parameters

moduleID
Opaque ModuleID of the module. Sent from Patcher.
pathToOrigModule
Path to original module ("C:\blah\Hello.exe")
compilerName
Name of the command-line compiler ("csc.exe")
compilerOptions
Compiler options ("/debug Hello.cs")
debugBuild
Is this a debug build?
sources
Module's source files ("Hello.cs", "HelloHelper.cs")

See Also

DynModule Class | EnC.Watcher Namespace


DynModule.OnFileChanged Method

Internal callback called by MyFileWatcher when a file is changed.

protected override void OnFileChanged(
string path
);

Parameters

path
Path of changed file.

See Also

DynModule Class | EnC.Watcher Namespace


DynModule.readFromSocket Method

Reads initialization data from TCP/IP message sent from Patcher.

public bool readFromSocket(
Socket socket
);

Parameters

socket

Return Value

true if initialization data was read successfully

See Also

DynModule Class | EnC.Watcher Namespace


DynModule.setModuleUpdatedCallback Method

Sets the callback used to notify when a module has been recompiled.

public void setModuleUpdatedCallback(
OnModuleUpdatedDelegate onModuleUpdatedDelegate
);

Parameters

onModuleUpdatedDelegate

See Also

DynModule Class | EnC.Watcher Namespace


DynModule.weaveAndCompile Method

Weaves aspects into the module source code and then compiles the weaved module.

public void weaveAndCompile();

See Also

DynModule Class | EnC.Watcher Namespace


EnCProcess Class

Summary description for EnCProcess.

For a list of all members of this type, see EnCProcess Members.

System.Object
EnC.Watcher.EnCProcess

public class EnCProcess

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: EnC.Watcher

Assembly: Watcher (in Watcher.exe)

See Also

EnCProcess Members | EnC.Watcher Namespace


EnCProcess Members

EnCProcess overview

Public Instance Constructors

EnCProcess Constructor

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
StartProcess |
ToString (inherited from Object) | Returns a String that represents the current Object.
WaitUntilShutdownReceived |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EnCProcess Class | EnC.Watcher Namespace


EnCProcess Constructor

public EnCProcess(
int nPortToUse
);

See Also

EnCProcess Class | EnC.Watcher Namespace


EnCProcess Methods

The methods of the EnCProcess class are listed below. For a complete list of EnCProcess class members, see the EnCProcess Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
StartProcess |
ToString (inherited from Object) | Returns a String that represents the current Object.
WaitUntilShutdownReceived |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EnCProcess Class | EnC.Watcher Namespace


EnCProcess.StartProcess Method

public bool StartProcess(
string exeName,
string exeArgs
);

See Also

EnCProcess Class | EnC.Watcher Namespace


EnCProcess.WaitUntilShutdownReceived Method

public void WaitUntilShutdownReceived();

See Also

EnCProcess Class | EnC.Watcher Namespace


EnCSocketServer Class

Summary description for EnCSocketServer.

For a list of all members of this type, see EnCSocketServer Members.

System.Object
EnC.Watcher.EnCSocketServer

public class EnCSocketServer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: EnC.Watcher

Assembly: Watcher (in Watcher.exe)

See Also

EnCSocketServer Members | EnC.Watcher Namespace


EnCSocketServer Members

EnCSocketServer overview

Public Instance Constructors

EnCSocketServer Constructor

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ModuleUpdatedCallback | This is called by DynClass when a module has been updated. We need to send the module info to the Profiler.
StartListening |
StopAndWait | Shuts down everything. Call this if we are exiting.
ToString (inherited from Object) | Returns a String that represents the current Object.
WaitForShutdown | This is only called when we did not spawn the target process. Instead, the Profiler has spawned us. In this case, we should handle network communication until the Profiler eventually sends us a shutdown message.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EnCSocketServer Class | EnC.Watcher Namespace


EnCSocketServer Constructor

public EnCSocketServer(
int nPort,
bool bUseHeartbeat,
ModuleDelegate onGotModuleInfo
);

See Also

EnCSocketServer Class | EnC.Watcher Namespace


EnCSocketServer Methods

The methods of the EnCSocketServer class are listed below. For a complete list of EnCSocketServer class members, see the EnCSocketServer Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ModuleUpdatedCallback | This is called by DynClass when a module has been updated. We need to send the module info to the Profiler.
StartListening |
StopAndWait | Shuts down everything. Call this if we are exiting.
ToString (inherited from Object) | Returns a String that represents the current Object.
WaitForShutdown | This is only called when we did not spawn the target process. Instead, the Profiler has spawned us. In this case, we should handle network communication until the Profiler eventually sends us a shutdown message.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EnCSocketServer Class | EnC.Watcher Namespace


EnCSocketServer.ModuleUpdatedCallback Method

This is called by DynClass when a module has been updated. We need to send the module info to the Profiler.

public void ModuleUpdatedCallback(
uint moduleID,
string tmpModulePath
);

Parameters

moduleID
ModuleID that's been updated. Must be the same as the one we received from the Profiler.
tmpModulePath
Temporary path to the compiled executable.

See Also

EnCSocketServer Class | EnC.Watcher Namespace


EnCSocketServer.StartListening Method

public void StartListening();

See Also

EnCSocketServer Class | EnC.Watcher Namespace


EnCSocketServer.StopAndWait Method

Shuts down everything. Call this if we are exiting.

public void StopAndWait();

See Also

EnCSocketServer Class | EnC.Watcher Namespace


EnCSocketServer.WaitForShutdown Method

This is only called when we did not spawn the target process. Instead, the Profiler has spawned us. In this case, we should handle network communication until the Profiler eventually sends us a shutdown message.

public void WaitForShutdown();

See Also

EnCSocketServer Class | EnC.Watcher Namespace


FileWatcherCollection Class

For a list of all members of this type, see FileWatcherCollection Members.

System.Object
EnC.Watcher.FileWatcherCollection
EnC.Watcher.AspectRulesFile
EnC.Watcher.DynModule

public class FileWatcherCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: EnC.Watcher

Assembly: Watcher (in Watcher.exe)

See Also

FileWatcherCollection Members | EnC.Watcher Namespace


FileWatcherCollection Members

FileWatcherCollection overview

Public Instance Constructors

FileWatcherCollection Constructor Initializes a new instance of the FileWatcherCollection class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
registerForChanges | Registers a file to be watched.
ToString (inherited from Object) | Returns a String that represents the current Object.
unregisterForChanges | Unregisters a file so its not watched anymore.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnFileChanged | Internal callback called by MyFileWatcher when a file is changed.

See Also

FileWatcherCollection Class | EnC.Watcher Namespace


FileWatcherCollection Constructor

Initializes a new instance of the FileWatcherCollection class.

public FileWatcherCollection();

See Also

FileWatcherCollection Class | EnC.Watcher Namespace


FileWatcherCollection Methods

The methods of the FileWatcherCollection class are listed below. For a complete list of FileWatcherCollection class members, see the FileWatcherCollection Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
registerForChanges | Registers a file to be watched.
ToString (inherited from Object) | Returns a String that represents the current Object.
unregisterForChanges | Unregisters a file so its not watched anymore.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnFileChanged | Internal callback called by MyFileWatcher when a file is changed.

See Also

FileWatcherCollection Class | EnC.Watcher Namespace


FileWatcherCollection.OnFileChanged Method

Internal callback called by MyFileWatcher when a file is changed.

protected virtual void OnFileChanged(
string path
);

Parameters

path
Path of changed file.

See Also

FileWatcherCollection Class | EnC.Watcher Namespace


FileWatcherCollection.registerForChanges Method

Registers a file to be watched.

public void registerForChanges(
string filename
);

Parameters

filename

See Also

FileWatcherCollection Class | EnC.Watcher Namespace


FileWatcherCollection.unregisterForChanges Method

Unregisters a file so its not watched anymore.

public void unregisterForChanges(
string filename
);

Parameters

filename

See Also

FileWatcherCollection Class | EnC.Watcher Namespace


Helper Class

Holder of some helper functions.

For a list of all members of this type, see Helper Members.

System.Object
EnC.Watcher.Helper

public class Helper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: EnC.Watcher

Assembly: Watcher (in Watcher.exe)

See Also

Helper Members | EnC.Watcher Namespace


Helper Members

Helper overview

Public Static Methods

CreateInstance | Creates an instance of the type whose name is specified, using the named assembly and default constructor (same as Activator.CreateInstance). For some reason, Activator.CreateInstance() didn't work.
GetGraph | Parses a C# source file into an ANTLR IGraph abstract syntax tree.
GetType | Overloaded. Obtains the Type for a string. Type.GetType(string) is supposed to do this exact thing but it doesn't work.
ReflectGetProperty | Calls the getter method for a Property of type string via Reflection.

Public Instance Constructors

Helper Constructor Initializes a new instance of the Helper class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Overloaded. Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Helper Class | EnC.Watcher Namespace


Helper Constructor

Initializes a new instance of the Helper class.

public Helper();

See Also

Helper Class | EnC.Watcher Namespace


Helper Methods

The methods of the Helper class are listed below. For a complete list of Helper class members, see the Helper Members topic.

Public Static Methods

CreateInstance | Creates an instance of the type whose name is specified, using the named assembly and default constructor (same as Activator.CreateInstance). For some reason, Activator.CreateInstance() didn't work.
GetGraph | Parses a C# source file into an ANTLR IGraph abstract syntax tree.
GetType | Overloaded. Obtains the Type for a string. Type.GetType(string) is supposed to do this exact thing but it doesn't work.
ReflectGetProperty | Calls the getter method for a Property of type string via Reflection.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Overloaded. Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Helper Class | EnC.Watcher Namespace


Helper.CreateInstance Method

Creates an instance of the type whose name is specified, using the named assembly and default constructor (same as Activator.CreateInstance). For some reason, Activator.CreateInstance() didn't work.

public static object CreateInstance(
string assemblyName,
string typeName
);

Parameters

assemblyName
Name of the assembly (without .dll) or full path to the assembly (with .dll).
typeName
Name of the type to create.

Return Value

See Also

Helper Class | EnC.Watcher Namespace


Helper.GetGraph Method

Parses a C# source file into an ANTLR IGraph abstract syntax tree.

public static IGraph GetGraph(
string path
);

Parameters

path
Path to source file.

Return Value

ANTLR IGraph abstract syntax tree.

See Also

Helper Class | EnC.Watcher Namespace


GetType Method

Goblin - A Platform for 3D AR and VR Applications

Helper.GetType Method

Obtains the Type for a string. Type.GetType(string) is supposed to do this exact thing but it doesn't work.

Overload List

Inherited from Object.

public Type GetType();

Obtains the Type for a string. Type.GetType(string) is supposed to do this exact thing but it doesn't work.

public static Type GetType(string);

See Also

Helper Class | EnC.Watcher Namespace


Helper.GetType Method (String)

Obtains the Type for a string. Type.GetType(string) is supposed to do this exact thing but it doesn't work.

public static Type GetType(
string typeName
);

Parameters

typeName

Return Value

See Also

Helper Class | EnC.Watcher Namespace | Helper.GetType Overload List


Helper.ReflectGetProperty Method

Calls the getter method for a Property of type string via Reflection.

public static string ReflectGetProperty(
IGraph ig,
string propertyName
);

Parameters

ig
IGraph element whose Property we want to retrieve.
propertyName
Name of the Property. Note: Property must be of type string.

Return Value

Value returned by the Property getter method.

See Also

Helper Class | EnC.Watcher Namespace


IGraphMatch Class

For a list of all members of this type, see IGraphMatch Members.

System.Object
EnC.Watcher.IGraphMatch

public class IGraphMatch

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: EnC.Watcher

Assembly: Watcher (in Watcher.exe)

See Also

IGraphMatch Members | EnC.Watcher Namespace


IGraphMatch Members

IGraphMatch overview

Public Instance Constructors

IGraphMatch Constructor

Public Instance Fields

match
parent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IGraphMatch Class | EnC.Watcher Namespace


IGraphMatch Constructor

public IGraphMatch(
IGraph parent,
IGraph match
);

See Also

IGraphMatch Class | EnC.Watcher Namespace


IGraphMatch Fields

The fields of the IGraphMatch class are listed below. For a complete list of IGraphMatch class members, see the IGraphMatch Members topic.

Public Instance Fields

match
parent

See Also

IGraphMatch Class | EnC.Watcher Namespace


IGraphMatch.match Field

public IGraph match;

See Also

IGraphMatch Class | EnC.Watcher Namespace


IGraphMatch.parent Field

public IGraph parent;

See Also

IGraphMatch Class | EnC.Watcher Namespace


ModuleDelegate Delegate

public delegate void ModuleDelegate(
DynModule dynModule
);

Requirements

Namespace: EnC.Watcher

Assembly: Watcher (in Watcher.exe)

See Also

EnC.Watcher Namespace


MyFileWatcher Class

For a list of all members of this type, see MyFileWatcher Members.

System.Object
EnC.Watcher.MyFileWatcher

public class MyFileWatcher

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: EnC.Watcher

Assembly: Watcher (in Watcher.exe)

See Also

MyFileWatcher Members | EnC.Watcher Namespace


MyFileWatcher Members

MyFileWatcher overview

Public Instance Constructors

MyFileWatcher Overloaded. Initializes a new instance of the MyFileWatcher class.

Public Instance Fields

_Changed
_path

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MyFileWatcher Class | EnC.Watcher Namespace


MyFileWatcher Constructor

Overload List

public MyFileWatcher(string);

public MyFileWatcher(string,OnChangedDelegate);

See Also

MyFileWatcher Class | EnC.Watcher Namespace


MyFileWatcher Constructor (String, OnChangedDelegate)

public MyFileWatcher(
string file,
OnChangedDelegate handlerOnChanged
);

See Also

MyFileWatcher Class | EnC.Watcher Namespace | MyFileWatcher Constructor Overload List


MyFileWatcher Constructor (String)

public MyFileWatcher(
string file
);

See Also

MyFileWatcher Class | EnC.Watcher Namespace | MyFileWatcher Constructor Overload List


MyFileWatcher Fields

The fields of the MyFileWatcher class are listed below. For a complete list of MyFileWatcher class members, see the MyFileWatcher Members topic.

Public Instance Fields

_Changed
_path

See Also

MyFileWatcher Class | EnC.Watcher Namespace


MyFileWatcher._Changed Field

public OnChangedDelegate _Changed;

See Also

MyFileWatcher Class | EnC.Watcher Namespace


MyFileWatcher._path Field

public string _path;

See Also

MyFileWatcher Class | EnC.Watcher Namespace


MyFileWatcher.OnChangedDelegate Delegate

public delegate void MyFileWatcher.OnChangedDelegate(
string fullPath
);

Requirements

Namespace: EnC.Watcher

Assembly: Watcher (in Watcher.exe)

See Also

EnC.Watcher Namespace


MyTrace Class

Summary description for MyTrace.

For a list of all members of this type, see MyTrace Members.

System.Object
EnC.Watcher.MyTrace

public class MyTrace

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: EnC.Watcher

Assembly: Watcher (in Watcher.exe)

See Also

MyTrace Members | EnC.Watcher Namespace


MyTrace Members

MyTrace overview

Public Static Fields

level

Public Static Methods

Log | Overloaded.
OutputDebugString |

Public Instance Constructors

MyTrace Constructor Initializes a new instance of the MyTrace class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MyTrace Class | EnC.Watcher Namespace


MyTrace Constructor

Initializes a new instance of the MyTrace class.

public MyTrace();

See Also

MyTrace Class | EnC.Watcher Namespace


MyTrace Fields

The fields of the MyTrace class are listed below. For a complete list of MyTrace class members, see the MyTrace Members topic.

Public Static Fields

level

See Also

MyTrace Class | EnC.Watcher Namespace


MyTrace.level Field

public static TraceSwitch level;

See Also

MyTrace Class | EnC.Watcher Namespace


MyTrace Methods

The methods of the MyTrace class are listed below. For a complete list of MyTrace class members, see the MyTrace Members topic.

Public Static Methods

Log | Overloaded.
OutputDebugString |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MyTrace Class | EnC.Watcher Namespace


Log Method

Goblin - A Platform for 3D AR and VR Applications

MyTrace.Log Method

Overload List

public static void Log(TraceLevel,string);

public static void Log(TraceLevel,string,params object[]);

See Also

MyTrace Class | EnC.Watcher Namespace


MyTrace.Log Method (TraceLevel, String)

public static void Log(
TraceLevel levelMessage,
string msg
);

See Also

MyTrace Class | EnC.Watcher Namespace | MyTrace.Log Overload List


MyTrace.Log Method (TraceLevel, String, Object[])

public static void Log(
TraceLevel levelMessage,
string format,
params object[] args
);

See Also

MyTrace Class | EnC.Watcher Namespace | MyTrace.Log Overload List


MyTrace.OutputDebugString Method

public static void OutputDebugString(
string message
);

See Also

MyTrace Class | EnC.Watcher Namespace


OnCompilerOptionFound Delegate

public delegate string OnCompilerOptionFound(
string options,
string optionName,
int start,
int length
);

Requirements

Namespace: EnC.Watcher

Assembly: Watcher (in Watcher.exe)

See Also

EnC.Watcher Namespace


OnModuleUpdatedDelegate Delegate

public delegate void OnModuleUpdatedDelegate(
uint moduleID,
string tmpModulePath
);

Requirements

Namespace: EnC.Watcher

Assembly: Watcher (in Watcher.exe)

See Also

EnC.Watcher Namespace


Pointcut Class

For a list of all members of this type, see Pointcut Members.

System.Object
EnC.Watcher.Pointcut

public class Pointcut

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: EnC.Watcher

Assembly: Watcher (in Watcher.exe)

See Also

Pointcut Members | EnC.Watcher Namespace


Pointcut Members

Pointcut overview

Public Instance Constructors

Pointcut Constructor Initializes a new instance of the Pointcut class.

Public Instance Fields

codeElementGraphType
codeElementTypeName
elementPattern

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
init |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Pointcut Class | EnC.Watcher Namespace


Pointcut Constructor

Initializes a new instance of the Pointcut class.

public Pointcut();

See Also

Pointcut Class | EnC.Watcher Namespace


Pointcut Fields

The fields of the Pointcut class are listed below. For a complete list of Pointcut class members, see the Pointcut Members topic.

Public Instance Fields

codeElementGraphType
codeElementTypeName
elementPattern

See Also

Pointcut Class | EnC.Watcher Namespace


Pointcut.codeElementGraphType Field

public GraphTypes codeElementGraphType;

See Also

Pointcut Class | EnC.Watcher Namespace


Pointcut.codeElementTypeName Field

public string codeElementTypeName;

See Also

Pointcut Class | EnC.Watcher Namespace


Pointcut.elementPattern Field

public string elementPattern;

See Also

Pointcut Class | EnC.Watcher Namespace


Pointcut Methods

The methods of the Pointcut class are listed below. For a complete list of Pointcut class members, see the Pointcut Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
init |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Pointcut Class | EnC.Watcher Namespace


Pointcut.init Method

public void init();

See Also

Pointcut Class | EnC.Watcher Namespace


ShutdownDelegate Delegate

public delegate void ShutdownDelegate();

Requirements

Namespace: EnC.Watcher

Assembly: Watcher (in Watcher.exe)

See Also

EnC.Watcher Namespace


Goblin.Apps

Goblin - A Platform for 3D AR and VR Applications

Goblin.Apps Namespace

Application plug-ins that are loaded by the Goblin Engine.

Namespace hierarchy

Classes

Class | Description
LigerHunter | Engine Sample Class


LigerHunter Class

Engine Sample Class

For a list of all members of this type, see LigerHunter Members.

System.Object
Goblin.Apps.LigerHunter

public class LigerHunter : IApp, IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Goblin.Apps

Assembly: Goblin.Apps.LigerHunter (in Goblin.Apps.LigerHunter.dll)

See Also

LigerHunter Members | Goblin.Apps Namespace


LigerHunter Members

LigerHunter overview

Public Instance Constructors

LigerHunter Constructor DEFAULT CTOR (does nothing)

Public Instance Methods

Dispose |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FrameMove | Called before rendering the next frame
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Init | Called by Goblin.Engine to allow application to cache the root of the Goblin.Engine object model and perform non-device-specific initialization.
initBoltTransformer |
initCameraTransformer |
initCrossBowTransformer |
initTrackerDriver |
reloadCrossbow | Creates a new bolt and attaches it to the crossbow
SceneGraphInit | Called each time the device is initialized
SceneGraphInited |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LigerHunter Class | Goblin.Apps Namespace


LigerHunter Constructor

DEFAULT CTOR (does nothing)

public LigerHunter();

See Also

LigerHunter Class | Goblin.Apps Namespace


LigerHunter Methods

The methods of the LigerHunter class are listed below. For a complete list of LigerHunter class members, see the LigerHunter Members topic.

Public Instance Methods

Dispose |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FrameMove | Called before rendering the next frame
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Init | Called by Goblin.Engine to allow application to cache the root of the Goblin.Engine object model and perform non-device-specific initialization.
initBoltTransformer |
initCameraTransformer |
initCrossBowTransformer |
initTrackerDriver |
reloadCrossbow | Creates a new bolt and attaches it to the crossbow
SceneGraphInit | Called each time the device is initialized
SceneGraphInited |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LigerHunter Class | Goblin.Apps Namespace


LigerHunter.Dispose Method

public void Dispose();

Implements

IDisposable.Dispose

See Also

LigerHunter Class | Goblin.Apps Namespace


LigerHunter.FrameMove Method

Called before rendering the next frame

public void FrameMove(
Device device,
float fps,
float elapsedTime
);

Parameters

device
fps
Current frames per second
elapsedTime
Time since last frame

Implements

IApp.FrameMove

Remarks

Implements IApp.FrameMove()

See Also

LigerHunter Class | Goblin.Apps Namespace


LigerHunter.Init Method

Called by Goblin.Engine to allow application to cache the root of the Goblin.Engine object model and perform non-device-specific initialization.

public void Init(
Engine engine
);

Parameters

engine
Root of the Goblin.Engine object model

Implements

IApp.Init

Remarks

Implements IApp.init()

See Also

LigerHunter Class | Goblin.Apps Namespace


LigerHunter.initBoltTransformer Method

public void initBoltTransformer();

See Also

LigerHunter Class | Goblin.Apps Namespace


LigerHunter.initCameraTransformer Method

public void initCameraTransformer();

See Also

LigerHunter Class | Goblin.Apps Namespace


LigerHunter.initCrossBowTransformer Method

public void initCrossBowTransformer();

See Also

LigerHunter Class | Goblin.Apps Namespace


LigerHunter.initTrackerDriver Method

public bool initTrackerDriver();

See Also

LigerHunter Class | Goblin.Apps Namespace


LigerHunter.reloadCrossbow Method

Creates a new bolt and attaches it to the crossbow

public void reloadCrossbow();

Parameters

Remarks

Called after each bolt is fired so that the crossbow always has a bolt in the barrel.

See Also

LigerHunter Class | Goblin.Apps Namespace


LigerHunter.SceneGraphInit Method

Called each time the device is initialized

public void SceneGraphInit(
Device theDevice
);

Parameters

theDevice

Implements

IApp.SceneGraphInit

Remarks

Implements IApp.initSceneGraph(). You must (re-)initialize all device-dependent objects or you'll get an exception during rendering.

See Also

LigerHunter Class | Goblin.Apps Namespace


LigerHunter.SceneGraphInited Method

public void SceneGraphInited(
Device device
);

Implements

IApp.SceneGraphInited

See Also

LigerHunter Class | Goblin.Apps Namespace


Goblin.Engine

Goblin - A Platform for 3D AR and VR Applications

Goblin.Engine Namespace

Namespace hierarchy

Classes

Class | Description
Engine | Engine Sample Class
Launcher |

Interfaces

Interface | Description
IApp |


Engine Class

Engine Sample Class

For a list of all members of this type, see Engine Members.

System.Object
Goblin.Engine.Engine

public class Engine : IFrameworkCallback, IDeviceCreation, IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Goblin.Engine

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

Engine Members | Goblin.Engine Namespace


Engine Members

Engine overview

Public Static Methods

CreateInstance | Creates an instance of the type whose name is specified, using the named assembly and default constructor (same as Activator.CreateInstance). For some reason, Activator.CreateInstance() didn't work.
Main | Entry point to the program. Initializes everything and goes into a message processing loop. Idle time is used to render the scene.

Public Instance Constructors

Engine Constructor DEFAULT CTOR

Public Instance Fields

dxFirstPersonCamera
inputMapper
nodeCamera
sampleFramework
sceneGraph
trackedCameraBtn
useTrackedCamera

Public Instance Methods

Dispose | Releases resources
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeApplication | Initializes the application
IsDeviceAcceptable | Called during device initialization, this code checks the device for some minimum set of capabilities, and rejects those that don't pass by returning false.
loadAppPlugin |
loadAppPlugins | Overloaded.
MasterMouseEventHandler |
MasterWndProcHandler | Before handling window messages, the sample framework passes incoming windows messages to the application through this callback function. If the application sets noFurtherProcessing to true, the sample framework will not process the message
ModifyDeviceSettings | This callback function is called immediately before a device is created to allow the application to modify the device settings. The supplied settings parameter contains the settings that the framework has selected for the new device, and the application can make any desired changes directly to this structure. Note however that the sample framework will not correct invalid device settings so care must be taken to return valid device settings, otherwise creating the Device will fail.
OnFrameMove | This callback function will be called once at the beginning of every frame. This is the best location for your application to handle updates to the scene, but is not intended to contain actual rendering calls, which should instead be placed in the OnFrameRender callback.
OnFrameRender | This callback function will be called at the end of every frame to perform all the rendering calls for the scene, and it will also be called if the window needs to be repainted. After this function has returned, the sample framework will call Device.Present to display the contents of the next buffer in the swap chain
Run | Runs the application
Shutdown | Saves changed settings
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

keyEvent
mouseEvent
wndProcEvent

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Engine Class | Goblin.Engine Namespace


Engine Constructor

DEFAULT CTOR

public Engine();

See Also

Engine Class | Goblin.Engine Namespace


Engine Fields

The fields of the Engine class are listed below. For a complete list of Engine class members, see the Engine Members topic.

Public Instance Fields

dxFirstPersonCamera
inputMapper
nodeCamera
sampleFramework
sceneGraph
trackedCameraBtn
useTrackedCamera

See Also

Engine Class | Goblin.Engine Namespace


Engine.dxFirstPersonCamera Field

public FirstPersonCamera dxFirstPersonCamera;

See Also

Engine Class | Goblin.Engine Namespace


Engine.inputMapper Field

public InputDeviceMapper inputMapper;

See Also

Engine Class | Goblin.Engine Namespace


Engine.nodeCamera Field

public CameraNode nodeCamera;

See Also

Engine Class | Goblin.Engine Namespace


Engine.sampleFramework Field

public Framework sampleFramework;

See Also

Engine Class | Goblin.Engine Namespace


Engine.sceneGraph Field

public SceneGraph sceneGraph;

See Also

Engine Class | Goblin.Engine Namespace


Engine.trackedCameraBtn Field

public Button trackedCameraBtn;

See Also

Engine Class | Goblin.Engine Namespace


Engine.useTrackedCamera Field

public bool useTrackedCamera;

See Also

Engine Class | Goblin.Engine Namespace


Engine Methods

The methods of the Engine class are listed below. For a complete list of Engine class members, see the Engine Members topic.

Public Static Methods

CreateInstance | Creates an instance of the type whose name is specified, using the named assembly and default constructor (same as Activator.CreateInstance). For some reason, Activator.CreateInstance() didn't work.
Main | Entry point to the program. Initializes everything and goes into a message processing loop. Idle time is used to render the scene.

Public Instance Methods

Dispose | Releases resources
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeApplication | Initializes the application
IsDeviceAcceptable | Called during device initialization, this code checks the device for some minimum set of capabilities, and rejects those that don't pass by returning false.
loadAppPlugin |
loadAppPlugins | Overloaded.
MasterMouseEventHandler |
MasterWndProcHandler | Before handling window messages, the sample framework passes incoming windows messages to the application through this callback function. If the application sets noFurtherProcessing to true, the sample framework will not process the message
ModifyDeviceSettings | This callback function is called immediately before a device is created to allow the application to modify the device settings. The supplied settings parameter contains the settings that the framework has selected for the new device, and the application can make any desired changes directly to this structure. Note however that the sample framework will not correct invalid device settings so care must be taken to return valid device settings, otherwise creating the Device will fail.
OnFrameMove | This callback function will be called once at the beginning of every frame. This is the best location for your application to handle updates to the scene, but is not intended to contain actual rendering calls, which should instead be placed in the OnFrameRender callback.
OnFrameRender | This callback function will be called at the end of every frame to perform all the rendering calls for the scene, and it will also be called if the window needs to be repainted. After this function has returned, the sample framework will call Device.Present to display the contents of the next buffer in the swap chain
Run | Runs the application
Shutdown | Saves changed settings
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Engine Class | Goblin.Engine Namespace


Engine.CreateInstance Method

Creates an instance of the type whose name is specified, using the named assembly and default constructor (same as Activator.CreateInstance). For some reason, Activator.CreateInstance() didn't work.

public static object CreateInstance(
string assemblyName,
string typeName,
bool reportErrors
);

Parameters

assemblyName
Name of the assembly (without .dll) or full path to the assembly (with .dll).
typeName
Name of the type to create.
reportErrors

Return Value

See Also

Engine Class | Goblin.Engine Namespace


Engine.Dispose Method

Releases resources

public void Dispose();

Implements

IDisposable.Dispose

See Also

Engine Class | Goblin.Engine Namespace


Engine.InitializeApplication Method

Initializes the application

public void InitializeApplication(
Device device
);

See Also

Engine Class | Goblin.Engine Namespace


Engine.IsDeviceAcceptable Method

Called during device initialization, this code checks the device for some minimum set of capabilities, and rejects those that don't pass by returning false.

public bool IsDeviceAcceptable(
Caps caps,
Format adapterFormat,
Format backBufferFormat,
bool windowed
);

Implements

IDeviceCreation.IsDeviceAcceptable

See Also

Engine Class | Goblin.Engine Namespace


Engine.loadAppPlugin Method

public void loadAppPlugin(
string pathPlugin
);

See Also

Engine Class | Goblin.Engine Namespace


loadAppPlugins Method

Goblin - A Platform for 3D AR and VR Applications

Engine.loadAppPlugins Method

Overload List

public void loadAppPlugins();

public void loadAppPlugins(string);

See Also

Engine Class | Goblin.Engine Namespace


Engine.loadAppPlugins Method ()

public void loadAppPlugins();

See Also

Engine Class | Goblin.Engine Namespace | Engine.loadAppPlugins Overload List


Engine.loadAppPlugins Method (String)

public void loadAppPlugins(
string directory
);

See Also

Engine Class | Goblin.Engine Namespace | Engine.loadAppPlugins Overload List


Engine.Main Method

Entry point to the program. Initializes everything and goes into a message processing loop. Idle time is used to render the scene.

public static int Main();

See Also

Engine Class | Goblin.Engine Namespace


Engine.MasterMouseEventHandler Method

public void MasterMouseEventHandler(
bool leftButtonDown,
bool rightButtonDown,
bool middleButtonDown,
bool sideButton1Down,
bool sideButton2Down,
int mouseWheelDelta,
int x,
int y
);

See Also

Engine Class | Goblin.Engine Namespace


Engine.MasterWndProcHandler Method

Before handling window messages, the sample framework passes incoming windows messages to the application through this callback function. If the application sets noFurtherProcessing to true, the sample framework will not process the message

public IntPtr MasterWndProcHandler(
IntPtr hWnd,
WindowMessage msg,
IntPtr wParam,
IntPtr lParam,
ref bool noFurtherProcessing
);

See Also

Engine Class | Goblin.Engine Namespace


Engine.ModifyDeviceSettings Method

This callback function is called immediately before a device is created to allow the application to modify the device settings. The supplied settings parameter contains the settings that the framework has selected for the new device, and the application can make any desired changes directly to this structure. Note however that the sample framework will not correct invalid device settings so care must be taken to return valid device settings, otherwise creating the Device will fail.

public void ModifyDeviceSettings(
DeviceSettings settings,
Caps caps
);

Implements

IDeviceCreation.ModifyDeviceSettings

See Also

Engine Class | Goblin.Engine Namespace


Engine.OnFrameMove Method

This callback function will be called once at the beginning of every frame. This is the best location for your application to handle updates to the scene, but is not intended to contain actual rendering calls, which should instead be placed in the OnFrameRender callback.

public void OnFrameMove(
Device device,
double appTime,
float elapsedTime
);

Implements

IFrameworkCallback.OnFrameMove

See Also

Engine Class | Goblin.Engine Namespace


Engine.OnFrameRender Method

This callback function will be called at the end of every frame to perform all the rendering calls for the scene, and it will also be called if the window needs to be repainted. After this function has returned, the sample framework will call Device.Present to display the contents of the next buffer in the swap chain

public void OnFrameRender(
Device device,
double appTime,
float elapsedTime
);

Implements

IFrameworkCallback.OnFrameRender

See Also

Engine Class | Goblin.Engine Namespace


Engine.Run Method

Runs the application

public int Run();

Return Value

Exit code

Remarks

Make sure you call Run(), Shutdown() and then Dispose()

See Also

Engine Class | Goblin.Engine Namespace


Engine.Shutdown Method

Saves changed settings

public void Shutdown();

Remarks

Make sure you call Run(), Shutdown() and then Dispose()

See Also

Engine Class | Goblin.Engine Namespace


Engine Events

The events of the Engine class are listed below. For a complete list of Engine class members, see the Engine Members topic.

Public Instance Events

keyEvent
mouseEvent
wndProcEvent

See Also

Engine Class | Goblin.Engine Namespace


Engine.keyEvent Event

public event KeyboardCallback keyEvent;

See Also

Engine Class | Goblin.Engine Namespace


Engine.mouseEvent Event

public event MouseCallback mouseEvent;

See Also

Engine Class | Goblin.Engine Namespace


Engine.wndProcEvent Event

public event WndProcCallback wndProcEvent;

See Also

Engine Class | Goblin.Engine Namespace


IApp Interface

For a list of all members of this type, see IApp Members.

public interface IApp : IDisposable

Types that implement IApp

Type | Description
LigerHunter | Engine Sample Class

Requirements

Namespace: Goblin.Engine

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

IApp Members | Goblin.Engine Namespace


IApp Members

IApp overview

Public Instance Methods

FrameMove
Init
SceneGraphInit
SceneGraphInited

See Also

IApp Interface | Goblin.Engine Namespace


IApp Methods

The methods of the IApp interface are listed below. For a complete list of IApp interface members, see the IApp Members topic.

Public Instance Methods

FrameMove
Init
SceneGraphInit
SceneGraphInited

See Also

IApp Interface | Goblin.Engine Namespace


IApp.FrameMove Method

void FrameMove(
Device device,
float fps,
float elapsedTime
);

See Also

IApp Interface | Goblin.Engine Namespace


IApp.Init Method

void Init(
Engine engine
);

See Also

IApp Interface | Goblin.Engine Namespace


IApp.SceneGraphInit Method

void SceneGraphInit(
Device device
);

See Also

IApp Interface | Goblin.Engine Namespace


IApp.SceneGraphInited Method

void SceneGraphInited(
Device device
);

See Also

IApp Interface | Goblin.Engine Namespace


Launcher Class

For a list of all members of this type, see Launcher Members.

System.Object
Goblin.Engine.Launcher

public class Launcher

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Goblin.Engine

Assembly: Goblin (in Goblin.exe)

See Also

Launcher Members | Goblin.Engine Namespace


Launcher Members

Launcher overview

Public Static Methods

Main Entry point to the program.

Public Instance Constructors

Launcher Constructor Initializes a new instance of the Launcher class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Launcher Class | Goblin.Engine Namespace


Launcher Constructor

Initializes a new instance of the Launcher class.

public Launcher();

See Also

Launcher Class | Goblin.Engine Namespace


Launcher Methods

The methods of the Launcher class are listed below. For a complete list of Launcher class members, see the Launcher Members topic.

Public Static Methods

Main Entry point to the program.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Launcher Class | Goblin.Engine Namespace


Launcher.Main Method

Entry point to the program.

public static int Main();

See Also

Launcher Class | Goblin.Engine Namespace


Goblin.Engine.Devices

Goblin - A Platform for 3D AR and VR Applications

Goblin.Engine.Devices Namespace

Namespace hierarchy

Classes

Class | Description
InputDevice | This is the class that a user of Goblin will deal with. Under the hood, this class wraps InputDriver, which in turn is subclassed for specific devices, such as InterSense 900, etc.
InputDevice_6DOF | Subclass of InputDevice, providing 6 degrees of freedom information about some data source
InputDeviceDriver | This is the base class for any provider of InputDevices Your driver inherits from this class, and provides one or more InputDevices via the addMappings function
InputDeviceMapper | This class performs two functions 1) it provides a mapping from string identifier to InputDevice, via its indexer 2) it contains a list of all InputDeviceDrivers, and serializes them when it itself is serialized
InterSense | Summary description for InterSense.
InterSense.ConnectionInfo |
InterSense.StationArray | Manages the array of stations. Uses lazy allocation to only allocate and update stations that are actually used.
InterSense.StationInfo | This class maintains a mapping of name->index, for use in serialization
InterSenseSocket | Summary description for InterSenseSocket.
InterSenseStation | Summary description for InterSenseStation.
ISDllBridge |
MyUdpClient | Helper class for accessing the Poll() method in UpdClient

Structures

Structure | Description
ISDllBridge.ISD_CAMERA_DATA_TYPE |
ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE |
ISDllBridge.ISD_STATION_INFO_TYPE |
ISDllBridge.ISD_STATION_STATE_TYPE |
ISDllBridge.ISD_TRACKER_DATA_TYPE |
ISDllBridge.ISD_TRACKER_DATA_TYPE.STATION_ARRAY |
ISDllBridge.ISD_TRACKER_INFO_TYPE |

Delegates

Delegate | Description
MatrixDelegate |
TransformDelegate |

Enumerations

Enumeration | Description
ISDllBridge.ISD_INTERFACE_TYPE |
ISDllBridge.ISD_SYSTEM_MODEL |
ISDllBridge.ISD_SYSTEM_TYPE |


InputDevice Class

This is the class that a user of Goblin will deal with. Under the hood, this class wraps InputDriver, which in turn is subclassed for specific devices, such as InterSense 900, etc.

For a list of all members of this type, see InputDevice Members.

System.Object
Goblin.Engine.Devices.InputDevice
Goblin.Engine.Devices.InputDevice_6DOF

public class InputDevice

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Goblin.Engine.Devices

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

InputDevice Members | Goblin.Engine.Devices Namespace


InputDevice Members

InputDevice overview

Public Instance Constructors

InputDevice Constructor Initializes a new instance of the InputDevice class.

Public Instance Fields

identifier

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InputDevice Class | Goblin.Engine.Devices Namespace


InputDevice Constructor

Initializes a new instance of the InputDevice class.

public InputDevice();

See Also

InputDevice Class | Goblin.Engine.Devices Namespace


InputDevice Fields

The fields of the InputDevice class are listed below. For a complete list of InputDevice class members, see the InputDevice Members topic.

Public Instance Fields

identifier

See Also

InputDevice Class | Goblin.Engine.Devices Namespace


InputDevice.identifier Field

public string identifier;

See Also

InputDevice Class | Goblin.Engine.Devices Namespace


InputDevice_6DOF Class

Subclass of InputDevice, providing 6 degrees of freedom information about some data source

For a list of all members of this type, see InputDevice_6DOF Members.

System.Object
Goblin.Engine.Devices.InputDevice
Goblin.Engine.Devices.InputDevice_6DOF
Goblin.Engine.Devices.InterSenseStation

public class InputDevice_6DOF : InputDevice

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Goblin.Engine.Devices

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

InputDevice_6DOF Members | Goblin.Engine.Devices Namespace


InputDevice_6DOF Members

InputDevice_6DOF overview

Public Instance Constructors

InputDevice_6DOF Constructor Initializes a new instance of the InputDevice_6DOF class.

Public Instance Fields

identifier (inherited from InputDevice)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetTransform |
GetTransformedAfter |
GetTransformedBefore |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Transform |
TransformAfter |
TransformBefore |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InputDevice_6DOF Class | Goblin.Engine.Devices Namespace


InputDevice_6DOF Constructor

Initializes a new instance of the InputDevice_6DOF class.

public InputDevice_6DOF();

See Also

InputDevice_6DOF Class | Goblin.Engine.Devices Namespace


InputDevice_6DOF Methods

The methods of the InputDevice_6DOF class are listed below. For a complete list of InputDevice_6DOF class members, see the InputDevice_6DOF Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetTransform |
GetTransformedAfter |
GetTransformedBefore |
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Transform |
TransformAfter |
TransformBefore |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InputDevice_6DOF Class | Goblin.Engine.Devices Namespace


InputDevice_6DOF.GetTransform Method

public virtual Matrix GetTransform();

See Also

InputDevice_6DOF Class | Goblin.Engine.Devices Namespace


InputDevice_6DOF.GetTransformedAfter Method

public virtual Matrix GetTransformedAfter(
Matrix inMat
);

See Also

InputDevice_6DOF Class | Goblin.Engine.Devices Namespace


InputDevice_6DOF.GetTransformedBefore Method

public virtual Matrix GetTransformedBefore(
Matrix inMat
);

See Also

InputDevice_6DOF Class | Goblin.Engine.Devices Namespace


InputDevice_6DOF.Transform Method

public virtual MatrixDelegate Transform();

See Also

InputDevice_6DOF Class | Goblin.Engine.Devices Namespace


InputDevice_6DOF.TransformAfter Method

public virtual TransformDelegate TransformAfter();

See Also

InputDevice_6DOF Class | Goblin.Engine.Devices Namespace


InputDevice_6DOF.TransformBefore Method

public virtual TransformDelegate TransformBefore();

See Also

InputDevice_6DOF Class | Goblin.Engine.Devices Namespace


InputDeviceDriver Class

This is the base class for any provider of InputDevices Your driver inherits from this class, and provides one or more InputDevices via the addMappings function

For a list of all members of this type, see InputDeviceDriver Members.

System.Object
Goblin.Engine.Devices.InputDeviceDriver
Goblin.Engine.Devices.InterSense

public abstract class InputDeviceDriver : IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Goblin.Engine.Devices

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

InputDeviceDriver Members | Goblin.Engine.Devices Namespace


InputDeviceDriver Members

InputDeviceDriver overview

Public Instance Constructors

InputDeviceDriver Constructor Initializes a new instance of the InputDeviceDriver class.

Public Instance Fields

identifier

Public Instance Methods

Dispose |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInputByName | This function returns the InputDevice corresponding to a name
GetType (inherited from Object) | Gets the Type of the current instance.
InitAfterDeserialization | This function is available in case your class needs to do additional work to completely restore its state after being deserialized
ToString (inherited from Object) | Returns a String that represents the current Object.
Update | Subclases should use this function to update all mapped inputs.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InputDeviceDriver Class | Goblin.Engine.Devices Namespace


InputDeviceDriver Constructor

Initializes a new instance of the InputDeviceDriver class.

public InputDeviceDriver();

See Also

InputDeviceDriver Class | Goblin.Engine.Devices Namespace


InputDeviceDriver Fields

The fields of the InputDeviceDriver class are listed below. For a complete list of InputDeviceDriver class members, see the InputDeviceDriver Members topic.

Public Instance Fields

identifier

See Also

InputDeviceDriver Class | Goblin.Engine.Devices Namespace


InputDeviceDriver.identifier Field

public string identifier;

See Also

InputDeviceDriver Class | Goblin.Engine.Devices Namespace


InputDeviceDriver Methods

The methods of the InputDeviceDriver class are listed below. For a complete list of InputDeviceDriver class members, see the InputDeviceDriver Members topic.

Public Instance Methods

Dispose |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInputByName | This function returns the InputDevice corresponding to a name
GetType (inherited from Object) | Gets the Type of the current instance.
InitAfterDeserialization | This function is available in case your class needs to do additional work to completely restore its state after being deserialized
ToString (inherited from Object) | Returns a String that represents the current Object.
Update | Subclases should use this function to update all mapped inputs.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InputDeviceDriver Class | Goblin.Engine.Devices Namespace


InputDeviceDriver.Dispose Method

public virtual void Dispose();

Implements

IDisposable.Dispose

See Also

InputDeviceDriver Class | Goblin.Engine.Devices Namespace


InputDeviceDriver.GetInputByName Method

This function returns the InputDevice corresponding to a name

public abstract InputDevice GetInputByName(
string input_uid
);

Parameters

input_uid

Return Value

See Also

InputDeviceDriver Class | Goblin.Engine.Devices Namespace


InputDeviceDriver.InitAfterDeserialization Method

This function is available in case your class needs to do additional work to completely restore its state after being deserialized

public virtual void InitAfterDeserialization();

See Also

InputDeviceDriver Class | Goblin.Engine.Devices Namespace


InputDeviceDriver.Update Method

Subclases should use this function to update all mapped inputs.

public abstract void Update(
float elapsed_seconds
);

Parameters

elapsed_seconds

See Also

InputDeviceDriver Class | Goblin.Engine.Devices Namespace


InputDeviceMapper Class

This class performs two functions 1) it provides a mapping from string identifier to InputDevice, via its indexer 2) it contains a list of all InputDeviceDrivers, and serializes them when it itself is serialized

For a list of all members of this type, see InputDeviceMapper Members.

System.Object
Goblin.Engine.Devices.InputDeviceMapper

public class InputDeviceMapper : ICustomSerialization, IInitAfterDeserialization, IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Goblin.Engine.Devices

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

InputDeviceMapper Members | Goblin.Engine.Devices Namespace


InputDeviceMapper Members

InputDeviceMapper overview

Public Static Methods

Deserialize This function is called by XmlSerializerHelper, if you choose to use it This returns a deserialized InputDeviceMapper. driverTypes is an array of all the types of driver you are interested in having 're-hydrated' from the XML file

Public Instance Constructors

InputDeviceMapper Constructor The InputDeviceMapper begins with no knowledge of drivers, you must add them either via Deserialize

Public Instance Fields

drivers

Public Instance Properties

HasChanged |
Item | main accessor for this class takes a unique device identifier string and returns the corresponding InputDeviceDriver (read only)

Public Instance Methods

Dispose |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
InitAfterDeserialization | Implementation of IInputAfterDeserialization
Serialize | Implementation of ICustomSerialization NOTE: do not try to use XmlSerializer.Serialize directly on this object this object has to run special code to deal with the homogeneous types in its list of InputDeviceDrivers
ToString | convenience method - prints out a list of the names of all drivers followed by a list of all inputs
Update | Call this from your main loop. This will update all the drivers that are mapped.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InputDeviceMapper Class | Goblin.Engine.Devices Namespace


InputDeviceMapper Constructor

The InputDeviceMapper begins with no knowledge of drivers, you must add them either via Deserialize

public InputDeviceMapper();

See Also

InputDeviceMapper Class | Goblin.Engine.Devices Namespace


InputDeviceMapper Fields

The fields of the InputDeviceMapper class are listed below. For a complete list of InputDeviceMapper class members, see the InputDeviceMapper Members topic.

Public Instance Fields

drivers

See Also

InputDeviceMapper Class | Goblin.Engine.Devices Namespace


InputDeviceMapper.drivers Field

public ArrayList drivers;

See Also

InputDeviceMapper Class | Goblin.Engine.Devices Namespace


InputDeviceMapper Properties

The properties of the InputDeviceMapper class are listed below. For a complete list of InputDeviceMapper class members, see the InputDeviceMapper Members topic.

Public Instance Properties

HasChanged |
Item | main accessor for this class takes a unique device identifier string and returns the corresponding InputDeviceDriver (read only)

See Also

InputDeviceMapper Class | Goblin.Engine.Devices Namespace


HasChanged Property

Goblin - A Platform for 3D AR and VR Applications

InputDeviceMapper.HasChanged Property

public bool HasChanged {get;}

See Also

InputDeviceMapper Class | Goblin.Engine.Devices Namespace


Item Property

Goblin - A Platform for 3D AR and VR Applications

InputDeviceMapper.Item Property

main accessor for this class takes a unique device identifier string and returns the corresponding InputDeviceDriver (read only)

public InputDeviceDriver this[
string device_id
] {get;}

See Also

InputDeviceMapper Class | Goblin.Engine.Devices Namespace


InputDeviceMapper Methods

The methods of the InputDeviceMapper class are listed below. For a complete list of InputDeviceMapper class members, see the InputDeviceMapper Members topic.

Public Static Methods

Deserialize This function is called by XmlSerializerHelper, if you choose to use it This returns a deserialized InputDeviceMapper. driverTypes is an array of all the types of driver you are interested in having 're-hydrated' from the XML file

Public Instance Methods

Dispose |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
InitAfterDeserialization | Implementation of IInputAfterDeserialization
Serialize | Implementation of ICustomSerialization NOTE: do not try to use XmlSerializer.Serialize directly on this object this object has to run special code to deal with the homogeneous types in its list of InputDeviceDrivers
ToString | convenience method - prints out a list of the names of all drivers followed by a list of all inputs
Update | Call this from your main loop. This will update all the drivers that are mapped.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InputDeviceMapper Class | Goblin.Engine.Devices Namespace


InputDeviceMapper.Deserialize Method

This function is called by XmlSerializerHelper, if you choose to use it This returns a deserialized InputDeviceMapper. driverTypes is an array of all the types of driver you are interested in having 're-hydrated' from the XML file

public static InputDeviceMapper Deserialize(
XmlReader reader,
Type[] driverTypes
);

Parameters

reader
driverTypes

Return Value

See Also

InputDeviceMapper Class | Goblin.Engine.Devices Namespace


InputDeviceMapper.Dispose Method

public void Dispose();

Implements

IDisposable.Dispose

See Also

InputDeviceMapper Class | Goblin.Engine.Devices Namespace


InputDeviceMapper.InitAfterDeserialization Method

Implementation of IInputAfterDeserialization

public void InitAfterDeserialization();

Implements

IInitAfterDeserialization.InitAfterDeserialization

See Also

InputDeviceMapper Class | Goblin.Engine.Devices Namespace


InputDeviceMapper.Serialize Method

Implementation of ICustomSerialization NOTE: do not try to use XmlSerializer.Serialize directly on this object this object has to run special code to deal with the homogeneous types in its list of InputDeviceDrivers

public void Serialize(
XmlWriter writer,
Type[] extraTypes
);

Parameters

writer
extraTypes

Implements

ICustomSerialization.Serialize

See Also

InputDeviceMapper Class | Goblin.Engine.Devices Namespace


InputDeviceMapper.ToString Method

convenience method - prints out a list of the names of all drivers followed by a list of all inputs

public override string ToString();

Return Value

See Also

InputDeviceMapper Class | Goblin.Engine.Devices Namespace


InputDeviceMapper.Update Method

Call this from your main loop. This will update all the drivers that are mapped.

public void Update(
float elapsed_seconds
);

Parameters

elapsed_seconds

See Also

InputDeviceMapper Class | Goblin.Engine.Devices Namespace


InterSense Class

Summary description for InterSense.

For a list of all members of this type, see InterSense Members.

System.Object
Goblin.Engine.Devices.InputDeviceDriver
Goblin.Engine.Devices.InterSense

public class InterSense : InputDeviceDriver

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Goblin.Engine.Devices

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

InterSense Members | Goblin.Engine.Devices Namespace


InterSense Members

InterSense overview

Public Static Fields

nINDEX_STATION_1
nINDEX_STATION_2_HAND
nINDEX_STATION_3_HMD
nINDEX_STATION_4_WIRELESS

Public Instance Constructors

InterSense Overloaded. Initializes a new instance of the InterSense class.

Public Instance Fields

connInfo
identifier (inherited from InputDeviceDriver)
stationInfo

Public Instance Methods

Dispose |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInputByName | Given a station name, returns the InputDevice that accesses its data
GetType (inherited from Object) | Gets the Type of the current instance.
Init |
InitAfterDeserialization | This gets called after deserialization
IsInited |
ToString (inherited from Object) | Returns a String that represents the current Object.
Update | Updates all its mapped inputs

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InterSense Class | Goblin.Engine.Devices Namespace


InterSense Constructor

Initializes a new instance of the InterSense class.

Overload List

Initializes a new instance of the InterSense class.

public InterSense();

public InterSense(string);

See Also

InterSense Class | Goblin.Engine.Devices Namespace


InterSense Constructor ()

Initializes a new instance of the InterSense class.

public InterSense();

See Also

InterSense Class | Goblin.Engine.Devices Namespace | InterSense Constructor Overload List


InterSense Constructor (String)

public InterSense(
string unique_identifier
);

See Also

InterSense Class | Goblin.Engine.Devices Namespace | InterSense Constructor Overload List


InterSense Fields

The fields of the InterSense class are listed below. For a complete list of InterSense class members, see the InterSense Members topic.

Public Static Fields

nINDEX_STATION_1
nINDEX_STATION_2_HAND
nINDEX_STATION_3_HMD
nINDEX_STATION_4_WIRELESS

Public Instance Fields

connInfo
identifier (inherited from InputDeviceDriver)
stationInfo

See Also

InterSense Class | Goblin.Engine.Devices Namespace


InterSense.connInfo Field

public ConnectionInfo connInfo;

See Also

InterSense Class | Goblin.Engine.Devices Namespace


InterSense.nINDEX_STATION_1 Field

public const int nINDEX_STATION_1 = 0;

See Also

InterSense Class | Goblin.Engine.Devices Namespace


InterSense.nINDEX_STATION_2_HAND Field

public const int nINDEX_STATION_2_HAND = 1;

See Also

InterSense Class | Goblin.Engine.Devices Namespace


InterSense.nINDEX_STATION_3_HMD Field

public const int nINDEX_STATION_3_HMD = 2;

See Also

InterSense Class | Goblin.Engine.Devices Namespace


InterSense.nINDEX_STATION_4_WIRELESS Field

public const int nINDEX_STATION_4_WIRELESS = 3;

See Also

InterSense Class | Goblin.Engine.Devices Namespace


InterSense.StationInfo Class

This class maintains a mapping of name->index, for use in serialization

For a list of all members of this type, see InterSense.StationInfo Members.

System.Object
Goblin.Engine.Devices.InterSense.StationInfo

public class InterSense.StationInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Goblin.Engine.Devices

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

InterSense.StationInfo Members | Goblin.Engine.Devices Namespace


InterSense Methods

The methods of the InterSense class are listed below. For a complete list of InterSense class members, see the InterSense Members topic.

Public Instance Methods

Dispose |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetInputByName | Given a station name, returns the InputDevice that accesses its data
GetType (inherited from Object) | Gets the Type of the current instance.
Init |
InitAfterDeserialization | This gets called after deserialization
IsInited |
ToString (inherited from Object) | Returns a String that represents the current Object.
Update | Updates all its mapped inputs

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InterSense Class | Goblin.Engine.Devices Namespace


InterSense.Dispose Method

public override void Dispose();

Implements

IDisposable.Dispose

See Also

InterSense Class | Goblin.Engine.Devices Namespace


InterSense.GetInputByName Method

Given a station name, returns the InputDevice that accesses its data

public override InputDevice GetInputByName(
string input_uid
);

Parameters

input_uid

Return Value

See Also

InterSense Class | Goblin.Engine.Devices Namespace


InterSense.Init Method

public bool Init();

See Also

InterSense Class | Goblin.Engine.Devices Namespace


InterSense.InitAfterDeserialization Method

This gets called after deserialization

public override void InitAfterDeserialization();

Parameters

See Also

InterSense Class | Goblin.Engine.Devices Namespace


InterSense.IsInited Method

public bool IsInited();

See Also

InterSense Class | Goblin.Engine.Devices Namespace


InterSense.Update Method

Updates all its mapped inputs

public override void Update(
float elapsed_seconds
);

Parameters

elapsed_seconds

See Also

InterSense Class | Goblin.Engine.Devices Namespace


InterSense.ConnectionInfo Class

For a list of all members of this type, see InterSense.ConnectionInfo Members.

System.Object
Goblin.Engine.Devices.InterSense.ConnectionInfo

public class InterSense.ConnectionInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Goblin.Engine.Devices

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

InterSense.ConnectionInfo Members | Goblin.Engine.Devices Namespace


InterSense.ConnectionInfo Members

InterSense.ConnectionInfo overview

Public Instance Constructors

InterSense.ConnectionInfo Overloaded. Initializes a new instance of the InterSense.ConnectionInfo class.

Public Instance Fields

host
port
preferNetwork
tryBoth

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InterSense.ConnectionInfo Class | Goblin.Engine.Devices Namespace


InterSense.ConnectionInfo Constructor

Initializes a new instance of the InterSense.ConnectionInfo class.

Overload List

Initializes a new instance of the InterSense.ConnectionInfo class.

public InterSense.ConnectionInfo();

public InterSense.ConnectionInfo(string,int,bool,bool);

See Also

InterSense.ConnectionInfo Class | Goblin.Engine.Devices Namespace


InterSense.ConnectionInfo Constructor ()

Initializes a new instance of the InterSense.ConnectionInfo class.

public InterSense.ConnectionInfo();

See Also

InterSense.ConnectionInfo Class | Goblin.Engine.Devices Namespace | InterSense.ConnectionInfo Constructor Overload List


InterSense.ConnectionInfo Constructor (String, Int32, Boolean, Boolean)

public InterSense.ConnectionInfo(
string host,
int port,
bool preferNetwork,
bool tryBoth
);

See Also

InterSense.ConnectionInfo Class | Goblin.Engine.Devices Namespace | InterSense.ConnectionInfo Constructor Overload List


InterSense.ConnectionInfo Fields

The fields of the InterSense.ConnectionInfo class are listed below. For a complete list of InterSense.ConnectionInfo class members, see the InterSense.ConnectionInfo Members topic.

Public Instance Fields

host
port
preferNetwork
tryBoth

See Also

InterSense.ConnectionInfo Class | Goblin.Engine.Devices Namespace


InterSense.ConnectionInfo.host Field

public string host;

See Also

InterSense.ConnectionInfo Class | Goblin.Engine.Devices Namespace


InterSense.ConnectionInfo.port Field

public int port;

See Also

InterSense.ConnectionInfo Class | Goblin.Engine.Devices Namespace


InterSense.ConnectionInfo.preferNetwork Field

public bool preferNetwork;

See Also

InterSense.ConnectionInfo Class | Goblin.Engine.Devices Namespace


InterSense.ConnectionInfo.tryBoth Field

public bool tryBoth;

See Also

InterSense.ConnectionInfo Class | Goblin.Engine.Devices Namespace


InterSense.StationArray Class

Manages the array of stations. Uses lazy allocation to only allocate and update stations that are actually used.

For a list of all members of this type, see InterSense.StationArray Members.

System.Object
Goblin.Engine.Devices.InterSense.StationArray

public class InterSense.StationArray

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Goblin.Engine.Devices

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

InterSense.StationArray Members | Goblin.Engine.Devices Namespace


InterSense.StationArray Members

InterSense.StationArray overview

Public Instance Constructors

InterSense.StationArray Constructor

Public Instance Properties

Item

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
isActive |
SetData |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InterSense.StationArray Class | Goblin.Engine.Devices Namespace


InterSense.StationArray Constructor

public InterSense.StationArray(
StationInfo[] info
);

See Also

InterSense.StationArray Class | Goblin.Engine.Devices Namespace


InterSense.StationArray Properties

The properties of the InterSense.StationArray class are listed below. For a complete list of InterSense.StationArray class members, see the InterSense.StationArray Members topic.

Public Instance Properties

Item

See Also

InterSense.StationArray Class | Goblin.Engine.Devices Namespace


Item Property

Goblin - A Platform for 3D AR and VR Applications

InterSense.StationArray.Item Property

public InterSenseStation this[
long index
] {get;}

See Also

InterSense.StationArray Class | Goblin.Engine.Devices Namespace


InterSense.StationArray Methods

The methods of the InterSense.StationArray class are listed below. For a complete list of InterSense.StationArray class members, see the InterSense.StationArray Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
isActive |
SetData |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InterSense.StationArray Class | Goblin.Engine.Devices Namespace


InterSense.StationArray.isActive Method

public bool isActive(
long index
);

See Also

InterSense.StationArray Class | Goblin.Engine.Devices Namespace


InterSense.StationArray.SetData Method

public void SetData(
ISD_TRACKER_DATA_TYPE dataISense
);

See Also

InterSense.StationArray Class | Goblin.Engine.Devices Namespace


InterSense.StationInfo Members

InterSense.StationInfo overview

Public Instance Constructors

InterSense.StationInfo Overloaded. Initializes a new instance of the InterSense.StationInfo class.

Public Instance Fields

index
name
transform

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InterSense.StationInfo Class | Goblin.Engine.Devices Namespace


InterSense.StationInfo Constructor

Initializes a new instance of the InterSense.StationInfo class.

Overload List

Initializes a new instance of the InterSense.StationInfo class.

public InterSense.StationInfo();

public InterSense.StationInfo(string,int,Matrix);

See Also

InterSense.StationInfo Class | Goblin.Engine.Devices Namespace


InterSense.StationInfo Constructor ()

Initializes a new instance of the InterSense.StationInfo class.

public InterSense.StationInfo();

See Also

InterSense.StationInfo Class | Goblin.Engine.Devices Namespace | InterSense.StationInfo Constructor Overload List


InterSense.StationInfo Constructor (String, Int32, Matrix)

public InterSense.StationInfo(
string name,
int index,
Matrix headTransform
);

See Also

InterSense.StationInfo Class | Goblin.Engine.Devices Namespace | InterSense.StationInfo Constructor Overload List


InterSense.StationInfo Fields

The fields of the InterSense.StationInfo class are listed below. For a complete list of InterSense.StationInfo class members, see the InterSense.StationInfo Members topic.

Public Instance Fields

index
name
transform

See Also

InterSense.StationInfo Class | Goblin.Engine.Devices Namespace


InterSense.StationInfo.index Field

public long index;

See Also

InterSense.StationInfo Class | Goblin.Engine.Devices Namespace


InterSense.StationInfo.name Field

public string name;

See Also

InterSense.StationInfo Class | Goblin.Engine.Devices Namespace


InterSense.StationInfo.transform Field

public Matrix transform;

See Also

InterSense.StationInfo Class | Goblin.Engine.Devices Namespace


InterSenseSocket Class

Summary description for InterSenseSocket.

For a list of all members of this type, see InterSenseSocket Members.

System.Object
Goblin.Engine.Devices.InterSenseSocket

public class InterSenseSocket : IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Goblin.Engine.Devices

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

InterSenseSocket Members | Goblin.Engine.Devices Namespace


InterSenseSocket Members

InterSenseSocket overview

Public Instance Constructors

InterSenseSocket Constructor Initializes a new instance of the InterSenseSocket class.

Public Instance Methods

Close |
Connect |
Dispose |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetData |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsConnected |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

hasGottenData
hostname
sourcePoint
udp

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InterSenseSocket Class | Goblin.Engine.Devices Namespace


InterSenseSocket Constructor

Initializes a new instance of the InterSenseSocket class.

public InterSenseSocket();

See Also

InterSenseSocket Class | Goblin.Engine.Devices Namespace


InterSenseSocket Fields

The fields of the InterSenseSocket class are listed below. For a complete list of InterSenseSocket class members, see the InterSenseSocket Members topic.

Protected Instance Fields

hasGottenData
hostname
sourcePoint
udp

See Also

InterSenseSocket Class | Goblin.Engine.Devices Namespace


InterSenseSocket.hasGottenData Field

protected bool hasGottenData;

See Also

InterSenseSocket Class | Goblin.Engine.Devices Namespace


InterSenseSocket.hostname Field

protected string hostname;

See Also

InterSenseSocket Class | Goblin.Engine.Devices Namespace


InterSenseSocket.sourcePoint Field

protected IPEndPoint sourcePoint;

See Also

InterSenseSocket Class | Goblin.Engine.Devices Namespace


InterSenseSocket.udp Field

protected MyUdpClient udp;

See Also

InterSenseSocket Class | Goblin.Engine.Devices Namespace


InterSenseSocket Methods

The methods of the InterSenseSocket class are listed below. For a complete list of InterSenseSocket class members, see the InterSenseSocket Members topic.

Public Instance Methods

Close |
Connect |
Dispose |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetData |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsConnected |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InterSenseSocket Class | Goblin.Engine.Devices Namespace


InterSenseSocket.Close Method

public void Close();

See Also

InterSenseSocket Class | Goblin.Engine.Devices Namespace


InterSenseSocket.Connect Method

public bool Connect(
string server_hostname,
int server_port
);

See Also

InterSenseSocket Class | Goblin.Engine.Devices Namespace


InterSenseSocket.Dispose Method

public void Dispose();

Implements

IDisposable.Dispose

See Also

InterSenseSocket Class | Goblin.Engine.Devices Namespace


InterSenseSocket.GetData Method

public bool GetData(
StationArray stationArray,
out ISD_TRACKER_DATA_TYPE dataISense
);

See Also

InterSenseSocket Class | Goblin.Engine.Devices Namespace


InterSenseSocket.IsConnected Method

public bool IsConnected();

See Also

InterSenseSocket Class | Goblin.Engine.Devices Namespace


InterSenseStation Class

Summary description for InterSenseStation.

For a list of all members of this type, see InterSenseStation Members.

System.Object
Goblin.Engine.Devices.InputDevice
Goblin.Engine.Devices.InputDevice_6DOF
Goblin.Engine.Devices.InterSenseStation

public class InterSenseStation : InputDevice_6DOF

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Goblin.Engine.Devices

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

InterSenseStation Members | Goblin.Engine.Devices Namespace


InterSenseStation Members

InterSenseStation overview

Public Instance Constructors

InterSenseStation Constructor

Public Instance Fields

identifier (inherited from InputDevice)
matTRANSFORM_TRACKER2EYE
nStationIndex

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetTransform |
GetTransformedAfter (inherited from InputDevice_6DOF) |
GetTransformedBefore (inherited from InputDevice_6DOF) |
GetType (inherited from Object) | Gets the Type of the current instance.
SetData |
ToString (inherited from Object) | Returns a String that represents the current Object.
Transform (inherited from InputDevice_6DOF) |
TransformAfter (inherited from InputDevice_6DOF) |
TransformBefore (inherited from InputDevice_6DOF) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InterSenseStation Class | Goblin.Engine.Devices Namespace


InterSenseStation Constructor

public InterSenseStation(
long _nStationIndex,
Matrix tracker_to_eye_transform
);

See Also

InterSenseStation Class | Goblin.Engine.Devices Namespace


InterSenseStation Fields

The fields of the InterSenseStation class are listed below. For a complete list of InterSenseStation class members, see the InterSenseStation Members topic.

Public Instance Fields

identifier (inherited from InputDevice)
matTRANSFORM_TRACKER2EYE
nStationIndex

See Also

InterSenseStation Class | Goblin.Engine.Devices Namespace


InterSenseStation.matTRANSFORM_TRACKER2EYE Field

public Matrix matTRANSFORM_TRACKER2EYE;

See Also

InterSenseStation Class | Goblin.Engine.Devices Namespace


InterSenseStation.nStationIndex Field

public long nStationIndex;

See Also

InterSenseStation Class | Goblin.Engine.Devices Namespace


InterSenseStation Methods

The methods of the InterSenseStation class are listed below. For a complete list of InterSenseStation class members, see the InterSenseStation Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetTransform |
GetTransformedAfter (inherited from InputDevice_6DOF) |
GetTransformedBefore (inherited from InputDevice_6DOF) |
GetType (inherited from Object) | Gets the Type of the current instance.
SetData |
ToString (inherited from Object) | Returns a String that represents the current Object.
Transform (inherited from InputDevice_6DOF) |
TransformAfter (inherited from InputDevice_6DOF) |
TransformBefore (inherited from InputDevice_6DOF) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InterSenseStation Class | Goblin.Engine.Devices Namespace


InterSenseStation.GetTransform Method

public override Matrix GetTransform();

See Also

InterSenseStation Class | Goblin.Engine.Devices Namespace


InterSenseStation.SetData Method

public void SetData(
ISD_TRACKER_DATA_TYPE dataISense
);

See Also

InterSenseStation Class | Goblin.Engine.Devices Namespace


ISDllBridge Class

For a list of all members of this type, see ISDllBridge Members.

System.Object
Goblin.Engine.Devices.ISDllBridge

public class ISDllBridge

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Goblin.Engine.Devices

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

ISDllBridge Members | Goblin.Engine.Devices Namespace


ISDllBridge Members

ISDllBridge overview

Public Static Fields

ISD_DEFAULT_FRAME
ISD_EULER
ISD_MAX_AUX_INPUTS
ISD_MAX_AUX_OUTPUTS
ISD_MAX_BUTTONS
ISD_MAX_CHANNELS
ISD_MAX_STATIONS
ISD_MAX_TRACKERS
ISD_QUATERNION
ISD_VSET_FRAME

Public Static Methods

ISD_AuxOutput
ISD_Boresight
ISD_BoresightReferenced
ISD_CloseTracker
ISD_ConfigureFromFile
ISD_GetCameraData
ISD_GetCommInfo
ISD_GetData
ISD_GetStationConfig
ISD_GetTime
ISD_OpenAllTrackers
ISD_OpenTracker
ISD_ResetHeading
ISD_SendScript
ISD_SetStationConfig
ISD_SetTrackerConfig

Public Instance Constructors

ISDllBridge Constructor Initializes a new instance of the ISDllBridge class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ISDllBridge Class | Goblin.Engine.Devices Namespace


ISDllBridge Constructor

Initializes a new instance of the ISDllBridge class.

public ISDllBridge();

See Also

ISDllBridge Class | Goblin.Engine.Devices Namespace


ISDllBridge Fields

The fields of the ISDllBridge class are listed below. For a complete list of ISDllBridge class members, see the ISDllBridge Members topic.

Public Static Fields

ISD_DEFAULT_FRAME
ISD_EULER
ISD_MAX_AUX_INPUTS
ISD_MAX_AUX_OUTPUTS
ISD_MAX_BUTTONS
ISD_MAX_CHANNELS
ISD_MAX_STATIONS
ISD_MAX_TRACKERS
ISD_QUATERNION
ISD_VSET_FRAME

See Also

ISDllBridge Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_DEFAULT_FRAME Field

public const int ISD_DEFAULT_FRAME = 1;

See Also

ISDllBridge Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_EULER Field

public const int ISD_EULER = 1;

See Also

ISDllBridge Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_MAX_AUX_INPUTS Field

public const int ISD_MAX_AUX_INPUTS = 4;

See Also

ISDllBridge Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_MAX_AUX_OUTPUTS Field

public const int ISD_MAX_AUX_OUTPUTS = 4;

See Also

ISDllBridge Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_MAX_BUTTONS Field

public const int ISD_MAX_BUTTONS = 8;

See Also

ISDllBridge Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_MAX_CHANNELS Field

public const int ISD_MAX_CHANNELS = 10;

See Also

ISDllBridge Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_MAX_STATIONS Field

public const int ISD_MAX_STATIONS = 8;

See Also

ISDllBridge Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_MAX_TRACKERS Field

public const int ISD_MAX_TRACKERS = 8;

See Also

ISDllBridge Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_QUATERNION Field

public const int ISD_QUATERNION = 2;

See Also

ISDllBridge Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_VSET_FRAME Field

public const int ISD_VSET_FRAME = 2;

See Also

ISDllBridge Class | Goblin.Engine.Devices Namespace


ISDllBridge Methods

The methods of the ISDllBridge class are listed below. For a complete list of ISDllBridge class members, see the ISDllBridge Members topic.

Public Static Methods

ISD_AuxOutput
ISD_Boresight
ISD_BoresightReferenced
ISD_CloseTracker
ISD_ConfigureFromFile
ISD_GetCameraData
ISD_GetCommInfo
ISD_GetData
ISD_GetStationConfig
ISD_GetTime
ISD_OpenAllTrackers
ISD_OpenTracker
ISD_ResetHeading
ISD_SendScript
ISD_SetStationConfig
ISD_SetTrackerConfig

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ISDllBridge Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_AuxOutput Method

public static bool ISD_AuxOutput(
IntPtr handle,
short stationID,
out byte AuxOutput,
short length
);

See Also

ISDllBridge Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_Boresight Method

public static bool ISD_Boresight(
IntPtr handle,
short stationID,
bool setVal
);

See Also

ISDllBridge Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_BoresightReferenced Method

public static bool ISD_BoresightReferenced(
IntPtr handle,
short stationID,
float yaw,
float pitch,
float roll
);

See Also

ISDllBridge Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_CloseTracker Method

public static bool ISD_CloseTracker(
IntPtr handle
);

See Also

ISDllBridge Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_ConfigureFromFile Method

public static bool ISD_ConfigureFromFile(
IntPtr handle,
out string path,
bool verbose
);

See Also

ISDllBridge Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_GetCameraData Method

public static bool ISD_GetCameraData(
IntPtr handle,
out ISD_CAMERA_DATA_TYPE Data
);

See Also

ISDllBridge Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_GetCommInfo Method

public static bool ISD_GetCommInfo(
IntPtr handle,
out ISD_TRACKER_INFO_TYPE Tracker
);

See Also

ISDllBridge Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_GetData Method

public static bool ISD_GetData(
IntPtr handle,
out ISD_TRACKER_DATA_TYPE data
);

See Also

ISDllBridge Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_GetStationConfig Method

public static bool ISD_GetStationConfig(
IntPtr handle,
out ISD_STATION_INFO_TYPE Station,
short stationID,
bool verbose
);

See Also

ISDllBridge Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_GetTime Method

public static float ISD_GetTime();

See Also

ISDllBridge Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_OpenAllTrackers Method

public static uint ISD_OpenAllTrackers(
int hParent,
out IntPtr handle,
bool infoScreen,
bool verbose
);

See Also

ISDllBridge Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_OpenTracker Method

public static IntPtr ISD_OpenTracker(
IntPtr hParent,
ulong commPort,
bool infoScreen,
bool verbose
);

See Also

ISDllBridge Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_ResetHeading Method

public static bool ISD_ResetHeading(
IntPtr handle,
short stationID
);

See Also

ISDllBridge Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_SendScript Method

public static bool ISD_SendScript(
IntPtr handle,
out string script
);

See Also

ISDllBridge Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_SetStationConfig Method

public static bool ISD_SetStationConfig(
IntPtr handle,
ref ISD_STATION_INFO_TYPE Station,
short stationID,
bool verbose
);

See Also

ISDllBridge Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_SetTrackerConfig Method

public static bool ISD_SetTrackerConfig(
IntPtr handle,
out ISD_TRACKER_INFO_TYPE Tracker,
bool verbose
);

See Also

ISDllBridge Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_CAMERA_DATA_TYPE Structure

For a list of all members of this type, see ISDllBridge.ISD_CAMERA_DATA_TYPE Members.

System.Object
System.ValueType
Goblin.Engine.Devices.ISDllBridge.ISD_CAMERA_DATA_TYPE

public struct ISDllBridge.ISD_CAMERA_DATA_TYPE

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Goblin.Engine.Devices

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

ISDllBridge.ISD_CAMERA_DATA_TYPE Members | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_CAMERA_DATA_TYPE Members

ISDllBridge.ISD_CAMERA_DATA_TYPE overview

Public Instance Fields

Camera0
Camera1
Camera2
Camera3
Camera4
Camera5
Camera6
Camera7

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

ISDllBridge.ISD_CAMERA_DATA_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_CAMERA_DATA_TYPE Fields

The fields of the ISDllBridge.ISD_CAMERA_DATA_TYPE structure are listed below. For a complete list of ISDllBridge.ISD_CAMERA_DATA_TYPE structure members, see the ISDllBridge.ISD_CAMERA_DATA_TYPE Members topic.

Public Instance Fields

Camera0
Camera1
Camera2
Camera3
Camera4
Camera5
Camera6
Camera7

See Also

ISDllBridge.ISD_CAMERA_DATA_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_CAMERA_DATA_TYPE.Camera0 Field

public ISD_CAMERA_ENCODER_DATA_TYPE Camera0;

See Also

ISDllBridge.ISD_CAMERA_DATA_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_CAMERA_DATA_TYPE.Camera1 Field

public ISD_CAMERA_ENCODER_DATA_TYPE Camera1;

See Also

ISDllBridge.ISD_CAMERA_DATA_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_CAMERA_DATA_TYPE.Camera2 Field

public ISD_CAMERA_ENCODER_DATA_TYPE Camera2;

See Also

ISDllBridge.ISD_CAMERA_DATA_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_CAMERA_DATA_TYPE.Camera3 Field

public ISD_CAMERA_ENCODER_DATA_TYPE Camera3;

See Also

ISDllBridge.ISD_CAMERA_DATA_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_CAMERA_DATA_TYPE.Camera4 Field

public ISD_CAMERA_ENCODER_DATA_TYPE Camera4;

See Also

ISDllBridge.ISD_CAMERA_DATA_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_CAMERA_DATA_TYPE.Camera5 Field

public ISD_CAMERA_ENCODER_DATA_TYPE Camera5;

See Also

ISDllBridge.ISD_CAMERA_DATA_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_CAMERA_DATA_TYPE.Camera6 Field

public ISD_CAMERA_ENCODER_DATA_TYPE Camera6;

See Also

ISDllBridge.ISD_CAMERA_DATA_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_CAMERA_DATA_TYPE.Camera7 Field

public ISD_CAMERA_ENCODER_DATA_TYPE Camera7;

See Also

ISDllBridge.ISD_CAMERA_DATA_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE Structure

For a list of all members of this type, see ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE Members.

System.Object
System.ValueType
Goblin.Engine.Devices.ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE

public struct ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Goblin.Engine.Devices

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE Members | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE Members

ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE overview

Public Instance Fields

Aperture
ApertureEncoder
bReserved1
bReserved2
bReserved3
dwReserved1
dwReserved2
dwReserved3
dwReserved4
Focus
FocusEncoder
FOV
fReserved1
fReserved2
fReserved3
fReserved4
lReserved1
lReserved2
lReserved3
lReserved4
NodalPoint
Timecode
TimecodeUserBits
TrackingStatus
ZoomEncoder

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE Fields

The fields of the ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE structure are listed below. For a complete list of ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE structure members, see the ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE Members topic.

Public Instance Fields

Aperture
ApertureEncoder
bReserved1
bReserved2
bReserved3
dwReserved1
dwReserved2
dwReserved3
dwReserved4
Focus
FocusEncoder
FOV
fReserved1
fReserved2
fReserved3
fReserved4
lReserved1
lReserved2
lReserved3
lReserved4
NodalPoint
Timecode
TimecodeUserBits
TrackingStatus
ZoomEncoder

See Also

ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE.Aperture Field

public float Aperture;

See Also

ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE.ApertureEncoder Field

public int ApertureEncoder;

See Also

ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE.bReserved1 Field

public byte bReserved1;

See Also

ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE.bReserved2 Field

public byte bReserved2;

See Also

ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE.bReserved3 Field

public byte bReserved3;

See Also

ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE.dwReserved1 Field

public uint dwReserved1;

See Also

ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE.dwReserved2 Field

public uint dwReserved2;

See Also

ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE.dwReserved3 Field

public uint dwReserved3;

See Also

ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE.dwReserved4 Field

public uint dwReserved4;

See Also

ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE.Focus Field

public float Focus;

See Also

ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE.FocusEncoder Field

public int FocusEncoder;

See Also

ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE.FOV Field

public float FOV;

See Also

ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE.fReserved1 Field

public float fReserved1;

See Also

ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE.fReserved2 Field

public float fReserved2;

See Also

ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE.fReserved3 Field

public float fReserved3;

See Also

ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE.fReserved4 Field

public float fReserved4;

See Also

ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE.lReserved1 Field

public int lReserved1;

See Also

ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE.lReserved2 Field

public int lReserved2;

See Also

ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE.lReserved3 Field

public int lReserved3;

See Also

ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE.lReserved4 Field

public int lReserved4;

See Also

ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE.NodalPoint Field

public float NodalPoint;

See Also

ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE.Timecode Field

public uint Timecode;

See Also

ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE.TimecodeUserBits Field

public uint TimecodeUserBits;

See Also

ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE.TrackingStatus Field

public byte TrackingStatus;

See Also

ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE.ZoomEncoder Field

public int ZoomEncoder;

See Also

ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_INTERFACE_TYPE Enumeration

public enum ISDllBridge.ISD_INTERFACE_TYPE

Members

Member Name | Description
ISD_INTERFACE_UNKNOWN |
ISD_INTERFACE_SERIAL |
ISD_INTERFACE_USB |
ISD_INTERFACE_ETHERNET_UDP |
ISD_INTERFACE_ETHERNET_TCP |
ISD_INTERFACE_IOCARD |
ISD_INTERFACE_PCMCIA |

Requirements

Namespace: Goblin.Engine.Devices

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_INFO_TYPE Structure

For a list of all members of this type, see ISDllBridge.ISD_STATION_INFO_TYPE Members.

System.Object
System.ValueType
Goblin.Engine.Devices.ISDllBridge.ISD_STATION_INFO_TYPE

public struct ISDllBridge.ISD_STATION_INFO_TYPE

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Goblin.Engine.Devices

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

ISDllBridge.ISD_STATION_INFO_TYPE Members | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_INFO_TYPE Members

ISDllBridge.ISD_STATION_INFO_TYPE overview

Public Instance Fields

AccelSensitivity
AngleFormat
bReserved1
bReserved3
bReserved4
Compass
CoordFrame
dwReserved3
dwReserved4
Enhancement
fReserved4
GetAuxInputs
GetCameraData
GetEncoderData
GetInputs
ID
InertiaCube
Prediction
Sensitivity
State
TimeStamped
TipOffset

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

ISDllBridge.ISD_STATION_INFO_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_INFO_TYPE Fields

The fields of the ISDllBridge.ISD_STATION_INFO_TYPE structure are listed below. For a complete list of ISDllBridge.ISD_STATION_INFO_TYPE structure members, see the ISDllBridge.ISD_STATION_INFO_TYPE Members topic.

Public Instance Fields

AccelSensitivity
AngleFormat
bReserved1
bReserved3
bReserved4
Compass
CoordFrame
dwReserved3
dwReserved4
Enhancement
fReserved4
GetAuxInputs
GetCameraData
GetEncoderData
GetInputs
ID
InertiaCube
Prediction
Sensitivity
State
TimeStamped
TipOffset

See Also

ISDllBridge.ISD_STATION_INFO_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_INFO_TYPE.AccelSensitivity Field

public uint AccelSensitivity;

See Also

ISDllBridge.ISD_STATION_INFO_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_INFO_TYPE.AngleFormat Field

public uint AngleFormat;

See Also

ISDllBridge.ISD_STATION_INFO_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_INFO_TYPE.bReserved1 Field

public int bReserved1;

See Also

ISDllBridge.ISD_STATION_INFO_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_INFO_TYPE.bReserved3 Field

public int bReserved3;

See Also

ISDllBridge.ISD_STATION_INFO_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_INFO_TYPE.bReserved4 Field

public int bReserved4;

See Also

ISDllBridge.ISD_STATION_INFO_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_INFO_TYPE.Compass Field

public int Compass;

See Also

ISDllBridge.ISD_STATION_INFO_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_INFO_TYPE.CoordFrame Field

public uint CoordFrame;

See Also

ISDllBridge.ISD_STATION_INFO_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_INFO_TYPE.dwReserved3 Field

public int dwReserved3;

See Also

ISDllBridge.ISD_STATION_INFO_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_INFO_TYPE.dwReserved4 Field

public int dwReserved4;

See Also

ISDllBridge.ISD_STATION_INFO_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_INFO_TYPE.Enhancement Field

public uint Enhancement;

See Also

ISDllBridge.ISD_STATION_INFO_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_INFO_TYPE.fReserved4 Field

public float fReserved4;

See Also

ISDllBridge.ISD_STATION_INFO_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_INFO_TYPE.GetAuxInputs Field

public int GetAuxInputs;

See Also

ISDllBridge.ISD_STATION_INFO_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_INFO_TYPE.GetCameraData Field

public int GetCameraData;

See Also

ISDllBridge.ISD_STATION_INFO_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_INFO_TYPE.GetEncoderData Field

public int GetEncoderData;

See Also

ISDllBridge.ISD_STATION_INFO_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_INFO_TYPE.GetInputs Field

public int GetInputs;

See Also

ISDllBridge.ISD_STATION_INFO_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_INFO_TYPE.ID Field

public uint ID;

See Also

ISDllBridge.ISD_STATION_INFO_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_INFO_TYPE.InertiaCube Field

public int InertiaCube;

See Also

ISDllBridge.ISD_STATION_INFO_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_INFO_TYPE.Prediction Field

public uint Prediction;

See Also

ISDllBridge.ISD_STATION_INFO_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_INFO_TYPE.Sensitivity Field

public uint Sensitivity;

See Also

ISDllBridge.ISD_STATION_INFO_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_INFO_TYPE.State Field

public int State;

See Also

ISDllBridge.ISD_STATION_INFO_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_INFO_TYPE.TimeStamped Field

public int TimeStamped;

See Also

ISDllBridge.ISD_STATION_INFO_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_INFO_TYPE.TipOffset Field

public float[] TipOffset;

See Also

ISDllBridge.ISD_STATION_INFO_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_STATE_TYPE Structure

For a list of all members of this type, see ISDllBridge.ISD_STATION_STATE_TYPE Members.

System.Object
System.ValueType
Goblin.Engine.Devices.ISDllBridge.ISD_STATION_STATE_TYPE

public struct ISDllBridge.ISD_STATION_STATE_TYPE

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Goblin.Engine.Devices

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

ISDllBridge.ISD_STATION_STATE_TYPE Members | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_STATE_TYPE Members

ISDllBridge.ISD_STATION_STATE_TYPE overview

Public Instance Fields

AnalogData
AuxInputs
bReserved3
ButtonState
CommIntegrity
dwReserved1
dwReserved2
dwReserved3
dwReserved4
fReserved2
fReserved3
fReserved4
lReserved2
lReserved3
lReserved4
NewData
Orientation
Position
StillTime
TimeStamp
TrackingStatus

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

ISDllBridge.ISD_STATION_STATE_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_STATE_TYPE Fields

The fields of the ISDllBridge.ISD_STATION_STATE_TYPE structure are listed below. For a complete list of ISDllBridge.ISD_STATION_STATE_TYPE structure members, see the ISDllBridge.ISD_STATION_STATE_TYPE Members topic.

Public Instance Fields

AnalogData
AuxInputs
bReserved3
ButtonState
CommIntegrity
dwReserved1
dwReserved2
dwReserved3
dwReserved4
fReserved2
fReserved3
fReserved4
lReserved2
lReserved3
lReserved4
NewData
Orientation
Position
StillTime
TimeStamp
TrackingStatus

See Also

ISDllBridge.ISD_STATION_STATE_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_STATE_TYPE.AnalogData Field

public short[] AnalogData;

See Also

ISDllBridge.ISD_STATION_STATE_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_STATE_TYPE.AuxInputs Field

public byte[] AuxInputs;

See Also

ISDllBridge.ISD_STATION_STATE_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_STATE_TYPE.bReserved3 Field

public byte bReserved3;

See Also

ISDllBridge.ISD_STATION_STATE_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_STATE_TYPE.ButtonState Field

public bool[] ButtonState;

See Also

ISDllBridge.ISD_STATION_STATE_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_STATE_TYPE.CommIntegrity Field

public byte CommIntegrity;

See Also

ISDllBridge.ISD_STATION_STATE_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_STATE_TYPE.dwReserved1 Field

public uint dwReserved1;

See Also

ISDllBridge.ISD_STATION_STATE_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_STATE_TYPE.dwReserved2 Field

public uint dwReserved2;

See Also

ISDllBridge.ISD_STATION_STATE_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_STATE_TYPE.dwReserved3 Field

public uint dwReserved3;

See Also

ISDllBridge.ISD_STATION_STATE_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_STATE_TYPE.dwReserved4 Field

public uint dwReserved4;

See Also

ISDllBridge.ISD_STATION_STATE_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_STATE_TYPE.fReserved2 Field

public float fReserved2;

See Also

ISDllBridge.ISD_STATION_STATE_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_STATE_TYPE.fReserved3 Field

public float fReserved3;

See Also

ISDllBridge.ISD_STATION_STATE_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_STATE_TYPE.fReserved4 Field

public float fReserved4;

See Also

ISDllBridge.ISD_STATION_STATE_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_STATE_TYPE.lReserved2 Field

public int lReserved2;

See Also

ISDllBridge.ISD_STATION_STATE_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_STATE_TYPE.lReserved3 Field

public int lReserved3;

See Also

ISDllBridge.ISD_STATION_STATE_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_STATE_TYPE.lReserved4 Field

public int lReserved4;

See Also

ISDllBridge.ISD_STATION_STATE_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_STATE_TYPE.NewData Field

public byte NewData;

See Also

ISDllBridge.ISD_STATION_STATE_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_STATE_TYPE.Orientation Field

public float[] Orientation;

See Also

ISDllBridge.ISD_STATION_STATE_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_STATE_TYPE.Position Field

public float[] Position;

See Also

ISDllBridge.ISD_STATION_STATE_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_STATE_TYPE.StillTime Field

public float StillTime;

See Also

ISDllBridge.ISD_STATION_STATE_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_STATE_TYPE.TimeStamp Field

public float TimeStamp;

See Also

ISDllBridge.ISD_STATION_STATE_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_STATION_STATE_TYPE.TrackingStatus Field

public byte TrackingStatus;

See Also

ISDllBridge.ISD_STATION_STATE_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_SYSTEM_MODEL Enumeration

public enum ISDllBridge.ISD_SYSTEM_MODEL

Members

Member Name | Description
ISD_UNKNOWN |
ISD_IS300 |
ISD_IS600 |
ISD_IS900 |
ISD_INTERTRAX |
ISD_INTERTRAX_2 |
ISD_INTERTRAX_LS |
ISD_INTERTRAX_LC |
ISD_ICUBE2 |
ISD_ICUBE2_PRO |
ISD_IS1200 |
ISD_ICUBE3 |

Requirements

Namespace: Goblin.Engine.Devices

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

Goblin.Engine.Devices Namespace


ISDllBridge.ISD_SYSTEM_TYPE Enumeration

public enum ISDllBridge.ISD_SYSTEM_TYPE

Members

Member Name | Description
ISD_NONE |
ISD_PRECISION_SERIES |
ISD_INTERTRAX_SERIES |

Requirements

Namespace: Goblin.Engine.Devices

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

Goblin.Engine.Devices Namespace


ISDllBridge.ISD_TRACKER_DATA_TYPE Structure

For a list of all members of this type, see ISDllBridge.ISD_TRACKER_DATA_TYPE Members.

System.Object
System.ValueType
Goblin.Engine.Devices.ISDllBridge.ISD_TRACKER_DATA_TYPE

public struct ISDllBridge.ISD_TRACKER_DATA_TYPE

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Goblin.Engine.Devices

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

ISDllBridge.ISD_TRACKER_DATA_TYPE Members | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_TRACKER_DATA_TYPE Members

ISDllBridge.ISD_TRACKER_DATA_TYPE overview

Public Instance Fields

Station

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

ISDllBridge.ISD_TRACKER_DATA_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_TRACKER_DATA_TYPE Fields

The fields of the ISDllBridge.ISD_TRACKER_DATA_TYPE structure are listed below. For a complete list of ISDllBridge.ISD_TRACKER_DATA_TYPE structure members, see the ISDllBridge.ISD_TRACKER_DATA_TYPE Members topic.

Public Instance Fields

Station

See Also

ISDllBridge.ISD_TRACKER_DATA_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_TRACKER_DATA_TYPE.Station Field

public STATION_ARRAY Station;

See Also

ISDllBridge.ISD_TRACKER_DATA_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_TRACKER_DATA_TYPE.STATION_ARRAY Structure

For a list of all members of this type, see ISDllBridge.ISD_TRACKER_DATA_TYPE.STATION_ARRAY Members.

System.Object
System.ValueType
Goblin.Engine.Devices.ISDllBridge.ISD_TRACKER_DATA_TYPE.STATION_ARRAY

public struct ISDllBridge.ISD_TRACKER_DATA_TYPE.STATION_ARRAY

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Goblin.Engine.Devices

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

ISDllBridge.ISD_TRACKER_DATA_TYPE.STATION_ARRAY Members | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_TRACKER_DATA_TYPE.STATION_ARRAY Members

ISDllBridge.ISD_TRACKER_DATA_TYPE.STATION_ARRAY overview

Public Instance Properties

Item

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

ISDllBridge.ISD_TRACKER_DATA_TYPE.STATION_ARRAY Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_TRACKER_DATA_TYPE.STATION_ARRAY Properties

The properties of the ISDllBridge.ISD_TRACKER_DATA_TYPE.STATION_ARRAY structure are listed below. For a complete list of ISDllBridge.ISD_TRACKER_DATA_TYPE.STATION_ARRAY structure members, see the ISDllBridge.ISD_TRACKER_DATA_TYPE.STATION_ARRAY Members topic.

Public Instance Properties

Item

See Also

ISDllBridge.ISD_TRACKER_DATA_TYPE.STATION_ARRAY Class | Goblin.Engine.Devices Namespace


Item Property

Goblin - A Platform for 3D AR and VR Applications

ISDllBridge.ISD_TRACKER_DATA_TYPE.STATION_ARRAY.Item Property

public ISDllBridge.ISD_STATION_STATE_TYPE this[
long index
] {get; set;}

See Also

ISDllBridge.ISD_TRACKER_DATA_TYPE.STATION_ARRAY Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_TRACKER_INFO_TYPE Structure

For a list of all members of this type, see ISDllBridge.ISD_TRACKER_INFO_TYPE Members.

System.Object
System.ValueType
Goblin.Engine.Devices.ISDllBridge.ISD_TRACKER_INFO_TYPE

public struct ISDllBridge.ISD_TRACKER_INFO_TYPE

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Goblin.Engine.Devices

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

ISDllBridge.ISD_TRACKER_INFO_TYPE Members | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_TRACKER_INFO_TYPE Members

ISDllBridge.ISD_TRACKER_INFO_TYPE overview

Public Instance Fields

bReserved2
bReserved3
bReserved4
dwReserved4
FirmwareRev
fReserved2
fReserved3
fReserved4
Interface
KBitsPerSec
LedEnable
LibVersion
Port
RecordsPerSec
SyncPhase
SyncRate
SyncState
TrackerModel
TrackerType
UltTimeout
UltVolume

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

ISDllBridge.ISD_TRACKER_INFO_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_TRACKER_INFO_TYPE Fields

The fields of the ISDllBridge.ISD_TRACKER_INFO_TYPE structure are listed below. For a complete list of ISDllBridge.ISD_TRACKER_INFO_TYPE structure members, see the ISDllBridge.ISD_TRACKER_INFO_TYPE Members topic.

Public Instance Fields

bReserved2
bReserved3
bReserved4
dwReserved4
FirmwareRev
fReserved2
fReserved3
fReserved4
Interface
KBitsPerSec
LedEnable
LibVersion
Port
RecordsPerSec
SyncPhase
SyncRate
SyncState
TrackerModel
TrackerType
UltTimeout
UltVolume

See Also

ISDllBridge.ISD_TRACKER_INFO_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_TRACKER_INFO_TYPE.bReserved2 Field

public int bReserved2;

See Also

ISDllBridge.ISD_TRACKER_INFO_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_TRACKER_INFO_TYPE.bReserved3 Field

public int bReserved3;

See Also

ISDllBridge.ISD_TRACKER_INFO_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_TRACKER_INFO_TYPE.bReserved4 Field

public int bReserved4;

See Also

ISDllBridge.ISD_TRACKER_INFO_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_TRACKER_INFO_TYPE.dwReserved4 Field

public uint dwReserved4;

See Also

ISDllBridge.ISD_TRACKER_INFO_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_TRACKER_INFO_TYPE.FirmwareRev Field

public float FirmwareRev;

See Also

ISDllBridge.ISD_TRACKER_INFO_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_TRACKER_INFO_TYPE.fReserved2 Field

public float fReserved2;

See Also

ISDllBridge.ISD_TRACKER_INFO_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_TRACKER_INFO_TYPE.fReserved3 Field

public float fReserved3;

See Also

ISDllBridge.ISD_TRACKER_INFO_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_TRACKER_INFO_TYPE.fReserved4 Field

public float fReserved4;

See Also

ISDllBridge.ISD_TRACKER_INFO_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_TRACKER_INFO_TYPE.Interface Field

public uint Interface;

See Also

ISDllBridge.ISD_TRACKER_INFO_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_TRACKER_INFO_TYPE.KBitsPerSec Field

public float KBitsPerSec;

See Also

ISDllBridge.ISD_TRACKER_INFO_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_TRACKER_INFO_TYPE.LedEnable Field

public int LedEnable;

See Also

ISDllBridge.ISD_TRACKER_INFO_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_TRACKER_INFO_TYPE.LibVersion Field

public float LibVersion;

See Also

ISDllBridge.ISD_TRACKER_INFO_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_TRACKER_INFO_TYPE.Port Field

public uint Port;

See Also

ISDllBridge.ISD_TRACKER_INFO_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_TRACKER_INFO_TYPE.RecordsPerSec Field

public uint RecordsPerSec;

See Also

ISDllBridge.ISD_TRACKER_INFO_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_TRACKER_INFO_TYPE.SyncPhase Field

public uint SyncPhase;

See Also

ISDllBridge.ISD_TRACKER_INFO_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_TRACKER_INFO_TYPE.SyncRate Field

public float SyncRate;

See Also

ISDllBridge.ISD_TRACKER_INFO_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_TRACKER_INFO_TYPE.SyncState Field

public uint SyncState;

See Also

ISDllBridge.ISD_TRACKER_INFO_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_TRACKER_INFO_TYPE.TrackerModel Field

public uint TrackerModel;

See Also

ISDllBridge.ISD_TRACKER_INFO_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_TRACKER_INFO_TYPE.TrackerType Field

public uint TrackerType;

See Also

ISDllBridge.ISD_TRACKER_INFO_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_TRACKER_INFO_TYPE.UltTimeout Field

public uint UltTimeout;

See Also

ISDllBridge.ISD_TRACKER_INFO_TYPE Class | Goblin.Engine.Devices Namespace


ISDllBridge.ISD_TRACKER_INFO_TYPE.UltVolume Field

public uint UltVolume;

See Also

ISDllBridge.ISD_TRACKER_INFO_TYPE Class | Goblin.Engine.Devices Namespace


MatrixDelegate Delegate

public delegate Matrix MatrixDelegate();

Requirements

Namespace: Goblin.Engine.Devices

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

Goblin.Engine.Devices Namespace


MyUdpClient Class

Helper class for accessing the Poll() method in UpdClient

For a list of all members of this type, see MyUdpClient Members.

System.Object
System.Net.Sockets.UdpClient
Goblin.Engine.Devices.MyUdpClient

public class MyUdpClient : UdpClient

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Goblin.Engine.Devices

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

MyUdpClient Members | Goblin.Engine.Devices Namespace


MyUdpClient Members

MyUdpClient overview

Public Instance Constructors

MyUdpClient Constructor

Public Instance Methods

Close (inherited from UdpClient) | Closes the UDP connection.
Connect (inherited from UdpClient) | Overloaded. Establishes a default remote host using the specified host name and port number.
DropMulticastGroup (inherited from UdpClient) | Overloaded. Leaves a multicast group.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
JoinMulticastGroup (inherited from UdpClient) | Overloaded. Adds a UdpClient to a multicast group.
PollForData |
Receive (inherited from UdpClient) | Returns a UDP datagram that was sent by a remote host.
Send (inherited from UdpClient) | Overloaded. Sends a UDP datagram to the host at the specified remote endpoint.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Active (inherited from UdpClient) | Gets or sets a value indicating whether a default remote host has been established.
Client (inherited from UdpClient) | Gets or sets the underlying network Socket.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MyUdpClient Class | Goblin.Engine.Devices Namespace


MyUdpClient Constructor

public MyUdpClient(
string hostname,
int port
);

See Also

MyUdpClient Class | Goblin.Engine.Devices Namespace


MyUdpClient Methods

The methods of the MyUdpClient class are listed below. For a complete list of MyUdpClient class members, see the MyUdpClient Members topic.

Public Instance Methods

Close (inherited from UdpClient) | Closes the UDP connection.
Connect (inherited from UdpClient) | Overloaded. Establishes a default remote host using the specified host name and port number.
DropMulticastGroup (inherited from UdpClient) | Overloaded. Leaves a multicast group.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
JoinMulticastGroup (inherited from UdpClient) | Overloaded. Adds a UdpClient to a multicast group.
PollForData |
Receive (inherited from UdpClient) | Returns a UDP datagram that was sent by a remote host.
Send (inherited from UdpClient) | Overloaded. Sends a UDP datagram to the host at the specified remote endpoint.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MyUdpClient Class | Goblin.Engine.Devices Namespace


MyUdpClient.PollForData Method

public bool PollForData(
int secs
);

See Also

MyUdpClient Class | Goblin.Engine.Devices Namespace


TransformDelegate Delegate

public delegate Matrix TransformDelegate(
Matrix mat
);

Requirements

Namespace: Goblin.Engine.Devices

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

Goblin.Engine.Devices Namespace


Goblin.Engine.Physics

Goblin - A Platform for 3D AR and VR Applications

Goblin.Engine.Physics Namespace

Namespace hierarchy

Classes

Class | Description
Collision | Summary description for CollisionInsurance.


Collision Class

Summary description for CollisionInsurance.

For a list of all members of this type, see Collision Members.

System.Object
Goblin.Engine.Physics.Collision

public class Collision

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Goblin.Engine.Physics

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

Collision Members | Goblin.Engine.Physics Namespace


Collision Members

Collision overview

Public Static Methods

BSinAABB
DoAABBBSIntersect
DoAABBIntersect
DoIntersect
DoMeshesIntersect
DoSphereRayIntersect
DoSpheresIntersect
IsCollision
IsRayColliding

Public Instance Constructors

Collision Constructor Initializes a new instance of the Collision class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Collision Class | Goblin.Engine.Physics Namespace


Collision Constructor

Initializes a new instance of the Collision class.

public Collision();

See Also

Collision Class | Goblin.Engine.Physics Namespace


Collision Methods

The methods of the Collision class are listed below. For a complete list of Collision class members, see the Collision Members topic.

Public Static Methods

BSinAABB
DoAABBBSIntersect
DoAABBIntersect
DoIntersect
DoMeshesIntersect
DoSphereRayIntersect
DoSpheresIntersect
IsCollision
IsRayColliding

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Collision Class | Goblin.Engine.Physics Namespace


Collision.BSinAABB Method

public static bool BSinAABB(
Vector3 min,
Vector3 max,
Vector3 center
);

See Also

Collision Class | Goblin.Engine.Physics Namespace


Collision.DoAABBBSIntersect Method

public static bool DoAABBBSIntersect(
Bounds bounds1,
Bounds bounds2
);

See Also

Collision Class | Goblin.Engine.Physics Namespace


Collision.DoAABBIntersect Method

public static bool DoAABBIntersect(
Bounds bounds1,
Bounds bounds2
);

See Also

Collision Class | Goblin.Engine.Physics Namespace


Collision.DoIntersect Method

public static bool DoIntersect(
Bounds bounds1,
Bounds bounds2
);

See Also

Collision Class | Goblin.Engine.Physics Namespace


Collision.DoMeshesIntersect Method

public static bool DoMeshesIntersect(
Node node1,
Vector3[] oldVerts,
Vector3[] newVerts,
Node node2,
out IntersectInformation closestHit
);

See Also

Collision Class | Goblin.Engine.Physics Namespace


Collision.DoSphereRayIntersect Method

public static bool DoSphereRayIntersect(
Vector3 center1,
float radius1,
Vector3 ray,
Vector3 dir
);

See Also

Collision Class | Goblin.Engine.Physics Namespace


Collision.DoSpheresIntersect Method

public static bool DoSpheresIntersect(
Bounds bounds1,
Bounds bounds2
);

See Also

Collision Class | Goblin.Engine.Physics Namespace


Collision.IsCollision Method

public static bool IsCollision(
Node node,
Bounds boundsNode,
Vector3[] oldVerts,
Vector3[] newVerts,
Node root,
bool stopAtFirstCollision,
out Node nodeHit,
out IntersectInformation closestHit
);

See Also

Collision Class | Goblin.Engine.Physics Namespace


Collision.IsRayColliding Method

public static bool IsRayColliding(
Node node,
Vector3 pos,
Vector3 dir,
Node root,
bool stopAtFirstCollision,
out Node nodeHit,
out IntersectInformation closestHit
);

See Also

Collision Class | Goblin.Engine.Physics Namespace


Goblin.Engine.Scene

Goblin - A Platform for 3D AR and VR Applications

Goblin.Engine.Scene Namespace

Namespace hierarchy

Classes

Class | Description
AccelerationTransformer | Moves an object by moving it forward in the direction it is pointing
Bounds |
CameraNode | Summary description for CameraNode.
ChaseAITransformer |
CollisionDamageControl | Handles object collisions by having the object "stick" to the object that it collided with.
CollisionSticker | Handles object collisions by having the object "stick" to the object that it collided with.
DamagableNode | Summary description for DamagableNode.
DamagingNode | Summary description for DamagableNode.
DXCameraTransformer | Summary description for DXCameraController.
IgnoreCollision | Handles collisions by ignoring them, allowing the object to pass through the other object. This is useful for objects that are controlled by a position tracker as opposed to an algorithm.
InverterTransformer |
MyMeshContainer | The mesh container class that will hold the animation data
Node | The frame that will hold mesh animation
SceneGraph | Summary description for SceneGraph.
TrackerTransformer |
Transformer | Controls the movement of an object in the scene over time. Subclasses will define specific 3D movement paths, e.g., movement in a straight line.
VelocityTransformer | Moves an object by moving it forward in the direction it is pointing
Xfrm |

Interfaces

Interface | Description
ICollisionListener | Interface for handling object collisions


AccelerationTransformer Class

Moves an object by moving it forward in the direction it is pointing

For a list of all members of this type, see AccelerationTransformer Members.

System.Object
Goblin.Engine.Scene.Transformer
Goblin.Engine.Scene.AccelerationTransformer

public class AccelerationTransformer : Transformer, ICollisionListener

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Goblin.Engine.Scene

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

AccelerationTransformer Members | Goblin.Engine.Scene Namespace


AccelerationTransformer Members

AccelerationTransformer overview

Public Instance Constructors

AccelerationTransformer Constructor

Public Instance Properties

Acceleration
Current (inherited from Transformer)
Velocity

Public Instance Methods

AddCollisionListener (inherited from Transformer) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FrameMove (inherited from Transformer) | Determines the new position for an object. If arriving at the new position would cause a collision, OnAfterCollisionDetection is called.
GetCollisionPosition (inherited from Transformer) |
GetDesiredPosition |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
OnBeforeCollided |
OnCollided |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AccelerationTransformer Class | Goblin.Engine.Scene Namespace


AccelerationTransformer Constructor

public AccelerationTransformer(
bool bStopOnCollision
);

See Also

AccelerationTransformer Class | Goblin.Engine.Scene Namespace


AccelerationTransformer Properties

The properties of the AccelerationTransformer class are listed below. For a complete list of AccelerationTransformer class members, see the AccelerationTransformer Members topic.

Public Instance Properties

Acceleration
Current (inherited from Transformer)
Velocity

See Also

AccelerationTransformer Class | Goblin.Engine.Scene Namespace


Acceleration Property

Goblin - A Platform for 3D AR and VR Applications

AccelerationTransformer.Acceleration Property

public Microsoft.DirectX.Vector3 Acceleration {get; set;}

See Also

AccelerationTransformer Class | Goblin.Engine.Scene Namespace


Velocity Property

Goblin - A Platform for 3D AR and VR Applications

AccelerationTransformer.Velocity Property

public Microsoft.DirectX.Vector3 Velocity {get; set;}

See Also

AccelerationTransformer Class | Goblin.Engine.Scene Namespace


AccelerationTransformer Methods

The methods of the AccelerationTransformer class are listed below. For a complete list of AccelerationTransformer class members, see the AccelerationTransformer Members topic.

Public Instance Methods

AddCollisionListener (inherited from Transformer) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FrameMove (inherited from Transformer) | Determines the new position for an object. If arriving at the new position would cause a collision, OnAfterCollisionDetection is called.
GetCollisionPosition (inherited from Transformer) |
GetDesiredPosition |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
OnBeforeCollided |
OnCollided |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AccelerationTransformer Class | Goblin.Engine.Scene Namespace


AccelerationTransformer.GetDesiredPosition Method

public override bool GetDesiredPosition(
Xfrm cur,
float elapsed,
ref Xfrm desired
);

See Also

AccelerationTransformer Class | Goblin.Engine.Scene Namespace


AccelerationTransformer.OnBeforeCollided Method

public void OnBeforeCollided(
Node node,
Node root,
Node nodeHit,
Xfrm old,
IntersectInformation intersect,
Xfrm desired
);

Implements

ICollisionListener.OnBeforeCollided

See Also

AccelerationTransformer Class | Goblin.Engine.Scene Namespace


AccelerationTransformer.OnCollided Method

public void OnCollided(
Node node,
Node root,
Node nodeHit,
Xfrm old,
Xfrm collided,
IntersectInformation intersect,
ref Xfrm desired
);

Implements

ICollisionListener.OnCollided

See Also

AccelerationTransformer Class | Goblin.Engine.Scene Namespace


Bounds Class

For a list of all members of this type, see Bounds Members.

System.Object
Goblin.Engine.Scene.Bounds

public class Bounds

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Goblin.Engine.Scene

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

Bounds Members | Goblin.Engine.Scene Namespace


Bounds Members

Bounds overview

Public Instance Constructors

Bounds Constructor Initializes a new instance of the Bounds class.

Public Instance Fields

boundingSphere |
center | Center of bounding sphere of object
max |
min |
radius | Radius of bounding sphere of object

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
getRandomPosition |
GetType (inherited from Object) | Gets the Type of the current instance.
set |
setAABB |
setSphere |
ToString (inherited from Object) | Returns a String that represents the current Object.
update | Overloaded.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Bounds Class | Goblin.Engine.Scene Namespace


Bounds Constructor

Initializes a new instance of the Bounds class.

public Bounds();

See Also

Bounds Class | Goblin.Engine.Scene Namespace


Bounds Fields

The fields of the Bounds class are listed below. For a complete list of Bounds class members, see the Bounds Members topic.

Public Instance Fields

boundingSphere |
center | Center of bounding sphere of object
max |
min |
radius | Radius of bounding sphere of object

See Also

Bounds Class | Goblin.Engine.Scene Namespace


Bounds.boundingSphere Field

public bool boundingSphere;

See Also

Bounds Class | Goblin.Engine.Scene Namespace


Bounds.center Field

Center of bounding sphere of object

public Vector3 center;

See Also

Bounds Class | Goblin.Engine.Scene Namespace


Bounds.max Field

public Vector3 max;

See Also

Bounds Class | Goblin.Engine.Scene Namespace


Bounds.min Field

public Vector3 min;

See Also

Bounds Class | Goblin.Engine.Scene Namespace


Bounds.radius Field

Radius of bounding sphere of object

public float radius;

See Also

Bounds Class | Goblin.Engine.Scene Namespace


Bounds Methods

The methods of the Bounds class are listed below. For a complete list of Bounds class members, see the Bounds Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
getRandomPosition |
GetType (inherited from Object) | Gets the Type of the current instance.
set |
setAABB |
setSphere |
ToString (inherited from Object) | Returns a String that represents the current Object.
update | Overloaded.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Bounds Class | Goblin.Engine.Scene Namespace


Bounds.getRandomPosition Method

public Vector3 getRandomPosition();

See Also

Bounds Class | Goblin.Engine.Scene Namespace


Bounds.set Method

public Bounds set(
Bounds that
);

See Also

Bounds Class | Goblin.Engine.Scene Namespace


Bounds.setAABB Method

public void setAABB(
Vector3 min,
Vector3 max
);

See Also

Bounds Class | Goblin.Engine.Scene Namespace


Bounds.setSphere Method

public void setSphere(
Vector3 center,
float radius
);

See Also

Bounds Class | Goblin.Engine.Scene Namespace


update Method

Goblin - A Platform for 3D AR and VR Applications

Bounds.update Method

Overload List

public void update(GraphicsStream,int);

public void update(Vector3[]);

See Also

Bounds Class | Goblin.Engine.Scene Namespace


Bounds.update Method (GraphicsStream, Int32)

public void update(
GraphicsStream vertStream,
int numVerts
);

See Also

Bounds Class | Goblin.Engine.Scene Namespace | Bounds.update Overload List


Bounds.update Method (Vector3[])

public void update(
Vector3[] vertices
);

See Also

Bounds Class | Goblin.Engine.Scene Namespace | Bounds.update Overload List


CameraNode Class

Summary description for CameraNode.

For a list of all members of this type, see CameraNode Members.

System.Object
Microsoft.DirectX.Direct3D.Frame
Goblin.Engine.Scene.Node
Goblin.Engine.Scene.CameraNode

public class CameraNode : Node

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Goblin.Engine.Scene

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

CameraNode Members | Goblin.Engine.Scene Namespace


CameraNode Members

CameraNode overview

Public Instance Constructors

CameraNode Constructor

Public Instance Properties

Animated (inherited from Node) | Is the node moving?
Bounds (inherited from Node) |
Collidable (inherited from Node) | check for collisions
CombinedTransformationMatrix (inherited from Node) |
FrameFirstChild (inherited from Microsoft.DirectX.Direct3D.Frame) |
FrameSibling (inherited from Microsoft.DirectX.Direct3D.Frame) |
HasMoved (inherited from Node) | Has the node moved since it last collided with something?
IsReal (inherited from Node) |
MeshContainer (inherited from Microsoft.DirectX.Direct3D.Frame) |
MyMeshCont (inherited from Node) | Contains the mesh for the node if it has one
Name (inherited from Microsoft.DirectX.Direct3D.Frame) |
Renderable (inherited from Node) | check for render
RenderRealAsBlack (inherited from Node) |
TransformationMatrix (inherited from Microsoft.DirectX.Direct3D.Frame) |
Transformer (inherited from Node) |

Public Instance Methods

AddXFile (inherited from Node) |
AddXFileData (inherited from Node) |
AppendChild (inherited from Node) | Overloaded.
CombineTransformations (inherited from Node) |
Dispose (inherited from Node) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
find (inherited from Node) |
findFirst (inherited from Node) |
FrameMove | Overloaded. Pass only the pos as the parentMatrix
FrameMove (inherited from Node) | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
getPosition (inherited from Node) |
GetType (inherited from Object) | Gets the Type of the current instance.
Render | Draw a frame and all child and sibling frames
RenderCollisionSphere (inherited from Node) |
RenderTrans (inherited from Node) |
setAllCollidable (inherited from Node) |
setAllRenderable (inherited from Node) |
setCollidable (inherited from Node) |
SetCombinedTransformations (inherited from Node) | Updates the combined transformation using the transformer
SetMesh (inherited from Node) |
setRenderable (inherited from Node) |
ToString (inherited from Node) | Overloaded. Update the frames matrices and combine it with it's parents

Protected Instance Methods

Finalize (inherited from Microsoft.DirectX.Direct3D.Frame) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CameraNode Class | Goblin.Engine.Scene Namespace


CameraNode Constructor

public CameraNode(
string name
);

See Also

CameraNode Class | Goblin.Engine.Scene Namespace


CameraNode Methods

The methods of the CameraNode class are listed below. For a complete list of CameraNode class members, see the CameraNode Members topic.

Public Instance Methods

AddXFile (inherited from Node) |
AddXFileData (inherited from Node) |
AppendChild (inherited from Node) | Overloaded.
CombineTransformations (inherited from Node) |
Dispose (inherited from Node) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
find (inherited from Node) |
findFirst (inherited from Node) |
FrameMove | Overloaded. Pass only the pos as the parentMatrix
FrameMove (inherited from Node) | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
getPosition (inherited from Node) |
GetType (inherited from Object) | Gets the Type of the current instance.
Render | Draw a frame and all child and sibling frames
RenderCollisionSphere (inherited from Node) |
RenderTrans (inherited from Node) |
setAllCollidable (inherited from Node) |
setAllRenderable (inherited from Node) |
setCollidable (inherited from Node) |
SetCombinedTransformations (inherited from Node) | Updates the combined transformation using the transformer
SetMesh (inherited from Node) |
setRenderable (inherited from Node) |
ToString (inherited from Node) | Overloaded. Update the frames matrices and combine it with it's parents

Protected Instance Methods

Finalize (inherited from Microsoft.DirectX.Direct3D.Frame) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CameraNode Class | Goblin.Engine.Scene Namespace


FrameMove Method

Goblin - A Platform for 3D AR and VR Applications

CameraNode.FrameMove Method

Pass only the pos as the parentMatrix

Overload List

Pass only the pos as the parentMatrix

public override void FrameMove(Node,Device,Matrix,float);

Inherited from Node.

public void FrameMove(Node,Device,float);

See Also

CameraNode Class | Goblin.Engine.Scene Namespace


CameraNode.FrameMove Method (Node, Device, Matrix, Single)

Pass only the pos as the parentMatrix

public override void FrameMove(
Node root,
Device device,
Matrix parentMatrix,
float elapsedTime
);

See Also

CameraNode Class | Goblin.Engine.Scene Namespace | CameraNode.FrameMove Overload List


CameraNode.Render Method

Draw a frame and all child and sibling frames

public override void Render(
Device device,
int pass
);

See Also

CameraNode Class | Goblin.Engine.Scene Namespace


ChaseAITransformer Class

For a list of all members of this type, see ChaseAITransformer Members.

System.Object
Goblin.Engine.Scene.Transformer
Goblin.Engine.Scene.ChaseAITransformer

public class ChaseAITransformer : Transformer, ICollisionListener

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Assumptions: for the underlying model, X is forward, Y is up, Z is left

Requirements

Namespace: Goblin.Engine.Scene

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

ChaseAITransformer Members | Goblin.Engine.Scene Namespace


ChaseAITransformer Members

ChaseAITransformer overview

Public Instance Constructors

ChaseAITransformer Constructor

Public Instance Properties

Current (inherited from Transformer) |
Speed | How fast the bot moves (m/s)
TurnSpeed | How well the bot corners (rad/s)
Waypoint | Current position we are moving towards

Public Instance Methods

AddCollisionListener (inherited from Transformer) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FrameMove | Called before each frame is rendered to allow us to update the position, state, etc. of the node
GetCollisionPosition (inherited from Transformer) |
GetDesiredPosition | Performs the physical motion
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
OnBeforeCollided |
OnCollided |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ChaseAITransformer Class | Goblin.Engine.Scene Namespace


ChaseAITransformer Constructor

public ChaseAITransformer(
Node _prey,
Bounds _spawnVolume
);

See Also

ChaseAITransformer Class | Goblin.Engine.Scene Namespace


ChaseAITransformer Properties

The properties of the ChaseAITransformer class are listed below. For a complete list of ChaseAITransformer class members, see the ChaseAITransformer Members topic.

Public Instance Properties

Current (inherited from Transformer) |
Speed | How fast the bot moves (m/s)
TurnSpeed | How well the bot corners (rad/s)
Waypoint | Current position we are moving towards

See Also

ChaseAITransformer Class | Goblin.Engine.Scene Namespace


Speed Property

Goblin - A Platform for 3D AR and VR Applications

ChaseAITransformer.Speed Property

How fast the bot moves (m/s)

public float Speed {get; set;}

See Also

ChaseAITransformer Class | Goblin.Engine.Scene Namespace


TurnSpeed Property

Goblin - A Platform for 3D AR and VR Applications

ChaseAITransformer.TurnSpeed Property

How well the bot corners (rad/s)

public float TurnSpeed {get; set;}

See Also

ChaseAITransformer Class | Goblin.Engine.Scene Namespace


Waypoint Property

Goblin - A Platform for 3D AR and VR Applications

ChaseAITransformer.Waypoint Property

Current position we are moving towards

public Microsoft.DirectX.Vector3 Waypoint {get;}

See Also

ChaseAITransformer Class | Goblin.Engine.Scene Namespace


ChaseAITransformer Methods

The methods of the ChaseAITransformer class are listed below. For a complete list of ChaseAITransformer class members, see the ChaseAITransformer Members topic.

Public Instance Methods

AddCollisionListener (inherited from Transformer) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FrameMove | Called before each frame is rendered to allow us to update the position, state, etc. of the node
GetCollisionPosition (inherited from Transformer) |
GetDesiredPosition | Performs the physical motion
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
OnBeforeCollided |
OnCollided |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ChaseAITransformer Class | Goblin.Engine.Scene Namespace


ChaseAITransformer.FrameMove Method

Called before each frame is rendered to allow us to update the position, state, etc. of the node

public override void FrameMove(
Node node,
Node root,
float elapsed
);

Parameters

node
Node being moved
root
Root node
elapsed
Time since last FrameMove (secs)

See Also

ChaseAITransformer Class | Goblin.Engine.Scene Namespace


ChaseAITransformer.GetDesiredPosition Method

Performs the physical motion

public override bool GetDesiredPosition(
Xfrm cur,
float elapsed,
ref Xfrm desired
);

See Also

ChaseAITransformer Class | Goblin.Engine.Scene Namespace


ChaseAITransformer.OnBeforeCollided Method

public void OnBeforeCollided(
Node node,
Node root,
Node nodeHit,
Xfrm old,
IntersectInformation intersect,
Xfrm desired
);

Implements

ICollisionListener.OnBeforeCollided

See Also

ChaseAITransformer Class | Goblin.Engine.Scene Namespace


ChaseAITransformer.OnCollided Method

public void OnCollided(
Node node,
Node root,
Node nodeHit,
Xfrm old,
Xfrm collided,
IntersectInformation intersect,
ref Xfrm desired
);

Implements

ICollisionListener.OnCollided

See Also

ChaseAITransformer Class | Goblin.Engine.Scene Namespace


CollisionDamageControl Class

Handles object collisions by having the object "stick" to the object that it collided with.

For a list of all members of this type, see CollisionDamageControl Members.

System.Object
Goblin.Engine.Scene.CollisionDamageControl

public class CollisionDamageControl : ICollisionListener

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Goblin.Engine.Scene

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

CollisionDamageControl Members | Goblin.Engine.Scene Namespace


CollisionDamageControl Members

CollisionDamageControl overview

Public Instance Constructors

CollisionDamageControl Constructor Initializes a new instance of the CollisionDamageControl class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
OnBeforeCollided |
OnCollided |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CollisionDamageControl Class | Goblin.Engine.Scene Namespace


CollisionDamageControl Constructor

Initializes a new instance of the CollisionDamageControl class.

public CollisionDamageControl();

See Also

CollisionDamageControl Class | Goblin.Engine.Scene Namespace


CollisionDamageControl Methods

The methods of the CollisionDamageControl class are listed below. For a complete list of CollisionDamageControl class members, see the CollisionDamageControl Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
OnBeforeCollided |
OnCollided |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CollisionDamageControl Class | Goblin.Engine.Scene Namespace


CollisionDamageControl.OnBeforeCollided Method

public void OnBeforeCollided(
Node node,
Node root,
Node nodeHit,
Xfrm old,
IntersectInformation intersect,
Xfrm desired
);

Implements

ICollisionListener.OnBeforeCollided

See Also

CollisionDamageControl Class | Goblin.Engine.Scene Namespace


CollisionDamageControl.OnCollided Method

public void OnCollided(
Node node,
Node root,
Node nodeHit,
Xfrm old,
Xfrm collided,
IntersectInformation intersect,
ref Xfrm desired
);

Implements

ICollisionListener.OnCollided

See Also

CollisionDamageControl Class | Goblin.Engine.Scene Namespace


CollisionSticker Class

Handles object collisions by having the object "stick" to the object that it collided with.

For a list of all members of this type, see CollisionSticker Members.

System.Object
Goblin.Engine.Scene.CollisionSticker

public class CollisionSticker : ICollisionListener

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Goblin.Engine.Scene

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

CollisionSticker Members | Goblin.Engine.Scene Namespace


CollisionSticker Members

CollisionSticker overview

Public Instance Constructors

CollisionSticker Constructor Initializes a new instance of the CollisionSticker class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
OnBeforeCollided |
OnCollided |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CollisionSticker Class | Goblin.Engine.Scene Namespace


CollisionSticker Constructor

Initializes a new instance of the CollisionSticker class.

public CollisionSticker();

See Also

CollisionSticker Class | Goblin.Engine.Scene Namespace


CollisionSticker Methods

The methods of the CollisionSticker class are listed below. For a complete list of CollisionSticker class members, see the CollisionSticker Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
OnBeforeCollided |
OnCollided |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CollisionSticker Class | Goblin.Engine.Scene Namespace


CollisionSticker.OnBeforeCollided Method

public void OnBeforeCollided(
Node node,
Node root,
Node nodeHit,
Xfrm old,
IntersectInformation intersect,
Xfrm desired
);

Implements

ICollisionListener.OnBeforeCollided

See Also

CollisionSticker Class | Goblin.Engine.Scene Namespace


CollisionSticker.OnCollided Method

public void OnCollided(
Node node,
Node root,
Node nodeHit,
Xfrm old,
Xfrm collided,
IntersectInformation intersect,
ref Xfrm desired
);

Implements

ICollisionListener.OnCollided

See Also

CollisionSticker Class | Goblin.Engine.Scene Namespace


DamagableNode Class

Summary description for DamagableNode.

For a list of all members of this type, see DamagableNode Members.

System.Object
Microsoft.DirectX.Direct3D.Frame
Goblin.Engine.Scene.Node
Goblin.Engine.Scene.DamagableNode

public class DamagableNode : Node

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Goblin.Engine.Scene

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

DamagableNode Members | Goblin.Engine.Scene Namespace


DamagableNode Members

DamagableNode overview

Public Instance Constructors

DamagableNode Constructor

Public Instance Properties

Animated (inherited from Node) | Is the node moving?
Bounds (inherited from Node) |
Collidable (inherited from Node) | check for collisions
CombinedTransformationMatrix (inherited from Node) |
FrameFirstChild (inherited from Microsoft.DirectX.Direct3D.Frame) |
FrameSibling (inherited from Microsoft.DirectX.Direct3D.Frame) |
HasMoved (inherited from Node) | Has the node moved since it last collided with something?
isAlive |
IsReal (inherited from Node) |
MeshContainer (inherited from Microsoft.DirectX.Direct3D.Frame) |
MyMeshCont (inherited from Node) | Contains the mesh for the node if it has one
Name (inherited from Microsoft.DirectX.Direct3D.Frame) |
Renderable (inherited from Node) | check for render
RenderRealAsBlack (inherited from Node) |
TransformationMatrix (inherited from Microsoft.DirectX.Direct3D.Frame) |
Transformer (inherited from Node) |

Public Instance Methods

AddXFile (inherited from Node) |
AddXFileData (inherited from Node) |
AppendChild (inherited from Node) | Overloaded.
CombineTransformations (inherited from Node) |
Damage |
Dispose (inherited from Node) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
find (inherited from Node) |
findFirst (inherited from Node) |
FrameMove (inherited from Node) | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
getPosition (inherited from Node) |
GetType (inherited from Object) | Gets the Type of the current instance.
Kill |
Render | Draw a frame and all child and sibling frames
RenderCollisionSphere (inherited from Node) |
RenderTrans (inherited from Node) |
setAllCollidable (inherited from Node) |
setAllRenderable (inherited from Node) |
setCollidable (inherited from Node) |
SetCombinedTransformations (inherited from Node) | Updates the combined transformation using the transformer
SetMesh (inherited from Node) |
setRenderable (inherited from Node) |
ToString (inherited from Node) | Overloaded. Update the frames matrices and combine it with it's parents

Protected Instance Methods

Finalize (inherited from Microsoft.DirectX.Direct3D.Frame) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DamagableNode Class | Goblin.Engine.Scene Namespace


DamagableNode Constructor

public DamagableNode(
string name,
int HP
);

See Also

DamagableNode Class | Goblin.Engine.Scene Namespace


DamagableNode Properties

The properties of the DamagableNode class are listed below. For a complete list of DamagableNode class members, see the DamagableNode Members topic.

Public Instance Properties

Animated (inherited from Node) | Is the node moving?
Bounds (inherited from Node) |
Collidable (inherited from Node) | check for collisions
CombinedTransformationMatrix (inherited from Node) |
FrameFirstChild (inherited from Microsoft.DirectX.Direct3D.Frame) |
FrameSibling (inherited from Microsoft.DirectX.Direct3D.Frame) |
HasMoved (inherited from Node) | Has the node moved since it last collided with something?
isAlive |
IsReal (inherited from Node) |
MeshContainer (inherited from Microsoft.DirectX.Direct3D.Frame) |
MyMeshCont (inherited from Node) | Contains the mesh for the node if it has one
Name (inherited from Microsoft.DirectX.Direct3D.Frame) |
Renderable (inherited from Node) | check for render
RenderRealAsBlack (inherited from Node) |
TransformationMatrix (inherited from Microsoft.DirectX.Direct3D.Frame) |
Transformer (inherited from Node) |

See Also

DamagableNode Class | Goblin.Engine.Scene Namespace


isAlive Property

Goblin - A Platform for 3D AR and VR Applications

DamagableNode.isAlive Property

public bool isAlive {get; set;}

See Also

DamagableNode Class | Goblin.Engine.Scene Namespace


DamagableNode Methods

The methods of the DamagableNode class are listed below. For a complete list of DamagableNode class members, see the DamagableNode Members topic.

Public Instance Methods

AddXFile (inherited from Node) |
AddXFileData (inherited from Node) |
AppendChild (inherited from Node) | Overloaded.
CombineTransformations (inherited from Node) |
Damage |
Dispose (inherited from Node) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
find (inherited from Node) |
findFirst (inherited from Node) |
FrameMove (inherited from Node) | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
getPosition (inherited from Node) |
GetType (inherited from Object) | Gets the Type of the current instance.
Kill |
Render | Draw a frame and all child and sibling frames
RenderCollisionSphere (inherited from Node) |
RenderTrans (inherited from Node) |
setAllCollidable (inherited from Node) |
setAllRenderable (inherited from Node) |
setCollidable (inherited from Node) |
SetCombinedTransformations (inherited from Node) | Updates the combined transformation using the transformer
SetMesh (inherited from Node) |
setRenderable (inherited from Node) |
ToString (inherited from Node) | Overloaded. Update the frames matrices and combine it with it's parents

Protected Instance Methods

Finalize (inherited from Microsoft.DirectX.Direct3D.Frame) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DamagableNode Class | Goblin.Engine.Scene Namespace


DamagableNode.Damage Method

public void Damage(
int damage
);

See Also

DamagableNode Class | Goblin.Engine.Scene Namespace


DamagableNode.Kill Method

public void Kill();

See Also

DamagableNode Class | Goblin.Engine.Scene Namespace


DamagableNode.Render Method

Draw a frame and all child and sibling frames

public override void Render(
Device device,
int pass
);

See Also

DamagableNode Class | Goblin.Engine.Scene Namespace


DamagingNode Class

Summary description for DamagableNode.

For a list of all members of this type, see DamagingNode Members.

System.Object
Microsoft.DirectX.Direct3D.Frame
Goblin.Engine.Scene.Node
Goblin.Engine.Scene.DamagingNode

public class DamagingNode : Node

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Goblin.Engine.Scene

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

DamagingNode Members | Goblin.Engine.Scene Namespace


DamagingNode Members

DamagingNode overview

Public Instance Constructors

DamagingNode Constructor

Public Instance Properties

Animated (inherited from Node) | Is the node moving?
Bounds (inherited from Node) |
Collidable (inherited from Node) | check for collisions
CombinedTransformationMatrix (inherited from Node) |
Damage |
FrameFirstChild (inherited from Microsoft.DirectX.Direct3D.Frame) |
FrameSibling (inherited from Microsoft.DirectX.Direct3D.Frame) |
HasMoved (inherited from Node) | Has the node moved since it last collided with something?
IsReal (inherited from Node) |
MeshContainer (inherited from Microsoft.DirectX.Direct3D.Frame) |
MyMeshCont (inherited from Node) | Contains the mesh for the node if it has one
Name (inherited from Microsoft.DirectX.Direct3D.Frame) |
Renderable (inherited from Node) | check for render
RenderRealAsBlack (inherited from Node) |
TransformationMatrix (inherited from Microsoft.DirectX.Direct3D.Frame) |
Transformer (inherited from Node) |

Public Instance Methods

AddXFile (inherited from Node) |
AddXFileData (inherited from Node) |
AppendChild (inherited from Node) | Overloaded.
CombineTransformations (inherited from Node) |
Dispose (inherited from Node) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
find (inherited from Node) |
findFirst (inherited from Node) |
FrameMove (inherited from Node) | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
getPosition (inherited from Node) |
GetType (inherited from Object) | Gets the Type of the current instance.
Hit |
Render (inherited from Node) | Draw a frame and all child and sibling frames
RenderCollisionSphere (inherited from Node) |
RenderTrans (inherited from Node) |
setAllCollidable (inherited from Node) |
setAllRenderable (inherited from Node) |
setCollidable (inherited from Node) |
SetCombinedTransformations (inherited from Node) | Updates the combined transformation using the transformer
SetMesh (inherited from Node) |
setRenderable (inherited from Node) |
stickOnHit |
ToString (inherited from Node) | Overloaded. Update the frames matrices and combine it with it's parents

Protected Instance Methods

Finalize (inherited from Microsoft.DirectX.Direct3D.Frame) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DamagingNode Class | Goblin.Engine.Scene Namespace


DamagingNode Constructor

public DamagingNode(
string name,
int dam
);

See Also

DamagingNode Class | Goblin.Engine.Scene Namespace


DamagingNode Properties

The properties of the DamagingNode class are listed below. For a complete list of DamagingNode class members, see the DamagingNode Members topic.

Public Instance Properties

Animated (inherited from Node) | Is the node moving?
Bounds (inherited from Node) |
Collidable (inherited from Node) | check for collisions
CombinedTransformationMatrix (inherited from Node) |
Damage |
FrameFirstChild (inherited from Microsoft.DirectX.Direct3D.Frame) |
FrameSibling (inherited from Microsoft.DirectX.Direct3D.Frame) |
HasMoved (inherited from Node) | Has the node moved since it last collided with something?
IsReal (inherited from Node) |
MeshContainer (inherited from Microsoft.DirectX.Direct3D.Frame) |
MyMeshCont (inherited from Node) | Contains the mesh for the node if it has one
Name (inherited from Microsoft.DirectX.Direct3D.Frame) |
Renderable (inherited from Node) | check for render
RenderRealAsBlack (inherited from Node) |
TransformationMatrix (inherited from Microsoft.DirectX.Direct3D.Frame) |
Transformer (inherited from Node) |

See Also

DamagingNode Class | Goblin.Engine.Scene Namespace


Damage Property

Goblin - A Platform for 3D AR and VR Applications

DamagingNode.Damage Property

public int Damage {get; set;}

See Also

DamagingNode Class | Goblin.Engine.Scene Namespace


DamagingNode Methods

The methods of the DamagingNode class are listed below. For a complete list of DamagingNode class members, see the DamagingNode Members topic.

Public Instance Methods

AddXFile (inherited from Node) |
AddXFileData (inherited from Node) |
AppendChild (inherited from Node) | Overloaded.
CombineTransformations (inherited from Node) |
Dispose (inherited from Node) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
find (inherited from Node) |
findFirst (inherited from Node) |
FrameMove (inherited from Node) | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
getPosition (inherited from Node) |
GetType (inherited from Object) | Gets the Type of the current instance.
Hit |
Render (inherited from Node) | Draw a frame and all child and sibling frames
RenderCollisionSphere (inherited from Node) |
RenderTrans (inherited from Node) |
setAllCollidable (inherited from Node) |
setAllRenderable (inherited from Node) |
setCollidable (inherited from Node) |
SetCombinedTransformations (inherited from Node) | Updates the combined transformation using the transformer
SetMesh (inherited from Node) |
setRenderable (inherited from Node) |
stickOnHit |
ToString (inherited from Node) | Overloaded. Update the frames matrices and combine it with it's parents

Protected Instance Methods

Finalize (inherited from Microsoft.DirectX.Direct3D.Frame) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DamagingNode Class | Goblin.Engine.Scene Namespace


DamagingNode.Hit Method

public void Hit();

See Also

DamagingNode Class | Goblin.Engine.Scene Namespace


DamagingNode.stickOnHit Method

public void stickOnHit(
Node node
);

See Also

DamagingNode Class | Goblin.Engine.Scene Namespace


DXCameraTransformer Class

Summary description for DXCameraController.

For a list of all members of this type, see DXCameraTransformer Members.

System.Object
Goblin.Engine.Scene.Transformer
Goblin.Engine.Scene.DXCameraTransformer

public class DXCameraTransformer : Transformer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Goblin.Engine.Scene

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

DXCameraTransformer Members | Goblin.Engine.Scene Namespace


DXCameraTransformer Members

DXCameraTransformer overview

Public Instance Constructors

DXCameraTransformer Constructor

Public Instance Properties

Current (inherited from Transformer)

Public Instance Methods

AddCollisionListener (inherited from Transformer) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FrameMove (inherited from Transformer) | Determines the new position for an object. If arriving at the new position would cause a collision, OnAfterCollisionDetection is called.
GetCollisionPosition (inherited from Transformer) |
GetDesiredPosition |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DXCameraTransformer Class | Goblin.Engine.Scene Namespace


DXCameraTransformer Constructor

public DXCameraTransformer(
Camera _camera
);

See Also

DXCameraTransformer Class | Goblin.Engine.Scene Namespace


DXCameraTransformer Methods

The methods of the DXCameraTransformer class are listed below. For a complete list of DXCameraTransformer class members, see the DXCameraTransformer Members topic.

Public Instance Methods

AddCollisionListener (inherited from Transformer) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FrameMove (inherited from Transformer) | Determines the new position for an object. If arriving at the new position would cause a collision, OnAfterCollisionDetection is called.
GetCollisionPosition (inherited from Transformer) |
GetDesiredPosition |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DXCameraTransformer Class | Goblin.Engine.Scene Namespace


DXCameraTransformer.GetDesiredPosition Method

public override bool GetDesiredPosition(
Xfrm cur,
float elapsed,
ref Xfrm desired
);

See Also

DXCameraTransformer Class | Goblin.Engine.Scene Namespace


ICollisionListener Interface

Interface for handling object collisions

For a list of all members of this type, see ICollisionListener Members.

public interface ICollisionListener

Types that implement ICollisionListener

Type | Description
AccelerationTransformer | Moves an object by moving it forward in the direction it is pointing
ChaseAITransformer |
CollisionDamageControl | Handles object collisions by having the object "stick" to the object that it collided with.
CollisionSticker | Handles object collisions by having the object "stick" to the object that it collided with.
IgnoreCollision | Handles collisions by ignoring them, allowing the object to pass through the other object. This is useful for objects that are controlled by a position tracker as opposed to an algorithm.
VelocityTransformer | Moves an object by moving it forward in the direction it is pointing

Requirements

Namespace: Goblin.Engine.Scene

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

ICollisionListener Members | Goblin.Engine.Scene Namespace


ICollisionListener Members

ICollisionListener overview

Public Instance Methods

OnBeforeCollided
OnCollided

See Also

ICollisionListener Interface | Goblin.Engine.Scene Namespace


ICollisionListener Methods

The methods of the ICollisionListener interface are listed below. For a complete list of ICollisionListener interface members, see the ICollisionListener Members topic.

Public Instance Methods

OnBeforeCollided
OnCollided

See Also

ICollisionListener Interface | Goblin.Engine.Scene Namespace


ICollisionListener.OnBeforeCollided Method

void OnBeforeCollided(
Node node,
Node root,
Node nodeHit,
Xfrm old,
IntersectInformation intersect,
Xfrm desired
);

See Also

ICollisionListener Interface | Goblin.Engine.Scene Namespace


ICollisionListener.OnCollided Method

void OnCollided(
Node node,
Node root,
Node nodeHit,
Xfrm old,
Xfrm collided,
IntersectInformation intersect,
ref Xfrm desired
);

See Also

ICollisionListener Interface | Goblin.Engine.Scene Namespace


IgnoreCollision Class

Handles collisions by ignoring them, allowing the object to pass through the other object. This is useful for objects that are controlled by a position tracker as opposed to an algorithm.

For a list of all members of this type, see IgnoreCollision Members.

System.Object
Goblin.Engine.Scene.IgnoreCollision

public class IgnoreCollision : ICollisionListener

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Goblin.Engine.Scene

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

IgnoreCollision Members | Goblin.Engine.Scene Namespace


IgnoreCollision Members

IgnoreCollision overview

Public Instance Constructors

IgnoreCollision Constructor Initializes a new instance of the IgnoreCollision class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
OnBeforeCollided |
OnCollided |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IgnoreCollision Class | Goblin.Engine.Scene Namespace


IgnoreCollision Constructor

Initializes a new instance of the IgnoreCollision class.

public IgnoreCollision();

See Also

IgnoreCollision Class | Goblin.Engine.Scene Namespace


IgnoreCollision Methods

The methods of the IgnoreCollision class are listed below. For a complete list of IgnoreCollision class members, see the IgnoreCollision Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
OnBeforeCollided |
OnCollided |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IgnoreCollision Class | Goblin.Engine.Scene Namespace


IgnoreCollision.OnBeforeCollided Method

public void OnBeforeCollided(
Node node,
Node root,
Node nodeHit,
Xfrm old,
IntersectInformation intersect,
Xfrm desired
);

Implements

ICollisionListener.OnBeforeCollided

See Also

IgnoreCollision Class | Goblin.Engine.Scene Namespace


IgnoreCollision.OnCollided Method

public void OnCollided(
Node node,
Node root,
Node nodeHit,
Xfrm old,
Xfrm collided,
IntersectInformation intersect,
ref Xfrm desired
);

Implements

ICollisionListener.OnCollided

See Also

IgnoreCollision Class | Goblin.Engine.Scene Namespace


InverterTransformer Class

For a list of all members of this type, see InverterTransformer Members.

System.Object
Goblin.Engine.Scene.Transformer
Goblin.Engine.Scene.InverterTransformer

public class InverterTransformer : Transformer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Goblin.Engine.Scene

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

InverterTransformer Members | Goblin.Engine.Scene Namespace


InverterTransformer Members

InverterTransformer overview

Public Instance Constructors

InverterTransformer Constructor

Public Instance Properties

Current (inherited from Transformer)

Public Instance Methods

AddCollisionListener (inherited from Transformer) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FrameMove (inherited from Transformer) | Determines the new position for an object. If arriving at the new position would cause a collision, OnAfterCollisionDetection is called.
GetCollisionPosition (inherited from Transformer) |
GetDesiredPosition |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InverterTransformer Class | Goblin.Engine.Scene Namespace


InverterTransformer Constructor

public InverterTransformer(
Transformer original
);

See Also

InverterTransformer Class | Goblin.Engine.Scene Namespace


InverterTransformer Methods

The methods of the InverterTransformer class are listed below. For a complete list of InverterTransformer class members, see the InverterTransformer Members topic.

Public Instance Methods

AddCollisionListener (inherited from Transformer) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FrameMove (inherited from Transformer) | Determines the new position for an object. If arriving at the new position would cause a collision, OnAfterCollisionDetection is called.
GetCollisionPosition (inherited from Transformer) |
GetDesiredPosition |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InverterTransformer Class | Goblin.Engine.Scene Namespace


InverterTransformer.GetDesiredPosition Method

public override bool GetDesiredPosition(
Xfrm cur,
float elapsed,
ref Xfrm desired
);

See Also

InverterTransformer Class | Goblin.Engine.Scene Namespace


MyMeshContainer Class

The mesh container class that will hold the animation data

For a list of all members of this type, see MyMeshContainer Members.

System.Object
Microsoft.DirectX.Direct3D.MeshContainer
Goblin.Engine.Scene.MyMeshContainer

public class MyMeshContainer : MeshContainer, IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Goblin.Engine.Scene

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

MyMeshContainer Members | Goblin.Engine.Scene Namespace


MyMeshContainer Members

MyMeshContainer overview

Public Instance Constructors

MyMeshContainer Constructor Initializes a new instance of the MyMeshContainer class.

Public Instance Properties

Bounds |
FineGrainCD |
MeshData (inherited from Microsoft.DirectX.Direct3D.MeshContainer) |
MyNextContainer |
Name (inherited from Microsoft.DirectX.Direct3D.MeshContainer) |
NextContainer (inherited from Microsoft.DirectX.Direct3D.MeshContainer) |
NumberAttributes | Total number of attributes this mesh container contains
NumberInfluences | Total number of influences this mesh container contains
NumberPaletteEntries | Total number of palette entries this mesh container contains
RenderAsBlack |
SkinInformation (inherited from Microsoft.DirectX.Direct3D.MeshContainer) |
TransformedMesh |

Public Instance Methods

Dispose |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FrameMove |
GetAdjacency (inherited from Microsoft.DirectX.Direct3D.MeshContainer) |
GetAdjacencyStream (inherited from Microsoft.DirectX.Direct3D.MeshContainer) |
GetBones | Retrieve the bone combinations used for this container
GetEffectInstances (inherited from Microsoft.DirectX.Direct3D.MeshContainer) |
GetFrames | Retrieve the animation frames used for this container
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetMaterials (inherited from Microsoft.DirectX.Direct3D.MeshContainer) |
GetOffsetMatrices | Retrieve the offset matrices used for this container
GetTextures | Retrieve the textures used for this container
getTransformedVertices |
GetType (inherited from Object) | Gets the Type of the current instance.
Init | Overloaded.
Render | Render a mesh container
Render2 | An attempt to implement Mesh.DrawSubset() so that we could draw a face with a different color.
RenderCollisionSphere |
RenderTrans |
SetAdjacency (inherited from Microsoft.DirectX.Direct3D.MeshContainer) | Overloaded.
SetBones | Set the bone combinations used for this container
SetEffectInstances (inherited from Microsoft.DirectX.Direct3D.MeshContainer) |
SetFrames | Set the animation frames used for this container
SetMaterials (inherited from Microsoft.DirectX.Direct3D.MeshContainer) |
SetOffsetMatrices | Set the offset matrices used for this container
SetTextures | Set the textures used for this container
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Microsoft.DirectX.Direct3D.MeshContainer) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MyMeshContainer Class | Goblin.Engine.Scene Namespace


MyMeshContainer Constructor

Initializes a new instance of the MyMeshContainer class.

public MyMeshContainer();

See Also

MyMeshContainer Class | Goblin.Engine.Scene Namespace


MyMeshContainer Properties

The properties of the MyMeshContainer class are listed below. For a complete list of MyMeshContainer class members, see the MyMeshContainer Members topic.

Public Instance Properties

Bounds |
FineGrainCD |
MeshData (inherited from Microsoft.DirectX.Direct3D.MeshContainer) |
MyNextContainer |
Name (inherited from Microsoft.DirectX.Direct3D.MeshContainer) |
NextContainer (inherited from Microsoft.DirectX.Direct3D.MeshContainer) |
NumberAttributes | Total number of attributes this mesh container contains
NumberInfluences | Total number of influences this mesh container contains
NumberPaletteEntries | Total number of palette entries this mesh container contains
RenderAsBlack |
SkinInformation (inherited from Microsoft.DirectX.Direct3D.MeshContainer) |
TransformedMesh |

See Also

MyMeshContainer Class | Goblin.Engine.Scene Namespace


Bounds Property

Goblin - A Platform for 3D AR and VR Applications

MyMeshContainer.Bounds Property

public Bounds Bounds {get;}

See Also

MyMeshContainer Class | Goblin.Engine.Scene Namespace


FineGrainCD Property

Goblin - A Platform for 3D AR and VR Applications

MyMeshContainer.FineGrainCD Property

public bool FineGrainCD {get; set;}

See Also

MyMeshContainer Class | Goblin.Engine.Scene Namespace


MyNextContainer Property

Goblin - A Platform for 3D AR and VR Applications

MyMeshContainer.MyNextContainer Property

public MyMeshContainer MyNextContainer {get;}

See Also

MyMeshContainer Class | Goblin.Engine.Scene Namespace


NumberAttributes Property

Goblin - A Platform for 3D AR and VR Applications

MyMeshContainer.NumberAttributes Property

Total number of attributes this mesh container contains

public int NumberAttributes {get; set;}

See Also

MyMeshContainer Class | Goblin.Engine.Scene Namespace


NumberInfluences Property

Goblin - A Platform for 3D AR and VR Applications

MyMeshContainer.NumberInfluences Property

Total number of influences this mesh container contains

public int NumberInfluences {get; set;}

See Also

MyMeshContainer Class | Goblin.Engine.Scene Namespace


NumberPaletteEntries Property

Goblin - A Platform for 3D AR and VR Applications

MyMeshContainer.NumberPaletteEntries Property

Total number of palette entries this mesh container contains

public int NumberPaletteEntries {get; set;}

See Also

MyMeshContainer Class | Goblin.Engine.Scene Namespace


RenderAsBlack Property

Goblin - A Platform for 3D AR and VR Applications

MyMeshContainer.RenderAsBlack Property

public bool RenderAsBlack {get; set;}

See Also

MyMeshContainer Class | Goblin.Engine.Scene Namespace


TransformedMesh Property

Goblin - A Platform for 3D AR and VR Applications

MyMeshContainer.TransformedMesh Property

public Microsoft.DirectX.Direct3D.Mesh TransformedMesh {get;}

See Also

MyMeshContainer Class | Goblin.Engine.Scene Namespace


MyMeshContainer Methods

The methods of the MyMeshContainer class are listed below. For a complete list of MyMeshContainer class members, see the MyMeshContainer Members topic.

Public Instance Methods

Dispose |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FrameMove |
GetAdjacency (inherited from Microsoft.DirectX.Direct3D.MeshContainer) |
GetAdjacencyStream (inherited from Microsoft.DirectX.Direct3D.MeshContainer) |
GetBones | Retrieve the bone combinations used for this container
GetEffectInstances (inherited from Microsoft.DirectX.Direct3D.MeshContainer) |
GetFrames | Retrieve the animation frames used for this container
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetMaterials (inherited from Microsoft.DirectX.Direct3D.MeshContainer) |
GetOffsetMatrices | Retrieve the offset matrices used for this container
GetTextures | Retrieve the textures used for this container
getTransformedVertices |
GetType (inherited from Object) | Gets the Type of the current instance.
Init | Overloaded.
Render | Render a mesh container
Render2 | An attempt to implement Mesh.DrawSubset() so that we could draw a face with a different color.
RenderCollisionSphere |
RenderTrans |
SetAdjacency (inherited from Microsoft.DirectX.Direct3D.MeshContainer) | Overloaded.
SetBones | Set the bone combinations used for this container
SetEffectInstances (inherited from Microsoft.DirectX.Direct3D.MeshContainer) |
SetFrames | Set the animation frames used for this container
SetMaterials (inherited from Microsoft.DirectX.Direct3D.MeshContainer) |
SetOffsetMatrices | Set the offset matrices used for this container
SetTextures | Set the textures used for this container
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Microsoft.DirectX.Direct3D.MeshContainer) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MyMeshContainer Class | Goblin.Engine.Scene Namespace


MyMeshContainer.Dispose Method

public void Dispose();

Implements

IDisposable.Dispose

See Also

MyMeshContainer Class | Goblin.Engine.Scene Namespace


MyMeshContainer.FrameMove Method

public void FrameMove(
Device device,
Matrix parentMatrix
);

See Also

MyMeshContainer Class | Goblin.Engine.Scene Namespace


MyMeshContainer.GetBones Method

Retrieve the bone combinations used for this container

public BoneCombination[] GetBones();

See Also

MyMeshContainer Class | Goblin.Engine.Scene Namespace


MyMeshContainer.GetFrames Method

Retrieve the animation frames used for this container

public Node[] GetFrames();

See Also

MyMeshContainer Class | Goblin.Engine.Scene Namespace


MyMeshContainer.GetOffsetMatrices Method

Retrieve the offset matrices used for this container

public Matrix[] GetOffsetMatrices();

See Also

MyMeshContainer Class | Goblin.Engine.Scene Namespace


MyMeshContainer.GetTextures Method

Retrieve the textures used for this container

public Texture[] GetTextures();

See Also

MyMeshContainer Class | Goblin.Engine.Scene Namespace


MyMeshContainer.getTransformedVertices Method

public void getTransformedVertices(
Matrix mat,
out Vector3[] verts
);

See Also

MyMeshContainer Class | Goblin.Engine.Scene Namespace


Init Method

Goblin - A Platform for 3D AR and VR Applications

MyMeshContainer.Init Method

Overload List

public void Init(Device,string,XFileData,string);

public void Init(Device,string,string,Mesh,GraphicsStream,ExtendedMaterial[],string);

See Also

MyMeshContainer Class | Goblin.Engine.Scene Namespace


MyMeshContainer.Init Method (Device, String, XFileData, String)

public void Init(
Device device,
string directory,
XFileData xfileData,
string indent
);

See Also

MyMeshContainer Class | Goblin.Engine.Scene Namespace | MyMeshContainer.Init Overload List


MyMeshContainer.Init Method (Device, String, String, Mesh, GraphicsStream, ExtendedMaterial[], String)

public void Init(
Device device,
string name,
string directory,
Mesh mesh,
GraphicsStream adjacency,
ExtendedMaterial[] materials,
string indent
);

See Also

MyMeshContainer Class | Goblin.Engine.Scene Namespace | MyMeshContainer.Init Overload List


MyMeshContainer.Render Method

Render a mesh container

public void Render(
Device device
);

See Also

MyMeshContainer Class | Goblin.Engine.Scene Namespace


MyMeshContainer.Render2 Method

An attempt to implement Mesh.DrawSubset() so that we could draw a face with a different color.

public void Render2(
Device device
);

See Also

MyMeshContainer Class | Goblin.Engine.Scene Namespace


MyMeshContainer.RenderCollisionSphere Method

public void RenderCollisionSphere(
Device device
);

See Also

MyMeshContainer Class | Goblin.Engine.Scene Namespace


MyMeshContainer.RenderTrans Method

public void RenderTrans(
Device device,
Matrix CTM,
bool Animated
);

See Also

MyMeshContainer Class | Goblin.Engine.Scene Namespace


MyMeshContainer.SetBones Method

Set the bone combinations used for this container

public void SetBones(
BoneCombination[] b
);

See Also

MyMeshContainer Class | Goblin.Engine.Scene Namespace


MyMeshContainer.SetFrames Method

Set the animation frames used for this container

public void SetFrames(
Node[] frames
);

See Also

MyMeshContainer Class | Goblin.Engine.Scene Namespace


MyMeshContainer.SetOffsetMatrices Method

Set the offset matrices used for this container

public void SetOffsetMatrices(
Matrix[] matrices
);

See Also

MyMeshContainer Class | Goblin.Engine.Scene Namespace


MyMeshContainer.SetTextures Method

Set the textures used for this container

public void SetTextures(
Texture[] textures
);

See Also

MyMeshContainer Class | Goblin.Engine.Scene Namespace


Node Class

The frame that will hold mesh animation

For a list of all members of this type, see Node Members.

System.Object
Microsoft.DirectX.Direct3D.Frame
Goblin.Engine.Scene.Node
Goblin.Engine.Scene.CameraNode
Goblin.Engine.Scene.DamagableNode
Goblin.Engine.Scene.DamagingNode

public class Node : Frame, IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Goblin.Engine.Scene

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

Node Members | Goblin.Engine.Scene Namespace


Node Members

Node overview

Public Instance Constructors

Node Constructor

Public Instance Properties

Animated | Is the node moving?
Bounds |
Collidable | check for collisions
CombinedTransformationMatrix |
FrameFirstChild (inherited from Microsoft.DirectX.Direct3D.Frame) |
FrameSibling (inherited from Microsoft.DirectX.Direct3D.Frame) |
HasMoved | Has the node moved since it last collided with something?
IsReal |
MeshContainer (inherited from Microsoft.DirectX.Direct3D.Frame) |
MyMeshCont | Contains the mesh for the node if it has one
Name (inherited from Microsoft.DirectX.Direct3D.Frame) |
Renderable | check for render
RenderRealAsBlack |
TransformationMatrix (inherited from Microsoft.DirectX.Direct3D.Frame) |
Transformer |

Public Instance Methods

AddXFile |
AddXFileData |
AppendChild | Overloaded.
CombineTransformations |
Dispose |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
find |
findFirst |
FrameMove | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
getPosition |
GetType (inherited from Object) | Gets the Type of the current instance.
Render | Draw a frame and all child and sibling frames
RenderCollisionSphere |
RenderTrans |
setAllCollidable |
setAllRenderable |
setCollidable |
SetCombinedTransformations | Updates the combined transformation using the transformer
SetMesh |
setRenderable |
ToString | Overloaded. Update the frames matrices and combine it with it's parents

Protected Instance Methods

Finalize (inherited from Microsoft.DirectX.Direct3D.Frame) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Node Class | Goblin.Engine.Scene Namespace


Node Constructor

public Node(
string name
);

See Also

Node Class | Goblin.Engine.Scene Namespace


Node Properties

The properties of the Node class are listed below. For a complete list of Node class members, see the Node Members topic.

Public Instance Properties

Animated | Is the node moving?
Bounds |
Collidable | check for collisions
CombinedTransformationMatrix |
FrameFirstChild (inherited from Microsoft.DirectX.Direct3D.Frame) |
FrameSibling (inherited from Microsoft.DirectX.Direct3D.Frame) |
HasMoved | Has the node moved since it last collided with something?
IsReal |
MeshContainer (inherited from Microsoft.DirectX.Direct3D.Frame) |
MyMeshCont | Contains the mesh for the node if it has one
Name (inherited from Microsoft.DirectX.Direct3D.Frame) |
Renderable | check for render
RenderRealAsBlack |
TransformationMatrix (inherited from Microsoft.DirectX.Direct3D.Frame) |
Transformer |

See Also

Node Class | Goblin.Engine.Scene Namespace


Animated Property

Goblin - A Platform for 3D AR and VR Applications

Node.Animated Property

Is the node moving?

public bool Animated {get; set;}

See Also

Node Class | Goblin.Engine.Scene Namespace


Bounds Property

Goblin - A Platform for 3D AR and VR Applications

Node.Bounds Property

public Bounds Bounds {get;}

See Also

Node Class | Goblin.Engine.Scene Namespace


Collidable Property

Goblin - A Platform for 3D AR and VR Applications

Node.Collidable Property

check for collisions

public bool Collidable {get; set;}

See Also

Node Class | Goblin.Engine.Scene Namespace


CombinedTransformationMatrix Property

Goblin - A Platform for 3D AR and VR Applications

Node.CombinedTransformationMatrix Property

public Microsoft.DirectX.Matrix CombinedTransformationMatrix {get; set;}

See Also

Node Class | Goblin.Engine.Scene Namespace


HasMoved Property

Goblin - A Platform for 3D AR and VR Applications

Node.HasMoved Property

Has the node moved since it last collided with something?

public bool HasMoved {get;}

See Also

Node Class | Goblin.Engine.Scene Namespace


IsReal Property

Goblin - A Platform for 3D AR and VR Applications

Node.IsReal Property

public bool IsReal {get; set;}

See Also

Node Class | Goblin.Engine.Scene Namespace


MyMeshCont Property

Goblin - A Platform for 3D AR and VR Applications

Node.MyMeshCont Property

Contains the mesh for the node if it has one

public MyMeshContainer MyMeshCont {get; set;}

See Also

Node Class | Goblin.Engine.Scene Namespace


Renderable Property

Goblin - A Platform for 3D AR and VR Applications

Node.Renderable Property

check for render

public bool Renderable {get; set;}

See Also

Node Class | Goblin.Engine.Scene Namespace


RenderRealAsBlack Property

Goblin - A Platform for 3D AR and VR Applications

Node.RenderRealAsBlack Property

public bool RenderRealAsBlack {get; set;}

See Also

Node Class | Goblin.Engine.Scene Namespace


Transformer Property

Goblin - A Platform for 3D AR and VR Applications

Node.Transformer Property

public Transformer Transformer {get; set;}

See Also

Node Class | Goblin.Engine.Scene Namespace


Node Methods

The methods of the Node class are listed below. For a complete list of Node class members, see the Node Members topic.

Public Instance Methods

AddXFile |
AddXFileData |
AppendChild | Overloaded.
CombineTransformations |
Dispose |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
find |
findFirst |
FrameMove | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
getPosition |
GetType (inherited from Object) | Gets the Type of the current instance.
Render | Draw a frame and all child and sibling frames
RenderCollisionSphere |
RenderTrans |
setAllCollidable |
setAllRenderable |
setCollidable |
SetCombinedTransformations | Updates the combined transformation using the transformer
SetMesh |
setRenderable |
ToString | Overloaded. Update the frames matrices and combine it with it's parents

Protected Instance Methods

Finalize (inherited from Microsoft.DirectX.Direct3D.Frame) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Node Class | Goblin.Engine.Scene Namespace


Node.AddXFile Method

public Node AddXFile(
Device device,
string fileName,
XFileManager xfileMgr
);

See Also

Node Class | Goblin.Engine.Scene Namespace


Node.AddXFileData Method

public void AddXFileData(
Device device,
string directory,
XFileData xfileData,
string indent
);

See Also

Node Class | Goblin.Engine.Scene Namespace


AppendChild Method

Goblin - A Platform for 3D AR and VR Applications

Node.AppendChild Method

Overload List

public Node AppendChild(Node);

public Frame AppendChild(Frame);

See Also

Node Class | Goblin.Engine.Scene Namespace


Node.AppendChild Method (Node)

public Node AppendChild(
Node child
);

See Also

Node Class | Goblin.Engine.Scene Namespace | Node.AppendChild Overload List


Node.AppendChild Method (Frame)

public Frame AppendChild(
Frame child
);

See Also

Node Class | Goblin.Engine.Scene Namespace | Node.AppendChild Overload List


Node.CombineTransformations Method

public void CombineTransformations(
Node root,
Device device,
Matrix parentMatrix
);

See Also

Node Class | Goblin.Engine.Scene Namespace


Node.Dispose Method

public void Dispose();

Implements

IDisposable.Dispose

See Also

Node Class | Goblin.Engine.Scene Namespace


Node.find Method

public void find(
string pattern,
ArrayList matches
);

See Also

Node Class | Goblin.Engine.Scene Namespace


Node.findFirst Method

public Node findFirst(
string pattern
);

See Also

Node Class | Goblin.Engine.Scene Namespace


FrameMove Method

Goblin - A Platform for 3D AR and VR Applications

Node.FrameMove Method

Overload List

public virtual void FrameMove(Node,Device,Matrix,float);

public void FrameMove(Node,Device,float);

See Also

Node Class | Goblin.Engine.Scene Namespace


Node.FrameMove Method (Node, Device, Matrix, Single)

public virtual void FrameMove(
Node root,
Device device,
Matrix parentMatrix,
float elapsedTime
);

See Also

Node Class | Goblin.Engine.Scene Namespace | Node.FrameMove Overload List


Node.FrameMove Method (Node, Device, Single)

public void FrameMove(
Node root,
Device device,
float elapsedTime
);

See Also

Node Class | Goblin.Engine.Scene Namespace | Node.FrameMove Overload List


Node.getPosition Method

public Vector3 getPosition();

See Also

Node Class | Goblin.Engine.Scene Namespace


Node.Render Method

Draw a frame and all child and sibling frames

public virtual void Render(
Device device,
int pass
);

See Also

Node Class | Goblin.Engine.Scene Namespace


Node.RenderCollisionSphere Method

public void RenderCollisionSphere(
Device device
);

See Also

Node Class | Goblin.Engine.Scene Namespace


Node.RenderTrans Method

public virtual void RenderTrans(
Device device
);

See Also

Node Class | Goblin.Engine.Scene Namespace


Node.setAllCollidable Method

public void setAllCollidable(
bool collision
);

See Also

Node Class | Goblin.Engine.Scene Namespace


Node.setAllRenderable Method

public void setAllRenderable(
bool render
);

See Also

Node Class | Goblin.Engine.Scene Namespace


Node.setCollidable Method

public void setCollidable(
bool collision,
string pattern
);

See Also

Node Class | Goblin.Engine.Scene Namespace


Node.SetCombinedTransformations Method

Updates the combined transformation using the transformer

public bool SetCombinedTransformations(
Node root,
Device device,
Matrix parentMatrix,
float elapsedTime
);

Parameters

root
device
parentMatrix
elapsedTime

Return Value

See Also

Node Class | Goblin.Engine.Scene Namespace


Node.SetMesh Method

public void SetMesh(
Device device,
string directory,
Mesh mesh,
GraphicsStream adjacency,
ExtendedMaterial[] materials,
string indent
);

See Also

Node Class | Goblin.Engine.Scene Namespace


Node.setRenderable Method

public void setRenderable(
bool render,
string pattern
);

See Also

Node Class | Goblin.Engine.Scene Namespace


ToString Method

Goblin - A Platform for 3D AR and VR Applications

Node.ToString Method

Update the frames matrices and combine it with it's parents

Overload List

Update the frames matrices and combine it with it's parents

public override string ToString();

public string ToString(string);

See Also

Node Class | Goblin.Engine.Scene Namespace


Node.ToString Method ()

Update the frames matrices and combine it with it's parents

public override string ToString();

See Also

Node Class | Goblin.Engine.Scene Namespace | Node.ToString Overload List


Node.ToString Method (String)

public string ToString(
string name
);

See Also

Node Class | Goblin.Engine.Scene Namespace | Node.ToString Overload List


SceneGraph Class

Summary description for SceneGraph.

For a list of all members of this type, see SceneGraph Members.

System.Object
Goblin.Engine.Scene.SceneGraph

public class SceneGraph : IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Goblin.Engine.Scene

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

SceneGraph Members | Goblin.Engine.Scene Namespace


SceneGraph Members

SceneGraph overview

Public Static Fields

CAMERA_PASS
GEOMETRY_PASS
SKIP_PASS

Public Instance Constructors

SceneGraph Constructor Initializes a new instance of the SceneGraph class.

Public Instance Properties

RootNode
XFileManager

Public Instance Methods

AddMesh |
AddNode |
CombineTransformations |
Dispose |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FrameMove |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Render |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SceneGraph Class | Goblin.Engine.Scene Namespace


SceneGraph Constructor

Initializes a new instance of the SceneGraph class.

public SceneGraph();

See Also

SceneGraph Class | Goblin.Engine.Scene Namespace


SceneGraph Fields

The fields of the SceneGraph class are listed below. For a complete list of SceneGraph class members, see the SceneGraph Members topic.

Public Static Fields

CAMERA_PASS
GEOMETRY_PASS
SKIP_PASS

See Also

SceneGraph Class | Goblin.Engine.Scene Namespace


SceneGraph.CAMERA_PASS Field

public const int CAMERA_PASS = 1;

See Also

SceneGraph Class | Goblin.Engine.Scene Namespace


SceneGraph.GEOMETRY_PASS Field

public const int GEOMETRY_PASS = 0;

See Also

SceneGraph Class | Goblin.Engine.Scene Namespace


SceneGraph.SKIP_PASS Field

public const int SKIP_PASS = -1;

See Also

SceneGraph Class | Goblin.Engine.Scene Namespace


SceneGraph Properties

The properties of the SceneGraph class are listed below. For a complete list of SceneGraph class members, see the SceneGraph Members topic.

Public Instance Properties

RootNode
XFileManager

See Also

SceneGraph Class | Goblin.Engine.Scene Namespace


RootNode Property

Goblin - A Platform for 3D AR and VR Applications

SceneGraph.RootNode Property

public Node RootNode {get;}

See Also

SceneGraph Class | Goblin.Engine.Scene Namespace


XFileManager Property

Goblin - A Platform for 3D AR and VR Applications

SceneGraph.XFileManager Property

public Microsoft.DirectX.Direct3D.XFileManager XFileManager {get;}

See Also

SceneGraph Class | Goblin.Engine.Scene Namespace


SceneGraph Methods

The methods of the SceneGraph class are listed below. For a complete list of SceneGraph class members, see the SceneGraph Members topic.

Public Instance Methods

AddMesh |
AddNode |
CombineTransformations |
Dispose |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FrameMove |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Render |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SceneGraph Class | Goblin.Engine.Scene Namespace


SceneGraph.AddMesh Method

public Node AddMesh(
Device device,
string name,
string directory,
Mesh mesh,
GraphicsStream adjacency,
ExtendedMaterial[] materials
);

See Also

SceneGraph Class | Goblin.Engine.Scene Namespace


SceneGraph.AddNode Method

public Node AddNode(
Node node
);

See Also

SceneGraph Class | Goblin.Engine.Scene Namespace


SceneGraph.CombineTransformations Method

public void CombineTransformations(
Device device,
Matrix worldMatrix
);

See Also

SceneGraph Class | Goblin.Engine.Scene Namespace


SceneGraph.Dispose Method

public void Dispose();

Implements

IDisposable.Dispose

See Also

SceneGraph Class | Goblin.Engine.Scene Namespace


SceneGraph.FrameMove Method

public void FrameMove(
Device device,
float elapsedTime
);

See Also

SceneGraph Class | Goblin.Engine.Scene Namespace


SceneGraph.Render Method

public void Render(
Device device,
Vector3 origin
);

See Also

SceneGraph Class | Goblin.Engine.Scene Namespace


TrackerTransformer Class

For a list of all members of this type, see TrackerTransformer Members.

System.Object
Goblin.Engine.Scene.Transformer
Goblin.Engine.Scene.TrackerTransformer

public class TrackerTransformer : Transformer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Goblin.Engine.Scene

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

TrackerTransformer Members | Goblin.Engine.Scene Namespace


TrackerTransformer Members

TrackerTransformer overview

Public Instance Constructors

TrackerTransformer Constructor

Public Instance Properties

Current (inherited from Transformer)

Public Instance Methods

AddCollisionListener (inherited from Transformer) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FrameMove (inherited from Transformer) | Determines the new position for an object. If arriving at the new position would cause a collision, OnAfterCollisionDetection is called.
GetCollisionPosition (inherited from Transformer) |
GetDesiredPosition |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TrackerTransformer Class | Goblin.Engine.Scene Namespace


TrackerTransformer Constructor

public TrackerTransformer(
InputDevice_6DOF device
);

See Also

TrackerTransformer Class | Goblin.Engine.Scene Namespace


TrackerTransformer Methods

The methods of the TrackerTransformer class are listed below. For a complete list of TrackerTransformer class members, see the TrackerTransformer Members topic.

Public Instance Methods

AddCollisionListener (inherited from Transformer) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FrameMove (inherited from Transformer) | Determines the new position for an object. If arriving at the new position would cause a collision, OnAfterCollisionDetection is called.
GetCollisionPosition (inherited from Transformer) |
GetDesiredPosition |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TrackerTransformer Class | Goblin.Engine.Scene Namespace


TrackerTransformer.GetDesiredPosition Method

public override bool GetDesiredPosition(
Xfrm cur,
float elapsed,
ref Xfrm desired
);

See Also

TrackerTransformer Class | Goblin.Engine.Scene Namespace


Transformer Class

Controls the movement of an object in the scene over time. Subclasses will define specific 3D movement paths, e.g., movement in a straight line.

For a list of all members of this type, see Transformer Members.

System.Object
Goblin.Engine.Scene.Transformer
Derived types

public class Transformer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Goblin.Engine.Scene

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

Transformer Members | Goblin.Engine.Scene Namespace


Transformer Members

Transformer overview

Public Instance Constructors

Transformer Constructor Initializes a new instance of the Transformer class.

Public Instance Properties

Current

Public Instance Methods

AddCollisionListener |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FrameMove | Determines the new position for an object. If arriving at the new position would cause a collision, OnAfterCollisionDetection is called.
GetCollisionPosition |
GetDesiredPosition |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Transformer Class | Goblin.Engine.Scene Namespace


Transformer Constructor

Initializes a new instance of the Transformer class.

public Transformer();

See Also

Transformer Class | Goblin.Engine.Scene Namespace


Transformer Properties

The properties of the Transformer class are listed below. For a complete list of Transformer class members, see the Transformer Members topic.

Public Instance Properties

Current

See Also

Transformer Class | Goblin.Engine.Scene Namespace


Current Property

Goblin - A Platform for 3D AR and VR Applications

Transformer.Current Property

public Xfrm Current {get; set;}

See Also

Transformer Class | Goblin.Engine.Scene Namespace


Transformer Methods

The methods of the Transformer class are listed below. For a complete list of Transformer class members, see the Transformer Members topic.

Public Instance Methods

AddCollisionListener |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FrameMove | Determines the new position for an object. If arriving at the new position would cause a collision, OnAfterCollisionDetection is called.
GetCollisionPosition |
GetDesiredPosition |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Transformer Class | Goblin.Engine.Scene Namespace


Transformer.AddCollisionListener Method

public void AddCollisionListener(
ICollisionListener listener
);

See Also

Transformer Class | Goblin.Engine.Scene Namespace


Transformer.FrameMove Method

Determines the new position for an object. If arriving at the new position would cause a collision, OnAfterCollisionDetection is called.

public virtual void FrameMove(
Node node,
Node root,
float elapsed
);

Parameters

node
root
Root of the scene graph
elapsed

See Also

Transformer Class | Goblin.Engine.Scene Namespace


Transformer.GetCollisionPosition Method

public virtual void GetCollisionPosition(
Xfrm cur,
Xfrm desired,
IntersectInformation closestHit,
out Xfrm next
);

See Also

Transformer Class | Goblin.Engine.Scene Namespace


Transformer.GetDesiredPosition Method

public virtual bool GetDesiredPosition(
Xfrm cur,
float elapsed,
ref Xfrm desired
);

See Also

Transformer Class | Goblin.Engine.Scene Namespace


VelocityTransformer Class

Moves an object by moving it forward in the direction it is pointing

For a list of all members of this type, see VelocityTransformer Members.

System.Object
Goblin.Engine.Scene.Transformer
Goblin.Engine.Scene.VelocityTransformer

public class VelocityTransformer : Transformer, ICollisionListener

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Goblin.Engine.Scene

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

VelocityTransformer Members | Goblin.Engine.Scene Namespace


VelocityTransformer Members

VelocityTransformer overview

Public Instance Constructors

VelocityTransformer Constructor Initializes a new instance of the VelocityTransformer class.

Public Instance Properties

Current (inherited from Transformer)
Velocity

Public Instance Methods

AddCollisionListener (inherited from Transformer) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FrameMove (inherited from Transformer) | Determines the new position for an object. If arriving at the new position would cause a collision, OnAfterCollisionDetection is called.
GetCollisionPosition (inherited from Transformer) |
GetDesiredPosition |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
OnBeforeCollided |
OnCollided |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

VelocityTransformer Class | Goblin.Engine.Scene Namespace


VelocityTransformer Constructor

Initializes a new instance of the VelocityTransformer class.

public VelocityTransformer();

See Also

VelocityTransformer Class | Goblin.Engine.Scene Namespace


VelocityTransformer Properties

The properties of the VelocityTransformer class are listed below. For a complete list of VelocityTransformer class members, see the VelocityTransformer Members topic.

Public Instance Properties

Current (inherited from Transformer)
Velocity

See Also

VelocityTransformer Class | Goblin.Engine.Scene Namespace


Velocity Property

Goblin - A Platform for 3D AR and VR Applications

VelocityTransformer.Velocity Property

public float Velocity {get; set;}

See Also

VelocityTransformer Class | Goblin.Engine.Scene Namespace


VelocityTransformer Methods

The methods of the VelocityTransformer class are listed below. For a complete list of VelocityTransformer class members, see the VelocityTransformer Members topic.

Public Instance Methods

AddCollisionListener (inherited from Transformer) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FrameMove (inherited from Transformer) | Determines the new position for an object. If arriving at the new position would cause a collision, OnAfterCollisionDetection is called.
GetCollisionPosition (inherited from Transformer) |
GetDesiredPosition |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
OnBeforeCollided |
OnCollided |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

VelocityTransformer Class | Goblin.Engine.Scene Namespace


VelocityTransformer.GetDesiredPosition Method

public override bool GetDesiredPosition(
Xfrm cur,
float elapsed,
ref Xfrm desired
);

See Also

VelocityTransformer Class | Goblin.Engine.Scene Namespace


VelocityTransformer.OnBeforeCollided Method

public void OnBeforeCollided(
Node node,
Node root,
Node nodeHit,
Xfrm old,
IntersectInformation intersect,
Xfrm desired
);

Implements

ICollisionListener.OnBeforeCollided

See Also

VelocityTransformer Class | Goblin.Engine.Scene Namespace


VelocityTransformer.OnCollided Method

public void OnCollided(
Node node,
Node root,
Node nodeHit,
Xfrm old,
Xfrm collided,
IntersectInformation intersect,
ref Xfrm desired
);

Implements

ICollisionListener.OnCollided

See Also

VelocityTransformer Class | Goblin.Engine.Scene Namespace


Xfrm Class

For a list of all members of this type, see Xfrm Members.

System.Object
Goblin.Engine.Scene.Xfrm

public class Xfrm : ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Goblin.Engine.Scene

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

Xfrm Members | Goblin.Engine.Scene Namespace


Xfrm Members

Xfrm overview

Public Static Operators

Equality Operator
Inequality Operator

Public Instance Constructors

Xfrm Constructor Initializes a new instance of the Xfrm class.

Public Instance Fields

position
rotation
scaling

Public Instance Properties

Scale

Public Instance Methods

Clone |
Combine |
Copy |
Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
IsIdentity |
rotateAxis |
rotateX |
rotateY |
rotateYPR |
rotateZ |
scale | Overloaded.
setPosition |
setScaling |
ToString (inherited from Object) | Returns a String that represents the current Object.
translate | Overloaded.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Xfrm Class | Goblin.Engine.Scene Namespace


Xfrm Constructor

Initializes a new instance of the Xfrm class.

public Xfrm();

See Also

Xfrm Class | Goblin.Engine.Scene Namespace


Xfrm Fields

The fields of the Xfrm class are listed below. For a complete list of Xfrm class members, see the Xfrm Members topic.

Public Instance Fields

position
rotation
scaling

See Also

Xfrm Class | Goblin.Engine.Scene Namespace


Xfrm.position Field

public Matrix position;

See Also

Xfrm Class | Goblin.Engine.Scene Namespace


Xfrm.rotation Field

public Matrix rotation;

See Also

Xfrm Class | Goblin.Engine.Scene Namespace


Xfrm.scaling Field

public Matrix scaling;

See Also

Xfrm Class | Goblin.Engine.Scene Namespace


Xfrm Properties

The properties of the Xfrm class are listed below. For a complete list of Xfrm class members, see the Xfrm Members topic.

Public Instance Properties

Scale

See Also

Xfrm Class | Goblin.Engine.Scene Namespace


Scale Property

Goblin - A Platform for 3D AR and VR Applications

Xfrm.Scale Property

public Microsoft.DirectX.Matrix Scale {get; set;}

See Also

Xfrm Class | Goblin.Engine.Scene Namespace


Xfrm Methods

The methods of the Xfrm class are listed below. For a complete list of Xfrm class members, see the Xfrm Members topic.

Public Instance Methods

Clone |
Combine |
Copy |
Equals |
GetHashCode |
GetType (inherited from Object) | Gets the Type of the current instance.
IsIdentity |
rotateAxis |
rotateX |
rotateY |
rotateYPR |
rotateZ |
scale | Overloaded.
setPosition |
setScaling |
ToString (inherited from Object) | Returns a String that represents the current Object.
translate | Overloaded.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Xfrm Class | Goblin.Engine.Scene Namespace


Xfrm.Clone Method

public object Clone();

Implements

ICloneable.Clone

See Also

Xfrm Class | Goblin.Engine.Scene Namespace


Xfrm.Combine Method

public Matrix Combine();

See Also

Xfrm Class | Goblin.Engine.Scene Namespace


Xfrm.Copy Method

public Xfrm Copy();

See Also

Xfrm Class | Goblin.Engine.Scene Namespace


Xfrm.Equals Method

public override bool Equals(
object rhs
);

See Also

Xfrm Class | Goblin.Engine.Scene Namespace


Xfrm.GetHashCode Method

public override int GetHashCode();

See Also

Xfrm Class | Goblin.Engine.Scene Namespace


Xfrm.IsIdentity Method

public bool IsIdentity();

See Also

Xfrm Class | Goblin.Engine.Scene Namespace


Xfrm.rotateAxis Method

public void rotateAxis(
Vector3 axis,
float radians
);

See Also

Xfrm Class | Goblin.Engine.Scene Namespace


Xfrm.rotateX Method

public void rotateX(
float radians
);

See Also

Xfrm Class | Goblin.Engine.Scene Namespace


Xfrm.rotateY Method

public void rotateY(
float radians
);

See Also

Xfrm Class | Goblin.Engine.Scene Namespace


Xfrm.rotateYPR Method

public void rotateYPR(
float yaw,
float pitch,
float roll
);

See Also

Xfrm Class | Goblin.Engine.Scene Namespace


Xfrm.rotateZ Method

public void rotateZ(
float radians
);

See Also

Xfrm Class | Goblin.Engine.Scene Namespace


scale Method

Goblin - A Platform for 3D AR and VR Applications

Xfrm.scale Method

Overload List

public void scale(float);

public void scale(float,float,float);

See Also

Xfrm Class | Goblin.Engine.Scene Namespace


Xfrm.scale Method (Single)

public void scale(
float scalar
);

See Also

Xfrm Class | Goblin.Engine.Scene Namespace | Xfrm.scale Overload List


Xfrm.scale Method (Single, Single, Single)

public void scale(
float x,
float y,
float z
);

See Also

Xfrm Class | Goblin.Engine.Scene Namespace | Xfrm.scale Overload List


Xfrm.setPosition Method

public void setPosition(
float x,
float y,
float z
);

See Also

Xfrm Class | Goblin.Engine.Scene Namespace


Xfrm.setScaling Method

public void setScaling(
float x,
float y,
float z
);

See Also

Xfrm Class | Goblin.Engine.Scene Namespace


translate Method

Goblin - A Platform for 3D AR and VR Applications

Xfrm.translate Method

Overload List

public void translate(Vector3);

public void translate(float,float,float);

See Also

Xfrm Class | Goblin.Engine.Scene Namespace


Xfrm.translate Method (Vector3)

public void translate(
Vector3 vec
);

See Also

Xfrm Class | Goblin.Engine.Scene Namespace | Xfrm.translate Overload List


Xfrm.translate Method (Single, Single, Single)

public void translate(
float x,
float y,
float z
);

See Also

Xfrm Class | Goblin.Engine.Scene Namespace | Xfrm.translate Overload List


Xfrm Operators

The operators of the Xfrm class are listed below. For a complete list of Xfrm class members, see the Xfrm Members topic.

Public Static Operators

Equality Operator
Inequality Operator

See Also

Xfrm Class | Xfrm Members | Goblin.Engine.Scene Namespace


Xfrm Equality Operator

public static bool operator ==(
Xfrm lhs,
Xfrm rhs
);

See Also

Xfrm Class | Goblin.Engine.Scene Namespace


Xfrm Inequality Operator

public static bool operator !=(
Xfrm lhs,
Xfrm rhs
);

See Also

Xfrm Class | Goblin.Engine.Scene Namespace


Goblin.Engine.Utilities

Goblin - A Platform for 3D AR and VR Applications

Goblin.Engine.Utilities Namespace

Namespace hierarchy

Classes

Class | Description
MyTrace | Summary description for MyTrace.
MyUtility | Summary description for MyUtility.
XmlSerializerHelper | Use this class' static functions to serialize/deserialize Goblin objects This adds a layer of functionality on top of System.Xml.Serialization Namely, it allows an object to take part in its own serialization/deserialization by implementing one or more of ICustomSerialization, IInitAfterDeserialization If an object wishes to provide its own deserialization, its Deserialize method must by necessity be static Therefore, provide the following function in your class and XmlSerializerHelper will call it in lieu of its own deserialization code public static object Deserialize(XmlReader reader, Type[] extraTypes)

Interfaces

Interface | Description
ICustomSerialization |
IInitAfterDeserialization |


ICustomSerialization Interface

For a list of all members of this type, see ICustomSerialization Members.

public interface ICustomSerialization

Types that implement ICustomSerialization

Type | Description
InputDeviceMapper | This class performs two functions 1) it provides a mapping from string identifier to InputDevice, via its indexer 2) it contains a list of all InputDeviceDrivers, and serializes them when it itself is serialized

Requirements

Namespace: Goblin.Engine.Utilities

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

ICustomSerialization Members | Goblin.Engine.Utilities Namespace


ICustomSerialization Members

ICustomSerialization overview

Public Instance Methods

Serialize

See Also

ICustomSerialization Interface | Goblin.Engine.Utilities Namespace


ICustomSerialization Methods

The methods of the ICustomSerialization interface are listed below. For a complete list of ICustomSerialization interface members, see the ICustomSerialization Members topic.

Public Instance Methods

Serialize

See Also

ICustomSerialization Interface | Goblin.Engine.Utilities Namespace


ICustomSerialization.Serialize Method

void Serialize(
XmlWriter writer,
Type[] extraTypes
);

See Also

ICustomSerialization Interface | Goblin.Engine.Utilities Namespace


IInitAfterDeserialization Interface

For a list of all members of this type, see IInitAfterDeserialization Members.

public interface IInitAfterDeserialization

Types that implement IInitAfterDeserialization

Type | Description
InputDeviceMapper | This class performs two functions 1) it provides a mapping from string identifier to InputDevice, via its indexer 2) it contains a list of all InputDeviceDrivers, and serializes them when it itself is serialized

Requirements

Namespace: Goblin.Engine.Utilities

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

IInitAfterDeserialization Members | Goblin.Engine.Utilities Namespace


IInitAfterDeserialization Members

IInitAfterDeserialization overview

Public Instance Methods

InitAfterDeserialization

See Also

IInitAfterDeserialization Interface | Goblin.Engine.Utilities Namespace


IInitAfterDeserialization Methods

The methods of the IInitAfterDeserialization interface are listed below. For a complete list of IInitAfterDeserialization interface members, see the IInitAfterDeserialization Members topic.

Public Instance Methods

InitAfterDeserialization

See Also

IInitAfterDeserialization Interface | Goblin.Engine.Utilities Namespace


IInitAfterDeserialization.InitAfterDeserialization Method

void InitAfterDeserialization();

See Also

IInitAfterDeserialization Interface | Goblin.Engine.Utilities Namespace


MyTrace Class

Summary description for MyTrace.

For a list of all members of this type, see MyTrace Members.

System.Object
Goblin.Engine.Utilities.MyTrace

public class MyTrace

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Goblin.Engine.Utilities

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

MyTrace Members | Goblin.Engine.Utilities Namespace


MyTrace Members

MyTrace overview

Public Static Fields

level
source

Public Static Methods

Log | Overloaded.
OutputDebugString |

Public Instance Constructors

MyTrace Constructor Initializes a new instance of the MyTrace class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MyTrace Class | Goblin.Engine.Utilities Namespace


MyTrace Constructor

Initializes a new instance of the MyTrace class.

public MyTrace();

See Also

MyTrace Class | Goblin.Engine.Utilities Namespace


MyTrace Fields

The fields of the MyTrace class are listed below. For a complete list of MyTrace class members, see the MyTrace Members topic.

Public Static Fields

level
source

See Also

MyTrace Class | Goblin.Engine.Utilities Namespace


MyTrace.level Field

public static TraceSwitch level;

See Also

MyTrace Class | Goblin.Engine.Utilities Namespace


MyTrace.source Field

public static string source;

See Also

MyTrace Class | Goblin.Engine.Utilities Namespace


MyTrace Methods

The methods of the MyTrace class are listed below. For a complete list of MyTrace class members, see the MyTrace Members topic.

Public Static Methods

Log | Overloaded.
OutputDebugString |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MyTrace Class | Goblin.Engine.Utilities Namespace


Log Method

Goblin - A Platform for 3D AR and VR Applications

MyTrace.Log Method

Overload List

public static void Log(TraceLevel,string);

public static void Log(TraceLevel,string,params object[]);

public static void Log(string,params object[]);

See Also

MyTrace Class | Goblin.Engine.Utilities Namespace


MyTrace.Log Method (TraceLevel, String)

public static void Log(
TraceLevel levelMessage,
string msg
);

See Also

MyTrace Class | Goblin.Engine.Utilities Namespace | MyTrace.Log Overload List


MyTrace.Log Method (TraceLevel, String, Object[])

public static void Log(
TraceLevel levelMessage,
string format,
params object[] args
);

See Also

MyTrace Class | Goblin.Engine.Utilities Namespace | MyTrace.Log Overload List


MyTrace.Log Method (String, Object[])

public static void Log(
string format,
params object[] args
);

See Also

MyTrace Class | Goblin.Engine.Utilities Namespace | MyTrace.Log Overload List


MyTrace.OutputDebugString Method

public static void OutputDebugString(
string message
);

See Also

MyTrace Class | Goblin.Engine.Utilities Namespace


MyUtility Class

Summary description for MyUtility.

For a list of all members of this type, see MyUtility Members.

System.Object
Goblin.Engine.Utilities.MyUtility

public class MyUtility

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Goblin.Engine.Utilities

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

MyUtility Members | Goblin.Engine.Utilities Namespace


MyUtility Members

MyUtility overview

Public Static Methods

MatrixGetTranslation |
MatrixToString | Overloaded.
MyFindMediaFile | Overloaded.
TraceMesh |
Vector3ToDXString |
Vector3ToString | Overloaded.
XFileGuid2Str |

Public Instance Constructors

MyUtility Constructor Initializes a new instance of the MyUtility class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MyUtility Class | Goblin.Engine.Utilities Namespace


MyUtility Constructor

Initializes a new instance of the MyUtility class.

public MyUtility();

See Also

MyUtility Class | Goblin.Engine.Utilities Namespace


MyUtility Methods

The methods of the MyUtility class are listed below. For a complete list of MyUtility class members, see the MyUtility Members topic.

Public Static Methods

MatrixGetTranslation |
MatrixToString | Overloaded.
MyFindMediaFile | Overloaded.
TraceMesh |
Vector3ToDXString |
Vector3ToString | Overloaded.
XFileGuid2Str |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MyUtility Class | Goblin.Engine.Utilities Namespace


MyUtility.MatrixGetTranslation Method

public static Vector3 MatrixGetTranslation(
Matrix mat
);

See Also

MyUtility Class | Goblin.Engine.Utilities Namespace


MatrixToString Method

Goblin - A Platform for 3D AR and VR Applications

MyUtility.MatrixToString Method

Overload List

public static string MatrixToString(Matrix);

public static string MatrixToString(Matrix,string);

See Also

MyUtility Class | Goblin.Engine.Utilities Namespace


MyUtility.MatrixToString Method (Matrix)

public static string MatrixToString(
Matrix mat
);

See Also

MyUtility Class | Goblin.Engine.Utilities Namespace | MyUtility.MatrixToString Overload List


MyUtility.MatrixToString Method (Matrix, String)

public static string MatrixToString(
Matrix mat,
string name
);

See Also

MyUtility Class | Goblin.Engine.Utilities Namespace | MyUtility.MatrixToString Overload List


MyFindMediaFile Method

Goblin - A Platform for 3D AR and VR Applications

MyUtility.MyFindMediaFile Method

Overload List

public static string MyFindMediaFile(string);

public static string MyFindMediaFile(string,string);

See Also

MyUtility Class | Goblin.Engine.Utilities Namespace


MyUtility.MyFindMediaFile Method (String)

public static string MyFindMediaFile(
string filename
);

See Also

MyUtility Class | Goblin.Engine.Utilities Namespace | MyUtility.MyFindMediaFile Overload List


MyUtility.MyFindMediaFile Method (String, String)

public static string MyFindMediaFile(
string subdirectory,
string filename
);

See Also

MyUtility Class | Goblin.Engine.Utilities Namespace | MyUtility.MyFindMediaFile Overload List


MyUtility.TraceMesh Method

public static void TraceMesh(
BaseMesh mesh,
string name
);

See Also

MyUtility Class | Goblin.Engine.Utilities Namespace


MyUtility.Vector3ToDXString Method

public static string Vector3ToDXString(
Vector3 v
);

See Also

MyUtility Class | Goblin.Engine.Utilities Namespace


Vector3ToString Method

Goblin - A Platform for 3D AR and VR Applications

MyUtility.Vector3ToString Method

Overload List

public static string Vector3ToString(Vector3);

public static string Vector3ToString(Vector3,string);

See Also

MyUtility Class | Goblin.Engine.Utilities Namespace


MyUtility.Vector3ToString Method (Vector3)

public static string Vector3ToString(
Vector3 v
);

See Also

MyUtility Class | Goblin.Engine.Utilities Namespace | MyUtility.Vector3ToString Overload List


MyUtility.Vector3ToString Method (Vector3, String)

public static string Vector3ToString(
Vector3 v,
string name
);

See Also

MyUtility Class | Goblin.Engine.Utilities Namespace | MyUtility.Vector3ToString Overload List


MyUtility.XFileGuid2Str Method

public static string XFileGuid2Str(
Guid guid
);

See Also

MyUtility Class | Goblin.Engine.Utilities Namespace


XmlSerializerHelper Class

Use this class' static functions to serialize/deserialize Goblin objects This adds a layer of functionality on top of System.Xml.Serialization Namely, it allows an object to take part in its own serialization/deserialization by implementing one or more of ICustomSerialization, IInitAfterDeserialization If an object wishes to provide its own deserialization, its Deserialize method must by necessity be static Therefore, provide the following function in your class and XmlSerializerHelper will call it in lieu of its own deserialization code public static object Deserialize(XmlReader reader, Type[] extraTypes)

For a list of all members of this type, see XmlSerializerHelper Members.

System.Object
Goblin.Engine.Utilities.XmlSerializerHelper

public class XmlSerializerHelper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Goblin.Engine.Utilities

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

XmlSerializerHelper Members | Goblin.Engine.Utilities Namespace


XmlSerializerHelper Members

XmlSerializerHelper overview

Public Static Methods

Deserialize | Overloaded.
Serialize | Overloaded.

Public Instance Constructors

XmlSerializerHelper Constructor Initializes a new instance of the XmlSerializerHelper class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlSerializerHelper Class | Goblin.Engine.Utilities Namespace


XmlSerializerHelper Constructor

Initializes a new instance of the XmlSerializerHelper class.

public XmlSerializerHelper();

See Also

XmlSerializerHelper Class | Goblin.Engine.Utilities Namespace


XmlSerializerHelper Methods

The methods of the XmlSerializerHelper class are listed below. For a complete list of XmlSerializerHelper class members, see the XmlSerializerHelper Members topic.

Public Static Methods

Deserialize | Overloaded.
Serialize | Overloaded.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

XmlSerializerHelper Class | Goblin.Engine.Utilities Namespace


Deserialize Method

Goblin - A Platform for 3D AR and VR Applications

XmlSerializerHelper.Deserialize Method

Overload List

public static object Deserialize(string,Type);

public static object Deserialize(string,Type,Type[]);

public static object Deserialize(XmlReader,Type);

public static object Deserialize(XmlReader,Type,Type[]);

See Also

XmlSerializerHelper Class | Goblin.Engine.Utilities Namespace


XmlSerializerHelper.Deserialize Method (String, Type)

public static object Deserialize(
string filename,
Type t
);

See Also

XmlSerializerHelper Class | Goblin.Engine.Utilities Namespace | XmlSerializerHelper.Deserialize Overload List


XmlSerializerHelper.Deserialize Method (String, Type, Type[])

public static object Deserialize(
string filename,
Type t,
Type[] extraTypes
);

See Also

XmlSerializerHelper Class | Goblin.Engine.Utilities Namespace | XmlSerializerHelper.Deserialize Overload List


XmlSerializerHelper.Deserialize Method (XmlReader, Type)

public static object Deserialize(
XmlReader reader,
Type t
);

See Also

XmlSerializerHelper Class | Goblin.Engine.Utilities Namespace | XmlSerializerHelper.Deserialize Overload List


XmlSerializerHelper.Deserialize Method (XmlReader, Type, Type[])

public static object Deserialize(
XmlReader reader,
Type t,
Type[] extraTypes
);

See Also

XmlSerializerHelper Class | Goblin.Engine.Utilities Namespace | XmlSerializerHelper.Deserialize Overload List


Serialize Method

Goblin - A Platform for 3D AR and VR Applications

XmlSerializerHelper.Serialize Method

Overload List

public static void Serialize(string,object);

public static void Serialize(string,object,Type[]);

public static void Serialize(XmlWriter,object);

public static void Serialize(XmlWriter,object,Type[]);

See Also

XmlSerializerHelper Class | Goblin.Engine.Utilities Namespace


XmlSerializerHelper.Serialize Method (String, Object)

public static void Serialize(
string filename,
object o
);

See Also

XmlSerializerHelper Class | Goblin.Engine.Utilities Namespace | XmlSerializerHelper.Serialize Overload List


XmlSerializerHelper.Serialize Method (String, Object, Type[])

public static void Serialize(
string filename,
object o,
Type[] extraTypes
);

See Also

XmlSerializerHelper Class | Goblin.Engine.Utilities Namespace | XmlSerializerHelper.Serialize Overload List


XmlSerializerHelper.Serialize Method (XmlWriter, Object)

public static void Serialize(
XmlWriter writer,
object o
);

See Also

XmlSerializerHelper Class | Goblin.Engine.Utilities Namespace | XmlSerializerHelper.Serialize Overload List


XmlSerializerHelper.Serialize Method (XmlWriter, Object, Type[])

public static void Serialize(
XmlWriter writer,
object o,
Type[] extraTypes
);

See Also

XmlSerializerHelper Class | Goblin.Engine.Utilities Namespace | XmlSerializerHelper.Serialize Overload List


Microsoft.Samples.DirectX.UtilityToolkit

Goblin - A Platform for 3D AR and VR Applications

Microsoft.Samples.DirectX.UtilityToolkit Namespace

Namespace hierarchy

Classes

Class | Description
ArcBall | Class holds arcball data
Button | Button control
Camera | Simple base camera class that moves and rotates. The base class records mouse and keyboard input for use by a derived class, and keeps common state.
Checkbox | Checkbox control
ComboBox | Combo box control
Control | Base class for all controls
CreatingDeviceException | Creating the device failed
CreatingDeviceObjectsException | Creating the device objects failed
DeviceEventArgs | Event arguments for device creation/reset
DeviceSettings | Holds the settings for creating a device
Dialog | All controls must be assigned to a dialog, which handles input and rendering for the controls.
DialogResourceManager | Manages shared resources of dialogs
DirectionWidget | Widget for controlling direction
DirectXSampleException | Base class for sample exceptions
DisplayModeSorter | Used to sort display modes
EditBox | A basic edit box
Element | Contains all the display tweakables for a sub-control
EnumAdapterInformation | Class describing an adapter which contains a unique adapter ordinal that is installed on the system.
EnumDeviceInformation | Class describing a Direct3D device that contains a unique supported device type
EnumDeviceSettingsCombo | Class describing device settings that contain a unique combination of adapter format, back buffer format, and windowed that is compatible with a particular Direct3D device and the application
Enumeration | Enumerates available Direct3D adapters, devices, modes, etc. Singleton.
FirstPersonCamera | Simple first person camera class that moves and rotates. It allows yaw and pitch but not roll. It uses keyboard and cursor to respond to keyboard and mouse input and updates the view matrix based on input.
FontNode | Structure for shared fonts
Framework | Managed Utility Framework Class
FrameworkMesh | Class for loading and rendering file-based meshes
FrameworkTimer |
ListBox | List box control
MediaNotFoundException | Media couldn't be found
ModelViewerCamera | Simple model viewing camera class that rotates around the object.
NativeMethods | Will hold native methods which are interop'd
NoCompatibleDevicesException | No compatible devices were found for this application.
NoDirect3DException | The No Direct3D exception. Something really had to go wrong for this to occur.
RadioButton | Radio button control
ResettingDeviceException | Resetting the device failed
ResettingDeviceObjectsException | Resetting the device failed
ResourceCache | Will be a resource cache for any resources that may be required by a sample This class will be 'static'
ScrollBar | A scroll bar control
SettingsDialog | Dialog for selection of device settings
Slider | Slider control
StaticText | StaticText text control
TextureNode | Structure for shared textures
Utility | Misc utility functionality

Interfaces

Interface | Description
IDeviceCreation | Interface that the framework will use to determine if a device is acceptable
IFrameworkCallback | Interface that the framework will use to call into samples

Structures

Structure | Description
BlendColor | Blends colors
ComboBoxItem | Stores data for a combo box item
ElementHolder | Contains all the display information for a given control type
EnumDepthStencilMultisampleConflict | A depth/stencil buffer format that is incompatible with a multisample type
ListBoxItem | Stores data for a list box item
MatchOptions | Options on how to match items
NativeMethods.Message | Windows Message
NativeMethods.MinMaxInformation | MinMax Info structure
NativeMethods.MonitorInformation | Monitor Info structure
NativeMethods.WindowClass | Window class structure
TextHelper | Manages the intertion point when drawing text
TimerData | Stores timer callback information

Delegates

Delegate | Description
DeviceEventHandler | Event Handler delegate for device creation/reset
KeyboardCallback |
MouseCallback |
NativeMethods.WndProcDelegate |
TimerCallback |
WndProcCallback |

Enumerations

Enumeration | Description
CameraKeys | Used to map keys to the camera
ControlState | Possible states of a control
ControlType | Predefined control types
ListBoxStyle | Style of the list box
MatchType | Used when finding valid device settings
MouseButtonMask | Mouse button mask values
NativeMethods.MouseButtons | Mouse buttons
NativeMethods.PeekMessageFlags | Peek message flags
NativeMethods.ShowWindowFlags | Show window flags styles
NativeMethods.WindowMessage | Window messages
NativeMethods.WindowStyles | Window styles
SettingsDialogControlIds |


ArcBall Class

Class holds arcball data

For a list of all members of this type, see ArcBall Members.

System.Object
Microsoft.Samples.DirectX.UtilityToolkit.ArcBall

public class ArcBall

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

ArcBall Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ArcBall Members

ArcBall overview

Public Static Methods

QuaternionFromBallPoints Computes a quaternion from ball points

Public Instance Constructors

ArcBall Constructor Create new instance of the arcball class

Public Instance Properties

CurrentQuaternion | Gets or sets the current quaternion
IsBeingDragged | Gets the dragging state
RotationMatrix | Gets the rotation matrix
TranslationDeltaMatrix | Gets the translation delta matrix
TranslationMatrix | Gets the translation matrix

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HandleMessages | Handle messages from the window
OnBegin | Begin the arcball 'dragging'
OnEnd | Done dragging the arcball
OnMove | The arcball is 'moving'
Reset | Resets the arcball
ScreenToVector | Convert a screen point to a vector
SetWindow | Overloaded. Set window paramters
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

center
currentPt
downPt
downQuat
height
isDragging
lastMousePosition
nowQuat
radius
radiusTranslation
rotation
translation
translationDelta
width

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ArcBall Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ArcBall Constructor

Create new instance of the arcball class

public ArcBall();

See Also

ArcBall Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ArcBall Fields

The fields of the ArcBall class are listed below. For a complete list of ArcBall class members, see the ArcBall Members topic.

Protected Instance Fields

center
currentPt
downPt
downQuat
height
isDragging
lastMousePosition
nowQuat
radius
radiusTranslation
rotation
translation
translationDelta
width

See Also

ArcBall Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ArcBall.center Field

protected Vector2 center;

See Also

ArcBall Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ArcBall.currentPt Field

protected Vector3 currentPt;

See Also

ArcBall Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ArcBall.downPt Field

protected Vector3 downPt;

See Also

ArcBall Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ArcBall.downQuat Field

protected Quaternion downQuat;

See Also

ArcBall Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ArcBall.height Field

protected int height;

See Also

ArcBall Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ArcBall.isDragging Field

protected bool isDragging;

See Also

ArcBall Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ArcBall.lastMousePosition Field

protected Point lastMousePosition;

See Also

ArcBall Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ArcBall.nowQuat Field

protected Quaternion nowQuat;

See Also

ArcBall Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ArcBall.radius Field

protected float radius;

See Also

ArcBall Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ArcBall.radiusTranslation Field

protected float radiusTranslation;

See Also

ArcBall Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ArcBall.rotation Field

protected Matrix rotation;

See Also

ArcBall Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ArcBall.translation Field

protected Matrix translation;

See Also

ArcBall Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ArcBall.translationDelta Field

protected Matrix translationDelta;

See Also

ArcBall Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ArcBall.width Field

protected int width;

See Also

ArcBall Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ArcBall Properties

The properties of the ArcBall class are listed below. For a complete list of ArcBall class members, see the ArcBall Members topic.

Public Instance Properties

CurrentQuaternion | Gets or sets the current quaternion
IsBeingDragged | Gets the dragging state
RotationMatrix | Gets the rotation matrix
TranslationDeltaMatrix | Gets the translation delta matrix
TranslationMatrix | Gets the translation matrix

See Also

ArcBall Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


CurrentQuaternion Property

Goblin - A Platform for 3D AR and VR Applications

ArcBall.CurrentQuaternion Property

Gets or sets the current quaternion

public Microsoft.DirectX.Quaternion CurrentQuaternion {get; set;}

See Also

ArcBall Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


IsBeingDragged Property

Goblin - A Platform for 3D AR and VR Applications

ArcBall.IsBeingDragged Property

Gets the dragging state

public bool IsBeingDragged {get;}

See Also

ArcBall Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


RotationMatrix Property

Goblin - A Platform for 3D AR and VR Applications

ArcBall.RotationMatrix Property

Gets the rotation matrix

public Microsoft.DirectX.Matrix RotationMatrix {get;}

See Also

ArcBall Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


TranslationDeltaMatrix Property

Goblin - A Platform for 3D AR and VR Applications

ArcBall.TranslationDeltaMatrix Property

Gets the translation delta matrix

public Microsoft.DirectX.Matrix TranslationDeltaMatrix {get;}

See Also

ArcBall Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


TranslationMatrix Property

Goblin - A Platform for 3D AR and VR Applications

ArcBall.TranslationMatrix Property

Gets the translation matrix

public Microsoft.DirectX.Matrix TranslationMatrix {get;}

See Also

ArcBall Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ArcBall Methods

The methods of the ArcBall class are listed below. For a complete list of ArcBall class members, see the ArcBall Members topic.

Public Static Methods

QuaternionFromBallPoints Computes a quaternion from ball points

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HandleMessages | Handle messages from the window
OnBegin | Begin the arcball 'dragging'
OnEnd | Done dragging the arcball
OnMove | The arcball is 'moving'
Reset | Resets the arcball
ScreenToVector | Convert a screen point to a vector
SetWindow | Overloaded. Set window paramters
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ArcBall Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ArcBall.HandleMessages Method

Handle messages from the window

public bool HandleMessages(
IntPtr hWnd,
WindowMessage msg,
IntPtr wParam,
IntPtr lParam
);

See Also

ArcBall Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ArcBall.OnBegin Method

Begin the arcball 'dragging'

public void OnBegin(
int x,
int y
);

See Also

ArcBall Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ArcBall.OnEnd Method

Done dragging the arcball

public void OnEnd();

See Also

ArcBall Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ArcBall.OnMove Method

The arcball is 'moving'

public void OnMove(
int x,
int y
);

See Also

ArcBall Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ArcBall.QuaternionFromBallPoints Method

Computes a quaternion from ball points

public static Quaternion QuaternionFromBallPoints(
Vector3 from,
Vector3 to
);

See Also

ArcBall Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ArcBall.Reset Method

Resets the arcball

public void Reset();

See Also

ArcBall Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ArcBall.ScreenToVector Method

Convert a screen point to a vector

public Vector3 ScreenToVector(
float screenPointX,
float screenPointY
);

See Also

ArcBall Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


SetWindow Method

Goblin - A Platform for 3D AR and VR Applications

ArcBall.SetWindow Method

Overload List

public void SetWindow(int,int);

Set window paramters

public void SetWindow(int,int,float);

See Also

ArcBall Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ArcBall.SetWindow Method (Int32, Int32)

public void SetWindow(
int w,
int h
);

See Also

ArcBall Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | ArcBall.SetWindow Overload List


ArcBall.SetWindow Method (Int32, Int32, Single)

Set window paramters

public void SetWindow(
int w,
int h,
float r
);

See Also

ArcBall Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | ArcBall.SetWindow Overload List


BlendColor Structure

Blends colors

For a list of all members of this type, see BlendColor Members.

System.Object
System.ValueType
Microsoft.Samples.DirectX.UtilityToolkit.BlendColor

public struct BlendColor

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

BlendColor Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


BlendColor Members

BlendColor overview

Public Instance Fields

Current
States

Public Instance Methods

Blend | Overloaded. Blend the colors together
Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize | Overloaded. Initialize the color blending
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

BlendColor Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


BlendColor Fields

The fields of the BlendColor structure are listed below. For a complete list of BlendColor structure members, see the BlendColor Members topic.

Public Instance Fields

Current
States

See Also

BlendColor Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


BlendColor.Current Field

public ColorValue Current;

See Also

BlendColor Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


BlendColor.States Field

public ColorValue[] States;

See Also

BlendColor Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


BlendColor Methods

The methods of the BlendColor structure are listed below. For a complete list of BlendColor structure members, see the BlendColor Members topic.

Public Instance Methods

Blend | Overloaded. Blend the colors together
Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize | Overloaded. Initialize the color blending
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

BlendColor Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Blend Method

Goblin - A Platform for 3D AR and VR Applications

BlendColor.Blend Method

Blend the colors together

Overload List

Blend the colors together

public void Blend(ControlState,float);

Blend the colors together

public void Blend(ControlState,float,float);

See Also

BlendColor Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


BlendColor.Blend Method (ControlState, Single)

Blend the colors together

public void Blend(
ControlState state,
float elapsedTime
);

See Also

BlendColor Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | BlendColor.Blend Overload List


BlendColor.Blend Method (ControlState, Single, Single)

Blend the colors together

public void Blend(
ControlState state,
float elapsedTime,
float rate
);

See Also

BlendColor Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | BlendColor.Blend Overload List


Initialize Method

Goblin - A Platform for 3D AR and VR Applications

BlendColor.Initialize Method

Initialize the color blending

Overload List

Initialize the color blending

public void Initialize(ColorValue);

Initialize the color blending

public void Initialize(ColorValue,ColorValue,ColorValue);

See Also

BlendColor Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


BlendColor.Initialize Method (ColorValue)

Initialize the color blending

public void Initialize(
ColorValue defaultColor
);

See Also

BlendColor Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | BlendColor.Initialize Overload List


BlendColor.Initialize Method (ColorValue, ColorValue, ColorValue)

Initialize the color blending

public void Initialize(
ColorValue defaultColor,
ColorValue disabledColor,
ColorValue hiddenColor
);

See Also

BlendColor Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | BlendColor.Initialize Overload List


Button Class

Button control

For a list of all members of this type, see Button Members.

System.Object
Microsoft.Samples.DirectX.UtilityToolkit.Control
Microsoft.Samples.DirectX.UtilityToolkit.StaticText
Microsoft.Samples.DirectX.UtilityToolkit.Button

public class Button : StaticText

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

Button Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Button Members

Button overview

Public Static Fields

ButtonLayer
FillLayer

Public Instance Constructors

Button Constructor Create new button instance

Public Instance Fields

index (inherited from Control)
isDefault (inherited from Control)

Public Instance Properties

CanHaveFocus | Can the button have focus
ControlType (inherited from Control) | Type of the control
Hotkey (inherited from Control) | The controls hotkey
ID (inherited from Control) | Unique ID of the control
IsEnabled (inherited from Control) | Is the control enabled
IsVisible (inherited from Control) | Is the control visible
Item (inherited from Control) | Index for the elements this control has access to
Parent (inherited from Control) | The parent dialog of this control
UserData (inherited from Control) | User specified data

Public Instance Methods

ContainsPoint (inherited from Control) | Does the control contain this point
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetTextCopy (inherited from StaticText) | Return a copy of the string
GetType (inherited from Object) | Gets the Type of the current instance.
HandleKeyboard | Will handle the keyboard strokes
HandleMouse | Handle mouse messages from the buttons
MsgProc (inherited from Control) | Message Handler
OnFocusIn (inherited from Control) | Called when control gets focus
OnFocusOut (inherited from Control) | Called when control loses focus
OnHotKey | The hotkey for this button was pressed
OnInitialize (inherited from Control) | Initialize the control
OnMouseEnter (inherited from Control) | Called when mouse goes over the control
OnMouseExit (inherited from Control) | Called when mouse leaves the control
Refresh (inherited from Control) | Refreshes the control
Render | Render the button
SetLocation (inherited from Control) | Called to set control's location
SetSize (inherited from Control) | Called to set control's size
SetText (inherited from StaticText) | Sets the updated text for this control
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

Click

Protected Instance Fields

boundingBox (inherited from Control)
controlId (inherited from Control)
controlType (inherited from Control)
controlX (inherited from Control)
controlY (inherited from Control)
elementList (inherited from Control)
enabled (inherited from Control)
hasFocus (inherited from Control)
height (inherited from Control)
hotKey (inherited from Control)
isMouseOver (inherited from Control)
isPressed
localUserData (inherited from Control)
parentDialog (inherited from Control)
textData (inherited from StaticText)
visible (inherited from Control)
width (inherited from Control)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseClickEvent | Create new button instance
UpdateRectangles (inherited from Control) | Updates the rectangles

See Also

Button Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Button Constructor

Create new button instance

public Button(
Dialog parent
);

See Also

Button Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Button Fields

The fields of the Button class are listed below. For a complete list of Button class members, see the Button Members topic.

Public Static Fields

ButtonLayer
FillLayer

Public Instance Fields

index (inherited from Control)
isDefault (inherited from Control)

Protected Instance Fields

boundingBox (inherited from Control)
controlId (inherited from Control)
controlType (inherited from Control)
controlX (inherited from Control)
controlY (inherited from Control)
elementList (inherited from Control)
enabled (inherited from Control)
hasFocus (inherited from Control)
height (inherited from Control)
hotKey (inherited from Control)
isMouseOver (inherited from Control)
isPressed
localUserData (inherited from Control)
parentDialog (inherited from Control)
textData (inherited from StaticText)
visible (inherited from Control)
width (inherited from Control)

See Also

Button Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Button.ButtonLayer Field

public const int ButtonLayer = 0;

See Also

Button Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Button.FillLayer Field

public const int FillLayer = 1;

See Also

Button Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Button.isPressed Field

protected bool isPressed;

See Also

Button Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Button Properties

The properties of the Button class are listed below. For a complete list of Button class members, see the Button Members topic.

Public Instance Properties

CanHaveFocus | Can the button have focus
ControlType (inherited from Control) | Type of the control
Hotkey (inherited from Control) | The controls hotkey
ID (inherited from Control) | Unique ID of the control
IsEnabled (inherited from Control) | Is the control enabled
IsVisible (inherited from Control) | Is the control visible
Item (inherited from Control) | Index for the elements this control has access to
Parent (inherited from Control) | The parent dialog of this control
UserData (inherited from Control) | User specified data

See Also

Button Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


CanHaveFocus Property

Goblin - A Platform for 3D AR and VR Applications

Button.CanHaveFocus Property

Can the button have focus

public override bool CanHaveFocus {get;}

See Also

Button Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Button Methods

The methods of the Button class are listed below. For a complete list of Button class members, see the Button Members topic.

Public Instance Methods

ContainsPoint (inherited from Control) | Does the control contain this point
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetTextCopy (inherited from StaticText) | Return a copy of the string
GetType (inherited from Object) | Gets the Type of the current instance.
HandleKeyboard | Will handle the keyboard strokes
HandleMouse | Handle mouse messages from the buttons
MsgProc (inherited from Control) | Message Handler
OnFocusIn (inherited from Control) | Called when control gets focus
OnFocusOut (inherited from Control) | Called when control loses focus
OnHotKey | The hotkey for this button was pressed
OnInitialize (inherited from Control) | Initialize the control
OnMouseEnter (inherited from Control) | Called when mouse goes over the control
OnMouseExit (inherited from Control) | Called when mouse leaves the control
Refresh (inherited from Control) | Refreshes the control
Render | Render the button
SetLocation (inherited from Control) | Called to set control's location
SetSize (inherited from Control) | Called to set control's size
SetText (inherited from StaticText) | Sets the updated text for this control
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseClickEvent | Create new button instance
UpdateRectangles (inherited from Control) | Updates the rectangles

See Also

Button Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Button.HandleKeyboard Method

Will handle the keyboard strokes

public override bool HandleKeyboard(
WindowMessage msg,
IntPtr wParam,
IntPtr lParam
);

See Also

Button Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Button.HandleMouse Method

Handle mouse messages from the buttons

public override bool HandleMouse(
WindowMessage msg,
Point pt,
IntPtr wParam,
IntPtr lParam
);

See Also

Button Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Button.OnHotKey Method

The hotkey for this button was pressed

public override void OnHotKey();

See Also

Button Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Button.RaiseClickEvent Method

Create new button instance

protected void RaiseClickEvent(
Button sender,
bool wasTriggeredByUser
);

See Also

Button Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Button.Render Method

Render the button

public override void Render(
Device device,
float elapsedTime
);

See Also

Button Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Button Events

The events of the Button class are listed below. For a complete list of Button class members, see the Button Members topic.

Public Instance Events

Click

See Also

Button Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Button.Click Event

public event EventHandler Click;

See Also

Button Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera Class

Simple base camera class that moves and rotates. The base class records mouse and keyboard input for use by a derived class, and keeps common state.

For a list of all members of this type, see Camera Members.

System.Object
Microsoft.Samples.DirectX.UtilityToolkit.Camera

public abstract class Camera

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

Camera Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera Members

Camera overview

Public Static Fields

UpDirection

Protected Static Methods

MapKey Maps NativeMethods.WindowMessage.Key* msg to a camera key

Public Instance Properties

EyeLocation | Returns the location of the eye
IsBeingDragged | Is the camera being 'dragged' at all?
IsMouseLeftButtonDown | Is the left mouse button down
IsMouseMiddleButtonDown | Is the middle mouse button down
IsMouseRightButtonDown | Is the right mouse button down
IsPositionMovementEnabled | Is position movement enabled
LookAtPoint | Returns the look at point of the camera
ProjectionMatrix | Returns the projection transformation matrix
ViewMatrix | Returns the view transformation matrix

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FrameMove | Abstract method to control camera during frame move
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HandleMessages | Call this from your message proc so this class can handle window messages
Reset | Reset the camera's position back to the default
SetProjectionParameters | Calculates the projection matrix based on input params
SetViewParameters | Client can call this to change the position and direction of camera
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

Camera Constructor Constructor for the base camera class (Sets up camera defaults)

Protected Instance Fields

aspectRatio
cameraPitchAngle
cameraYawAngle
currentButtonMask
defaultEye
defaultLookAt
dragRectangle
dragTimer
eye
farPlane
fieldOfView
framesToSmoothMouseData
isClipToBoundary
isEnablePositionMovement
isEnableYAxisMovement
isInvertPitch
isMouseLButtonDown
isMouseMButtonDown
isMouseRButtonDown
isMovementDrag
isResetCursorAfterMove
keys
lastMousePosition
lookAt
maxBoundary
minBoundary
mouseDelta
mouseWheelDelta
moveScaler
nearPlane
projMatrix
rotationScaler
rotationVelocity
totalDragTimeToZero
velocity
velocityDrag
viewMatrix

Protected Instance Methods

ConstrainToBoundary | Clamps V to lie inside boundaries
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
UpdateMouseDelta | Figure out the mouse delta based on mouse movement
UpdateVelocity |

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera Constructor

Constructor for the base camera class (Sets up camera defaults)

protected Camera();

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera Fields

The fields of the Camera class are listed below. For a complete list of Camera class members, see the Camera Members topic.

Public Static Fields

UpDirection

Protected Instance Fields

aspectRatio
cameraPitchAngle
cameraYawAngle
currentButtonMask
defaultEye
defaultLookAt
dragRectangle
dragTimer
eye
farPlane
fieldOfView
framesToSmoothMouseData
isClipToBoundary
isEnablePositionMovement
isEnableYAxisMovement
isInvertPitch
isMouseLButtonDown
isMouseMButtonDown
isMouseRButtonDown
isMovementDrag
isResetCursorAfterMove
keys
lastMousePosition
lookAt
maxBoundary
minBoundary
mouseDelta
mouseWheelDelta
moveScaler
nearPlane
projMatrix
rotationScaler
rotationVelocity
totalDragTimeToZero
velocity
velocityDrag
viewMatrix

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera.aspectRatio Field

protected float aspectRatio;

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera.cameraPitchAngle Field

protected float cameraPitchAngle;

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera.cameraYawAngle Field

protected float cameraYawAngle;

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera.currentButtonMask Field

protected int currentButtonMask;

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera.defaultEye Field

protected Vector3 defaultEye;

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera.defaultLookAt Field

protected Vector3 defaultLookAt;

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera.dragRectangle Field

protected Rectangle dragRectangle;

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera.dragTimer Field

protected float dragTimer;

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera.eye Field

protected Vector3 eye;

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera.farPlane Field

protected float farPlane;

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera.fieldOfView Field

protected float fieldOfView;

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera.framesToSmoothMouseData Field

protected float framesToSmoothMouseData;

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera.isClipToBoundary Field

protected bool isClipToBoundary;

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera.isEnablePositionMovement Field

protected bool isEnablePositionMovement;

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera.isEnableYAxisMovement Field

protected bool isEnableYAxisMovement;

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera.isInvertPitch Field

protected bool isInvertPitch;

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera.isMouseLButtonDown Field

protected bool isMouseLButtonDown;

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera.isMouseMButtonDown Field

protected bool isMouseMButtonDown;

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera.isMouseRButtonDown Field

protected bool isMouseRButtonDown;

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera.isMovementDrag Field

protected bool isMovementDrag;

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera.isResetCursorAfterMove Field

protected bool isResetCursorAfterMove;

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera.keys Field

protected bool[] keys;

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera.lastMousePosition Field

protected Point lastMousePosition;

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera.lookAt Field

protected Vector3 lookAt;

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera.maxBoundary Field

protected Vector3 maxBoundary;

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera.minBoundary Field

protected Vector3 minBoundary;

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera.mouseDelta Field

protected Vector2 mouseDelta;

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera.mouseWheelDelta Field

protected int mouseWheelDelta;

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera.moveScaler Field

protected float moveScaler;

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera.nearPlane Field

protected float nearPlane;

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera.projMatrix Field

protected Matrix projMatrix;

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera.rotationScaler Field

protected float rotationScaler;

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera.rotationVelocity Field

protected Vector2 rotationVelocity;

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera.totalDragTimeToZero Field

protected float totalDragTimeToZero;

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera.UpDirection Field

public static readonly Vector3 UpDirection;

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera.velocity Field

protected Vector3 velocity;

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera.velocityDrag Field

protected Vector3 velocityDrag;

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ViewMatrix Property

Goblin - A Platform for 3D AR and VR Applications

Camera.ViewMatrix Property

Returns the view transformation matrix

public Microsoft.DirectX.Matrix ViewMatrix {get;}

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera Properties

The properties of the Camera class are listed below. For a complete list of Camera class members, see the Camera Members topic.

Public Instance Properties

EyeLocation | Returns the location of the eye
IsBeingDragged | Is the camera being 'dragged' at all?
IsMouseLeftButtonDown | Is the left mouse button down
IsMouseMiddleButtonDown | Is the middle mouse button down
IsMouseRightButtonDown | Is the right mouse button down
IsPositionMovementEnabled | Is position movement enabled
LookAtPoint | Returns the look at point of the camera
ProjectionMatrix | Returns the projection transformation matrix
ViewMatrix | Returns the view transformation matrix

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EyeLocation Property

Goblin - A Platform for 3D AR and VR Applications

Camera.EyeLocation Property

Returns the location of the eye

public Microsoft.DirectX.Vector3 EyeLocation {get;}

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


IsBeingDragged Property

Goblin - A Platform for 3D AR and VR Applications

Camera.IsBeingDragged Property

Is the camera being 'dragged' at all?

public bool IsBeingDragged {get;}

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


IsMouseLeftButtonDown Property

Goblin - A Platform for 3D AR and VR Applications

Camera.IsMouseLeftButtonDown Property

Is the left mouse button down

public bool IsMouseLeftButtonDown {get;}

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


IsMouseMiddleButtonDown Property

Goblin - A Platform for 3D AR and VR Applications

Camera.IsMouseMiddleButtonDown Property

Is the middle mouse button down

public bool IsMouseMiddleButtonDown {get;}

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


IsMouseRightButtonDown Property

Goblin - A Platform for 3D AR and VR Applications

Camera.IsMouseRightButtonDown Property

Is the right mouse button down

public bool IsMouseRightButtonDown {get;}

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


IsPositionMovementEnabled Property

Goblin - A Platform for 3D AR and VR Applications

Camera.IsPositionMovementEnabled Property

Is position movement enabled

public bool IsPositionMovementEnabled {get; set;}

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


LookAtPoint Property

Goblin - A Platform for 3D AR and VR Applications

Camera.LookAtPoint Property

Returns the look at point of the camera

public Microsoft.DirectX.Vector3 LookAtPoint {get;}

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ProjectionMatrix Property

Goblin - A Platform for 3D AR and VR Applications

Camera.ProjectionMatrix Property

Returns the projection transformation matrix

public Microsoft.DirectX.Matrix ProjectionMatrix {get;}

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera Methods

The methods of the Camera class are listed below. For a complete list of Camera class members, see the Camera Members topic.

Protected Static Methods

MapKey Maps NativeMethods.WindowMessage.Key* msg to a camera key

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FrameMove | Abstract method to control camera during frame move
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HandleMessages | Call this from your message proc so this class can handle window messages
Reset | Reset the camera's position back to the default
SetProjectionParameters | Calculates the projection matrix based on input params
SetViewParameters | Client can call this to change the position and direction of camera
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

ConstrainToBoundary | Clamps V to lie inside boundaries
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
UpdateMouseDelta | Figure out the mouse delta based on mouse movement
UpdateVelocity |

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera.ConstrainToBoundary Method

Clamps V to lie inside boundaries

protected void ConstrainToBoundary(
ref Vector3 v
);

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera.FrameMove Method

Abstract method to control camera during frame move

public abstract void FrameMove(
float elapsedTime
);

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera.HandleMessages Method

Call this from your message proc so this class can handle window messages

public virtual bool HandleMessages(
IntPtr hWnd,
WindowMessage msg,
IntPtr wParam,
IntPtr lParam
);

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera.MapKey Method

Maps NativeMethods.WindowMessage.Key* msg to a camera key

protected static CameraKeys MapKey(
IntPtr param
);

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera.Reset Method

Reset the camera's position back to the default

public virtual void Reset();

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera.SetProjectionParameters Method

Calculates the projection matrix based on input params

public virtual void SetProjectionParameters(
float fov,
float aspect,
float near,
float far
);

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera.SetViewParameters Method

Client can call this to change the position and direction of camera

public virtual void SetViewParameters(
Vector3 eyePt,
Vector3 lookAtPt
);

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera.UpdateMouseDelta Method

Figure out the mouse delta based on mouse movement

protected void UpdateMouseDelta(
float elapsedTime
);

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Camera.UpdateVelocity Method

protected void UpdateVelocity(
float elapsedTime
);

See Also

Camera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


CameraKeys Enumeration

Used to map keys to the camera

public enum CameraKeys

Members

Member Name | Description
StrafeLeft |
StrafeRight |
MoveForward |
MoveBackward |
MoveUp |
MoveDown |
Reset |
ControlDown |
MaxKeys |
Unknown |

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

Microsoft.Samples.DirectX.UtilityToolkit Namespace


Checkbox Class

Checkbox control

For a list of all members of this type, see Checkbox Members.

System.Object
Microsoft.Samples.DirectX.UtilityToolkit.Control
Microsoft.Samples.DirectX.UtilityToolkit.StaticText
Microsoft.Samples.DirectX.UtilityToolkit.Button
Microsoft.Samples.DirectX.UtilityToolkit.Checkbox

public class Checkbox : Button

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

Checkbox Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Checkbox Members

Checkbox overview

Public Static Fields

BoxLayer
CheckLayer

Public Instance Constructors

Checkbox Constructor Create new checkbox instance

Public Instance Fields

index (inherited from Control)
isDefault (inherited from Control)

Public Instance Properties

CanHaveFocus (inherited from Button) | Can the button have focus
ControlType (inherited from Control) | Type of the control
Hotkey (inherited from Control) | The controls hotkey
ID (inherited from Control) | Unique ID of the control
IsChecked | Checked property
IsEnabled (inherited from Control) | Is the control enabled
IsVisible (inherited from Control) | Is the control visible
Item (inherited from Control) | Index for the elements this control has access to
Parent (inherited from Control) | The parent dialog of this control
UserData (inherited from Control) | User specified data

Public Instance Methods

ContainsPoint | Does the control contain the point?
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetTextCopy (inherited from StaticText) | Return a copy of the string
GetType (inherited from Object) | Gets the Type of the current instance.
HandleKeyboard | Handle the keyboard for the checkbox
HandleMouse | Handle mouse messages from the checkbox
MsgProc (inherited from Control) | Message Handler
OnFocusIn (inherited from Control) | Called when control gets focus
OnFocusOut (inherited from Control) | Called when control loses focus
OnHotKey | Override hotkey to fire event
OnInitialize (inherited from Control) | Initialize the control
OnMouseEnter (inherited from Control) | Called when mouse goes over the control
OnMouseExit (inherited from Control) | Called when mouse leaves the control
Refresh (inherited from Control) | Refreshes the control
Render | Render the checkbox control
SetLocation (inherited from Control) | Called to set control's location
SetSize (inherited from Control) | Called to set control's size
SetText (inherited from StaticText) | Sets the updated text for this control
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

Changed
Click (inherited from Button)

Protected Instance Fields

boundingBox (inherited from Control)
buttonRect
controlId (inherited from Control)
controlType (inherited from Control)
controlX (inherited from Control)
controlY (inherited from Control)
elementList (inherited from Control)
enabled (inherited from Control)
hasFocus (inherited from Control)
height (inherited from Control)
hotKey (inherited from Control)
isBoxChecked
isMouseOver (inherited from Control)
isPressed (inherited from Button)
localUserData (inherited from Control)
parentDialog (inherited from Control)
textData (inherited from StaticText)
textRect
visible (inherited from Control)
width (inherited from Control)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseChangedEvent | Create new button instance
RaiseClickEvent (inherited from Button) | Create new button instance
SetCheckedInternal | Sets the checked state and fires the event if necessary
UpdateRectangles | Update the rectangles

See Also

Checkbox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Checkbox Constructor

Create new checkbox instance

public Checkbox(
Dialog parent
);

See Also

Checkbox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Checkbox Fields

The fields of the Checkbox class are listed below. For a complete list of Checkbox class members, see the Checkbox Members topic.

Public Static Fields

BoxLayer
CheckLayer

Public Instance Fields

index (inherited from Control)
isDefault (inherited from Control)

Protected Instance Fields

boundingBox (inherited from Control)
buttonRect
controlId (inherited from Control)
controlType (inherited from Control)
controlX (inherited from Control)
controlY (inherited from Control)
elementList (inherited from Control)
enabled (inherited from Control)
hasFocus (inherited from Control)
height (inherited from Control)
hotKey (inherited from Control)
isBoxChecked
isMouseOver (inherited from Control)
isPressed (inherited from Button)
localUserData (inherited from Control)
parentDialog (inherited from Control)
textData (inherited from StaticText)
textRect
visible (inherited from Control)
width (inherited from Control)

See Also

Checkbox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Checkbox.BoxLayer Field

public const int BoxLayer = 0;

See Also

Checkbox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Checkbox.buttonRect Field

protected Rectangle buttonRect;

See Also

Checkbox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Checkbox.CheckLayer Field

public const int CheckLayer = 1;

See Also

Checkbox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Checkbox.isBoxChecked Field

protected bool isBoxChecked;

See Also

Checkbox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Checkbox.textRect Field

protected Rectangle textRect;

See Also

Checkbox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Checkbox Properties

The properties of the Checkbox class are listed below. For a complete list of Checkbox class members, see the Checkbox Members topic.

Public Instance Properties

CanHaveFocus (inherited from Button) | Can the button have focus
ControlType (inherited from Control) | Type of the control
Hotkey (inherited from Control) | The controls hotkey
ID (inherited from Control) | Unique ID of the control
IsChecked | Checked property
IsEnabled (inherited from Control) | Is the control enabled
IsVisible (inherited from Control) | Is the control visible
Item (inherited from Control) | Index for the elements this control has access to
Parent (inherited from Control) | The parent dialog of this control
UserData (inherited from Control) | User specified data

See Also

Checkbox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


IsChecked Property

Goblin - A Platform for 3D AR and VR Applications

Checkbox.IsChecked Property

Checked property

public virtual bool IsChecked {get; set;}

See Also

Checkbox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Checkbox Methods

The methods of the Checkbox class are listed below. For a complete list of Checkbox class members, see the Checkbox Members topic.

Public Instance Methods

ContainsPoint | Does the control contain the point?
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetTextCopy (inherited from StaticText) | Return a copy of the string
GetType (inherited from Object) | Gets the Type of the current instance.
HandleKeyboard | Handle the keyboard for the checkbox
HandleMouse | Handle mouse messages from the checkbox
MsgProc (inherited from Control) | Message Handler
OnFocusIn (inherited from Control) | Called when control gets focus
OnFocusOut (inherited from Control) | Called when control loses focus
OnHotKey | Override hotkey to fire event
OnInitialize (inherited from Control) | Initialize the control
OnMouseEnter (inherited from Control) | Called when mouse goes over the control
OnMouseExit (inherited from Control) | Called when mouse leaves the control
Refresh (inherited from Control) | Refreshes the control
Render | Render the checkbox control
SetLocation (inherited from Control) | Called to set control's location
SetSize (inherited from Control) | Called to set control's size
SetText (inherited from StaticText) | Sets the updated text for this control
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseChangedEvent | Create new button instance
RaiseClickEvent (inherited from Button) | Create new button instance
SetCheckedInternal | Sets the checked state and fires the event if necessary
UpdateRectangles | Update the rectangles

See Also

Checkbox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Checkbox.ContainsPoint Method

Does the control contain the point?

public override bool ContainsPoint(
Point pt
);

See Also

Checkbox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Checkbox.HandleKeyboard Method

Handle the keyboard for the checkbox

public override bool HandleKeyboard(
WindowMessage msg,
IntPtr wParam,
IntPtr lParam
);

See Also

Checkbox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Checkbox.HandleMouse Method

Handle mouse messages from the checkbox

public override bool HandleMouse(
WindowMessage msg,
Point pt,
IntPtr wParam,
IntPtr lParam
);

See Also

Checkbox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Checkbox.OnHotKey Method

Override hotkey to fire event

public override void OnHotKey();

See Also

Checkbox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Checkbox.RaiseChangedEvent Method

Create new button instance

protected void RaiseChangedEvent(
Checkbox sender,
bool wasTriggeredByUser
);

See Also

Checkbox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Checkbox.Render Method

Render the checkbox control

public override void Render(
Device device,
float elapsedTime
);

See Also

Checkbox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Checkbox.SetCheckedInternal Method

Sets the checked state and fires the event if necessary

protected virtual void SetCheckedInternal(
bool ischecked,
bool fromInput
);

See Also

Checkbox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Checkbox.UpdateRectangles Method

Update the rectangles

protected override void UpdateRectangles();

See Also

Checkbox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Checkbox Events

The events of the Checkbox class are listed below. For a complete list of Checkbox class members, see the Checkbox Members topic.

Public Instance Events

Changed
Click (inherited from Button)

See Also

Checkbox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Checkbox.Changed Event

public event EventHandler Changed;

See Also

Checkbox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBox Class

Combo box control

For a list of all members of this type, see ComboBox Members.

System.Object
Microsoft.Samples.DirectX.UtilityToolkit.Control
Microsoft.Samples.DirectX.UtilityToolkit.StaticText
Microsoft.Samples.DirectX.UtilityToolkit.Button
Microsoft.Samples.DirectX.UtilityToolkit.ComboBox

public class ComboBox : Button

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

ComboBox Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBox Members

ComboBox overview

Public Static Fields

ComboButtonLayer
DropdownLayer
MainLayer
SelectionLayer

Public Instance Constructors

ComboBox Constructor Create new combo box control

Public Instance Fields

index (inherited from Control)
isDefault (inherited from Control)

Public Instance Properties

CanHaveFocus | Can this control have focus
ControlType (inherited from Control) | Type of the control
Hotkey (inherited from Control) | The controls hotkey
ID (inherited from Control) | Unique ID of the control
IsEnabled (inherited from Control) | Is the control enabled
IsVisible (inherited from Control) | Is the control visible
Item | Overloaded. Indexer for items in the list
NumberItems | Number of items current in the list
Parent (inherited from Control) | The parent dialog of this control
UserData (inherited from Control) | User specified data

Public Instance Methods

AddItem | Adds an item to the combo box control
Clear | Removes all items from the control
ContainsItem | Overloaded. Determines whether this control contains an item
ContainsPoint (inherited from Control) | Does the control contain this point
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetItemData | Gets the data for an item
GetSelectedData | Gets the data for the selected item
GetSelectedItem | Gets the selected item
GetTextCopy (inherited from StaticText) | Return a copy of the string
GetType (inherited from Object) | Gets the Type of the current instance.
HandleKeyboard | Called when the control needs to handle the keyboard
HandleMouse | Called when the control should handle the mouse
MsgProc (inherited from Control) | Message Handler
OnFocusIn (inherited from Control) | Called when control gets focus
OnFocusOut | Called when focus leaves the control
OnHotKey | Called when the control's hotkey is pressed
OnInitialize | Initialize the scrollbar control here
OnMouseEnter (inherited from Control) | Called when mouse goes over the control
OnMouseExit (inherited from Control) | Called when mouse leaves the control
Refresh (inherited from Control) | Refreshes the control
RemoveAt | Removes an item at a particular index
Render | Called when the control should be rendered
SetDropHeight | Sets the drop height of this control
SetLocation (inherited from Control) | Called to set control's location
SetScrollbarWidth | Sets the scroll bar width of this control
SetSelected | Overloaded. Sets the selected item by index
SetSelectedByData | Sets the selected item by data
SetSize (inherited from Control) | Called to set control's size
SetText (inherited from StaticText) | Sets the updated text for this control
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

Changed
Click (inherited from Button)

Protected Instance Fields

boundingBox (inherited from Control)
buttonRect
controlId (inherited from Control)
controlType (inherited from Control)
controlX (inherited from Control)
controlY (inherited from Control)
dropDownRect
dropDownTextRect
dropHeight
elementList (inherited from Control)
enabled (inherited from Control)
focusedIndex
hasFocus (inherited from Control)
height (inherited from Control)
hotKey (inherited from Control)
isComboOpen
isMouseOver (inherited from Control)
isPressed (inherited from Button)
itemList
localUserData (inherited from Control)
parentDialog (inherited from Control)
scrollbarControl
scrollWidth
selectedIndex
textData (inherited from StaticText)
textRect
visible (inherited from Control)
width (inherited from Control)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FindItem | Overloaded. Finds an item in the list and returns the index
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseChangedEvent | Create new button instance
RaiseClickEvent (inherited from Button) | Create new button instance
UpdateRectangles | Update the rectangles for the combo box control

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBox Constructor

Create new combo box control

public ComboBox(
Dialog parent
);

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBox Fields

The fields of the ComboBox class are listed below. For a complete list of ComboBox class members, see the ComboBox Members topic.

Public Static Fields

ComboButtonLayer
DropdownLayer
MainLayer
SelectionLayer

Public Instance Fields

index (inherited from Control)
isDefault (inherited from Control)

Protected Instance Fields

boundingBox (inherited from Control)
buttonRect
controlId (inherited from Control)
controlType (inherited from Control)
controlX (inherited from Control)
controlY (inherited from Control)
dropDownRect
dropDownTextRect
dropHeight
elementList (inherited from Control)
enabled (inherited from Control)
focusedIndex
hasFocus (inherited from Control)
height (inherited from Control)
hotKey (inherited from Control)
isComboOpen
isMouseOver (inherited from Control)
isPressed (inherited from Button)
itemList
localUserData (inherited from Control)
parentDialog (inherited from Control)
scrollbarControl
scrollWidth
selectedIndex
textData (inherited from StaticText)
textRect
visible (inherited from Control)
width (inherited from Control)

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBox.buttonRect Field

protected Rectangle buttonRect;

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBox.ComboButtonLayer Field

public const int ComboButtonLayer = 1;

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBox.DropdownLayer Field

public const int DropdownLayer = 2;

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBox.dropDownRect Field

protected Rectangle dropDownRect;

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBox.dropDownTextRect Field

protected Rectangle dropDownTextRect;

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBox.dropHeight Field

protected int dropHeight;

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBox.focusedIndex Field

protected int focusedIndex;

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBox.isComboOpen Field

protected bool isComboOpen;

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBox.itemList Field

protected ArrayList itemList;

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBox.MainLayer Field

public const int MainLayer = 0;

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBox.scrollbarControl Field

protected ScrollBar scrollbarControl;

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBox.scrollWidth Field

protected int scrollWidth;

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBox.selectedIndex Field

protected int selectedIndex;

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBox.SelectionLayer Field

public const int SelectionLayer = 3;

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBox.textRect Field

protected Rectangle textRect;

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBox Properties

The properties of the ComboBox class are listed below. For a complete list of ComboBox class members, see the ComboBox Members topic.

Public Instance Properties

CanHaveFocus | Can this control have focus
ControlType (inherited from Control) | Type of the control
Hotkey (inherited from Control) | The controls hotkey
ID (inherited from Control) | Unique ID of the control
IsEnabled (inherited from Control) | Is the control enabled
IsVisible (inherited from Control) | Is the control visible
Item | Overloaded. Indexer for items in the list
NumberItems | Number of items current in the list
Parent (inherited from Control) | The parent dialog of this control
UserData (inherited from Control) | User specified data

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


CanHaveFocus Property

Goblin - A Platform for 3D AR and VR Applications

ComboBox.CanHaveFocus Property

Can this control have focus

public override bool CanHaveFocus {get;}

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Item Property

Goblin - A Platform for 3D AR and VR Applications

ComboBox.Item Property

Indexer for items in the list

public ComboBoxItem this[
int index
] {get;}

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NumberItems Property

Goblin - A Platform for 3D AR and VR Applications

ComboBox.NumberItems Property

Number of items current in the list

public int NumberItems {get;}

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBox Methods

The methods of the ComboBox class are listed below. For a complete list of ComboBox class members, see the ComboBox Members topic.

Public Instance Methods

AddItem | Adds an item to the combo box control
Clear | Removes all items from the control
ContainsItem | Overloaded. Determines whether this control contains an item
ContainsPoint (inherited from Control) | Does the control contain this point
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetItemData | Gets the data for an item
GetSelectedData | Gets the data for the selected item
GetSelectedItem | Gets the selected item
GetTextCopy (inherited from StaticText) | Return a copy of the string
GetType (inherited from Object) | Gets the Type of the current instance.
HandleKeyboard | Called when the control needs to handle the keyboard
HandleMouse | Called when the control should handle the mouse
MsgProc (inherited from Control) | Message Handler
OnFocusIn (inherited from Control) | Called when control gets focus
OnFocusOut | Called when focus leaves the control
OnHotKey | Called when the control's hotkey is pressed
OnInitialize | Initialize the scrollbar control here
OnMouseEnter (inherited from Control) | Called when mouse goes over the control
OnMouseExit (inherited from Control) | Called when mouse leaves the control
Refresh (inherited from Control) | Refreshes the control
RemoveAt | Removes an item at a particular index
Render | Called when the control should be rendered
SetDropHeight | Sets the drop height of this control
SetLocation (inherited from Control) | Called to set control's location
SetScrollbarWidth | Sets the scroll bar width of this control
SetSelected | Overloaded. Sets the selected item by index
SetSelectedByData | Sets the selected item by data
SetSize (inherited from Control) | Called to set control's size
SetText (inherited from StaticText) | Sets the updated text for this control
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FindItem | Overloaded. Finds an item in the list and returns the index
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseChangedEvent | Create new button instance
RaiseClickEvent (inherited from Button) | Create new button instance
UpdateRectangles | Update the rectangles for the combo box control

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBox.AddItem Method

Adds an item to the combo box control

public void AddItem(
string text,
object data
);

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBox.Clear Method

Removes all items from the control

public void Clear();

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ContainsItem Method

Goblin - A Platform for 3D AR and VR Applications

ComboBox.ContainsItem Method

Determines whether this control contains an item

Overload List

Determines whether this control contains an item

public bool ContainsItem(string);

Determines whether this control contains an item

public bool ContainsItem(string,int);

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBox.ContainsItem Method (String)

Determines whether this control contains an item

public bool ContainsItem(
string text
);

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | ComboBox.ContainsItem Overload List


ComboBox.ContainsItem Method (String, Int32)

Determines whether this control contains an item

public bool ContainsItem(
string text,
int start
);

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | ComboBox.ContainsItem Overload List


FindItem Method

Goblin - A Platform for 3D AR and VR Applications

ComboBox.FindItem Method

Finds an item in the list and returns the index

Overload List

Finds an item in the list and returns the index

protected int FindItem(string);

Finds an item in the list and returns the index

protected int FindItem(string,int);

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBox.FindItem Method (String)

Finds an item in the list and returns the index

protected int FindItem(
string text
);

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | ComboBox.FindItem Overload List


ComboBox.FindItem Method (String, Int32)

Finds an item in the list and returns the index

protected int FindItem(
string text,
int start
);

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | ComboBox.FindItem Overload List


ComboBox.GetItemData Method

Gets the data for an item

public object GetItemData(
string text
);

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBox.GetSelectedData Method

Gets the data for the selected item

public object GetSelectedData();

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBox.GetSelectedItem Method

Gets the selected item

public ComboBoxItem GetSelectedItem();

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBox.HandleKeyboard Method

Called when the control needs to handle the keyboard

public override bool HandleKeyboard(
WindowMessage msg,
IntPtr wParam,
IntPtr lParam
);

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBox.HandleMouse Method

Called when the control should handle the mouse

public override bool HandleMouse(
WindowMessage msg,
Point pt,
IntPtr wParam,
IntPtr lParam
);

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBox.OnFocusOut Method

Called when focus leaves the control

public override void OnFocusOut();

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBox.OnHotKey Method

Called when the control's hotkey is pressed

public override void OnHotKey();

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBox.OnInitialize Method

Initialize the scrollbar control here

public override void OnInitialize();

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBox.RaiseChangedEvent Method

Create new button instance

protected void RaiseChangedEvent(
ComboBox sender,
bool wasTriggeredByUser
);

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBox.RemoveAt Method

Removes an item at a particular index

public void RemoveAt(
int index
);

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBox.Render Method

Called when the control should be rendered

public override void Render(
Device device,
float elapsedTime
);

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBox.SetDropHeight Method

Sets the drop height of this control

public void SetDropHeight(
int height
);

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBox.SetScrollbarWidth Method

Sets the scroll bar width of this control

public void SetScrollbarWidth(
int width
);

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


SetSelected Method

Goblin - A Platform for 3D AR and VR Applications

ComboBox.SetSelected Method

Sets the selected item by index

Overload List

Sets the selected item by index

public void SetSelected(int);

Sets the selected item by text

public void SetSelected(string);

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBox.SetSelected Method (Int32)

Sets the selected item by index

public void SetSelected(
int index
);

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | ComboBox.SetSelected Overload List


ComboBox.SetSelected Method (String)

Sets the selected item by text

public void SetSelected(
string text
);

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | ComboBox.SetSelected Overload List


ComboBox.SetSelectedByData Method

Sets the selected item by data

public void SetSelectedByData(
object data
);

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBox.UpdateRectangles Method

Update the rectangles for the combo box control

protected override void UpdateRectangles();

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBox Events

The events of the ComboBox class are listed below. For a complete list of ComboBox class members, see the ComboBox Members topic.

Public Instance Events

Changed
Click (inherited from Button)

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBox.Changed Event

public event EventHandler Changed;

See Also

ComboBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBoxItem Structure

Stores data for a combo box item

For a list of all members of this type, see ComboBoxItem Members.

System.Object
System.ValueType
Microsoft.Samples.DirectX.UtilityToolkit.ComboBoxItem

public struct ComboBoxItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

ComboBoxItem Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBoxItem Members

ComboBoxItem overview

Public Instance Fields

IsItemVisible
ItemData
ItemRect
ItemText

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

ComboBoxItem Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBoxItem Fields

The fields of the ComboBoxItem structure are listed below. For a complete list of ComboBoxItem structure members, see the ComboBoxItem Members topic.

Public Instance Fields

IsItemVisible
ItemData
ItemRect
ItemText

See Also

ComboBoxItem Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBoxItem.IsItemVisible Field

public bool IsItemVisible;

See Also

ComboBoxItem Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBoxItem.ItemData Field

public object ItemData;

See Also

ComboBoxItem Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBoxItem.ItemRect Field

public Rectangle ItemRect;

See Also

ComboBoxItem Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ComboBoxItem.ItemText Field

public string ItemText;

See Also

ComboBoxItem Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Control Class

Base class for all controls

For a list of all members of this type, see Control Members.

System.Object
Microsoft.Samples.DirectX.UtilityToolkit.Control

public abstract class Control

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

Control Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Control Members

Control overview

Public Instance Fields

index
isDefault

Public Instance Properties

CanHaveFocus | Can the control have focus
ControlType | Type of the control
Hotkey | The controls hotkey
ID | Unique ID of the control
IsEnabled | Is the control enabled
IsVisible | Is the control visible
Item | Index for the elements this control has access to
Parent | The parent dialog of this control
UserData | User specified data

Public Instance Methods

ContainsPoint | Does the control contain this point
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HandleKeyboard | Handle the keyboard data
HandleMouse | Handle the mouse data
MsgProc | Message Handler
OnFocusIn | Called when control gets focus
OnFocusOut | Called when control loses focus
OnHotKey | Called when the control's hotkey is hit
OnInitialize | Initialize the control
OnMouseEnter | Called when mouse goes over the control
OnMouseExit | Called when mouse leaves the control
Refresh | Refreshes the control
Render | Render the control
SetLocation | Called to set control's location
SetSize | Called to set control's size
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

Control Constructor Create a new instance of a control

Protected Instance Fields

boundingBox
controlId
controlType
controlX
controlY
elementList
enabled
hasFocus
height
hotKey
isMouseOver
localUserData
parentDialog
visible
width

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
UpdateRectangles | Updates the rectangles

See Also

Control Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Control Constructor

Create a new instance of a control

protected Control(
Dialog parent
);

See Also

Control Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Control Fields

The fields of the Control class are listed below. For a complete list of Control class members, see the Control Members topic.

Public Instance Fields

index
isDefault

Protected Instance Fields

boundingBox
controlId
controlType
controlX
controlY
elementList
enabled
hasFocus
height
hotKey
isMouseOver
localUserData
parentDialog
visible
width

See Also

Control Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Control.boundingBox Field

protected Rectangle boundingBox;

See Also

Control Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Control.controlId Field

protected int controlId;

See Also

Control Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ControlType Property

Goblin - A Platform for 3D AR and VR Applications

Control.ControlType Property

Type of the control

public virtual ControlType ControlType {get;}

See Also

Control Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Control.controlX Field

protected int controlX;

See Also

Control Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Control.controlY Field

protected int controlY;

See Also

Control Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Control.elementList Field

protected ArrayList elementList;

See Also

Control Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Control.enabled Field

protected bool enabled;

See Also

Control Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Control.hasFocus Field

protected bool hasFocus;

See Also

Control Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Control.height Field

protected int height;

See Also

Control Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Hotkey Property

Goblin - A Platform for 3D AR and VR Applications

Control.Hotkey Property

The controls hotkey

public virtual System.Windows.Forms.Keys Hotkey {get; set;}

See Also

Control Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Control.index Field

public uint index;

See Also

Control Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Control.isDefault Field

public bool isDefault;

See Also

Control Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Control.isMouseOver Field

protected bool isMouseOver;

See Also

Control Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Control.localUserData Field

protected object localUserData;

See Also

Control Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Control.parentDialog Field

protected Dialog parentDialog;

See Also

Control Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Control.visible Field

protected bool visible;

See Also

Control Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Control.width Field

protected int width;

See Also

Control Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Control Properties

The properties of the Control class are listed below. For a complete list of Control class members, see the Control Members topic.

Public Instance Properties

CanHaveFocus | Can the control have focus
ControlType | Type of the control
Hotkey | The controls hotkey
ID | Unique ID of the control
IsEnabled | Is the control enabled
IsVisible | Is the control visible
Item | Index for the elements this control has access to
Parent | The parent dialog of this control
UserData | User specified data

See Also

Control Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


CanHaveFocus Property

Goblin - A Platform for 3D AR and VR Applications

Control.CanHaveFocus Property

Can the control have focus

public virtual bool CanHaveFocus {get;}

See Also

Control Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ID Property

Goblin - A Platform for 3D AR and VR Applications

Control.ID Property

Unique ID of the control

public virtual int ID {get; set;}

See Also

Control Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


IsEnabled Property

Goblin - A Platform for 3D AR and VR Applications

Control.IsEnabled Property

Is the control enabled

public virtual bool IsEnabled {get; set;}

See Also

Control Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


IsVisible Property

Goblin - A Platform for 3D AR and VR Applications

Control.IsVisible Property

Is the control visible

public virtual bool IsVisible {get; set;}

See Also

Control Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Item Property

Goblin - A Platform for 3D AR and VR Applications

Control.Item Property

Index for the elements this control has access to

public Element this[
uint index
] {get; set;}

See Also

Control Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Parent Property

Goblin - A Platform for 3D AR and VR Applications

Control.Parent Property

The parent dialog of this control

public Dialog Parent {get;}

See Also

Control Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


UserData Property

Goblin - A Platform for 3D AR and VR Applications

Control.UserData Property

User specified data

public object UserData {get; set;}

See Also

Control Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Control Methods

The methods of the Control class are listed below. For a complete list of Control class members, see the Control Members topic.

Public Instance Methods

ContainsPoint | Does the control contain this point
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HandleKeyboard | Handle the keyboard data
HandleMouse | Handle the mouse data
MsgProc | Message Handler
OnFocusIn | Called when control gets focus
OnFocusOut | Called when control loses focus
OnHotKey | Called when the control's hotkey is hit
OnInitialize | Initialize the control
OnMouseEnter | Called when mouse goes over the control
OnMouseExit | Called when mouse leaves the control
Refresh | Refreshes the control
Render | Render the control
SetLocation | Called to set control's location
SetSize | Called to set control's size
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
UpdateRectangles | Updates the rectangles

See Also

Control Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Control.ContainsPoint Method

Does the control contain this point

public virtual bool ContainsPoint(
Point pt
);

See Also

Control Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Control.HandleKeyboard Method

Handle the keyboard data

public virtual bool HandleKeyboard(
WindowMessage msg,
IntPtr wParam,
IntPtr lParam
);

See Also

Control Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Control.HandleMouse Method

Handle the mouse data

public virtual bool HandleMouse(
WindowMessage msg,
Point pt,
IntPtr wParam,
IntPtr lParam
);

See Also

Control Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Control.MsgProc Method

Message Handler

public virtual bool MsgProc(
IntPtr hWnd,
WindowMessage msg,
IntPtr wParam,
IntPtr lParam
);

See Also

Control Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Control.OnFocusIn Method

Called when control gets focus

public virtual void OnFocusIn();

See Also

Control Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Control.OnFocusOut Method

Called when control loses focus

public virtual void OnFocusOut();

See Also

Control Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Control.OnHotKey Method

Called when the control's hotkey is hit

public virtual void OnHotKey();

See Also

Control Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Control.OnInitialize Method

Initialize the control

public virtual void OnInitialize();

See Also

Control Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Control.OnMouseEnter Method

Called when mouse goes over the control

public virtual void OnMouseEnter();

See Also

Control Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Control.OnMouseExit Method

Called when mouse leaves the control

public virtual void OnMouseExit();

See Also

Control Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Control.Refresh Method

Refreshes the control

public virtual void Refresh();

See Also

Control Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Control.Render Method

Render the control

public virtual void Render(
Device device,
float elapsedTime
);

See Also

Control Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Control.SetLocation Method

Called to set control's location

public virtual void SetLocation(
int x,
int y
);

See Also

Control Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Control.SetSize Method

Called to set control's size

public virtual void SetSize(
int w,
int h
);

See Also

Control Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Control.UpdateRectangles Method

Updates the rectangles

protected virtual void UpdateRectangles();

See Also

Control Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ControlState Enumeration

Possible states of a control

public enum ControlState

Members

Member Name | Description
Normal |
Disabled |
Hidden |
Focus |
MouseOver |
Pressed |
LastState |

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

Microsoft.Samples.DirectX.UtilityToolkit Namespace


ControlType Enumeration

Predefined control types

public enum ControlType

Members

Member Name | Description
StaticText |
Button |
CheckBox |
RadioButton |
ComboBox |
Slider |
ListBox |
EditBox |
Scrollbar |

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

Microsoft.Samples.DirectX.UtilityToolkit Namespace


CreatingDeviceException Class

Creating the device failed

For a list of all members of this type, see CreatingDeviceException Members.

System.Object
System.Exception
System.ApplicationException
Microsoft.Samples.DirectX.UtilityToolkit.DirectXSampleException
Microsoft.Samples.DirectX.UtilityToolkit.CreatingDeviceException

public class CreatingDeviceException : DirectXSampleException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

CreatingDeviceException Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


CreatingDeviceException Members

CreatingDeviceException overview

Public Instance Constructors

CreatingDeviceException Overloaded. Initializes a new instance of the CreatingDeviceException class.

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CreatingDeviceException Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


CreatingDeviceException Constructor

Initializes a new instance of the CreatingDeviceException class.

Overload List

Initializes a new instance of the CreatingDeviceException class.

public CreatingDeviceException();

public CreatingDeviceException(Exception);

See Also

CreatingDeviceException Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


CreatingDeviceException Constructor ()

Initializes a new instance of the CreatingDeviceException class.

public CreatingDeviceException();

See Also

CreatingDeviceException Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | CreatingDeviceException Constructor Overload List


CreatingDeviceException Constructor (Exception)

public CreatingDeviceException(
Exception inner
);

See Also

CreatingDeviceException Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | CreatingDeviceException Constructor Overload List


CreatingDeviceObjectsException Class

Creating the device objects failed

For a list of all members of this type, see CreatingDeviceObjectsException Members.

System.Object
System.Exception
System.ApplicationException
Microsoft.Samples.DirectX.UtilityToolkit.DirectXSampleException
Microsoft.Samples.DirectX.UtilityToolkit.CreatingDeviceObjectsException

public class CreatingDeviceObjectsException : DirectXSampleException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

CreatingDeviceObjectsException Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


CreatingDeviceObjectsException Members

CreatingDeviceObjectsException overview

Public Instance Constructors

CreatingDeviceObjectsException Overloaded. Initializes a new instance of the CreatingDeviceObjectsException class.

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CreatingDeviceObjectsException Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


CreatingDeviceObjectsException Constructor

Initializes a new instance of the CreatingDeviceObjectsException class.

Overload List

Initializes a new instance of the CreatingDeviceObjectsException class.

public CreatingDeviceObjectsException();

public CreatingDeviceObjectsException(Exception);

See Also

CreatingDeviceObjectsException Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


CreatingDeviceObjectsException Constructor ()

Initializes a new instance of the CreatingDeviceObjectsException class.

public CreatingDeviceObjectsException();

See Also

CreatingDeviceObjectsException Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | CreatingDeviceObjectsException Constructor Overload List


CreatingDeviceObjectsException Constructor (Exception)

public CreatingDeviceObjectsException(
Exception inner
);

See Also

CreatingDeviceObjectsException Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | CreatingDeviceObjectsException Constructor Overload List


DeviceEventArgs Class

Event arguments for device creation/reset

For a list of all members of this type, see DeviceEventArgs Members.

System.Object
System.EventArgs
Microsoft.Samples.DirectX.UtilityToolkit.DeviceEventArgs

public class DeviceEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

DeviceEventArgs Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DeviceEventArgs Members

DeviceEventArgs overview

Public Instance Constructors

DeviceEventArgs Constructor

Public Instance Fields

BackBufferDescription
Device

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DeviceEventArgs Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DeviceEventArgs Constructor

public DeviceEventArgs(
Device d,
SurfaceDescription desc
);

See Also

DeviceEventArgs Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DeviceEventArgs Fields

The fields of the DeviceEventArgs class are listed below. For a complete list of DeviceEventArgs class members, see the DeviceEventArgs Members topic.

Public Instance Fields

BackBufferDescription
Device

See Also

DeviceEventArgs Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DeviceEventArgs.BackBufferDescription Field

public SurfaceDescription BackBufferDescription;

See Also

DeviceEventArgs Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DeviceEventArgs.Device Field

public Device Device;

See Also

DeviceEventArgs Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DeviceEventHandler Delegate

Event Handler delegate for device creation/reset

public delegate void DeviceEventHandler(
object sender,
DeviceEventArgs e
);

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

Microsoft.Samples.DirectX.UtilityToolkit Namespace


DeviceSettings Class

Holds the settings for creating a device

For a list of all members of this type, see DeviceSettings Members.

System.Object
Microsoft.Samples.DirectX.UtilityToolkit.DeviceSettings

public class DeviceSettings : ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

DeviceSettings Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DeviceSettings Members

DeviceSettings overview

Public Instance Constructors

DeviceSettings Constructor Initializes a new instance of the DeviceSettings class.

Public Instance Fields

AdapterFormat
AdapterOrdinal
BehaviorFlags
DeviceType
presentParams

Public Instance Methods

Clone | Clone this object
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DeviceSettings Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DeviceSettings Constructor

Initializes a new instance of the DeviceSettings class.

public DeviceSettings();

See Also

DeviceSettings Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DeviceSettings Fields

The fields of the DeviceSettings class are listed below. For a complete list of DeviceSettings class members, see the DeviceSettings Members topic.

Public Instance Fields

AdapterFormat
AdapterOrdinal
BehaviorFlags
DeviceType
presentParams

See Also

DeviceSettings Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DeviceSettings.AdapterFormat Field

public Format AdapterFormat;

See Also

DeviceSettings Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DeviceSettings.AdapterOrdinal Field

public uint AdapterOrdinal;

See Also

DeviceSettings Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DeviceSettings.BehaviorFlags Field

public CreateFlags BehaviorFlags;

See Also

DeviceSettings Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DeviceSettings.DeviceType Field

public DeviceType DeviceType;

See Also

DeviceSettings Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DeviceSettings.presentParams Field

public PresentParameters presentParams;

See Also

DeviceSettings Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DeviceSettings Methods

The methods of the DeviceSettings class are listed below. For a complete list of DeviceSettings class members, see the DeviceSettings Members topic.

Public Instance Methods

Clone | Clone this object
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DeviceSettings Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DeviceSettings.Clone Method

Clone this object

public DeviceSettings Clone();

See Also

DeviceSettings Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog Class

All controls must be assigned to a dialog, which handles input and rendering for the controls.

For a list of all members of this type, see Dialog Members.

System.Object
Microsoft.Samples.DirectX.UtilityToolkit.Dialog

public class Dialog

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

Dialog Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog Members

Dialog overview

Public Static Fields

BlackColorValue
TransparentWhite
WheelDelta
WhiteColorValue

Public Static Methods

ClearFocus | Clears focus of the dialog
RequestFocus | Request that this control has focus
SetRefreshTime | Set the static refresh time

Public Instance Constructors

Dialog Constructor Create a new instance of the dialog class

Public Instance Properties

CaptionHeight | The dialog's caption height
Height | Dialogs height
IsMinimized | Is the dilaog minimized
IsUsingKeyboardInput | Is the dilaog using keyboard input
IsUsingMouseInput | Is the dilaog using mouse input
IsUsingNonUserEvents | Is the dilaog using non user events
Location | The dialog's location
SampleFramework |
Width | Dialogs width

Public Instance Methods

AddButton | Overloaded. Adds a button control to the dialog
AddCheckBox | Overloaded. Adds a checkbox to the dialog
AddComboBox | Overloaded. Adds a combobox control to the dialog
AddControl | Adds a control to the dialog
AddEditBox | Overloaded. Adds an edit box control to the dialog
AddListBox | Overloaded. Adds a listbox control to the dialog
AddRadioButton | Overloaded. Adds a radiobutton to the dialog
AddSlider | Overloaded. Adds a slider control to the dialog
AddStatic | Overloaded. Adds a static text control to the dialog
ClearComboBox | Clears the combo box of all items
ClearRadioButtonGroup | Clears the radio button group
DrawRectangle | Draw a rectangle
DrawSprite | Draw a sprite
DrawText | Overloaded. Draw's some text
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetButton | Returns the button control located at this index(if one exists)
GetCheckbox | Returns the checkbox control located at this index(if one exists)
GetComboBox | Returns the combo box control located at this index(if one exists)
GetControl | Overloaded. Returns the control located at this index(if one exists)
GetControlAtPoint | Returns the control located at a point (if one exists)
GetControlEnable | Gets the control enabled property
GetDefaultElement | Gets the default element
GetFont | Shared resource access. Indexed fonts and textures are shared among all the controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetListBox | Returns the listbox control located at this index(if one exists)
GetRadioButton | Returns the radio button control located at this index(if one exists)
GetSlider | Returns the slider control located at this index(if one exists)
GetStaticText | Returns the static text control located at this index(if one exists)
GetTexture | Shared resource access. Indexed fonts and textures are shared among all the controls.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeControl | Initializes a control
MessageProc | Handle messages for this dialog
OnRender | Render the dialog
RemoveAllControls | Removes all controls from this dialog
SetBackgroundColors | Overloaded. Called to set dialog's border colors
SetCaptionEnabled | Called to set dialog's caption enabled state
SetCaptionText | Called to set dialog's caption
SetControlEnable | Sets the control enabled property
SetDefaultElement | Sets the default element
SetFont | Shared resource access. Indexed fonts and textures are shared among all the controls.
SetLocation | Called to set dialog's location
SetSize | Called to set dialog's size
SetTexture | Shared resource access. Indexed fonts and textures are shared among all the controls.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog Constructor

Create a new instance of the dialog class

public Dialog(
Framework sample
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog Fields

The fields of the Dialog class are listed below. For a complete list of Dialog class members, see the Dialog Members topic.

Public Static Fields

BlackColorValue
TransparentWhite
WheelDelta
WhiteColorValue

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog.BlackColorValue Field

public static readonly ColorValue BlackColorValue;

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog.TransparentWhite Field

public static readonly ColorValue TransparentWhite;

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog.WheelDelta Field

public const int WheelDelta = 120;

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog.WhiteColorValue Field

public static readonly ColorValue WhiteColorValue;

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog Properties

The properties of the Dialog class are listed below. For a complete list of Dialog class members, see the Dialog Members topic.

Public Instance Properties

CaptionHeight | The dialog's caption height
Height | Dialogs height
IsMinimized | Is the dilaog minimized
IsUsingKeyboardInput | Is the dilaog using keyboard input
IsUsingMouseInput | Is the dilaog using mouse input
IsUsingNonUserEvents | Is the dilaog using non user events
Location | The dialog's location
SampleFramework |
Width | Dialogs width

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


CaptionHeight Property

Goblin - A Platform for 3D AR and VR Applications

Dialog.CaptionHeight Property

The dialog's caption height

public int CaptionHeight {get; set;}

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Height Property

Goblin - A Platform for 3D AR and VR Applications

Dialog.Height Property

Dialogs height

public int Height {get; set;}

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


IsMinimized Property

Goblin - A Platform for 3D AR and VR Applications

Dialog.IsMinimized Property

Is the dilaog minimized

public bool IsMinimized {get; set;}

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


IsUsingKeyboardInput Property

Goblin - A Platform for 3D AR and VR Applications

Dialog.IsUsingKeyboardInput Property

Is the dilaog using keyboard input

public bool IsUsingKeyboardInput {get; set;}

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


IsUsingMouseInput Property

Goblin - A Platform for 3D AR and VR Applications

Dialog.IsUsingMouseInput Property

Is the dilaog using mouse input

public bool IsUsingMouseInput {get; set;}

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


IsUsingNonUserEvents Property

Goblin - A Platform for 3D AR and VR Applications

Dialog.IsUsingNonUserEvents Property

Is the dilaog using non user events

public bool IsUsingNonUserEvents {get; set;}

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Location Property

Goblin - A Platform for 3D AR and VR Applications

Dialog.Location Property

The dialog's location

public System.Drawing.Point Location {get; set;}

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


SampleFramework Property

Goblin - A Platform for 3D AR and VR Applications

Dialog.SampleFramework Property

public Framework SampleFramework {get;}

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Width Property

Goblin - A Platform for 3D AR and VR Applications

Dialog.Width Property

Dialogs width

public int Width {get; set;}

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog Methods

The methods of the Dialog class are listed below. For a complete list of Dialog class members, see the Dialog Members topic.

Public Static Methods

ClearFocus | Clears focus of the dialog
RequestFocus | Request that this control has focus
SetRefreshTime | Set the static refresh time

Public Instance Methods

AddButton | Overloaded. Adds a button control to the dialog
AddCheckBox | Overloaded. Adds a checkbox to the dialog
AddComboBox | Overloaded. Adds a combobox control to the dialog
AddControl | Adds a control to the dialog
AddEditBox | Overloaded. Adds an edit box control to the dialog
AddListBox | Overloaded. Adds a listbox control to the dialog
AddRadioButton | Overloaded. Adds a radiobutton to the dialog
AddSlider | Overloaded. Adds a slider control to the dialog
AddStatic | Overloaded. Adds a static text control to the dialog
ClearComboBox | Clears the combo box of all items
ClearRadioButtonGroup | Clears the radio button group
DrawRectangle | Draw a rectangle
DrawSprite | Draw a sprite
DrawText | Overloaded. Draw's some text
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetButton | Returns the button control located at this index(if one exists)
GetCheckbox | Returns the checkbox control located at this index(if one exists)
GetComboBox | Returns the combo box control located at this index(if one exists)
GetControl | Overloaded. Returns the control located at this index(if one exists)
GetControlAtPoint | Returns the control located at a point (if one exists)
GetControlEnable | Gets the control enabled property
GetDefaultElement | Gets the default element
GetFont | Shared resource access. Indexed fonts and textures are shared among all the controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetListBox | Returns the listbox control located at this index(if one exists)
GetRadioButton | Returns the radio button control located at this index(if one exists)
GetSlider | Returns the slider control located at this index(if one exists)
GetStaticText | Returns the static text control located at this index(if one exists)
GetTexture | Shared resource access. Indexed fonts and textures are shared among all the controls.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeControl | Initializes a control
MessageProc | Handle messages for this dialog
OnRender | Render the dialog
RemoveAllControls | Removes all controls from this dialog
SetBackgroundColors | Overloaded. Called to set dialog's border colors
SetCaptionEnabled | Called to set dialog's caption enabled state
SetCaptionText | Called to set dialog's caption
SetControlEnable | Sets the control enabled property
SetDefaultElement | Sets the default element
SetFont | Shared resource access. Indexed fonts and textures are shared among all the controls.
SetLocation | Called to set dialog's location
SetSize | Called to set dialog's size
SetTexture | Shared resource access. Indexed fonts and textures are shared among all the controls.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


AddButton Method

Goblin - A Platform for 3D AR and VR Applications

Dialog.AddButton Method

Adds a button control to the dialog

Overload List

Adds a button control to the dialog

public Button AddButton(int,string,int,int,int,int);

Adds a button control to the dialog

public Button AddButton(int,string,int,int,int,int,Keys,bool);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog.AddButton Method (Int32, String, Int32, Int32, Int32, Int32)

Adds a button control to the dialog

public Button AddButton(
int id,
string text,
int x,
int y,
int w,
int h
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | Dialog.AddButton Overload List


Dialog.AddButton Method (Int32, String, Int32, Int32, Int32, Int32, Keys, Boolean)

Adds a button control to the dialog

public Button AddButton(
int id,
string text,
int x,
int y,
int w,
int h,
Keys hotkey,
bool isDefault
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | Dialog.AddButton Overload List


AddCheckBox Method

Goblin - A Platform for 3D AR and VR Applications

Dialog.AddCheckBox Method

Adds a checkbox control to the dialog

Overload List

Adds a checkbox control to the dialog

public Checkbox AddCheckBox(int,string,int,int,int,int,bool);

Adds a checkbox to the dialog

public Checkbox AddCheckBox(int,string,int,int,int,int,bool,Keys,bool);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog.AddCheckBox Method (Int32, String, Int32, Int32, Int32, Int32, Boolean)

Adds a checkbox control to the dialog

public Checkbox AddCheckBox(
int id,
string text,
int x,
int y,
int w,
int h,
bool ischecked
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | Dialog.AddCheckBox Overload List


Dialog.AddCheckBox Method (Int32, String, Int32, Int32, Int32, Int32, Boolean, Keys, Boolean)

Adds a checkbox to the dialog

public Checkbox AddCheckBox(
int id,
string text,
int x,
int y,
int w,
int h,
bool ischecked,
Keys hotkey,
bool isDefault
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | Dialog.AddCheckBox Overload List


AddComboBox Method

Goblin - A Platform for 3D AR and VR Applications

Dialog.AddComboBox Method

Adds a combobox control to the dialog

Overload List

Adds a combobox control to the dialog

public ComboBox AddComboBox(int,int,int,int,int);

Adds a combobox control to the dialog

public ComboBox AddComboBox(int,int,int,int,int,Keys,bool);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog.AddComboBox Method (Int32, Int32, Int32, Int32, Int32)

Adds a combobox control to the dialog

public ComboBox AddComboBox(
int id,
int x,
int y,
int w,
int h
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | Dialog.AddComboBox Overload List


Dialog.AddComboBox Method (Int32, Int32, Int32, Int32, Int32, Keys, Boolean)

Adds a combobox control to the dialog

public ComboBox AddComboBox(
int id,
int x,
int y,
int w,
int h,
Keys hotkey,
bool isDefault
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | Dialog.AddComboBox Overload List


Dialog.AddControl Method

Adds a control to the dialog

public void AddControl(
Control control
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


AddEditBox Method

Goblin - A Platform for 3D AR and VR Applications

Dialog.AddEditBox Method

Adds an edit box control to the dialog

Overload List

Adds an edit box control to the dialog

public EditBox AddEditBox(int,string,int,int,int,int);

Adds an edit box control to the dialog

public EditBox AddEditBox(int,string,int,int,int,int,bool);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog.AddEditBox Method (Int32, String, Int32, Int32, Int32, Int32)

Adds an edit box control to the dialog

public EditBox AddEditBox(
int id,
string text,
int x,
int y,
int w,
int h
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | Dialog.AddEditBox Overload List


Dialog.AddEditBox Method (Int32, String, Int32, Int32, Int32, Int32, Boolean)

Adds an edit box control to the dialog

public EditBox AddEditBox(
int id,
string text,
int x,
int y,
int w,
int h,
bool isDefault
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | Dialog.AddEditBox Overload List


AddListBox Method

Goblin - A Platform for 3D AR and VR Applications

Dialog.AddListBox Method

Adds a listbox control to the dialog

Overload List

Adds a listbox control to the dialog

public ListBox AddListBox(int,int,int,int,int);

Adds a listbox control to the dialog

public ListBox AddListBox(int,int,int,int,int,ListBoxStyle);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog.AddListBox Method (Int32, Int32, Int32, Int32, Int32)

Adds a listbox control to the dialog

public ListBox AddListBox(
int id,
int x,
int y,
int w,
int h
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | Dialog.AddListBox Overload List


Dialog.AddListBox Method (Int32, Int32, Int32, Int32, Int32, ListBoxStyle)

Adds a listbox control to the dialog

public ListBox AddListBox(
int id,
int x,
int y,
int w,
int h,
ListBoxStyle style
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | Dialog.AddListBox Overload List


AddRadioButton Method

Goblin - A Platform for 3D AR and VR Applications

Dialog.AddRadioButton Method

Adds a radio button control to the dialog

Overload List

Adds a radio button control to the dialog

public RadioButton AddRadioButton(int,uint,string,int,int,int,int,bool);

Adds a radiobutton to the dialog

public RadioButton AddRadioButton(int,uint,string,int,int,int,int,bool,Keys,bool);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog.AddRadioButton Method (Int32, UInt32, String, Int32, Int32, Int32, Int32, Boolean)

Adds a radio button control to the dialog

public RadioButton AddRadioButton(
int id,
uint groupId,
string text,
int x,
int y,
int w,
int h,
bool ischecked
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | Dialog.AddRadioButton Overload List


Dialog.AddRadioButton Method (Int32, UInt32, String, Int32, Int32, Int32, Int32, Boolean, Keys, Boolean)

Adds a radiobutton to the dialog

public RadioButton AddRadioButton(
int id,
uint groupId,
string text,
int x,
int y,
int w,
int h,
bool ischecked,
Keys hotkey,
bool isDefault
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | Dialog.AddRadioButton Overload List


AddSlider Method

Goblin - A Platform for 3D AR and VR Applications

Dialog.AddSlider Method

Adds a slider control to the dialog

Overload List

Adds a slider control to the dialog

public Slider AddSlider(int,int,int,int,int);

Adds a slider control to the dialog

public Slider AddSlider(int,int,int,int,int,int,int,int,bool);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog.AddSlider Method (Int32, Int32, Int32, Int32, Int32)

Adds a slider control to the dialog

public Slider AddSlider(
int id,
int x,
int y,
int w,
int h
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | Dialog.AddSlider Overload List


Dialog.AddSlider Method (Int32, Int32, Int32, Int32, Int32, Int32, Int32, Int32, Boolean)

Adds a slider control to the dialog

public Slider AddSlider(
int id,
int x,
int y,
int w,
int h,
int min,
int max,
int initialValue,
bool isDefault
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | Dialog.AddSlider Overload List


AddStatic Method

Goblin - A Platform for 3D AR and VR Applications

Dialog.AddStatic Method

Adds a static text control to the dialog

Overload List

Adds a static text control to the dialog

public StaticText AddStatic(int,string,int,int,int,int);

Adds a static text control to the dialog

public StaticText AddStatic(int,string,int,int,int,int,bool);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog.AddStatic Method (Int32, String, Int32, Int32, Int32, Int32)

Adds a static text control to the dialog

public StaticText AddStatic(
int id,
string text,
int x,
int y,
int w,
int h
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | Dialog.AddStatic Overload List


Dialog.AddStatic Method (Int32, String, Int32, Int32, Int32, Int32, Boolean)

Adds a static text control to the dialog

public StaticText AddStatic(
int id,
string text,
int x,
int y,
int w,
int h,
bool isDefault
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | Dialog.AddStatic Overload List


Dialog.ClearComboBox Method

Clears the combo box of all items

public void ClearComboBox(
int id
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog.ClearFocus Method

Clears focus of the dialog

public static void ClearFocus();

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog.ClearRadioButtonGroup Method

Clears the radio button group

public void ClearRadioButtonGroup(
uint groupIndex
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog.DrawRectangle Method

Draw a rectangle

public void DrawRectangle(
Rectangle rect,
ColorValue color
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog.DrawSprite Method

Draw a sprite

public void DrawSprite(
Element element,
Rectangle rect
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DrawText Method

Goblin - A Platform for 3D AR and VR Applications

Dialog.DrawText Method

Draw's some text

Overload List

Draw's some text

public void DrawText(string,Element,Rectangle);

Draw's some text

public void DrawText(string,Element,Rectangle,bool);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog.DrawText Method (String, Element, Rectangle)

Draw's some text

public void DrawText(
string text,
Element element,
Rectangle rect
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | Dialog.DrawText Overload List


Dialog.DrawText Method (String, Element, Rectangle, Boolean)

Draw's some text

public void DrawText(
string text,
Element element,
Rectangle rect,
bool shadow
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | Dialog.DrawText Overload List


Dialog.GetButton Method

Returns the button control located at this index(if one exists)

public Button GetButton(
int id
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog.GetCheckbox Method

Returns the checkbox control located at this index(if one exists)

public Checkbox GetCheckbox(
int id
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog.GetComboBox Method

Returns the combo box control located at this index(if one exists)

public ComboBox GetComboBox(
int id
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


GetControl Method

Goblin - A Platform for 3D AR and VR Applications

Dialog.GetControl Method

Returns the control located at this index(if one exists)

Overload List

Returns the control located at this index(if one exists)

public Control GetControl(int);

Returns the control located at this index of this type(if one exists)

public Control GetControl(int,ControlType);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog.GetControl Method (Int32)

Returns the control located at this index(if one exists)

public Control GetControl(
int id
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | Dialog.GetControl Overload List


Dialog.GetControl Method (Int32, ControlType)

Returns the control located at this index of this type(if one exists)

public Control GetControl(
int id,
ControlType typeControl
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | Dialog.GetControl Overload List


Dialog.GetControlAtPoint Method

Returns the control located at a point (if one exists)

public Control GetControlAtPoint(
Point pt
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog.GetControlEnable Method

Gets the control enabled property

public bool GetControlEnable(
int id
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog.GetDefaultElement Method

Gets the default element

public Element GetDefaultElement(
ControlType ctype,
uint index
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog.GetFont Method

Shared resource access. Indexed fonts and textures are shared among all the controls.

public FontNode GetFont(
uint index
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog.GetListBox Method

Returns the listbox control located at this index(if one exists)

public ListBox GetListBox(
int id
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog.GetRadioButton Method

Returns the radio button control located at this index(if one exists)

public RadioButton GetRadioButton(
int id
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog.GetSlider Method

Returns the slider control located at this index(if one exists)

public Slider GetSlider(
int id
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog.GetStaticText Method

Returns the static text control located at this index(if one exists)

public StaticText GetStaticText(
int id
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog.GetTexture Method

Shared resource access. Indexed fonts and textures are shared among all the controls.

public TextureNode GetTexture(
uint index
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog.InitializeControl Method

Initializes a control

public void InitializeControl(
Control control
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog.MessageProc Method

Handle messages for this dialog

public bool MessageProc(
IntPtr hWnd,
WindowMessage msg,
IntPtr wParam,
IntPtr lParam
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog.OnRender Method

Render the dialog

public void OnRender(
float elapsedTime
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog.RemoveAllControls Method

Removes all controls from this dialog

public void RemoveAllControls();

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog.RequestFocus Method

Request that this control has focus

public static void RequestFocus(
Control control
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


SetBackgroundColors Method

Goblin - A Platform for 3D AR and VR Applications

Dialog.SetBackgroundColors Method

Called to set dialog's border colors

Overload List

Called to set dialog's border colors

public void SetBackgroundColors(ColorValue);

Called to set dialog's border colors

public void SetBackgroundColors(ColorValue,ColorValue,ColorValue,ColorValue);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog.SetBackgroundColors Method (ColorValue)

Called to set dialog's border colors

public void SetBackgroundColors(
ColorValue allCorners
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | Dialog.SetBackgroundColors Overload List


Dialog.SetBackgroundColors Method (ColorValue, ColorValue, ColorValue, ColorValue)

Called to set dialog's border colors

public void SetBackgroundColors(
ColorValue topLeft,
ColorValue topRight,
ColorValue bottomLeft,
ColorValue bottomRight
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | Dialog.SetBackgroundColors Overload List


Dialog.SetCaptionEnabled Method

Called to set dialog's caption enabled state

public void SetCaptionEnabled(
bool isEnabled
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog.SetCaptionText Method

Called to set dialog's caption

public void SetCaptionText(
string text
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog.SetControlEnable Method

Sets the control enabled property

public void SetControlEnable(
int id,
bool isenabled
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog.SetDefaultElement Method

Sets the default element

public void SetDefaultElement(
ControlType ctype,
uint index,
Element e
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog.SetFont Method

Shared resource access. Indexed fonts and textures are shared among all the controls.

public void SetFont(
uint index,
string faceName,
uint height,
FontWeight weight
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog.SetLocation Method

Called to set dialog's location

public void SetLocation(
int x,
int y
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog.SetRefreshTime Method

Set the static refresh time

public static void SetRefreshTime(
float time
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog.SetSize Method

Called to set dialog's size

public void SetSize(
int w,
int h
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Dialog.SetTexture Method

Shared resource access. Indexed fonts and textures are shared among all the controls.

public void SetTexture(
uint index,
string filename
);

See Also

Dialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DialogResourceManager Class

Manages shared resources of dialogs

For a list of all members of this type, see DialogResourceManager Members.

System.Object
Microsoft.Samples.DirectX.UtilityToolkit.DialogResourceManager

public sealed class DialogResourceManager

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

DialogResourceManager Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DialogResourceManager Members

DialogResourceManager overview

Public Static Methods

GetGlobalInstance

Public Instance Properties

Device | Gets the device
Sprite |
StateBlock |

Public Instance Methods

AddFont | Adds a font to the resource manager
AddTexture | Adds a texture to the resource manager
CreateFont | Creates a font
CreateTexture | Creates a texture
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFontNode | Gets a font node from the cache
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetTextureNode | Gets a texture node from the cache
GetType (inherited from Object) | Gets the Type of the current instance.
OnCreateDevice | Called when the device is created
OnDestroyDevice | Destroy any resources and clear the caches
OnLostDevice | Clear any resources that need to be lost
OnResetDevice | Called when the device is reset
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DialogResourceManager Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DialogResourceManager Properties

The properties of the DialogResourceManager class are listed below. For a complete list of DialogResourceManager class members, see the DialogResourceManager Members topic.

Public Instance Properties

Device | Gets the device
Sprite |
StateBlock |

See Also

DialogResourceManager Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Device Property

Goblin - A Platform for 3D AR and VR Applications

DialogResourceManager.Device Property

Gets the device

public Microsoft.DirectX.Direct3D.Device Device {get;}

See Also

DialogResourceManager Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Sprite Property

Goblin - A Platform for 3D AR and VR Applications

DialogResourceManager.Sprite Property

public Microsoft.DirectX.Direct3D.Sprite Sprite {get;}

See Also

DialogResourceManager Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


StateBlock Property

Goblin - A Platform for 3D AR and VR Applications

DialogResourceManager.StateBlock Property

public Microsoft.DirectX.Direct3D.StateBlock StateBlock {get;}

See Also

DialogResourceManager Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DialogResourceManager Methods

The methods of the DialogResourceManager class are listed below. For a complete list of DialogResourceManager class members, see the DialogResourceManager Members topic.

Public Static Methods

GetGlobalInstance

Public Instance Methods

AddFont | Adds a font to the resource manager
AddTexture | Adds a texture to the resource manager
CreateFont | Creates a font
CreateTexture | Creates a texture
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFontNode | Gets a font node from the cache
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetTextureNode | Gets a texture node from the cache
GetType (inherited from Object) | Gets the Type of the current instance.
OnCreateDevice | Called when the device is created
OnDestroyDevice | Destroy any resources and clear the caches
OnLostDevice | Clear any resources that need to be lost
OnResetDevice | Called when the device is reset
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DialogResourceManager Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DialogResourceManager.AddFont Method

Adds a font to the resource manager

public int AddFont(
string faceName,
uint height,
FontWeight weight
);

See Also

DialogResourceManager Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DialogResourceManager.AddTexture Method

Adds a texture to the resource manager

public int AddTexture(
string filename
);

See Also

DialogResourceManager Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DialogResourceManager.CreateFont Method

Creates a font

public void CreateFont(
int font
);

See Also

DialogResourceManager Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DialogResourceManager.CreateTexture Method

Creates a texture

public void CreateTexture(
int tex
);

See Also

DialogResourceManager Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DialogResourceManager.GetFontNode Method

Gets a font node from the cache

public FontNode GetFontNode(
int index
);

See Also

DialogResourceManager Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DialogResourceManager.GetGlobalInstance Method

public static DialogResourceManager GetGlobalInstance();

See Also

DialogResourceManager Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DialogResourceManager.GetTextureNode Method

Gets a texture node from the cache

public TextureNode GetTextureNode(
int index
);

See Also

DialogResourceManager Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DialogResourceManager.OnCreateDevice Method

Called when the device is created

public void OnCreateDevice(
Device d
);

See Also

DialogResourceManager Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DialogResourceManager.OnDestroyDevice Method

Destroy any resources and clear the caches

public void OnDestroyDevice();

See Also

DialogResourceManager Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DialogResourceManager.OnLostDevice Method

Clear any resources that need to be lost

public void OnLostDevice();

See Also

DialogResourceManager Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DialogResourceManager.OnResetDevice Method

Called when the device is reset

public void OnResetDevice(
Device device
);

See Also

DialogResourceManager Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DirectionWidget Class

Widget for controlling direction

For a list of all members of this type, see DirectionWidget Members.

System.Object
Microsoft.Samples.DirectX.UtilityToolkit.DirectionWidget

public class DirectionWidget

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

DirectionWidget Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DirectionWidget Members

DirectionWidget overview

Public Static Methods

OnCreateDevice | Called when the device has been created
OnDestroyDevice | Called when the device has been destroyed
OnLostDevice | Called when the device has been lost

Public Instance Constructors

DirectionWidget Constructor Initializes a new instance of the DirectionWidget class.

Public Instance Properties

IsBeingDragged | Is this widget being dragged
LightDirection | Light direction of this widget
Radius | Radius of this widget
RotateButtonMask | Rotation button mask

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HandleMessages | Handle messages from the window
OnRender | Render the light widget
OnResetDevice | Called when the device has been reset
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DirectionWidget Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DirectionWidget Constructor

Initializes a new instance of the DirectionWidget class.

public DirectionWidget();

See Also

DirectionWidget Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DirectionWidget Properties

The properties of the DirectionWidget class are listed below. For a complete list of DirectionWidget class members, see the DirectionWidget Members topic.

Public Instance Properties

IsBeingDragged | Is this widget being dragged
LightDirection | Light direction of this widget
Radius | Radius of this widget
RotateButtonMask | Rotation button mask

See Also

DirectionWidget Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


IsBeingDragged Property

Goblin - A Platform for 3D AR and VR Applications

DirectionWidget.IsBeingDragged Property

Is this widget being dragged

public bool IsBeingDragged {get;}

See Also

DirectionWidget Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


LightDirection Property

Goblin - A Platform for 3D AR and VR Applications

DirectionWidget.LightDirection Property

Light direction of this widget

public Microsoft.DirectX.Vector3 LightDirection {get; set;}

See Also

DirectionWidget Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Radius Property

Goblin - A Platform for 3D AR and VR Applications

DirectionWidget.Radius Property

Radius of this widget

public float Radius {get; set;}

See Also

DirectionWidget Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


RotateButtonMask Property

Goblin - A Platform for 3D AR and VR Applications

DirectionWidget.RotateButtonMask Property

Rotation button mask

public MouseButtonMask RotateButtonMask {get; set;}

See Also

DirectionWidget Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DirectionWidget Methods

The methods of the DirectionWidget class are listed below. For a complete list of DirectionWidget class members, see the DirectionWidget Members topic.

Public Static Methods

OnCreateDevice | Called when the device has been created
OnDestroyDevice | Called when the device has been destroyed
OnLostDevice | Called when the device has been lost

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HandleMessages | Handle messages from the window
OnRender | Render the light widget
OnResetDevice | Called when the device has been reset
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DirectionWidget Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DirectionWidget.HandleMessages Method

Handle messages from the window

public bool HandleMessages(
IntPtr hWnd,
WindowMessage msg,
IntPtr wParam,
IntPtr lParam
);

See Also

DirectionWidget Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DirectionWidget.OnCreateDevice Method

Called when the device has been created

public static void OnCreateDevice(
Device device
);

See Also

DirectionWidget Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DirectionWidget.OnDestroyDevice Method

Called when the device has been destroyed

public static void OnDestroyDevice();

See Also

DirectionWidget Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DirectionWidget.OnLostDevice Method

Called when the device has been lost

public static void OnLostDevice();

See Also

DirectionWidget Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DirectionWidget.OnRender Method

Render the light widget

public void OnRender(
ColorValue color,
Matrix view,
Matrix proj,
Vector3 eye
);

See Also

DirectionWidget Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DirectionWidget.OnResetDevice Method

Called when the device has been reset

public void OnResetDevice(
SurfaceDescription desc
);

See Also

DirectionWidget Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DirectXSampleException Class

Base class for sample exceptions

For a list of all members of this type, see DirectXSampleException Members.

System.Object
System.Exception
System.ApplicationException
Microsoft.Samples.DirectX.UtilityToolkit.DirectXSampleException

public class DirectXSampleException : ApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

DirectXSampleException Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DirectXSampleException Members

DirectXSampleException overview

Public Instance Constructors

DirectXSampleException Overloaded. Initializes a new instance of the DirectXSampleException class.

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DirectXSampleException Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DirectXSampleException Constructor

Overload List

public DirectXSampleException(string);

public DirectXSampleException(string,Exception);

See Also

DirectXSampleException Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DirectXSampleException Constructor (String)

public DirectXSampleException(
string message
);

See Also

DirectXSampleException Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | DirectXSampleException Constructor Overload List


DirectXSampleException Constructor (String, Exception)

public DirectXSampleException(
string message,
Exception inner
);

See Also

DirectXSampleException Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | DirectXSampleException Constructor Overload List


DisplayModeSorter Class

Used to sort display modes

For a list of all members of this type, see DisplayModeSorter Members.

System.Object
Microsoft.Samples.DirectX.UtilityToolkit.DisplayModeSorter

public class DisplayModeSorter : IComparer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

DisplayModeSorter Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DisplayModeSorter Members

DisplayModeSorter overview

Public Instance Constructors

DisplayModeSorter Constructor Initializes a new instance of the DisplayModeSorter class.

Public Instance Methods

Compare | Compare two display modes
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DisplayModeSorter Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DisplayModeSorter Constructor

Initializes a new instance of the DisplayModeSorter class.

public DisplayModeSorter();

See Also

DisplayModeSorter Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DisplayModeSorter Methods

The methods of the DisplayModeSorter class are listed below. For a complete list of DisplayModeSorter class members, see the DisplayModeSorter Members topic.

Public Instance Methods

Compare | Compare two display modes
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DisplayModeSorter Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DisplayModeSorter.Compare Method

Compare two display modes

public int Compare(
object x,
object y
);

Implements

IComparer.Compare

See Also

DisplayModeSorter Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox Class

A basic edit box

For a list of all members of this type, see EditBox Members.

System.Object
Microsoft.Samples.DirectX.UtilityToolkit.Control
Microsoft.Samples.DirectX.UtilityToolkit.EditBox

public class EditBox : Control

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

EditBox Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox Members

EditBox overview

Public Static Fields

LeftBorder
LowerBorder
LowerLeftBorder
LowerRightBorder
RightBorder
TextLayer
TopBorder
TopLeftBorder
TopRightBorder

Protected Static Fields

isHidingCaret

Public Instance Constructors

EditBox Constructor Creates a new edit box control

Public Instance Fields

index (inherited from Control)
isDefault (inherited from Control)

Public Instance Properties

CanHaveFocus | Can the edit box have focus
ControlType (inherited from Control) | Type of the control
Hotkey (inherited from Control) | The controls hotkey
ID (inherited from Control) | Unique ID of the control
IsEnabled (inherited from Control) | Is the control enabled
IsVisible (inherited from Control) | Is the control visible
Item (inherited from Control) | Index for the elements this control has access to
Parent (inherited from Control) | The parent dialog of this control
Text | Get or sets the text
UserData (inherited from Control) | User specified data

Public Instance Methods

Clear | Clears the edit box
ContainsPoint (inherited from Control) | Does the control contain this point
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCopyText | Gets a copy of the text
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HandleKeyboard | Handle keyboard input to the edit box
HandleMouse | Handle mouse messages
MsgProc | Handle all other messages
OnFocusIn | Update the caret when focus is in
OnFocusOut (inherited from Control) | Called when control loses focus
OnHotKey (inherited from Control) | Called when the control's hotkey is hit
OnInitialize (inherited from Control) | Initialize the control
OnMouseEnter (inherited from Control) | Called when mouse goes over the control
OnMouseExit (inherited from Control) | Called when mouse leaves the control
Refresh (inherited from Control) | Refreshes the control
Render | Render the control
SetBorderWidth | Update the border
SetCaretColor | Update the caret color
SetLocation (inherited from Control) | Called to set control's location
SetSelectedBackColor | Update the selected background color
SetSelectedTextColor | Update the text selected color
SetSize (inherited from Control) | Called to set control's size
SetSpacing | Update the spacing
SetText | Sets the text for the control
SetTextColor | Update the text color
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

Changed
Enter

Protected Instance Fields

blinkTime
border
boundingBox (inherited from Control)
caretColor
caretPosition
controlId (inherited from Control)
controlType (inherited from Control)
controlX (inherited from Control)
controlY (inherited from Control)
elementList (inherited from Control)
elementRects
enabled (inherited from Control)
firstVisible
hasFocus (inherited from Control)
height (inherited from Control)
hotKey (inherited from Control)
isCaretOn
isInsertMode
isMouseDragging
isMouseOver (inherited from Control)
lastBlink
localUserData (inherited from Control)
parentDialog (inherited from Control)
selectedBackColor
selectedTextColor
spacing
textColor
textData
textRect
visible (inherited from Control)
width (inherited from Control)

Protected Instance Methods

CopyToClipboard | Copy the selected text to the clipboard
DeleteSelectionText | Deletes the text that is currently selected
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PasteFromClipboard | Paste the clipboard data to the control
PlaceCaret | Set the caret to a character position, and adjust the scrolling if necessary
RaiseChangedEvent | Raises the changed event
RaiseEnterEvent | Raises the Enter event
ResetCaretBlink | Reset's the caret blink time
UpdateRectangles | Updates the rectangles used by the control

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox Constructor

Creates a new edit box control

public EditBox(
Dialog parent
);

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox Fields

The fields of the EditBox class are listed below. For a complete list of EditBox class members, see the EditBox Members topic.

Public Static Fields

LeftBorder
LowerBorder
LowerLeftBorder
LowerRightBorder
RightBorder
TextLayer
TopBorder
TopLeftBorder
TopRightBorder

Protected Static Fields

isHidingCaret

Public Instance Fields

index (inherited from Control)
isDefault (inherited from Control)

Protected Instance Fields

blinkTime
border
boundingBox (inherited from Control)
caretColor
caretPosition
controlId (inherited from Control)
controlType (inherited from Control)
controlX (inherited from Control)
controlY (inherited from Control)
elementList (inherited from Control)
elementRects
enabled (inherited from Control)
firstVisible
hasFocus (inherited from Control)
height (inherited from Control)
hotKey (inherited from Control)
isCaretOn
isInsertMode
isMouseDragging
isMouseOver (inherited from Control)
lastBlink
localUserData (inherited from Control)
parentDialog (inherited from Control)
selectedBackColor
selectedTextColor
spacing
textColor
textData
textRect
visible (inherited from Control)
width (inherited from Control)

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.blinkTime Field

protected double blinkTime;

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.border Field

protected int border;

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.caretColor Field

protected ColorValue caretColor;

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.caretPosition Field

protected int caretPosition;

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.elementRects Field

protected Rectangle[] elementRects;

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.firstVisible Field

protected int firstVisible;

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.isCaretOn Field

protected bool isCaretOn;

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.isHidingCaret Field

protected static bool isHidingCaret;

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.isInsertMode Field

protected bool isInsertMode;

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.isMouseDragging Field

protected bool isMouseDragging;

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.lastBlink Field

protected double lastBlink;

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.LeftBorder Field

public const int LeftBorder = 4;

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.LowerBorder Field

public const int LowerBorder = 7;

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.LowerLeftBorder Field

public const int LowerLeftBorder = 6;

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.LowerRightBorder Field

public const int LowerRightBorder = 8;

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.RightBorder Field

public const int RightBorder = 5;

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.selectedBackColor Field

protected ColorValue selectedBackColor;

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.selectedTextColor Field

protected ColorValue selectedTextColor;

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.spacing Field

protected int spacing;

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.textColor Field

protected ColorValue textColor;

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.textData Field

protected RichTextBox textData;

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.TextLayer Field

public const int TextLayer = 0;

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.textRect Field

protected Rectangle textRect;

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.TopBorder Field

public const int TopBorder = 2;

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.TopLeftBorder Field

public const int TopLeftBorder = 1;

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.TopRightBorder Field

public const int TopRightBorder = 3;

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox Properties

The properties of the EditBox class are listed below. For a complete list of EditBox class members, see the EditBox Members topic.

Public Instance Properties

CanHaveFocus | Can the edit box have focus
ControlType (inherited from Control) | Type of the control
Hotkey (inherited from Control) | The controls hotkey
ID (inherited from Control) | Unique ID of the control
IsEnabled (inherited from Control) | Is the control enabled
IsVisible (inherited from Control) | Is the control visible
Item (inherited from Control) | Index for the elements this control has access to
Parent (inherited from Control) | The parent dialog of this control
Text | Get or sets the text
UserData (inherited from Control) | User specified data

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


CanHaveFocus Property

Goblin - A Platform for 3D AR and VR Applications

EditBox.CanHaveFocus Property

Can the edit box have focus

public override bool CanHaveFocus {get;}

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Text Property

Goblin - A Platform for 3D AR and VR Applications

EditBox.Text Property

Get or sets the text

public string Text {get; set;}

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox Methods

The methods of the EditBox class are listed below. For a complete list of EditBox class members, see the EditBox Members topic.

Public Instance Methods

Clear | Clears the edit box
ContainsPoint (inherited from Control) | Does the control contain this point
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCopyText | Gets a copy of the text
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HandleKeyboard | Handle keyboard input to the edit box
HandleMouse | Handle mouse messages
MsgProc | Handle all other messages
OnFocusIn | Update the caret when focus is in
OnFocusOut (inherited from Control) | Called when control loses focus
OnHotKey (inherited from Control) | Called when the control's hotkey is hit
OnInitialize (inherited from Control) | Initialize the control
OnMouseEnter (inherited from Control) | Called when mouse goes over the control
OnMouseExit (inherited from Control) | Called when mouse leaves the control
Refresh (inherited from Control) | Refreshes the control
Render | Render the control
SetBorderWidth | Update the border
SetCaretColor | Update the caret color
SetLocation (inherited from Control) | Called to set control's location
SetSelectedBackColor | Update the selected background color
SetSelectedTextColor | Update the text selected color
SetSize (inherited from Control) | Called to set control's size
SetSpacing | Update the spacing
SetText | Sets the text for the control
SetTextColor | Update the text color
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyToClipboard | Copy the selected text to the clipboard
DeleteSelectionText | Deletes the text that is currently selected
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
PasteFromClipboard | Paste the clipboard data to the control
PlaceCaret | Set the caret to a character position, and adjust the scrolling if necessary
RaiseChangedEvent | Raises the changed event
RaiseEnterEvent | Raises the Enter event
ResetCaretBlink | Reset's the caret blink time
UpdateRectangles | Updates the rectangles used by the control

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.Clear Method

Clears the edit box

public void Clear();

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.CopyToClipboard Method

Copy the selected text to the clipboard

protected void CopyToClipboard();

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.DeleteSelectionText Method

Deletes the text that is currently selected

protected void DeleteSelectionText();

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.GetCopyText Method

Gets a copy of the text

public string GetCopyText();

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.HandleKeyboard Method

Handle keyboard input to the edit box

public override bool HandleKeyboard(
WindowMessage msg,
IntPtr wParam,
IntPtr lParam
);

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.HandleMouse Method

Handle mouse messages

public override bool HandleMouse(
WindowMessage msg,
Point pt,
IntPtr wParam,
IntPtr lParam
);

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.MsgProc Method

Handle all other messages

public override bool MsgProc(
IntPtr hWnd,
WindowMessage msg,
IntPtr wParam,
IntPtr lParam
);

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.OnFocusIn Method

Update the caret when focus is in

public override void OnFocusIn();

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.PasteFromClipboard Method

Paste the clipboard data to the control

protected void PasteFromClipboard();

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.PlaceCaret Method

Set the caret to a character position, and adjust the scrolling if necessary

protected void PlaceCaret(
int pos
);

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.RaiseChangedEvent Method

Raises the changed event

protected void RaiseChangedEvent(
EditBox sender,
bool wasTriggeredByUser
);

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.RaiseEnterEvent Method

Raises the Enter event

protected void RaiseEnterEvent(
EditBox sender,
bool wasTriggeredByUser
);

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.Render Method

Render the control

public override void Render(
Device device,
float elapsedTime
);

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.ResetCaretBlink Method

Reset's the caret blink time

protected void ResetCaretBlink();

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.SetBorderWidth Method

Update the border

public void SetBorderWidth(
int b
);

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.SetCaretColor Method

Update the caret color

public void SetCaretColor(
ColorValue color
);

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.SetSelectedBackColor Method

Update the selected background color

public void SetSelectedBackColor(
ColorValue color
);

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.SetSelectedTextColor Method

Update the text selected color

public void SetSelectedTextColor(
ColorValue color
);

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.SetSpacing Method

Update the spacing

public void SetSpacing(
int space
);

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.SetText Method

Sets the text for the control

public void SetText(
string text,
bool selected
);

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.SetTextColor Method

Update the text color

public void SetTextColor(
ColorValue color
);

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.UpdateRectangles Method

Updates the rectangles used by the control

protected override void UpdateRectangles();

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox Events

The events of the EditBox class are listed below. For a complete list of EditBox class members, see the EditBox Members topic.

Public Instance Events

Changed
Enter

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.Changed Event

public event EventHandler Changed;

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EditBox.Enter Event

public event EventHandler Enter;

See Also

EditBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Element Class

Contains all the display tweakables for a sub-control

For a list of all members of this type, see Element Members.

System.Object
Microsoft.Samples.DirectX.UtilityToolkit.Element

public class Element : ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

Element Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Element Members

Element overview

Public Instance Constructors

Element Constructor Initializes a new instance of the Element class.

Public Instance Fields

FontColor
FontIndex
textFormat
TextureColor
TextureIndex
textureRect

Public Instance Methods

Clone | Clone an object
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Refresh | Refresh this element
SetFont | Overloaded. Set the font
SetTexture | Overloaded. Set the texture
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Element Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Element Constructor

Initializes a new instance of the Element class.

public Element();

See Also

Element Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Element Fields

The fields of the Element class are listed below. For a complete list of Element class members, see the Element Members topic.

Public Instance Fields

FontColor
FontIndex
textFormat
TextureColor
TextureIndex
textureRect

See Also

Element Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Element.FontColor Field

public BlendColor FontColor;

See Also

Element Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Element.FontIndex Field

public uint FontIndex;

See Also

Element Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Element.textFormat Field

public DrawTextFormat textFormat;

See Also

Element Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Element.TextureColor Field

public BlendColor TextureColor;

See Also

Element Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Element.TextureIndex Field

public uint TextureIndex;

See Also

Element Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Element.textureRect Field

public Rectangle textureRect;

See Also

Element Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Element Methods

The methods of the Element class are listed below. For a complete list of Element class members, see the Element Members topic.

Public Instance Methods

Clone | Clone an object
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Refresh | Refresh this element
SetFont | Overloaded. Set the font
SetTexture | Overloaded. Set the texture
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Element Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Element.Clone Method

Clone an object

public Element Clone();

See Also

Element Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Element.Refresh Method

Refresh this element

public void Refresh();

See Also

Element Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


SetFont Method

Goblin - A Platform for 3D AR and VR Applications

Element.SetFont Method

Set the font

Overload List

Set the font

public void SetFont(uint);

Set the font

public void SetFont(uint,ColorValue,DrawTextFormat);

See Also

Element Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Element.SetFont Method (UInt32)

Set the font

public void SetFont(
uint font
);

See Also

Element Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | Element.SetFont Overload List


Element.SetFont Method (UInt32, ColorValue, DrawTextFormat)

Set the font

public void SetFont(
uint font,
ColorValue defaultFontColor,
DrawTextFormat format
);

See Also

Element Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | Element.SetFont Overload List


SetTexture Method

Goblin - A Platform for 3D AR and VR Applications

Element.SetTexture Method

Set the texture

Overload List

Set the texture

public void SetTexture(uint,Rectangle);

Set the texture

public void SetTexture(uint,Rectangle,ColorValue);

See Also

Element Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Element.SetTexture Method (UInt32, Rectangle)

Set the texture

public void SetTexture(
uint tex,
Rectangle texRect
);

See Also

Element Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | Element.SetTexture Overload List


Element.SetTexture Method (UInt32, Rectangle, ColorValue)

Set the texture

public void SetTexture(
uint tex,
Rectangle texRect,
ColorValue defaultTextureColor
);

See Also

Element Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | Element.SetTexture Overload List


ElementHolder Structure

Contains all the display information for a given control type

For a list of all members of this type, see ElementHolder Members.

System.Object
System.ValueType
Microsoft.Samples.DirectX.UtilityToolkit.ElementHolder

public struct ElementHolder

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

ElementHolder Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ElementHolder Members

ElementHolder overview

Public Instance Fields

ControlType
Element
ElementIndex

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

ElementHolder Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ElementHolder Fields

The fields of the ElementHolder structure are listed below. For a complete list of ElementHolder structure members, see the ElementHolder Members topic.

Public Instance Fields

ControlType
Element
ElementIndex

See Also

ElementHolder Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ElementHolder.ControlType Field

public ControlType ControlType;

See Also

ElementHolder Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ElementHolder.Element Field

public Element Element;

See Also

ElementHolder Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ElementHolder.ElementIndex Field

public uint ElementIndex;

See Also

ElementHolder Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EnumAdapterInformation Class

Class describing an adapter which contains a unique adapter ordinal that is installed on the system.

For a list of all members of this type, see EnumAdapterInformation Members.

System.Object
Microsoft.Samples.DirectX.UtilityToolkit.EnumAdapterInformation

public class EnumAdapterInformation

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

EnumAdapterInformation Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EnumAdapterInformation Members

EnumAdapterInformation overview

Public Instance Constructors

EnumAdapterInformation Constructor Initializes a new instance of the EnumAdapterInformation class.

Public Instance Fields

AdapterInformation
AdapterOrdinal
deviceInfoList
displayModeList
UniqueDescription

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EnumAdapterInformation Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EnumAdapterInformation Constructor

Initializes a new instance of the EnumAdapterInformation class.

public EnumAdapterInformation();

See Also

EnumAdapterInformation Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EnumAdapterInformation Fields

The fields of the EnumAdapterInformation class are listed below. For a complete list of EnumAdapterInformation class members, see the EnumAdapterInformation Members topic.

Public Instance Fields

AdapterInformation
AdapterOrdinal
deviceInfoList
displayModeList
UniqueDescription

See Also

EnumAdapterInformation Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EnumAdapterInformation.AdapterInformation Field

public AdapterDetails AdapterInformation;

See Also

EnumAdapterInformation Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EnumAdapterInformation.AdapterOrdinal Field

public uint AdapterOrdinal;

See Also

EnumAdapterInformation Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EnumAdapterInformation.deviceInfoList Field

public ArrayList deviceInfoList;

See Also

EnumAdapterInformation Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EnumAdapterInformation.displayModeList Field

public ArrayList displayModeList;

See Also

EnumAdapterInformation Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EnumAdapterInformation.UniqueDescription Field

public string UniqueDescription;

See Also

EnumAdapterInformation Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EnumDepthStencilMultisampleConflict Structure

A depth/stencil buffer format that is incompatible with a multisample type

For a list of all members of this type, see EnumDepthStencilMultisampleConflict Members.

System.Object
System.ValueType
Microsoft.Samples.DirectX.UtilityToolkit.EnumDepthStencilMultisampleConflict

public struct EnumDepthStencilMultisampleConflict

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

EnumDepthStencilMultisampleConflict Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EnumDepthStencilMultisampleConflict Members

EnumDepthStencilMultisampleConflict overview

Public Instance Fields

DepthStencilFormat
MultisampleType

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

EnumDepthStencilMultisampleConflict Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EnumDepthStencilMultisampleConflict Fields

The fields of the EnumDepthStencilMultisampleConflict structure are listed below. For a complete list of EnumDepthStencilMultisampleConflict structure members, see the EnumDepthStencilMultisampleConflict Members topic.

Public Instance Fields

DepthStencilFormat
MultisampleType

See Also

EnumDepthStencilMultisampleConflict Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EnumDepthStencilMultisampleConflict.DepthStencilFormat Field

public DepthFormat DepthStencilFormat;

See Also

EnumDepthStencilMultisampleConflict Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EnumDepthStencilMultisampleConflict.MultisampleType Field

public MultiSampleType MultisampleType;

See Also

EnumDepthStencilMultisampleConflict Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EnumDeviceInformation Class

Class describing a Direct3D device that contains a unique supported device type

For a list of all members of this type, see EnumDeviceInformation Members.

System.Object
Microsoft.Samples.DirectX.UtilityToolkit.EnumDeviceInformation

public class EnumDeviceInformation

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

EnumDeviceInformation Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EnumDeviceInformation Members

EnumDeviceInformation overview

Public Instance Constructors

EnumDeviceInformation Constructor Initializes a new instance of the EnumDeviceInformation class.

Public Instance Fields

AdapterOrdinal
Caps
deviceSettingsList
DeviceType

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EnumDeviceInformation Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EnumDeviceInformation Constructor

Initializes a new instance of the EnumDeviceInformation class.

public EnumDeviceInformation();

See Also

EnumDeviceInformation Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EnumDeviceInformation Fields

The fields of the EnumDeviceInformation class are listed below. For a complete list of EnumDeviceInformation class members, see the EnumDeviceInformation Members topic.

Public Instance Fields

AdapterOrdinal
Caps
deviceSettingsList
DeviceType

See Also

EnumDeviceInformation Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EnumDeviceInformation.AdapterOrdinal Field

public uint AdapterOrdinal;

See Also

EnumDeviceInformation Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EnumDeviceInformation.Caps Field

public Caps Caps;

See Also

EnumDeviceInformation Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EnumDeviceInformation.deviceSettingsList Field

public ArrayList deviceSettingsList;

See Also

EnumDeviceInformation Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EnumDeviceInformation.DeviceType Field

public DeviceType DeviceType;

See Also

EnumDeviceInformation Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EnumDeviceSettingsCombo Class

Class describing device settings that contain a unique combination of adapter format, back buffer format, and windowed that is compatible with a particular Direct3D device and the application

For a list of all members of this type, see EnumDeviceSettingsCombo Members.

System.Object
Microsoft.Samples.DirectX.UtilityToolkit.EnumDeviceSettingsCombo

public class EnumDeviceSettingsCombo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

EnumDeviceSettingsCombo Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EnumDeviceSettingsCombo Members

EnumDeviceSettingsCombo overview

Public Instance Constructors

EnumDeviceSettingsCombo Constructor Initializes a new instance of the EnumDeviceSettingsCombo class.

Public Instance Fields

AdapterFormat
adapterInformation
AdapterOrdinal
BackBufferFormat
depthStencilConflictList
depthStencilFormatList
deviceInformation
DeviceType
IsWindowed
multiSampleQualityList
multiSampleTypeList
presentIntervalList

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EnumDeviceSettingsCombo Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EnumDeviceSettingsCombo Constructor

Initializes a new instance of the EnumDeviceSettingsCombo class.

public EnumDeviceSettingsCombo();

See Also

EnumDeviceSettingsCombo Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EnumDeviceSettingsCombo Fields

The fields of the EnumDeviceSettingsCombo class are listed below. For a complete list of EnumDeviceSettingsCombo class members, see the EnumDeviceSettingsCombo Members topic.

Public Instance Fields

AdapterFormat
adapterInformation
AdapterOrdinal
BackBufferFormat
depthStencilConflictList
depthStencilFormatList
deviceInformation
DeviceType
IsWindowed
multiSampleQualityList
multiSampleTypeList
presentIntervalList

See Also

EnumDeviceSettingsCombo Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EnumDeviceSettingsCombo.AdapterFormat Field

public Format AdapterFormat;

See Also

EnumDeviceSettingsCombo Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EnumDeviceSettingsCombo.adapterInformation Field

public EnumAdapterInformation adapterInformation;

See Also

EnumDeviceSettingsCombo Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EnumDeviceSettingsCombo.AdapterOrdinal Field

public uint AdapterOrdinal;

See Also

EnumDeviceSettingsCombo Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EnumDeviceSettingsCombo.BackBufferFormat Field

public Format BackBufferFormat;

See Also

EnumDeviceSettingsCombo Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EnumDeviceSettingsCombo.depthStencilConflictList Field

public ArrayList depthStencilConflictList;

See Also

EnumDeviceSettingsCombo Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EnumDeviceSettingsCombo.depthStencilFormatList Field

public ArrayList depthStencilFormatList;

See Also

EnumDeviceSettingsCombo Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EnumDeviceSettingsCombo.deviceInformation Field

public EnumDeviceInformation deviceInformation;

See Also

EnumDeviceSettingsCombo Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EnumDeviceSettingsCombo.DeviceType Field

public DeviceType DeviceType;

See Also

EnumDeviceSettingsCombo Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EnumDeviceSettingsCombo.IsWindowed Field

public bool IsWindowed;

See Also

EnumDeviceSettingsCombo Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EnumDeviceSettingsCombo.multiSampleQualityList Field

public ArrayList multiSampleQualityList;

See Also

EnumDeviceSettingsCombo Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EnumDeviceSettingsCombo.multiSampleTypeList Field

public ArrayList multiSampleTypeList;

See Also

EnumDeviceSettingsCombo Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


EnumDeviceSettingsCombo.presentIntervalList Field

public ArrayList presentIntervalList;

See Also

EnumDeviceSettingsCombo Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Enumeration Class

Enumerates available Direct3D adapters, devices, modes, etc. Singleton.

For a list of all members of this type, see Enumeration Members.

System.Object
Microsoft.Samples.DirectX.UtilityToolkit.Enumeration

public sealed class Enumeration

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

Enumeration Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Enumeration Members

Enumeration overview

Public Static Properties

AdapterInformationList | Use this after Enumerate to get the list of adapter information
IsHardwareVertexProcessingPossible | Allows the user to set if hardware vertex processing is available
IsMixedVertexProcessingPossible | Allows the user to set if mixed vertex processing is available
IsPostPixelShaderBlendingRequred | Allows the user to set if post pixel shader blending is required
IsPureHardwareVertexProcessingPossible | Allows the user to set if pure hardware vertex processing is available
IsSoftwareVertexProcessingPossible | Allows the user to set if software vertex processing is available
MultisampleQualityMax | Property for MultisampleQualityMax
PossibleDepthStencilFormatList | Allows the user to get the possible depth stencil formats
PossibleMultisampleTypeList | Allows the user to get the possible multisample types
PossiblePresentIntervalsList | Allows the user to get the possible present intervals

Public Static Methods

Enumerate | Enumerates available D3D adapters, devices, modes, etc
GetAdapterInformation | Get the adapter information for a specific adapter
GetDeviceInfo | Get a specific device information for a device and type
GetDeviceSettingsCombo | Overloaded. Returns a specific device combination
ResetPossibleDepthStencilFormats | Resets the list of possible depth stencil formats
ResetPossibleMultisampleTypeList | Resets the possible multisample type list
ResetPossiblePresentIntervalList | Resets the possible present interval list
SetRefreshMinMax | Sets the minimum and maximum refresh
SetResolutionMinMax | Set the minimum and maximum resolution items

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Enumeration Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Enumeration Properties

The properties of the Enumeration class are listed below. For a complete list of Enumeration class members, see the Enumeration Members topic.

Public Static Properties

AdapterInformationList | Use this after Enumerate to get the list of adapter information
IsHardwareVertexProcessingPossible | Allows the user to set if hardware vertex processing is available
IsMixedVertexProcessingPossible | Allows the user to set if mixed vertex processing is available
IsPostPixelShaderBlendingRequred | Allows the user to set if post pixel shader blending is required
IsPureHardwareVertexProcessingPossible | Allows the user to set if pure hardware vertex processing is available
IsSoftwareVertexProcessingPossible | Allows the user to set if software vertex processing is available
MultisampleQualityMax | Property for MultisampleQualityMax
PossibleDepthStencilFormatList | Allows the user to get the possible depth stencil formats
PossibleMultisampleTypeList | Allows the user to get the possible multisample types
PossiblePresentIntervalsList | Allows the user to get the possible present intervals

See Also

Enumeration Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


AdapterInformationList Property

Goblin - A Platform for 3D AR and VR Applications

Enumeration.AdapterInformationList Property

Use this after Enumerate to get the list of adapter information

public static System.Collections.ArrayList AdapterInformationList {get;}

See Also

Enumeration Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


IsHardwareVertexProcessingPossible Property

Goblin - A Platform for 3D AR and VR Applications

Enumeration.IsHardwareVertexProcessingPossible Property

Allows the user to set if hardware vertex processing is available

public static bool IsHardwareVertexProcessingPossible {get; set;}

See Also

Enumeration Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


IsMixedVertexProcessingPossible Property

Goblin - A Platform for 3D AR and VR Applications

Enumeration.IsMixedVertexProcessingPossible Property

Allows the user to set if mixed vertex processing is available

public static bool IsMixedVertexProcessingPossible {get; set;}

See Also

Enumeration Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


IsPostPixelShaderBlendingRequred Property

Goblin - A Platform for 3D AR and VR Applications

Enumeration.IsPostPixelShaderBlendingRequred Property

Allows the user to set if post pixel shader blending is required

public static bool IsPostPixelShaderBlendingRequred {get; set;}

See Also

Enumeration Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


IsPureHardwareVertexProcessingPossible Property

Goblin - A Platform for 3D AR and VR Applications

Enumeration.IsPureHardwareVertexProcessingPossible Property

Allows the user to set if pure hardware vertex processing is available

public static bool IsPureHardwareVertexProcessingPossible {get; set;}

See Also

Enumeration Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


IsSoftwareVertexProcessingPossible Property

Goblin - A Platform for 3D AR and VR Applications

Enumeration.IsSoftwareVertexProcessingPossible Property

Allows the user to set if software vertex processing is available

public static bool IsSoftwareVertexProcessingPossible {get; set;}

See Also

Enumeration Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


MultisampleQualityMax Property

Goblin - A Platform for 3D AR and VR Applications

Enumeration.MultisampleQualityMax Property

Property for MultisampleQualityMax

public static uint MultisampleQualityMax {get; set;}

See Also

Enumeration Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


PossibleDepthStencilFormatList Property

Goblin - A Platform for 3D AR and VR Applications

Enumeration.PossibleDepthStencilFormatList Property

Allows the user to get the possible depth stencil formats

public static System.Collections.ArrayList PossibleDepthStencilFormatList {get;}

See Also

Enumeration Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


PossibleMultisampleTypeList Property

Goblin - A Platform for 3D AR and VR Applications

Enumeration.PossibleMultisampleTypeList Property

Allows the user to get the possible multisample types

public static System.Collections.ArrayList PossibleMultisampleTypeList {get;}

See Also

Enumeration Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


PossiblePresentIntervalsList Property

Goblin - A Platform for 3D AR and VR Applications

Enumeration.PossiblePresentIntervalsList Property

Allows the user to get the possible present intervals

public static System.Collections.ArrayList PossiblePresentIntervalsList {get;}

See Also

Enumeration Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Enumeration Methods

The methods of the Enumeration class are listed below. For a complete list of Enumeration class members, see the Enumeration Members topic.

Public Static Methods

Enumerate | Enumerates available D3D adapters, devices, modes, etc
GetAdapterInformation | Get the adapter information for a specific adapter
GetDeviceInfo | Get a specific device information for a device and type
GetDeviceSettingsCombo | Overloaded. Returns a specific device combination
ResetPossibleDepthStencilFormats | Resets the list of possible depth stencil formats
ResetPossibleMultisampleTypeList | Resets the possible multisample type list
ResetPossiblePresentIntervalList | Resets the possible present interval list
SetRefreshMinMax | Sets the minimum and maximum refresh
SetResolutionMinMax | Set the minimum and maximum resolution items

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Enumeration Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Enumeration.Enumerate Method

Enumerates available D3D adapters, devices, modes, etc

public static void Enumerate(
IDeviceCreation acceptableCallback
);

See Also

Enumeration Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Enumeration.GetAdapterInformation Method

Get the adapter information for a specific adapter

public static EnumAdapterInformation GetAdapterInformation(
uint ordinal
);

See Also

Enumeration Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Enumeration.GetDeviceInfo Method

Get a specific device information for a device and type

public static EnumDeviceInformation GetDeviceInfo(
uint ordinal,
DeviceType deviceType
);

See Also

Enumeration Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


GetDeviceSettingsCombo Method

Goblin - A Platform for 3D AR and VR Applications

Enumeration.GetDeviceSettingsCombo Method

Returns a specific device combination from a device settings object

Overload List

Returns a specific device combination from a device settings object

public static EnumDeviceSettingsCombo GetDeviceSettingsCombo(DeviceSettings);

Returns a specific device combination

public static EnumDeviceSettingsCombo GetDeviceSettingsCombo(uint,DeviceType,Format,Format,bool);

See Also

Enumeration Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Enumeration.GetDeviceSettingsCombo Method (DeviceSettings)

Returns a specific device combination from a device settings object

public static EnumDeviceSettingsCombo GetDeviceSettingsCombo(
DeviceSettings settings
);

See Also

Enumeration Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | Enumeration.GetDeviceSettingsCombo Overload List


Enumeration.GetDeviceSettingsCombo Method (UInt32, DeviceType, Format, Format, Boolean)

Returns a specific device combination

public static EnumDeviceSettingsCombo GetDeviceSettingsCombo(
uint ordinal,
DeviceType deviceType,
Format adapterFormat,
Format backBufferFormat,
bool isWindowed
);

See Also

Enumeration Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | Enumeration.GetDeviceSettingsCombo Overload List


Enumeration.ResetPossibleDepthStencilFormats Method

Resets the list of possible depth stencil formats

public static void ResetPossibleDepthStencilFormats();

See Also

Enumeration Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Enumeration.ResetPossibleMultisampleTypeList Method

Resets the possible multisample type list

public static void ResetPossibleMultisampleTypeList();

See Also

Enumeration Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Enumeration.ResetPossiblePresentIntervalList Method

Resets the possible present interval list

public static void ResetPossiblePresentIntervalList();

See Also

Enumeration Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Enumeration.SetRefreshMinMax Method

Sets the minimum and maximum refresh

public static void SetRefreshMinMax(
uint minRefresh,
uint maxRefresh
);

See Also

Enumeration Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Enumeration.SetResolutionMinMax Method

Set the minimum and maximum resolution items

public static void SetResolutionMinMax(
uint minWidth,
uint minHeight,
uint maxWidth,
uint maxHeight
);

See Also

Enumeration Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


FirstPersonCamera Class

Simple first person camera class that moves and rotates. It allows yaw and pitch but not roll. It uses keyboard and cursor to respond to keyboard and mouse input and updates the view matrix based on input.

For a list of all members of this type, see FirstPersonCamera Members.

System.Object
Microsoft.Samples.DirectX.UtilityToolkit.Camera
Microsoft.Samples.DirectX.UtilityToolkit.FirstPersonCamera

public class FirstPersonCamera : Camera

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

FirstPersonCamera Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


FirstPersonCamera Members

FirstPersonCamera overview

Public Instance Constructors

FirstPersonCamera Constructor Initializes a new instance of the FirstPersonCamera class.

Public Instance Properties

EyeLocation (inherited from Camera) | Returns the location of the eye
IsBeingDragged (inherited from Camera) | Is the camera being 'dragged' at all?
IsMouseLeftButtonDown (inherited from Camera) | Is the left mouse button down
IsMouseMiddleButtonDown (inherited from Camera) | Is the middle mouse button down
IsMouseRightButtonDown (inherited from Camera) | Is the right mouse button down
IsPositionMovementEnabled (inherited from Camera) | Is position movement enabled
LookAtPoint (inherited from Camera) | Returns the look at point of the camera
ProjectionMatrix (inherited from Camera) | Returns the projection transformation matrix
ViewMatrix (inherited from Camera) | Returns the view transformation matrix

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FrameMove |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HandleMessages (inherited from Camera) | Call this from your message proc so this class can handle window messages
Reset (inherited from Camera) | Reset the camera's position back to the default
SetProjectionParameters (inherited from Camera) | Calculates the projection matrix based on input params
SetRotationButtons | Enable or disable each of the mouse buttons for rotation drag.
SetViewParameters (inherited from Camera) | Client can call this to change the position and direction of camera
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

activeButtonMask
aspectRatio (inherited from Camera)
cameraPitchAngle (inherited from Camera)
cameraWorld
cameraYawAngle (inherited from Camera)
currentButtonMask (inherited from Camera)
defaultEye (inherited from Camera)
defaultLookAt (inherited from Camera)
dragRectangle (inherited from Camera)
dragTimer (inherited from Camera)
eye (inherited from Camera)
farPlane (inherited from Camera)
fieldOfView (inherited from Camera)
framesToSmoothMouseData (inherited from Camera)
isClipToBoundary (inherited from Camera)
isEnablePositionMovement (inherited from Camera)
isEnableYAxisMovement (inherited from Camera)
isInvertPitch (inherited from Camera)
isMouseLButtonDown (inherited from Camera)
isMouseMButtonDown (inherited from Camera)
isMouseRButtonDown (inherited from Camera)
isMovementDrag (inherited from Camera)
isResetCursorAfterMove (inherited from Camera)
keys (inherited from Camera)
lastMousePosition (inherited from Camera)
lookAt (inherited from Camera)
maxBoundary (inherited from Camera)
minBoundary (inherited from Camera)
mouseDelta (inherited from Camera)
mouseWheelDelta (inherited from Camera)
moveScaler (inherited from Camera)
nearPlane (inherited from Camera)
projMatrix (inherited from Camera)
rotationScaler (inherited from Camera)
rotationVelocity (inherited from Camera)
totalDragTimeToZero (inherited from Camera)
velocity (inherited from Camera)
velocityDrag (inherited from Camera)
viewMatrix (inherited from Camera)

Protected Instance Methods

ConstrainToBoundary (inherited from Camera) | Clamps V to lie inside boundaries
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
UpdateMouseDelta (inherited from Camera) | Figure out the mouse delta based on mouse movement
UpdateVelocity (inherited from Camera) |

See Also

FirstPersonCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


FirstPersonCamera Constructor

Initializes a new instance of the FirstPersonCamera class.

public FirstPersonCamera();

See Also

FirstPersonCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


FirstPersonCamera Fields

The fields of the FirstPersonCamera class are listed below. For a complete list of FirstPersonCamera class members, see the FirstPersonCamera Members topic.

Protected Instance Fields

activeButtonMask
aspectRatio (inherited from Camera)
cameraPitchAngle (inherited from Camera)
cameraWorld
cameraYawAngle (inherited from Camera)
currentButtonMask (inherited from Camera)
defaultEye (inherited from Camera)
defaultLookAt (inherited from Camera)
dragRectangle (inherited from Camera)
dragTimer (inherited from Camera)
eye (inherited from Camera)
farPlane (inherited from Camera)
fieldOfView (inherited from Camera)
framesToSmoothMouseData (inherited from Camera)
isClipToBoundary (inherited from Camera)
isEnablePositionMovement (inherited from Camera)
isEnableYAxisMovement (inherited from Camera)
isInvertPitch (inherited from Camera)
isMouseLButtonDown (inherited from Camera)
isMouseMButtonDown (inherited from Camera)
isMouseRButtonDown (inherited from Camera)
isMovementDrag (inherited from Camera)
isResetCursorAfterMove (inherited from Camera)
keys (inherited from Camera)
lastMousePosition (inherited from Camera)
lookAt (inherited from Camera)
maxBoundary (inherited from Camera)
minBoundary (inherited from Camera)
mouseDelta (inherited from Camera)
mouseWheelDelta (inherited from Camera)
moveScaler (inherited from Camera)
nearPlane (inherited from Camera)
projMatrix (inherited from Camera)
rotationScaler (inherited from Camera)
rotationVelocity (inherited from Camera)
totalDragTimeToZero (inherited from Camera)
velocity (inherited from Camera)
velocityDrag (inherited from Camera)
viewMatrix (inherited from Camera)

See Also

FirstPersonCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


FirstPersonCamera.activeButtonMask Field

protected int activeButtonMask;

See Also

FirstPersonCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


FirstPersonCamera.cameraWorld Field

protected Matrix cameraWorld;

See Also

FirstPersonCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


FirstPersonCamera Methods

The methods of the FirstPersonCamera class are listed below. For a complete list of FirstPersonCamera class members, see the FirstPersonCamera Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FrameMove |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HandleMessages (inherited from Camera) | Call this from your message proc so this class can handle window messages
Reset (inherited from Camera) | Reset the camera's position back to the default
SetProjectionParameters (inherited from Camera) | Calculates the projection matrix based on input params
SetRotationButtons | Enable or disable each of the mouse buttons for rotation drag.
SetViewParameters (inherited from Camera) | Client can call this to change the position and direction of camera
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

ConstrainToBoundary (inherited from Camera) | Clamps V to lie inside boundaries
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
UpdateMouseDelta (inherited from Camera) | Figure out the mouse delta based on mouse movement
UpdateVelocity (inherited from Camera) |

See Also

FirstPersonCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


FirstPersonCamera.FrameMove Method

public override void FrameMove(
float elapsedTime
);

See Also

FirstPersonCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


FirstPersonCamera.SetRotationButtons Method

Enable or disable each of the mouse buttons for rotation drag.

public void SetRotationButtons(
bool left,
bool middle,
bool right
);

See Also

FirstPersonCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


FontNode Class

Structure for shared fonts

For a list of all members of this type, see FontNode Members.

System.Object
Microsoft.Samples.DirectX.UtilityToolkit.FontNode

public class FontNode

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

FontNode Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


FontNode Members

FontNode overview

Public Instance Constructors

FontNode Constructor Initializes a new instance of the FontNode class.

Public Instance Fields

FaceName
Font
Height
Weight

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FontNode Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


FontNode Constructor

Initializes a new instance of the FontNode class.

public FontNode();

See Also

FontNode Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


FontNode Fields

The fields of the FontNode class are listed below. For a complete list of FontNode class members, see the FontNode Members topic.

Public Instance Fields

FaceName
Font
Height
Weight

See Also

FontNode Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


FontNode.FaceName Field

public string FaceName;

See Also

FontNode Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


FontNode.Font Field

public Font Font;

See Also

FontNode Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


FontNode.Height Field

public uint Height;

See Also

FontNode Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


FontNode.Weight Field

public FontWeight Weight;

See Also

FontNode Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Framework Class

Managed Utility Framework Class

For a list of all members of this type, see Framework Members.

System.Object
Microsoft.Samples.DirectX.UtilityToolkit.Framework

public sealed class Framework : IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

Framework Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Framework Members

Framework overview

Public Static Fields

DefaultSizeHeight
DefaultSizeWidth
TrueIntPtr

Public Instance Constructors

Framework Constructor Constructor, init data here

Public Instance Properties

BackBufferSurfaceDescription | Returns the back buffer surface description
CanAutomaticallyChangeMonitor | Determines if the adapter can automatically change monitors
ClientRectangle | Client rectangle size
Device | Returns the device current in use for the framework
DeviceCaps | Returns the device capabilities
DeviceSettings | Return the device settings of the current device. If no device exists yet, then return blank device settings
DeviceStats | Device statistics
ExitCode | Exit code from the framework
FPS | Frames per second application is running at
FrameStats | Frame statistics
IsD3DSettingsDialogShowing | Returns whether the settings is showing
IsIgnoringSizeChanges | Should the framework ignore size changes?
IsNotifiedOnMouseMove | Should the framework also notify for mouse moves
IsOverridingFullScreen | Should the framework override and start fullscreen?
IsWindowed | Return if windowed in the current device. If no device exists yet, return false
OverridingAdapterOrdinal | Should the framework override the monitor to use?
PresentParameters | Return the present params of the current device. If no device exists yet, then return blank present params
Window | Get the current window used for rendering
WindowClientRectangle | Client rectangle size
WindowDeviceFullscreen | Get the current window used for full screen rendering
WindowDeviceWindowed | Get the current window used for windowed rendering
WindowFocus | Get the current focus window

Public Instance Methods

CloseWindow | Will close the window
CreateDevice | Overloaded. Creates a Direct3D device. If CreateWindow or SetWindow has not already been called, it will call CreateWindow with default parameters. Instead of calling this, you can call SetDevice or CreateDeviceFromSettings
CreateDeviceFromSettings | Overloaded. Tells the framework to change to a device created from the passed in device settings If CreateWindow() has not already been called, it will call it with the default parameters. Instead of calling this, you can call CreateDevice() or SetDevice()
CreateWindow | Overloaded. Creates a window with the specified title, icon, menu, and starting position. If Init hasn't been called, this will call with default params. Instead of calling this, you can call SetWindow to use an existing window
DisplayErrorMessage | Display an custom error msg box
Dispose | Shut down the sample framework
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize |
KillTimer | Kills an already created timer
LoadFirstIconFromResource | Will try to load the first icon from the resources
MainLoop | Handles app's message loop and rendering when idle. If CreateDevice*() or SetDevice() has not already been called, it will call CreateDevice() with the default parameters.
Pause | Pauses time or rendering. Keeps a ref count so pausing can be layered
Render3DEnvironment | Render the 3D environment by: - Checking if the device is lost and trying to reset it if it is - Get the elapsed time since the last frame - Calling the app's framemove and render callback - Calling Present() If you're not using MainLoop, consider using Render3DEnvironment
Reset3DEnvironment | Resets the 3D environment by: - Calls the device lost callback - Resets the device - Stores the back buffer description - Sets up the full screen Direct3D cursor if requested - Calls the device reset callback
ResetState | Resets the state associated with the sample framework
SetCallbackInterface |
SetConstantFrameTime | Overloaded. Allows to set constant time per frame
SetCursorSettings | Handles setting up the cursor settings for fullscreen
SetDevice | Passes a previously created Direct3D device for use by the framework. If CreateWindow() has not already been called, it will call it with the default parameters. Instead of calling this, you can call CreateDevice() or CreateDeviceFromSettings()
SetDeviceCreationInterface |
SetKeyboardCallback |
SetMouseCallback |
SetTimer | Adds a timer to the list of timers for the application
SetWindow | Sets a previously created window for the framework to use. If Init has not already been called, it will call it with default parameters. Instead of calling this you can call CreateWindow to create a new window.
SetWndProcCallback |
ShowSettingsDialog | Show the settings dialog, and create if needed
ToggleFullscreen | Toggle between full screen and windowed
ToggleReference | Toggle between Hardware and Reference
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

DeviceCreated | The event fired for when the device is created
DeviceLost | The event fired for when the device is lost
DeviceReset | The event fired for when the device is reset
Disposing | The event fired for disposing of the device

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Framework Constructor

Constructor, init data here

public Framework();

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Framework Fields

The fields of the Framework class are listed below. For a complete list of Framework class members, see the Framework Members topic.

Public Static Fields

DefaultSizeHeight
DefaultSizeWidth
TrueIntPtr

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Framework.DefaultSizeHeight Field

public const int DefaultSizeHeight = 480;

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Framework.DefaultSizeWidth Field

public const int DefaultSizeWidth = 640;

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Framework.TrueIntPtr Field

public static readonly IntPtr TrueIntPtr;

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Framework Properties

The properties of the Framework class are listed below. For a complete list of Framework class members, see the Framework Members topic.

Public Instance Properties

BackBufferSurfaceDescription | Returns the back buffer surface description
CanAutomaticallyChangeMonitor | Determines if the adapter can automatically change monitors
ClientRectangle | Client rectangle size
Device | Returns the device current in use for the framework
DeviceCaps | Returns the device capabilities
DeviceSettings | Return the device settings of the current device. If no device exists yet, then return blank device settings
DeviceStats | Device statistics
ExitCode | Exit code from the framework
FPS | Frames per second application is running at
FrameStats | Frame statistics
IsD3DSettingsDialogShowing | Returns whether the settings is showing
IsIgnoringSizeChanges | Should the framework ignore size changes?
IsNotifiedOnMouseMove | Should the framework also notify for mouse moves
IsOverridingFullScreen | Should the framework override and start fullscreen?
IsWindowed | Return if windowed in the current device. If no device exists yet, return false
OverridingAdapterOrdinal | Should the framework override the monitor to use?
PresentParameters | Return the present params of the current device. If no device exists yet, then return blank present params
Window | Get the current window used for rendering
WindowClientRectangle | Client rectangle size
WindowDeviceFullscreen | Get the current window used for full screen rendering
WindowDeviceWindowed | Get the current window used for windowed rendering
WindowFocus | Get the current focus window

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


BackBufferSurfaceDescription Property

Goblin - A Platform for 3D AR and VR Applications

Framework.BackBufferSurfaceDescription Property

Returns the back buffer surface description

public Microsoft.DirectX.Direct3D.SurfaceDescription BackBufferSurfaceDescription {get;}

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


CanAutomaticallyChangeMonitor Property

Goblin - A Platform for 3D AR and VR Applications

Framework.CanAutomaticallyChangeMonitor Property

Determines if the adapter can automatically change monitors

public bool CanAutomaticallyChangeMonitor {get; set;}

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ClientRectangle Property

Goblin - A Platform for 3D AR and VR Applications

Framework.ClientRectangle Property

Client rectangle size

public System.Drawing.Rectangle ClientRectangle {get;}

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Device Property

Goblin - A Platform for 3D AR and VR Applications

Framework.Device Property

Returns the device current in use for the framework

public Microsoft.DirectX.Direct3D.Device Device {get;}

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DeviceCaps Property

Goblin - A Platform for 3D AR and VR Applications

Framework.DeviceCaps Property

Returns the device capabilities

public Microsoft.DirectX.Direct3D.Caps DeviceCaps {get;}

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DeviceSettings Property

Goblin - A Platform for 3D AR and VR Applications

Framework.DeviceSettings Property

Return the device settings of the current device. If no device exists yet, then return blank device settings

public DeviceSettings DeviceSettings {get;}

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DeviceStats Property

Goblin - A Platform for 3D AR and VR Applications

Framework.DeviceStats Property

Device statistics

public string DeviceStats {get;}

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ExitCode Property

Goblin - A Platform for 3D AR and VR Applications

Framework.ExitCode Property

Exit code from the framework

public int ExitCode {get;}

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


FPS Property

Goblin - A Platform for 3D AR and VR Applications

Framework.FPS Property

Frames per second application is running at

public float FPS {get;}

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


FrameStats Property

Goblin - A Platform for 3D AR and VR Applications

Framework.FrameStats Property

Frame statistics

public string FrameStats {get;}

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


IsD3DSettingsDialogShowing Property

Goblin - A Platform for 3D AR and VR Applications

Framework.IsD3DSettingsDialogShowing Property

Returns whether the settings is showing

public bool IsD3DSettingsDialogShowing {get;}

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


IsIgnoringSizeChanges Property

Goblin - A Platform for 3D AR and VR Applications

Framework.IsIgnoringSizeChanges Property

Should the framework ignore size changes?

public bool IsIgnoringSizeChanges {get; set;}

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


IsNotifiedOnMouseMove Property

Goblin - A Platform for 3D AR and VR Applications

Framework.IsNotifiedOnMouseMove Property

Should the framework also notify for mouse moves

public bool IsNotifiedOnMouseMove {get; set;}

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


IsOverridingFullScreen Property

Goblin - A Platform for 3D AR and VR Applications

Framework.IsOverridingFullScreen Property

Should the framework override and start fullscreen?

public bool IsOverridingFullScreen {get; set;}

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


IsWindowed Property

Goblin - A Platform for 3D AR and VR Applications

Framework.IsWindowed Property

Return if windowed in the current device. If no device exists yet, return false

public bool IsWindowed {get;}

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


OverridingAdapterOrdinal Property

Goblin - A Platform for 3D AR and VR Applications

Framework.OverridingAdapterOrdinal Property

Should the framework override the monitor to use?

public int OverridingAdapterOrdinal {get; set;}

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


PresentParameters Property

Goblin - A Platform for 3D AR and VR Applications

Framework.PresentParameters Property

Return the present params of the current device. If no device exists yet, then return blank present params

public Microsoft.DirectX.Direct3D.PresentParameters PresentParameters {get;}

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Window Property

Goblin - A Platform for 3D AR and VR Applications

Framework.Window Property

Get the current window used for rendering

public System.IntPtr Window {get;}

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


WindowClientRectangle Property

Goblin - A Platform for 3D AR and VR Applications

Framework.WindowClientRectangle Property

Client rectangle size

public System.Drawing.Rectangle WindowClientRectangle {get;}

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


WindowDeviceFullscreen Property

Goblin - A Platform for 3D AR and VR Applications

Framework.WindowDeviceFullscreen Property

Get the current window used for full screen rendering

public System.IntPtr WindowDeviceFullscreen {get;}

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


WindowDeviceWindowed Property

Goblin - A Platform for 3D AR and VR Applications

Framework.WindowDeviceWindowed Property

Get the current window used for windowed rendering

public System.IntPtr WindowDeviceWindowed {get;}

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


WindowFocus Property

Goblin - A Platform for 3D AR and VR Applications

Framework.WindowFocus Property

Get the current focus window

public System.IntPtr WindowFocus {get;}

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Framework Methods

The methods of the Framework class are listed below. For a complete list of Framework class members, see the Framework Members topic.

Public Instance Methods

CloseWindow | Will close the window
CreateDevice | Overloaded. Creates a Direct3D device. If CreateWindow or SetWindow has not already been called, it will call CreateWindow with default parameters. Instead of calling this, you can call SetDevice or CreateDeviceFromSettings
CreateDeviceFromSettings | Overloaded. Tells the framework to change to a device created from the passed in device settings If CreateWindow() has not already been called, it will call it with the default parameters. Instead of calling this, you can call CreateDevice() or SetDevice()
CreateWindow | Overloaded. Creates a window with the specified title, icon, menu, and starting position. If Init hasn't been called, this will call with default params. Instead of calling this, you can call SetWindow to use an existing window
DisplayErrorMessage | Display an custom error msg box
Dispose | Shut down the sample framework
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize |
KillTimer | Kills an already created timer
LoadFirstIconFromResource | Will try to load the first icon from the resources
MainLoop | Handles app's message loop and rendering when idle. If CreateDevice*() or SetDevice() has not already been called, it will call CreateDevice() with the default parameters.
Pause | Pauses time or rendering. Keeps a ref count so pausing can be layered
Render3DEnvironment | Render the 3D environment by: - Checking if the device is lost and trying to reset it if it is - Get the elapsed time since the last frame - Calling the app's framemove and render callback - Calling Present() If you're not using MainLoop, consider using Render3DEnvironment
Reset3DEnvironment | Resets the 3D environment by: - Calls the device lost callback - Resets the device - Stores the back buffer description - Sets up the full screen Direct3D cursor if requested - Calls the device reset callback
ResetState | Resets the state associated with the sample framework
SetCallbackInterface |
SetConstantFrameTime | Overloaded. Allows to set constant time per frame
SetCursorSettings | Handles setting up the cursor settings for fullscreen
SetDevice | Passes a previously created Direct3D device for use by the framework. If CreateWindow() has not already been called, it will call it with the default parameters. Instead of calling this, you can call CreateDevice() or CreateDeviceFromSettings()
SetDeviceCreationInterface |
SetKeyboardCallback |
SetMouseCallback |
SetTimer | Adds a timer to the list of timers for the application
SetWindow | Sets a previously created window for the framework to use. If Init has not already been called, it will call it with default parameters. Instead of calling this you can call CreateWindow to create a new window.
SetWndProcCallback |
ShowSettingsDialog | Show the settings dialog, and create if needed
ToggleFullscreen | Toggle between full screen and windowed
ToggleReference | Toggle between Hardware and Reference
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Framework.CloseWindow Method

Will close the window

public void CloseWindow();

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


CreateDevice Method

Goblin - A Platform for 3D AR and VR Applications

Framework.CreateDevice Method

Creates a Direct3D device. If CreateWindow or SetWindow has not already been called, it will call CreateWindow with default parameters. Instead of calling this, you can call SetDevice or CreateDeviceFromSettings This is the CLS compliant version

Overload List

Creates a Direct3D device. If CreateWindow or SetWindow has not already been called, it will call CreateWindow with default parameters. Instead of calling this, you can call SetDevice or CreateDeviceFromSettings This is the CLS compliant version

public void CreateDevice(int,bool,int,int,IDeviceCreation);

Creates a Direct3D device. If CreateWindow or SetWindow has not already been called, it will call CreateWindow with default parameters. Instead of calling this, you can call SetDevice or CreateDeviceFromSettings

public void CreateDevice(uint,bool,int,int,IDeviceCreation);

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Framework.CreateDevice Method (Int32, Boolean, Int32, Int32, IDeviceCreation)

Creates a Direct3D device. If CreateWindow or SetWindow has not already been called, it will call CreateWindow with default parameters. Instead of calling this, you can call SetDevice or CreateDeviceFromSettings This is the CLS compliant version

public void CreateDevice(
int adapterOridinal,
bool windowed,
int suggestedWidth,
int suggestedHeight,
IDeviceCreation callback
);

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | Framework.CreateDevice Overload List


Framework.CreateDevice Method (UInt32, Boolean, Int32, Int32, IDeviceCreation)

Creates a Direct3D device. If CreateWindow or SetWindow has not already been called, it will call CreateWindow with default parameters. Instead of calling this, you can call SetDevice or CreateDeviceFromSettings

public void CreateDevice(
uint adapterOridinal,
bool windowed,
int suggestedWidth,
int suggestedHeight,
IDeviceCreation callback
);

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | Framework.CreateDevice Overload List


CreateDeviceFromSettings Method

Goblin - A Platform for 3D AR and VR Applications

Framework.CreateDeviceFromSettings Method

Tells the framework to change to a device created from the passed in device settings If CreateWindow() has not already been called, it will call it with the default parameters. Instead of calling this, you can call CreateDevice() or SetDevice()

Overload List

Tells the framework to change to a device created from the passed in device settings If CreateWindow() has not already been called, it will call it with the default parameters. Instead of calling this, you can call CreateDevice() or SetDevice()

public void CreateDeviceFromSettings(DeviceSettings);

Tells the framework to change to a device created from the passed in device settings If CreateWindow() has not already been called, it will call it with the default parameters. Instead of calling this, you can call CreateDevice() or SetDevice()

public void CreateDeviceFromSettings(DeviceSettings,bool);

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Framework.CreateDeviceFromSettings Method (DeviceSettings)

Tells the framework to change to a device created from the passed in device settings If CreateWindow() has not already been called, it will call it with the default parameters. Instead of calling this, you can call CreateDevice() or SetDevice()

public void CreateDeviceFromSettings(
DeviceSettings deviceSettings
);

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | Framework.CreateDeviceFromSettings Overload List


Framework.CreateDeviceFromSettings Method (DeviceSettings, Boolean)

Tells the framework to change to a device created from the passed in device settings If CreateWindow() has not already been called, it will call it with the default parameters. Instead of calling this, you can call CreateDevice() or SetDevice()

public void CreateDeviceFromSettings(
DeviceSettings deviceSettings,
bool preserveInput
);

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | Framework.CreateDeviceFromSettings Overload List


CreateWindow Method

Goblin - A Platform for 3D AR and VR Applications

Framework.CreateWindow Method

Calls into CreateWindow with default paramters

Overload List

Calls into CreateWindow with default paramters

public void CreateWindow(string);

Creates a window with the specified title, icon, menu, and starting position. If Init hasn't been called, this will call with default params. Instead of calling this, you can call SetWindow to use an existing window

public void CreateWindow(string,Icon,MainMenu,int,int);

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Framework.CreateWindow Method (String)

Calls into CreateWindow with default paramters

public void CreateWindow(
string windowTitle
);

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | Framework.CreateWindow Overload List


Framework.CreateWindow Method (String, Icon, MainMenu, Int32, Int32)

Creates a window with the specified title, icon, menu, and starting position. If Init hasn't been called, this will call with default params. Instead of calling this, you can call SetWindow to use an existing window

public void CreateWindow(
string windowTitle,
Icon icon,
MainMenu menu,
int x,
int y
);

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | Framework.CreateWindow Overload List


Framework.DisplayErrorMessage Method

Display an custom error msg box

public void DisplayErrorMessage(
Exception e
);

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Framework.Dispose Method

Shut down the sample framework

public void Dispose();

Implements

IDisposable.Dispose

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Framework.Initialize Method

public void Initialize(
bool isParsingCommandLine,
bool handleDefaultKeys,
bool showMessageBoxOnError
);

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Framework.KillTimer Method

Kills an already created timer

public void KillTimer(
int id
);

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Framework.LoadFirstIconFromResource Method

Will try to load the first icon from the resources

public Icon LoadFirstIconFromResource();

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Framework.MainLoop Method

Handles app's message loop and rendering when idle. If CreateDevice*() or SetDevice() has not already been called, it will call CreateDevice() with the default parameters.

public void MainLoop();

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Framework.Pause Method

Pauses time or rendering. Keeps a ref count so pausing can be layered

public void Pause(
bool pauseTime,
bool pauseRendering
);

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Framework.Render3DEnvironment Method

Render the 3D environment by: - Checking if the device is lost and trying to reset it if it is - Get the elapsed time since the last frame - Calling the app's framemove and render callback - Calling Present() If you're not using MainLoop, consider using Render3DEnvironment

public void Render3DEnvironment();

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Framework.Reset3DEnvironment Method

Resets the 3D environment by: - Calls the device lost callback - Resets the device - Stores the back buffer description - Sets up the full screen Direct3D cursor if requested - Calls the device reset callback

public void Reset3DEnvironment();

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Framework.ResetState Method

Resets the state associated with the sample framework

public void ResetState();

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Framework.SetCallbackInterface Method

public void SetCallbackInterface(
IFrameworkCallback callback
);

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


SetConstantFrameTime Method

Goblin - A Platform for 3D AR and VR Applications

Framework.SetConstantFrameTime Method

Allows to set constant time per frame

Overload List

Allows to set constant time per frame

public void SetConstantFrameTime(bool);

Allows to set constant time per frame

public void SetConstantFrameTime(bool,float);

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Framework.SetConstantFrameTime Method (Boolean)

Allows to set constant time per frame

public void SetConstantFrameTime(
bool constantFrameTime
);

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | Framework.SetConstantFrameTime Overload List


Framework.SetConstantFrameTime Method (Boolean, Single)

Allows to set constant time per frame

public void SetConstantFrameTime(
bool constantFrameTime,
float timePerFrame
);

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | Framework.SetConstantFrameTime Overload List


Framework.SetCursorSettings Method

Handles setting up the cursor settings for fullscreen

public void SetCursorSettings(
bool showCursorWhenFullscreen,
bool clipCursorWhenFullscreen
);

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Framework.SetDevice Method

Passes a previously created Direct3D device for use by the framework. If CreateWindow() has not already been called, it will call it with the default parameters. Instead of calling this, you can call CreateDevice() or CreateDeviceFromSettings()

public void SetDevice(
Device device
);

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Framework.SetDeviceCreationInterface Method

public void SetDeviceCreationInterface(
IDeviceCreation callback
);

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Framework.SetKeyboardCallback Method

public void SetKeyboardCallback(
KeyboardCallback callback
);

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Framework.SetMouseCallback Method

public void SetMouseCallback(
MouseCallback callback
);

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Framework.SetTimer Method

Adds a timer to the list of timers for the application

public int SetTimer(
TimerCallback callbackTimer,
float timeoutInSeconds
);

Return Value

A unqiue id of the timer

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Framework.SetWindow Method

Sets a previously created window for the framework to use. If Init has not already been called, it will call it with default parameters. Instead of calling this you can call CreateWindow to create a new window.

public void SetWindow(
IntPtr windowFocus,
IntPtr windowDeviceFullscreen,
IntPtr windowDeviceWindowed,
bool handleMessages
);

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Framework.SetWndProcCallback Method

public void SetWndProcCallback(
WndProcCallback callback
);

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Framework.ShowSettingsDialog Method

Show the settings dialog, and create if needed

public void ShowSettingsDialog(
bool shouldShow
);

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Framework.ToggleFullscreen Method

Toggle between full screen and windowed

public void ToggleFullscreen();

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Framework.ToggleReference Method

Toggle between Hardware and Reference

public void ToggleReference();

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Framework Events

The events of the Framework class are listed below. For a complete list of Framework class members, see the Framework Members topic.

Public Instance Events

DeviceCreated | The event fired for when the device is created
DeviceLost | The event fired for when the device is lost
DeviceReset | The event fired for when the device is reset
Disposing | The event fired for disposing of the device

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Framework.DeviceCreated Event

The event fired for when the device is created

public event DeviceEventHandler DeviceCreated;

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Framework.DeviceLost Event

The event fired for when the device is lost

public event EventHandler DeviceLost;

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Framework.DeviceReset Event

The event fired for when the device is reset

public event DeviceEventHandler DeviceReset;

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Framework.Disposing Event

The event fired for disposing of the device

public event EventHandler Disposing;

See Also

Framework Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


FrameworkMesh Class

Class for loading and rendering file-based meshes

For a list of all members of this type, see FrameworkMesh Members.

System.Object
Microsoft.Samples.DirectX.UtilityToolkit.FrameworkMesh

public sealed class FrameworkMesh : IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

FrameworkMesh Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


FrameworkMesh Members

FrameworkMesh overview

Public Instance Constructors

FrameworkMesh Overloaded. Initializes a new instance of the FrameworkMesh class.

Public Instance Properties

IsUsingMaterials | Should the mesh be rendered with materials
LocalMesh | Returns the local memory mesh
NumberMaterials | Number of materials in mesh
SystemMesh | Returns the system memory mesh

Public Instance Methods

ComputeBoundingSphere | Compute a bounding sphere for this mesh
Create | Create the mesh data
CreateMaterials | Create the materials for the mesh
Dispose | Cleans up any resources required when this object is disposed
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetMaterial | Gets a material from the mesh
GetTexture | Gets a texture from the mesh
GetType (inherited from Object) | Gets the Type of the current instance.
Render | Overloaded. Renders this mesh
SetVertexDeclaration | Updates the mesh to a new vertex declaration
SetVertexFormat | Updates the mesh to a new vertex format
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FrameworkMesh Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


FrameworkMesh Constructor

Create a new mesh using this file

Overload List

Create a new mesh

public FrameworkMesh();

Create a new mesh using this file

public FrameworkMesh(Device,string);

See Also

FrameworkMesh Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


FrameworkMesh Constructor (Device, String)

Create a new mesh using this file

public FrameworkMesh(
Device device,
string name
);

See Also

FrameworkMesh Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | FrameworkMesh Constructor Overload List


FrameworkMesh Constructor ()

Create a new mesh

public FrameworkMesh();

See Also

FrameworkMesh Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | FrameworkMesh Constructor Overload List


FrameworkMesh Properties

The properties of the FrameworkMesh class are listed below. For a complete list of FrameworkMesh class members, see the FrameworkMesh Members topic.

Public Instance Properties

IsUsingMaterials | Should the mesh be rendered with materials
LocalMesh | Returns the local memory mesh
NumberMaterials | Number of materials in mesh
SystemMesh | Returns the system memory mesh

See Also

FrameworkMesh Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


IsUsingMaterials Property

Goblin - A Platform for 3D AR and VR Applications

FrameworkMesh.IsUsingMaterials Property

Should the mesh be rendered with materials

public bool IsUsingMaterials {get; set;}

See Also

FrameworkMesh Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


LocalMesh Property

Goblin - A Platform for 3D AR and VR Applications

FrameworkMesh.LocalMesh Property

Returns the local memory mesh

public Microsoft.DirectX.Direct3D.Mesh LocalMesh {get;}

See Also

FrameworkMesh Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NumberMaterials Property

Goblin - A Platform for 3D AR and VR Applications

FrameworkMesh.NumberMaterials Property

Number of materials in mesh

public int NumberMaterials {get;}

See Also

FrameworkMesh Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


SystemMesh Property

Goblin - A Platform for 3D AR and VR Applications

FrameworkMesh.SystemMesh Property

Returns the system memory mesh

public Microsoft.DirectX.Direct3D.Mesh SystemMesh {get;}

See Also

FrameworkMesh Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


FrameworkMesh Methods

The methods of the FrameworkMesh class are listed below. For a complete list of FrameworkMesh class members, see the FrameworkMesh Members topic.

Public Instance Methods

ComputeBoundingSphere | Compute a bounding sphere for this mesh
Create | Create the mesh data
CreateMaterials | Create the materials for the mesh
Dispose | Cleans up any resources required when this object is disposed
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetMaterial | Gets a material from the mesh
GetTexture | Gets a texture from the mesh
GetType (inherited from Object) | Gets the Type of the current instance.
Render | Overloaded. Renders this mesh
SetVertexDeclaration | Updates the mesh to a new vertex declaration
SetVertexFormat | Updates the mesh to a new vertex format
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FrameworkMesh Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


FrameworkMesh.ComputeBoundingSphere Method

Compute a bounding sphere for this mesh

public float ComputeBoundingSphere(
out Vector3 center
);

See Also

FrameworkMesh Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


FrameworkMesh.Create Method

Create the mesh data

public void Create(
Device device,
string name
);

See Also

FrameworkMesh Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


FrameworkMesh.CreateMaterials Method

Create the materials for the mesh

public void CreateMaterials(
string folder,
Device device,
GraphicsStream adjacency,
ExtendedMaterial[] materials
);

See Also

FrameworkMesh Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


FrameworkMesh.Dispose Method

Cleans up any resources required when this object is disposed

public void Dispose();

Implements

IDisposable.Dispose

See Also

FrameworkMesh Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


FrameworkMesh.GetMaterial Method

Gets a material from the mesh

public Material GetMaterial(
int index
);

See Also

FrameworkMesh Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


FrameworkMesh.GetTexture Method

Gets a texture from the mesh

public BaseTexture GetTexture(
int index
);

See Also

FrameworkMesh Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Render Method

Goblin - A Platform for 3D AR and VR Applications

FrameworkMesh.Render Method

Renders this mesh

Overload List

Renders this mesh

public void Render(Device);

Renders this mesh

public void Render(Device,bool,bool);

See Also

FrameworkMesh Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


FrameworkMesh.Render Method (Device)

Renders this mesh

public void Render(
Device device
);

See Also

FrameworkMesh Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | FrameworkMesh.Render Overload List


FrameworkMesh.Render Method (Device, Boolean, Boolean)

Renders this mesh

public void Render(
Device device,
bool canDrawOpaque,
bool canDrawAlpha
);

See Also

FrameworkMesh Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | FrameworkMesh.Render Overload List


FrameworkMesh.SetVertexDeclaration Method

Updates the mesh to a new vertex declaration

public void SetVertexDeclaration(
Device device,
VertexElement[] decl
);

See Also

FrameworkMesh Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


FrameworkMesh.SetVertexFormat Method

Updates the mesh to a new vertex format

public void SetVertexFormat(
Device device,
VertexFormats format
);

See Also

FrameworkMesh Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


FrameworkTimer Class

For a list of all members of this type, see FrameworkTimer Members.

System.Object
Microsoft.Samples.DirectX.UtilityToolkit.FrameworkTimer

public class FrameworkTimer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

FrameworkTimer Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


FrameworkTimer Members

FrameworkTimer overview

Public Static Properties

IsStopped Returns true if timer stopped

Public Static Methods

Advance | Advance the timer a tenth of a second
GetAbsoluteTime | Get the absolute system time
GetElapsedTime | get the time that elapsed between GetElapsedTime() calls
GetTime | Get the current time
Reset | Resets the timer
Start | Starts the timer
Stop | Stop (or pause) the timer

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FrameworkTimer Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


FrameworkTimer Properties

The properties of the FrameworkTimer class are listed below. For a complete list of FrameworkTimer class members, see the FrameworkTimer Members topic.

Public Static Properties

IsStopped Returns true if timer stopped

See Also

FrameworkTimer Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


IsStopped Property

Goblin - A Platform for 3D AR and VR Applications

FrameworkTimer.IsStopped Property

Returns true if timer stopped

public static bool IsStopped {get;}

See Also

FrameworkTimer Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


FrameworkTimer Methods

The methods of the FrameworkTimer class are listed below. For a complete list of FrameworkTimer class members, see the FrameworkTimer Members topic.

Public Static Methods

Advance | Advance the timer a tenth of a second
GetAbsoluteTime | Get the absolute system time
GetElapsedTime | get the time that elapsed between GetElapsedTime() calls
GetTime | Get the current time
Reset | Resets the timer
Start | Starts the timer
Stop | Stop (or pause) the timer

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FrameworkTimer Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


FrameworkTimer.Advance Method

Advance the timer a tenth of a second

public static void Advance();

See Also

FrameworkTimer Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


FrameworkTimer.GetAbsoluteTime Method

Get the absolute system time

public static double GetAbsoluteTime();

See Also

FrameworkTimer Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


FrameworkTimer.GetElapsedTime Method

get the time that elapsed between GetElapsedTime() calls

public static double GetElapsedTime();

See Also

FrameworkTimer Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


FrameworkTimer.GetTime Method

Get the current time

public static double GetTime();

See Also

FrameworkTimer Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


FrameworkTimer.Reset Method

Resets the timer

public static void Reset();

See Also

FrameworkTimer Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


FrameworkTimer.Start Method

Starts the timer

public static void Start();

See Also

FrameworkTimer Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


FrameworkTimer.Stop Method

Stop (or pause) the timer

public static void Stop();

See Also

FrameworkTimer Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


IDeviceCreation Interface

Interface that the framework will use to determine if a device is acceptable

For a list of all members of this type, see IDeviceCreation Members.

public interface IDeviceCreation

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

IDeviceCreation Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


IDeviceCreation Members

IDeviceCreation overview

Public Instance Methods

IsDeviceAcceptable
ModifyDeviceSettings

See Also

IDeviceCreation Interface | Microsoft.Samples.DirectX.UtilityToolkit Namespace


IDeviceCreation Methods

The methods of the IDeviceCreation interface are listed below. For a complete list of IDeviceCreation interface members, see the IDeviceCreation Members topic.

Public Instance Methods

IsDeviceAcceptable
ModifyDeviceSettings

See Also

IDeviceCreation Interface | Microsoft.Samples.DirectX.UtilityToolkit Namespace


IDeviceCreation.IsDeviceAcceptable Method

bool IsDeviceAcceptable(
Caps caps,
Format adapterFormat,
Format backBufferFormat,
bool isWindowed
);

See Also

IDeviceCreation Interface | Microsoft.Samples.DirectX.UtilityToolkit Namespace


IDeviceCreation.ModifyDeviceSettings Method

void ModifyDeviceSettings(
DeviceSettings settings,
Caps caps
);

See Also

IDeviceCreation Interface | Microsoft.Samples.DirectX.UtilityToolkit Namespace


IFrameworkCallback Interface

Interface that the framework will use to call into samples

For a list of all members of this type, see IFrameworkCallback Members.

public interface IFrameworkCallback

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

IFrameworkCallback Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


IFrameworkCallback Members

IFrameworkCallback overview

Public Instance Methods

OnFrameMove
OnFrameRender

See Also

IFrameworkCallback Interface | Microsoft.Samples.DirectX.UtilityToolkit Namespace


IFrameworkCallback Methods

The methods of the IFrameworkCallback interface are listed below. For a complete list of IFrameworkCallback interface members, see the IFrameworkCallback Members topic.

Public Instance Methods

OnFrameMove
OnFrameRender

See Also

IFrameworkCallback Interface | Microsoft.Samples.DirectX.UtilityToolkit Namespace


IFrameworkCallback.OnFrameMove Method

void OnFrameMove(
Device device,
double totalTime,
float elapsedTime
);

See Also

IFrameworkCallback Interface | Microsoft.Samples.DirectX.UtilityToolkit Namespace


IFrameworkCallback.OnFrameRender Method

void OnFrameRender(
Device device,
double totalTime,
float elapsedTime
);

See Also

IFrameworkCallback Interface | Microsoft.Samples.DirectX.UtilityToolkit Namespace


KeyboardCallback Delegate

public delegate void KeyboardCallback(
Keys key,
bool keyDown,
bool altDown
);

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBox Class

List box control

For a list of all members of this type, see ListBox Members.

System.Object
Microsoft.Samples.DirectX.UtilityToolkit.Control
Microsoft.Samples.DirectX.UtilityToolkit.ListBox

public class ListBox : Control

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

ListBox Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBox Members

ListBox overview

Public Static Fields

MainLayer
SelectionLayer

Public Instance Constructors

ListBox Constructor Create a new list box control

Public Instance Fields

index (inherited from Control)
isDefault (inherited from Control)

Public Instance Properties

CanHaveFocus | Can this control have focus
ControlType (inherited from Control) | Type of the control
Hotkey (inherited from Control) | The controls hotkey
ID (inherited from Control) | Unique ID of the control
IsEnabled (inherited from Control) | Is the control enabled
IsVisible (inherited from Control) | Is the control visible
Item | Overloaded. Indexer for items in the list
NumberItems | Number of items current in the list
Parent (inherited from Control) | The parent dialog of this control
Style | Sets the style of the listbox
UserData (inherited from Control) | User specified data

Public Instance Methods

AddItem | Adds an item to the list box control
Clear | Removes all items from the control
ContainsPoint (inherited from Control) | Does the control contain this point
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSelectedIndex | For single-selection listbox, returns the index of the selected item. For multi-selection, returns the first selected item after the previousSelected position. To search for the first selected item, the app passes -1 for previousSelected. For subsequent searches, the app passes the returned index back to GetSelectedIndex as. previousSelected. Returns -1 on error or if no item is selected.
GetSelectedItem | Overloaded. Gets the selected item
GetType (inherited from Object) | Gets the Type of the current instance.
HandleKeyboard | Called when the control needs to handle the keyboard
HandleMouse | Called when the control should handle the mouse
InsertItem | Inserts an item to the list box control
MsgProc (inherited from Control) | Message Handler
OnFocusIn (inherited from Control) | Called when control gets focus
OnFocusOut (inherited from Control) | Called when control loses focus
OnHotKey (inherited from Control) | Called when the control's hotkey is hit
OnInitialize | Initialize the scrollbar control here
OnMouseEnter (inherited from Control) | Called when mouse goes over the control
OnMouseExit (inherited from Control) | Called when mouse leaves the control
Refresh (inherited from Control) | Refreshes the control
RemoveAt | Removes an item at a particular index
Render | Called when the control should be rendered
SelectItem | Selects this item
SetBorder | Sets the border and margin sizes
SetLocation (inherited from Control) | Called to set control's location
SetScrollbarWidth | Sets the scroll bar width of this control
SetSize (inherited from Control) | Called to set control's size
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

ContentsChanged
DoubleClick
Selection

Protected Instance Fields

border
boundingBox (inherited from Control)
controlId (inherited from Control)
controlType (inherited from Control)
controlX (inherited from Control)
controlY (inherited from Control)
elementList (inherited from Control)
enabled (inherited from Control)
hasFocus (inherited from Control)
height (inherited from Control)
hotKey (inherited from Control)
isDragging
isMouseOver (inherited from Control)
itemList
localUserData (inherited from Control)
margin
parentDialog (inherited from Control)
scrollbarControl
scrollWidth
selectedIndex
selectedStarted
selectionRect
style
textHeight
textRect
visible (inherited from Control)
width (inherited from Control)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseContentsChangedEvent | Raises the contents changed event
RaiseDoubleClickEvent | Raises the double click event
RaiseSelectionEvent | Raises the selection event
UpdateRectangles | Update the rectangles for the list box control

See Also

ListBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBox Constructor

Create a new list box control

public ListBox(
Dialog parent
);

See Also

ListBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBox Fields

The fields of the ListBox class are listed below. For a complete list of ListBox class members, see the ListBox Members topic.

Public Static Fields

MainLayer
SelectionLayer

Public Instance Fields

index (inherited from Control)
isDefault (inherited from Control)

Protected Instance Fields

border
boundingBox (inherited from Control)
controlId (inherited from Control)
controlType (inherited from Control)
controlX (inherited from Control)
controlY (inherited from Control)
elementList (inherited from Control)
enabled (inherited from Control)
hasFocus (inherited from Control)
height (inherited from Control)
hotKey (inherited from Control)
isDragging
isMouseOver (inherited from Control)
itemList
localUserData (inherited from Control)
margin
parentDialog (inherited from Control)
scrollbarControl
scrollWidth
selectedIndex
selectedStarted
selectionRect
style
textHeight
textRect
visible (inherited from Control)
width (inherited from Control)

See Also

ListBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBox.border Field

protected int border;

See Also

ListBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBox.isDragging Field

protected bool isDragging;

See Also

ListBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBox.itemList Field

protected ArrayList itemList;

See Also

ListBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBox.MainLayer Field

public const int MainLayer = 0;

See Also

ListBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBox.margin Field

protected int margin;

See Also

ListBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBox.scrollbarControl Field

protected ScrollBar scrollbarControl;

See Also

ListBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBox.scrollWidth Field

protected int scrollWidth;

See Also

ListBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBox.selectedIndex Field

protected int selectedIndex;

See Also

ListBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBox.selectedStarted Field

protected int selectedStarted;

See Also

ListBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBox.SelectionLayer Field

public const int SelectionLayer = 1;

See Also

ListBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBox.selectionRect Field

protected Rectangle selectionRect;

See Also

ListBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Style Property

Goblin - A Platform for 3D AR and VR Applications

ListBox.Style Property

Sets the style of the listbox

public ListBoxStyle Style {get; set;}

See Also

ListBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBox.textHeight Field

protected int textHeight;

See Also

ListBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBox.textRect Field

protected Rectangle textRect;

See Also

ListBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBox Properties

The properties of the ListBox class are listed below. For a complete list of ListBox class members, see the ListBox Members topic.

Public Instance Properties

CanHaveFocus | Can this control have focus
ControlType (inherited from Control) | Type of the control
Hotkey (inherited from Control) | The controls hotkey
ID (inherited from Control) | Unique ID of the control
IsEnabled (inherited from Control) | Is the control enabled
IsVisible (inherited from Control) | Is the control visible
Item | Overloaded. Indexer for items in the list
NumberItems | Number of items current in the list
Parent (inherited from Control) | The parent dialog of this control
Style | Sets the style of the listbox
UserData (inherited from Control) | User specified data

See Also

ListBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


CanHaveFocus Property

Goblin - A Platform for 3D AR and VR Applications

ListBox.CanHaveFocus Property

Can this control have focus

public override bool CanHaveFocus {get;}

See Also

ListBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Item Property

Goblin - A Platform for 3D AR and VR Applications

ListBox.Item Property

Indexer for items in the list

public ListBoxItem this[
int index
] {get;}

See Also

ListBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NumberItems Property

Goblin - A Platform for 3D AR and VR Applications

ListBox.NumberItems Property

Number of items current in the list

public int NumberItems {get;}

See Also

ListBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBox Methods

The methods of the ListBox class are listed below. For a complete list of ListBox class members, see the ListBox Members topic.

Public Instance Methods

AddItem | Adds an item to the list box control
Clear | Removes all items from the control
ContainsPoint (inherited from Control) | Does the control contain this point
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetSelectedIndex | For single-selection listbox, returns the index of the selected item. For multi-selection, returns the first selected item after the previousSelected position. To search for the first selected item, the app passes -1 for previousSelected. For subsequent searches, the app passes the returned index back to GetSelectedIndex as. previousSelected. Returns -1 on error or if no item is selected.
GetSelectedItem | Overloaded. Gets the selected item
GetType (inherited from Object) | Gets the Type of the current instance.
HandleKeyboard | Called when the control needs to handle the keyboard
HandleMouse | Called when the control should handle the mouse
InsertItem | Inserts an item to the list box control
MsgProc (inherited from Control) | Message Handler
OnFocusIn (inherited from Control) | Called when control gets focus
OnFocusOut (inherited from Control) | Called when control loses focus
OnHotKey (inherited from Control) | Called when the control's hotkey is hit
OnInitialize | Initialize the scrollbar control here
OnMouseEnter (inherited from Control) | Called when mouse goes over the control
OnMouseExit (inherited from Control) | Called when mouse leaves the control
Refresh (inherited from Control) | Refreshes the control
RemoveAt | Removes an item at a particular index
Render | Called when the control should be rendered
SelectItem | Selects this item
SetBorder | Sets the border and margin sizes
SetLocation (inherited from Control) | Called to set control's location
SetScrollbarWidth | Sets the scroll bar width of this control
SetSize (inherited from Control) | Called to set control's size
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseContentsChangedEvent | Raises the contents changed event
RaiseDoubleClickEvent | Raises the double click event
RaiseSelectionEvent | Raises the selection event
UpdateRectangles | Update the rectangles for the list box control

See Also

ListBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBox.AddItem Method

Adds an item to the list box control

public void AddItem(
string text,
object data
);

See Also

ListBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBox.Clear Method

Removes all items from the control

public void Clear();

See Also

ListBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBox.GetSelectedIndex Method

For single-selection listbox, returns the index of the selected item. For multi-selection, returns the first selected item after the previousSelected position. To search for the first selected item, the app passes -1 for previousSelected. For subsequent searches, the app passes the returned index back to GetSelectedIndex as. previousSelected. Returns -1 on error or if no item is selected.

public int GetSelectedIndex(
int previousSelected
);

See Also

ListBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


GetSelectedItem Method

Goblin - A Platform for 3D AR and VR Applications

ListBox.GetSelectedItem Method

Gets the selected item

Overload List

Gets the selected item

public ListBoxItem GetSelectedItem();

Gets the selected item

public ListBoxItem GetSelectedItem(int);

See Also

ListBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBox.GetSelectedItem Method ()

Gets the selected item

public ListBoxItem GetSelectedItem();

See Also

ListBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | ListBox.GetSelectedItem Overload List


ListBox.GetSelectedItem Method (Int32)

Gets the selected item

public ListBoxItem GetSelectedItem(
int previousSelected
);

See Also

ListBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | ListBox.GetSelectedItem Overload List


ListBox.HandleKeyboard Method

Called when the control needs to handle the keyboard

public override bool HandleKeyboard(
WindowMessage msg,
IntPtr wParam,
IntPtr lParam
);

See Also

ListBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBox.HandleMouse Method

Called when the control should handle the mouse

public override bool HandleMouse(
WindowMessage msg,
Point pt,
IntPtr wParam,
IntPtr lParam
);

See Also

ListBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBox.InsertItem Method

Inserts an item to the list box control

public void InsertItem(
int index,
string text,
object data
);

See Also

ListBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBox.OnInitialize Method

Initialize the scrollbar control here

public override void OnInitialize();

See Also

ListBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBox.RaiseContentsChangedEvent Method

Raises the contents changed event

protected void RaiseContentsChangedEvent(
ListBox sender,
bool wasTriggeredByUser
);

See Also

ListBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBox.RaiseDoubleClickEvent Method

Raises the double click event

protected void RaiseDoubleClickEvent(
ListBox sender,
bool wasTriggeredByUser
);

See Also

ListBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBox.RaiseSelectionEvent Method

Raises the selection event

protected void RaiseSelectionEvent(
ListBox sender,
bool wasTriggeredByUser
);

See Also

ListBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBox.RemoveAt Method

Removes an item at a particular index

public void RemoveAt(
int index
);

See Also

ListBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBox.Render Method

Called when the control should be rendered

public override void Render(
Device device,
float elapsedTime
);

See Also

ListBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBox.SelectItem Method

Selects this item

public void SelectItem(
int newIndex
);

See Also

ListBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBox.SetBorder Method

Sets the border and margin sizes

public void SetBorder(
int borderSize,
int marginSize
);

See Also

ListBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBox.SetScrollbarWidth Method

Sets the scroll bar width of this control

public void SetScrollbarWidth(
int width
);

See Also

ListBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBox.UpdateRectangles Method

Update the rectangles for the list box control

protected override void UpdateRectangles();

See Also

ListBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBox Events

The events of the ListBox class are listed below. For a complete list of ListBox class members, see the ListBox Members topic.

Public Instance Events

ContentsChanged
DoubleClick
Selection

See Also

ListBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBox.ContentsChanged Event

public event EventHandler ContentsChanged;

See Also

ListBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBox.DoubleClick Event

public event EventHandler DoubleClick;

See Also

ListBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBox.Selection Event

public event EventHandler Selection;

See Also

ListBox Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBoxItem Structure

Stores data for a list box item

For a list of all members of this type, see ListBoxItem Members.

System.Object
System.ValueType
Microsoft.Samples.DirectX.UtilityToolkit.ListBoxItem

public struct ListBoxItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

ListBoxItem Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBoxItem Members

ListBoxItem overview

Public Instance Fields

IsItemSelected
ItemData
ItemRect
ItemText

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

ListBoxItem Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBoxItem Fields

The fields of the ListBoxItem structure are listed below. For a complete list of ListBoxItem structure members, see the ListBoxItem Members topic.

Public Instance Fields

IsItemSelected
ItemData
ItemRect
ItemText

See Also

ListBoxItem Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBoxItem.IsItemSelected Field

public bool IsItemSelected;

See Also

ListBoxItem Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBoxItem.ItemData Field

public object ItemData;

See Also

ListBoxItem Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBoxItem.ItemRect Field

public Rectangle ItemRect;

See Also

ListBoxItem Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBoxItem.ItemText Field

public string ItemText;

See Also

ListBoxItem Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ListBoxStyle Enumeration

Style of the list box

public enum ListBoxStyle

Members

Member Name | Description
SingleSelection |
Multiselection |

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

Microsoft.Samples.DirectX.UtilityToolkit Namespace


MatchOptions Structure

Options on how to match items

For a list of all members of this type, see MatchOptions Members.

System.Object
System.ValueType
Microsoft.Samples.DirectX.UtilityToolkit.MatchOptions

public struct MatchOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

MatchOptions Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


MatchOptions Members

MatchOptions overview

Public Instance Fields

AdapterFormat
AdapterOrdinal
BackBufferCount
BackBufferFormat
DepthFormat
DeviceType
MultiSample
PresentFlags
PresentInterval
RefreshRate
Resolution
StencilFormat
SwapEffect
VertexProcessing
Windowed

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

MatchOptions Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


MatchOptions Fields

The fields of the MatchOptions structure are listed below. For a complete list of MatchOptions structure members, see the MatchOptions Members topic.

Public Instance Fields

AdapterFormat
AdapterOrdinal
BackBufferCount
BackBufferFormat
DepthFormat
DeviceType
MultiSample
PresentFlags
PresentInterval
RefreshRate
Resolution
StencilFormat
SwapEffect
VertexProcessing
Windowed

See Also

MatchOptions Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


MatchOptions.AdapterFormat Field

public MatchType AdapterFormat;

See Also

MatchOptions Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


MatchOptions.AdapterOrdinal Field

public MatchType AdapterOrdinal;

See Also

MatchOptions Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


MatchOptions.BackBufferCount Field

public MatchType BackBufferCount;

See Also

MatchOptions Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


MatchOptions.BackBufferFormat Field

public MatchType BackBufferFormat;

See Also

MatchOptions Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


MatchOptions.DepthFormat Field

public MatchType DepthFormat;

See Also

MatchOptions Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


MatchOptions.DeviceType Field

public MatchType DeviceType;

See Also

MatchOptions Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


MatchOptions.MultiSample Field

public MatchType MultiSample;

See Also

MatchOptions Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


MatchOptions.PresentFlags Field

public MatchType PresentFlags;

See Also

MatchOptions Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


MatchOptions.PresentInterval Field

public MatchType PresentInterval;

See Also

MatchOptions Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


MatchOptions.RefreshRate Field

public MatchType RefreshRate;

See Also

MatchOptions Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


MatchOptions.Resolution Field

public MatchType Resolution;

See Also

MatchOptions Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


MatchOptions.StencilFormat Field

public MatchType StencilFormat;

See Also

MatchOptions Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


MatchOptions.SwapEffect Field

public MatchType SwapEffect;

See Also

MatchOptions Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


MatchOptions.VertexProcessing Field

public MatchType VertexProcessing;

See Also

MatchOptions Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


MatchOptions.Windowed Field

public MatchType Windowed;

See Also

MatchOptions Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


MatchType Enumeration

Used when finding valid device settings

public enum MatchType

Members

Member Name | Description
IgnoreInput |
PreserveInput |
ClosestToInput |

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

Microsoft.Samples.DirectX.UtilityToolkit Namespace


MediaNotFoundException Class

Media couldn't be found

For a list of all members of this type, see MediaNotFoundException Members.

System.Object
System.Exception
System.ApplicationException
Microsoft.Samples.DirectX.UtilityToolkit.DirectXSampleException
Microsoft.Samples.DirectX.UtilityToolkit.MediaNotFoundException

public class MediaNotFoundException : DirectXSampleException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

MediaNotFoundException Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


MediaNotFoundException Members

MediaNotFoundException overview

Public Instance Constructors

MediaNotFoundException Overloaded. Initializes a new instance of the MediaNotFoundException class.

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MediaNotFoundException Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


MediaNotFoundException Constructor

Initializes a new instance of the MediaNotFoundException class.

Overload List

Initializes a new instance of the MediaNotFoundException class.

public MediaNotFoundException();

public MediaNotFoundException(Exception);

See Also

MediaNotFoundException Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


MediaNotFoundException Constructor ()

Initializes a new instance of the MediaNotFoundException class.

public MediaNotFoundException();

See Also

MediaNotFoundException Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | MediaNotFoundException Constructor Overload List


MediaNotFoundException Constructor (Exception)

public MediaNotFoundException(
Exception inner
);

See Also

MediaNotFoundException Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | MediaNotFoundException Constructor Overload List


ModelViewerCamera Class

Simple model viewing camera class that rotates around the object.

For a list of all members of this type, see ModelViewerCamera Members.

System.Object
Microsoft.Samples.DirectX.UtilityToolkit.Camera
Microsoft.Samples.DirectX.UtilityToolkit.ModelViewerCamera

public class ModelViewerCamera : Camera

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

ModelViewerCamera Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ModelViewerCamera Members

ModelViewerCamera overview

Public Instance Constructors

ModelViewerCamera Constructor Creates new instance of the model viewer camera

Public Instance Properties

EyeLocation (inherited from Camera) | Returns the location of the eye
IsAttachedToModel | Is the camera attached to a model
IsBeingDragged (inherited from Camera) | Is the camera being 'dragged' at all?
IsMouseLeftButtonDown (inherited from Camera) | Is the left mouse button down
IsMouseMiddleButtonDown (inherited from Camera) | Is the middle mouse button down
IsMouseRightButtonDown (inherited from Camera) | Is the right mouse button down
IsPositionMovementEnabled (inherited from Camera) | Is position movement enabled
LookAtPoint (inherited from Camera) | Returns the look at point of the camera
MaximumRadius | The maximum radius
MinimumRadius | The minimum radius
ProjectionMatrix (inherited from Camera) | Returns the projection transformation matrix
ViewMatrix (inherited from Camera) | Returns the view transformation matrix
WorldMatrix | Gets the world matrix

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FrameMove |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HandleMessages | Call this from your message proc so this class can handle window messages
Reset | Reset the camera's position back to the default
SetButtonMasks | Sets button masks
SetIsPitchLimited | Sets whether the pitch is limited or not
SetModelCenter | Sets the model's center
SetProjectionParameters (inherited from Camera) | Calculates the projection matrix based on input params
SetRadius | Overloaded. Sets radius
SetViewParameters | Override for setting the view parameters
SetViewQuat | Sets the view quat
SetWindow | Overloaded. Sets arcball window
SetWorldQuat | Sets the world quat
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

aspectRatio (inherited from Camera)
attachCameraToModel
cameraPitchAngle (inherited from Camera)
cameraYawAngle (inherited from Camera)
currentButtonMask (inherited from Camera)
defaultEye (inherited from Camera)
defaultLookAt (inherited from Camera)
defaultRadius
dragRectangle (inherited from Camera)
dragTimer (inherited from Camera)
eye (inherited from Camera)
farPlane (inherited from Camera)
fieldOfView (inherited from Camera)
framesToSmoothMouseData (inherited from Camera)
isClipToBoundary (inherited from Camera)
isEnablePositionMovement (inherited from Camera)
isEnableYAxisMovement (inherited from Camera)
isInvertPitch (inherited from Camera)
isMouseLButtonDown (inherited from Camera)
isMouseMButtonDown (inherited from Camera)
isMouseRButtonDown (inherited from Camera)
isMovementDrag (inherited from Camera)
isPitchLimited
isResetCursorAfterMove (inherited from Camera)
keys (inherited from Camera)
lastCameraRotation
lastModelRotation
lastMousePosition (inherited from Camera)
lookAt (inherited from Camera)
maxBoundary (inherited from Camera)
maxRadius
minBoundary (inherited from Camera)
minRadius
modelCenter
modelRotation
mouseDelta (inherited from Camera)
mouseWheelDelta (inherited from Camera)
moveScaler (inherited from Camera)
nearPlane (inherited from Camera)
projMatrix (inherited from Camera)
radius
rotateCameraButtonMask
rotateModelButtonMask
rotationScaler (inherited from Camera)
rotationVelocity (inherited from Camera)
totalDragTimeToZero (inherited from Camera)
velocity (inherited from Camera)
velocityDrag (inherited from Camera)
viewArcball
viewMatrix (inherited from Camera)
world
worldArcball
zoomButtonMask

Protected Instance Methods

ConstrainToBoundary (inherited from Camera) | Clamps V to lie inside boundaries
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
UpdateMouseDelta (inherited from Camera) | Figure out the mouse delta based on mouse movement
UpdateVelocity (inherited from Camera) |

See Also

ModelViewerCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ModelViewerCamera Constructor

Creates new instance of the model viewer camera

public ModelViewerCamera();

See Also

ModelViewerCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ModelViewerCamera Fields

The fields of the ModelViewerCamera class are listed below. For a complete list of ModelViewerCamera class members, see the ModelViewerCamera Members topic.

Protected Instance Fields

aspectRatio (inherited from Camera)
attachCameraToModel
cameraPitchAngle (inherited from Camera)
cameraYawAngle (inherited from Camera)
currentButtonMask (inherited from Camera)
defaultEye (inherited from Camera)
defaultLookAt (inherited from Camera)
defaultRadius
dragRectangle (inherited from Camera)
dragTimer (inherited from Camera)
eye (inherited from Camera)
farPlane (inherited from Camera)
fieldOfView (inherited from Camera)
framesToSmoothMouseData (inherited from Camera)
isClipToBoundary (inherited from Camera)
isEnablePositionMovement (inherited from Camera)
isEnableYAxisMovement (inherited from Camera)
isInvertPitch (inherited from Camera)
isMouseLButtonDown (inherited from Camera)
isMouseMButtonDown (inherited from Camera)
isMouseRButtonDown (inherited from Camera)
isMovementDrag (inherited from Camera)
isPitchLimited
isResetCursorAfterMove (inherited from Camera)
keys (inherited from Camera)
lastCameraRotation
lastModelRotation
lastMousePosition (inherited from Camera)
lookAt (inherited from Camera)
maxBoundary (inherited from Camera)
maxRadius
minBoundary (inherited from Camera)
minRadius
modelCenter
modelRotation
mouseDelta (inherited from Camera)
mouseWheelDelta (inherited from Camera)
moveScaler (inherited from Camera)
nearPlane (inherited from Camera)
projMatrix (inherited from Camera)
radius
rotateCameraButtonMask
rotateModelButtonMask
rotationScaler (inherited from Camera)
rotationVelocity (inherited from Camera)
totalDragTimeToZero (inherited from Camera)
velocity (inherited from Camera)
velocityDrag (inherited from Camera)
viewArcball
viewMatrix (inherited from Camera)
world
worldArcball
zoomButtonMask

See Also

ModelViewerCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ModelViewerCamera.attachCameraToModel Field

protected bool attachCameraToModel;

See Also

ModelViewerCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ModelViewerCamera.defaultRadius Field

protected float defaultRadius;

See Also

ModelViewerCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ModelViewerCamera.isPitchLimited Field

protected bool isPitchLimited;

See Also

ModelViewerCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ModelViewerCamera.lastCameraRotation Field

protected Matrix lastCameraRotation;

See Also

ModelViewerCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ModelViewerCamera.lastModelRotation Field

protected Matrix lastModelRotation;

See Also

ModelViewerCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ModelViewerCamera.maxRadius Field

protected float maxRadius;

See Also

ModelViewerCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ModelViewerCamera.minRadius Field

protected float minRadius;

See Also

ModelViewerCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ModelViewerCamera.modelCenter Field

protected Vector3 modelCenter;

See Also

ModelViewerCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ModelViewerCamera.modelRotation Field

protected Matrix modelRotation;

See Also

ModelViewerCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ModelViewerCamera.radius Field

protected float radius;

See Also

ModelViewerCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ModelViewerCamera.rotateCameraButtonMask Field

protected int rotateCameraButtonMask;

See Also

ModelViewerCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ModelViewerCamera.rotateModelButtonMask Field

protected int rotateModelButtonMask;

See Also

ModelViewerCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ModelViewerCamera.viewArcball Field

protected ArcBall viewArcball;

See Also

ModelViewerCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ModelViewerCamera.world Field

protected Matrix world;

See Also

ModelViewerCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ModelViewerCamera.worldArcball Field

protected ArcBall worldArcball;

See Also

ModelViewerCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ModelViewerCamera.zoomButtonMask Field

protected int zoomButtonMask;

See Also

ModelViewerCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ModelViewerCamera Properties

The properties of the ModelViewerCamera class are listed below. For a complete list of ModelViewerCamera class members, see the ModelViewerCamera Members topic.

Public Instance Properties

EyeLocation (inherited from Camera) | Returns the location of the eye
IsAttachedToModel | Is the camera attached to a model
IsBeingDragged (inherited from Camera) | Is the camera being 'dragged' at all?
IsMouseLeftButtonDown (inherited from Camera) | Is the left mouse button down
IsMouseMiddleButtonDown (inherited from Camera) | Is the middle mouse button down
IsMouseRightButtonDown (inherited from Camera) | Is the right mouse button down
IsPositionMovementEnabled (inherited from Camera) | Is position movement enabled
LookAtPoint (inherited from Camera) | Returns the look at point of the camera
MaximumRadius | The maximum radius
MinimumRadius | The minimum radius
ProjectionMatrix (inherited from Camera) | Returns the projection transformation matrix
ViewMatrix (inherited from Camera) | Returns the view transformation matrix
WorldMatrix | Gets the world matrix

See Also

ModelViewerCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


IsAttachedToModel Property

Goblin - A Platform for 3D AR and VR Applications

ModelViewerCamera.IsAttachedToModel Property

Is the camera attached to a model

public bool IsAttachedToModel {get; set;}

See Also

ModelViewerCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


MaximumRadius Property

Goblin - A Platform for 3D AR and VR Applications

ModelViewerCamera.MaximumRadius Property

The maximum radius

public float MaximumRadius {get; set;}

See Also

ModelViewerCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


MinimumRadius Property

Goblin - A Platform for 3D AR and VR Applications

ModelViewerCamera.MinimumRadius Property

The minimum radius

public float MinimumRadius {get; set;}

See Also

ModelViewerCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


WorldMatrix Property

Goblin - A Platform for 3D AR and VR Applications

ModelViewerCamera.WorldMatrix Property

Gets the world matrix

public Microsoft.DirectX.Matrix WorldMatrix {get;}

See Also

ModelViewerCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ModelViewerCamera Methods

The methods of the ModelViewerCamera class are listed below. For a complete list of ModelViewerCamera class members, see the ModelViewerCamera Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FrameMove |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HandleMessages | Call this from your message proc so this class can handle window messages
Reset | Reset the camera's position back to the default
SetButtonMasks | Sets button masks
SetIsPitchLimited | Sets whether the pitch is limited or not
SetModelCenter | Sets the model's center
SetProjectionParameters (inherited from Camera) | Calculates the projection matrix based on input params
SetRadius | Overloaded. Sets radius
SetViewParameters | Override for setting the view parameters
SetViewQuat | Sets the view quat
SetWindow | Overloaded. Sets arcball window
SetWorldQuat | Sets the world quat
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

ConstrainToBoundary (inherited from Camera) | Clamps V to lie inside boundaries
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
UpdateMouseDelta (inherited from Camera) | Figure out the mouse delta based on mouse movement
UpdateVelocity (inherited from Camera) |

See Also

ModelViewerCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ModelViewerCamera.FrameMove Method

public override void FrameMove(
float elapsedTime
);

See Also

ModelViewerCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ModelViewerCamera.HandleMessages Method

Call this from your message proc so this class can handle window messages

public override bool HandleMessages(
IntPtr hWnd,
WindowMessage msg,
IntPtr wParam,
IntPtr lParam
);

See Also

ModelViewerCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ModelViewerCamera.Reset Method

Reset the camera's position back to the default

public override void Reset();

See Also

ModelViewerCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ModelViewerCamera.SetButtonMasks Method

Sets button masks

public void SetButtonMasks(
int rotateModel,
int zoom,
int rotateCamera
);

See Also

ModelViewerCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ModelViewerCamera.SetIsPitchLimited Method

Sets whether the pitch is limited or not

public void SetIsPitchLimited(
bool limit
);

See Also

ModelViewerCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ModelViewerCamera.SetModelCenter Method

Sets the model's center

public void SetModelCenter(
Vector3 c
);

See Also

ModelViewerCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


SetRadius Method

Goblin - A Platform for 3D AR and VR Applications

ModelViewerCamera.SetRadius Method

Sets radius

Overload List

Sets radius

public void SetRadius(float);

Sets radius

public void SetRadius(float,float,float);

See Also

ModelViewerCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ModelViewerCamera.SetRadius Method (Single)

Sets radius

public void SetRadius(
float r
);

See Also

ModelViewerCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | ModelViewerCamera.SetRadius Overload List


ModelViewerCamera.SetRadius Method (Single, Single, Single)

Sets radius

public void SetRadius(
float r,
float min,
float max
);

See Also

ModelViewerCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | ModelViewerCamera.SetRadius Overload List


ModelViewerCamera.SetViewParameters Method

Override for setting the view parameters

public override void SetViewParameters(
Vector3 eyePt,
Vector3 lookAtPt
);

See Also

ModelViewerCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ModelViewerCamera.SetViewQuat Method

Sets the view quat

public void SetViewQuat(
Quaternion q
);

See Also

ModelViewerCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


SetWindow Method

Goblin - A Platform for 3D AR and VR Applications

ModelViewerCamera.SetWindow Method

Sets arcball window

Overload List

Sets arcball window

public void SetWindow(int,int);

Sets arcball window

public void SetWindow(int,int,float);

See Also

ModelViewerCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ModelViewerCamera.SetWindow Method (Int32, Int32)

Sets arcball window

public void SetWindow(
int w,
int h
);

See Also

ModelViewerCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | ModelViewerCamera.SetWindow Overload List


ModelViewerCamera.SetWindow Method (Int32, Int32, Single)

Sets arcball window

public void SetWindow(
int w,
int h,
float r
);

See Also

ModelViewerCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | ModelViewerCamera.SetWindow Overload List


ModelViewerCamera.SetWorldQuat Method

Sets the world quat

public void SetWorldQuat(
Quaternion q
);

See Also

ModelViewerCamera Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


MouseButtonMask Enumeration

Mouse button mask values

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum MouseButtonMask

Members

Member Name | Description | Value
None |  | 0
Left |  | 1
Middle |  | 2
Right |  | 4
Wheel |  | 8

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

Microsoft.Samples.DirectX.UtilityToolkit Namespace


MouseCallback Delegate

public delegate void MouseCallback(
bool leftButtonDown,
bool rightButtonDown,
bool middleButtonDown,
bool sideButton1Down,
bool sideButton2Down,
int mouseWheelDelta,
int x,
int y
);

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods Class

Will hold native methods which are interop'd

For a list of all members of this type, see NativeMethods Members.

System.Object
Microsoft.Samples.DirectX.UtilityToolkit.NativeMethods

public class NativeMethods

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

NativeMethods Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods Members

NativeMethods overview

Public Static Methods

AdjustWindowRect |
CreateWindow |
DefWindowProc |
DestroyWindow |
DispatchMessage |
GetAsyncKeyState |
GetCaretBlinkTime |
GetClientRect |
GetMonitorInfo |
GetParent |
GetStyle | Get new window style
GetWindowRect |
HiWord | Returns the high word
HookWindowsMessages | Hooks window messages to go through this new callback
IsIconic |
IsKeyDown | Is this key down right now
LoWord | Returns the low word
MakeUInt32 | Makes two shorts into a long
MonitorFromWindow |
PeekMessage |
PostQuitMessage |
QueryPerformanceCounter |
QueryPerformanceFrequency |
RegisterClass |
ReleaseCapture |
ScreenToClient |
SendMessage |
SetCapture |
SetFocus |
SetMenu |
SetStyle | Set new window style
SetWindowPos |
ShowWindow |
timeBeginPeriod |
TranslateMessage |
UnregisterClass |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NativeMethods Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods Methods

The methods of the NativeMethods class are listed below. For a complete list of NativeMethods class members, see the NativeMethods Members topic.

Public Static Methods

AdjustWindowRect |
CreateWindow |
DefWindowProc |
DestroyWindow |
DispatchMessage |
GetAsyncKeyState |
GetCaretBlinkTime |
GetClientRect |
GetMonitorInfo |
GetParent |
GetStyle | Get new window style
GetWindowRect |
HiWord | Returns the high word
HookWindowsMessages | Hooks window messages to go through this new callback
IsIconic |
IsKeyDown | Is this key down right now
LoWord | Returns the low word
MakeUInt32 | Makes two shorts into a long
MonitorFromWindow |
PeekMessage |
PostQuitMessage |
QueryPerformanceCounter |
QueryPerformanceFrequency |
RegisterClass |
ReleaseCapture |
ScreenToClient |
SendMessage |
SetCapture |
SetFocus |
SetMenu |
SetStyle | Set new window style
SetWindowPos |
ShowWindow |
timeBeginPeriod |
TranslateMessage |
UnregisterClass |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NativeMethods Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.AdjustWindowRect Method

public static bool AdjustWindowRect(
ref Rectangle rect,
WindowStyles style,
bool menu
);

See Also

NativeMethods Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.CreateWindow Method

public static IntPtr CreateWindow(
int exStyle,
string className,
string windowName,
WindowStyles style,
int x,
int y,
int width,
int height,
IntPtr parent,
IntPtr menuHandle,
IntPtr instanceHandle,
IntPtr zero
);

See Also

NativeMethods Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.DefWindowProc Method

public static IntPtr DefWindowProc(
IntPtr hWnd,
WindowMessage msg,
IntPtr wParam,
IntPtr lParam
);

See Also

NativeMethods Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.DestroyWindow Method

public static bool DestroyWindow(
IntPtr hWnd
);

See Also

NativeMethods Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.DispatchMessage Method

public static bool DispatchMessage(
ref Message msg
);

See Also

NativeMethods Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.GetAsyncKeyState Method

public static short GetAsyncKeyState(
uint key
);

See Also

NativeMethods Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.GetCaretBlinkTime Method

public static int GetCaretBlinkTime();

See Also

NativeMethods Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.GetClientRect Method

public static bool GetClientRect(
IntPtr hWnd,
out Rectangle rect
);

See Also

NativeMethods Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.GetMonitorInfo Method

public static bool GetMonitorInfo(
IntPtr hWnd,
ref MonitorInformation info
);

See Also

NativeMethods Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.GetParent Method

public static IntPtr GetParent(
IntPtr hWnd
);

See Also

NativeMethods Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.GetStyle Method

Get new window style

public static WindowStyles GetStyle(
IntPtr window
);

See Also

NativeMethods Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.GetWindowRect Method

public static bool GetWindowRect(
IntPtr hWnd,
out Rectangle rect
);

See Also

NativeMethods Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.HiWord Method

Returns the high word

public static short HiWord(
uint l
);

See Also

NativeMethods Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.HookWindowsMessages Method

Hooks window messages to go through this new callback

public static void HookWindowsMessages(
IntPtr window,
WndProcDelegate callback
);

See Also

NativeMethods Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.IsIconic Method

public static bool IsIconic(
IntPtr hWnd
);

See Also

NativeMethods Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.IsKeyDown Method

Is this key down right now

public static bool IsKeyDown(
Keys key
);

See Also

NativeMethods Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.LoWord Method

Returns the low word

public static short LoWord(
uint l
);

See Also

NativeMethods Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.MakeUInt32 Method

Makes two shorts into a long

public static uint MakeUInt32(
short l,
short r
);

See Also

NativeMethods Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.MonitorFromWindow Method

public static IntPtr MonitorFromWindow(
IntPtr hWnd,
uint flags
);

See Also

NativeMethods Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.PeekMessage Method

public static bool PeekMessage(
out Message msg,
IntPtr hWnd,
uint messageFilterMin,
uint messageFilterMax,
PeekMessageFlags flags
);

See Also

NativeMethods Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.PostQuitMessage Method

public static void PostQuitMessage(
int exitCode
);

See Also

NativeMethods Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.QueryPerformanceCounter Method

public static bool QueryPerformanceCounter(
ref long PerformanceCount
);

See Also

NativeMethods Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.QueryPerformanceFrequency Method

public static bool QueryPerformanceFrequency(
ref long PerformanceFrequency
);

See Also

NativeMethods Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.RegisterClass Method

public static IntPtr RegisterClass(
ref WindowClass wndClass
);

See Also

NativeMethods Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.ReleaseCapture Method

public static bool ReleaseCapture();

See Also

NativeMethods Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.ScreenToClient Method

public static bool ScreenToClient(
IntPtr hWnd,
ref Point rect
);

See Also

NativeMethods Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.SendMessage Method

public static IntPtr SendMessage(
IntPtr windowHandle,
WindowMessage msg,
IntPtr w,
IntPtr l
);

See Also

NativeMethods Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.SetCapture Method

public static IntPtr SetCapture(
IntPtr handle
);

See Also

NativeMethods Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.SetFocus Method

public static IntPtr SetFocus(
IntPtr hWnd
);

See Also

NativeMethods Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.SetMenu Method

public static bool SetMenu(
IntPtr hWnd,
IntPtr menuHandle
);

See Also

NativeMethods Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.SetStyle Method

Set new window style

public static void SetStyle(
IntPtr window,
WindowStyles newStyle
);

See Also

NativeMethods Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.SetWindowPos Method

public static bool SetWindowPos(
IntPtr hWnd,
IntPtr hWndAfter,
int x,
int y,
int w,
int h,
uint flags
);

See Also

NativeMethods Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.ShowWindow Method

public static bool ShowWindow(
IntPtr hWnd,
ShowWindowFlags flags
);

See Also

NativeMethods Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.timeBeginPeriod Method

public static IntPtr timeBeginPeriod(
uint period
);

See Also

NativeMethods Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.TranslateMessage Method

public static bool TranslateMessage(
ref Message msg
);

See Also

NativeMethods Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.UnregisterClass Method

public static bool UnregisterClass(
string className,
IntPtr instanceHandle
);

See Also

NativeMethods Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.Message Structure

Windows Message

For a list of all members of this type, see NativeMethods.Message Members.

System.Object
System.ValueType
Microsoft.Samples.DirectX.UtilityToolkit.NativeMethods.Message

public struct NativeMethods.Message

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

NativeMethods.Message Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.Message Members

NativeMethods.Message overview

Public Instance Fields

hWnd
lParam
msg
p
time
wParam

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

NativeMethods.Message Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.Message Fields

The fields of the NativeMethods.Message structure are listed below. For a complete list of NativeMethods.Message structure members, see the NativeMethods.Message Members topic.

Public Instance Fields

hWnd
lParam
msg
p
time
wParam

See Also

NativeMethods.Message Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.Message.hWnd Field

public IntPtr hWnd;

See Also

NativeMethods.Message Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.Message.lParam Field

public IntPtr lParam;

See Also

NativeMethods.Message Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.Message.msg Field

public WindowMessage msg;

See Also

NativeMethods.Message Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.Message.p Field

public Point p;

See Also

NativeMethods.Message Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.Message.time Field

public uint time;

See Also

NativeMethods.Message Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.Message.wParam Field

public IntPtr wParam;

See Also

NativeMethods.Message Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.MinMaxInformation Structure

MinMax Info structure

For a list of all members of this type, see NativeMethods.MinMaxInformation Members.

System.Object
System.ValueType
Microsoft.Samples.DirectX.UtilityToolkit.NativeMethods.MinMaxInformation

public struct NativeMethods.MinMaxInformation

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

NativeMethods.MinMaxInformation Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.MinMaxInformation Members

NativeMethods.MinMaxInformation overview

Public Instance Fields

MaxPosition
MaxSize
MaxTrackSize
MinTrackSize
reserved

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

NativeMethods.MinMaxInformation Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.MinMaxInformation Fields

The fields of the NativeMethods.MinMaxInformation structure are listed below. For a complete list of NativeMethods.MinMaxInformation structure members, see the NativeMethods.MinMaxInformation Members topic.

Public Instance Fields

MaxPosition
MaxSize
MaxTrackSize
MinTrackSize
reserved

See Also

NativeMethods.MinMaxInformation Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.MinMaxInformation.MaxPosition Field

public Point MaxPosition;

See Also

NativeMethods.MinMaxInformation Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.MinMaxInformation.MaxSize Field

public Point MaxSize;

See Also

NativeMethods.MinMaxInformation Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.MinMaxInformation.MaxTrackSize Field

public Point MaxTrackSize;

See Also

NativeMethods.MinMaxInformation Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.MinMaxInformation.MinTrackSize Field

public Point MinTrackSize;

See Also

NativeMethods.MinMaxInformation Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.MinMaxInformation.reserved Field

public Point reserved;

See Also

NativeMethods.MinMaxInformation Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.MonitorInformation Structure

Monitor Info structure

For a list of all members of this type, see NativeMethods.MonitorInformation Members.

System.Object
System.ValueType
Microsoft.Samples.DirectX.UtilityToolkit.NativeMethods.MonitorInformation

public struct NativeMethods.MonitorInformation

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

NativeMethods.MonitorInformation Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.MonitorInformation Members

NativeMethods.MonitorInformation overview

Public Instance Fields

Flags
MonitorRectangle
Size
WorkRectangle

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

NativeMethods.MonitorInformation Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.MonitorInformation Fields

The fields of the NativeMethods.MonitorInformation structure are listed below. For a complete list of NativeMethods.MonitorInformation structure members, see the NativeMethods.MonitorInformation Members topic.

Public Instance Fields

Flags
MonitorRectangle
Size
WorkRectangle

See Also

NativeMethods.MonitorInformation Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.MonitorInformation.Flags Field

public uint Flags;

See Also

NativeMethods.MonitorInformation Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.MonitorInformation.MonitorRectangle Field

public Rectangle MonitorRectangle;

See Also

NativeMethods.MonitorInformation Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.MonitorInformation.Size Field

public uint Size;

See Also

NativeMethods.MonitorInformation Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.MonitorInformation.WorkRectangle Field

public Rectangle WorkRectangle;

See Also

NativeMethods.MonitorInformation Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.MouseButtons Enumeration

Mouse buttons

public enum NativeMethods.MouseButtons

Members

Member Name | Description
Left |
Right |
Middle |
Side1 |
Side2 |

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.PeekMessageFlags Enumeration

Peek message flags

public enum NativeMethods.PeekMessageFlags

Members

Member Name | Description
NoRemove |
Remove |
NoYield |

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.ShowWindowFlags Enumeration

Show window flags styles

public enum NativeMethods.ShowWindowFlags

Members

Member Name | Description
Hide |
ShowNormal |
Normal |
ShowMinimized |
ShowMaximized |
ShowNoActivate |
Show |
Minimize |
ShowMinNoActivate |
ShowNotActivated |
Restore |
ShowDefault |
ForceMinimize |

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.WindowClass Structure

Window class structure

For a list of all members of this type, see NativeMethods.WindowClass Members.

System.Object
System.ValueType
Microsoft.Samples.DirectX.UtilityToolkit.NativeMethods.WindowClass

public struct NativeMethods.WindowClass

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

NativeMethods.WindowClass Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.WindowClass Members

NativeMethods.WindowClass overview

Public Instance Fields

backgroundBrush
ClassName
CursorHandle
IconHandle
InstanceHandle
MenuName
Styles
WindowsProc

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

NativeMethods.WindowClass Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.WindowClass Fields

The fields of the NativeMethods.WindowClass structure are listed below. For a complete list of NativeMethods.WindowClass structure members, see the NativeMethods.WindowClass Members topic.

Public Instance Fields

backgroundBrush
ClassName
CursorHandle
IconHandle
InstanceHandle
MenuName
Styles
WindowsProc

See Also

NativeMethods.WindowClass Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.WindowClass.backgroundBrush Field

public IntPtr backgroundBrush;

See Also

NativeMethods.WindowClass Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.WindowClass.ClassName Field

public string ClassName;

See Also

NativeMethods.WindowClass Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.WindowClass.CursorHandle Field

public IntPtr CursorHandle;

See Also

NativeMethods.WindowClass Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.WindowClass.IconHandle Field

public IntPtr IconHandle;

See Also

NativeMethods.WindowClass Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.WindowClass.InstanceHandle Field

public IntPtr InstanceHandle;

See Also

NativeMethods.WindowClass Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.WindowClass.MenuName Field

public string MenuName;

See Also

NativeMethods.WindowClass Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.WindowClass.Styles Field

public int Styles;

See Also

NativeMethods.WindowClass Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.WindowClass.WindowsProc Field

public WndProcDelegate WindowsProc;

See Also

NativeMethods.WindowClass Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.WindowMessage Enumeration

Window messages

public enum NativeMethods.WindowMessage

Members

Member Name | Description
Destroy |
Close |
Quit |
Paint |
SetCursor |
ActivateApplication |
EnterMenuLoop |
ExitMenuLoop |
NonClientHitTest |
PowerBroadcast |
SystemCommand |
GetMinMax |
KeyDown |
KeyUp |
Character |
SystemKeyDown |
SystemKeyUp |
SystemCharacter |
MouseMove |
LeftButtonDown |
LeftButtonUp |
LeftButtonDoubleClick |
RightButtonDown |
RightButtonUp |
RightButtonDoubleClick |
MiddleButtonDown |
MiddleButtonUp |
MiddleButtonDoubleClick |
MouseWheel |
XButtonDown |
XButtonUp |
XButtonDoubleClick |
MouseFirst |
MouseLast |
EnterSizeMove |
ExitSizeMove |
Size |

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.WindowStyles Enumeration

Window styles

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum NativeMethods.WindowStyles

Members

Member Name | Description | Value
Overlapped |  | 0
Popup |  | 2147483648
Child |  | 1073741824
Minimize |  | 536870912
Visible |  | 268435456
Disabled |  | 134217728
ClipSiblings |  | 67108864
ClipChildren |  | 33554432
Maximize |  | 16777216
Caption |  | 12582912
Border |  | 8388608
DialogFrame |  | 4194304
VerticalScroll |  | 2097152
HorizontalScroll |  | 1048576
SystemMenu |  | 524288
ThickFrame |  | 262144
Group |  | 131072
TabStop |  | 65536
MinimizeBox |  | 131072
MaximizeBox |  | 65536

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

Microsoft.Samples.DirectX.UtilityToolkit Namespace


NativeMethods.WndProcDelegate Delegate

public delegate IntPtr NativeMethods.WndProcDelegate(
IntPtr hWnd,
WindowMessage msg,
IntPtr wParam,
IntPtr lParam
);

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

Microsoft.Samples.DirectX.UtilityToolkit Namespace


NoCompatibleDevicesException Class

No compatible devices were found for this application.

For a list of all members of this type, see NoCompatibleDevicesException Members.

System.Object
System.Exception
System.ApplicationException
Microsoft.Samples.DirectX.UtilityToolkit.DirectXSampleException
Microsoft.Samples.DirectX.UtilityToolkit.NoCompatibleDevicesException

public class NoCompatibleDevicesException : DirectXSampleException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

NoCompatibleDevicesException Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NoCompatibleDevicesException Members

NoCompatibleDevicesException overview

Public Instance Constructors

NoCompatibleDevicesException Overloaded. Initializes a new instance of the NoCompatibleDevicesException class.

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NoCompatibleDevicesException Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NoCompatibleDevicesException Constructor

Initializes a new instance of the NoCompatibleDevicesException class.

Overload List

Initializes a new instance of the NoCompatibleDevicesException class.

public NoCompatibleDevicesException();

public NoCompatibleDevicesException(Exception);

See Also

NoCompatibleDevicesException Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NoCompatibleDevicesException Constructor ()

Initializes a new instance of the NoCompatibleDevicesException class.

public NoCompatibleDevicesException();

See Also

NoCompatibleDevicesException Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | NoCompatibleDevicesException Constructor Overload List


NoCompatibleDevicesException Constructor (Exception)

public NoCompatibleDevicesException(
Exception inner
);

See Also

NoCompatibleDevicesException Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | NoCompatibleDevicesException Constructor Overload List


NoDirect3DException Class

The No Direct3D exception. Something really had to go wrong for this to occur.

For a list of all members of this type, see NoDirect3DException Members.

System.Object
System.Exception
System.ApplicationException
Microsoft.Samples.DirectX.UtilityToolkit.DirectXSampleException
Microsoft.Samples.DirectX.UtilityToolkit.NoDirect3DException

public class NoDirect3DException : DirectXSampleException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

NoDirect3DException Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NoDirect3DException Members

NoDirect3DException overview

Public Instance Constructors

NoDirect3DException Overloaded. Initializes a new instance of the NoDirect3DException class.

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NoDirect3DException Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NoDirect3DException Constructor

Initializes a new instance of the NoDirect3DException class.

Overload List

Initializes a new instance of the NoDirect3DException class.

public NoDirect3DException();

public NoDirect3DException(Exception);

See Also

NoDirect3DException Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


NoDirect3DException Constructor ()

Initializes a new instance of the NoDirect3DException class.

public NoDirect3DException();

See Also

NoDirect3DException Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | NoDirect3DException Constructor Overload List


NoDirect3DException Constructor (Exception)

public NoDirect3DException(
Exception inner
);

See Also

NoDirect3DException Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | NoDirect3DException Constructor Overload List


RadioButton Class

Radio button control

For a list of all members of this type, see RadioButton Members.

System.Object
Microsoft.Samples.DirectX.UtilityToolkit.Control
Microsoft.Samples.DirectX.UtilityToolkit.StaticText
Microsoft.Samples.DirectX.UtilityToolkit.Button
Microsoft.Samples.DirectX.UtilityToolkit.Checkbox
Microsoft.Samples.DirectX.UtilityToolkit.RadioButton

public class RadioButton : Checkbox

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

RadioButton Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


RadioButton Members

RadioButton overview

Public Instance Constructors

RadioButton Constructor Create new radio button instance

Public Instance Fields

index (inherited from Control)
isDefault (inherited from Control)

Public Instance Properties

ButtonGroup | Button Group property
CanHaveFocus (inherited from Button) | Can the button have focus
ControlType (inherited from Control) | Type of the control
Hotkey (inherited from Control) | The controls hotkey
ID (inherited from Control) | Unique ID of the control
IsChecked (inherited from Checkbox) | Checked property
IsEnabled (inherited from Control) | Is the control enabled
IsVisible (inherited from Control) | Is the control visible
Item (inherited from Control) | Index for the elements this control has access to
Parent (inherited from Control) | The parent dialog of this control
UserData (inherited from Control) | User specified data

Public Instance Methods

ContainsPoint (inherited from Checkbox) | Does the control contain the point?
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetTextCopy (inherited from StaticText) | Return a copy of the string
GetType (inherited from Object) | Gets the Type of the current instance.
HandleKeyboard | Handle the keyboard for the checkbox
HandleMouse | Handle mouse messages from the radio button
MsgProc (inherited from Control) | Message Handler
OnFocusIn (inherited from Control) | Called when control gets focus
OnFocusOut (inherited from Control) | Called when control loses focus
OnHotKey | Override hotkey to fire event
OnInitialize (inherited from Control) | Initialize the control
OnMouseEnter (inherited from Control) | Called when mouse goes over the control
OnMouseExit (inherited from Control) | Called when mouse leaves the control
Refresh (inherited from Control) | Refreshes the control
Render (inherited from Checkbox) | Render the checkbox control
SetChecked | Sets the check state and potentially clears the group
SetLocation (inherited from Control) | Called to set control's location
SetSize (inherited from Control) | Called to set control's size
SetText (inherited from StaticText) | Sets the updated text for this control
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

Changed (inherited from Checkbox)
Click (inherited from Button)

Protected Instance Fields

boundingBox (inherited from Control)
buttonGroupIndex
buttonRect (inherited from Checkbox)
controlId (inherited from Control)
controlType (inherited from Control)
controlX (inherited from Control)
controlY (inherited from Control)
elementList (inherited from Control)
enabled (inherited from Control)
hasFocus (inherited from Control)
height (inherited from Control)
hotKey (inherited from Control)
isBoxChecked (inherited from Checkbox)
isMouseOver (inherited from Control)
isPressed (inherited from Button)
localUserData (inherited from Control)
parentDialog (inherited from Control)
textData (inherited from StaticText)
textRect (inherited from Checkbox)
visible (inherited from Control)
width (inherited from Control)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseChangedEvent (inherited from Checkbox) | Create new button instance
RaiseClickEvent (inherited from Button) | Create new button instance
SetCheckedInternal | Overloaded. Sets the checked state and fires the event if necessary
SetCheckedInternal (inherited from Checkbox) | Overloaded. Sets the checked state and fires the event if necessary
UpdateRectangles (inherited from Checkbox) | Update the rectangles

See Also

RadioButton Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


RadioButton Constructor

Create new radio button instance

public RadioButton(
Dialog parent
);

See Also

RadioButton Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


RadioButton Fields

The fields of the RadioButton class are listed below. For a complete list of RadioButton class members, see the RadioButton Members topic.

Public Instance Fields

index (inherited from Control)
isDefault (inherited from Control)

Protected Instance Fields

boundingBox (inherited from Control)
buttonGroupIndex
buttonRect (inherited from Checkbox)
controlId (inherited from Control)
controlType (inherited from Control)
controlX (inherited from Control)
controlY (inherited from Control)
elementList (inherited from Control)
enabled (inherited from Control)
hasFocus (inherited from Control)
height (inherited from Control)
hotKey (inherited from Control)
isBoxChecked (inherited from Checkbox)
isMouseOver (inherited from Control)
isPressed (inherited from Button)
localUserData (inherited from Control)
parentDialog (inherited from Control)
textData (inherited from StaticText)
textRect (inherited from Checkbox)
visible (inherited from Control)
width (inherited from Control)

See Also

RadioButton Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


RadioButton.buttonGroupIndex Field

protected uint buttonGroupIndex;

See Also

RadioButton Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


RadioButton Properties

The properties of the RadioButton class are listed below. For a complete list of RadioButton class members, see the RadioButton Members topic.

Public Instance Properties

ButtonGroup | Button Group property
CanHaveFocus (inherited from Button) | Can the button have focus
ControlType (inherited from Control) | Type of the control
Hotkey (inherited from Control) | The controls hotkey
ID (inherited from Control) | Unique ID of the control
IsChecked (inherited from Checkbox) | Checked property
IsEnabled (inherited from Control) | Is the control enabled
IsVisible (inherited from Control) | Is the control visible
Item (inherited from Control) | Index for the elements this control has access to
Parent (inherited from Control) | The parent dialog of this control
UserData (inherited from Control) | User specified data

See Also

RadioButton Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ButtonGroup Property

Goblin - A Platform for 3D AR and VR Applications

RadioButton.ButtonGroup Property

Button Group property

public uint ButtonGroup {get; set;}

See Also

RadioButton Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


RadioButton Methods

The methods of the RadioButton class are listed below. For a complete list of RadioButton class members, see the RadioButton Members topic.

Public Instance Methods

ContainsPoint (inherited from Checkbox) | Does the control contain the point?
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetTextCopy (inherited from StaticText) | Return a copy of the string
GetType (inherited from Object) | Gets the Type of the current instance.
HandleKeyboard | Handle the keyboard for the checkbox
HandleMouse | Handle mouse messages from the radio button
MsgProc (inherited from Control) | Message Handler
OnFocusIn (inherited from Control) | Called when control gets focus
OnFocusOut (inherited from Control) | Called when control loses focus
OnHotKey | Override hotkey to fire event
OnInitialize (inherited from Control) | Initialize the control
OnMouseEnter (inherited from Control) | Called when mouse goes over the control
OnMouseExit (inherited from Control) | Called when mouse leaves the control
Refresh (inherited from Control) | Refreshes the control
Render (inherited from Checkbox) | Render the checkbox control
SetChecked | Sets the check state and potentially clears the group
SetLocation (inherited from Control) | Called to set control's location
SetSize (inherited from Control) | Called to set control's size
SetText (inherited from StaticText) | Sets the updated text for this control
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseChangedEvent (inherited from Checkbox) | Create new button instance
RaiseClickEvent (inherited from Button) | Create new button instance
SetCheckedInternal | Overloaded. Sets the checked state and fires the event if necessary
SetCheckedInternal (inherited from Checkbox) | Overloaded. Sets the checked state and fires the event if necessary
UpdateRectangles (inherited from Checkbox) | Update the rectangles

See Also

RadioButton Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


RadioButton.HandleKeyboard Method

Handle the keyboard for the checkbox

public override bool HandleKeyboard(
WindowMessage msg,
IntPtr wParam,
IntPtr lParam
);

See Also

RadioButton Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


RadioButton.HandleMouse Method

Handle mouse messages from the radio button

public override bool HandleMouse(
WindowMessage msg,
Point pt,
IntPtr wParam,
IntPtr lParam
);

See Also

RadioButton Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


RadioButton.OnHotKey Method

Override hotkey to fire event

public override void OnHotKey();

See Also

RadioButton Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


RadioButton.SetChecked Method

Sets the check state and potentially clears the group

public void SetChecked(
bool ischecked,
bool clear
);

See Also

RadioButton Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


SetCheckedInternal Method

Goblin - A Platform for 3D AR and VR Applications

RadioButton.SetCheckedInternal Method

Sets the checked state and fires the event if necessary

Overload List

Inherited from Checkbox.

protected virtual void SetCheckedInternal(bool,bool);

Sets the checked state and fires the event if necessary

protected virtual void SetCheckedInternal(bool,bool,bool);

See Also

RadioButton Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


RadioButton.SetCheckedInternal Method (Boolean, Boolean, Boolean)

Sets the checked state and fires the event if necessary

protected virtual void SetCheckedInternal(
bool ischecked,
bool clearGroup,
bool fromInput
);

See Also

RadioButton Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | RadioButton.SetCheckedInternal Overload List


ResettingDeviceException Class

Resetting the device failed

For a list of all members of this type, see ResettingDeviceException Members.

System.Object
System.Exception
System.ApplicationException
Microsoft.Samples.DirectX.UtilityToolkit.DirectXSampleException
Microsoft.Samples.DirectX.UtilityToolkit.ResettingDeviceException

public class ResettingDeviceException : DirectXSampleException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

ResettingDeviceException Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ResettingDeviceException Members

ResettingDeviceException overview

Public Instance Constructors

ResettingDeviceException Overloaded. Initializes a new instance of the ResettingDeviceException class.

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ResettingDeviceException Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ResettingDeviceException Constructor

Initializes a new instance of the ResettingDeviceException class.

Overload List

Initializes a new instance of the ResettingDeviceException class.

public ResettingDeviceException();

public ResettingDeviceException(Exception);

See Also

ResettingDeviceException Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ResettingDeviceException Constructor ()

Initializes a new instance of the ResettingDeviceException class.

public ResettingDeviceException();

See Also

ResettingDeviceException Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | ResettingDeviceException Constructor Overload List


ResettingDeviceException Constructor (Exception)

public ResettingDeviceException(
Exception inner
);

See Also

ResettingDeviceException Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | ResettingDeviceException Constructor Overload List


ResettingDeviceObjectsException Class

Resetting the device failed

For a list of all members of this type, see ResettingDeviceObjectsException Members.

System.Object
System.Exception
System.ApplicationException
Microsoft.Samples.DirectX.UtilityToolkit.DirectXSampleException
Microsoft.Samples.DirectX.UtilityToolkit.ResettingDeviceObjectsException

public class ResettingDeviceObjectsException : DirectXSampleException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

ResettingDeviceObjectsException Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ResettingDeviceObjectsException Members

ResettingDeviceObjectsException overview

Public Instance Constructors

ResettingDeviceObjectsException Overloaded. Initializes a new instance of the ResettingDeviceObjectsException class.

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ResettingDeviceObjectsException Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ResettingDeviceObjectsException Constructor

Initializes a new instance of the ResettingDeviceObjectsException class.

Overload List

Initializes a new instance of the ResettingDeviceObjectsException class.

public ResettingDeviceObjectsException();

public ResettingDeviceObjectsException(Exception);

See Also

ResettingDeviceObjectsException Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ResettingDeviceObjectsException Constructor ()

Initializes a new instance of the ResettingDeviceObjectsException class.

public ResettingDeviceObjectsException();

See Also

ResettingDeviceObjectsException Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | ResettingDeviceObjectsException Constructor Overload List


ResettingDeviceObjectsException Constructor (Exception)

public ResettingDeviceObjectsException(
Exception inner
);

See Also

ResettingDeviceObjectsException Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | ResettingDeviceObjectsException Constructor Overload List


ResourceCache Class

Will be a resource cache for any resources that may be required by a sample This class will be 'static'

For a list of all members of this type, see ResourceCache Members.

System.Object
Microsoft.Samples.DirectX.UtilityToolkit.ResourceCache

public class ResourceCache

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

ResourceCache Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ResourceCache Members

ResourceCache overview

Public Static Methods

GetGlobalInstance

Public Instance Methods

CreateCubeTextureFromFile | Create a cube texture from a file
CreateCubeTextureFromFileEx | Create a cube texture from a file
CreateEffectFromFile | Overloaded. Create an effect from a file
CreateFont | Overloaded. Create a font object
CreateTextureFromFile | Create a texture from a file
CreateTextureFromFileEx | Create a texture from a file
CreateVolumeTextureFromFile | Create a volume texture from a file
CreateVolumeTextureFromFileEx | Create a volume texture from a file
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
OnCreateDevice | Called when the device is created
OnDestroyDevice | Destroy any resources and clear the caches
OnLostDevice | Clear any resources that need to be lost
OnResetDevice | Called when the device is reset
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

effectCache
fontCache
textureCache

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ResourceCache Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ResourceCache Fields

The fields of the ResourceCache class are listed below. For a complete list of ResourceCache class members, see the ResourceCache Members topic.

Protected Instance Fields

effectCache
fontCache
textureCache

See Also

ResourceCache Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ResourceCache.effectCache Field

protected Hashtable effectCache;

See Also

ResourceCache Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ResourceCache.fontCache Field

protected Hashtable fontCache;

See Also

ResourceCache Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ResourceCache.textureCache Field

protected Hashtable textureCache;

See Also

ResourceCache Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ResourceCache Methods

The methods of the ResourceCache class are listed below. For a complete list of ResourceCache class members, see the ResourceCache Members topic.

Public Static Methods

GetGlobalInstance

Public Instance Methods

CreateCubeTextureFromFile | Create a cube texture from a file
CreateCubeTextureFromFileEx | Create a cube texture from a file
CreateEffectFromFile | Overloaded. Create an effect from a file
CreateFont | Overloaded. Create a font object
CreateTextureFromFile | Create a texture from a file
CreateTextureFromFileEx | Create a texture from a file
CreateVolumeTextureFromFile | Create a volume texture from a file
CreateVolumeTextureFromFileEx | Create a volume texture from a file
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
OnCreateDevice | Called when the device is created
OnDestroyDevice | Destroy any resources and clear the caches
OnLostDevice | Clear any resources that need to be lost
OnResetDevice | Called when the device is reset
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ResourceCache Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ResourceCache.CreateCubeTextureFromFile Method

Create a cube texture from a file

public CubeTexture CreateCubeTextureFromFile(
Device device,
string filename
);

See Also

ResourceCache Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ResourceCache.CreateCubeTextureFromFileEx Method

Create a cube texture from a file

public CubeTexture CreateCubeTextureFromFileEx(
Device device,
string filename,
int size,
int mip,
Usage usage,
Format fmt,
Pool pool,
Filter filter,
Filter mipfilter,
int colorkey
);

See Also

ResourceCache Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


CreateEffectFromFile Method

Goblin - A Platform for 3D AR and VR Applications

ResourceCache.CreateEffectFromFile Method

Create an effect from a file

Overload List

Create an effect from a file

public Effect CreateEffectFromFile(Device,string,Macro[],Include,ShaderFlags,EffectPool);

Create an effect from a file

public Effect CreateEffectFromFile(Device,string,Macro[],Include,ShaderFlags,EffectPool,out string);

See Also

ResourceCache Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ResourceCache.CreateEffectFromFile Method (Device, String, Macro[], Include, ShaderFlags, EffectPool)

Create an effect from a file

public Effect CreateEffectFromFile(
Device device,
string filename,
Macro[] defines,
Include includeFile,
ShaderFlags flags,
EffectPool effectPool
);

See Also

ResourceCache Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | ResourceCache.CreateEffectFromFile Overload List


ResourceCache.CreateEffectFromFile Method (Device, String, Macro[], Include, ShaderFlags, EffectPool, String)

Create an effect from a file

public Effect CreateEffectFromFile(
Device device,
string filename,
Macro[] defines,
Include includeFile,
ShaderFlags flags,
EffectPool effectPool,
out string errors
);

See Also

ResourceCache Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | ResourceCache.CreateEffectFromFile Overload List


CreateFont Method

Goblin - A Platform for 3D AR and VR Applications

ResourceCache.CreateFont Method

Create a font object

Overload List

Create a font object

public Font CreateFont(Device,FontDescription);

Create a font object

public Font CreateFont(Device,int,int,FontWeight,int,bool,CharacterSet,Precision,FontQuality,PitchAndFamily,string);

See Also

ResourceCache Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ResourceCache.CreateFont Method (Device, FontDescription)

Create a font object

public Font CreateFont(
Device device,
FontDescription desc
);

See Also

ResourceCache Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | ResourceCache.CreateFont Overload List


ResourceCache.CreateFont Method (Device, Int32, Int32, FontWeight, Int32, Boolean, CharacterSet, Precision, FontQuality, PitchAndFamily, String)

Create a font object

public Font CreateFont(
Device device,
int height,
int width,
FontWeight weight,
int mip,
bool italic,
CharacterSet charSet,
Precision outputPrecision,
FontQuality quality,
PitchAndFamily pandf,
string fontName
);

See Also

ResourceCache Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | ResourceCache.CreateFont Overload List


ResourceCache.CreateTextureFromFile Method

Create a texture from a file

public Texture CreateTextureFromFile(
Device device,
string filename
);

See Also

ResourceCache Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ResourceCache.CreateTextureFromFileEx Method

Create a texture from a file

public Texture CreateTextureFromFileEx(
Device device,
string filename,
int w,
int h,
int mip,
Usage usage,
Format fmt,
Pool pool,
Filter filter,
Filter mipfilter,
int colorkey
);

See Also

ResourceCache Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ResourceCache.CreateVolumeTextureFromFile Method

Create a volume texture from a file

public VolumeTexture CreateVolumeTextureFromFile(
Device device,
string filename
);

See Also

ResourceCache Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ResourceCache.CreateVolumeTextureFromFileEx Method

Create a volume texture from a file

public VolumeTexture CreateVolumeTextureFromFileEx(
Device device,
string filename,
int w,
int h,
int d,
int mip,
Usage usage,
Format fmt,
Pool pool,
Filter filter,
Filter mipfilter,
int colorkey
);

See Also

ResourceCache Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ResourceCache.GetGlobalInstance Method

public static ResourceCache GetGlobalInstance();

See Also

ResourceCache Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ResourceCache.OnCreateDevice Method

Called when the device is created

public void OnCreateDevice(
Device device
);

See Also

ResourceCache Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ResourceCache.OnDestroyDevice Method

Destroy any resources and clear the caches

public void OnDestroyDevice();

See Also

ResourceCache Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ResourceCache.OnLostDevice Method

Clear any resources that need to be lost

public void OnLostDevice();

See Also

ResourceCache Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ResourceCache.OnResetDevice Method

Called when the device is reset

public void OnResetDevice(
Device device
);

See Also

ResourceCache Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ScrollBar Class

A scroll bar control

For a list of all members of this type, see ScrollBar Members.

System.Object
Microsoft.Samples.DirectX.UtilityToolkit.Control
Microsoft.Samples.DirectX.UtilityToolkit.ScrollBar

public class ScrollBar : Control

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

ScrollBar Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ScrollBar Members

ScrollBar overview

Public Static Fields

DownButtonLayer
ThumbLayer
TrackLayer
UpButtonLayer

Protected Static Fields

MinimumThumbSize

Public Instance Constructors

ScrollBar Constructor Creates a new instance of the scroll bar class

Public Instance Fields

index (inherited from Control)
isDefault (inherited from Control)

Public Instance Properties

CanHaveFocus (inherited from Control) | Can the control have focus
ControlType (inherited from Control) | Type of the control
Hotkey (inherited from Control) | The controls hotkey
ID (inherited from Control) | Unique ID of the control
IsEnabled (inherited from Control) | Is the control enabled
IsVisible (inherited from Control) | Is the control visible
Item (inherited from Control) | Index for the elements this control has access to
PageSize | Size of a 'page'
Parent (inherited from Control) | The parent dialog of this control
TrackPosition | Position of the track
UserData (inherited from Control) | User specified data

Public Instance Methods

ContainsPoint (inherited from Control) | Does the control contain this point
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HandleKeyboard (inherited from Control) | Handle the keyboard data
HandleMouse | Stores data for a combo box item
MsgProc (inherited from Control) | Message Handler
OnFocusIn (inherited from Control) | Called when control gets focus
OnFocusOut (inherited from Control) | Called when control loses focus
OnHotKey (inherited from Control) | Called when the control's hotkey is hit
OnInitialize (inherited from Control) | Initialize the control
OnMouseEnter (inherited from Control) | Called when mouse goes over the control
OnMouseExit (inherited from Control) | Called when mouse leaves the control
Refresh (inherited from Control) | Refreshes the control
Render | Render the scroll bar control
Scroll | Scrolls by delta items. A positive value scrolls down, while a negative scrolls down
SetLocation (inherited from Control) | Called to set control's location
SetSize (inherited from Control) | Called to set control's size
SetTrackRange | Sets the track range
ShowItem | Shows an item
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

boundingBox (inherited from Control)
controlId (inherited from Control)
controlType (inherited from Control)
controlX (inherited from Control)
controlY (inherited from Control)
downButtonRect
elementList (inherited from Control)
enabled (inherited from Control)
end
hasFocus (inherited from Control)
height (inherited from Control)
hotKey (inherited from Control)
isMouseOver (inherited from Control)
localUserData (inherited from Control)
pageSize
parentDialog (inherited from Control)
position
showingThumb
start
thumbRect
trackRect
upButtonRect
visible (inherited from Control)
width (inherited from Control)

Protected Instance Methods

Cap | Clips position at boundaries
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
UpdateRectangles | Update all of the rectangles
UpdateThumbRectangle | Compute the dimension of the scroll thumb

See Also

ScrollBar Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ScrollBar Constructor

Creates a new instance of the scroll bar class

public ScrollBar(
Dialog parent
);

See Also

ScrollBar Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ScrollBar Fields

The fields of the ScrollBar class are listed below. For a complete list of ScrollBar class members, see the ScrollBar Members topic.

Public Static Fields

DownButtonLayer
ThumbLayer
TrackLayer
UpButtonLayer

Protected Static Fields

MinimumThumbSize

Public Instance Fields

index (inherited from Control)
isDefault (inherited from Control)

Protected Instance Fields

boundingBox (inherited from Control)
controlId (inherited from Control)
controlType (inherited from Control)
controlX (inherited from Control)
controlY (inherited from Control)
downButtonRect
elementList (inherited from Control)
enabled (inherited from Control)
end
hasFocus (inherited from Control)
height (inherited from Control)
hotKey (inherited from Control)
isMouseOver (inherited from Control)
localUserData (inherited from Control)
pageSize
parentDialog (inherited from Control)
position
showingThumb
start
thumbRect
trackRect
upButtonRect
visible (inherited from Control)
width (inherited from Control)

See Also

ScrollBar Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ScrollBar.DownButtonLayer Field

public const int DownButtonLayer = 2;

See Also

ScrollBar Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ScrollBar.downButtonRect Field

protected Rectangle downButtonRect;

See Also

ScrollBar Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ScrollBar.end Field

protected int end;

See Also

ScrollBar Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ScrollBar.MinimumThumbSize Field

protected const int MinimumThumbSize = 8;

See Also

ScrollBar Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


PageSize Property

Goblin - A Platform for 3D AR and VR Applications

ScrollBar.PageSize Property

Size of a 'page'

public int PageSize {get; set;}

See Also

ScrollBar Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ScrollBar.position Field

protected int position;

See Also

ScrollBar Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ScrollBar.showingThumb Field

protected bool showingThumb;

See Also

ScrollBar Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ScrollBar.start Field

protected int start;

See Also

ScrollBar Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ScrollBar.ThumbLayer Field

public const int ThumbLayer = 3;

See Also

ScrollBar Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ScrollBar.thumbRect Field

protected Rectangle thumbRect;

See Also

ScrollBar Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ScrollBar.TrackLayer Field

public const int TrackLayer = 0;

See Also

ScrollBar Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ScrollBar.trackRect Field

protected Rectangle trackRect;

See Also

ScrollBar Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ScrollBar.UpButtonLayer Field

public const int UpButtonLayer = 1;

See Also

ScrollBar Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ScrollBar.upButtonRect Field

protected Rectangle upButtonRect;

See Also

ScrollBar Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ScrollBar Properties

The properties of the ScrollBar class are listed below. For a complete list of ScrollBar class members, see the ScrollBar Members topic.

Public Instance Properties

CanHaveFocus (inherited from Control) | Can the control have focus
ControlType (inherited from Control) | Type of the control
Hotkey (inherited from Control) | The controls hotkey
ID (inherited from Control) | Unique ID of the control
IsEnabled (inherited from Control) | Is the control enabled
IsVisible (inherited from Control) | Is the control visible
Item (inherited from Control) | Index for the elements this control has access to
PageSize | Size of a 'page'
Parent (inherited from Control) | The parent dialog of this control
TrackPosition | Position of the track
UserData (inherited from Control) | User specified data

See Also

ScrollBar Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


TrackPosition Property

Goblin - A Platform for 3D AR and VR Applications

ScrollBar.TrackPosition Property

Position of the track

public int TrackPosition {get; set;}

See Also

ScrollBar Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ScrollBar Methods

The methods of the ScrollBar class are listed below. For a complete list of ScrollBar class members, see the ScrollBar Members topic.

Public Instance Methods

ContainsPoint (inherited from Control) | Does the control contain this point
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HandleKeyboard (inherited from Control) | Handle the keyboard data
HandleMouse | Stores data for a combo box item
MsgProc (inherited from Control) | Message Handler
OnFocusIn (inherited from Control) | Called when control gets focus
OnFocusOut (inherited from Control) | Called when control loses focus
OnHotKey (inherited from Control) | Called when the control's hotkey is hit
OnInitialize (inherited from Control) | Initialize the control
OnMouseEnter (inherited from Control) | Called when mouse goes over the control
OnMouseExit (inherited from Control) | Called when mouse leaves the control
Refresh (inherited from Control) | Refreshes the control
Render | Render the scroll bar control
Scroll | Scrolls by delta items. A positive value scrolls down, while a negative scrolls down
SetLocation (inherited from Control) | Called to set control's location
SetSize (inherited from Control) | Called to set control's size
SetTrackRange | Sets the track range
ShowItem | Shows an item
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Cap | Clips position at boundaries
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
UpdateRectangles | Update all of the rectangles
UpdateThumbRectangle | Compute the dimension of the scroll thumb

See Also

ScrollBar Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ScrollBar.Cap Method

Clips position at boundaries

protected void Cap();

See Also

ScrollBar Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ScrollBar.HandleMouse Method

Stores data for a combo box item

public override bool HandleMouse(
WindowMessage msg,
Point pt,
IntPtr wParam,
IntPtr lParam
);

See Also

ScrollBar Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ScrollBar.Render Method

Render the scroll bar control

public override void Render(
Device device,
float elapsedTime
);

See Also

ScrollBar Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ScrollBar.Scroll Method

Scrolls by delta items. A positive value scrolls down, while a negative scrolls down

public void Scroll(
int delta
);

See Also

ScrollBar Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ScrollBar.SetTrackRange Method

Sets the track range

public void SetTrackRange(
int startRange,
int endRange
);

See Also

ScrollBar Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ScrollBar.ShowItem Method

Shows an item

public void ShowItem(
int index
);

See Also

ScrollBar Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ScrollBar.UpdateRectangles Method

Update all of the rectangles

protected override void UpdateRectangles();

See Also

ScrollBar Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


ScrollBar.UpdateThumbRectangle Method

Compute the dimension of the scroll thumb

protected void UpdateThumbRectangle();

See Also

ScrollBar Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


SettingsDialog Class

Dialog for selection of device settings

For a list of all members of this type, see SettingsDialog Members.

System.Object
Microsoft.Samples.DirectX.UtilityToolkit.SettingsDialog

public class SettingsDialog

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

SettingsDialog Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


SettingsDialog Members

SettingsDialog overview

Public Instance Constructors

SettingsDialog Constructor Creates a new settings dialog

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HandleMessages | Hand messages off to dialog
OnCreateDevice | Called when the device is created
OnRender | Render the dialog
OnResetDevice | Called when the device is reset
Refresh | Changes the UI defaults to the current device settings
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SettingsDialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


SettingsDialog Constructor

Creates a new settings dialog

public SettingsDialog(
Framework sample
);

See Also

SettingsDialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


SettingsDialog Methods

The methods of the SettingsDialog class are listed below. For a complete list of SettingsDialog class members, see the SettingsDialog Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HandleMessages | Hand messages off to dialog
OnCreateDevice | Called when the device is created
OnRender | Render the dialog
OnResetDevice | Called when the device is reset
Refresh | Changes the UI defaults to the current device settings
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SettingsDialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


SettingsDialog.HandleMessages Method

Hand messages off to dialog

public void HandleMessages(
IntPtr hWnd,
WindowMessage msg,
IntPtr wParam,
IntPtr lParam
);

See Also

SettingsDialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


SettingsDialog.OnCreateDevice Method

Called when the device is created

public void OnCreateDevice(
Device d
);

See Also

SettingsDialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


SettingsDialog.OnRender Method

Render the dialog

public void OnRender(
float elapsedTime
);

See Also

SettingsDialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


SettingsDialog.OnResetDevice Method

Called when the device is reset

public void OnResetDevice();

See Also

SettingsDialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


SettingsDialog.Refresh Method

Changes the UI defaults to the current device settings

public void Refresh();

See Also

SettingsDialog Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


SettingsDialogControlIds Enumeration

public enum SettingsDialogControlIds

Members

Member Name | Description
Static |
None |
OK |
Cancel |
Adapter |
DeviceType |
Windowed |
Fullscreen |
AdapterFormat |
AdapterFormatLabel |
Resolution |
ResolutionLabel |
RefreshRate |
RefreshRateLabel |
BackBufferFormat |
DepthStencil |
MultisampleType |
MultisampleQuality |
VertexProcessing |
PresentInterval |
DeviceClip |
RadioButtonGroup |

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

Microsoft.Samples.DirectX.UtilityToolkit Namespace


Slider Class

Slider control

For a list of all members of this type, see Slider Members.

System.Object
Microsoft.Samples.DirectX.UtilityToolkit.Control
Microsoft.Samples.DirectX.UtilityToolkit.Slider

public class Slider : Control

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

Slider Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Slider Members

Slider overview

Public Static Fields

ButtonLayer
TrackLayer

Public Instance Constructors

Slider Constructor Create new button instance

Public Instance Fields

index (inherited from Control)
isDefault (inherited from Control)

Public Instance Properties

CanHaveFocus | Slider's can always have focus
ControlType (inherited from Control) | Type of the control
Hotkey (inherited from Control) | The controls hotkey
ID (inherited from Control) | Unique ID of the control
IsEnabled (inherited from Control) | Is the control enabled
IsVisible (inherited from Control) | Is the control visible
Item (inherited from Control) | Index for the elements this control has access to
Parent (inherited from Control) | The parent dialog of this control
UserData (inherited from Control) | User specified data
Value | Current value of the slider

Public Instance Methods

ContainsPoint | Does the control contain this point?
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HandleKeyboard | Handle keyboard input
HandleMouse | Handle mouse input input
MsgProc (inherited from Control) | Message Handler
OnFocusIn (inherited from Control) | Called when control gets focus
OnFocusOut (inherited from Control) | Called when control loses focus
OnHotKey (inherited from Control) | Called when the control's hotkey is hit
OnInitialize (inherited from Control) | Initialize the control
OnMouseEnter (inherited from Control) | Called when mouse goes over the control
OnMouseExit (inherited from Control) | Called when mouse leaves the control
Refresh (inherited from Control) | Refreshes the control
Render | Render the slider
SetLocation (inherited from Control) | Called to set control's location
SetRange | Sets the range of the slider
SetSize (inherited from Control) | Called to set control's size
ToString (inherited from Object) | Returns a String that represents the current Object.
ValueFromPosition | Gets a value from a position

Public Instance Events

ValueChanged

Protected Instance Fields

boundingBox (inherited from Control)
buttonRect
buttonX
controlId (inherited from Control)
controlType (inherited from Control)
controlX (inherited from Control)
controlY (inherited from Control)
currentValue
dragOffset
dragX
elementList (inherited from Control)
enabled (inherited from Control)
hasFocus (inherited from Control)
height (inherited from Control)
hotKey (inherited from Control)
isMouseOver (inherited from Control)
isPressed
localUserData (inherited from Control)
maxValue
minValue
parentDialog (inherited from Control)
visible (inherited from Control)
width (inherited from Control)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseValueChanged | Current value of the slider
SetValueInternal | Sets the value internally and fires the event if needed
UpdateRectangles | Update the rectangles for the control

See Also

Slider Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Slider Constructor

Create new button instance

public Slider(
Dialog parent
);

See Also

Slider Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Slider Fields

The fields of the Slider class are listed below. For a complete list of Slider class members, see the Slider Members topic.

Public Static Fields

ButtonLayer
TrackLayer

Public Instance Fields

index (inherited from Control)
isDefault (inherited from Control)

Protected Instance Fields

boundingBox (inherited from Control)
buttonRect
buttonX
controlId (inherited from Control)
controlType (inherited from Control)
controlX (inherited from Control)
controlY (inherited from Control)
currentValue
dragOffset
dragX
elementList (inherited from Control)
enabled (inherited from Control)
hasFocus (inherited from Control)
height (inherited from Control)
hotKey (inherited from Control)
isMouseOver (inherited from Control)
isPressed
localUserData (inherited from Control)
maxValue
minValue
parentDialog (inherited from Control)
visible (inherited from Control)
width (inherited from Control)

See Also

Slider Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Slider.ButtonLayer Field

public const int ButtonLayer = 1;

See Also

Slider Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Slider.buttonRect Field

protected Rectangle buttonRect;

See Also

Slider Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Slider.buttonX Field

protected int buttonX;

See Also

Slider Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Slider.currentValue Field

protected int currentValue;

See Also

Slider Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Slider.dragOffset Field

protected int dragOffset;

See Also

Slider Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Slider.dragX Field

protected int dragX;

See Also

Slider Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Slider.isPressed Field

protected bool isPressed;

See Also

Slider Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Slider.maxValue Field

protected int maxValue;

See Also

Slider Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Slider.minValue Field

protected int minValue;

See Also

Slider Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Slider.TrackLayer Field

public const int TrackLayer = 0;

See Also

Slider Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Slider Properties

The properties of the Slider class are listed below. For a complete list of Slider class members, see the Slider Members topic.

Public Instance Properties

CanHaveFocus | Slider's can always have focus
ControlType (inherited from Control) | Type of the control
Hotkey (inherited from Control) | The controls hotkey
ID (inherited from Control) | Unique ID of the control
IsEnabled (inherited from Control) | Is the control enabled
IsVisible (inherited from Control) | Is the control visible
Item (inherited from Control) | Index for the elements this control has access to
Parent (inherited from Control) | The parent dialog of this control
UserData (inherited from Control) | User specified data
Value | Current value of the slider

See Also

Slider Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


CanHaveFocus Property

Goblin - A Platform for 3D AR and VR Applications

Slider.CanHaveFocus Property

Slider's can always have focus

public override bool CanHaveFocus {get;}

See Also

Slider Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Value Property

Goblin - A Platform for 3D AR and VR Applications

Slider.Value Property

Current value of the slider

public int Value {get; set;}

See Also

Slider Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Slider Methods

The methods of the Slider class are listed below. For a complete list of Slider class members, see the Slider Members topic.

Public Instance Methods

ContainsPoint | Does the control contain this point?
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HandleKeyboard | Handle keyboard input
HandleMouse | Handle mouse input input
MsgProc (inherited from Control) | Message Handler
OnFocusIn (inherited from Control) | Called when control gets focus
OnFocusOut (inherited from Control) | Called when control loses focus
OnHotKey (inherited from Control) | Called when the control's hotkey is hit
OnInitialize (inherited from Control) | Initialize the control
OnMouseEnter (inherited from Control) | Called when mouse goes over the control
OnMouseExit (inherited from Control) | Called when mouse leaves the control
Refresh (inherited from Control) | Refreshes the control
Render | Render the slider
SetLocation (inherited from Control) | Called to set control's location
SetRange | Sets the range of the slider
SetSize (inherited from Control) | Called to set control's size
ToString (inherited from Object) | Returns a String that represents the current Object.
ValueFromPosition | Gets a value from a position

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseValueChanged | Current value of the slider
SetValueInternal | Sets the value internally and fires the event if needed
UpdateRectangles | Update the rectangles for the control

See Also

Slider Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Slider.ContainsPoint Method

Does the control contain this point?

public override bool ContainsPoint(
Point pt
);

See Also

Slider Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Slider.HandleKeyboard Method

Handle keyboard input

public override bool HandleKeyboard(
WindowMessage msg,
IntPtr wParam,
IntPtr lParam
);

See Also

Slider Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Slider.HandleMouse Method

Handle mouse input input

public override bool HandleMouse(
WindowMessage msg,
Point pt,
IntPtr wParam,
IntPtr lParam
);

See Also

Slider Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Slider.RaiseValueChanged Method

Current value of the slider

protected void RaiseValueChanged(
Slider sender,
bool wasTriggeredByUser
);

See Also

Slider Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Slider.Render Method

Render the slider

public override void Render(
Device device,
float elapsedTime
);

See Also

Slider Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Slider.SetRange Method

Sets the range of the slider

public void SetRange(
int min,
int max
);

See Also

Slider Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Slider.SetValueInternal Method

Sets the value internally and fires the event if needed

protected void SetValueInternal(
int newValue,
bool fromInput
);

See Also

Slider Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Slider.UpdateRectangles Method

Update the rectangles for the control

protected override void UpdateRectangles();

See Also

Slider Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Slider.ValueFromPosition Method

Gets a value from a position

public int ValueFromPosition(
int x
);

See Also

Slider Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Slider Events

The events of the Slider class are listed below. For a complete list of Slider class members, see the Slider Members topic.

Public Instance Events

ValueChanged

See Also

Slider Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Slider.ValueChanged Event

public event EventHandler ValueChanged;

See Also

Slider Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


StaticText Class

StaticText text control

For a list of all members of this type, see StaticText Members.

System.Object
Microsoft.Samples.DirectX.UtilityToolkit.Control
Microsoft.Samples.DirectX.UtilityToolkit.StaticText

public class StaticText : Control

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

StaticText Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


StaticText Members

StaticText overview

Public Static Fields

TextElement

Public Instance Constructors

StaticText Constructor Create a new instance of a static text control

Public Instance Fields

index (inherited from Control)
isDefault (inherited from Control)

Public Instance Properties

CanHaveFocus (inherited from Control) | Can the control have focus
ControlType (inherited from Control) | Type of the control
Hotkey (inherited from Control) | The controls hotkey
ID (inherited from Control) | Unique ID of the control
IsEnabled (inherited from Control) | Is the control enabled
IsVisible (inherited from Control) | Is the control visible
Item (inherited from Control) | Index for the elements this control has access to
Parent (inherited from Control) | The parent dialog of this control
UserData (inherited from Control) | User specified data

Public Instance Methods

ContainsPoint (inherited from Control) | Does the control contain this point
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetTextCopy | Return a copy of the string
GetType (inherited from Object) | Gets the Type of the current instance.
HandleKeyboard (inherited from Control) | Handle the keyboard data
HandleMouse (inherited from Control) | Handle the mouse data
MsgProc (inherited from Control) | Message Handler
OnFocusIn (inherited from Control) | Called when control gets focus
OnFocusOut (inherited from Control) | Called when control loses focus
OnHotKey (inherited from Control) | Called when the control's hotkey is hit
OnInitialize (inherited from Control) | Initialize the control
OnMouseEnter (inherited from Control) | Called when mouse goes over the control
OnMouseExit (inherited from Control) | Called when mouse leaves the control
Refresh (inherited from Control) | Refreshes the control
Render | Render this control
SetLocation (inherited from Control) | Called to set control's location
SetSize (inherited from Control) | Called to set control's size
SetText | Sets the updated text for this control
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

boundingBox (inherited from Control)
controlId (inherited from Control)
controlType (inherited from Control)
controlX (inherited from Control)
controlY (inherited from Control)
elementList (inherited from Control)
enabled (inherited from Control)
hasFocus (inherited from Control)
height (inherited from Control)
hotKey (inherited from Control)
isMouseOver (inherited from Control)
localUserData (inherited from Control)
parentDialog (inherited from Control)
textData
visible (inherited from Control)
width (inherited from Control)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
UpdateRectangles (inherited from Control) | Updates the rectangles

See Also

StaticText Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


StaticText Constructor

Create a new instance of a static text control

public StaticText(
Dialog parent
);

See Also

StaticText Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


StaticText Fields

The fields of the StaticText class are listed below. For a complete list of StaticText class members, see the StaticText Members topic.

Public Static Fields

TextElement

Public Instance Fields

index (inherited from Control)
isDefault (inherited from Control)

Protected Instance Fields

boundingBox (inherited from Control)
controlId (inherited from Control)
controlType (inherited from Control)
controlX (inherited from Control)
controlY (inherited from Control)
elementList (inherited from Control)
enabled (inherited from Control)
hasFocus (inherited from Control)
height (inherited from Control)
hotKey (inherited from Control)
isMouseOver (inherited from Control)
localUserData (inherited from Control)
parentDialog (inherited from Control)
textData
visible (inherited from Control)
width (inherited from Control)

See Also

StaticText Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


StaticText.textData Field

protected string textData;

See Also

StaticText Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


StaticText.TextElement Field

public const int TextElement = 0;

See Also

StaticText Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


StaticText Methods

The methods of the StaticText class are listed below. For a complete list of StaticText class members, see the StaticText Members topic.

Public Instance Methods

ContainsPoint (inherited from Control) | Does the control contain this point
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetTextCopy | Return a copy of the string
GetType (inherited from Object) | Gets the Type of the current instance.
HandleKeyboard (inherited from Control) | Handle the keyboard data
HandleMouse (inherited from Control) | Handle the mouse data
MsgProc (inherited from Control) | Message Handler
OnFocusIn (inherited from Control) | Called when control gets focus
OnFocusOut (inherited from Control) | Called when control loses focus
OnHotKey (inherited from Control) | Called when the control's hotkey is hit
OnInitialize (inherited from Control) | Initialize the control
OnMouseEnter (inherited from Control) | Called when mouse goes over the control
OnMouseExit (inherited from Control) | Called when mouse leaves the control
Refresh (inherited from Control) | Refreshes the control
Render | Render this control
SetLocation (inherited from Control) | Called to set control's location
SetSize (inherited from Control) | Called to set control's size
SetText | Sets the updated text for this control
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
UpdateRectangles (inherited from Control) | Updates the rectangles

See Also

StaticText Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


StaticText.GetTextCopy Method

Return a copy of the string

public string GetTextCopy();

See Also

StaticText Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


StaticText.Render Method

Render this control

public override void Render(
Device device,
float elapsedTime
);

See Also

StaticText Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


StaticText.SetText Method

Sets the updated text for this control

public void SetText(
string newText
);

See Also

StaticText Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


TextHelper Structure

Manages the intertion point when drawing text

For a list of all members of this type, see TextHelper Members.

System.Object
System.ValueType
Microsoft.Samples.DirectX.UtilityToolkit.TextHelper

public struct TextHelper

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

TextHelper Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


TextHelper Members

TextHelper overview

Public Instance Constructors

TextHelper Constructor Create a new instance of the text helper class

Public Instance Methods

Begin | Begin the sprite rendering
DrawTextLine | Overloaded. Draw a line of text
End | End the sprite
Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
SetForegroundColor | Overloaded. The color of the text
SetInsertionPoint | Overloaded. Insertion point of the text
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

TextHelper Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


TextHelper Constructor

Create a new instance of the text helper class

public TextHelper(
Font f,
Sprite s,
int l
);

See Also

TextHelper Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


TextHelper Methods

The methods of the TextHelper structure are listed below. For a complete list of TextHelper structure members, see the TextHelper Members topic.

Public Instance Methods

Begin | Begin the sprite rendering
DrawTextLine | Overloaded. Draw a line of text
End | End the sprite
Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
SetForegroundColor | Overloaded. The color of the text
SetInsertionPoint | Overloaded. Insertion point of the text
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

TextHelper Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


TextHelper.Begin Method

Begin the sprite rendering

public void Begin();

See Also

TextHelper Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


DrawTextLine Method

Goblin - A Platform for 3D AR and VR Applications

TextHelper.DrawTextLine Method

Draw a line of text

Overload List

Draw a line of text

public void DrawTextLine(string);

Draw a line of text

public void DrawTextLine(string,params object[]);

See Also

TextHelper Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


TextHelper.DrawTextLine Method (String)

Draw a line of text

public void DrawTextLine(
string text
);

See Also

TextHelper Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | TextHelper.DrawTextLine Overload List


TextHelper.DrawTextLine Method (String, Object[])

Draw a line of text

public void DrawTextLine(
string text,
params object[] args
);

See Also

TextHelper Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | TextHelper.DrawTextLine Overload List


TextHelper.End Method

End the sprite

public void End();

See Also

TextHelper Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


SetForegroundColor Method

Goblin - A Platform for 3D AR and VR Applications

TextHelper.SetForegroundColor Method

Overload List

public void SetForegroundColor(Color);

The color of the text

public void SetForegroundColor(int);

See Also

TextHelper Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


TextHelper.SetForegroundColor Method (Color)

public void SetForegroundColor(
Color c
);

See Also

TextHelper Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | TextHelper.SetForegroundColor Overload List


TextHelper.SetForegroundColor Method (Int32)

The color of the text

public void SetForegroundColor(
int c
);

See Also

TextHelper Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | TextHelper.SetForegroundColor Overload List


SetInsertionPoint Method

Goblin - A Platform for 3D AR and VR Applications

TextHelper.SetInsertionPoint Method

Insertion point of the text

Overload List

Insertion point of the text

public void SetInsertionPoint(Point);

public void SetInsertionPoint(int,int);

See Also

TextHelper Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


TextHelper.SetInsertionPoint Method (Point)

Insertion point of the text

public void SetInsertionPoint(
Point p
);

See Also

TextHelper Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | TextHelper.SetInsertionPoint Overload List


TextHelper.SetInsertionPoint Method (Int32, Int32)

public void SetInsertionPoint(
int x,
int y
);

See Also

TextHelper Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | TextHelper.SetInsertionPoint Overload List


TextureNode Class

Structure for shared textures

For a list of all members of this type, see TextureNode Members.

System.Object
Microsoft.Samples.DirectX.UtilityToolkit.TextureNode

public class TextureNode

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

TextureNode Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


TextureNode Members

TextureNode overview

Public Instance Constructors

TextureNode Constructor Initializes a new instance of the TextureNode class.

Public Instance Fields

Filename
Height
Texture
Width

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TextureNode Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


TextureNode Constructor

Initializes a new instance of the TextureNode class.

public TextureNode();

See Also

TextureNode Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


TextureNode Fields

The fields of the TextureNode class are listed below. For a complete list of TextureNode class members, see the TextureNode Members topic.

Public Instance Fields

Filename
Height
Texture
Width

See Also

TextureNode Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


TextureNode.Filename Field

public string Filename;

See Also

TextureNode Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


TextureNode.Height Field

public uint Height;

See Also

TextureNode Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


TextureNode.Texture Field

public Texture Texture;

See Also

TextureNode Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


TextureNode.Width Field

public uint Width;

See Also

TextureNode Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


TimerCallback Delegate

public delegate void TimerCallback(
uint eventId
);

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

Microsoft.Samples.DirectX.UtilityToolkit Namespace


TimerData Structure

Stores timer callback information

For a list of all members of this type, see TimerData Members.

System.Object
System.ValueType
Microsoft.Samples.DirectX.UtilityToolkit.TimerData

public struct TimerData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

TimerData Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


TimerData Members

TimerData overview

Public Instance Fields

callback
Countdown
IsEnabled
TimeoutInSecs

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

TimerData Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


TimerData Fields

The fields of the TimerData structure are listed below. For a complete list of TimerData structure members, see the TimerData Members topic.

Public Instance Fields

callback
Countdown
IsEnabled
TimeoutInSecs

See Also

TimerData Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


TimerData.callback Field

public TimerCallback callback;

See Also

TimerData Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


TimerData.Countdown Field

public float Countdown;

See Also

TimerData Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


TimerData.IsEnabled Field

public bool IsEnabled;

See Also

TimerData Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


TimerData.TimeoutInSecs Field

public float TimeoutInSecs;

See Also

TimerData Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Utility Class

Misc utility functionality

For a list of all members of this type, see Utility Members.

System.Object
Microsoft.Samples.DirectX.UtilityToolkit.Utility

public class Utility

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

Utility Members | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Utility Members

Utility overview

Public Static Properties

SdkMediaPath Returns the DirectX SDK media path

Public Static Methods

AppendDirectorySeparator | Returns a valid string with a directory separator at the end.
FindMediaFile | Returns a valid path to a DXSDK media file
GetCubeMapViewMatrix | Overloaded. Returns the view matrix for a cube map face

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Utility Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Utility Properties

The properties of the Utility class are listed below. For a complete list of Utility class members, see the Utility Members topic.

Public Static Properties

SdkMediaPath Returns the DirectX SDK media path

See Also

Utility Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


SdkMediaPath Property

Goblin - A Platform for 3D AR and VR Applications

Utility.SdkMediaPath Property

Returns the DirectX SDK media path

public static string SdkMediaPath {get;}

See Also

Utility Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Utility Methods

The methods of the Utility class are listed below. For a complete list of Utility class members, see the Utility Members topic.

Public Static Methods

AppendDirectorySeparator | Returns a valid string with a directory separator at the end.
FindMediaFile | Returns a valid path to a DXSDK media file
GetCubeMapViewMatrix | Overloaded. Returns the view matrix for a cube map face

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Utility Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Utility.AppendDirectorySeparator Method

Returns a valid string with a directory separator at the end.

public static string AppendDirectorySeparator(
string pathName
);

See Also

Utility Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Utility.FindMediaFile Method

Returns a valid path to a DXSDK media file

public static string FindMediaFile(
string filename
);

Parameters

filename
Filename we're searching for

Return Value

Full path to the file

See Also

Utility Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


GetCubeMapViewMatrix Method

Goblin - A Platform for 3D AR and VR Applications

Utility.GetCubeMapViewMatrix Method

Returns the view matrix for a cube map face

Overload List

Returns the view matrix for a cube map face

public static Matrix GetCubeMapViewMatrix(CubeMapFace);

Returns the view matrix for a cube map face

public static Matrix GetCubeMapViewMatrix(int);

See Also

Utility Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace


Utility.GetCubeMapViewMatrix Method (CubeMapFace)

Returns the view matrix for a cube map face

public static Matrix GetCubeMapViewMatrix(
CubeMapFace face
);

See Also

Utility Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | Utility.GetCubeMapViewMatrix Overload List


Utility.GetCubeMapViewMatrix Method (Int32)

Returns the view matrix for a cube map face

public static Matrix GetCubeMapViewMatrix(
int face
);

See Also

Utility Class | Microsoft.Samples.DirectX.UtilityToolkit Namespace | Utility.GetCubeMapViewMatrix Overload List


WndProcCallback Delegate

public delegate IntPtr WndProcCallback(
IntPtr hWnd,
WindowMessage msg,
IntPtr wParam,
IntPtr lParam,
ref bool NoFurtherProcessing
);

Requirements

Namespace: Microsoft.Samples.DirectX.UtilityToolkit

Assembly: Goblin.Engine (in Goblin.Engine.dll)

See Also

Microsoft.Samples.DirectX.UtilityToolkit Namespace


CSharpGraph Hierarchy

System.Object
CSharpGraph
AssemblyReference
AssemblyReferenceCollection
Case
CaseCollection
Catch
CatchCollection
Comment
CommentStmtCollection
CompileUnit
CompileUnitCollection
CustomAttribute
CustomAttributeCollection
Declarator
DeclaratorCollection
Expression
ExpressionCollection
Import
ImportCollection
MemberDecl
MemberDeclCollection
NamespaceDecl
NamespaceDeclCollection
Param
ParamCollection
ParamDecl
ParamDeclCollection
RankSpecifier
RankSpecifierCollection
Statement
StatementCollection
TypeDeclCollection
TypeRef
TypeRefCollection
VariableDecl

See Also

CSharpGraph Class | CSharpGraph Members | DDW.CSharp.Dom Namespace


Expression Hierarchy

System.Object
CSharpGraph
Expression
ArrayCreateExpr
ArrayInitializer
AssignExpr
BinaryExpr
CastExpr
CreateDelegateExpr
DelegateInvokeExpr
MethodInvokeExpr
ObjectCreateExpr
PostfixExpr
PrimitiveExpr
Reference
SubExpr
TernaryExpr
TypeOfExpr
UnaryExpr

See Also

Expression Class | Expression Members | DDW.CSharp.Dom Namespace


MemberDecl Hierarchy

System.Object
CSharpGraph
MemberDecl
AccessorDecl
ConstantDecl
ConstructorDecl
DestructorDecl
EnumMemberDecl
EventDecl
FieldDecl
IndexerDecl
MethodDecl
OperatorDecl
PropertyDecl
TypeDecl

See Also

MemberDecl Class | MemberDecl Members | DDW.CSharp.Dom Namespace


PrimitiveExpr Hierarchy

System.Object
CSharpGraph
Expression
PrimitiveExpr
BooleanLiteral
CharLiteral
IntegerLiteral
NullLiteral
RealLiteral
StringLiteral

See Also

PrimitiveExpr Class | PrimitiveExpr Members | DDW.CSharp.Dom Namespace


Reference Hierarchy

System.Object
CSharpGraph
Expression
Reference
ArgumentRef
ArrayElementRef
BaseRef
BuiltInType
EventRef
FieldRef
IndexerRef
LocalRef
MemberAccess
MethodRef
PropertyRef
PropertySetValueRef
ThisRef
UnknownReference

See Also

Reference Class | Reference Members | DDW.CSharp.Dom Namespace


Statement Hierarchy

System.Object
CSharpGraph
Statement
AttachDelegateStmt
BreakStmt
CheckedStmt
CommentStmt
ConstantDeclStmt
ContinueStmt
ExprStmt
ForEachStmt
GotoStmt
IfStmt
IterationStmt
LabeledStmt
LockStmt
RemoveDelegateStmt
ReturnStmt
SwitchStmt
ThrowStmt
TryCatchFinallyStmt
UncheckedStmt
UsingStmt
VariableDeclStmt

See Also

Statement Class | Statement Members | DDW.CSharp.Dom Namespace


DDW.CSharp.DomHierarchy

Goblin - A Platform for 3D AR and VR Applications

DDW.CSharp.Dom Hierarchy

System.Object
DDW.CSharp.Dom.AssemblyReferenceCollection.IAssemblyReferenceCollectionEnumerator
DDW.CSharp.Dom.CaseCollection.ICaseCollectionEnumerator
DDW.CSharp.Dom.CatchCollection.ICatchCollectionEnumerator
DDW.CSharp.Dom.CommentStmtCollection.ICommentStmtCollectionEnumerator
DDW.CSharp.Dom.CompileUnitCollection.ICompileUnitCollectionEnumerator
DDW.CSharp.Dom.CSharpGraph ---- DDW.CSharp.Dom.IGraph
DDW.CSharp.Dom.AssemblyReference
DDW.CSharp.Dom.AssemblyReferenceCollection ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList, System.ICloneable
DDW.CSharp.Dom.Case
DDW.CSharp.Dom.CaseCollection ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList, System.ICloneable
DDW.CSharp.Dom.Catch
DDW.CSharp.Dom.CatchCollection ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList, System.ICloneable
DDW.CSharp.Dom.Comment
DDW.CSharp.Dom.CommentStmtCollection ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList, System.ICloneable
DDW.CSharp.Dom.CompileUnit ---- DDW.CSharp.Dom.IScope
DDW.CSharp.Dom.CompileUnitCollection ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList, System.ICloneable
DDW.CSharp.Dom.CustomAttribute
DDW.CSharp.Dom.CustomAttributeCollection ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList, System.ICloneable
DDW.CSharp.Dom.Declarator ---- DDW.CSharp.Dom.IDeclaration
DDW.CSharp.Dom.DeclaratorCollection ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList, System.ICloneable
DDW.CSharp.Dom.Expression
DDW.CSharp.Dom.ArrayCreateExpr
DDW.CSharp.Dom.ArrayInitializer
DDW.CSharp.Dom.AssignExpr
DDW.CSharp.Dom.BinaryExpr
DDW.CSharp.Dom.CastExpr
DDW.CSharp.Dom.CreateDelegateExpr
DDW.CSharp.Dom.DelegateInvokeExpr
DDW.CSharp.Dom.MethodInvokeExpr
DDW.CSharp.Dom.ObjectCreateExpr
DDW.CSharp.Dom.PostfixExpr
DDW.CSharp.Dom.PrimitiveExpr
DDW.CSharp.Dom.BooleanLiteral
DDW.CSharp.Dom.CharLiteral
DDW.CSharp.Dom.IntegerLiteral
DDW.CSharp.Dom.NullLiteral
DDW.CSharp.Dom.RealLiteral
DDW.CSharp.Dom.StringLiteral
DDW.CSharp.Dom.Reference ---- DDW.CSharp.Dom.IDeclaration, DDW.CSharp.Dom.ISymbolRef
DDW.CSharp.Dom.ArgumentRef
DDW.CSharp.Dom.ArrayElementRef
DDW.CSharp.Dom.BaseRef
DDW.CSharp.Dom.BuiltInType
DDW.CSharp.Dom.EventRef
DDW.CSharp.Dom.FieldRef
DDW.CSharp.Dom.IndexerRef
DDW.CSharp.Dom.LocalRef
DDW.CSharp.Dom.MemberAccess
DDW.CSharp.Dom.MethodRef
DDW.CSharp.Dom.PropertyRef
DDW.CSharp.Dom.PropertySetValueRef
DDW.CSharp.Dom.ThisRef
DDW.CSharp.Dom.UnknownReference
DDW.CSharp.Dom.SubExpr
DDW.CSharp.Dom.TernaryExpr
DDW.CSharp.Dom.TypeOfExpr
DDW.CSharp.Dom.UnaryExpr
DDW.CSharp.Dom.ExpressionCollection ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList, System.ICloneable
DDW.CSharp.Dom.Import
DDW.CSharp.Dom.ImportCollection ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList, System.ICloneable
DDW.CSharp.Dom.MemberDecl
DDW.CSharp.Dom.AccessorDecl ---- DDW.CSharp.Dom.IScope
DDW.CSharp.Dom.ConstantDecl
DDW.CSharp.Dom.ConstructorDecl ---- DDW.CSharp.Dom.IDeclaration, DDW.CSharp.Dom.IOverloadable, DDW.CSharp.Dom.IScope
DDW.CSharp.Dom.DestructorDecl ---- DDW.CSharp.Dom.IDeclaration, DDW.CSharp.Dom.IScope
DDW.CSharp.Dom.EnumMemberDecl ---- DDW.CSharp.Dom.IDeclaration
DDW.CSharp.Dom.EventDecl
DDW.CSharp.Dom.FieldDecl
DDW.CSharp.Dom.IndexerDecl ---- DDW.CSharp.Dom.IDeclaration, DDW.CSharp.Dom.IOverloadable, DDW.CSharp.Dom.IScope
DDW.CSharp.Dom.MethodDecl ---- DDW.CSharp.Dom.IDeclaration, DDW.CSharp.Dom.IOverloadable, DDW.CSharp.Dom.IScope
DDW.CSharp.Dom.OperatorDecl ---- DDW.CSharp.Dom.IDeclaration, DDW.CSharp.Dom.IOverloadable, DDW.CSharp.Dom.IScope
DDW.CSharp.Dom.PropertyDecl ---- DDW.CSharp.Dom.IDeclaration
DDW.CSharp.Dom.TypeDecl ---- DDW.CSharp.Dom.IDeclaration
DDW.CSharp.Dom.ClassDecl ---- DDW.CSharp.Dom.IScope
DDW.CSharp.Dom.DelegateDecl
DDW.CSharp.Dom.EnumDecl ---- DDW.CSharp.Dom.IScope
DDW.CSharp.Dom.InterfaceDecl ---- DDW.CSharp.Dom.IScope
DDW.CSharp.Dom.StructDecl ---- DDW.CSharp.Dom.IScope
DDW.CSharp.Dom.MemberDeclCollection ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList, System.ICloneable
DDW.CSharp.Dom.NamespaceDecl ---- DDW.CSharp.Dom.IDeclaration, DDW.CSharp.Dom.IScope
DDW.CSharp.Dom.NamespaceDeclCollection ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList, System.ICloneable
DDW.CSharp.Dom.Param
DDW.CSharp.Dom.ParamCollection ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList, System.ICloneable
DDW.CSharp.Dom.ParamDecl ---- DDW.CSharp.Dom.IDeclaration
DDW.CSharp.Dom.ParamDeclCollection ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList, System.ICloneable
DDW.CSharp.Dom.RankSpecifier
DDW.CSharp.Dom.RankSpecifierCollection ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList, System.ICloneable
DDW.CSharp.Dom.Statement
DDW.CSharp.Dom.AttachDelegateStmt
DDW.CSharp.Dom.BreakStmt
DDW.CSharp.Dom.CheckedStmt
DDW.CSharp.Dom.CommentStmt
DDW.CSharp.Dom.ConstantDeclStmt
DDW.CSharp.Dom.ContinueStmt
DDW.CSharp.Dom.ExprStmt
DDW.CSharp.Dom.ForEachStmt
DDW.CSharp.Dom.GotoStmt
DDW.CSharp.Dom.IfStmt
DDW.CSharp.Dom.IterationStmt
DDW.CSharp.Dom.LabeledStmt
DDW.CSharp.Dom.LockStmt
DDW.CSharp.Dom.RemoveDelegateStmt
DDW.CSharp.Dom.ReturnStmt
DDW.CSharp.Dom.SwitchStmt
DDW.CSharp.Dom.ThrowStmt
DDW.CSharp.Dom.TryCatchFinallyStmt
DDW.CSharp.Dom.UncheckedStmt
DDW.CSharp.Dom.UsingStmt
DDW.CSharp.Dom.VariableDeclStmt
DDW.CSharp.Dom.StatementCollection ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList, System.ICloneable
DDW.CSharp.Dom.TypeDeclCollection ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList, System.ICloneable
DDW.CSharp.Dom.TypeRef ---- DDW.CSharp.Dom.IDeclaration, DDW.CSharp.Dom.ISymbolRef
DDW.CSharp.Dom.TypeRefCollection ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList, System.ICloneable
DDW.CSharp.Dom.VariableDecl
DDW.CSharp.Dom.CustomAttributeCollection.ICustomAttributeCollectionEnumerator
DDW.CSharp.Dom.DeclaratorCollection.IDeclaratorCollectionEnumerator
DDW.CSharp.Dom.ExpressionCollection.IExpressionCollectionEnumerator
DDW.CSharp.Dom.IDeclaration
DDW.CSharp.Dom.IGraph
DDW.CSharp.Dom.ImportCollection.IImportCollectionEnumerator
DDW.CSharp.Dom.IOverloadable
DDW.CSharp.Dom.IScope
DDW.CSharp.Dom.ISymbolRef ---- DDW.CSharp.Dom.IDeclaration
DDW.CSharp.Dom.LinePragma
DDW.CSharp.Dom.MemberDeclCollection.IMemberDeclCollectionEnumerator
DDW.CSharp.Dom.NamespaceDeclCollection.INamespaceDeclCollectionEnumerator
DDW.CSharp.Dom.ParamCollection.IParamCollectionEnumerator
DDW.CSharp.Dom.ParamDeclCollection.IParamDeclCollectionEnumerator
DDW.CSharp.Dom.RankSpecifierCollection.IRankCollectionEnumerator
DDW.CSharp.Dom.StatementCollection.IStatementCollectionEnumerator
DDW.CSharp.Dom.TypeDeclCollection.ITypeDeclCollectionEnumerator
DDW.CSharp.Dom.TypeRefCollection.ITypeRefCollectionEnumerator
System.Attribute
DDW.CSharp.Dom.CodeElementAttribute
DDW.CSharp.Dom.CodeCollectionAttribute
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
DDW.CSharp.Dom.AccessorModifiers
DDW.CSharp.Dom.AssemblyReferenceCollection.Tag
DDW.CSharp.Dom.AssignOperator
DDW.CSharp.Dom.AttributeTarget
DDW.CSharp.Dom.BinaryOperator
DDW.CSharp.Dom.CaseCollection.Tag
DDW.CSharp.Dom.CatchCollection.Tag
DDW.CSharp.Dom.CommentStmtCollection.Tag
DDW.CSharp.Dom.CompileUnitCollection.Tag
DDW.CSharp.Dom.CustomAttributeCollection.Tag
DDW.CSharp.Dom.DeclaratorCollection.Tag
DDW.CSharp.Dom.ExpressionCollection.Tag
DDW.CSharp.Dom.GraphTypes
DDW.CSharp.Dom.ImportCollection.Tag
DDW.CSharp.Dom.IterationType
DDW.CSharp.Dom.MemberDeclCollection.Tag
DDW.CSharp.Dom.MemberKind
DDW.CSharp.Dom.Modifiers
DDW.CSharp.Dom.NamespaceDeclCollection.Tag
DDW.CSharp.Dom.OverloadableOperator
DDW.CSharp.Dom.ParamCollection.Tag
DDW.CSharp.Dom.ParamDeclCollection.Tag
DDW.CSharp.Dom.ParamDirection
DDW.CSharp.Dom.PostfixOperator
DDW.CSharp.Dom.RankSpecifierCollection.Tag
DDW.CSharp.Dom.StatementCollection.Tag
DDW.CSharp.Dom.TypeDeclCollection.Tag
DDW.CSharp.Dom.TypeKind
DDW.CSharp.Dom.TypeModifiers
DDW.CSharp.Dom.TypeRefCollection.Tag
DDW.CSharp.Dom.UnaryOperator

See Also

DDW.CSharp.Dom Namespace


DDW.CSharp.GenHierarchy

Goblin - A Platform for 3D AR and VR Applications

DDW.CSharp.Gen Hierarchy

System.Object
DDW.CSharp.Gen.LineWriter
DDW.CSharp.Walk.GraphParserBase
DDW.CSharp.Gen.CSharpGen

See Also

DDW.CSharp.Gen Namespace


CSharpAST Hierarchy

System.Object
BaseAST
CSharpAST
ArgDirection
Args
AssignOp
BaseTypes
BinaryOp
CompileUnit
CustomAttribute
CustomAttributes
Declarator
DeclArgs
Expression
Expressions
FinallyStmt
Members
ModifierAttributes
NamespaceNode
Op
Statement
Statements
SwitchSection
TernaryOp
TryStmt
TypeMemberNode
Types
UnaryOp
UsingNode

See Also

CSharpAST Class | CSharpAST Members | DDW.CSharp.Parse Namespace


Expression Hierarchy

System.Object
BaseAST
CSharpAST
Expression
Arg
ArrayRankExpr
AssignExpr
BinaryExpr
CastExpr
DeclArg
PrimaryExpression
PrimaryFollowExpression
QualIdent
SubExpr
TernaryExpr
TypeRef
UnaryExpr

See Also

Expression Class | Expression Members | DDW.CSharp.Parse Namespace


PrimaryExpression Hierarchy

System.Object
BaseAST
CSharpAST
Expression
PrimaryExpression
ArrayCreateExpr
ArrayInitExpr
BaseRefExpr
BuiltInType
CheckedExpr
Ident
ObjectCreateExpr
PrimitiveExpr
ThisRefExpr
TypeOfExpr
UncheckedExpr

See Also

PrimaryExpression Class | PrimaryExpression Members | DDW.CSharp.Parse Namespace


PrimitiveExpr Hierarchy

System.Object
BaseAST
CSharpAST
Expression
PrimaryExpression
PrimitiveExpr
BooleanLiteral
CharLiteral
IntegerLiteral
NullLiteral
RealLiteral
StringLiteral

See Also

PrimitiveExpr Class | PrimitiveExpr Members | DDW.CSharp.Parse Namespace


Statement Hierarchy

System.Object
BaseAST
CSharpAST
Statement
BreakStmt
CatchClause
CheckedStmt
CommentNode
ConstantDeclStmt
ContinueStmt
ExprStmt
ForEachStmt
GotoStmt
IfStmt
IterationStmt
LabeledStmt
LockStmt
ReturnStmt
SwitchStmt
ThrowStmt
TryCatchFinallyStmt
UncheckedStmt
UsingStmt
VariableDeclStmt

See Also

Statement Class | Statement Members | DDW.CSharp.Parse Namespace


TypeMemberNode Hierarchy

System.Object
BaseAST
CSharpAST
TypeMemberNode
AccessorNode
ConstantNode
ConstructorNode
DestructorNode
EnumMemberNode
EventNode
FieldNode
IndexerNode
MethodNode
OperatorNode
PropertyNode
TypeNode

See Also

TypeMemberNode Class | TypeMemberNode Members | DDW.CSharp.Parse Namespace


DDW.CSharp.ParseHierarchy

Goblin - A Platform for 3D AR and VR Applications

DDW.CSharp.Parse Hierarchy

System.Object
antlr.BaseAST ---- antlr.collections.AST, System.ICloneable
antlr.CommonAST
DDW.CSharp.Parse.LineNumberAST
DDW.CSharp.Parse.CSharpAST
DDW.CSharp.Parse.ArgDirection
DDW.CSharp.Parse.Args
DDW.CSharp.Parse.AssignOp
DDW.CSharp.Parse.BaseTypes
DDW.CSharp.Parse.BinaryOp
DDW.CSharp.Parse.CompileUnit
DDW.CSharp.Parse.CustomAttribute
DDW.CSharp.Parse.CustomAttributes
DDW.CSharp.Parse.Declarator
DDW.CSharp.Parse.DeclArgs
DDW.CSharp.Parse.Expression
DDW.CSharp.Parse.Arg
DDW.CSharp.Parse.ArrayRankExpr
DDW.CSharp.Parse.AssignExpr
DDW.CSharp.Parse.BinaryExpr
DDW.CSharp.Parse.CastExpr
DDW.CSharp.Parse.DeclArg
DDW.CSharp.Parse.PrimaryExpression
DDW.CSharp.Parse.ArrayCreateExpr
DDW.CSharp.Parse.ArrayInitExpr
DDW.CSharp.Parse.BaseRefExpr
DDW.CSharp.Parse.BuiltInType
DDW.CSharp.Parse.CheckedExpr
DDW.CSharp.Parse.Ident
DDW.CSharp.Parse.ObjectCreateExpr
DDW.CSharp.Parse.PrimitiveExpr
DDW.CSharp.Parse.BooleanLiteral
DDW.CSharp.Parse.CharLiteral
DDW.CSharp.Parse.IntegerLiteral
DDW.CSharp.Parse.NullLiteral
DDW.CSharp.Parse.RealLiteral
DDW.CSharp.Parse.StringLiteral
DDW.CSharp.Parse.ThisRefExpr
DDW.CSharp.Parse.TypeOfExpr
DDW.CSharp.Parse.UncheckedExpr
DDW.CSharp.Parse.PrimaryFollowExpression
DDW.CSharp.Parse.IndexerExpr
DDW.CSharp.Parse.InvokeExpr
DDW.CSharp.Parse.MemberAccessExpr
DDW.CSharp.Parse.PostfixExpr
DDW.CSharp.Parse.QualIdent
DDW.CSharp.Parse.SubExpr
DDW.CSharp.Parse.TernaryExpr
DDW.CSharp.Parse.TypeRef
DDW.CSharp.Parse.UnaryExpr
DDW.CSharp.Parse.Expressions
DDW.CSharp.Parse.FinallyStmt
DDW.CSharp.Parse.Members
DDW.CSharp.Parse.ModifierAttributes
DDW.CSharp.Parse.NamespaceNode
DDW.CSharp.Parse.Op
DDW.CSharp.Parse.Statement
DDW.CSharp.Parse.BreakStmt
DDW.CSharp.Parse.CatchClause
DDW.CSharp.Parse.CheckedStmt
DDW.CSharp.Parse.CommentNode
DDW.CSharp.Parse.ConstantDeclStmt
DDW.CSharp.Parse.ContinueStmt
DDW.CSharp.Parse.ExprStmt
DDW.CSharp.Parse.ForEachStmt
DDW.CSharp.Parse.GotoStmt
DDW.CSharp.Parse.IfStmt
DDW.CSharp.Parse.IterationStmt
DDW.CSharp.Parse.LabeledStmt
DDW.CSharp.Parse.LockStmt
DDW.CSharp.Parse.ReturnStmt
DDW.CSharp.Parse.SwitchStmt
DDW.CSharp.Parse.ThrowStmt
DDW.CSharp.Parse.TryCatchFinallyStmt
DDW.CSharp.Parse.UncheckedStmt
DDW.CSharp.Parse.UsingStmt
DDW.CSharp.Parse.VariableDeclStmt
DDW.CSharp.Parse.Statements
DDW.CSharp.Parse.IncStmt
DDW.CSharp.Parse.InitStmt
DDW.CSharp.Parse.SwitchSection
DDW.CSharp.Parse.TernaryOp
DDW.CSharp.Parse.TryStmt
DDW.CSharp.Parse.TypeMemberNode
DDW.CSharp.Parse.AccessorNode
DDW.CSharp.Parse.ConstantNode
DDW.CSharp.Parse.ConstructorNode
DDW.CSharp.Parse.DestructorNode
DDW.CSharp.Parse.EnumMemberNode
DDW.CSharp.Parse.EventNode
DDW.CSharp.Parse.FieldNode
DDW.CSharp.Parse.IndexerNode
DDW.CSharp.Parse.MethodNode
DDW.CSharp.Parse.OperatorNode
DDW.CSharp.Parse.PropertyNode
DDW.CSharp.Parse.TypeNode
DDW.CSharp.Parse.ClassNode
DDW.CSharp.Parse.DelegateNode
DDW.CSharp.Parse.EnumNode
DDW.CSharp.Parse.InterfaceNode
DDW.CSharp.Parse.StructNode
DDW.CSharp.Parse.Types
DDW.CSharp.Parse.UnaryOp
DDW.CSharp.Parse.UsingNode
antlr.CharScanner ---- antlr.debug.ICharScannerDebugSubject, antlr.debug.IDebugSubject, antlr.TokenStream
DDW.CSharp.Parse.CSharpLexer
antlr.Parser ---- antlr.debug.IDebugSubject, antlr.debug.IParserDebugSubject
antlr.LLkParser
DDW.CSharp.Parse.CSharpParser
DDW.CSharp.Parse.Attribution
DDW.CSharp.Parse.CSharpTokenTypes

See Also

DDW.CSharp.Parse Namespace


DDW.CSharp.SymbolTableHierarchy

Goblin - A Platform for 3D AR and VR Applications

DDW.CSharp.SymbolTable Hierarchy

System.Object
DDW.CSharp.SymbolTable.Definition ---- DDW.CSharp.SymbolTable.IDefinition
DDW.CSharp.SymbolTable.BuiltInDefinition
DDW.CSharp.SymbolTable.OverloadableDefinition
DDW.CSharp.SymbolTable.Symbol ---- DDW.CSharp.SymbolTable.ISymbol
DDW.CSharp.SymbolTable.DefinitionCollection ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList, System.ICloneable
DDW.CSharp.SymbolTable.DefinitionCollection.IDefinitionCollectionEnumerator
DDW.CSharp.SymbolTable.ExpressionRoot
DDW.CSharp.SymbolTable.ExpressionRootCollection ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList, System.ICloneable
DDW.CSharp.SymbolTable.ExpressionRootCollection.IExpressionRootCollectionEnumerator
DDW.CSharp.SymbolTable.IDefinition
DDW.CSharp.SymbolTable.INamedScope
DDW.CSharp.SymbolTable.ISymbol ---- DDW.CSharp.SymbolTable.IDefinition
DDW.CSharp.SymbolTable.Scope
DDW.CSharp.SymbolTable.AssemblyScope
DDW.CSharp.SymbolTable.BlockScope
DDW.CSharp.SymbolTable.MemberScope ---- DDW.CSharp.SymbolTable.INamedScope
DDW.CSharp.SymbolTable.NamespaceScope ---- DDW.CSharp.SymbolTable.INamedScope
DDW.CSharp.SymbolTable.TypeScope ---- DDW.CSharp.SymbolTable.INamedScope
DDW.CSharp.SymbolTable.ScopeCollection ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList, System.ICloneable
DDW.CSharp.SymbolTable.ScopeCollection.IScopeCollectionEnumerator
DDW.CSharp.SymbolTable.TypeScopeCollection ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList, System.ICloneable
DDW.CSharp.SymbolTable.TypeScopeCollection.ITypeScopeCollectionEnumerator
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
DDW.CSharp.SymbolTable.DefinitionCollection.Tag
DDW.CSharp.SymbolTable.ExpressionRootCollection.Tag
DDW.CSharp.SymbolTable.LiteralType
DDW.CSharp.SymbolTable.ScopeCollection.Tag
DDW.CSharp.SymbolTable.TypeScopeCollection.Tag

See Also

DDW.CSharp.SymbolTable Namespace


DDW.CSharp.WalkHierarchy

Goblin - A Platform for 3D AR and VR Applications

DDW.CSharp.Walk Hierarchy

System.Object
DDW.CSharp.Walk.GraphParserBase
DDW.CSharp.Walk.IGraphVisitor
DDW.CSharp.Walk.PropertyWalker
DDW.CSharp.Walk.PropertyWalkerBase ---- DDW.CSharp.Walk.IGraphVisitor
DDW.CSharp.Walk.PropertyWalkerTest

See Also

DDW.CSharp.Walk Namespace


EnC.WatcherHierarchy

Goblin - A Platform for 3D AR and VR Applications

EnC.Watcher Hierarchy

System.Object
EnC.Watcher.AspectRule
EnC.Watcher.AspectRules
EnC.Watcher.EnCProcess
EnC.Watcher.EnCSocketServer
EnC.Watcher.FileWatcherCollection
EnC.Watcher.AspectRulesFile
EnC.Watcher.DynModule
EnC.Watcher.Helper
EnC.Watcher.IGraphMatch
EnC.Watcher.MyFileWatcher
EnC.Watcher.MyTrace
EnC.Watcher.Pointcut
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
EnC.Watcher.ModuleDelegate
EnC.Watcher.MyFileWatcher.OnChangedDelegate
EnC.Watcher.OnCompilerOptionFound
EnC.Watcher.OnModuleUpdatedDelegate
EnC.Watcher.ShutdownDelegate

See Also

EnC.Watcher Namespace


Goblin.AppsHierarchy

Goblin - A Platform for 3D AR and VR Applications

Goblin.Apps Hierarchy

System.Object
Goblin.Apps.LigerHunter ---- Goblin.Engine.IApp, System.IDisposable

See Also

Goblin.Apps Namespace


Goblin.Engine.DevicesHierarchy

Goblin - A Platform for 3D AR and VR Applications

Goblin.Engine.Devices Hierarchy

System.Object
Goblin.Engine.Devices.InputDevice
Goblin.Engine.Devices.InputDevice_6DOF
Goblin.Engine.Devices.InterSenseStation
Goblin.Engine.Devices.InputDeviceDriver ---- System.IDisposable
Goblin.Engine.Devices.InterSense
Goblin.Engine.Devices.InputDeviceMapper ---- Goblin.Engine.Utilities.ICustomSerialization, Goblin.Engine.Utilities.IInitAfterDeserialization, System.IDisposable
Goblin.Engine.Devices.InterSense.ConnectionInfo
Goblin.Engine.Devices.InterSense.StationArray
Goblin.Engine.Devices.InterSense.StationInfo
Goblin.Engine.Devices.InterSenseSocket ---- System.IDisposable
Goblin.Engine.Devices.ISDllBridge
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
Goblin.Engine.Devices.MatrixDelegate
Goblin.Engine.Devices.TransformDelegate
System.Net.Sockets.UdpClient ---- System.IDisposable
Goblin.Engine.Devices.MyUdpClient
System.ValueType
Goblin.Engine.Devices.ISDllBridge.ISD_CAMERA_DATA_TYPE
Goblin.Engine.Devices.ISDllBridge.ISD_CAMERA_ENCODER_DATA_TYPE
Goblin.Engine.Devices.ISDllBridge.ISD_STATION_INFO_TYPE
Goblin.Engine.Devices.ISDllBridge.ISD_STATION_STATE_TYPE
Goblin.Engine.Devices.ISDllBridge.ISD_TRACKER_DATA_TYPE
Goblin.Engine.Devices.ISDllBridge.ISD_TRACKER_DATA_TYPE.STATION_ARRAY
Goblin.Engine.Devices.ISDllBridge.ISD_TRACKER_INFO_TYPE
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Goblin.Engine.Devices.ISDllBridge.ISD_INTERFACE_TYPE
Goblin.Engine.Devices.ISDllBridge.ISD_SYSTEM_MODEL
Goblin.Engine.Devices.ISDllBridge.ISD_SYSTEM_TYPE

See Also

Goblin.Engine.Devices Namespace


Goblin.Engine.PhysicsHierarchy

Goblin - A Platform for 3D AR and VR Applications

Goblin.Engine.Physics Hierarchy

System.Object
Goblin.Engine.Physics.Collision

See Also

Goblin.Engine.Physics Namespace


Transformer Hierarchy

System.Object
Transformer
AccelerationTransformer
ChaseAITransformer
DXCameraTransformer
InverterTransformer
TrackerTransformer
VelocityTransformer

See Also

Transformer Class | Transformer Members | Goblin.Engine.Scene Namespace


Goblin.Engine.SceneHierarchy

Goblin - A Platform for 3D AR and VR Applications

Goblin.Engine.Scene Hierarchy

System.Object
Goblin.Engine.Scene.Bounds
Goblin.Engine.Scene.CollisionDamageControl ---- Goblin.Engine.Scene.ICollisionListener
Goblin.Engine.Scene.CollisionSticker ---- Goblin.Engine.Scene.ICollisionListener
Goblin.Engine.Scene.ICollisionListener
Goblin.Engine.Scene.IgnoreCollision ---- Goblin.Engine.Scene.ICollisionListener
Goblin.Engine.Scene.SceneGraph ---- System.IDisposable
Goblin.Engine.Scene.Transformer
Goblin.Engine.Scene.AccelerationTransformer ---- Goblin.Engine.Scene.ICollisionListener
Goblin.Engine.Scene.ChaseAITransformer ---- Goblin.Engine.Scene.ICollisionListener
Goblin.Engine.Scene.DXCameraTransformer
Goblin.Engine.Scene.InverterTransformer
Goblin.Engine.Scene.TrackerTransformer
Goblin.Engine.Scene.VelocityTransformer ---- Goblin.Engine.Scene.ICollisionListener
Goblin.Engine.Scene.Xfrm ---- System.ICloneable
Microsoft.DirectX.Direct3D.Frame
Goblin.Engine.Scene.Node ---- System.IDisposable
Goblin.Engine.Scene.CameraNode
Goblin.Engine.Scene.DamagableNode
Goblin.Engine.Scene.DamagingNode
Microsoft.DirectX.Direct3D.MeshContainer
Goblin.Engine.Scene.MyMeshContainer ---- System.IDisposable

See Also

Goblin.Engine.Scene Namespace


Goblin.Engine.UtilitiesHierarchy

Goblin - A Platform for 3D AR and VR Applications

Goblin.Engine.Utilities Hierarchy

System.Object
Goblin.Engine.Utilities.ICustomSerialization
Goblin.Engine.Utilities.IInitAfterDeserialization
Goblin.Engine.Utilities.MyTrace
Goblin.Engine.Utilities.MyUtility
Goblin.Engine.Utilities.XmlSerializerHelper

See Also

Goblin.Engine.Utilities Namespace


Goblin.EngineHierarchy

Goblin - A Platform for 3D AR and VR Applications

Goblin.Engine Hierarchy

System.Object
Goblin.Engine.Engine ---- Microsoft.Samples.DirectX.UtilityToolkit.IDeviceCreation, Microsoft.Samples.DirectX.UtilityToolkit.IFrameworkCallback, System.IDisposable
Goblin.Engine.IApp ---- System.IDisposable
Goblin.Engine.Launcher

See Also

Goblin.Engine Namespace


Microsoft.Samples.DirectX.UtilityToolkitHierarchy

Goblin - A Platform for 3D AR and VR Applications

Microsoft.Samples.DirectX.UtilityToolkit Hierarchy

System.Object
Microsoft.Samples.DirectX.UtilityToolkit.ArcBall
Microsoft.Samples.DirectX.UtilityToolkit.Camera
Microsoft.Samples.DirectX.UtilityToolkit.FirstPersonCamera
Microsoft.Samples.DirectX.UtilityToolkit.ModelViewerCamera
Microsoft.Samples.DirectX.UtilityToolkit.Control
Microsoft.Samples.DirectX.UtilityToolkit.EditBox
Microsoft.Samples.DirectX.UtilityToolkit.ListBox
Microsoft.Samples.DirectX.UtilityToolkit.ScrollBar
Microsoft.Samples.DirectX.UtilityToolkit.Slider
Microsoft.Samples.DirectX.UtilityToolkit.StaticText
Microsoft.Samples.DirectX.UtilityToolkit.Button
Microsoft.Samples.DirectX.UtilityToolkit.Checkbox
Microsoft.Samples.DirectX.UtilityToolkit.RadioButton
Microsoft.Samples.DirectX.UtilityToolkit.ComboBox
Microsoft.Samples.DirectX.UtilityToolkit.DeviceSettings ---- System.ICloneable
Microsoft.Samples.DirectX.UtilityToolkit.Dialog
Microsoft.Samples.DirectX.UtilityToolkit.DialogResourceManager
Microsoft.Samples.DirectX.UtilityToolkit.DirectionWidget
Microsoft.Samples.DirectX.UtilityToolkit.DisplayModeSorter ---- System.Collections.IComparer
Microsoft.Samples.DirectX.UtilityToolkit.Element ---- System.ICloneable
Microsoft.Samples.DirectX.UtilityToolkit.EnumAdapterInformation
Microsoft.Samples.DirectX.UtilityToolkit.EnumDeviceInformation
Microsoft.Samples.DirectX.UtilityToolkit.EnumDeviceSettingsCombo
Microsoft.Samples.DirectX.UtilityToolkit.Enumeration
Microsoft.Samples.DirectX.UtilityToolkit.FontNode
Microsoft.Samples.DirectX.UtilityToolkit.Framework ---- System.IDisposable
Microsoft.Samples.DirectX.UtilityToolkit.FrameworkMesh ---- System.IDisposable
Microsoft.Samples.DirectX.UtilityToolkit.FrameworkTimer
Microsoft.Samples.DirectX.UtilityToolkit.IDeviceCreation
Microsoft.Samples.DirectX.UtilityToolkit.IFrameworkCallback
Microsoft.Samples.DirectX.UtilityToolkit.NativeMethods
Microsoft.Samples.DirectX.UtilityToolkit.ResourceCache
Microsoft.Samples.DirectX.UtilityToolkit.SettingsDialog
Microsoft.Samples.DirectX.UtilityToolkit.TextureNode
Microsoft.Samples.DirectX.UtilityToolkit.Utility
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
Microsoft.Samples.DirectX.UtilityToolkit.DeviceEventHandler
Microsoft.Samples.DirectX.UtilityToolkit.KeyboardCallback
Microsoft.Samples.DirectX.UtilityToolkit.MouseCallback
Microsoft.Samples.DirectX.UtilityToolkit.NativeMethods.WndProcDelegate
Microsoft.Samples.DirectX.UtilityToolkit.TimerCallback
Microsoft.Samples.DirectX.UtilityToolkit.WndProcCallback
System.EventArgs
Microsoft.Samples.DirectX.UtilityToolkit.DeviceEventArgs
System.Exception ---- System.Runtime.Serialization.ISerializable
System.ApplicationException
Microsoft.Samples.DirectX.UtilityToolkit.DirectXSampleException
Microsoft.Samples.DirectX.UtilityToolkit.CreatingDeviceException
Microsoft.Samples.DirectX.UtilityToolkit.CreatingDeviceObjectsException
Microsoft.Samples.DirectX.UtilityToolkit.MediaNotFoundException
Microsoft.Samples.DirectX.UtilityToolkit.NoCompatibleDevicesException
Microsoft.Samples.DirectX.UtilityToolkit.NoDirect3DException
Microsoft.Samples.DirectX.UtilityToolkit.ResettingDeviceException
Microsoft.Samples.DirectX.UtilityToolkit.ResettingDeviceObjectsException
System.ValueType
Microsoft.Samples.DirectX.UtilityToolkit.BlendColor
Microsoft.Samples.DirectX.UtilityToolkit.ComboBoxItem
Microsoft.Samples.DirectX.UtilityToolkit.ElementHolder
Microsoft.Samples.DirectX.UtilityToolkit.EnumDepthStencilMultisampleConflict
Microsoft.Samples.DirectX.UtilityToolkit.ListBoxItem
Microsoft.Samples.DirectX.UtilityToolkit.MatchOptions
Microsoft.Samples.DirectX.UtilityToolkit.NativeMethods.Message
Microsoft.Samples.DirectX.UtilityToolkit.NativeMethods.MinMaxInformation
Microsoft.Samples.DirectX.UtilityToolkit.NativeMethods.MonitorInformation
Microsoft.Samples.DirectX.UtilityToolkit.NativeMethods.WindowClass
Microsoft.Samples.DirectX.UtilityToolkit.TextHelper
Microsoft.Samples.DirectX.UtilityToolkit.TimerData
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Microsoft.Samples.DirectX.UtilityToolkit.CameraKeys
Microsoft.Samples.DirectX.UtilityToolkit.ControlState
Microsoft.Samples.DirectX.UtilityToolkit.ControlType
Microsoft.Samples.DirectX.UtilityToolkit.ListBoxStyle
Microsoft.Samples.DirectX.UtilityToolkit.MatchType
Microsoft.Samples.DirectX.UtilityToolkit.MouseButtonMask
Microsoft.Samples.DirectX.UtilityToolkit.NativeMethods.MouseButtons
Microsoft.Samples.DirectX.UtilityToolkit.NativeMethods.PeekMessageFlags
Microsoft.Samples.DirectX.UtilityToolkit.NativeMethods.ShowWindowFlags
Microsoft.Samples.DirectX.UtilityToolkit.NativeMethods.WindowMessage
Microsoft.Samples.DirectX.UtilityToolkit.NativeMethods.WindowStyles
Microsoft.Samples.DirectX.UtilityToolkit.SettingsDialogControlIds

See Also

Microsoft.Samples.DirectX.UtilityToolkit Namespace