Subject: [Autoconf] Multi-subnet manets and manet local addresses

From: "Shoaib Rao" <[email-masked]>
Date: Sun, 9 Apr 2006 13:01:17 -0700

Hi,

Reading this draft and the following discussion it's not clear to me

*) Do we still need multiple subnets as proposed in
draft-thaler-autoconf-multisubnet-manets
   The above draft does not list any reason or sites any documents as
to why a single link
   approach (option A) is a bad choice.

*) Can manet router's other interfaces that need to communicate with
other manet routers use MLA. The draft seems to imply that in the
"address scope section". This would allow for a weak DAD.

*) In case the mdelis multiple subnets how will the network prefix
handled ? It can not be FC00::/7 or can it be.

Regards,

Shoaib.

_______________________________________________
Autoconf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/autoconf

---

From: "Templin, Fred L" <[email-masked]>
Date: Mon, 10 Apr 2006 08:32:37 -0700

Shoaib,

I think the document is saying that if you can treat
the MANET as a single link by running the MANET routing
protocol at L2 (option A), then there is no problem for
existing protocols and applications. But, if you must run
the MANET routing protocol at L3, then the multi-subnet
MANET approach (option C) avoids potential issues brought
on by treating it as a single subnet (option B).

I believe this means that option A is the preferred
approach and options B or C should be used only when
necessary. As stated in section 1 (C), the remainder
of the document concerns itself only with option C.

Fred
[email-masked]

-----Original Message-----
From: Shoaib Rao [mailto:[email-masked]] 
Sent: Sunday, April 09, 2006 1:01 PM
To: autoconf
Subject: [Autoconf] Multi-subnet manets and manet local addresses

Hi,

Regards,

Shoaib.

---

From: "Shoaib Rao" <[email-masked]>
Date: Mon, 10 Apr 2006 23:04:03 -0700

> on by treating it as a single subnet (option B).
Thanks for clearing this up.

> of the document concerns itself only with option C.

Does this mean there will be two routing protocols. I hope not. It
would be complicated to choose and mix the two.

Shoaib.