Subject: Re: [Autoconf] RE: Avoiding wasted address space in Multi-Subnet MANETs

From: "Ian Chakeres" <[email-masked]>
Date: Mon, 3 Apr 2006 13:28:57 -0700

Dave, I think that using L2/L2.5 is a viable approach for some
solutions. For heterogeneous networks, especially those with
heterogeneous links, a L3 solution is the best approach for MANET
technology. I envision that in many networks there might even be
several MANET protocols running at different layers simultaneously.

I am not arguing for/against /64s.
Ian

FYI: The MANET routing protocols are able to operate with any prefix,
including /128.

On 3/31/06, Dave Thaler <[email-masked]> wrote:
> A good way to avoid wasting space in a particular environment
> like TRILL is to use a solution which does not involve
> decrementing TTL.  That is, a layer-2 (or 2.5) solution,
> rather than a layer-3 solution.
>
> Once you start decrementing TTL, then you need /64s for
> all the reasons discussed at IETF and in the two relevant
> documents (support for all types of Ipv6 addresses (CGA,
> temporary addresses, etc), non-MANET-client support,
> not breaking upper layer assumptions, etc.)
>
> -Dave
>
> -----Original Message-----
> From: Templin, Fred L [mailto:[email-masked]]
> Sent: Friday, March 31, 2006 2:14 PM
> To: [email-masked]
> Cc: Dave Thaler
> Subject: Avoiding wasted address space in Multi-Subnet MANETs
>
> I like the idea of allocating subnet prefixes to MANET routers
> very much, but I have heard concerns voiced in other working
> groups (TRILL, in particular) that allocating an entire /64
> prefix to a router that may use only a small fraction of the
> available address space is wasteful.
>
> I realize that /64 is the finest granularity for subnet
> assignment in IPv6, but it could be that not all routers
> in a MANET will need to allocate prefixes for the purpose
> of downstream delegation. Can there be a hybrid method
> whereby MANET routers that need to allocate prefix(es) for
> downstream delegation allocate as many /64s as they need
> and other MANET routers delegate a /128, i.e., a host route?
> (Those router that require prefixes for downstream delegation
> at a later time could always defer the delegation until such
> a time that the /64s are actually needed.)
>
> Fred
> [email-masked]
>
> _______________________________________________
> Autoconf mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/autoconf
>

_______________________________________________
Autoconf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/autoconf

---

From: Jari Arkko <[email-masked]>
Date: Tue, 18 Apr 2006 15:04:38 +0300

>available address space is wasteful.
For background, we have roughly similar "waste" in other contexts.
For instance, in RFC 3314 the IETF recommended that cellular phones
adopt a prefix-per-phone model. The benefits in that context included
better operation with devices connected to the cellular phones (e.g.
laptops with standard IPv6 stacks). Our current discussion sounds a
bit familiar to that... but of course the numbers can be different,
depending on what kind of deployment we expect. For cell phones
it was in the billions.

--Jari