Subject: [Autoconf] Configuring 'default' in Multi-Subnet MANETs

From: "Templin, Fred L" <[email-masked]>
Date: Thu, 30 Mar 2006 16:58:35 -0800

Dave,

I notice that 'draft-thaler-autoconf-multisubnet-manets'
is silent on the subject of how MANET routers can
configure and use a default route. Do you have any
thoughts on this?

Fred
[email-masked] 

_______________________________________________
Autoconf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/autoconf

---

From: "Joe Macker" <[email-masked]>
Date: Fri, 31 Mar 2006 13:20:24 -0500

Fred/All:
I know this question was addressed at Dave, but for at least proactive
routing issues should addressed with some relationship to architecture.
e.g., stub areas, totally stub areas, NSSA type, transit. So I think you
have to first say what is the deployment scenario. 

For stub or totally stub the border router(s) should proactively inject a
default route.  This is normal operation for things like MANET-OSPF and OLSR
types of deployments.  Other cases are more complex. Are there reasons why
this should be different than normal intra-domain types of approaches?  I
see draft-thaler-autoconf-multisubnet-manets as a valid subcase of what we
can do. Is there some motivation why there is a difference here in default
route injection approach?  I guess I am thinking in terms of typical OSPF
default route handling/deployment use cases.
  
Did you have something in mind or just curious? I think it's a good
question, but I would like to see this discussion be more generally
addressed and am presently hoping we could follow standard best practices
where it makes sense.  I'd  also like to hear if someone has a reason why we
should do something different.

-Joe

>-----Original Message-----
>From: Templin, Fred L [mailto:[email-masked]] 
>Sent: Thursday, March 30, 2006 7:59 PM
>To: [email-masked]
>Cc: [email-masked]
>Subject: [Autoconf] Configuring 'default' in Multi-Subnet MANETs
>
>Dave,
>
>is silent on the subject of how MANET routers can configure 
>and use a default route. Do you have any thoughts on this?
>
>Fred

---

From: "Charles E. Perkins" <[email-masked]>
Date: Fri, 31 Mar 2006 10:52:35 -0800

Hello Joe,

I have some comments after your e-mail, about the
presentation made by Dave Thaler.

Joe Macker wrote:

> ...   would like to see this discussion be more generally
First, I was surprised that Dave came out against host routes for
ad hoc networks.  This position is not stated clearly in his drafts,
and I find it worrisome because so much work in ad hoc networks
does use host routes.  I think it is _possible_ to use link local
addresses for forwarding packets to a neighbor, but I shudder
and worry if new protocol will be "required" in order to assure
that link-local addresses are unique across an entire ad hoc network.
Using IPv? addresses with global scope almost entirely avoids
this problem.  There are proposals already known to the group
about how to get such addresses.

If we suppose (a priori) that link-local addresses are unique, without
requiring additional protocol, then things can be made to work more
easily.  I still do not think it provides any noticeable benefit over using
IPv? addresses with global scope, but at least there don't seem to be
too many nasty repercussions.  But that's _if_ we can assume that
the link-local addresses are unique without doing any real work.
So, for instance, one could restrict the results of the [autoconf]
working group to apply only when the radio devices can be assumed
to come equipped with known unique MAC addresses, from which
known unique link-local addresses can be derived.

One thing I tried to point out at the meeting, was that, purely within
the constraints imposed by IPv6, link-local addresses are only
known to be unique within a link.  In a typical radio environment,
a link is not so well-defined, but it is typically either taken to be
either the whole ad hoc network, or a one-hop neighborhood of a
node.  The former case imposes the abovementioned strong requirement
for globally unique link-local addresses (e.g. by MAC address uniqueness).
The latter case is quite tricky, and protocol solutions have to deal with
mobility and the dynamic nature of the neighborhood.  Either way is
treacherous it seems to me, unless the working group is comfortable
with assuming the convenience of global uniqueness for MAC addresses.

In short, I think that the proposal to use link-local addresses is
problematic, and does not offer any clear advantages over using
host routes.  Using unnumbered interfaces for IPv4 is a somewhat
different case, and as far as I can tell it doesn't introduce terrible
problems, but on the other hand it doesn't provide any noticeable
benefits either as far as I can tell.  And, to be honest, I didn't think
about this case very much so I might have overlooked something.

Regards,
Charlie P.

---

From: "Templin, Fred L" <[email-masked]>
Date: Fri, 31 Mar 2006 13:32:05 -0800

Joe,

In retrospect, it was more of a general question for
the MANET routing protocols than anything specific to
Multi-Subnet MANETs so I'm going to change the subject
line. I agree that with the proactive routing protocols
the MANET border routers can inject a default route into
the routing protocol and it propagates through the MANET
just fine. (In fact, I now recall that we did this with
TBRPF back in the 2001-2002 timeframe as I'm sure you
have done with any proactive routing protocols you may
be using in your studies.)

However, from reading the globalv6 proposal, it seems
that the landscape may be different for the reactive
protocols. In 'draft-wakikawa-manet-globalv6-05.txt',
sections 5.3 and 6 the authors assert that special
handling is needed in the reactive protocol case to
establish a default route and direct packets through
a default gateway.

In particular, since the reactive protocols do not
maintain complete topology information at each MANET
router, globalv6 says that nodes sending packets via a
particular MANET border router must insert a routing
header that names the final destination and insert
the address of the MANET border router in the IPv6
destination address. This seems like it would require
a kernel hack to make it work.

So its clear that this discussion is aside from the
question of Multi-Subnet MANETs, but it might be a
differentiator between reactive and proactive protocols
from the standpoint of Internet attachment.

Fred

-----Original Message-----
From: Joe Macker [mailto:[email-masked]] 
Sent: Friday, March 31, 2006 10:20 AM
To: Templin, Fred L; [email-masked]
Cc: [email-masked]
Subject: RE: [Autoconf] Configuring 'default' in Multi-Subnet MANETs

Fred/All:

For stub or totally stub the border router(s) should proactively inject
a
default route.  This is normal operation for things like MANET-OSPF and
OLSR
types of deployments.  Other cases are more complex. Are there reasons
why
this should be different than normal intra-domain types of approaches?
I
see draft-thaler-autoconf-multisubnet-manets as a valid subcase of what
we
can do. Is there some motivation why there is a difference here in
default
route injection approach?  I guess I am thinking in terms of typical
OSPF
default route handling/deployment use cases.
  
Did you have something in mind or just curious? I think it's a good
question, but I would like to see this discussion be more generally
addressed and am presently hoping we could follow standard best
practices
where it makes sense.  I'd  also like to hear if someone has a reason
why we
should do something different.

-Joe

---

From: "Templin, Fred L" <[email-masked]>
Date: Fri, 31 Mar 2006 13:54:52 -0800

The Multi-Subnet MANETs document wisely declares details
of the subnet allocation protocol as out of scope, but
this forum seems to be the right place to discuss them.

>From the requirements listed in section 4.1 of the
document, a natural candidate for subnet allocation
would seem to be DHCP. But, I am concerned that the
dynamic nature of path changes in the MANET could have
adverse effect on the chain of DHCP relays between the
client and the DHCP server. Can anyone comment about
the applicability of DHCP in MANETs?

Fred

---

From: "Charles E. Perkins" <[email-masked]>
Date: Fri, 31 Mar 2006 13:59:33 -0800

Hello Fred,

Templin, Fred L wrote:

>   .....                 I am concerned that the
>client and the DHCP server.
>

I share this concern, and I think that as a practical matter
DHCP is not well suited for dynamic ad hoc networks.
For networks that have gateways to the Internet, schemes
have been worked out to rely on a stable DHCP server,
but even these seem vulnerable to failures, it seems to me.

Regards,
Charlie P.

---

From: "Templin, Fred L" <[email-masked]>
Date: Fri, 31 Mar 2006 14:14:18 -0800

I like the idea of allocating subnet prefixes to MANET routers
very much, but I have heard concerns voiced in other working
groups (TRILL, in particular) that allocating an entire /64
prefix to a router that may use only a small fraction of the
available address space is wasteful.

I realize that /64 is the finest granularity for subnet
assignment in IPv6, but it could be that not all routers
in a MANET will need to allocate prefixes for the purpose
of downstream delegation. Can there be a hybrid method
whereby MANET routers that need to allocate prefix(es) for
downstream delegation allocate as many /64s as they need
and other MANET routers delegate a /128, i.e., a host route?
(Those router that require prefixes for downstream delegation
at a later time could always defer the delegation until such
a time that the /64s are actually needed.) 

Fred

---

From: "Joe Macker" <[email-masked]>
Date: Fri, 31 Mar 2006 18:29:45 -0500

Charlie:

At least so you understand some of my thoughts better..
I don't have time tonight to say too much but let me say this.

I think I live in both worlds!

I see Dave's general approach as valid and supported presently. 
Its close to the architecture approach taken by manet-ospf type
developers,etc.
e.g., unnumbered addresses or link local addresses (IPv6) on manet
interfaces.
He may see it as the only approach (I'll let him answer that).

It was worrisome to me to see some people didn't realize this was already
taking place.
Perhaps bad communications on our part.

And I do feel people/companies etc can decide how to deploy things in their
own way.

I do not think these need to be standardized.
Perhaps BCPs at some point, if there is rough consensus, to better
communicate.

I agree requiring only one specific architecture approach is likely wrong,
but it helps to identify valid ones.
Thus when documenting solutions or best practices one can be specific about
particular architectural assumptions.

I also see the host/router or (all 1s prefix) approach as also valid.
I and many others have done stub PDA and laptop networks as such.
It doesn't really break things if you do it right.
So I didn't see "the sky falling"

It may make some local interface protocols unnecessary because its not an
Ethernet subnet model.
Some experimenters forget this and put a prefix mask on the MANET interface.

Use multicast link local for signalling (even in IPv4 I do not like
broadcast). 
Do a proper prefix assignment on that interface. 
This has been done for years. Support attached prefixes, no problem,
supported as well.

MORE ISSUES: I also had disagreements with introductory parts of the ID as
well.
We had early discussions with zeroconf,etc and we agreed their scope did not
include this model.
It seemd a little unnecessary to make all this arguments. The approach is
valid and useful without the arguments

Finally, I think its good to have these discussions and see if we can come
to some consensus.
Perhaps we can agree there are two types of valid architectural models and
proceed.

I agreed with you on the stronger MAC or link local uniqueness issue.
I think for wireless deployments this is an important issue.

I want to leave the option open to turn of DAD or be more passive if one can
trust one's deployment strategy.
These are intradomain protocols after all

Boy, I said more than I thought I had time for and got in trouble with the
wife! Got to go. 

>From: Charles E. Perkins [mailto:[email-masked]] 
>Sent: Friday, March 31, 2006 1:53 PM
>To: Joe Macker
>Cc: [email-masked]; [email-masked]
>Subject: Re: [Autoconf] Configuring 'default' in Multi-Subnet MANETs
>
>
>Hello Joe,
>
>I have some comments after your e-mail, about the presentation 
>made by Dave Thaler.
>
>Joe Macker wrote:
>
>>practices where it makes sense.  I'd  also like to hear if 
>someone has 
>>a reason why we should do something different.
>>  
>>
>First, I was surprised that Dave came out against host routes 
>for ad hoc networks.  This position is not stated clearly in 
>his drafts, and I find it worrisome because so much work in ad 
>hoc networks does use host routes.  I think it is _possible_ 
>to use link local addresses for forwarding packets to a 
>neighbor, but I shudder and worry if new protocol will be 
>"required" in order to assure that link-local addresses are 
>unique across an entire ad hoc network.
>If we suppose (a priori) that link-local addresses are unique, 
>without requiring additional protocol, then things can be made 
>to work more easily.  I still do not think it provides any 
>noticeable benefit over using IPv? addresses with global 
>scope, but at least there don't seem to be too many nasty 
>repercussions.  But that's _if_ we can assume that the 
>link-local addresses are unique without doing any real work.
>So, for instance, one could restrict the results of the 
>[autoconf] working group to apply only when the radio devices 
>can be assumed to come equipped with known unique MAC 
>addresses, from which known unique link-local addresses can be derived.
>
>One thing I tried to point out at the meeting, was that, 
>purely within the constraints imposed by IPv6, link-local 
>addresses are only known to be unique within a link.  In a 
>typical radio environment, a link is not so well-defined, but 
>it is typically either taken to be either the whole ad hoc 
>network, or a one-hop neighborhood of a node.  The former case 
>imposes the abovementioned strong requirement for globally 
>unique link-local addresses (e.g. by MAC address uniqueness).
>The latter case is quite tricky, and protocol solutions have 
>to deal with mobility and the dynamic nature of the 
>neighborhood.  Either way is treacherous it seems to me, 
>unless the working group is comfortable with assuming the 
>convenience of global uniqueness for MAC addresses.
>
>In short, I think that the proposal to use link-local 
>addresses is problematic, and does not offer any clear 
>advantages over using host routes.  Using unnumbered 
>interfaces for IPv4 is a somewhat different case, and as far 
>as I can tell it doesn't introduce terrible problems, but on 
>the other hand it doesn't provide any noticeable benefits 
>either as far as I can tell.  And, to be honest, I didn't 
>think about this case very much so I might have overlooked something.
>
>Regards,
>Charlie P.
>
>

---

From: "Dave Thaler" <[email-masked]>
Date: Fri, 31 Mar 2006 10:44:07 -0800

I agree with Joe.

Injecting a default route from the border router(s) into the routing
protocol in use is no different from injection of any other route from
any other router, and it's orthogonal to the issue of how to number
internal routers as discussed in the multisubnet-manets document.

-Dave

-----Original Message-----
From: Joe Macker [mailto:[email-masked]] 
Sent: Friday, March 31, 2006 10:20 AM
To: 'Templin, Fred L'; [email-masked]
Cc: Dave Thaler
Subject: RE: [Autoconf] Configuring 'default' in Multi-Subnet MANETs

Fred/All:

-Joe

---

From: "Dave Thaler" <[email-masked]>
Date: Fri, 31 Mar 2006 15:39:43 -0800

A good way to avoid wasting space in a particular environment 
like TRILL is to use a solution which does not involve 
decrementing TTL.  That is, a layer-2 (or 2.5) solution, 
rather than a layer-3 solution.

Once you start decrementing TTL, then you need /64s for
all the reasons discussed at IETF and in the two relevant
documents (support for all types of Ipv6 addresses (CGA,
temporary addresses, etc), non-MANET-client support, 
not breaking upper layer assumptions, etc.)

-Dave

-----Original Message-----
From: Templin, Fred L [mailto:[email-masked]] 
Sent: Friday, March 31, 2006 2:14 PM
To: [email-masked]
Cc: Dave Thaler
Subject: Avoiding wasted address space in Multi-Subnet MANETs

Fred