Subject: RE: [Autoconf] The case for address uniqueness

From: "Templin, Fred L" <[email-masked]>
Date: Thu, 2 Feb 2006 14:34:01 -0800

Charlie,

OK to most of what you said, but is there really such a thing
as "stateless" address autoconfiguration without also requiring
a robust DAD mechanism? DAD is hard in MANETs due to the reasons
you gave in an earlier message (partitions and merges) and it
won't be made easier when nodes start using interface ID generation
mechanisms like CGA instead of assigning an interface's MAC address.
Can we rely on optimistic DAD and/or DAD avoidance?

Thanks - Fred
[email-masked]

> -----Original Message-----
> From: Charles E. Perkins [mailto:[email-masked]] 
> Sent: Thursday, February 02, 2006 12:33 PM
> To: Templin, Fred L
> Cc: [email-masked]
> Subject: Re: [Autoconf] The case for address uniqueness
> 
> 
> Hello Fred,
> 
> 
> ext Templin, Fred L wrote:
> 
> >These discussions have been going on for so many years now that
> >it seems they may never converge on a "one-size-fits-all" solution
> >for MANET autoconfiguration.
> >
> This may not be a good indicator, though, since autoconfiguration has
> never been on the charter for MANET as far as I remember.
> 
> > Is there a chance we could steer
> >things toward a best current practices direction? If so, what
> >would they look like, e.g.:
> >
> >  - use IPv6 link-local for neighbor discovery
> >  
> >
> I would prefer not to make this constraint.  By doing so, the neighbor
> discovery process is then required to suffer multiple rounds 
> of signaling
> just to get neighbors to know the node's useful IP address.
> 
> >  - use IPv6 Unique Local Addresses (ULAs) for intra-MANET comm's
> >  
> >
> This sounds great for nodes that don't already have global addresses.
> 
> >  - use DHCPv6 to get a globally unique address for Internet comm's
> >  
> >
> I would prefer a stateless approach whenever it's available.
> 
> >Is there a chance we will see some convergence soon or will the
> >status remain quo for the forseeable future?
> >  
> >
> I guess both are very possible.  It's up to us!  The fact that the
> working group has been approved is a good sign, though.
> 
> Regards,
> Charlie P.
> 
> 
> 

_______________________________________________
Autoconf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/autoconf

---

From: "Pedro M. Ruiz" <[email-masked]>
Date: Fri, 03 Feb 2006 11:28:39 +0100

I think there is a very good reason to go for stateless address 
autoconfiguration which is that fact that the MANET must keep on working 
even if connectivity to Internet is completely lost for some period of 
time.

My second point is that if we agree that duplication is expected to be 
unlikely to happen, we can live with the assumption that there is no 
duplication. In case of duplication, we can let those nodes with 
duplicate addresses to solve the issue if its eventually happens. Given 
that it won't happen too often, peformance shouldn't be compromised by 
such DAD resolution scheme.

Regards,

--Pedro

---

From: "Charles E. Perkins" <[email-masked]>
Date: Fri, 03 Feb 2006 08:06:03 -0800

Hello Fred,

Templin, Fred L wrote:

>OK to most of what you said
>
Thanks!

> but is there really such a thing
>a robust DAD mechanism?
Briefly, yes -- but ...

> DAD is hard in MANETs due to the reasons
...as you hint, the tradeoff is likely to be in reliability.  In other 
words, _if_
one could design a stateful mechanism that was appropriate for disconnected
ad hoc networks, then that mechanism could probably be made more robust.
The impediments seem to include (probably there are others):
- substantially increased signaling
- creation of signaling hotspots
- single point of failure
- algorithmically difficult
- stateful ==> configuration requirements ==> not exactly ad hoc

My guess is that stateless will continue to be "better" for a while
until some new approaches are discovered and developed.
I'll bet that will not happen this year.  My other guess is that it
won't look like DHCP.

Regards,
Charlie P.

---

From: "Joe Macker" <[email-masked]>
Date: Fri, 3 Feb 2006 12:02:21 -0500

Fred:
I think those are some good points.

Some related experience with DAD in mobile systems is that its more
problematic when DAD is considered completely essential in all cases and
must be completed prior to allowing interface configuration. This can add
signficant delay and reliability problems. I believe you captured some
salient points for consideration and that some things should remain
deplyment specific.  I also feel a more general DAD solutions is welcome and
fine for edge system architectures that need it and can live with the
tradeoffs.

We should also remember IPv6 lends itself well to hybrid stateless and
stateful configuration concepts.

>From: [email-masked] 
>[mailto:[email-masked]] On Behalf Of Pedro M. Ruiz
>Sent: Friday, February 03, 2006 5:29 AM
>To: Templin, Fred L
>Cc: [email-masked]
>I think there is a very good reason to go for stateless 
>address autoconfiguration which is that fact that the MANET 
>must keep on working even if connectivity to Internet is 
>completely lost for some period of time. 
>
>My second point is that if we agree that duplication is 
>expected to be unlikely to happen, we can live with the 
>assumption that there is no duplication. In case of 
>duplication, we can let those nodes with duplicate addresses 
>to solve the issue if its eventually happens. Given that it 
>won't happen too often, peformance shouldn't be compromised by