Subject: RE: [Autoconf] The case for address uniqueness

From: "Templin, Fred L" <[email-masked]>
Date: Thu, 2 Feb 2006 11:05:51 -0800

Charlie and others,

These discussions have been going on for so many years now that
it seems they may never converge on a "one-size-fits-all" solution
for MANET autoconfiguration. Is there a chance we could steer
things toward a best current practices direction? If so, what
would they look like, e.g.:

  - use IPv6 link-local for neighbor discovery
  - use IPv6 Unique Local Addresses (ULAs) for intra-MANET comm's
  - use DHCPv6 to get a globally unique address for Internet comm's

Is there a chance we will see some convergence soon or will the
status remain quo for the forseeable future?

Fred
[email-masked]

> -----Original Message-----
> From: Charles E. Perkins [mailto:[email-masked]] 
> Sent: Thursday, February 02, 2006 10:17 AM
> To: Christophe Jelger
> Cc: [email-masked]
> Subject: Re: [Autoconf] The case for address uniqueness
> 
> 
> Hello Christophe,
> 
> I would like to support the view that we should
> avoid requirements for a strong DAD mechanism.
> 
> Christophe Jelger wrote:
> 
> >
> > I agree, but whatever solution one designs there can always 
> be cases 
> > of address collisions (network merges, manually configured 
> addresses). 
> > Thus I think the focus should be on address collision 
> detection+repair.
> >
> 
> I have two thought experiments that lead me to believe that duplicate
> address detection is properly the responsibility for the 
> nodes that own
> the duplicated address.
> 
> (1): What if a node moves so fast between two parts of the network
>        that it "seems" to be in two places?   One could 
> easily imagine that
>        such movement would fit within the time periods 
> defined by local
>        "hello" messages, depending on the range of radio transmission.
> 
> (2) What if one node leaves the network, and later rejoins?  This is
>       certainly a network partition.  If each such event 
> causes the network
>       to initiate global signaling for DAD, then a meltdown is almost
>       guaranteed eventually.  How can we distinguish between a reboot
>       and a temporary node departure?  Is there any real difference as
>       far as the network is concerned?
> 
> If the node itself detects duplication by any of several heuristics,
> then it can (a) borrow a new temporary address and (b) take
> corrective action.
> 
> Regards,
> Charlie P.
> 
> 
> 
> 
> _______________________________________________
> Autoconf mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/autoconf
> 

_______________________________________________
Autoconf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/autoconf

---

From: "Charles E. Perkins" <[email-masked]>
Date: Thu, 02 Feb 2006 12:32:39 -0800

Hello Fred,

ext Templin, Fred L wrote:

>for MANET autoconfiguration.
>
This may not be a good indicator, though, since autoconfiguration has
never been on the charter for MANET as far as I remember.

> Is there a chance we could steer
I would prefer not to make this constraint.  By doing so, the neighbor
discovery process is then required to suffer multiple rounds of signaling
just to get neighbors to know the node's useful IP address.

>  - use IPv6 Unique Local Addresses (ULAs) for intra-MANET comm's
This sounds great for nodes that don't already have global addresses.

>  - use DHCPv6 to get a globally unique address for Internet comm's
I would prefer a stateless approach whenever it's available.

>status remain quo for the forseeable future?
I guess both are very possible.  It's up to us!  The fact that the
working group has been approved is a good sign, though.

Regards,
Charlie P.