Subject: Fwd: I-D ACTION:draft-nottingham-atompub-feed-history-06.txt

From: Mark Nottingham <[email-masked]>
Date: Wed, 28 Jun 2006 17:06:41 -0700

As discussed earlier.

Begin forwarded message:

> From: [email-masked]
> Date: 28 June 2006 3:50:01 PM
> To: [email-masked]
> Subject: I-D ACTION:draft-nottingham-atompub-feed-history-06.txt
> Reply-To: [email-masked]
>
> A New Internet-Draft is available from the on-line Internet-Drafts  
> directories.
>
>
> 	Title		: Extensions for Multi-Document Syndicated Feeds
> 	Author(s)	: M. Nottingham
> 	Filename	: draft-nottingham-atompub-feed-history-06.txt
> 	Pages		: 17
> 	Date		: 2006-6-28
> 	
> This specification defines three types of syndicated feeds that
>    enable publication of entries across one or more feed documents.
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-nottingham-atompub-feed- 
> history-06.txt
>
> To remove yourself from the I-D Announcement list, send a message to
> [email-masked] with the word unsubscribe in the body  
> of the message.
> You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
> to change your subscription settings.
>
>
> Internet-Drafts are also available by anonymous FTP. Login with the  
> username
> "anonymous" and a password of your e-mail address. After logging in,
> type "cd internet-drafts" and then
> 	"get draft-nottingham-atompub-feed-history-06.txt".
>
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
>
> Internet-Drafts can also be obtained by e-mail.
>
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE /internet-drafts/draft-nottingham-atompub-feed-history-06.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
> 		
> 		
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> Content-Type: text/plain
> Content-ID: <[email-masked]>
>
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/i-d-announce

--
Mark Nottingham     http://www.mnot.net/

---

From: James M Snell <[email-masked]>
Date: Thu, 29 Jun 2006 19:45:31 -0700

A couple of comments...

Section 6

   Archive documents are feed documents that contain less recent entries
   in the feed.  The set of entries contained in an archive document
   published at a particular URI MUST NOT change over time.

I definitely understand the motivation for the "MUST NOT" here, but I'm
not sure if it's enforceable.  For instance, on my blog, I may go back
and delete an old entry that appears within an archive feed.  Such a
change should be reflected in the archive feed.  I would recommend
changing this to a "SHOULD NOT" with a comment that removing entries
from an archive document has a negative impact on the cacheability of
the document and the effectiveness of the archive.

Section 6.1

The archive document examples do not have the <fh:archive /> element

Mark Nottingham wrote:
>> http://www.ietf.org/internet-drafts/draft-nottingham-atompub-feed-history-06.txt
>>
>>
>> [email-masked] with the word unsubscribe in the body of
>> the message.

---

From: Stefan Eissing <[email-masked]>
Date: Fri, 30 Jun 2006 10:14:40 +0200

Mark, my comments to the document:

- much easier to understand with the split of the 3 use cases
- very nice that archive documents are supposed to be frozen and  
fixed (dunno when that changed, but I think it was not so from the  
start)

2 minor nitpicks (hey, its me):

- it seems that "logical feed" and "syndicated feed" is the very same  
thing. Maybe agreeing on one term would benefit the document? (Or  
explain the difference...)

- should the Atom-formatted Archive Document on page 10 have an  
fh:archive element?

Cheers, Stefan

Am 29.06.2006 um 02:06 schrieb Mark Nottingham:

>> [email-masked] with the word unsubscribe in the  
>> body of the message.
>> Internet-Drafts are also available by anonymous FTP. Login with  
>> the username