Subject: Atom feeds and S3

From: "M. David Peterson" <[email-masked]>
Date: Wed, 12 Apr 2006 23:33:31 -0600

FYI...
http://developer.amazonwebservices.com/connect/thread.jspa?messageID=37055&#37055

--
<M:D/>

M. David Peterson
http://www.xsltblog.com/

---

From: James M Snell <[email-masked]>
Date: Wed, 12 Apr 2006 23:00:17 -0700

The Atom output is invalid.

Wrong date format
<updated>4/13/2006 12:31:22 AM</updated>
<updated>4/13/2006 12:31:22 AM</updated>
<updated>4/13/2006 12:31:22 AM</updated>

Whitespace in ID
<id> http://s3.amazonaws.com/dds</id>
<id> http://s3.amazonaws.com/dds/37MB?torrent</id>
<id> http://s3.amazonaws.com/dds/6MB?torrent</id>

Invalid link syntax
<link> http://s3.amazonaws.com/dds/37MB</link>
<link> http://s3.amazonaws.com/dds/6MB</link>

- James

M. David Peterson wrote:
> <http://developer.amazonwebservices.com/connect/thread.jspa?messageID=37055&#37055>
> 
> -- 
> <M:D/>
> 
> M. David Peterson
> http://www.xsltblog.com/

---

From: "M. David Peterson" <[email-masked]>
Date: Thu, 13 Apr 2006 00:08:22 -0600

Yeah, I realized that when I looked at it... but instead of pointing at the
problems I figured I would point him at the feedvalidator and see what the
result is.  This guy (Dominic) is a pure hacker at heart, releasing a new
version of his commandline tool every other day or so for the last 3
weeks... The first release was in Java, and now he has followed up with a C#
port of the Java app.  It has some cool features that no one else had really
even considered, showcased quite nicely by his RSS update a bit earlier this
evening, to be followed only an hour or two after my request by the Atom
version.

So it seemed to me pointing him at the feedvalidator instead of pointing out
all of the problems in the public S3 forums was the smarter route.  If it
turns out they're still invalid when he releases, its completely open
source, so I will take a few moments and provide the fixes and send it back
to him in private.  One way or the other we still get valid Atom and RSS, so
I figure its probably worth holding things back and after he releases the
update, if necessary, handle things from there.

As soon as something tangible and valid is ready to go, I'll ping back this
same thread.  Based on how fast this guy codes, it shouldnt take long. :)

On 4/13/06, James M Snell <[email-masked]> wrote:
> > <

--
<M:D/>

M. David Peterson
http://www.xsltblog.com/

---

From: "M. David Peterson" <[email-masked]>
Date: Thu, 13 Apr 2006 00:21:59 -0600

re: Invalid link syntax

Are you refering to the white space or
the '37MB' (or both)?  Just to note, the 37MB is an object on the S3 server
in which you can store meta data along with an ACL-based XML rights file to
determin who can access the
file.  It might very well represent a 37MB video file called
foobar.avi, but when you upload a file to the S3 servers, you can name
it anything you want, which can include several characters, such as
the '/', that would otherwise not be allowed in a file name.  The
point is to provide
the ability to simulate a file system (e.g. /path/to/file/file.html),
when in fact thats the name of the actual
file, thus building on top of a single root based file system that
uses the term 'bucket' to represent the /base folder, and object to
represent the file itself
inside of each bucket.

Obviously the purpose is optimization of the file
path via globbing the file objects, while at the same time allowing
for ease of duplication as data redundancy is a built in requirement
the uses to build the system and push it out over a decentralized
server surface.

--
<M:D/>

M. David Peterson
http://www.xsltblog.com/

---

From: James M Snell <[email-masked]>
Date: Wed, 12 Apr 2006 23:27:01 -0700

It should be <link href="http://s3.amazonaws.com/dds/37MB" />

M. David Peterson wrote:
> in which you can store meta data along with an ACL-based XML rights file
> to determin who can access the
> foobar.avi, but when you upload a file to the S3 servers, you can name it anything you want, which can include several characters, such as the '/', that would otherwise not be allowed in a file name.  The point is to provide
> the ability to simulate a file system (
> e.g. /path/to/file/file.html), when in fact thats the name of the actual
> file, thus building on top of a single root based file system that uses the term 'bucket' to represent the /base folder, and object to represent the file itself
> inside of each bucket.
> 
> path via globbing the file objects, while at the same time allowing for ease of duplication as data redundancy is a built in requirement the uses to build the system and push it out over a decentralized server surface.
>

---

From: "M. David Peterson" <[email-masked]>
Date: Thu, 13 Apr 2006 11:38:28 -0600

:D  Okay, now I feel like an idiot :D

Right on... well I'll make sure that the output validates for both Atom and
RSS and ping back when it does.

Thanks for the follow-up!

On 4/13/06, James M Snell <[email-masked]> wrote:
> it anything you want, which can include several characters, such as the '/',
> that would otherwise not be allowed in a file name.  The point is to provide
> > file, thus building on top of a single root based file system that uses
> the term 'bucket' to represent the /base folder, and object to represent the
> file itself
> > inside of each bucket.
> >
> > path via globbing the file objects, while at the same time allowing for
> ease of duplication as data redundancy is a built in requirement the uses to
> build the system and push it out over a decentralized server surface.
> >
>
>

--
<M:D/>

M. David Peterson
http://www.xsltblog.com/

---

From: "M. David Peterson" <[email-masked]>
Date: Thu, 13 Apr 2006 12:16:39 -0600

Dominic's recent reply:

Yes I will ensure they are valid using feedvalidator.
> Thanks.
> -Dominic

On 4/13/06, M. David Peterson <[email-masked]> wrote:
> Right on... well I'll make sure that the output validates for both Atom
> and RSS and ping back when it does.
>
> > for ease of duplication as data redundancy is a built in requirement the
> > uses to build the system and push it out over a decentralized server
> > surface.
> > >
> >
> >
>
>
> --
>
> <M:D/>
>
> M. David Peterson
> http://www.xsltblog.com/
>

--
<M:D/>

M. David Peterson
http://www.xsltblog.com/

---

From: "M. David Peterson" <[email-masked]>
Date: Fri, 14 Apr 2006 16:14:03 -0600

fyi... from >
http://developer.amazonwebservices.com/connect/message.jspa?messageID=37110#37110

---
#Sh3ll 2.0 is now available...

#Sh3ll (Amazon S3 command shell for C#)

The #Sh3ll (pronounced sharp-shell) is a C# based command shell for managing
your Amazon S3 objects.
It is built upon the Amazon S3 REST C# library.
#Sh3ll has been built with Microsoft .NET 1.1

This is an enhancement release:
1. Added "listrss" command, which outputs a valid RSS 2.0 feed for a
bucket's item listing.
2. Added "listatom" command, which outputs a valid Atom 1.0 feed for a
bucket's item listing.
3. Added command runtime display.

Download

Get #Sh3ll-2 .0.zip now ! >
http://s3.amazonaws.com/sharpSh3ll/sharpSh3ll-2.0.zip
---

On 4/13/06, M. David Peterson < [email-masked]> wrote:
> On 4/13/06, James M Snell < [email-masked]> wrote:
>
> >

--
<M:D/>

M. David Peterson
http://www.xsltblog.com/