Subject: New list member

From: Kirit Sælensminde <[email-masked]>
Date: Fri, 7 Apr 2006 22:04:09 +0700

I’m new to the list so I thought I’d introduce myself (I have no idea if this is the right thing to do or not, but still). I have been reading the archives and it all looks pretty interesting, not to mention informative. It certainly cleared up some questions I had about the semantics of some items included in our first feed.

My company is a small software house and we build ERM systems, traditionally for telcos and financial institutions. I won’t bore everyone with details that you won’t find interesting, suffice it to say that the latest version of our development system (FOST.3) is now in beta and including Atom feeds is part of that process.

The only public system showing the new version of the technology is on my web site (http://www.kirit.com/) where we also have an Atom 1.0 feed (http://www.kirit.com/_fslib/_content/atom.asp), which is pretty basic, but at least seems to conform to the spec (at least as far as the validator and our understanding of the spec is concerned).

Probably of more interest is that we will be bringing online some other sites during the next few months that will feature some extra linguistic complications. Specifically we are planning one site entirely in Thai and another site that will be published in a mixture of English and Norwegian, with many items in both. We also have some permissioning requirements as the same logical feed will need to contain different content depending on the security profile of the entity picking the feed up.

Kirit Sælensminde

CTO, FSL Technologies Ltd

http://www.kirit.com/ <http://www.kirit.com/>

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Mon, 10 Apr 2006 08:27:23 +0200

On Fri, Apr 07, 2006 at 10:04:09PM +0700,
 Kirit Saensminde <[email-masked]> wrote 
 a message of 150 lines which said:

> we also have an Atom 1.0 feed
> (http://www.kirit.com/_fslib/_content/atom.asp), which is pretty
> basic, but at least seems to conform to the spec (at least as far as
> the validator and our understanding of the spec is concerned).

rnv and xmllint approves it, too :-)

> We also have some permissioning requirements as the same logical
> feed will need to contain different content depending on the
> security profile of the entity picking the feed up.

It has to be done on the server, since, by definition, you cannot
trust the client. So, I would say it is off-topic for Atom.