Subject: Re: xml:base in your Atom feed

From: "M. David Peterson" <[email-masked]>
Date: Sat, 1 Apr 2006 07:49:29 -0700

> Hosting is not the point.

Yep.  'tis why I said the word "backup".

On 3/31/06, A. Pagaltzis <[email-masked]> wrote:
>
>
> * M. David Peterson <[email-masked]> [2006-04-01 03:15]:
> > Obviously the main wiki would be better, but if this can act as
> > a backup plan, then let me know if and when and I will set up
> > access to that box for you.
>
> Hosting is not the point. I have webspace and I can link files I
> host from the main wiki, as before. Collaboration is the point.
> I'm hoping for a way for anyone to pitch in without having to
> fight any red tape, so that the test suite can be expanded by
> whoever happens to have a spare tuit.
>
> Regards,
> --
> Aristotle Pagaltzis // <http://plasmasturm.org/>
>
>

--
<M:D/>

M. David Peterson
http://www.xsltblog.com/

---

From: "M. David Peterson" <[email-masked]>
Date: Thu, 20 Apr 2006 18:17:25 -0600

* FOR THE ARCHIVES ONLY -- CORRECTION OF AN ERROR ON A NOW DEAD
DISCUSSION.  DON'T WORRY ABOUT READING THIS *

While on the topic of mis-reads (see April 20th response to James
Snell re: Known FeedDemon issue? if reading this in the archives and
actually care enough to seek out proper context), I need to repent of
this misread:

My response:

>> and here I was holding this inside of me as I always assumed
>> "obviously it's implemented for a reason"....

>> This makes me happy :)  Thanks Sam!

came from reading this:

> > As late as this morning, all link/@href attributes in my Atom feed
> > contained absolute URIs.

skimming to this:

> > It would be helpful if people were to update:
> >
> > http://intertwingly.net/wiki/pie/XmlBaseConformanceTests

and assuming this was Sam simply stating that using full URI's should
be considered a best practice.

The next day I reread and realized my mistake, but decided then to
just let it be.  But in realizing that people might read the archives
and walk away completely baffled by my response I decided it would be
best to get this error properly documented.

On 3/31/06, M. David Peterson <[email-masked]> wrote:
> and here I was holding this inside of me as I always assumed
> "obviously it's implemented for a reason"....
>
> This makes me happy :)  Thanks Sam!
>
> On 3/31/06, Sam Ruby <[email-masked]> wrote:
> >
> > Antone Roundy wrote:
> > > On Mar 31, 2006, at 4:12 PM, Sam Ruby wrote:
> > >
> > >> Antone Roundy wrote:
> > >>
> > >>> Sam,
> > >>>
> > >>> Funny that this should come up today given the recent discussion  on
> > >>> the
> > >>> mailing list--NetNewsWire isn't getting the links in your Atom  feed
> > >>> right.
> > >>
> > >> There is an off chance that I have been following the list.  ;-)
> > >
> > > I certainly didn't mean to imply that you weren't--I just wanted to
> > > point out what I'm seeing in case you didn't know that this  particular
> > > feed reader is having this particular problem today.  And  I thought it
> > > might be of interest to the WG to know what NNW is doing  given that
> > > it's doing something that has been argued against within  the last 24
> > > hours.
> >
> > ;-)
> >
> > > I don't remember which version of your feed I was subscribed to
> > > before--perhaps I wasn't subscribed to the Atom feed and NNW updated  my
> > > subscription when you redirected to it. So I don't know whether  you
> > > purposely removed xml:base to see what chaos would ensue, or  whether it
> > > hasn't been there all along and I just haven't seen the  problem since I
> > > was subscribed to a different version.
> >
> > As late as this morning, all link/@href attributes in my Atom feed
> > contained absolute URIs.
> >
> > One of the original problems that Atom set out to solve was the desire
> > by people to use relative URIs.  Even in their content.  In fact,
> > PARTICULARLY in their content.
> >
> > My recent post of Common Feed Errors demonstrate that this demand
> > certainly exists - even in RSS:
> >
> > http://www.intertwingly.net/blog/2006/03/13/Common-Feed-Errors
> >
> > It would be helpful if people were to update:
> >
> > http://intertwingly.net/wiki/pie/XmlBaseConformanceTests
> >
> > - Sam Ruby
> >
> >
>
>
> --
> <M:D/>
>
> M. David Peterson
> http://www.xsltblog.com/
>

--
<M:D/>

M. David Peterson
http://www.xsltblog.com/