Subject: Re: [arch-d] Name this concept

From: Schumacher Laurent <[email-masked]>
Date: Thu, 02 Mar 2006 08:19:43 +0100

Hello,

John Leslie wrote :

>> ... while the Locator is a network layer address, the Endpoint
>> Identifier is a session layer concept, and what we're really saying
>> is that we need some form of session management layer that lives
>> *above* the transport.
>
>   I agree. I'm not particular about the name; but there are many
>reasons to work on "session management":
>
>- mobility;
>- security;
>- congestion;
>- pre-emption;
>- Quality-of-Service;
>- et cetera.
>
Isn't it what Session Initiation Protocol (SIP, RFC 3261) is addressing?

Just my two cents,
LS

-- 
Laurent Schumacher <[email-masked]>
Computer Science Institute, FUNDP - The University of Namur
------------------------------------------------------------
        Web page: http://www.info.fundp.ac.be/~lsc/
------------------------------------------------------------

_______________________________________________
Architecture-discuss mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/architecture-discuss

---

From: John Leslie <[email-masked]>
Date: Thu, 2 Mar 2006 19:18:32 -0500

> Isn't it what Session Initiation Protocol (SIP, RFC 3261) is addressing?

   To tell truth, I don't know. I took RFC3261 at its word:
" 
" SIP is an agile, general-purpose tool for creating, modifying, and
" terminating sessions that works independently of underlying transport
" protocols and without dependency on the type of session that is being
" established.

... which is pretty open-ended. OTOH, it goes into so many details of
multimedia that I'm left scratching my head whether it can deal with
anything else.

   In any case, when I say "TCP-bis session" I'm thinking of ordinary
stuff like web-surfing, instant messaging, and email, not multimedia.

   Perhaps someone else can enlighten us whether SIP sessions are
the right animal to be discussing? (I'd be happy to start saying
"SIP session" instead of "TCP-bis session"...)

--
John Leslie <[email-masked]>

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 02 Mar 2006 22:05:48 -0500

SIP's strength lies in achieving rendezvous. It is not a transport 
protocol, though some would use it that way. With multimedia and with 
any other application, the details of flow specification  are in the 
message body, not technically part of the SIP protocol itself. SIP does 
have protocol support for the negotiation process before the session is 
set up.