Subject: RE: [Adslmib] VDSL2 draft draft-ietf-adslmib-vdsl2-01.txt

From: "Edward Beili" <[email-masked]>
Date: Sun, 27 Aug 2006 22:07:37 +0300

Menachem,
The so called G.Bond effort in the ITU-T included 3 specifications: G.998.1 (ATM), G.998.2 (Ethernet) and G.998.3 (TDIM). I would like you to add the 3rd bonding specification G.998.3 to the liaison.
 
Note that all 3 specifications are pretty different, e.g. G.998.1 and G.998.2 define only a single service (ATM and Ethernet respectively), while G.998.3 is a multi-service protocol, with a specific service allocation configuration. My personal view is that a separate MIB is required for each bonding protocol.
 
Thanks,
-Edward

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Sunday, August 27, 2006 10:21 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Adslmib] VDSL2 draft draft-ietf-adslmib-vdsl2-01.txt

Frank, 

        Thank you for  your comments, I have modified the second paragraph. 

Best Regards, 
Menachem Dodge

[email-masked] 

25/08/2006 08:37 

To
[email-masked] 

cc
[email-masked], [email-masked], [email-masked], [email-masked], [email-masked], "Romascanu, Dan \(Dan\)" <[email-masked]> 

Subject
Re: [Adslmib] VDSL2 draft draft-ietf-adslmib-vdsl2-01.txt

Menachem,
Could you make it clearer in the liaison that the request to DSLForum to address bonding is not in the context of WT-129? The "issue" your text proposal refers to is that "bonding is not addressed by DSLF". The issue is not that "bonding is not addressed in WT-129". Or did you intentionally leave this point vague ?
Thanks,
Frank

 <mailto:[email-masked]> [email-masked] wrote: 

Hi, 

       There appears to be enough interest in the xDSL Bonding issue, and there have not been any objections. 

Therefore, I propose the following: 

        1. I will send a liaison to the DSL Forum in response to WT-129 asking them to address the issue of xDSL Bonding. 
                    Please review the attached liaison and let me know if you have any remarks. Does anyone have any other issues 
                    that they would like to raise, regarding WT-129 ? 

        2. I have spoken with Edward Beili, the editor of the draft-ietf-hubmib-efm-cu-mib-05 and we agree that there is a 
                    good chance that we can re-use the ifAvailableStack Table. Therefore, as this document is not yet published, 
                    I will send an email to Dan and Edward requesting that Edward separate out this table and generalize the 
                    comments to allow for bonding of all xDSL types. 

        3. Once we receive a response from the DSL Forum and also from Edward and Dan regarding the hubmib cu mib we can then 
                    decide how best to proceed. A charter change will be required before any work can be done on this subject. 

We need to move the VDSL2 MIB forward.  The latest VDSL2 draft is draft-ietf-adslmib-vdsl2-01.txt. Does anyone have any comments? 

Best Regards, 
Menachem Dodge

 <mailto:[email-masked]> <[email-masked]> 

22/08/2006 09:51 

To
 <mailto:[email-masked]> <[email-masked]>,  <mailto:[email-masked]> <[email-masked]>,  <mailto:[email-masked]> <[email-masked]> 

cc
 <mailto:[email-masked]> [email-masked],  <mailto:[email-masked]> [email-masked] 

Subject
RE: [Adslmib] VDSL2 draft draft-ietf-adslmib-vdsl2-01.txt

Clay, 
  
I did go through the hubmib EFM draft, looking at it from bonding perspective. 
  
- The draft-ietf-hubmib-efm-cu-mib-05 is based on IEEE 802.3ah-2004 (not on G.998.2). 
  
- ITU-T G.998.2 refers to the IEEE standard for most part; but it generalizes the Ethernet bonding to all xDSL technologies. 
  
- ITU-T G.998.2 doesn’t restrict Ethernet bonding to SHDSL and VDSL alone (which IEEE 802.3ah-2004 does). 
  
My views are: 
a)       We should have a separate MIB for xDSL bonding 
b)       Generalize as far as possible taking both G.998.1 and G.998.2 into account 
  
Regards 
Naren 

  _____  

From: Clay Sikes [  <mailto:[email-masked]> mailto:[email-masked]] 
Sent: Monday, August 21, 2006 7:42 PM
To: Narendranath Nair (WT01 - Broadband Networks);  <mailto:[email-masked]> [email-masked]
Cc:  <mailto:[email-masked]> [email-masked];  <mailto:[email-masked]> [email-masked]
Subject: Re: [Adslmib] VDSL2 draft draft-ietf-adslmib-vdsl2-01.txt 
  
Hi,

I thought that G.998.1 is commonly used to bond ADSL while G.998.2 via IEEE 802.3ah is commonly used to bond SHDSL and VDSL.
Naren, have you looked at the draft-ietf-hubmib-efm-cu-mib-05 for G.998.2/IEEE 802.ah?

It does seem like there needs to be a MIB for G.998.1.

Regards, 
Clay

On 8/21/2006 6:15 AM,  <mailto:[email-masked]> [email-masked] wrote: 
Frank, 
  
Shouldn’t we take into consideration ITU-T G.998.1 also, and have one common model for both ATM and Ethernet bonding? 
  
Regards 
Naren 

  _____  

From:  <mailto:[email-masked]> [email-masked] [  <mailto:[email-masked]> mailto:[email-masked]] 
Sent: Monday, August 21, 2006 1:57 PM
To:  <mailto:[email-masked]> [email-masked]
Cc:  <mailto:[email-masked]> [email-masked]
Subject: Re: [Adslmib] VDSL2 draft draft-ietf-adslmib-vdsl2-01.txt 
  
Menachem,
The bonding should not be addressed within the VDSL2 MIB. The ITU-T G.998.2 Ethernet bonding standard aplies to SHDSL, ADSL(2)(plus) and VDSL2. It should be addressed separately, as management of a bonding layer on top of the physical layer, hence on top of the VDSL2 MIB, and not as part of it.
Regards,
Frank

 <mailto:[email-masked]> [email-masked] wrote:

Hi, 

       The VDSL2 draft draft-ietf-adslmib-vdsl2-01.txt was posted two weeks ago. 

       I hope that everyone is reviewing this document. 

       There has been no response regarding the xDSL Bonding issue raised two weeks ago. Does this imply no interest? 
Editors? Anyone? 

Best Regards, 
Menachem.

  

  _____  

  
_______________________________________________ 
Adslmib mailing list 
 <mailto:[email-masked]> [email-masked] 
 <https://www1.ietf.org/mailman/listinfo/adslmib> https://www1.ietf.org/mailman/listinfo/adslmib 

  _____  

_______________________________________________ 
Adslmib mailing list 
 <mailto:[email-masked]> [email-masked] 
 <https://www1.ietf.org/mailman/listinfo/adslmib> https://www1.ietf.org/mailman/listinfo/adslmib 
  _______________________________________________
Adslmib mailing list
 <mailto:[email-masked]> [email-masked]
 <https://www1.ietf.org/mailman/listinfo/adslmib> https://www1.ietf.org/mailman/listinfo/adslmib

  _____  

Subject: Response To Your Liaison on WT-129.

Date:  24th August, 2006.

To:    Gavin Young, 
      DSL Forum Technical Committee Chair
      "Gavin Young"  <mailto:[email-masked]> <[email-masked]>

      Peter Adams, 
      DSL Forum Operations and Network Management Working Group Chair
      "Peter Adams"  <mailto:[email-masked]> <[email-masked]>

Cc:    IETF  <mailto:[email-masked]> [email-masked]
       <mailto:[email-masked]> [email-masked]
       
      Loa Andersson
      "Loa Andersson"  <mailto:[email-masked]> <[email-masked]>

      Dan Romascanu
      Operations and Management Area Director
      "Romascanu, Dan"  <mailto:[email-masked]> <[email-masked]>

      Michael Sneed
      IETF ADSL MIB Working Group Co-Chair
      "Michael Sneed"  <mailto:[email-masked]> [email-masked]

From:  IETF ADSL MIB Working Group

Response  contact:                  Menachem Dodge
                       IETF ADSL MIB Working Group Co-Chair
                       "Menachem Dodge"  <mailto:[email-masked]> <[email-masked]>

Technical contact:      "Menachem Dodge"  <mailto:[email-masked]> <[email-masked]>

PURPOSE: Response

Subject: Response To Your Liaison on WT-129.

Dear Gavin and Peter,

                Thank you for your liaison and WT-129 Version 3.0. We would be very grateful if
you would continue to keep us informed of any changes to this Working Text document.

                In response to WT-129, we would like to raise the issue of xDSL Bonding, as 
defined by the ITU-T documents G.998.1 and G.998.2, but is currently not addressed in 
WT-129. The IETF ADSL MIB Working Group believes that this issue is important
and would be very pleased if the DSL Forum Operations and Network Management Working Group
would address this issue.

                Yours Sincerely,

                Menachem Dodge
       IETF ADSL MIB Working Group Co-Chair

_______________________________________________
Adslmib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/adslmib

---

From: [email-masked]
Date: Mon, 28 Aug 2006 09:58:58 +0300

Edward,

        Thank you for pointing this out. I have now added G.998.3 to the 
liaison.

        Does anyone have any further comments?

Best Regards,
Menachem

"Edward Beili" <[email-masked]> 
27/08/2006 22:07

To
<[email-masked]>, <[email-masked]>
cc
<[email-masked]>, <[email-masked]>, 
<[email-masked]>, <[email-masked]>
Subject
RE: [Adslmib] VDSL2 draft draft-ietf-adslmib-vdsl2-01.txt

Menachem,
The so called G.Bond effort in the ITU-T included 3 specifications: 
G.998.1 (ATM), G.998.2 (Ethernet) and G.998.3 (TDIM). I would like you to 
add the 3rd bonding specification G.998.3 to the liaison.
 
Note that all 3 specifications are pretty different, e.g. G.998.1 and 
G.998.2 define only a single service (ATM and Ethernet respectively), 
while G.998.3 is a multi-service protocol, with a specific service 
allocation configuration. My personal view is that a separate MIB is 
required for each bonding protocol.
 
Thanks,
-Edward
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Sunday, August 27, 2006 10:21 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]; 
[email-masked]

Frank, 

        Thank you for  your comments, I have modified the second 
paragraph. 

Best Regards, 
Menachem Dodge

To
[email-masked] 
cc
[email-masked], [email-masked], [email-masked], 
[email-masked], [email-masked], "Romascanu, Dan 
\(Dan\)" <[email-masked]> 
Subject
Re: [Adslmib] VDSL2 draft draft-ietf-adslmib-vdsl2-01.txt

Menachem,
Could you make it clearer in the liaison that the request to DSLForum to 
address bonding is not in the context of WT-129? The "issue" your text 
proposal refers to is that "bonding is not addressed by DSLF". The issue 
is not that "bonding is not addressed in WT-129". Or did you intentionally 
leave this point vague ?
Thanks,
Frank

[email-masked] wrote: 

Hi, 

       There appears to be enough interest in the xDSL Bonding issue, and 
there have not been any objections. 

        1. I will send a liaison to the DSL Forum in response to WT-129 
asking them to address the issue of xDSL Bonding. 
                    Please review the attached liaison and let me know if 
you have any remarks. Does anyone have any other issues 
                    that they would like to raise, regarding WT-129 ? 

        2. I have spoken with Edward Beili, the editor of the 
draft-ietf-hubmib-efm-cu-mib-05 and we agree that there is a 
                    good chance that we can re-use the ifAvailableStack 
Table. Therefore, as this document is not yet published, 
                    I will send an email to Dan and Edward requesting that 
Edward separate out this table and generalize the 
                    comments to allow for bonding of all xDSL types. 

        3. Once we receive a response from the DSL Forum and also from 
Edward and Dan regarding the hubmib cu mib we can then 
                    decide how best to proceed. A charter change will be 
required before any work can be done on this subject. 

We need to move the VDSL2 MIB forward.  The latest VDSL2 draft is 
draft-ietf-adslmib-vdsl2-01.txt. Does anyone have any comments? 

Best Regards, 
Menachem Dodge

<[email-masked]> 
22/08/2006 09:51 

To
<[email-masked]>, <[email-masked]>, 
<[email-masked]> 
cc
[email-masked], [email-masked] 
Subject
RE: [Adslmib] VDSL2 draft draft-ietf-adslmib-vdsl2-01.txt

Clay, 
  
I did go through the hubmib EFM draft, looking at it from bonding 
perspective. 
  
- The draft-ietf-hubmib-efm-cu-mib-05 is based on IEEE 802.3ah-2004 (not 
on G.998.2). 
  
- ITU-T G.998.2 refers to the IEEE standard for most part; but it 
generalizes the Ethernet bonding to all xDSL technologies. 
  
- ITU-T G.998.2 doesn’t restrict Ethernet bonding to SHDSL and VDSL alone 
(which IEEE 802.3ah-2004 does). 
  
My views are: 
a)       We should have a separate MIB for xDSL bonding 
b)       Generalize as far as possible taking both G.998.1 and G.998.2 
into account 
  
Regards 
Naren 

From: Clay Sikes [mailto:[email-masked]] 
Sent: Monday, August 21, 2006 7:42 PM
To: Narendranath Nair (WT01 - Broadband Networks); 
[email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [Adslmib] VDSL2 draft draft-ietf-adslmib-vdsl2-01.txt 
  
Hi,

I thought that G.998.1 is commonly used to bond ADSL while G.998.2 via 
IEEE 802.3ah is commonly used to bond SHDSL and VDSL.
Naren, have you looked at the draft-ietf-hubmib-efm-cu-mib-05 for 
G.998.2/IEEE 802.ah?

Regards, 
Clay

On 8/21/2006 6:15 AM, [email-masked] wrote: 
Frank, 
  
Shouldn’t we take into consideration ITU-T G.998.1 also, and have one 
common model for both ATM and Ethernet bonding? 
  
Regards 
Naren 

From: [email-masked] [
mailto:[email-masked]] 
Sent: Monday, August 21, 2006 1:57 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [Adslmib] VDSL2 draft draft-ietf-adslmib-vdsl2-01.txt 
  
Menachem,
The bonding should not be addressed within the VDSL2 MIB. The ITU-T 
G.998.2 Ethernet bonding standard aplies to SHDSL, ADSL(2)(plus) and 
VDSL2. It should be addressed separately, as management of a bonding layer 
on top of the physical layer, hence on top of the VDSL2 MIB, and not as 
part of it.
Regards,
Frank

[email-masked] wrote:

Hi, 

       The VDSL2 draft draft-ietf-adslmib-vdsl2-01.txt was posted two 
weeks ago. 

       There has been no response regarding the xDSL Bonding issue raised 
two weeks ago. Does this imply no interest? 
Editors? Anyone? 

Best Regards, 
Menachem.

  

  

Date:  24th August, 2006.

To:    Gavin Young, 
      DSL Forum Technical Committee Chair
      "Gavin Young" <[email-masked]>

      Peter Adams, 
      DSL Forum Operations and Network Management Working Group Chair
      "Peter Adams" <[email-masked]>

Cc:    IETF [email-masked]
      [email-masked]
 
      Loa Andersson
      "Loa Andersson" <[email-masked]>

      Dan Romascanu
      Operations and Management Area Director
      "Romascanu, Dan" <[email-masked]>

      Michael Sneed
      IETF ADSL MIB Working Group Co-Chair
      "Michael Sneed" [email-masked]

Response  contact:                  Menachem Dodge
                       IETF ADSL MIB Working Group Co-Chair
                       "Menachem Dodge" <[email-masked]>

Technical contact:      "Menachem Dodge" <[email-masked]>

PURPOSE: Response

Dear Gavin and Peter,

                Thank you for your liaison and WT-129 Version 3.0. We 
would be very grateful if
you would continue to keep us informed of any changes to this Working Text 
document.

                In response to WT-129, we would like to raise the issue of 
xDSL Bonding, as 
defined by the ITU-T documents G.998.1 and G.998.2, but is currently not 
addressed in 
WT-129. The IETF ADSL MIB Working Group believes that this issue is 
important
and would be very pleased if the DSL Forum Operations and Network 
Management Working Group
would address this issue.

                Yours Sincerely,

                Menachem Dodge