Subject: [AAA-WG]: Diameter OriginHost and OriginRealm values

From: Gerard Tixier <[email-masked]>
Date: Wed, 31 May 2006 10:49:00 +0200

Hello,

i could not find the answer to my question in rfc 3588 or in the mail 
archive, so here it is:

does the Origin-Host value has to include the Origin-Realm ?

for example is the following correct ?
Origin-Host : myclient
Origin-Realm : acme.com

or does it have to be :
Origin-Host : myclient.acme.com
Origin-Realm : acme.com

all the examples in rfc 3588 seem to favour the second solution.
but is it normative ?

Thank you and best regards
Gerard.

---

From: <[email-masked]>
Date: Wed, 31 May 2006 12:46:15 +0300

Hi,

> does the Origin-Host value has to include the Origin-Realm ?

No. But Origin-Host has to be fully qualified host name.

> for example is the following correct ?

Probably not. Name 'myclient' does not look like
a valid host name.

The following might be a better example:
  Origin-Host  : myclient.example.com
  Origin-Realm : acme.com

BR,
Mikko Aittola

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of ext Gerard Tixier
> Sent: 31 May, 2006 11:49
> To: [email-masked]
> Subject: [AAA-WG]: Diameter OriginHost and OriginRealm values
> 
> Hello,
>

---

From: Andreas Fredriksson <[email-masked]>
Date: Wed, 31 May 2006 13:12:32 +0200

> No. But Origin-Host has to be fully qualified host name.

Does this rule out IPv4 addresses (e.g. 10.20.30.40)? We're having
problems with our stack because some vendors actually send a textual IP 
address in their Origin-Host.

Thanks,
Andreas

-- 
Andreas Fredriksson
Software Engineer, Digital Route

---

From: "darshak" <[email-masked]>
Date: Wed, 31 May 2006 16:53:08 +0530

Hi all 
I m new to this AAA stuff,I have read DIAMETER RFCs,But i dont understand 
Translation Agent 
Can any1 giude me how DIAMETER 
tnaslates radius request to diameter 
          and diameter request to radius