Subject: RE: [16ng] Assumption of the Acess Router knows all on-link addresses

From: "Junghoon Jee" <[email-masked]>
Date: Thu, 3 Aug 2006 10:48:06 +0900

Hello Syam,
Please find very short questio below,

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Syam 
> Madanapalli
> Sent: Friday, July 21, 2006 12:15 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [16ng] Assumption of the Acess Router knows all 
> on-link addresses
> 
> 
> Hi,
> 
> >From the 16ng minutes:
> 
>     Dave Thaler: On IP*CS, the assumption that the router 
> knows all on-link
>     addresses based on DAD does not hold in the IPv6 
> architecture/protocol.
>     There are at least 4 reasons, probably more, why this is a
faulty
>      assumption.
> 
> 
> The current WiMAX solution is based on this assumption, so 
> will you please provide reasons why this assumption is faulty?
> 
> Learning addresses in use using DAD is one mechanism. The AR 
> can also learn from MLD and may be from 802.16 MAC connection 
> establishment etc.

Could you clarify how AR can learn all the on-link addresses of SSs
from the 802.16 MAC connections?
It is more general to take consideration about the fact that the AR is
separated from the BS where the 802.16 classification occurs.

Best Regards,
-Junghoon 

> And in case the AR does not know about the address, an MS may 
> not be able to communicate using that address.
> 
> 
> Thanks,
> Syam
> _______________________________________________
> 16ng mailing list
> [email-masked]
> http://eeca16.sogang.ac.kr/mailman/listinfo/16ng

_______________________________________________
16ng mailing list
[email-masked]
http://eeca16.sogang.ac.kr/mailman/listinfo/16ng

---

From: "Syam Madanapalli" <[email-masked]>
Date: Thu, 3 Aug 2006 08:28:33 +0530

Hi Junghoon,

> separated from the BS where the 802.16 classification occurs.

In WiMAX Architecture he connection is extended to ASN GW by
having a R6 tunnel between BS and ASN GW.

Thanks,
Syam

---

From: "Junghoon Jee" <[email-masked]>
Date: Thu, 3 Aug 2006 13:32:30 +0900

> > > The current WiMAX solution is based on this assumption, 
> so will you 
> > > please provide reasons why this assumption is faulty?
> > >
> > > Learning addresses in use using DAD is one mechanism. The AR can

> > > also learn from MLD and may be from 802.16 MAC connection 
> > > establishment etc.
> >

Yes, I already know about the WiMAX architecture model where the GRE
tunnel is used between BS and ASN GW.
So, how the GRE tunnels are utilized for an ASN GW to learn the all
the on-link addresses of SSs?
 
-Junghoon