Subject: RE: [16ng] Re: Assumption of the Acess Router knows all on-linkaddresses

From: Pars MUTAF <[email-masked]>
Date: Mon, 24 Jul 2006 21:09:14 +0200

Selon Dave Thaler <[email-masked]>:

> Pars writes:
> > Is the following scenario considered important?:
> >
> > The access router learns all IPv6 addresses in the
> > subnet (from DAD).
>
> No it doesn't.  It can't, since DAD isn't seen for all addresses.
> So this scenario can't exist without changing the core IPv6
> architecture.

Hi,
OK. I ask my question differently:

How the access router could know all IP addresses in its subnet
(these hosts don't move?). And what happens if the AR has lost
the addresses?

Thank you!
pars

>
> -Dave
>
> > But, the access router crashes,
> > and you replace it with another one
> > (or it reboots with loss of state because of power
> > cut etc). For example 10000 subscribers are currently
> > in the subnet. They all become disconnected?
> >
> > I'm asking this question because, normally IPv6
> > could automatically recover from such a bad
> > situation without problem (because it has a 'reactive'
> > neighbor discovery mechanism).
> >
> >
> > May be the Wimax hosts should perform DAD frequently
> > to make sure that the AR did not forget their address?
> > How frequently?
> >
> >
> > Thanks
> > pars
> >
> >
> >
> >
> >
> >
> >
> > On Mon, 2006-07-24 at 08:50 +0530, Syam Madanapalli wrote:
> > > Hi,
> > >
> > > On 7/22/06, Dave Thaler <[email-masked]> wrote:
> > > > There are now at least 5 (probably more reasons).
> > > > The main point is that the IPv6 protocol was not designed with any
> > such
> > > > assumption, but instead was designed with the opposite
> assumption...
> > > > that no one other than the address owner ever knows the complete
> list.
> > >
> > > At least ISP should know the address so that he can allow
> > > the communication. I think, we can assume this.
> > >
> > > >
> > > > The 5 reasons known so far are:
> > > > 1) Packet loss (DAD isn't sent reliably)
> > > > 2) Anycast addresses.  Per RFC 2462, DAD MUST NOT be done on
> anycast
> > > > addresses, but they are then used just like unicast addresses.
> > > > 3) DupAddrDetectTransmits can be configured to be 0, in which case
> > > > you won't see any DAD.
> > >
> > > I think the above 3 apply for the RFC 2642 as well.
> > > In WiMAX, one can double check during the MAC transport connection
> > > for the address uniqueness.
> > >
> > > > 4) RFC 2462 contains a clause in 5.4 whereby DAD may be skipped
> > > > for global addresses if you already did DAD on the link-local with
> > > > the same interface identifier.
> > >
> > > This has been deprecated in 2462bis:
> > >
> > >       "this kind of
> > >       "optimization" is NOT RECOMMENDED, and new implementations
> MUST
> > >       NOT do that optimization."
> > >
> > > > 5) The link may be partitioned for various reasons.  For example,
> > > > there can be devices in between the router and the host which
> > > > act like a hub in that the host thinks the link is up and does
> DAD,
> > > > but where the hub is disconnected from the router.
> > >
> > > Again I am not sure how this is handled with RFC 2462.
> > >
> > > >
> > > > The above list is almost certainly not exhaustive, and more
> reasons
> > can
> > > > be added at any time, given the IPv6 architecture.
> > > >
> > > > Bottom line is that you cannot base anything on the assumption
> that
> > > > anyone else is authoritative besides the host.  You can use a
> cache
> > for
> > > > optimization, but never as an authoritative source.
> > >
> > > Sure. Currently Address Cache is almost being used as an
> authoritative
> > source.
> > > I think the missing of an address in this list, may be because of
> one
> > > of the above
> > > causes which I this is problem for RFC 2462 as well.
> > >
> > > As I mentioned, in WiMAX one can double check the address uniqueness
> > during
> > > the transport connection establishment, though this is not specified
> > currently.
> > >
> > > Thanks,
> > > Syam
> > >
> > > >
> > > > -Dave
> > > >
> > > > -----Original Message-----
> > > > From: Syam Madanapalli [mailto:[email-masked]]
> > > > Sent: Thursday, July 20, 2006 8:15 PM
> > > > To: Dave Thaler
> > > > Cc: [email-masked]; Soohong Daniel Park
> > > > Subject: Assumption of the Acess Router knows all on-link
> addresses
> > > >
> > > > Hi,
> > > >
> > > > From the 16ng minutes:
> > > >
> > > >    Dave Thaler: On IP*CS, the assumption that the router knows all
> > > > on-link
> > > >    addresses based on DAD does not hold in the IPv6
> > > > architecture/protocol.
> > > >    There are at least 4 reasons, probably more, why this is a
> faulty
> > > >     assumption.
> > > >
> > > >
> > > > The current WiMAX solution is based on this assumption, so will
> you
> > > > please
> > > > provide reasons why this assumption is faulty?
> > > >
> > > > Learning addresses in use using DAD is one mechanism. The AR can
> also
> > > > learn from MLD and may be from 802.16 MAC connection establishment
> > etc.
> > > > And in case the AR does not know about the address, an MS may not
> be
> > > > able to
> > > > communicate using that address.
> > > >
> > > >
> > > > Thanks,
> > > > Syam
> > > >
> > > _______________________________________________
> > > 16ng mailing list
> > > [email-masked]
> > > http://eeca16.sogang.ac.kr/mailman/listinfo/16ng
> >
>
>

----------------------------------------------------------------
This message was sent using IMP, the Internet Messaging Program.
_______________________________________________
16ng mailing list
[email-masked]
http://eeca16.sogang.ac.kr/mailman/listinfo/16ng

---

From: Pars MUTAF <[email-masked]>
Date: Mon, 24 Jul 2006 21:41:09 +0200

Thanks. I agree with you.
pars

Selon Dave Thaler <[email-masked]>:

> > From: Pars MUTAF [mailto:[email-masked]]
> > Sent: Monday, July 24, 2006 12:09 PM
> > To: Dave Thaler
> > Cc: Syam Madanapalli; [email-masked]
> > Subject: RE: [16ng] Re: Assumption of the Acess Router knows all on-
> > linkaddresses
> >
> > (these hosts don't move?).
>
> It can't, unless you define a new protocol that is much more complex
> than DAD.  (I would recommend against this.)
>
> > And what happens if the AR has lost
> > the addresses?
>
> It needs to use Neighbor Discovery at the time it has a packet that it
> needs to send.
>
> -Dave
>
> > Thank you!
> > pars
> >
> >
> >
> > >
> > > -Dave
> > >